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Introduction to Tecplot RS

Introduction
Welcome to Tecplot RS! We’re very happy to include you among our many delighted customers. The
manual you are reading outlines important information you need to get the most out of your new
program so that you can quickly produce detailed and high-quality plots of your reservoir data.

This document is intended as a tutorial to get you up and running with RS as quickly as possible. Most
of what you need to know to create plots for viewing reservoir data is contained within this manual.
Your installation also contains a comprehensive User Manual that goes into more detail. You will
occasionally be directed to that document for a deeper explanation of certain features. We encourage
you to use both documents to learn all the functionality that is available to you.

Configuring Your System

Before using Tecplot RS for the very first time, there are a couple of settings that you can make that
will greatly enhance your experience. If Tecplot RS is running, you should close it before making these
changes.

Plot Styles and Simulator Selection

RS can read data files from a variety of simulators, and you are not limited to using just one. However,
if you identify the type of files that you most frequently use, RS can pre-set some defaults that will
create better plots 'out of the box'.

RS will apply styles such as line colors and patterns according to the property being shown. It does this
using a lookup table of property (variable) name and the associated styles. Since property names are
generally specific to the simulator, if you identify the simulator then your initial list of property names
will be appropriate. If you use multiple simulators, the other property names and associated styles can
be easily added to the table. This setting just gives you a starting point.

In the root folder of your Tecplot RS installation (for Windows platforms this is usually C:\Program
Files\Tecplot\TecRS 2025 R1) you will see several files with names such as rsvariables_eclipse.txt and
rsvariables_cmg.txt. These files contain simulator-specific data that provide the starting point for
creating tables of styles to be used when creating plots in RS.
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On your very first launch of the RS program, you’ll get a small dialog that
prompts you for the style definitions to use. Since the example data files for
this tutorial are in Eclipse format, you should choose the Eclipse/SLB option.
You should also check the toggle to "Set as Default", as it will ensure that this
option is always used by default.

If this dialog does NOT appear, it means that a default has already been
established. No problem! From the menu select Options > Plot Options and
then access the Variables tab. If the Eclipse/SLB option is not shown as the
version being used, simply click on the  Change…  button and this same
dialog will be launched, allowing you to change it.

RS_USER Environment Variable

After your first time using RS, you should notice that it remembers your previous settings and will
default to those options when possible. These include such things as plot styles, the most recent files
loaded, and the display state (e.g. the type of plot and the property being displayed) when you last used
a particular data file. The defaults are saved in small files that, in most cases, you aren’t even aware of
and can be deleted with no harm.

It is sometimes desirable for these defaults to be shared by everyone using the program, or you may
prefer to save these settings on a per-user basis. The RS_USER environment variable is a way to have
more control over this. When RS_USER is set, it defines a folder that controls the first place RS will look
for the files that are used to record the defaults. Each user can specify their own location, thus
ensuring that Bill’s preferences do not interfere with Mary’s.

The environment variable setting is optional. When used, you will know exactly where your
preferences are being recorded and this will reduce the likelihood of interfering with others who have
different preferences. Simply choose a writable folder where these files should be placed and create an
environment variable named RS_USER that points to that folder. The Help About Tecplot RS dialog will
display the RS_USER environment variable setting.

Manual Organization

This document is organized into 2 parts. Part I (section 1-13) covers XY Plots, or the line plots typically
used to display observed or simulated data for individual wells or other entities. Part II (section 14-19)
contains instructions for Grid Plots; 2D and 3D plots of the entire reservoir, with the ability to animate
the display to see changes in variable values over time.

The section in each part are organized much like a training seminar might be. They start by
introducing basic operations in the early section and then continue into the more advanced functions
in subsequent sections. Most concepts are presented as a series of exercises that you may work along
with if you like. The data files used in the examples were installed along with the software. Installation
of Tecplot RS is usually quite simple and automatic, and instructions for doing so are presented in a
separate document.
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
Even if you have a need for only the grid plotting functions, you should read and do
the examples in section 1 through 5. These sections explain some basic concepts that
are used in both XY and Grid plots.

The Tecplot RS Environment

When you launch the program your screen should look something like this:

The Plot Area

The largest part of the work environment is the plot area. This is where the images you create will be
displayed. You’ll see a white area that represents the page on which plots would be printed.

Each page may contain one or more frames. The frame acts as the container for all drawing elements.
Each frame can be independently sized and positioned on the paper. Because most items in a plot are
scaled relative to the frame, you can create layouts that will automatically adjust to different paper
sizes, or resize frames to squeeze in an extra image at the last minute.



The very first time you use Tecplot RS, the sidebar may appear much wider than
shown here. To fix this, use the mouse to 'grab' the right edge of the sidebar and drag
it all the way to the left. This will reset it, and the setting should be 'remembered' in
subsequent uses of the program.
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The Menu Bar

The Menu Bar gives you access to the various functions within Tecplot RS.

• Project - Loading, saving, and exporting data or images.

• Edit - Standard copy/cut/paste operations

• View - Control the look of the workspace and the view of the data

• Plot Type - Switch between the many different types of plots in RS

• Templates - Create, save, and apply custom views that you define.

• Gallery - Save finished plots and come back to them at any time.

• Data - Display data info and alter the data via equations or other means.

• Options - Customize how Tecplot RS works for you.

• Insert - Add text, geometries, and images to your plots.

• Plot - Miscellaneous settings that control the appearance of certain plots.

• Frame - Create new frames and order or arrange existing ones.

• Analyze - Create plots with analysis data such as histograms.

• Macro - Record and play back scripts to automate repetitive tasks.

• Help - Access the documentation and help for RS.

The Toolbar

Buttons on the toolbar give you one-click access to many of the functions found in the menu bar. You
can hover over the buttons to display a tool tip that describes the operation. There are 29 buttons
organized in 6 groups by category. From left to right they are:

• File handling group

• Create new project

• Open existing project

• Load XY data

• Load grid data

• Load VDB data

• Manage data

• Save project

• View group
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• Zoom in/out

• Move plot (pan)

• Rotate around the Z-axis

• Roller-ball rotation

• Move light source

• Redraw

• Reset to default view

• Plot control group

• Mouse select mode

• Adjust mode

• Add/edit text

• Plot options

• Multi-Frame options

• Update the paper layout
template

• Query group

• Measure mode

• Probe mode

• Quick probe

• Display data group

• Add streamtraces

• Cell blanking

• Analysis group

• Histogram plots

• Cross plots

• Integration

• Create new variables with
equations

• Macros

The Sidebar

Although pop-up dialogs are used for some operations, most of your inputs and selections will be made
in the sidebar area. The sidebar will change according to the Plot Type (XY Variables, 2D Grid, 3D Grid,
etc.) you have selected.

You can completely turn off the sidebar, which will give you the maximum plot area. You can also
detach the sidebar from the main window. To do this, double-click on the top portion of the sidebar
frame where it reads "Plot Controls." You can then drag the sidebar to a new location. To re-dock the
sidebar, double-click again on that same area.

While most controls on the sidebar change according to the plot type, there are several that are
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common to more than one.

The toggles on the sidebar are primarily used to
turn on and off the various drawing layers or
elements of the plot. For example, when
displaying 2D or 3D Grids you can control
whether or not the mesh is shown, or whether to
draw the wells. Note that you may elect to have
the toggles applied on a frame-by-frame basis
(giving you the ability to turn off the mesh on one
frame and have it on in a second), or have them
applied to all frames in a multi-frame plot. This
selection is made in the Multi-Frame dialog.

The current plot type is displayed in a small option menu at the bottom of the sidebar. This simply
duplicates the Plot Type options on the menu bar, and you can make a selection in either place.

Help

In addition to the manuals, on-line help is available throughout the program. The small ? button next
to the control shown above will bring up help for the current plot type.  Help  buttons are also
included on individual dialogs that bring up context-sensitive assistance for the problem at hand.
Finally, you can also navigate through the entire collection of help screens from the Help > Tecplot RS
Help option from the main menu.

Welcome Screen

Every time you start Tecplot RS, the Welcome Screen will appear:
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In this window you’ll see a list of your most recent projects, which can be quickly loaded by simply
clicking on the file name. You’ll also have links to the documentation included in the installation,
online resources, menu options for loading new files, version information, and notifications about new
releases of the software that may be downloaded. Some of these features duplicate options in the main
menu and toolbar, but this screen is designed to present the most frequently needed first steps for
working with Tecplot RS. The window will automatically close once you load a file or project, or you
may close it using the [X] in the top right corner.

13



Part 1: Basic XY Plots

Basic XY Plots

Loading XY Data Files

Your first step will be to load a file containing the data you wish to plot. Tecplot RS supports a variety
of file types from a number of sources, including output from several popular simulators plus user-
created files containing observed data. Appendix F contains detailed information about supported file
types.

Click on Project > Load XY Data from the menu,

or click the  icon from the toolbar. This will
bring up the dialog shown here.

The File name(s) list shows what has been
selected so far (nothing yet).

Start by clicking on the Add… button to choose
the data file for this first exercise.

This will bring up a typical file browser dialog such as this one:

We’ll start with an Eclipse Unified Summary file
(UNSMRY), so change the file filter to reflect that
option. Then navigate to the examples folder,
which will be in the location where Tecplot RS
was installed. On Windows installations, this is
usually C:\ Program Files\Tecplot\TecRS 2025
R1\examples. Finally, select the Chelan.unsmry file
and click Open.

When you get back to the Load XY Data dialog, you’ll see the Chelan.unsmry file in the list of file names.
Click on the OK button to load the data.

XY Variables Plot

The program should display the XY Variables plot type. This happens automatically when the first file
opened is an XY file. However, if you previously selected a different option, it may be necessary for you
to choose the correct plot type now. Do this by selecting Plot Type > XY Variables from the menu or
sidebar.
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Using the lists in the sidebar, select OIL-01 in Entities and WPR in the Y1 variables list.

Congratulations! You’ve just created your first plot with Tecplot RS.

Choosing Entities

Near the top of the sidebar is a list of all the entities found in the sample file. From this list you can
choose the structure or data that will be plotted. Right now, the first entity in the list (OIL-01) is
highlighted and displayed.

You should now select a different entity. There are several ways to do this:

• Use the mouse to click on a different name, such as OIL-03.

• Click on the  >  (next) or  <  (previous) buttons beneath the list.

• If the control containing the list is active (has focus), then the up and down arrow keys on your
keyboard may be used.

Note how each time you choose a different entity, the plot changes instantly.
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Choosing Variables

Beneath the entity list are three controls containing a list of all variables found in the file. With these
options you have complete control over which values are shown and on which axes. By default, the
program puts time or date on the X-axis and the first variable other than time or date on the first Y-
axis.

You should now choose
a different variable for
the Y1 axis. For
example, choose FIELD
from the Entity list box
and GPR from the Y1
axis variable list box,
your display should
then look like this.

As with entity
selections, note how the
plot is updated instantly
when you choose a new
variable.

Displaying Multiple Variables

Although the entity list allows you to select only a single well, you may choose to display multiple
variables in your plot. To start, highlight both OPR and GPR in the Y1 axis list box. This plot should
instantly change to show two lines for the selected entity; a green one representing the oil production
rates, and a red one for the gas production rates.



Normally, when you choose one item in a list box the highlight on the previously
selected item is cleared. To make multiple selections in a list box that allows them, you
can use the following techniques:

• To choose two or more consecutive items, you can click on the first one and then,
while holding down the left mouse button, "drag" the highlight to the last item
before releasing the mouse button.

• You can also choose a range of items by clicking on the first one and then holding
down the Shift  key while clicking on the last item.

• To choose two or more non-consecutive items, hold down the Ctrl  key and click on
the desired selections.

• Ctrl  +  Left-click  can also be used to un-select a single item without removing your
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other selections.

• Ctrl  +  drag  or Shift  +  Left-click  method may be used together to choose
consecutive items without undoing previous selections.

Since you chose both
OPR and GPR in the Y1
axis list box, both
variables are scaled to a
single Y axis on the left
side of the plot. Since
both values have
similar value ranges
(even though the units
are different), the plot is
acceptable.

Now add WPR to currently selected Y1 axis variables ( Ctrl  +  Left-click ) to display a total of three
variables. For the FIELD entity, your plot would look something like this:
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Since the production rates for oil and gas are an order of magnitude greater than the water rates (not
to mention different units), we don’t see much variation in the WPR line.

Creating Multiple Y Axes

To solve this problem,
let’s move the water
production rate to a
second Y axis. To do
this, simply click on
WPR in the second list
box.
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Now your plot should look something like this:

A second Y axis has been created and automatically scaled to ranges more suitable for the water
production rate.



Save a Gallery Plot
It’s time to save your first Gallery Plot. You’ll learn more about these in a later
chapter, but for now just follow these steps:

1. From the menu bar, select Gallery > Save.

2. A small dialog will pop up asking for a name. Enter Field Production Rates.

As you work through the examples you’ll be asked to save additional gallery plots. Be
sure to do these steps AND those that have you save a Project File, which is covered in
the Saving a Project File section.

You can have a total of up to 5 Y-axes, and you can choose multiple variables for each. The variable
selections for the additional axes are made in the same list box that was used for the second Y axes.
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Use the small drop list labeled "Y2-5" to control which axis you are selecting variables for.

Stepping Through Entities

Once you have chosen the desired variables and the axes on which you would like them to be
displayed, try stepping through the various entities. One option is to click on the "Next" button: 
This will display each entity in turn.

You can also automate the entire sequence of entities. Start by selecting the first entity in the list, and

then press the "Play" button: 

XY Entities Plots
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There are other types of XY plots, but the methods
used to create them are essentially the same as
what you’ve already learned. Let’s look at another
type by selecting Plot Type > XY Entities from the
menu.

Single Entity Plot
At first glance it may appear that this is no
different from the XY Variables plots that you just
made. The difference is that with XY Variables, the
plot shows a single entity with one or more
variables. But with XY Entities, the plot displays a
single variable for one or more entities.

The default selections are highlighted, and you
should see a simple plot for the Water Production
Rate for the OIL-01 well. (If not, make these
selections as shown to the right.) Now the
Previous and Next buttons will cycle through the
variables and update the plot accordingly.

Multiple Entities Plot

To see the real difference between the XY Entities and XY Variables plot types, select multiple items
from the Entities list. Highlight OIL-01 through OIL-04, and you should immediately see a plot that
looks similar to the following:
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With XY Entities plots, you can compare the same variable for multiple wells or other entities. You can
now look at different variables for all four wells by stepping through the variable selections. You can
also press the Play button to automatically scroll through all variables.

Sum and Average Options

Now click on the Sum tpggle to turn it
on:

And instantly see the resulting plot…
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With just a click of a toggle, you have instructed Tecplot RS to add the values for two or more wells
(those selected in the Entities list). There’s also a toggle to average values.

Saving a Project File

As your final step in this exercise, you’re going to create a Project File. On the menu, choose Project >
Exit.

A dialog will pop up asking if you want to save your current project. Choose YES.

Enter "Chelan" as the name of the project and click the Save button.

Project files are one of the greatest time savers available in Tecplot RS. A project file saves the names of
all the files you have loaded, the styles (plot appearance) that you have defined, and the plot type and
selections active at the time the project was saved. The purpose is to return you to the same place (or
nearly so) the next time you use those files.

With the project file, you can now interrupt your work in the Quick Start tutorial and return to it later
without having to repeat previous steps.
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When you restart Tecplot RS, your ten most recent project files are listed in the Project menu and/or
the Welcome Screen, so a single click is all that is needed to select one. As you do additional work, you
will be asked if you want to save any changes to the project file. Changes might include loading
additional data files, refining styles, etc. For this tutorial, always save those changes unless you have
specific reasons not to.
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Part 2: XY Plot Appearance

XY Plot Appearance
Now that you have a general idea about how to create a plot, let’s look at changing it to match the way
you want it to look. If necessary, start Tecplot RS and choose the Chelan project file (created in the
previous section) from the list of files under the Project drop-down menu.

Paper Layout

The plots you created in Chapter 1 had titles, a legend, and date
information. These reflected the factory defaults for a paper
template that is used for all plots in Tecplot RS. You don’t have to
use these defaults - the Paper Layout function lets you create new
templates to your specifications. You can even tell Tecplot RS to use
a specific template every time you run the program.

Choose Plot Type > Paper Layout. Your plot will disappear, and
the sidebar will change to reflect the options for Paper Layout.

While in Paper Layout mode, you can modify or create new
templates for all your plots. You can add text, titles, legends, and
other standard items. You’ll have complete control over the font,
color, size, and placement of each item.

The Tecplot RS templates are stored in files that you can name and
load as needed, so you can create many different styles for use with
different types of plots. To help get you started, a couple of sample
template files were included and installed along with Tecplot RS.

Complete information about the Paper Layout templates can be
found in Appendix B of the User’s Manual. For now, you’ll just
make use of some pre-defined templates.

From the Paper Layout sidebar press the  Load…  button. This will bring up a separate file loading
dialog. The sample files are in the examples folder under your Tecplot home directory (the one you
selected when you first installed Tecplot RS). Find and load the file named SingleFrame.rslayx.

Once loaded, your display should look similar to this:
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Adding Your Company Name

The sample template contains a place for your company name, indicated with an arrow above. You’re
going to make a quick change to the template to insert the correct name.

Double-click the text that reads "YOUR COMPANY NAME." The Text Details dialog appears:
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Change the text so that the correct name appears in the text box, then press the Close button. The
display will be updated with the name you selected.

Saving the Paper Layout Template

Click on the Save As button. Assign a new name for the file, such as "MyTemplate1". You can also
toggle on the option to "Load at startup". If you do so, the next time you run Tecplot RS, it will
automatically use this layout for your plot.

From the menu, choose Plot Type > XY Variables or Plot Type > XY Entities to return to your
previous plot. Your plot should reappear, but it will now use the modified template including your
company name.

Customization Using Plot Options

There are many more ways of fine-tuning the appearance of your plots. This exercise will introduce
Plot Options. Start by creating an XY plot using XY Variables. Make sure you’re using XY Variables and
not XY Entities, and that OPR is one of the variables being shown. It doesn’t matter which entity (well)
you choose.

Now double-click on the green line representing OPR. This should launch the Plot Options dialog, and
OPR should be highlighted in the selection list:
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This page shows the styles that are used when plotting OPR (Oil Production Rate) for the "Active" style
set. Note that many of the options are shown as Default. This refers to the default styles that are
defined by the Eclipse/SLB simulator option that you selected at the start of this tutorial.

If you wanted to change the defaults you could do so using the Variables tab. However, the default may
also be referenced in style sets for comparison plots (these will be covered in a later section). For this
exercise, you are going to change your plot’s styles directly as opposed to redefining the "default"
settings.

Using the controls on the dialog, change the line thickness to 0.7, and uncheck the Symbols toggle. Then
press the Apply button to see the results, which should be a thicker line without symbols.

Next, use the sidebar to turn on GPR (if it’s not already displayed). To alter the styles for this line, you
can either double-click on the red line representing the gas production rate, or simply select it from the
variable list in the Plot Options dialog.

Note that symbols are still turned on for this selection, and the line thickness remains at 0.4. Each
variable (property) has its own set of styles. This makes it easier to differentiate them on a plot.

For the GPR, use the drop-down list for the symbol shape to select Character (at the bottom of the list).
This will activate a small text field next to the list, and you should put the letter 'G' in that box. Change
the symbol size to 1.8, and the line thickness to 0.1. Finally, press the Apply button.
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The result is a greater distinction between styles for each line.

This exercise is intended as a basic introduction to Plot Options. In later chapters you’ll be making
more advanced changes. A complete discussion of Plot Options can be found in Appendix D of the RS
User’s Manual.

Save Changes To The Project File

When asked if you want to save changes to the Chelan project file, be sure to do so. This will save the
new paper layout template and changes to the line styles in Plot Options.

Note that you will get this message whenever you close the program or load a new project file, even if
you’ve made no changes to the project. It’s just a way to ensure that you never lose a setting that you
wanted to keep.
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Part 3: Multi-frame XY Plots

Multi-Frame XY Plots
Up to now, all the examples have utilized a single frame. In this exercise you will learn how to create a
page containing multiple plots.

The Multi-Frame Options Dialog

With the Chelan data file loaded, go to the XY Variables plot type. If necessary, highlight the first entity
in the list (OIL-01) and set up the variables so that OPR and GPR are on the Y1 axis, and WPR is on Y2.

To bring up the dialog that controls the multi-
frame options, you can either click on the multi-

frames button  or choose Options > Multi-
Frame Options from the menu. This will bring up
the dialog shown here.

Change the Frame Mode to  Multi-Frame . Make
sure the other settings are also as shown, then
click on  Close .

Your plot should immediately change to look something like this:

30



You should have a total of four frames (two rows by two columns), showing the first four wells.

Now click on the  Next  button  under the entity list. You’ll notice that the highlighted entity
"jumps" down four spaces and Gas-05 and the FIELD entities are displayed on your screen. The Next
and Previous buttons automatically adjust to the number of frames selected for display.

Note that each frame displays the same set of variables and a different entity.

Mult-Frame In XY Entities

Using the Plot Type menu, switch to XY Entities. Select the WIR variable and the FIELD entity. Make
sure to turn off the Sum toggle if it’s still on. Now you should have four frames for the FIELD entity,
each showing a different variable:
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Again, try the Next and Previous button controls. This time, they cycle through the variable selections.
Not all variables are present or interesting for the FIELD entity, so some of these plots might be blank
or display a message indicating that the variable does not exist. You might look at the other entities
when you run into such a plot.

Multi-Frame Paper Layout

Now that we are displaying multiple frames, there is redundant information being displayed. The
company name, file name, and date are repeated in each frame. In the XY Entities plots, the entity
names are repeated, and in the XY Variables plots the same variable list appears in each frame. In this
exercise, you’ll instruct the system to use a paper layout template that cleans up the display.

From the menu, choose Plot Type > Paper Layout. Then click the  Load  button. As you did in the
exercise in Chapter 2, you’re going to use a sample layout that was provided with your software. This
one is named "MultiFrame.rslayx", and it is also in the examples folder under the Tecplot RS home
directory.

Once loaded, your template should look something like this:
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Don’t worry that the template shows only a single frame even though you will be making multi-frame
plots. The style in the single plot frame will be applied to all frames.

The new template differs from the previous one in that it makes use of the header and footer frames.
The header and/or footer will appear only once on the paper. No plots will be placed in the header or
footer - they can contain only text. Since the header and footer appear only once on the paper, they are
the ideal place to put text that doesn’t change from frame to frame.

Another advantage of the header and footer frames is that the text in it can never interfere with the
plot itself.

In this sample paper template, the plot title has been placed in the header frame and the frame title in
the plot frame. When creating plots, Tecplot RS will use the plot title for labels that apply to all frames
of a multi-frame plot, and will use the frame title for items that change in each frame.

As in the first exercise, there is a place for your company name, this time in the footer frame. Double
click on the text and change it accordingly. Finally, click on  Save As  and save your new template
under a different name that you choose.

Return to the XY Variables plot type.
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Your plot should now look something like this:

Note how the plot title (in the header) reflects the variable names, which are the same for all frames.
Within each frame, the entity is identified in the space designated for the frame title.

Now switch to the XY Entities plot type and change the variable to GO1:
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This time, the title in the header frame reflects the entity name (which is the same for every frame),
and the titles in the individual frames identify the variables.



Save Gallery Plot #2
Save another gallery plot using Gallery > Save. The name will default to the one you
saved before, but change it to Field Multi Frames. You have now saved two different
plots to the gallery. You’ll soon see how these are used

Save Changes To The Project File

As the final step in this exercise, save your changes to the project file, either by clicking on the Save

icon  on the toolbar or selecting Project > Save from the menu. The project file will now contain
your changes for the line styles, your paper layout template for the multi-frame plot, and the gallery
plots.

35



Part 4: Filters

Filters
Assuming you are continuing from the previous exercise, you have the sample data file Chelan.unsmry
loaded and the paper is set up for 4 frames (2 rows x 2 columns). With those settings in place, select the
XY Entities plot type.

The Need For Filters

In the previous exercise, we saw that some variables do not exist for every entity. This leads to some
plots in our multi-frame layout having only an error message in them, as shown below, where we have
chosen the OIL-01 entity along with API as the Y variable.

Flip through the variables using the Previous and Next buttons.

Now choose FIELD as the entity and flip through the variables again using the Previous and Next
buttons. Again, some frames will have the message, this time for different variables.
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What is happening here is this: Entities
are classified into different types. Type
classifications include Field, Wells,
Layers (completions), Groups, and
other options that are simulator
dependent. All entities of a single type
share the same list of variables, but
some variables will exist for one entity
type but not another. For example, in
this file the Field and Well types both
include WPR, OPR, and GPR, but the
VPR variable is used only for the Field,
and the LGR variable is assigned only to
Wells.

By default, the list shown in the dialog
contains all variables, regardless of
whether they are used in just one entity
type or all of them. The entity list also
contains all entities regardless of type.
As you step through the variable list
creating XY Entity plots, you will get the
blank frames when one of the variables
doesn’t exist for the particular entity
being plotted.

The filter option can solve this problem.
When you click on the  Filter…
button, this dialog appears.

The Type Filter

There are two list boxes in the Filtering dialog. The top one contains the Entity Type list. This is a list of
all the possible entity types. Note that some entity types may not be familiar to you. This is because the
list includes the types used by all the different simulators that are supported by Tecplot RS, and some
of the types may not apply to the simulator software that you are using.

By choosing items in the filter list, you can limit both the variables and entities that are displayed in
the main dialog. For example, if you choose "Wells" as the filter, only well entities will be shown in the
entities list, and only those variables recorded for wells will be included in the variables list.
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By default, all entity types except completions and blocks are selected, which is why Tecplot RS tried to
plot variables that might not have existed for a particular entity.

The lower list box, titled "Entity List", contains a preview of the entities from the current data file that
are of the type(s) selected in the Type Filter. If you choose Wells in the type filter, the lower list box will
show you which of your entities belong to that classification.

In the Chelan data set, when you highlight only the Flow option in the upper list box, your lower list
box is empty. This is an indication that the current file does not contain any entities of this type.

By choosing each type in succession, you can see exactly which entities (if any) belong to a
classification. This information is also summarized on the Manage Data dialog.

You may select multiple types in the Filter list (Hint: use [Ctrl + Left-click] to choose non-consecutive
items.) For this exercise, however, choose only the Wells option and then click on the  OK  button.

When you return to the XY Entities sidebar you’ll notice that both the entity and variable lists are
smaller. Now when you step through the different variables using the Next and Previous buttons, there
will be no more blank frames.

The Entity Filter

Now let’s return to the XY Variables plot type. Your type filter will still be set to display only the entities
and variables in the Wells classification, and you can now use the Next and Previous buttons to scroll
through the various wells.

What if you were interested in only some of these wells? For very large oil fields, the list can be quite
long, and often you’ll work with a subset of the available wells.
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This is where the Entity List becomes useful. Click on the  Filter…  button
to return to the Filtering dialog. You will notice that, by default, all the
entities in the lower list box are selected.

Change this by highlighting only a subset of these entities. For this exercise,
choose wells 1, 3, and 4 (using Ctrl  +  Left-click  to select 3 and 4) and then
click the  OK  button to return to your plot.

Now the only items that appear in
the Entities list and on the plot are
the three wells you selected in the
Entity List.


After accessing the Filtering options, it may be necessary to reset the variables you
would like to display. Because the application of a filter may change the variables
available in the list, the selections are returned to the default state.

After resetting the variables to be displayed, your plot should now be limited to only the three wells
that interest you.

Sorting

There are additional options in the Filter dialog that further increase its power. The next one we’ll
examine is the Sorting option.
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Return to the Filter dialog. In the Sorting section,
choose "By Variable Value" and Descending order.
You’ll see that the Variable option menu becomes
active. From this list, choose "WPR" (Water
Production Rate), and press the  Apply  button.

Now your selection list is sorted so that the wells
with the highest WPR appear first, and others
follow in decreasing order.

When sorting by variable values, Tecplot RS considers the maximum value for the variable over all
time steps.

Note also that sorting the list does not change either the type filter or selections you made within the
entity list. (For example, FIELD is not shown in the Entity List because we still have only Wells selected
in the Entity Type list.) However, sorting will affect the order of the entities that appear on the sidebar,
and also the order that they are plotted when you step through multiple plots or use the Play button.
This is a great way of organizing your plots according to critical quantities.

Selection Methods

Just as you can sort by various criteria, you can also automatically select entities using similar
operations. For example, you can find all wells with names that begin with or contain a specified
character or string of characters. You can choose wells according to production values that are above,
below, or even between a set of limits that you specify.

You can even limit the search to a certain time range. So, for example, you can instruct the program to
find all wells with Oil Production Rates that were above 500 STB/Day between 1966 and 1980.

These options are a way to automatically highlight items in the Selection List, so that you don’t have to
do so manually. In addition, you can specify whether the new entities are added to, removed from, or
completely replace the current selections. This gives you a tremendous amount of flexibility and power
to choose precisely the wells or other entities that interest you most.
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These automated selections are made using the tabs in the lower right
corner of the Filters dialog.

Use the Name tab to designate criteria for finding wells by name, and the
Values tab to do the search described above based on Oil Production Rate
and Date.

After setting the selection criteria, press the  Apply  button to make the
selections and see the changes highlighted in the Selection List.

Before using the Sel Sets tab, you’ll need to know more about another
powerful tool: Selection Sets!
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Part 5: Selection Sets

Selection Sets

Our example data set is small, but in the real
world you could be dealing with projects
containing thousands of wells. In those cases,
choosing or making changes to the entities you
want to include can be time consuming. The Filter
dialog allows you to choose a subset of wells or
other entities that are of interest to you. Those
selections are then used in lists and other
displays, making it much easier to find the entities
you want.

It would be nice if those selections could be
remembered for future use, and that’s exactly
what Selection Sets are all about!

At its simplest level, a selection set is simply a list
of entity names. Tecplot RS can save this list so
that you can reload it, eliminating the need to
repeat the selection process.

Creating Selection Sets

Although there are other ways to create selection sets, the Filter dialog is a good place to start.

If you were following the examples in the preceding chapter, you have the Filter dialog displayed and
wells OIL-01, 03, and 04 are highlighted in the selection list. You’ll also see a button labeled  Make New
SS , and a text field with "SS001" in it.

Press the  Make New SS  button now. The only thing that will appear to happen is the text field will
change to "SS002". However, you’ve just saved a selection set containing the items that were
highlighted.

Selecting by Entity Name
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From the Name tab, enter an 'L' in the text box
labeled Comparison String. Make sure the Search
Condition is set to Containing, and choose the
radio button to Replace Selections.

When you press the Apply button, the items in the
list box should change so that entities names
containing an 'L' are highlighted (everything
except GAS-05). Replace the "SS002" with "L
Names" and again press Make New SS.

Selecting by Variable Value

Change to the Values tab, and fill out the options as shown here. Click on
Apply , followed by  Make New SS .

You now have three selection sets. SS001 contains the wells that you
highlighted manually, "L Names" includes all entities with names containing
the letter 'L', and "Low H2O" contains entities whose maximum water
output is less than 28 BBL/Day.

Viewing And Editing Selection Sets

Click on the  Edit SS…  button to bring up another dialog that will allow you to both view and alter
your selection sets (NOTE: This dialog can also be accessed from the menu Data > Selection Sets…):
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When you highlight a selection set in the list on the left, the Entities list will
update to display the items in that particular set. Note the "-00" after the
name in the Entities list. This is 00 for most entity types (including Wells
and Field), but when you have a file that includes completions or RFT data,
the suffix identifies the sub-structure.

To remove entities from a set, simply highlight one or more names in the
Entities list and then click on  Remove Items . (Note: You cannot use this
dialog to add entities to the list.)

You can also rename a selection set. To do this, first type the new name in
the text field, then press the  Rename  button above it.

To delete a selection set, first highlight the name and then click  Delete .

Using Selection Sets

Now that you have a few sets defined and saved, what are you going to do with them?

The primary purpose of selection sets is to make selections! Use
them to choose multiple items in a long list, particularly the one in
the Filtering dialog. Close the Selection Set dialog to return control
to the Filtering dialog and then choose the Sel Sets tab.

Make sure the Replace Selections option is selected. Then highlight
each of your selection sets in turn and press  Apply . You’ll see how
the items in the Selection List are highlighted accordingly. So while
you used the list to create selection sets in the first place, you’re
now using the sets to select items in the list.

By now you may have also figured out that you can use selection
sets to make other selection sets. For example, you could initialize
the list using Replace Selections and SS001, and then change to
Remove From Selections and choose the Low H2O set. You can also
add two sets together using the Add to Selections option. The
possibilities are endless.

When you get to the Grid plots, you’ll see that selection sets can be
used to control which wells are displayed in 2D and 3D.

In XY plots, they offer a quick way to filter the entities that appear. They also form the foundation for
another powerful tool:  User Groups .

Save Changes To The Project File

Be sure to save changes to your Project File so you don’t lose your selection sets!
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Part 6: User Groups

User Groups
Simulator output often includes cumulative quantities for the entire field and one or more sub-groups
of wells. These may be classified as separate entity types under the heading of groups, areas, or
regions, depending on the simulator. Each set of cumulative values is saved as an individual entity and
the data can be plotted just as individual wells are.

The User Group function lets you create your own new entities where the variable values are
calculated from two or more wells. It allows you to choose which variables to include and whether to
calculate them by summing or averaging the individual well values, or as ratios computed from the
summed or averaged results. The new entities and variables are then added to the lists and they can be
plotted using any of the XY plotting routines.

Preparation

In order to create user groups you must first define one or more selection sets. The wells to be
combined are specified in the selection set. Only well entity types can be combined to create user
groups-other types (field, RFT data, block data, etc.) will be ignored.

The selection set name will become the user group name, so you should name the selection set
accordingly. Using the default selection set names is fine (i.e. SS001), but you may want to have
something more descriptive.

The Selection Sets that were created in the previous exercise will work fine for this one.

Creation
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From the menu, select Data > Groups/Patterns/Branches to
bring up this dialog.

The variables in the list are those associated with the
current Well entity type. By default, all the identifiable
production rate, injection rate, and cumulative values are
placed in the "Variables to be summed" column, and all
remaining values are in the "Unused variables" column.

This is provided as a starting point only. To change things,
you simply highlight the variables that need to be moved,
then use the  <  or  >  buttons to transfer them to a
different list. For example, if you didn’t want to include VPR
and VPC values in your user group entities, highlight those
names and press  >  to move them to the Unused variables
column. In addition, you might also decide to average some
of the pressure readings, so you could highlight BHP, WHP,
and SWP in the middle column and then press  >  to move
them to the "Variables to be averaged" column.

Four items are included in the Calculate list. These values are calculated after all the others have been
summed or averaged, and they depend on certain other values to be included in the calculations:

Mnemonic Meaning Formula

WOR Water / Oil Ratio WPR / OPR

GOR Gas / Oil Ratio GPR / OPR

WCT Water Cut 100 * WPR / (WPR + OPR)

OCT Oil Cut 100 * OPR / (WPR + OPR)

By default, all four values are highlighted (meaning that they will be calculated), but you can change
this as you wish.

Finally, the available selection sets are shown in the bottom-most list. Again, all of them are marked for
inclusion by default, but you can change this and highlight only those you want to use to create new
user groups.

To create the new user groups, make sure all your selections are as desired and click on  OK . The
dialog will close and a small progress dialog will be displayed so you can see how things are going.
Once things are complete, the new user group entity names and variables will be added to the sidebars
and you can immediately begin plotting the results.
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

When you create user groups, your selections REPLACE any existing user group
entities. It isn’t possible to add a single new user group to those created earlier. In
general, most of the work to build user groups is in the creation of the selection sets,
and the actual solution is done in a single operation.

Save the Project File Changes

If you save changes to your project file after creating user groups, they will be available the next time
you load the project.
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Part 7: XY Equations

XY Equations
In the preceding chapter on User Groups, you saw how new variables such as Oil Cut and Water Cut
could be calculated from the other values that were recorded. Wouldn’t it be nice to have this
capability for other entity types?

You can! That’s what XY Equations are all about. To access this function, use the menu to select Data >
XY Equations and you’ll see this dialog.

Data equations are used to compute new variables from existing XY values. You can create a single
new variable or several. The new values will be included in the list of variables you can select for
plotting. You can also use equations to modify existing variables.

Writing Equations

Although equations can be much more complex than this, a basic equation might appear as:

{newvar} = {existvar1} <operator> {existvar2}

i. where <operator> includes (but is not limited to) standard operators such as +, -, /, and *. For
example:

{GOR} = {GPR} / {OPR}

48



The new variable is named "GOR" and is defined as the ratio of gas production rate to the oil
production rate. Both new and existing variable names are always surrounded by curly brackets {}.

You can also include constants and parentheses in your calculations, such as:

{WCT} = 100.0 * {WPR} / ({WPR} + {OPR})

The capabilities of equations go far beyond these simple examples. A complete description of equations
can be found in the appendix of the RS User’s Manual. Although the instructions in the manual show
the use of variable numbers to define equations (e.g., "V3" instead of "{WPR}"), we recommend always
using explicit variable names. This will help avoid errors and will also make your equations generic so
that they can be used with different projects.

The box at the top of dialog shows the equations already entered. The current equation is displayed in
a line-edit control just beneath it, with the  Enter  and  Cancel  buttons to the right. To enter a new
equation, you can simply begin typing in this field. You can also double-click the  NEW  line in the upper
list box to automatically start a new equation.

You may simply use the keyboard to enter your equations, but the dialog offers many shortcuts to
make your job easier. The variables that are found in your current data set are shown in a list box.
Double-clicking on one of these will insert the variable name into the current equation at the cursor
position, complete with surrounding curly brackets. As soon as you save an equation (using the  Enter
button) with a new variables, that name will also be added to the list (even though you haven’t solved
it yet) so that it may be referenced in subsequent equations.

The most commonly used equation functions are also available on the dialog. Clicking on those will
also insert them, along with parentheses with the cursor within, to facilitate the next entry.

Saving and Loading Equations

Equations will be saved in your project file. However, it is also possible to save them to a separate file.
This makes it easier to use them in multiple projects, without having to input them each time. The
dialog contains buttons to Save As (where you can assign a new name to the file that will hold the
equations), Save (to save changes to an existing file), and Load (so you can reload a previously saved
file).

Applying Equations

Once you have your equations entered, you’ll use the  Apply  button to solve the new variables. Before
doing that there’s a few things to consider.

If Tecplot RS detects that the variable used as the divisor has a range of values that include zero, it
normally will not accept the equation because of the potential for divide by 0 errors. However, there is
an option to "Ignore /0 errors". If this is checked, then any divide by 0 operation will be assigned a
value of 999999.
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Solving the water cut makes sense for well entities, but not for RFT records.
For this reason, you also need to choose the entity types that will receive the
new variables. This is done using the "Apply to" multi-select list.

Once the entity types have been chosen, click on the  Apply  button.
Depending on the size of your current data set, the process can require
anything from the blink of an eye to several minutes. Once complete, the
new variables will appear in the selection list and can be immediately
selected for plotting.

Project File Changes

As usual, save changes to your project file. Although the XY equations themselves are saved in a project
file, they are not automatically applied when it is loaded. You can, however, create a macro that
includes the steps needed to apply the equations.
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Part 8: Custom Plots

Custom Plots
You’ve seen how the primary filter limits both the entities and variables, and the secondary filter
further limits the entity list. The XY Variables and XY Entities plot types give you the ability to quickly
create plots using these filtered lists. You can even automatically create multiple pages of plots,
scrolling through every entity or each variable.

Another level of control is achieved using the XY Custom plot type. With this option you can define
exactly which variables are plotted for each entity and in what order.

You can choose any subset of values, effectively giving you a secondary filter for variables. You can
even design an entire page where some frames display one variable and others may show multiple
values. In addition, you can create different sets of these specifications, so that you could have a design
for each entity type.

The Custom Options Dialog

All these selections are made using the Custom Options dialog. This can be accessed from the menu bar
under Options > Custom Options.

This dialog contains options similar to those in XY Variables. It includes controls for choosing the
variables for each axis, including multiple Y axes and one or more variables on each.

Your custom plot definition will include the following:

• How many frames are shown for each entity. Each frame contains one plot. Note that this does not
necessarily have to correspond to how many frames are shown on a single page. If you define 6
frames per entity, and set up your multi-plot options for 2 frames/page, the program will create 3
pages of plots per entity.

• For each frame, exactly which variables are shown and on which axes.

You start by defining the total number of frames. This is done in the small drop list labeled "Total". You
may choose from 2 to 12 frames.

For each frame you must select the variable or variables you would like to display, and also which axis
they should appear on. This operates identically to the selections made in XY Variables.

A list control is used to select which frames you are specifying:
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For this exercise, you are going to do the following:

• Set a total of 6 frames.

• All frames will have Time on the X-Axis.

• Y-Axis variables will be as follows:
    Frame 1: Gas Production Rate (GPR)
    Frame 2: Water Production Rate (WPR)
    Frame 3: Oil Production Rate (OPR)
    Frame 4: Cumulative Gas Production (GPC)
    Frame 5: Cumulative Oil Production (OPC)
    Frame 6: Gas / Oil Ratio (GOR) on Y1 and Water/Oil Ratio (WOR) on Y2

If necessary, open the sample Chelan project file, then set up the Custom Plot options as described
above. The illustration on the preceding page shows what the Custom Plot Options dialog should look
like for frame 5.

Creating XY Custom Plots
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Select Plot Type > XY Custom. The sidebar will show the available
entities.

Access the Frames options and set things up for 4 multi-frames in a
2x2 configuration.

For the FIELD entity, the first page of the display looks something like this:
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Because your multi-frames options are set up for 2 x 2 frames, only the first four of the six frames you
specified are shown.

Pressing the  Next  button [>] brings up the remaining frames:
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You might prefer to set up your multi-frames options to a 3 x 2 frame layout, so that all frames for the
selected entity are displayed on a single page:
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By combining the options in Filters, Multi-Frames, and Custom Plots, you can create plots that display
only the variables you want, choose the order they appear, and limit which entities are output.

The Play Button

To quickly view all the pages, highlight the first entity in the list and then press the Play button( ).
The program will automatically scroll through each page.

If the animation is a bit too fast, you can slow things down. Access Plot Options and choose the first tab
(Load / Save). The animation speed is controlled by a slider:
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Want to print your plots or record to a file them for display outside of Tecplot RS? See RS Variables
Files of the RS User’s Manual for a discussion of output options.

Save Project File Changes

When you update your project file with the recent changes, the settings for custom plots will be saved.
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Part 9: Comparing XY Data Sets

Comparing XY Data Sets
It is often useful to be able to compare data from two or more files. The separate data sets may be
simulator output versus observed values, or perhaps multiple simulator runs. Tecplot RS contains tools
to allow you to display comparison data in several different ways.

Loading Multiple Data Files

Since the data sets to be compared are stored in different files, you must start by loading at least two.
You can load hundreds of XY files at once if needed, and you can choose files from among all those
loaded for display and/or comparison.

Start with the Chelan project file that you have been using for the preceding exercises. If multiple
frames are being displayed, use the Multi Frame Options dialog to switch back to a single frame.

Click on Project > Load XY Data or use the button on the toolbar, and then use the  Add…  button to
bring up a file browser.

The first file you loaded was a Unified Summary file from the Eclipse simulator. This time, you’re going
to choose a History file, which contains the actual recorded output. This will allow you to compare
recorded and simulated data.

Using the drop-down on the browser dialog, change the filter to "Eclipse(SLB)/Chears files". If needed,
browse to the Examples folder which will be in under the folder where Tecplot RS was installed. Then
select chelan.hist and open the file.
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The Active Data Set

When you load multiple files, you must designate the active data set. Only one data set may be
designated as active. The active data set is the one that will be displayed by default in all plots. When
comparing data sets, the active set will be the one the others are compared to, and the active data set
will determine which entities and variables appear in the selection lists.

Since you now have two data sets loaded, the Manage Data dialog will pop up:
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This dialog is used to designate the active data set,
which is the one highlighted in the list at the
bottom of the dialog. You can also see basic
information about the highlighted file in the
upper portion of the dialog.

By default, your original data file (chelan.unsmry)
file will remain active, and you’ll want to leave it
that way for this exercise.

Comparing Data Sets Within a Frame

The first approach for comparing data sets is to plot them in a single frame, usually using a different
line style for each. This can be done using the XY Variables, XY Entities, RFT, or XY Custom plot options.
All those sidebars contain these controls:

For this exercise, we’ll use XY Variables. Change to this plot type if needed. Select the OIL-01 entity and
WPR for the variable on the Y1 axis.

Now turn on the Compare toggle. Your plot is immediately updated to show both the active and
comparison data sets:
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A different line style is used for each data set, making it possible to see which is which.

Altering Styles for Comparison Data Sets

In Chapter 2 you got a brief introduction to Plot Options, where you were able to change the line
thickness and symbols for plotted lines. Now you’ll see how to use Plot Options to help differentiate the
lines for each comparison data set. On your plot, double-click on the blue line representing WPR for
the active data set. This should bring up the Plot Options dialog as shown here:
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Note that the Style Set option list is set to "Active". The settings you see are used when plotting WPR for
the active data set.

To see the settings used for the comparison data set, use that drop list to select "Comp 1". Alternatively,
double click on the orange line on your plot. The settings should now appear as:
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Two things are different from the styles for the Active data set: The line color is Orange, and the line
pattern is Short Dash.

You may prefer different settings, such as maintaining the line color and changing only the symbols.
There are many options that will help differentiate comparison data sets, such as:

• Make the line thicker on the active data set and thinner on the comparison set.

• Turn symbol fill on for the active set and off for Comp 1.

• Show only symbols on Comp 1 (turn off the Show toggle for lines), and show only lines on Active
(turn off the Show toggle for symbols).

• Make your symbols square for one set and diamonds for the other.

These are just a few of the many ways you can have Tecplot RS vary the styles between the active and
comparison data sets.

Note that there are also multiple Comp # options, allowing you to do comparisons of additional
datasets with styles changing for each.

The Delta Option

When comparing data sets in XY Variables or XY Custom, you may also turn on the Delta toggle. This
changes your plot so that the values represent the difference between the active and the comparison
data sets. The line for the active data set is unchanged and may be plotted for reference, but the lines
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for the comparison data sets are computed as the difference between the comparison data set and the
active. NOTE: The Delta toggle is not offered for comparisons in the XY Entities and RFT plot types.



When doing comparisons it is generally best to use DATE (rather than TIME) as the X-
Axis variable. This is because the TIME values often start at 0 but are measured from
different references, so that identical time values may actually not be measured at the
same physical time. Dates do not have this problem.

If you want to use TIME, then simply ensure that both files reference the same
starting point.

What Can Be Compared?

Remember that the list of entities and variables in the dialog come from the active data set, and these
may be reduced using the selections from the Filter dialog.

When you select an entity name from the sidebar, that entity is guaranteed to exist in the active data
set since this is where the list comes from. The program then looks for an entity of the same name in
the comparison data set(s). When using this comparison option, entity names MUST match exactly,
otherwise no comparison line is drawn.

There is some flexibility with matching variable names, however. It is not unusual that files from
different sources would use different names for the same quantity. For this reason, Tecplot RS allows
variable aliases. The rsvariables (simulator option) file defines a starting set of variable names and
aliases, but you can alter or expand these for each project.

To see the aliases along with other settings that originated from rsvariables, use the Variables tab on
the Plot Options dialog.
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When searching the comparison data set for the variable to be plotted, the program first looks for the
one that matches the name used in the active data set. If a match is not found, it checks to see if any
aliases have been defined for that variable, and searches the comparison data set for a match with
those. In the dialog shown above, if we selected "WPR" (the standard mnemonic for Eclipse simulators)
as the variable to plot, and this was not found in the comparison data set, the program would also look
for "QWP" (the standard mnemonic used by VIP).

You can designate a total of three variable aliases. This won’t be required for this exercise, since the
provided file does not require them, but you now know where to go when you need to set up variable
aliases.

Comparing Data Sets in XY Freestyle

The methods described above create lines for two or more data sets in a single frame. This approach is
very automated, but it has some limitations in that entity names and variable names must match.

The XY Freestyle plot type offers another way to do comparisons. It’s not quite as automated as the
Compare toggle. In freestyle mode, each line plotted must be individually selected. However, it is
completely flexible, allowing you to do such things as place comparisons in side-by-side frames,
compare entities with different names, define unique styles for each line, etc.

Start by using the Multi Frame option to set up 4 frames in a 2x2 arrangement. Then select the XY
Freestyle plot type. Initially, your plot will display an error message in all frames. This is OK and is
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because you haven’t specified the variables for the plot.

In XY Freestyle, you can create multiple pages, with multiple frames on each page, and any
combination of plots within each frame. For this exercise, you’re going to do side-by-side comparisons
of two variables (OPR and WPR) on the FIELD entity from the two files that are currently loaded (the
history and simulated data).

To do this, follow these steps:
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1. Set options for all plots:

1. Page = 1

2. Line = 1

3. Entity = FIELD

4. X-Axis = DATE

2. For Frame 1, choose:

1. File = chelan.unsmry

2. Y-Axis = OPR

3. Change to Frame 2 and choose:

1. File = chelan.unsmry

2. Y-Axis = WPR

4. Change to Frame 3 and choose:

1. File = chelan.hist

2. Y-Axis = OPR

5. Change to Fame 4 and choose:

1. File = chelan.hist

2. Y-Axis = WPR


When changing to a different frame, you can enter the desired frame number directly
into the Frame field, use the small up/down buttons next to the field to advance to the
next frame, or simply click inside the desired frame in the plot.

Your plot should look something like this:
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Feel free to experiment with adding more maps, frames, and pages. You can also double-click on the
lines to change styles.
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Part 10: RFT Plots

RFT Plots
RFT data are basically the same as the observed data that come from the Eclipse *.unsmry or similar
files. The primary difference is that with RFT data the independent variable is depth instead of time.
While RFT data can be plotted using any of the three basic XY plotting functions (XY Variables, XY
Entities, and XY Custom), Tecplot RS includes a specialized module for RFT data that simplifies some of
the selections.

Loading RFT Data

Since they are stored in separate files, RFT data must be loaded separately. Start by bringing up the XY
file loading dialog, then click on the  Add  button to bring up the browser. From the list of file types,
select "VIP files." You may then load the chelan.frft file that was included with the sample files
installed on your system.

When you click  OK  in the Load XY Data dialog, Tecplot RS will ask if you want to append the RFT data
to the current data set. Click  Yes .

Next, the Manage Data dialog will be displayed.
You may notice that the RFT file you just loaded
does NOT appear in the list of available data sets.
However, if you look at the top of the dialog, you’ll
see that the active data set (chelan.unsmry) now
indicates that the RFT data have been appended.

Tecplot RS groups the RFT data into its own entity
type, just as wells, regions, quality data, etc. are
types. The Filter options also include the RFT type.

By appending RFT data to the current data set,
you make it easier to access and switch between
plot types. Hit the  Save  button to update your
Project File so that the RFT data will be loaded the
next time you use the project.
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RFT Plots

Choose Plot Type > RFT to switch to the RFT sidebar.

As with other plot types, you can plot a single line
or several. For RFT plots, the multiple lines show
data at various dates. Remember that time/date
are NOT the independent variable in this data
type - DEPTH is. So each time is shown on a
separate plot line.

By default, RS selects DEPTH (the independent
variable) for the Y-Axis, and PRESSURE (the first
dependent variable) for the X-Axis.

Your job is to select well OIL-01 for the entity to
plot, and to choose one or more dates for which a
plot is desired. For this exercise we’ll use years
1972 - 1974.

Note that the Y axis is inverted so that values increase downward, a more natural way to visualize
depth.
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Save Gallery Plot #3


It’s time to save another gallery plot. Use Gallery > Save and name this one RFT
Pressure. Then save your project file by clicking on the save icon or selecting Project
> Save from the menu. In Plot Gallery you’ll make use of your saved plots.

Comparing RFT Plots

You may compare RFT data from two or more files. Comparing XY Data Sets describes the basic
operation for comparison plots.

When searching for a match between the active data set and the comparison data set(s), the program
must look at both the well name and time/date identifier. The well names must match exactly, but it
would be unreasonable to expect that dates or times would be identical. For this reason, when
searching the comparison data set for a match, the program will find the time closest to the one
selected for the active data set. The time will be reflected in the legend so that you can see which
measurements are being used.
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In general, it is better to set your time units to Date, as this removes the ambiguity caused with time
(days) values.

The delta option is disabled when comparing RFT data.
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Part 11: Completion Profiles

Completion Profiles
As with RFT data, completion data may be plotted using any of the standard XY plotting functions.
However, Tecplot RS provides a different view and a simplified interface for completion data, designed
to compare results from each completion in a single well.

The data files you have been working with thus far do not contain completion data, so we’ll need to
load another data set. Use the XY File loader to load the completions.unsmry file. This will be in a sub-
folder names "Completions" under the Examples directory where you found the Chelan data.

After loading the new data set, the Manage Data dialog will be displayed. You will need to make the
new data set active by highlighting it. You’ll also see in the information area that this data set contains
29 completion entities.
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After dismissing the Manage Data dialog, select Plot Type >
Completion Profiles to bring up this sidebar:

The list of wells is automatically limited to those containing
completion data. These appear in the first list box. The
number in parenthesis indicates the number of completions
in each well.

The available times are shown in the center list box. Each
plot will reflect values at a selected time. The display of days
versus date is determined by a setting in Plot Options on the
first tab.

The variable to be plotted is selected at the bottom of the
sidebar. To start, make the selections as shown here.

The resulting plot will look like this.
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The bars give you a clear picture of how each completion is contributing to the total well production.

This plot shows only Oil Production Rate, but you can select up to three different variables for display.
It is generally best to show each variable on a different axis, especially if their units and/or ranges vary
significantly. This works just like it did in the XY Variables exercise.

In the second list box containing the variable names, choose WPR. Then change the drop-down menu
that is labeled "X2-3" to select axis 3 and select GPR.

Now your plot should look like this:
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Save Gallery Plot #4

Once again save a gallery plot, and name this one Completion Rates. Again, be sure to save your project
file.
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Part 12: Plot Gallery

Plot Gallery
In previous chapters you’ve been directed to use the Gallery > Save function to save several plots. It’s
now time to see what this can do for you.

If needed, load the Chelan project file that was saved in the preceding chapters. Then Select Gallery >
Manage from the menu. This should bring up this dialog:

Here you see the four saved gallery plots. Plots are
grouped by plot type, which helps when
managing large numbers of plots. The groups can
be individually expanded and collapsed using the
controls next to the group name.

If your dialog does not include all these plots, it is
probably because you failed to save the project
file. Gallery plots are saved only when the project
is saved.

To display a plot, you can either highlight it and
click  Display , or simply double-click on the
name. You should do this now for each of the
saved plots.

Note that when you display a plot, not only will you see the same image as when it was saved, but the
sidebar will also update to reflect the plot type and all the selections made. That’s because gallery plots
are not simply an image, but record the "state" of the program. This means you can use gallery plots to
get back to where you were when the plot was created, and perhaps continue work or use them as a
starting point for creating new plots.

The Plot Gallery manager dialog also includes buttons that will allow you to export, print, or delete the
highlighted plot, plus a Save button that is identical to using the Save option from the menu. The dialog
is 'modeless', meaning that it can remain open while you do other work (although you’ll probably want
to move it off to the side).
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The ten most recently used gallery plots are also displayed under the Gallery pull-down menu, and
you can display them by clicking on the name there.

Gallery Plots save every selection needed to reproduce the state of RS when you saved them, with one
exception. Selections made in the Plot Options dialog are saved only once as part of the project file. In
other words, Plot Options are a 'global' setting for the project, and any changes made there will be
reflected in ALL gallery plots that are part of that project.

2D and 3D grid plots can also be saved in the gallery, so as you move into those exercises, be sure to
save some plots and experiment more with the gallery.
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Part 13: Flow Tables

Flow Tables

The Flow Tables function requires that you be
familiar with CHEARS flow table (.flot) files.

Flow table plots display the information in one or
more *.flot files. Flow tables contain an N-
dimensional array of bottom hole pressure (BHP)
values plotted for N-independent variables. BHP
is shown on the Y-axis of the plot. Flow tables also
include a dependent variable which Tecplot RS
places on the X-axis. (Dependent variable applies
to the flow table, not to the Tecplot RS plot.) Flow
tables are plotted by creating XY-slices from a
combination of independent variable settings.

Loading Flow Table Data

Flow table data are very different from the data sets used in the other XY plotting options. Because of
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their uniqueness, they are not loaded from the standard File Loading dialog but are instead accessed
through the Flow Table sidebar (select Plot Type > Flow Tables):

Pressing the  Load…  button will bring up the standard file selection dialog that will allow you to
choose the .flot file to be loaded. Chelan.flot is included in the example files installed with Tecplot RS,
and you can load it now.

You may load more than one flow table file at a time. If you do so, you may find it helpful to turn on the
Show Source File toggle. This will show the file name along with the flow table number.

Once loaded, flow tables can be removed using the  Unload  button.

The Flow Tables Selections

Once data are loaded the sidebar will show the available variables
and options.

The Well Type (injector or producer) and dependent variable are
determined by the data file. They are displayed on the sidebar for
reference.

Flow Table Number

You must select one flow table number to view from the Flow
Table Number list box. Changing the flow table number may
cause the options in the remaining list boxes and option menus
to change, since each table may have different dimensions.

Multi

When a variable is selected in the Multi drop-list, the list
beneath shows all the associated independent values of the
selected variable. From this list you may select one or more data
values. Each will be shown on the plot using a different line
color.

Single

There may be one or more variables listed in the drop-list under
the Single heading. As you choose each one, the list box beneath
will display the independent values for that variable.

You should choose one value for each of the single variables. These selections will determine the data
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to be plotted. Your choices will also be reflected in the plot title:
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Part 14: Setting Axis Ranges And Scales

Setting Axis Ranges and Scales

Frame Range

In preparation for the next exercise in this section, please be sure the chelan.unsmry file is loaded and is
the active data set. Set up the multi-frame options to display a total of 4 frames in a 2 x 2 arrangement.

Select the XY Variables plot type and choose OIL-01 as the first entity and GPR (Gas Production Rate) as
the Y-axis variable.

Look at the ranges shown on each of the 4 frames and note that the upper limit varies in each
(anywhere from 800 to 5000). The ranges selected for each frame are, by default, chosen to 'fit' the data
being displayed.

Now double click on the Y-axis title - the text that says "Gas Prod Rate (MSCF/DAY)". This should launch
the Plot Options dialog with the XY Axes tab selected and GPR highlighted in the Variable list:
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This page of the Plot Options
dialog allows you to control the
axis styles and limits for XY
plots. The settings are unique to
each variable, so that you can
tailor the options accordingly.

For our default plot, the selected
Range option is "Frame",
meaning that the axis range will
be determined by the data
shown in each individual frame.
This is fine for getting the
greatest amount of detail, but
not terribly useful for comparing
multiple entities in side-by-side
frames.

Data Range

For this exercise, change the Range option to "Data". This option tells Tecplot RS to set the axis range to
fit the minimum and maximum for all entities of a single type. This works within entity types so that
the FIELD range (generally the sum of all wells) doesn’t skew the ranges for individual wells.

You’ll need to click on the  Apply  button in order to see your changes. When you do, your plot should
look something like this:
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Now all four frames have a range from 0 to 5000, making it easier to see the values of each well
relative to the others.

Manual Range

The third option in the Range pull-down menu is "Manual". When you select this, three text boxes
labeled Min, Max, and Interval will be activated. We’ll use these to input our own range, overriding the
calculated values.

Enter 0 (zero) as the Min value and 10000 in the Max box. In the Interval box, enter a value of 500.
Then click on  Apply  to see this plot:
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The lines appear flattened because we’ve scaled to a much larger range. The axis labeling interval is
also much tighter, showing major grid lines every 500 feet.


Leaving the interval at 0 (zero) would have instructed Tecplot RS to compute a 'nice'
interval. When specifying an interval other than 0, Tecplot RS will give you exactly
what you request.

Axis Scales

Another option on the XY Axes tab of the Plot Options dialog is to define a scale factor to be applied to
the plot axes. By default, this is set to 1 meaning that no change is made. You can use scale factors to
shorten the axis labels (e.g. to show values in thousands of barrels instead of barrels). They can also be
used to convert the plot to different units of measure, such as English to metric.

For example, our GPR values are expressed in MSCF (thousands of cubic feet). We can change this to
cubic meters by specifying a factor of 0.03531467 (there are 35.31467 cubic feet in 1 cubic meter, and
then we divide by 1000).
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For this exercise, first set the
Range option back to Data.
Change the Scale option to
"Enter", and the enter the value
0.03531467 in the text box
beneath the scale options.

We’ll also want to reflect the
new units in the axis label. To do
this, check the "Unit override"
toggle and then enter "m3" in the
text box that appears.

Finally, click on  Apply  to see
the results.

Log Scales

The final option available for scaling the grid axes is a logarithmic scale. For this exercise first choose
OPC (Cumulative Oil Production) from the variables list in the sidebar in order to display this on your
plot, and then double-click on the axis label to highlight OPC in the Plot Options dialog.

Toggle on the "Log" option (leave the scale value at 1), and then press  Apply . Your first frame should
look like this:
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As you can see, there are many things you can do to customize the appearance of your plots.

Saving Plot Styles in a Named File

There are many customization settings in the Plot Options dialog, and setting things up exactly as you
want may take some time. If you click on the  Save  button, all the settings you made in this section
will be saved to your current Project File and will be used the next time you open that project.

Many Plot Options settings are not limited to a specific project, though. In particular, line styles and
paper layout templates (covered in XY Plot Appearance) are often company-wide standards. You don’t
want to have to repeat your changes every time you start a new project.

Happily, you don’t have to. All your Plot Options settings can be saved in a named file and used as a
default starting point whenever you create a new project.
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To do this, bring up the Plot
Options dialog and choose the
Load/Save tab.

Click on  Save As…  and enter a
name and location for a file that
will hold the style settings. Once
this is saved, check the "Load at
startup" toggle. This will instruct
RS to use these styles any time
you start a new project.

You can also use this feature to share Plot Options styles between projects. The  Load…  button will
open project files as well as files saved from the Plot Options dialog.
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Part 15: Loading Grid Data

Loading Grid Data
Tecplot RS has many sophisticated functions for plotting both 2D and 3D representations of a reservoir
model. Your first step will be to load a file containing the data you wish to plot.

If you did the XY examples in the first part of this tutorial and have an existing Chelan project file,
make sure it is open. This will allow you to add the new grid data to the existing XY data.

Load Grid Dialog

To load most grid data, you can use either Project > Load Grid Data or the  toolbar button. This
will bring up a browser that is used to choose the appropriate file.

For data in the NEXUS VDB format, instead of a file name you’ll be selecting a case folder directly

under the .vdb folder. Use the  button or menu option for VDB data. This will bring up a folder
browser.

Grid File Types

RS supports a variety of data formats for grid data. At the time of this writing, these include:

• Eclipse/SLB (also includes CHEARS)

• CMG (available on Windows platforms only).

• Sensor Map

• UTCHEM

• VIP Map files (older NEXUS… format)

• VDB folders (newer NEXUS format)

New loaders are added regularly - check with your Tecplot representative for an up-to-date list.

When the file browser is launched the filter will include options for each type. The sample data files
included in your Tecplot RS installation are Eclipse/SLB format, so choose that if needed. Then choose
the chelan.grid file from the examples folder.
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After you open the file, you’ll see this dialog:

The Eclipse data are actually found in three or more files. These include:

• *.grid - Grid file, containing the grid geometry.
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• *.egrid - Alternative format for the grid geometry

• *.init - Init file, containing static properties such as porosity or permeability.

• *.unrst - Unified restart file, containing time-dependent values such as pressure and oil saturation.

• *.Xnnnn - Individual restart files, each containing one time step.

You normally need to browse to only the grid file name. The program will automatically find the
additional files as long as the root names match that of the grid file. You’ll see that the init and unrst
files were found and filled in for you.

You may also notice that the unsmry file containing the XY data was also found. When loading grid
data, you have the option of loading a single XY file along with it. You can clear this field if you don’t
want the XY data loaded, or use the  …  button to browse to a different file. Don’t worry if the XY data
for this file are already loaded; Tecplot RS will detect this and won’t load it a second time.

The options shown on the Files tab of this dialog are specific to loading Eclipse grids. Had you chosen
files from a different simulator type the options would be a bit different. See the User’s Manual for a
description of each type.

There is a separate Options tab that is common to all file types. Select that tab now.

Grid Loading Options

Before loading a grid, it is important that you review and understand the available options that
determine how the data are loaded and/or interpreted.

Grid Optimization

The Optimization options can be used to control how the grid will look, reduce the amount of RAM
needed to load the grid, and improve performance when loading and viewing the data. There are three
optimization options: Keep original grid, Create corner point - Shift, and Create Corner Point - Average.
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In the grid file, the reservoir is modeled as thousands or even
millions of individual cells. These cells are shaped like bricks, so
eight individual points or nodes (with X-Y-Z coordinates) are
required for each brick:

If two cells are adjacent and the nodes match, Tecplot RS will always "share" the nodes so that fewer
points are needed. In this example, two bricks require 12 nodes instead of 16:

If the nodes aren’t coincident, then all 16 points will be required:

Tecplot RS gives you two options for creating corner point grids from these "stepped" block models. By
doing so, you smooth out the surface and force the sharing of nodes. This will greatly reduce the
number of points required to store and display the model, and also give a more realistic look to the
model.
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The Shift option simply joins the corner of one cell to the adjacent node in the next higher-numbered
plane. The Average option, on the other hand, calculates a new node whose Z value is the average of
the nodes being joined, and both corners are moved to this new location.

If NNCs (Non-Neighbor Connections) exist in the grid, the grid will NOT be smoothed across the NNC
plane. In effect, NNCs define fault lines. NNCs are specific to Eclipse/SLB files, but other file formats
have similar means of defining faults that will also be honored.


Creating a corner-point grid does NOT change the variable values (pressure,
saturations, etc.) Only the shape of the grid is affected.

Tolerances

If you elect the "Keep original grid" option, the program will not force the smoothing. However, it will
still try to save resources by sharing nodes that are duplicates (or nearly so).

You can enter a tolerance that defines how close the node coordinates must be in order to be
considered the same. Different tolerances may be entered for horizontal (XY) and vertical (Z)
dimensions. Tolerances may be very small, but don’t use 0 (zero) because this pretty much guarantees
that coordinates will never match. That’s because there is always a small error due to the inability of a
computer to exactly represent a floating-point value.

In general, a value of .05 (less than an inch) will deal with machine accuracy errors. If you encounter
files where no smoothing is being performed even though the coordinates seem to match, you can try
larger values. If you want to force more nodes to be smoothed, you can make the tolerance larger.

The RSGRID File

The options for grid optimization are very important the very first time you load grid data into Tecplot
RS. That’s because RS does the smoothing or node sharing and then saves the results into a new file
with an extension of .rsgrid. The optimization can be a lengthy process, so we don’t want to repeat it
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every time the file is loaded. The first load may take a longer time while the RSGRID file is created, but
subsequent loads will be much faster.

The first three radio buttons on the Options tab are needed when you already have an rsgrid file but
want to change the optimization options. They work like this:

Use existing RSGRID file settings Creates a new file only if the RSGRID file is older than the simulator
file that it was originally created from. In that case, the
optimization settings used will be those that were in effect when
the old file was originally created (the ones in the dialog are
ignored).

Update RSGIRD file with these
settings

Creates a new file if the optimization options in the dialog are
different than those used when creating the existing RSGRID file. If
the RSGRID file is older than the source file, the new one will use
the dialog settings.

Create a new RSGRID file Forces creation of a new RSGRID file using the settings in the
dialog, no matter what.

You can also create the RSGRID file outside the Tecplot RS environment. A small executable program
named rspreprocess.exe has been provided to allow you to do this. It can even be automatically
launched at the end of a simulator run. See the Command Line Options section in the RS User’s Manual
for more information.

Loading The Grid

For this exercise you’re going to load two grid files. Both will be found in the installation folder (on
Windows this is usually C:\Program Files\Tecplot\TecRS 2025 R1) under a sub-folder named examples.

If you haven’t yet done so, start by loading the Chelan.grid file. The Solution Data files should be filled
in for you automatically. You can leave the Options selections at their default settings, and the
Streamlines and Survey Wells fields should be blank. The Make active toggle should be checked. Click
OK  to load the file.
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Loading Multiple Grid Files

Tecplot RS will let you load up to ten different grid files at once, and you can quickly flip back and forth
between them or plot them side-by-side for comparison purposes.

 Now that the Chelan file is loaded, you’ll repeat the process and choose a second file. This time
choose the quinaultlgr.grid file from the same folder. When the Load Grid Data dialog comes up,
notice that the Make active toggle will be turned off by default. As with XY files, you can load multiple
grids but only one will be designated the active file. The program assumes that all files after the first
are inactive, but you can change it with this toggle. For now, leave all controls in their default state and
press  OK  to load the new grid.

The Manage Data Dialog
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 You can also change the active grid using the Manage
Data dialog, accessed from either the toolbar or under the
Project menu. This dialog also lets you:

• View information about your loaded files.

• Choose a different active data set.

• Designate a display name, which is usually a shorter
name to identify the data set.

• Unload one or more loaded data sets.

Launch this dialog, choose the Grid tab, and highlight each
of the Available Data Sets in turn. As you do, information
about the highlighted file will be displayed at the top.

To change to a different active data set, simply highlight the
file name in the lower list box. When you press  OK  and
choose the desired plot type, the plot shown and sidebar
lists will reflect the data from the newly active grid. For this
tutorial, make sure that Chelan is highlighted before exiting
the Manage Data dialog.

Since grid files can often take up large amounts of system RAM, when a grid is no longer needed it is a
good idea to unload it. This releases the system memory in preparation for loading another file. The
Unload tab can be used to unload selected files.

Save A Project File

 Now that you have grid data loaded, be sure to save the Project File. This will save you many steps
when you want to use these data again. If you already have the Chelan project file open, simply
clicking the  Save  button will add the newly loaded grid files. If you don’t have a current project,
clicking the  Save  button will bring up a dialog asking you to assign a name to the file.

Project Files are one of the best time savers available in Tecplot RS. Use them to quickly return to
where you were last working.
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Part 16: Basic Grid Plots

Basic Grid Plots
In order to create the example plots shown in this chapter, make sure you have the chelan.grid file
loaded and active. This can be found in the examples folder under your installation directory.

 You will also want to open the Multi-Frame Options dialog and set the Frame Mode to Single
Frame.

Selecting The Grid Plot Type

If the grid file is the first file you open after starting Tecplot RS, the program will default to the 2D Grid
plot type. If you were previously working in another plot type, however, this automatic switch will not
happen.

In either case, you can select the type of grid display (2D or 3D) under the Plot Type heading on the
menu, or using the small option menu at the bottom of the sidebar.

The 2D Grid plot displays one plane (layer) of grid cells at a time. You can choose which planes to plot
by specifying both the view (I, J, or K) and the plane index. Radial grids also have the option of
displaying the developed views at constant R or Theta values.

3D Grid plots show the entire reservoir grid in a 3-dimensional orthogonal or perspective view. The
initial orientation of the view is preset, but the view is easily rotated, zoomed, or translated
interactively.

Grid Sidebars

A different sidebar is displayed for the 2D and 3D Grid plot types, but both share some common
controls. In this section we’ll cover the selections and operations that are common to both 2D and 3D
plots.
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Changing The View (Rotate, Translate, And Zoom)

You’re going to start by examining some of the options for adjusting the view. If you aren’t there
already, please select Plot Type > 2D Grid. By default, the first K plane should be shown:

Zooming In/Out

Tecplot RS establishes the initial view so that the values on the X and Y axis should encompass the
entire grid. There may be times that you would like to change that, perhaps because you’d like to take a
closer look at a particular area.

Using the mouse, position the pointer anywhere on the frame. Click and hold down the middle mouse
button, then move the mouse up and down. If you have only a two-button mouse with no middle
mouse button, you can instead use Ctrl  +  Right-Mouse  button. Notice how the grid moves away from
you as you move the mouse up, and closer when the mouse is moved down. Release the mouse button
when you are satisfied with the view.
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 Another zoom tool can be found on the tool bar. With this, you can click and drag to create a
rectangle around the desired view area.

Panning

The mouse can also be used to "shift" the view within the frame. This time, use the right mouse button.
Click anywhere on the frame and hold down the button while dragging the view left, right, up, or
down.

 Alternatively, you can change to pan mode by clicking on the button shown here.

Adjusting The 3D View

These same controls will work on the 3D grid view. Select Plot Type > 3D Grid. Your initial display
should appear:
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As you did in the 2D view, use the middle mouse button to zoom in and out, or the right mouse button
to pan up/down/left/right.

Rotating The 3D View

 There are several options for rotating the 3D view. Start by clicking on the tool bar button
pictured here. You can now press and hold the left mouse button, and as you drag the pointer your plot
will rotate the view about the vertical (Z) axis.

While in this mode, press X or Y on your keyboard to change the axis of rotation to the X-axis or Y-axis,
respectively.

 Another rotation option uses a trackball approach, where the plot can be rotated freely about all
axes. You can access trackball rotation in two ways. The first option is to click on the tool bar button
shown here. Then, use the left mouse button to "roll" the ball in any direction. Alternatively, you can
hold down the Ctrl  +  Right-Mouse  button, and accomplish the same thing.

Reset View

Any time you’d like to start over when setting the view, press the  button. This will return the plot
(both 2D and 3D) to the initial default settings.

Note that in 2D views, the view is also reset any time you change the view plane (e.g. from I to J plane
views).

View Presets

When 3D views are displayed, there are additional preset rotations available to you. Choose View >
View Presets from the menu to choose from 8 standard orthographic projections plus a plan (aerial)
view.

Paper Zoom

The view zoom options change how the data appears within the plot frame. You can also zoom in on
the paper view, which is often helpful to read small text or see greater detail without modifying the
plot itself. To do this, use the Shift  key along with the middle or right mouse buttons as described for
zooming and panning.

Selecting Variables

101



The variables contained in the solution files are presented in a
single- select list box near the top of the sidebar. Time-dependent
(restart) variables are listed first, followed by static (init) values.
Names are sorted alphabetically within each group. When the
dialog is first initialized, the first variable in the list is highlighted
by default. Each cell in the grid plot will be filled with a color
representing the value of that variable at a given time.

Note that the legend in the corner of the frame also shows the possible range of variable values and the
colors associated with each.

On your system, try selecting several variables in turn and observe how the colors and legend changes
for each.

Selecting Times

Beneath the list of variables is a small slider control. This is used to
choose the time step for time-dependent variables. Note that if the
active file does not contain time-dependent variables then this
control will be disabled.

Start by selecting a time-dependent variable such as pressure or oil saturation (SOIL). Then use the
mouse to drag the slider to a different position. When you release the mouse button the plot will be
updated to reflect the values at the new time. As you move the slider, the time or date will also be
displayed in the text field, allowing you to zero in on the date of interest.
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The time can also be labeled on the plot, although this requires that the paper layout template include
either the RS_PLOTTITLE or RS_ENTITY dynamic text. See Paper Layout section for details.

Stepping Through Times

 The slider is handy for quickly jumping to a particular time, but other options exist that
give you a little more precise control. The small buttons beneath the slider look and act much like
controls on a DVD player. Position the slider on the far left (first time step) and then click on the  >
"Next" button a couple of times. This will display each time step in turn. Press the  <  "Previous" button
to back up a step.

Animating The Time Sequence

You can also automate the entire sequence of time steps. Start by selecting the first time step and then

press the  button. The program will cycle quickly through the entire range of time values. You can
also animate backwards.

While the sequence is being animated, the  button will become active, and you can press it to
interrupt the animation sequence.

Controlling Animation Speed

Sometimes the animation sequence goes by too quickly, especially when the grid is relatively small.
You can control this using a selection in the Plot Options dialog.

 Plot Options may be accessed using either the Options > Plot Options menu or the button on the
tool bar. Either method will bring up a tabbed dialog. Select the first tab, which is labeled Load/Save:
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A slider labeled "Animation Step Delay" controls the pause between each animated time step. Move it
to the right to increase the delay and slow down the animation.

Variable Display Toggles

When in 2D Grid mode, next to the list of variable names will be
two toggles: OWG and Time Delta. When it 3D Grid mode, these
toggles are radio buttons along with 6 addition radio buttons for
setting the 3D derived view.

In 3D Grid mode, derived views are mutually exclusive and only
one can be selected at a time. The individual radio buttons may be
disabled if the active grid does not have the data needed to support
that function.

Standard

This is the default view when no other derived views are selected.

OWG (Oil / Water / Gas)

This derived view will be available only if your data set includes values for oil, water, and gas

104



saturations. Note that if any two of these exist in the file, Tecplot RS will automatically compute the
third for you. Select the OWG derived view and note how the plot changes to a ternary RGB
(Red/Green/Blue) color scheme. The intensity of each color is determined by the associated saturation
variable: Blue = Water, Red = Gas, and Green = Oil. The legend also changes to the RGB color triangle.

You can change the time steps or animate the plot to see how the relative oil, gas, and water
saturations change over time. For example, by observing the predominantly blue regions you can
easily monitor areas with high water saturations.

Time Delta, KSum delta, KAvg delta

Instead of showing the variable value at each time step, you may create plots that represent the change
in values over time relative to a reference time step (usually the first, but you can select any reference
time step using the  …  button). This is accomplished using one of the "delta" derived views.

 For 2D Grids, "Time Delta" is a toggle

For any of the delta derived views, the colors in each cell represent the difference in values at the
current time and reference time. If the slider is at the first time step AND your reference time step is
step #1 (the default), then the entire grid should be a solid color representing a value of zero. As you
move to later times the colors will show how the variable value increases or decreases over time.
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Delta derived views are not available when no time-dependent variables exist in the file. Try selecting
a Delta option with the sample data. Make sure you have a time dependent variable selected, choose a
time step other than the first, and note the changes on your display.

Note that delta derived views control time deltas within a single grid and between two different times.
There is a delta toggle at the bottom of the sidebar that controls grid delta values between two
different data sets.

K Sum and K Avg (3D plots only)

When activated, the K Sum derived view will cause Tecplot RS to sum all the variable values in a
column (all cells with matching I and J indices). The summed value is displayed in all cells of that
column. Since these data are typically viewed from the top, the program will switch to a plane view,

but the full 3D grid still exists and can be seen using the Reset View button  or the view presets
under the View menu. Cells in LGRs are summed separately from the parent grids, and if the LGR is
not at the grid surface you will need to switch back to an orthographic projection in order to see it.
When K Avg is selected, the summed values are divided by the number of cells in that column.


PLEASE NOTE that this is NOT a volume-weighted option. K Sum and K Average will
limit calculations to visible cells - those not turned off by blanking or Inside View
settings. Blanking and Inside Views are covered in Value Blanking and Inside Views.

Selecting 2D Planes

If you are viewing a 3D grid right now, please switch to the 2D view.
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When you switched to the 2D view the program defaulted to display the plane at K=1. You’re not
limited to this view - the controls in the middle of the 2D Grid sidebar let you choose both the view
direction and the plane number.

The View Plane options let you choose to look at planes in any of
the three dimensions: I, J, or K. When you make this selection, the
list box on the left will be updated to include the plane numbers
available in that dimension. The highlighted number indicates the
index being viewed. You may choose another plane by clicking on
the desired number, or the  <  and  >  buttons can be used to scroll
up and down the list. When the list control has focus, the arrow
keys on your keyboard can also be used.

For this exercise, look at several different planes in each of the three views (I, J, and K). Try changing
the variable and/or animating time steps.

The LGR controls (to the right of the plane list box) are activated when your file has local grid
refinements. You’ll learn how to use these in a later exercise.

Wells Toggle

On the top of the sidebar are several toggles that control additional items
that can be displayed on your grid plot. Start by placing the time slider to
the middle of the scale, then turn on the Wells toggle to show the well
geometries for the reservoir.
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In 2D Grid plots, a well is usually displayed only if it has a
completion in the current plane. As you step through the
available planes, you may see wells appear and disappear
accordingly.

In the I planes, for example, you won’t see a well until you
hit plane #8!

Switch back to a 3D Grid plot type to view the wells in 3 dimensions:

Wells change over time. If you don’t see any on your plot, it may be because your slider is at the initial
time step and no wells are on line at that time. Try advancing the times and see how things change. In
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the example Chelan file, you may see 0, 2, 3, 4, or 5 wells depending on the selected time.

A symbol is drawn at the top of each well, and varying shapes and colors are used to differentiate well
types; producer, gas injector, water injector, etc. Other symbols are shown at each well node or
completion, although they may be hidden on the 3D view.

Using Zone Layers and Zone Effects to View the Grid Interior

To view the hidden completion nodes, turn on the Translucency toggle on
the sidebar menu. The surface should change so that you can see through to
the previously hidden details beneath.

You may also want to turn off the Mesh layer and/or rotate the view to make
the wells easier to see. Finally, turning on the Light option will highlight the
surface details that were lost when the mesh was turned off.

Changing Well Styles

 You have extensive control over how wells are drawn and labeled in Tecplot RS. These options are
found on the Wells tab in Plot Options.
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The simulator output generally includes a type for each well. The Chelan data set contains two types -
producer and gas injector. In addition, Tecplot RS also reads the well status and knows when a well is
closed down or shut in. Finally, the individual completions will also have two states - open or closed. In
2D and 3D grid views, symbols will be drawn at the well head and completion nodes that will help
identify each type and state. Since states may change over time, the symbols will be updated to reflect
the changing status as you move the slider.

You may designate the shape, color, and size for each of these symbols. For this exercise, we’re going to
select a different symbol for completions, enlarge the text so it’s easier to read, and adjust the
placement of the well head with respect to the grid surface.

Note that the current symbol type is Producer, and the other options show that wells of this type will
be shown as a black sphere that is drawn at a size that is 2.2% of the frame size.

Change the Type to "Open Node". The shape, color, and size should show
circle, white, and 0.8%, reflecting the options for drawing the symbols at
open completion nodes. Use the option menu to change the shape to Square.
You’ll then need to click on the  Apply  button to see your changes on the
plot.

Feel free to change some of the other options and see the effects of your changes. Remember that not
all the wells exist in the Chelan data set at earlier times, so you may need to push the time slider to at
least the middle of the range.
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Next, let’s change the size of the well labels to make them a bit
easier to read. The default size is 2.0, again representing a
percentage of the frame height. Change this to 2.2 and again click
on  Apply  to see the differences. You can also alter the color and
font.

Finally, we’ll learn how to control the placement of the well type symbol. The well type symbol is
drawn above the surface of the grid in order to make it visible. There are four different ways for
computing the offset:

1. offset from well head (actually the first node in the well geometry)

2. offset from grid max (the highest elevation in the grid geometry)

3. Fixed offset from well head

4. Fixed offset from grid max

Generally the first two options are better defaults since they will adapt nicely for different grids. The
default is option #2, which ensures that the well type symbols are always placed at the same elevation,
and that elevation will be somewhat higher than the highest point on the surface.

For this exercise, change to the option "%offset from well head", and change the offset value to 20.
After clicking on  Apply  you’ll see that the well type symbols more closely follow the surface of the
grid.

Again, feel free to experiment with all the options on the Wells tab to see how they affect your plot. You
may also want to save one or more gallery plots as you work.
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More Wells…

A small  …  button next to the Wells toggle gives you additional control over the well display. Press it
to bring up this dialog.

With the options presented here, you can limit the displayed wells to a subset of those in the file. This
is often helpful when there are so many wells in the reservoir that displaying all of them makes it
difficult to see the details.

By default, all your wells will be selected for display. Simply change the
highlights in the list box to choose a subset of the available wells for display.
Use  Refresh  to apply your changes to the current plot.

Of course, if you have thousands of wells, choosing the ones you want to
display from a list box is not terribly efficient. That’s where the additional
controls come in. Here we have Selection Sets again!

If you haven’t done so already, you should read chapters 4 and 5, which
cover the basic concept of selection sets and how to create them using
Filters.

Within this dialog, you can both create new selection sets from the list of
highlighted wells, AND you can use existing selection sets to change those
highlights.

To create a new selection set (SS), start by highlighting the wells you want to include in the upper list
box. Assign a name for the set (or use the supplied default) and click on  Make SS .

To use an existing SS to alter the highlights, select the set you want from the lower list box. Choose the
rule for making the changes:

• Add to selections: Each well name from the selection set will be highlighted in the upper list box,
without disturbing existing selections.

• Remove from selections: Each well name from the selection set will be turned off in the upper list
box, without disturbing other selections.

• Replace selections: All highlights in the upper list will be modified so that only the wells in the
selection set will be highlighted.

Press  Apply  to use the selection set to alter the wells selected for display.

112



You can also use the mouse to change the list highlights. To do this, start by
turning on the well display with the well labels (labels are controlled in Plot
Options). This is necessary because you will be selecting the well labels with
the mouse, rather than the well symbols. If you like you can make the labels
very small.

Make sure the Mouse tab is active on the dialog. Use the mouse to pick the
wells. You can do this by rubber-banding a box around the ones you want,
and also by holding down  Shift  and clicking on individual labels. Just
remember it is the labels (text) you want; any other picks will be ignored.

Press  Apply  to use the picked wells to alter the well highlights.

Save Your Project File

Hitting the  button will ensure that the Selection Sets that you just created plus your style changes
will be saved in your current Project File.

More Options

There are dozens of different options for changing the way grid plots are displayed. Here are some
things you should try with 3D Grid views so that you can see the possibilities:

• On the Plot Options: Wells tab, try both the Frame Units and Grid Units settings for text (note that
you will have to click on the  Apply  button to see the effects). Each time, zoom in and out on the
grid view and watch what happens to the well labels.

• In the Plot Options: Grid Axes tab, turn on the toggle for Show 3D Axes.

• In the Plot Options: Grids tab, switch the Contour Type to Continuous Flood. Look at several
variables and time steps in both 2D and 3D Grid types, comparing them to the results you had
when Cell Center Flood was selected.

• With wells displayed, turn on and off the sidebar toggles for Mesh, Contour, Connect, Lighting, and
Translucency.

• In the Grid Options dialog, set the 3D Z-Axis Scale to 2. View the results, then try it again using a
scale of 0 (zero).
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Part 17: Multi-frame Grid Plots

Multi-Frame Grid Plots
Up to now, all the grid examples have utilized a single frame. In this exercise you will learn how to
create a page containing multiple grid plots.

The Multi-Frame Options Dialog

If you worked through the chapters on XY plots,
you should already be familiar with the multi-
frame options. However, there are a few new
things to learn when creating multi-frames with
grid data.

 To bring up the dialog that controls the
multi-frame options, choose Options > Multi-
Frame Options from the menu, or press the
button on the sidebar. This will bring up the
following dialog:

Change the Frame Mode to Multi, as shown here.
Make sure the other settings are also as shown,
and then select  Close .

Displaying Multiple Grid Views

If you have loaded the Chelan data set, the 2D Grid views for K plane 1 will look something like this.

114



You should have a total of four frames (two rows by two columns). All frames will contain the same
view and plane number, but a different variable will be displayed in each.

Try changing the time step, view plane, and plane number. You’ll see all four frames update
simultaneously.

Changing Variables In Multi-Frame Views

Your initial multi-frame grid plot will put the currently selected variable in the first frame, and each
subsequent frame will display the next variable in the list. This is a useful default, but is easily
changed.

To select a new variable for a specific frame, first make the frame active by clicking anywhere within
it. Then, choose the variable to be shown in that frame from the sidebar. The affected frame should be
instantly updated to reflect the new values. You can do this for each frame in turn.

Frame Linking
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You can control whether a change made to one frame will be made just in
that frame or in all frames of a multi-frame plot. The choices are made
using the toggles in the Multi-Frame dialog.

Link Grid View - Rotation

While multiple frames are displayed, use any of the techniques you learned in Loading The Grid to
change the view in one of the frames. You may rotate a 3D view, zoom in, or translate.

Right now, you any change made to one frame is made in all the others simultaneously. This happens
because the Link Grid Views toggle in the Multi-Frames dialog was turned on. This setting instructs
Tecplot RS to make sure all frames have matching views.

You can return to the Multi-Frames dialog and turn off the toggle. When view linking is off, you can
click on each frame in turn and set a different view:
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Link Layer Toggles

Layer Toggles include the Mesh, Contour, Connect (which turns on/off the lines connecting well nodes),
Shade, Translucency, and Light options at the top of the grid sidebars, and the Lines and Symbols
toggles in the XY plot sidebars. When linked, any change to these toggles will affect all frames. Turn off
the link to set these options independently for each frame.

Link Well Toggle

When turned off, well geometries in grid plots will be displayed only in the first frame. When on, wells
will be displayed in all frames. Unlike the layer toggles, well display cannot change from frame to
frame. This option simply lets you control whether wells are shown in one frame or all.

Link Inside Views - Blanking

Inside Views and Value Blanking are ways to view and explore the interior of your grid model. These
are covered in Advanced Grid Plots. This option in the Multi-Frame Options dialog control whether
those views are shown in only the first frame or in all frames.

Special Purpose Multi-Frame Plots

Tecplot RS also has two other 'special purpose' multi-frame grid plots.

Dual Porosity Views

Some grid models contain dual-porosity data, which have two sets of solution variables for a single
grid model - one set for the matrix grid and another set for fracture values. Using the Grid Options
dialog (accessible from a button on the side bar), you can choose to display the values for either the
fracture or matrix.

You can also choose a "Both"
view. In this case, the selections
in the Multi-Frame Options
dialog are overridden, and
Tecplot RS will display two
frames - one for matrix and one
for fracture values.

All selections for variables,
styles, and display options are
also linked, again overriding the
toggles in the Multi-Frames
dialog.
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This option is available only when the active grid contains dual porosity data.

Side-By-Side Grid Comparisons

Tecplot RS also allows you to create side-by-side frames that will compare two or more data sets. This
feature is covered in Grid Comparison Plots. For these plots, the number of frames is dependent on the
number of data sets selected for comparison, ignoring the rows/columns selections in the Multi-Frame
dialog.
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Part 18: Advanced Grid Plots

Advanced Grid Plots

 In preparation for the exercises in this chapter you will use the quinaultlgr data set. If you are
using the project file created in Setting Axis Ranges and Scales, the file is already loaded and you
simply need to set it as the active data set using the Manage Data dialog.

If you neglected to create a project file, simply repeat the steps in Setting Axis Ranges and Scales and
create it now. However, this time be sure to make quinaultlgr the active data set.

1. After loading/selecting the grid file, select Plot Type > 2D Grid.

2. Open the multi-frame dialog, and:

◦ Select Multi Frames

◦ Choose 2 columns and 1 row

◦ Turn ON both the view and value blanking linking toggles

3. Set the View Plane to K - XY Axes.

4. Highlight plane 1 in the plane number dialogs.

5. Click on each frame and select SOIL (Oil Saturation) as the variable. (You’ll need to do this for both
frames).

6. Advance the time slider to the approximate middle of the scale.

7. Click on the  Grid Options  button and make sure your settings look like this, then close the dialog:
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At this point your screen should look something like this:

You’re ready to begin.

2D Plane In 3D View

2D Plane in 3D View is a toggle on the 2D Grid Plot
Controls sidebar. Turn it on now, and your plot
should change to this:

You now have 2 views of the same plane - one viewed "head-on", and the other in 3D! If your 3D view is
cut off on the edges, use the middle mouse button to zoom out a little.
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In the first list box with plane
numbers, select plane #2 either
by highlighting it or by pressing
the Next button. 

With the Quick 3D view, it’s easy to see where the selected plane falls in the grid area. Select each K
plane in turn and watch how things change in the sidebar and on the plot.
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

The last frame of a multi-frame view always becomes the Quick 3D frame, no matter
how many plot frames are shown. If you are in single-frame mode, then your current
2D view will be switched to 3D. It will switch back to 2D mode when you turn off the
Quick 3D toggle.

LGRs

Our sample grid contains LGRs (Local Grid Refinements), and as you stepped through the planes you
may have noticed that the second list box and LGR drop-list options changed when you made
selections in the first.

The planes selected in the larger list box are those of the global grid. If the selected plane intersects an
LGR, then the other controls will reflect which LGRs are intersected and which planes are available in
those LGRs.
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For example, start by selecting K plane #1. Then
click on the drop-down list on the right to expand
it.

The LGR drop list now shows three LGR names:
B_INJ, C_INJ, and B_PROD. These are all the LGRs
that are intersected by K plane 1.

C_INJ is slightly indented under B_INJ. This
indicates that C_INJ is a sub-grid of B_INJ. In other
words, C_INJ is a child grid and B_INJ is the
parent. B_INJ and B_PROD are both children of the
parent global grid.

If needed, choose the B_INJ option and notice that the second list box contains numbers from 1 to 6,
indicating that the B_INJ LGR contains six K planes. Plane #1 is highlighted, so this is the one that
appears on the plot.

Change the highlight in the smaller list box to "2", and note how your plot changes:

The changes in the 2D view are subtle, but in the Quick 3D view it’s easy to see that we are viewing a
different plane in the LGR. You can also see how the planes from the main grid line up with the LGR
plane.
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If you choose plane 2 in the larger list box, the LGR plane will sync to plane 3. Choosing plane 3 in the
global grid will show plane 5 in the LGR, although you can again choose a different LGR plane.

Selections made to the parent grid will always choose the closest plane in the child. By default,
the child LGR planes can be selected independently of the parent. However, you can change
this using the Lock button.

Click on the lock button  to engage it, then select successive planes in the child grid. You’ll notice
that the parent grid plane now follows the selections in the child.



The intersecting planes are determined by relative indices, not by coordinate values.
If your grid is irregular, the program may not choose the "correct" intersecting LGR
plane. However, the Quick 3D view will make it easy to see, and you can choose any of
the available planes using the list box.

Using these controls you can view any 2D plane in any I, J, or K orientation. The Quick 3D view is not
required, but can be helpful to determine spatial relationships, especially when there are LGRs.

Inside Views

The Quick 3D view effectively shows a slice of your model in 3D space. However, the primary purpose
of Quick 3D is to make it easier to identify which 2D plane you are viewing, especially when LGRs are
involved. However, there are many additional tools for looking 'inside' your grid.

For this exercise, first return to the Multi-Frame options and switch the Frame Mode back to
Single Frame. After closing that dialog, change the Plot Type to 3D Grid.

IJK Slices

The 3D Grid sidebar contains a group of controls labeled "Inside
Views". Change the settings on your sidebar to match what is
shown here, and also press the  Clear All  button. You’ll notice
some similarity to the controls you used in the previous exercise.
There’s an option list for choosing which grid/LGR, an option list
for the plane (I, J, or K), and a list box with plane numbers that
correspond to the selected grid and view plane.

Your plot should show a translucent box that represents the grid boundary: Now do the following:

1. With Grid = GLOBAL, Plane = I, highlight planes 3 and 8 (HINT: Hold down the Ctrl  key in order to
select or unselect items in a list that are not consecutive).
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2. Change to Grid = B_INJ, Plane = J and highlight plane 4.

3. Change to Grid = C_PROD, Plane = K, and highlight 3.

If the Auto-Update toggle was checked, you should have seen each plane appear as you selected it. If
not, press the  Apply  button to see this plot:

With IJK Slices, you can choose any number of planes, in any direction, and for any grid/LGR. Unlike
the 2D Grid view, the LGR planes displayed here are independent of the plane selected in the parent
grid.

XYZ Slices
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XYZ Slices give you another option for looking at the interior of
your model. In this case, the slice position is determined purely by
coordinate value, and no selection of plane number or LGR is
needed.

Use the option menu to change the view type to XYZ Slice, then set
your controls as shown here.

Experiment by moving the sliders around, selecting a different
X/Y/Z direction, and changing the number of slices. You can also
use sidebar controls to change the value shown or the time step.

Arbitrary Slices
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Arbitrary slices give you yet another option for viewing
slices through your model. In this mode you can define the
endpoints of one or more vertical slices that can be oriented
in any direction.

A common application for this would be to view a slice
between wells. Since you choose the endpoints of the slice
using the mouse, you can create slices through any two
points.

Start by selecting the Arb Slice view type for Inside Views.
For this exercise you should start with the Show and Clip
toggles turned off as shown here. You should also turn on
the Wells display. If there are any items in the Slices list,
highlight them and hit  Delete… .

Your plot should look something like this:

To create an arbitrary slice:

First, select the type of slice from the following combo box options:

• Chain Creates a slice from two selected points. Each additional selected point will add another slice
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from the end of the previous one until the  Stop  button is selected or the right mouse button is
clicked.

• Radial Creates a slice from two selected points. Each additional selected point will add a slice using
the first point as the anchor. This operation continues until the  Stop  button is selected or the right
mouse button is clicked.

• Pairs Creates a slice from two selected points. Each additional selected point will begin the start of
another two point pair until the  Stop  button is selected or the right mouse button is clicked.

Next, do the following to create your arbitrary slice:

1. Click the  Start  button to begin creating your arbitrary slice based on the definition you selected.
This will switch the pointer tool into a mode for interactively selecting points.

2. Click the top surface of the grid (not the sides) to add a point or points for your slice to pass
through. Ctrl  +  Left-Click  for your slice to pass through the nearest well. Right-Click  the pointer to
end the selection process. You can add a new slice sequence by clicking the  Start  button again.
The point(s) and well(s) you have selected will appear in the Slices box. Points will be labeled P1 to
Pn, and any wells you have selected will be labeled with their name. Locations clicked will display
a small + mark:

3. Use the check boxes next to the points to toggle the selected slice. You can also highlight the slices
then Right-Click  to toggle them on or off by selecting the Turn On or Turn Off menu items. Slices
can also be deleted by being highlighted and then selecting the Delete menu item. Optionally,
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Toggle-on Clip to end the slice at the cell containing the endpoint. Toggle-off Clip to extend the slice
to the edge of the grid.

4. Toggle-on Show to incorporate your selections in your plot.

5. Toggle-on "Independent slice frames" to switch to a view which displays each enabled slice in it’s
own frame in addition to a reference frame (upper left) which shows all slices. Individual slices in
each frame are rotated such that the slice normal vector is pointed directly at the camera. That is,
the slice view is "flattened" similar to a 2D view. When selecting an individual slice frame, the
frame is highlighted, and the slice is highlighted in the reference frame view. You can also click on a
slice in the reference frame to highlight the individual frame which contains the selected slice.


When "Independent Slice Frames" are active, the plot view cannot be changed to
Multi-Frame.

See below for an example of two arbitrary slices.

Additional Inside Views

There are several more Inside View options that you can use to explore the interior of your model:
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IJK Blank

Similar to IJK Slicing, but instead of selecting individual slices you choose a range of planes in the I,
J, and/or K directions.

Well Blank

View the cells containing well completions. Choose which wells you want to show.

Iso Surfaces

Create surfaces along a constant variable value, such as where water saturation is equal to .5.

LGRs

Turn on/off the display of LGRs so that each can be viewed independently.

Streamlines

Load and display streamline data output in the Frontsim format.

NNCs

Display Non-Neighbor Connection faces (Eclipse/SLB files only) and flood with special NNC
variables.

Faults

Display cell faces along fault lines as defined by user input constraints, in the grid file, or NNC
definitions.

Grid Data Equations

Data equations are used to compute new variables from existing grid values. You can create a single
new variable or several. New variables appear in the list and can be selected for contouring. If the new
values are computed from time-dependent data, they will be updated as the time step changes.

Although equations can be much more complex than this, a basic equation might appear as:

    {newvar} = {existvar1} <operator> {existvar2}

... where <operator> includes (but is not limited to) standard operators such as +, -, /, and *.

For example:

    {RATIO} = {SWAT} / {SOIL}

The new variable is named "RATIO" and is defined as the ratio of water to oil saturation. Both new and
existing variable names are always surrounded by curly brackets { }.
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
If Tecplot RS detects that the variable used as the divisor has a range of values that
include zero, it will not accept the equation because of the potential for divide by 0
errors.

You can also include constants in your calculations, such as:

    {SGAS} = 1.0 - {SOIL} - {SWAT}

The capabilities of equations go far beyond these simple examples. A complete description of equations
can be found in Equation Reference in the Tecplot RS User’s Manual.

Although the instructions in the manual show the use of variable numbers to define equations (e.g.,
"V3" instead of "{SOIL}"), we recommend using explicit variable names for reservoir plots. This will
help avoid errors and will also make your equations generic so that they can be used with different
projects.

For this exercise, start by bringing up the dialog using either Data > Grid Equations from the
RS top level menu or the  Equation  button on the toolbar.

Start by double-clicking the [NEW] line at the top of the list. The entry field will then display:

{VARNAME1}=

You may edit the variable name to be something else, such as "MYVAR", and then make sure to move
the cursor back to the end of the line.

{MYVAR} = {SOIL} * {GROSS}
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Be sure that you have curly braces around each variable name. For variables that already exist, the
best way to do this is to select the variables by double-clicking on them in the list: it’s not only faster, it
prevents typos. You can use the mouse or keyboard to enter the multiplication symbol, *, and the
assignment operator, =.

Press the Enter  key on your keyboard or click the  Enter  button on the dialog to record the equation,
which will put it in the list of variables at the top. Once there, the  Test  button can be used to make
sure you have a valid equation.

Close the dialog, then look at the variable list in the sidebar. MYVAR should appear at the end of the list
(you may need to scroll down). Select it and the plot will be contoured with the new values. Change the
slider to see it updated for different times. You can use this variable as you would any other in the list.

Equations will be saved in your project file and will be automatically applied the next time you load
the project. Equation variables always appear at the end of the variable list.

Value Blanking

Value Blanking is a powerful tool that lets you turn on or off individual drawing elements (usually
cells) according to the values of selected constraint variables.

The best way to understand value blanking is to see it in action. For this exercise, load the
quinaultlgr.grid file and set the frame mode to Single Frame. Select the 3D Grid plot type, and make
sure Inside Views are turned off. Choose the variable SOIL and move the time slider to the starting
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position.

The dialog shown below is accessed either by pressing the Value Blanking button on the
toolbar, or by choosing Data > Cell Blanking from the menu. Make sure the Value tab is active.

Start by turning on the toggle to "Include Value Blanking".

Next, change the settings for constraint #1 to those shown here.

With these settings, you are asking Tecplot RS to display only those
grid cells that have an oil saturation in excess of 0.5.

Finally, press the  Apply  button.

There’s no immediate change to your plot, because all the oil saturation values are greater than 0.5 at
the first time step. However, advance the slider to about the middle of the range and your plot will look
like this:
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The oil saturation is decreasing in the corner where the injector well is located. When the saturation
drops below the .5 limit, the cell is blanked.

It is not necessary to display the same variable that is used for the blanking criterion. Try changing the

display variable to Pressure and then press  to animate the time sequence. Now you can watch the
pressures change in cells where the oil saturation is high.

You can enter multiple constraints for value blanking, and you can also test against other variables as
well as constants.

Value blanking can also be applied on 2D grids.

Value Blanking In Multi-Frame Plots
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Remember that the Multi-Frame dialog also has a toggle related to
value blanking: Link Inside Views / Blanking.

If left unchecked, value blanking and inside views are applied to
only the first frame of a multi-frame plot.

If you want all your frames to show the same views, remember to
turn on this toggle.

Note that many Inside Views are simply specialized applications of blanking. Value Blanking, IJK Slices,
IJK Blanking, and Well Blanking all make it possible to explore the interior of your grid model by
blanking the cells you are not interested in seeing. Blanked cells are also useful when doing
computations, as you’ll see in the next exercises

Data Integration

Integration can be found using the Integration dialog, which is accessed using either Analyze >
Integration from the menu, or the button on the toolbar.

This function will create a report showing values computed from the grid cells. For any given variable
the program will display minimum and maximum values, the sum of all values, and the average for
the selected cells.

The variable being calculated is selected on the sidebar - it is the same one that is currently displayed
on the grid. The sidebar also controls the time at which values are computed for transient variables.

You can also apply a volume value. For example, if the GROSS value represents the cell volume,
applying this will give you a second set of values for the product of SOIL * GROSS.
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The cells used to compute these values can be limited according to the Value Blanking criteria. Visible
Cells is the default criterion, meaning that the results will reflect only the cells that you can see on the
screen.

For this exercise, try turning on and off the Value Blanking from the preceding exercise and note the
difference in the number of cells and the totals for each. You can also try this while displaying Inside
Views or 2D Grid plots. The latter is a way you might limit the calculations to only those cells in a single
K plane, for example.

Another option is the ability to bin the results by another variable. For example, you can see how the
cell depth affects the oil saturation:

Quick Plots
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Tecplot RS offers a variety of "Quick Plots". Quick
plots utilize one or more separate, smaller frames
that 'borrow' some space from the main plot
frames. The amount of space that will be occupied
by the quick plots, and their position is
determined by settings in the "Multi-Frame"
dialog. For this exercise, set the options as shown
here.

Histograms

 Your first quick plot will be a histogram that
shows the number and distribution of values in
the grid plot. You can use either the button from
the toolbar or the menu (Analyze > Histogram) to
bring up this dialog (Note that you must be
showing either a 2D or 3D grid plot in order to
choose this option). You can also check the "Stats"
toggle on the top of the sidebar.

Start by setting the options as shown here. On the
main sidebar, choose the variable and time step
that you would like to see. The histogram should
update immediately to reflect your selections.

For example, the histogram plot below shows oil saturation on the last time step of our sample file.
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Try animating your plot over time. The histogram plot will animate along with the grid plot.

As with integrations, you can limit which cells are included in the histogram. Change the Limits option
to "Visible Cells", and change your grid plot to use either Value Blanking or one of the inside views that
show whole cells (IJK Slices, IJK Blanking, or Well Blanking). Note that the title of the histogram frame
indicates how many total cells were found.

The histogram dialog also gives you options for controlling the number of bins, the amount of data in
the header, and how the data ranges are determined. Experiment with each of these to see how they
impact the plot.

Time/History Cell Plots
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The next quick plot you’ll look at is accessed by
checking the Time/history toggle on the sidebar. It
is found just under the toggles for Mesh, Contour,
etc.

You need to ensure that the variable selected for
display is a transient (time-dependent) value. In
the Quinault LGR sample data, the first four
variables (plus the computed "MYVAR" values we
calculated a few pages ago) are transient.

As soon as the Time/history toggle is checked your mouse pointer will change from an arrow to a
crosshair. This is your cue to click on the cell for which you want a Time/history plot. Once chosen your
plot should be immediately updated an should look something like this:

This plot shows the oil saturation values for a single cell over for time steps. If you change the variable
or click a different cell, the Time/history frame updates to reflect the new selection.
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Part 19: Combo Plots

Combo Plots
Combo Plots are those where grid plots can be combined with other data types. The combo data may
include XY files from simulator or observed data files, RFT data, and streamline data files. In general,
these data are in a file separate from the grid file and must be loaded independently. For this exercise,
both the needed files (guinaultlgr.grid and quinaultlgr-xyp.unsmry) should already be part of your
Project File.

In some cases, the auxiliary data are shown in a separate frame alongside the grid plot, as you saw
with the Time/history Cell Plot in the preceding chapter. In other cases, the display is integrated into
the grid plot.

Time/History Well Plots

You’ve already used the time/history toggle to do the cell plot. Now you’ll see another plot that can be
placed in the same frame.

When the Time/history frame is active, the mouse
pointer is in "probe" mode as indicated by the
cross hairs. This time, instead of simply clicking
on a cell, select the well selection crosshair option.

Then select the well at the producer. The best
place to click is on the well symbol - the black
circle at the top of the well geometry. If needed,
turn on the wells display using the toggle on the
sidebar.

This time, the quick frame should display the plot from the XY file. It will be identical to the plot you
would get using the XY Variables plot type. In fact, you control the variables that are plotted using that
function, so if you don’t see the variable(s) you want, simply switch to that plot type and make the
desired selection.

Bubble Plots
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Bubble plots also show data from the XY file, but
instead of using a separate frame the values are
shown right on the grid. This time, they are
formatted as "bubbles" on the well head.

For this exercise, first turn off the Time/history
plot to give you a better view of the main grid.
Turn on the toggles for both Wells and Bubbles
(note that you must have both grid and XY data
loaded in order to turn on the Bubbles toggle).
Click on the  …  button next to the Bubbles
toggle to bring up this dialog, and change the
settings to match these.

Once the settings are as shown, you can either hit
Apply Changes  or turn on the Auto-Apply check
box.

With the bubbles displayed, move the slider or
press the  Play  button to animate the time steps.
You’ll see the bubbles change to reflect the values
at each time step.

There are many additional options for displaying
bubble plots. Refer to the User Manual for full
instructions.

Click the  button to update your project file with the bubble styles. The next time you display
bubbles with this project, you won’t have to repeat the style selections.
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Streamlines

Tecplot RS will display streamline data in 3D Plot views, providing a look at how fluids move through
the reservoir model over time. In most cases, streamline data are stored separately from the grid file
but they will be associated with it. For this exercise, you’ll create a new project using grid and
streamline files from the examples folder.

 The first step is to create a new project, either by clicking on the button in the toolbar or by
selecting Project > New from the menu. If you have an existing project open, you should generally
elect to save your changes unless you’ve made specific alterations that you don’t want to save.

 The files for this exercise are found in a folder named "streamlines" that is a sub-folder to
examples where all other data have been located. The file is named exercise1_nk.grid. After browsing to
and choosing that file, you’ll see these options:
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When you select the grid file, the solution data should be filled in for you automatically. Note that there
is a separate field for choosing the streamline file underneath the solution data file list. Since the
streamline file had the same base name as the grid file, it was found automatically. The  …  browse
button can be used to load streamlines that are named differently.

Once the data have been loaded
you should select the 3D Grid plot
type, if needed. Then, choose
Streamlines in the Inside View
type and set the options as
shown.

You will also need to advance the
time slider at least one step past
the first time (streams rarely
exist at the first time step).

143



As with any Tecplot RS plot, you have control over which data to show and how to display it. The
display options are part of the Streamlines Inside View sidebar.

Note that after making changes you may need to click on the  Apply  button to update the plot.

Time Slider

Streamlines data are computed and recorded at different start times. These times are linked to the grid
time slider. You can move the slider to a new position to see the stream simulation at that time, and
you can even animate the progression. If stream times do not exactly match the grid times, the display
will show the nearest stream on or before the selected grid time.

Select By

When this option is first launched, the Select By option defaults to "All", meaning all streamlines are
flagged for display. You may change this in order to limit the streams that are viewed. You can choose
the streams according to their Source (usually the injector well), Sink (a boundary or producer well), or
by individual Pairs.

When you choose a new Select By option, the multi-select list to the right is cleared and repopulated
with the available source, sink, or pair identifiers. You can then elect which ones to display by
highlighting your choices in the list.

The example file contains a single source (the injector well), two sinks (the producer wells), and thus
two pairs. Feel free to experiment with different selections.

Color By

Use this option to control how streams are colored. Your choices include:

• Source: The program will cycle through eight colors, using a different one for each source or
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injector well.

• Sink: Streamline color will be determined by the termination well or boundary.

• Pair: Each well pair will be plotted in a different color (cycling through the 8 available colors).

• Variable: The streams will be multi-colored, according to the variable values assigned to each
stream node or segment. If multiple variables are included, you may choose which one from the
Variable option menu. If you are using one of the supplied paper layout templates, a separate
legend should appear for the streamline variable.

• Time of Flight: Streams may be colored according to the Time of Flight value associated with each
node.

Skip

The Skip interval is used to reduce the number of streamlines displayed, and is especially helpful when
there are so many streams that plotting all of them makes it impossible to see details. The skip factor
defaults to 2 (plot every other stream), but you may select a value from 1 to 100. Regardless of the skip
factor, the program always plots at least one stream between each selected well pair.

Time of Flight

This slider makes is possible to visualize the progress of streams over time. The slider is scaled over the
full range of Time of Flight (TOF) values for the selected streams. If you position it at an intermediate
point, partial streamlines are drawn according to that limit.

Use Log Scale

It is not unusual for a very small percentage of the streamlines to have a much longer TOF than the
rest. This can skew the TOF range so that most of the progress occurs at the very bottom of the scale. In
these cases, there is little difference in shading when coloring by Time of Flight, and you often lack
enough fineness in the scale slider to control the display.

This can be corrected using the Log Scale option, which will apply a logarithmic scale over the TOF
range. This will impact both the color bands used when streams are colored by Time of Flight, and will
make the scale bar usable for these cases.
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Part 20: Grid Comparison Plots

Grid Comparison Plots
In Comparing XY Data Sets you saw how you can create comparison XY plots using two or more files.
This time you’ll see how to do side-by-side comparisons of grid data.

You’ll use a new set of files for this exercise, so start by choosing the  New Project  tool button
or menu option.

The new files can be found in the Examples folder
of your Tecplot RS installation under a sub-folder
named comparisons. You’ll need load three
different grid files and their associated solution
data files (.init and .unrst… files). The files are in
Eclipse/SLB format, and the file names are spe9a,
spe9b, and spe9c. The solution files should be
filled in automatically once you choose the grid
file.

 If you open the Manage Data dialog, you
should see that you have three grids loaded with
spe9a as the active data set.

Once all three files are loaded, choose the 3D Grid plot type and select the PRESSURE variable. Move
the time slider all the way to the right to display the last time step:
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Finally, at the bottom of the sidebar in the area
marked "Data Set", turn on the  Compare  toggle.
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A new dialog, Compare Grid Data, is displayed.
When you asked Tecplot RS to create a
comparison plot, it selected the second file by
default but it also automatically launched the
Compare Grid options dialog so that you could
change that selection if desired.

You can also launch this dialog by clicking on the
Options  button next to the Compare toggle.

To compare all three files at once, highlight both
spe9b and spe9c in the selection list.

Note that the active file is also included in the list
and identified as such. Although it is possible to
select it, this would result in comparing the file to
itself, so you should normally leave it unselected.

However, there’s also a separate control for choosing the active data set. This allows you to change the
master data set to which all other grids are compared. When doing grid comparisons, it’s best to use
this dialog to choose the active data set (instead of the Manage Data dialog) since it is smarter about
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'swapping' between other comparison grids.

Now all three grids are shown:

Although they look the same, you’re actually viewing three different data sets. Selections you make on
the sidebar will be applied to all. Try rotating the view or changing the variable, time step, or display
toggles. You should see all three frames update accordingly.

The number of frames shown is controlled by the number of data sets being compared - the settings in
the Multi-Frame dialog are not used here. Other settings in that dialog are also overridden; for
example, turning on the Wells display will always show wells on all frames even if well linking is
turned off.

The data sets shown here represent three separate simulator runs with slight variations in the input
parameters. It’s difficult to see the differences, since the values don’t vary much. If we change the
display to show the delta (difference) values instead, the differences will become clearer.

Start by choosing the SGAS variable, and then toggle on the  Show Deltas  toggle. This toggle is found
on both the Compare Grid Data options dialog and on the sidebar. Your display will now show
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something like this, and it’s much easier to see where differences exist. Your image may not match
exactly since we’ve rotated and zoomed in a bit, but you can do the same.

Note that the first frame shows the raw values from the active data set. The other two frames show the
delta values - the value from the active set minus the value for the same cell in the comparison data
set, and the frame title reflects this. You’ll also see that the legends on the smaller frames span a
narrower range of values, both positive and negative, with 0 at the center. This makes the differences
much easier to identify.

These sample data sets were all created from the same simulator. That isn’t always the case in real life -
you may wish to do comparisons for solutions from different simulators. In those situations the data
may not align as well as these do. For example:

• The grid dimensions may not match or the coordinate system may be different.

• The simulators may use different names for the same value.

• The time steps may not span the same range or be on the exact same dates.

Tecplot RS handles these situations as follows:
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• If the grid origins or coordinate units are different, the views won’t be linked. You’ll simply have to
do rotations and zooms on each frame separately.

• If the grid IJK dimensions or number of cells is different, you won’t be able to calculate delta values
but you’ll still be able to do side- by-side displays. 2D Grid plots and inside views that reference IJK
planes will work up to the limits of the planes in each grid. For example, if you select K plane 18 in
the active grid and the comparison grid has only 15 K layers, nothing will be shown in the
comparison frame, but selecting K plane 12 will show data in both frames.

• If the variable names are different you can define aliases, just as you did for XY plots (see chapter 9
of this tutorial). After defining an alias for a variable that is already selected for display, you may
need to switch to a different variable and then back again in order for the new alias to be
recognized.

• If the times are not a match, Tecplot RS will find the date closest to the one selected. The frame title
will reflect what was used.

In Conclusion

We hope you have found this tutorial to be helpful for getting started with Tecplot RS. You should now
have a solid foundation for navigating the program and creating the various plots. There are many
more features, including macros, pick blanking, history matching, cross plots, and templates, to name a
few. Now that you are familiar with the basic operation, you should feel comfortable exploring these
other options.

There are many additional resources for learning the program. Help buttons exist on almost all dialogs
and from the top level menu. The User’s Manual provides detail on all options. Our online Knowledge
Base has answers for many frequently asked questions, and the Tecplot Talk user forum lets you
communicate with other users of the product. Finally, customers with an active TecPLUS subscription
may contact support for assistance.

Thank you for choosing Tecplot RS!
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