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Part 1: Introduction to Tecplot Focus

Introduction
Tecplot Focus is a powerful tool for visualizing a wide range of technical data. It offers line plotting, 2D
and 3D surface plots in a variety of formats, and 3D volumetric visualization.

The user documentation for Tecplot Focus includes these resources:

User’s Manual (this document)

This manual provides a complete description of working with Tecplot Focus features.

Scripting Guide

This guide provides Tecplot macro command syntax and information on working with macro files
and commands.

Quick Reference Guide

This guide provides a handy reference for dynamic text, macro variables, keyboard shortcuts,
special characters, and more.

Data Format Guide

This guide provides information on outputting simulator data to Tecplot Focus file format.

Installation Guide

These instructions give a detailed description of how to install Tecplot Focus on your system.

Release Notes

These notes provide information about new and/or updated Tecplot Focus features.

Welcome Screen

When you start Tecplot Focus, the Welcome Screen, shown below, appears. You can also open it at any
time (even while working on a plot in Tecplot Focus) by choosing View→Welcome Screen.
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The Welcome Screen contains links that help you quickly get started working with your data and
Tecplot Focus.

• Across the top are links for creating a new layout and for opening existing layouts and data files.

• The left section provides a list of layouts you have recently worked with.

• The right column contains links to documentation and other resources to help you get the most out
of Tecplot Focus.

• At the very bottom of the right column is information for contacting Technical Support, including
the version and platform information you will need for a support incident.

The Welcome Screen automatically disappears when you open a layout or create a new one. You may
also close it manually by clicking the red X button in the upper right corner; this returns you to your
existing layout if you have chosen View→Welcome Screen while you were working with a plot.

Input Devices

Tecplot Focus supports the following input devices:

Standard mouse

Used for pointing at, selecting, and manipulating objects in the workspace; changing the view;
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choosing fields and manipulating controls in dialogs and sidebars; and performing actions or
commands using the toolbar or menus. Most mice have multiple buttons and a scroll wheel, which
provide quick access to specific functions.

Keyboard

Used for entering data and text and for activating commands using menu shortcuts. In conjunction
with a mouse, can be used to switch modes when clicking or dragging.

3D mouse

A secondary input device that allows 3D Cartesian plots to be zoomed, translated, and rotated with a
touch. Additionally, the always-active 3D mouse doesn’t make you select mouse modes, commands,
or keyboard shortcuts. A 3D mouse can therefore enable faster exploration of your data and
improve the experience of working with your 3D plots.


Tecplot Focus supports 3D mouse products from 3Dconnexion, such as the
SpaceMouse, SpaceNavigator, and SpacePilot lines, and only on the Windows
platform.

Actions available with a 3D mouse include:

Translation

Push the mouse cap left or right, pull it up, or push it down, to translate the plot left/right or
up/down on the screen.

Zooming

Push the mouse cap toward you or away from you to zoom the plot. Hold down the Alt key while
zooming to switch zoom methods.

The default zoom method depends on whether the current frame’s 3D view mode is perspective or
orthographic (see Three-dimensional View Details). The results of zooming using the 3D mouse and
the Alt key are shown here.

Pushing or pulling mouse cap In perspective mode In orthographic mode

Normal (without Alt key) Changes view distance Changes view width

Alternate (pressing Alt key) Changes view width Changes view distance

Rotation

Rotation is around the defined center of rotation, by default the center of the data. However, the
axis of rotation is relative to the screen rather than to the data.

X axis

Tilt the mouse cap forward or back to rotate around the screen’s X axis, as if rolling your plot
toward you or away from you.
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Y axis

Twist the mouse cap clockwise or counterclockwise to rotate around the screen’s Y axis, as if on a
lazy susan.

Z axis

Tilt the mouse cap left or right to rotate around the screen’s Z axis, like the hands of a clock.

With practice, it is possible to perform more than one of these operations at the same time. At first,
though, it is best to be careful to invoke only one function at a time.

Most 3D mice also have one or more buttons, which can be mapped to commands that you use
frequently using the software provided with the device.



An area of interest can be inspected in greater detail from any angle if the origin of
rotation is assigned to it. Mapping the "o" key (orientation change) to a 3D mouse via
the device GUI may facilitate a more natural workflow. Simply point the regular
mouse cursor at the area of interest and press the orientation change button.

Tecplot Focus supports the following actions (built-in to the 3D mouse software) that may be mapped to
buttons using the device software:

• Fit (same as View→Fit Surfaces)

• Front, Back, Top, Bottom, Left, and Right View

• Isometric View 1 (Tecplot Focus default view) and 2 (theta 180° from default)

• Roll CW and CCW (in 90° increments)

Interface

Five major sections make up the Tecplot Focus interface.
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Menu Bar

The menu bar offers access to Tecplot Focus features.

Tecplot Focus’s features are organized into the following menus:

File

Use the File menu to read or write data files and plot layouts, and print and export plots.

Edit

Use the Edit menu to select, undo, cut, copy, paste, and delete objects, and to change the draw order
for selected items.


Generally, Cut, Copy, and Paste of items other than text work only within Tecplot
Focus. You can, however, copy an image of a selected frame or the text of a selected
text object to the clipboard. See Clipboard Exporting to Other Applications.
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View

Use the View menu to manipulate the way your data is shown or to open a sidebar or the Welcome
Screen. See View Modification.

Plot

Use the Plot menu to control the style of your plots. The menu items available depend on the active
plot type (chosen in the Plot sidebar).

Insert

Use the Insert menu to add text and geometries (polylines, squares, rectangles, circles, and ellipses).
If you have a 3D zone, you may also use the Insert menu to insert a slice. If the plot type is set to 2D
or 3D Cartesian, you may insert a streamtrace.

Animate

Use the Animate menu to create animations of your plot.

Data

Use the Data menu to create, manipulate, and examine data. Types of data manipulation available
in Tecplot Focus include zone creation, interpolation, triangulation, and creation or alteration of
variables.

Frame

Use the Frame menu to create, edit, and control frames.

Options

Use the Options menu to control your Tecplot Focus experience, including rulers, grids, and
performance.

Scripting

Use the Scripting menu to play or record macros, and to access the Quick Macros Panel.

Tools

Use the Tools menu to launch an add-on.

Analyze

*[This feature is only available in Tecplot 360]* Use the Analyze menu to examine grid quality,
perform integrations, generate particle paths, extract flow features, and estimate numerical errors.

Help

Get help for Tecplot Focus features, or view the About dialog, which contains version and platform
information.

Context Menu and Toolbar

In many places within Tecplot Focus, clicking with the right mouse button displays a context menu that
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gives you quick access to just the operations most relevant to what you’re clicking. Often, these
operations are also available in some other way, such as using a toolbar button, the pull-down menus,
or a dialog.

In the Tecplot Focus workspace, the following objects have context menus with the specified functions:

Frames

Change frame order, load and save frame style, frame details

Axis

Axis settings

Slices

Hide, edit slice details, extract slices, slice style

Iso-surfaces

Hide, choose variable, edit iso-surface details, extract surfaces, change iso-surface style

Zones

Hide, deactivate, zone style

Streamtraces

Extract, delete, streamtrace settings

3D orientation axis

Hide axis, axis settings

Line maps

Deactivate, copy, change curve type, mapping style, Fourier transform (when applicable), show
curve details on plot; write curve details or data to file

Legends

Hide, change box type, legend settings

Geometries (shapes)

Change line and fill color, delete, edit geometry settings. For polylines, you may also extract data
along the line.

Text

Change color, cut, copy, delete, align(left, right, center, top, bottom), text settings.

When working with zones, slices, and iso-surfaces, a context toolbar appears above the context menu.
This toolbar allows you to turn on or off the grid, contour, vector, shade, edge, and translucency layers
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for the selected object(s) by clicking the icons. (Iso-surfaces do not have vector or edge layers.)
Additionally, you may adjust frequently-used style settings for each layer using the drop-down menu to
the right of each icon, for example selecting a color for the grid (or choosing a variable by which to
color it).

A different context toolbar appears when you right-click a line in XY or polar line plots. This toolbar
allows you to turn on or off the line, symbol, and error bars for the selected line map by clicking the
icons. You can also adjust the attributes of these (for example, line color, symbol shape, or error
variable) using drop-down menus to the right of each icon.

When a geometry object is right-clicked, the Geometry context menu appears. This menu allows you to
Cut, Copy, Delete the object as well as adjust the line and fill attributes. When multiple geometries are
selected, the Alignment of the objects can be adjusted as well.

Right-clicking on a Text object brings up the Text context menu. This menu allows you to Cut, Copy,
Delete the object as well as change the alignment or open the Text details dialog. You can also adjust
the text attributes such as bold, italics, color, and text angle.
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In some places, such as in the Mapping Style and Zone Style dialogs, right-clicking is the primary way
to alter the displayed data.



The right mouse button is also used for translating (moving) the plot. This doesn’t
conflict with its use for context menus. The context menu appears when you right-
click without moving the mouse; dragging with the right mouse button performs the
translation operation.

Sidebars

Tecplot Focus’s three main sidebars provide easy access to frequently-used functionality:

Plot Sidebar

Includes controls for manipulating the appearance of your plot.

Pages Sidebar

A list of the pages currently open, allowing you to switch between them, and to create, rename, and
delete pages.

Frames Sidebar

A list of the frames in the current page, allowing you to easily manage their order and other
characteristics.

Initially, the Plot and Pages sidebars appear "docked" on the left side of the workspace—attached to the
left side of the plot area. The Frames sidebar is initially hidden, but appears on the left side of the
workspace when enabled using the View menu.

Any visible sidebar may be moved to the right side of the workspace, or even dragged out of the
workspace entirely (for example, to move it to another display) by dragging its title bar.
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When more than one sidebar is docked to the same side of the workspace, they can be combined in
two ways:

Tabbed panels

Only one sidebar is visible at a time; tabs appear at the bottom of the sidebar are to choose which
sidebar you want to use. This is the default mode; the screen image in Interface shows how this
looks.

Sharing space vertically

Both sidebars are visible at the same time. You can drag the boundary between the two sidebars to
adjust the proportion of the space used by each.

Which style is used depends on where you dock the second sidebar: drag to the top or bottom of the
already-docked sidebar to split the area, or drag to the middle to combine them and use tabs to switch
between them.

Additional sidebars are available for certain other features throughout Tecplot Focus. For example, the
Quick Macro Panel is a sidebar that initially appears docked to the right side of the workspace. Like the
other sidebars, it may be "torn off" from the window or share space with another sidebar. The Probe
Sidebar is another; it displays the results of probe operations.

Any sidebar may be closed if it is in your way. To open it again, choose the desired sidebar from the
appropriate menu, or right-click any sidebar or the menu bar and choose the desired sidebar from the
context menu.

Sidebar Menu Command

Plot View→Plot sidebar

Pages View→Pages sidebar

Frames View→Frames sidebar

Probe Data→Probe sidebar

Quick Macro Panel Scripting→Quick Macros

Plot Sidebar

The controls available in the Plot sidebar depend on the plot type of the active frame. For 2D or 3D
Cartesian plot types, you can show or hide zone layers, and zone effects, and derived objects from your
plot. For line plots (XY and polar) you can show or hide mapping layers.

You can open the Plot sidebar from the View menu if it is not currently visible. To customize your plot,
simply:

• Select a plot type from the Plot Types drop-down menu.

• Use the toggle switches to add or subtract Map Layers/Zone Layers, or Zone Effects, or Derived
Objects. Use the Zone Style/Mapping Style dialogs to further customize your plot by showing or
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hiding zones in specific plot layers/mappings, changing the way a zone or group of zones is
displayed, or changing various plot settings.

Figure 1. The Plot sidebar as it appears for a 3D Cartesian plot (left) and XY Line plot (right).

Plot Types

The Plot Type, combined with a frame’s dataset, active layers, and their associated attributes, define a
plot. Each plot type represents one view of the data. There are five plot types available:
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3D Cartesian

3D plots of surfaces and volumes.

2D Cartesian

2D plots of surfaces, where the vertical and horizontal axis are both dependent variables (i.e.
 and , where  is another variable).

XY Line

Line plots of independent and dependent variables on a Cartesian grid. Typically the horizontal axis
(x) is the independent variable and the y-axis a dependent variable, .

Polar Line

Line plots of independent and dependent variables on a polar grid.

Sketch

Create plots without data such as drawings, flow charts, and viewgraphs.

Zone Layers

A layer is a way of representing a frame’s dataset. The complete plot is the sum of all the active layers,
axes, text, geometries, and other elements added to the data plotted in the layers. The six zone layers
for 2D and 3D Cartesian plot types are:

Mesh

A grid of lines connecting the data points within each zone.

Contour

Iso-valued lines, the region between these lines can be set to contour flooding.

Shade

Used to tint each zone with a solid color, or to add light-source shading to a 3D surface plot. Used in
conjunction with the Lighting zone effect you may set Paneled or Gouraud shading. Used in
conjunction with the Translucency zone effect, you may create a translucent surface for your plot.
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Vector

The direction and magnitude of vector quantities.

Edge

Zone edges and creases for ordered data and creases for finite element data.

Scatter

Symbols at the location of each data point.

Zone Style

Select the Zone Style button to launch the Zone Style dialog. The Zone Style dialog is used to
customize the zone layers that you have added to your plot. Refer to the chapter for each zone layer for
details on working with the Zone Style dialog.

Transient Controls

When working with transient data, simply press the Play  button in the Plot sidebar to animate
over time. The active frame will be animated from the Current Solution Time to the last time step. You
may also drag the slider to change the Current Solution Time of your plot.

The Animation Controls have the following functions:

Jumps to the Starting Value. (Keyboard: Home)

Jumps toward the Starting Value by one step. (Keyboard: Left arrow)

Runs the animation as specified by the 'Operation' field of the Time Details dialog. The Play button
becomes a Pause button while the animation is playing. (Keyboard: Space bar)

Jumps toward the Ending Value by one step. (Keyboard: Right arrow)

Jumps to the Ending Value. (Keyboard: End)

Use the  button to launch the Time Details dialog. See Time Aware for more information on Time
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controls and the Time Details dialog.

Derived Objects

For Cartesian plot types (2D and 3D): Toggle-on Iso-surfaces, Slices, or Streamtraces from the Plot
sidebar to add any or all of these elements to your plot. For convenience, the tool buttons for Slices and
Streamtraces also appear here. The Details dialogs for each of the derived objects can be accessed via
their respective buttons ( , , ). Refer to Iso-Surfaces, Slices, or Streamtraces for details on
working with these objects.

Zone Effects

For 3D Cartesian plot types, use the Plot sidebar to turn lighting and translucency on or off. Only
shaded and flooded contour surface plot types are affected. Refer to Shade Layer and Translucency for
additional information.

Map Layers

A layer is a way of representing a frame’s dataset. The complete plot is the sum of all the active layers,
axes, text, geometries, and other elements added to the data plotted in the layers.

The four XY Line map layers are:

Lines

Plots a pair of variables, X and Y, as a set of line segments or a fitted curve.

Symbols

A pair of variables, X and Y, as individual data points represented by a symbol you specify.

Bars

A pair of variables, X and Y, as a horizontal or vertical bar chart.
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Error Bars

Allows you to add error bars to your plot.

The two map layers for Polar Line are:

Lines

A pair of variables, X and Y, as a set of line segments or a fitted curve.

Symbols

A pair of variables, e.g. X and Y, as individual data points represented by a symbol you specify.

Select the Mapping Style button to launch the Mapping Style dialog. The Mapping Style dialog allows
you to customize the style settings for each of the plot layers and specify the points to plot. The pages of
the dialog are discussed in detail in XY and Polar Line Plots.

Snap Modes

Snap modes allow you to easily place objects at convenient reference points, either on the axis grid or
on the workspace paper. Most movable objects (including text, images, geometries, frames, axes,
legends, and the orientation axis) can be snapped. Data points in zones and line maps are also subject
to snap modes when being adjusted.

The snap controls in the Plot sidebar become available when such objects are selected using the
Selector  or the Adjustor  or, in the case of text and geometries, when they are being placed
initially using the appropriate tool.

None

No snapping is performed; objects may be positioned freely.

Snap to Grid

Constrain object movement to whole steps on the axis grid as defined in the Grid page of the Axis
Details dialog (Plot→Axis); see Axis Grid Options. This can be useful for aligning objects with points
of interest in a plot.

Snap to Paper

Constrain object movement to whole steps on the paper’s grid as defined in the Ruler/Grid dialog
(Options→Ruler/Grid); see Grid and Ruler Set-Up. This can be useful for positioning frames
precisely for printing, or for absolute positioning of text, geometries, and other plot elements.
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One or the other of the snap modes may be unavailable depending on the plot type or the kind of
object being moved. For example, a frame cannot be aligned to the grid because it contains the grid, so
the Grid snap mode is disabled when moving a frame.

Redraw Buttons

The redraw buttons allow you to keep your plot up to date: Clicking the middle mouse button redraws
the current active frame.

Auto Redraw

Use Auto Redraw

When selected, the plot will be automatically redrawn, whenever style or data changes. Some users
prefer to turn this option off while setting multiple style settings and then manually press the
Redraw or Redraw All button on the Plot sidebar to see a full plot.

 You can interrupt an auto-redraw at any time with a mouse click or key press.

Pages Sidebar

In Tecplot Focus, a page is a container for any number of frames, each of which is a container for a
plot. A layout can contain any number of pages (although many layouts contain only one). You can use
the Pages sidebar to see the pages in the current layout, to choose which page is displayed in the
workspace, and to create, rename, and delete pages.

The Pages sidebar may be opened from the View menu if it is not currently visible. In the Pages
sidebar, you may:

• Click Add to add a new page. The new page is initially named "Untitled."

• Click a page to view it in the workspace. Only one page is visible at a time.

• Double-click a page to specify or change its name. The name becomes editable in the sidebar;
simply type the new name, then press Enter.

• Click Delete to delete the active page.


The Cut, Copy, and Paste commands on the Edit menu can be used to move or copy
frames between pages. Click a frame border to select it, copy or cut it to the clipboard,
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then switch to the destination page using the Pages sidebar and paste it.

Frames Sidebar

The Frames sidebar allows you to manage the frames on the current page, including activating and
ordering them, which is particularly useful when you have many overlapping frames on a page. It is
initially hidden, but may be opened from the View menu. See Frames for more information on
working with frames.

Toolbar

Each of the tools represented in the Toolbar changes the mouse mode and allows you to interactively
edit your plot.

The Toolbar is actually up to four separate toolbars, with buttons grouped by function.

File toolbar

Buttons for dealing with files (hidden by default)

View toolbar

Buttons for manipulating the view

Data toolbar

Buttons for working with data

Insert toolbar

Buttons that insert objects into the workspace.

In the default toolbar configuration, shown above, the toolbars appear next to each other. Each,
however, can be moved independently to any edge of the workspace by grabbing the drag handle at
the left edge of the toolbar. To hide or show a toolbar, right-click the menu bar and choose the desired
toolbar.

Selector Tool

 Use the Selector tool to select objects in your workspace. To select multiple objects, hold down Shift
while clicking the second and subsequent objects. The selected objects can then be moved (translated)
using the Selector tool itself.

The following kinds of objects can be moved (translated) using the Selector tool:

• frames

• axis grid area

• text
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• geometries

• contour labels

• streamtraces

• streamtrace termination line

• legends

• 3D frame axis

To select an object and open that object’s attributes dialog, double-click any object

Adjustor Tool

 Use the Adjustor tool to perform any of the following modifications to your plot and data:

• Location of individual or groups of data points in the grid.

• Values of the dataset variables at a particular point.

• Length or placement of individual axes (2D Cartesian and XY Line plot types only).

• Spacing between an axis label and its associated axis (2D Cartesian and XY Line plot types only).

• The points in a polyline (and therefore its shape).

The Adjustor tool behaves like the Selector tool when you click objects other than those listed above.
For example, if you click a rectangular geometry, the entire object is selected, since the Adjustor tool
has no special functionality with a rectangular geometry. When adjusting a polyline, click close to the
points in the polyline to avoid the entire object being selected.


The Adjustor tool can alter your data. Be sure you want to use the Adjustor tool before
dragging points in the data region.

Click a point or object to select it. To select multiple points, you can hold Shift while clicking additional
points after the first. In line plots, you can select points from only one mapping at a time.

Once you have selected all desired points, move the Adjustor over the selection handles of one of the
points, then click-and-drag to the desired location of the first data point. The other selected points will
move as a unit with respect to the chosen data point, maintaining their relative positions.



For XY Line plots, if several mappings are using the same data for one of the variables,
adjusting one of the mappings will result in simultaneous adjustments to the others.
You can avoid this by pressing the H or V key on your keyboard while adjusting the
selected point. The H and V keys restrict the adjustment to the horizontal and vertical
directions, respectively.
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Zoom Tool

 Zoom into or away from the plot. Geometries zoom with the plot; however, text does not.

When a mouse-click occurs (without dragging), the zooming is centered at the location of your click.

There are two zoom modes: plot zooming and paper zooming.

For plot zooming

drag the magnifying glass cursor to draw a box around the region that you want to fit into the
frame. The box may be larger than the frame. Making the box larger than the frame zooms away
from the plot. The region within the view box will be resized to fit into the frame.


If Snap to Grid (located in the Sidebar) is selected, you cannot make the zoom box
larger than the grid area.

To return to the previous view, choose the View→Last menu (Control-L). To restore the original 2D
view, choose View→Fit Everything (Ctrl-E) or View→Fit to Full Size (Ctrl-F).

The results of plot zooming for the 2D plot type are dependent upon the axis mode selected in the Axis
Details dialog (accessed via the Plot menu):

2D Independent Axis Mode

Allows the selected region to expand to exactly fit in the frame. The axes are rescaled independently
to fit the zoom box.

2D Dependent Axis Mode

In dependent mode, the axes are not fit perfectly to the zoom box. The longest dimension from the
zoom box is applied to an associated axis, and the other axis is resized according to the dependency
relation.

For paper zooming

Shift-drag the magnifying glass cursor to draw a box about the region that you want to magnify. The
plot is resized so that the longest dimension of the zoom box fits into the workspace. You can fit all
frames to the workspace by using Fit All Frames to Workspace on the View menu.



Clicking anywhere in your plot while the zoom tool is active will center the zoom
around your click. Alternatively, Control-click centers the plot on the point that was
clicked and zooms out.

Use the center mouse button and drag (or hold down the scroll wheel and drag) to
interactively zoom into or out of the plot.

3D mouse

Tecplot Focus also supports a 3D mouse, an input device that allows zooming (and translation and
rotation) of 3D plots with a touch. You do not need to activate the Zoom tool to use the 3D mouse for
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zooming. Simply push the mouse’s cap toward or away from you to zoom. Hold the Alt key while
zooming with the 3D mouse to switch the zoom method (see Input Devices for details).

Avoid tilting the mouse cap, as this may induce unintended rotation.

Translate Tool

Use the Translate tool to translate data within a frame or the paper within the workspace.

While in Translate mode, drag the cursor to move the data with respect to the frame, or Shift-drag to
move the paper with respect to the workspace.


You may translate even when some other tool is selected by dragging with the right
mouse button.

While the Translate tool is active, you can zoom your image by pressing + to magnify, - to shrink. If you
are Shift-dragging to move the paper, the rescale buttons + and - will magnify or shrink the paper, as
long as you have the mouse button depressed.

3D mouse

Tecplot Focus also supports a 3D mouse, an input device that can be used to translate 3D plots at any
time with just a touch, regardless of the tool or mode selected.

• Pull the mouse’s cap up or push it down to translate up or down on the screen.

• Move the mouse’s cap left or right to translate left or right on the screen.

Avoid tilting or rotating the mouse when using these motions to avoid rotating the plot.

Three-dimensional Rotation

There are six 3D rotation mouse modes:

Spherical 

Drag the mouse horizontally to rotate about the Z-axis; drag the mouse vertically to control the tilt
of the Z-axis.

Rollerball 

Drag the mouse in a direction to move with respect to the current orientation on the screen. In this
mode, your mouse acts much like a rollerball.

Twist 

Drag the mouse clockwise around the image to rotate the image clockwise. Drag the mouse
counterclockwise around the image to rotate the image counterclockwise.

X-axis 

Drag the mouse to rotate the image about the X-axis.
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Y-axis 

Drag the mouse to rotate the image about the Y-axis.

Z-axis 

Drag the mouse to rotate the image about the Z-axis.

Once you have selected a rotation mouse mode, you can quickly switch to any of the others using the
following keyboard shortcuts:

Drag Rotate about the defined rotation origin with your current Rotate tool.

Alt-drag Rotate about the viewer position using your current Rotate tool.

Middle-click-and-
drag/Alt-right click-and-
drag

Smooth zoom in and out of the data.

Right-click-and-drag Translate the data.

Control-right-click-and-
drag or Command-right-
click-and-drag (Mac)

This option can be used without first selecting a rotation mouse mode.
Simply hover over your intended point of origin, and then Control-right-
click-and-drag to translate the image.

3D mouse

Tecplot Focus also supports a 3D mouse, an input device that can be used to rotate 3D plots at any
time regardless of the tool or mode selected. The axis of rotation is relative to the screen rather than
to the data.

• Tilt the mouse’s cap forward or backward to rotate around the screen’s X axis, as if rolling
toward or away from you.

• Twist the mouse’s cap clockwise or counterclockwise to rotate around the screen’s Y axis, as if
on a lazy susan.

• Tilt the mouse’s cap left or right to rotate around the screen’s Z axis, like the hands of a clock.

Slice Tool

 Use the Slicing tool to control your slice(s) interactively.

The following keyboard/mouse options are available when the Slice tool is active:

+ Primary Slices, Start End Slices Active - Turn on intermediate slices (if not
already active) and adds a slice.

Primary Slices active [ONLY] - Turns on Start/End Slices and adds a slice.

Start/End Slices active [ONLY] - Turns on Start/End Slices and adds a slice.

33



- Primary Slices, Start End Slices Active - Removes start and end slices.

Primary Slices active [ONLY] - Removes the primary slice.

Start/End Slices active [ONLY] - Removes the Start and End Slices.

Click/Drag Updates the position of the primary slice (if active). If only start and end
slices are visible, click updates the position of the starting slice.

Alt-click/Alt-drag Determine the XYZ-location by ignoring zones and looking only at derived
volume objects (streamtraces, slices, iso-surfaces).

Shift-click Switches from one Primary slice to Start/End Slices by adding a slice.

Shift-drag Move the start or end slice (whichever is closest to the initial click location).
Show Start/End Slices is activated, if necessary.

I, J, K (ordered zones
only)

Switch to slicing constant I, J, or K-planes respectively.

X, Y, Z Switch to slicing constant X, Y, or Z-planes respectively.

1-8 Numbers one through eight switch to the corresponding slice group.

Add Streamtrace

 Select the Add Streamtrace tool to add a streamtrace interactively by clicking anywhere in your
plot. Select the number of streamtraces to include with each click (rake) using 1-9 on the keyboard.



Keyboard Shortcuts

D

Switch to streamrods

R

Switch to streamribbons

S

Switch to surface lines

V

Switch to volume lines

1-9

Change the number of streamtraces to be added when placing a rake of
streamtraces

Shift

Draws a rake on concave 3D volume surfaces. These rakes are normally not drawn,
as they occur outside of the data
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Refer to Streamtraces for more information.

Streamtrace Termination Line

 Select the Add Streamtrace Termination Line tool to add a streamtrace termination line
interactively.

To draw a Streamtrace Termination Line:

• Move the cursor into the data region.

• Click once at the desired starting point for the line.

• Click again at each desired break point.

• When the polyline is complete, double-click on the last point of the polyline, or press ESC on your
keyboard.

• The drawn polyline ends any streamtraces that pass through it.

Add Contour Level

 Select the Add Contour Level tool to add a contour level by clicking anywhere in the active data
region. A new contour level, passing through the specified location, is calculated and drawn.

Alt-click Place a contour line by probing on a streamtrace,
slice, or iso-surface.

Click Place a contour line.

Control-Click Replace the nearest contour line with a new line.

Drag Move the new contour line.

- Switch to the Delete Contour Level tool.

The following keyboard and mouse shortcuts are related to the Add Contour Level tool.

Delete Contour Level

 Select the Delete Contour Level tool to delete a contour level by clicking anywhere in the active
data region. The contour line nearest the specified location is deleted.


Use the + key to switch to the Add Contour Level tool and the - key to switch back to
the Delete Contour Level tool.

Add Contour Labels

 Select the Add Contour Label tool to switch to the Contour Label mode, enabling you to add a
contour label by clicking anywhere in the active data region.

A contour label is added to the plot at the specified location; its level or value information is taken
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from the nearest contour line. This allows you to place labels at a slight offset from the lines they label.


The Contour type must be lines or lines and flood in order for this tool to be active.
You can set the contour type on the Contour page of the Zone Style dialog.

Probe Tool

 Select the Probe At tool to probe for values of the dataset’s variables at a particular point.

To obtain interpolated values of the dataset variables at the specified location, click at any point in the
data region.

To obtain exact values for the data point nearest the specified location, Control-click at the desired
location.



For XY plots, when you move into the axis grid area, the cursor cross hair is
augmented by a vertical or horizontal line, depending on whether you are probing
along the X-axis or the Y-axis. You can change the axis to probe simply by pressing X
to probe the X-axis or Y to probe the Y-axis.

Specify Equations

 Opens the Specify Equations dialog. See Data Alteration through Equations.

Insert Text

 Select the Add Text tool to add text to any frame.

When this tool is in use, the Snap To buttons in the Plot sidebar become available to allow you to easily
align your text with features of your plot.

Insert Image/Georeferenced Image

 Select the Insert Image tool to insert an image or Georeferenced image to the plot.

See Images and Georeferenced Images for more information.

Insert Geometries

Use the geometry buttons to insert geometries into your plot. When these tools are in use, the Snap To
buttons in the Plot sidebar become available to allow you to easily align your geometry with features
of your plot.

•  Polylines

•  Squares

•  Rectangles
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•  Circle

•  Ellipse

Create New Frame

 Select the Create Frame tool to create a new frame.

To add a frame:

• Click once in the workspace to anchor one corner of the frame.

• Drag the diagonal corner until the frame is the desired size and shape.


If you have data loaded before you create a new frame, you can attach the existing
dataset to the new frame by changing the plot type.

Status Line

The status line appears along the bottom of the Tecplot Focus window to provide a progress bar and
other information when Tecplot Focus computes lengthy calculations. Other "hints," such as
coordinates and tips for using the currently-selected tool, also appear here.

Tecplot Focus Workspace

In the Tecplot Focus workspace, you can create sketches and plots. You create each sketch or plot
within a frame. Each visible measure of the workspace is called a page. The current state of the
workspace, including the sizing and positioning of frames, the number and contents of pages, the
location of the data files used by each frame, and all current attributes for all frames, makes up a
layout. By default, the workspace displays a representation of where the paper plots are drawn, as well
as a reference grid and rulers. The frame most recently selected is called the active frame.

You can include multiple pages in your layout, each of which can contain multiple frames. Use the
Pages Sidebar (open it from the View menu if it’s not visible) to create and manage pages.

Getting Help

Tecplot Focus features a fully integrated Help system. Detailed help is accessible by:

• Selecting Tecplot Focus Help from the Help menu.

• Clicking the Help button in any dialog.

The Help dialog supports text search, has hypertext links, and provides detailed information on all
menus and dialogs.

You may also send an e-mail to support@tecplot.com with your questions.
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Using the Workspace
This chapter discusses the structures and features of Tecplot Focus that act the same regardless of the
data type or plot layers you are using. These include:

Data Hierarchy

How Tecplot Focus manages data.

Interface Coordinate Systems

Tecplot Focus’s use of different coordinate systems, and when and where they occur.

Frames

Areas in the workspace in which you can create plots and control formatting.

Workspace Management Options

Factors that determine the color and orientation of your paper, as well as the ruler and grid, in
order to precisely size and position objects. For in-depth information on Display Performance, refer
to Performance Dialog.

View Modification

The commands to zoom, translate, and fit plots within frames.

Edit Menu

The commands to cut, copy, and paste plot elements in the workspace.

Data Hierarchy

Tecplot Focus structures data in two levels: datasets, which display in frames, and zones, which make
up a dataset. Each dataset is composed of one or more zones, and each zone contains one or more
variables. All zones within a dataset contain the same set of variables.
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Zone 1

Zone 2

Zone 3

Zone 1

Zone 2

Zone 1

Zone 2

Zone 3

Workspace

Frame 1 Frame 2 Frame 3

Data file 1

Data set 1

Data file 2

Data set 2

Data file 3

Figure 2. This chart displays a visual representation of Tecplot Focus’s data hierarchy. Frames 1 & 2 display
Dataset 1, and Dataset 1 contains three zones from one data file. Frame 3 contains Dataset 2, which is
composed of five zones (two from data file 2 and three from data file 3).

Data Displays in Frames

Tecplot Focus always displays data in a window called a "frame". By default, Tecplot Focus opens one
frame when you launch Tecplot Focus or open a new layout, but you can display multiple plots
concurrently in Tecplot Focus by adding additional frames. You can add frames to the workspace using
the Frame menu. You can display one dataset in one frame, or you can share one dataset between
multiple frames. Using the same dataset in multiple frames allows you to generate different plots of the
same data. To learn more about working with frames, see Frames.
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Frames appear on pages. You can manage multiple pages in Tecplot Focus using the Pages Sidebar and
macro commands in the default Quick Macro Panel. Each page has its own collection of frames.

A Dataset Includes All Data in a Frame

A dataset is defined as "all of the data in a frame". To create a dataset, load one or more data files into
an empty frame in Tecplot Focus, or create a zone in a frame.

Datasets Are Made of Zones

A zone represents a subset of a dataset. A dataset can be composed of a single zone or several zones.
Zones are either defined in a data file or created directly in Tecplot Focus. The number of zones in a
dataset is the sum of the number of zones in each of the data files included in the dataset, plus any
zones created within Tecplot Focus.

Typically, a data file is divided into zones based on its physical coordinates. For example, a dataset of
an airplane may consist of a zone for each wing, each wheel, the nose, etc. Alternatively, zones may be
defined based on the material. For example, a dataset of a fluid tank may have a zone for the tank itself
and additional zones for each fluid inside the tank.

 All zones in a given dataset must have the same variables defined for each data point.

Interface Coordinate Systems

Tecplot Focus incorporates a number of coordinate systems, including the paper, frame, and the
physical coordinate systems for the plot (2D, 3D, XY, or Polar). The origins of each coordinate system
and their relationship to one another is shown in Figure 3.
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Figure 3. Tecplot Focus Coordinate System. The physical coordinate system(s) of the dataset (for example, 3D
Cartesian or 2D Cartesian) are encompassed in the Frame Coordinate System.

The physical coordinate system (2D or 3D) depends on the plot type of the active frame. Two-
dimensional physical coordinates are often referred to as grid coordinates. The Grid coordinate system
is aligned with the coordinate system used by the plot axes; the Frame coordinate system is fixed to the
frame and does not change when the plot is zoomed, translated, or rotated.

In 2D Cartesian plots, objects such as text labels and geometries are drawn in either the Frame or the
Grid coordinate system. In 3D Cartesian plots, these objects are drawn in either the Frame coordinate
system, or in what is known as the Eye coordinate system. The eye coordinate system is aligned with
the Grid coordinate system; so objects drawn in the Eye coordinate system move with the data as you
zoom and translate, but remain fixed when you rotate the plot.
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Figure 4. A 3D volume plot with streamribbons and a streamtrace termination line. This figure illustrates how
the termination points vary as the plot is rotated. Notice that the termination line itself remains in place on the
screen as the plot is rotated.

Frames

All plots and sketches are displayed within frames. Initially, the Tecplot Focus workspace contains one
frame. You may add additional frames, resize and reposition frames, modify background color, and
specify border and header appearance. Tecplot Focus acts upon only one frame, The Active Frame, at
any given time (however, frames may be linked, so that changing one may also change others). The
active frame displays with a darker, thicker border than the inactive frames so that you can easily see
which frame is active.


Tecplot Focus uses the height of the frame for objects scaled by frame units, such as
font size. When you enter a frame unit value into a dialog or when you set frame size
and position on the paper, you may specify a different unit system (inches, points,
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centimeters, or pixels). Tecplot Focus automatically converts the values into frame
units.

The Active Frame

The active frame, indicated by default with a darker and thicker border, is the frame in your
workspace affected by all operations you do in Tecplot Focus. To make a frame the active frame, click
anywhere inside that frame with the Selector tool (or any other tool except the Create New Frame
tool). Reference the following sections for additional actions you can perform on frames.

Frame Creation

To create a new frame, which you can use to display a new dataset or another view of an already-
loaded data set, select the New Frame  button in the toolbar. Or select Create New Frame from the
Frame menu. Selecting either the New Frame tool or Create New Frame in the Frame menu will
change your selector tool into a small + symbol. Click with this tool in your workspace where you want
one corner of your new frame, and drag across the workspace to where you would like the opposite
corner of your new frame.



Tecplot Focus automatically makes the new frame the active frame.

For optimal printing of your plot(s), draw frames that sit completely within the paper
displayed in the workspace. See Create Multiple Frames for information on
simultaneously creating multiple frames.



Data Set Inheritance

After creating a new frame, you can assign the frame to share the dataset of another
frame by changing the frame order and the plot type of the new frame. When you
switch a frame without data out of Sketch plot type, Tecplot Focus searches for
another frame with which to share data. It performs this search in the order that the
frames are drawn on-screen, starting from the top and moving down. The empty
frame will inherit data from the first frame in the draw order that contains data.

Edit Active Frame

The Edit Active Frame dialog (accessed from the Frame menu) allows you to adjust the dimensions
and style of your active frame. When you are working with multiple frames, select a frame with your
selector tool to make that frame active. Then select Edit Active Frame from the Frame menu to adjust
the position and properties of that frame.
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Frame Dimensions

You can size and position a frame using your mouse, the keyboard, or a dialog. To use only your mouse,
select the frame to activate the resizing handles (black boxes on the edges and corners of the frame).
Click and drag on a handle to resize a frame, or click and drag on an edge in a location without a
handle to change the frame location. To specify size or position with a dialog, select Edit Active Frame
from the Frame menu.

In the Edit Active Frame dialog, you may specify the exact location for the frame’s left and top sides,
along with width and height.

Left Side

Left edge of the frame, relative to the workspace.

Top Side

Top edge of the frame, relative to the workspace.

Width

Width of the frame (coordinates are: left side to left side + width).

Height

Height of the frame (coordinates are: top side to top side - height).

The units in the Frame Dimensions region of the dialog are based on the units set for the Ruler
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Spacing in Options→Ruler/Grid.



You may also use the mouse or the arrow keys to resize and position frames. Click
anywhere on a frame’s header or border to activate resizing handles for the frame. To
scale frames proportionally (maintaining the vertical to horizontal aspect ratio) select
the frames, then press + on your keyboard to enlarge or - to reduce.

After selecting frames, you may position them using the arrow keys on your keyboard. You can move
frames up, down, left, or right in one-pixel increments for precise location.


To fit the active frame to the entire printable region of US letter-size paper (landscape
orientation), set Left Side=0.127, Top Side=0.125, Width=10.75, and Height=8.25. Or, set
Width=8.25 and Height=10.75 for portrait orientation.

Frame Border and Header Controls

Use the Edit Active Frame dialog (accessed from the Frame menu) to adjust the frame border or
header.

Toggling-off Show Border makes the frame border invisible. Use the Thickness box in the Edit Active
Frame dialog to adjust the line thickness of the border.

Remember that Tecplot Focus uses a thicker border to indicate The Active Frame, so making borders
thicker can make it become more difficult to determine which frame is active.

The frame header displays when both Show Border and Show Header are toggled-on. If you turn off
the border by toggling-off Show Border, the header turns off as well.

The frame header contains user-configurable information which defaults to:

&(FrameName) | &(date) | &(DataSetTitle)

where FrameName is the frame’s name, date is the date the frame was created or revised, and
DataSetTitle is the title of the active dataset. You can change these defaults in your configuration file
using the $!GLOBALFRAME command (see the Scripting Guide).

Frame Background Color Modification

Select the Color box in the Edit Active Frame dialog (accessed from the Frame menu) to adjust the
frame background color. Toggle-off Show Background to set the frame background to transparent.
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Frame Name Modification

Enter text in the Frame Name region of the Edit Active Frame dialog (accessed from the Frame menu)
to change the name of the active frame. The text entered here is displayed as the name of the frame.

Frame Linking

The Set Links for Active Frame dialog, accessible through Frame→Frame Linking, allows you to link
specific style attributes either between frames or within a frame. Linking between frames, on the
Between Frames page of the dialog, allows you to quickly make changes in one frame and propagate
them to a number of other frames. Linking within frames, on the Within Frame page, links attributes
between similar objects within a frame.

Attribute Linking Between Frames

Use the Between Frames page of the Set Links for Active Frame dialog (accessed from
Frame→Frame Linking) to link the following attributes (shown below):

Frame Size and Position

Use this option to overlay transparent frames. (See Frame Background Color Modification.)
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Solution Time

All frames display the same solution time.

X Axis Range, Y Axis Range (For XY Line and 2D plots)

Links the X-Axis or Y-Axis range and the positioning of the left and right sides of the viewport.

 For XY Line plots, axis range linking applies only to the first axes, X1 and/or Y1.

XY Axis Position (For XY Line and 2D plots)

Links the positioning of the X and Y-Axes between frames, including the method used for
positioning the axes, such as aligning with an opposing axis value.

Polar Plot View

Link views for frames using the Polar Line plot type.

3D Plot View

Link the 3D axes and 3D view.

Slice Positions

Link slice positions and slice planes for active slices (not slice style).

Iso-Surface Locations

Link iso-surface values (but not iso-surface plot style).

Contour Levels

Link the values and number of contour levels for 2D and 3D plots.

Value Blanking Constraints

Link all value-blanking attributes.


It is not necessary to close and reopen the dialog between frames. Simply select
another frame with the dialog open to edit linking for the newly active frame.

Frame Linking Groups

You can segregate frames into groups so that only frames in that group receive changes made in the
linked attributes. By default, all frames are added to Group 1. Add a frame to a group by selecting the
appropriate group number from the Frame is a Member of Group drop-down menu on the Between
Frames page of the Set Links for Active Frame dialog. You can assign frames to groups 1-20. New
frames added to a group take on the characteristics of previous members of the group.
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Figure 5. Five frames in two groups with different linking options.

Propagating Between-Frame Link Attributes to Other Frames

Once link attributes are set in a frame group, you must set these same attributes in other frames for
linking to occur. Each frame may have each of the attributes selected or not linked. If you want all or a
selected group of frames to have the same link attributes, select the appropriate Apply Settings to…
button to quickly propagate the link settings. Alternatively, you can select each frame individually,
making the same selections on the Set Links for Active Frame dialog for each chosen frame.



When 2D or XY Line frames have dependent axes and these axis ranges are linked, a
"best-fit" attempt is made to match the axis ranges between frames. Misalignments
can occur when the aspect ratios for the lengths of the axes is not the same between
two frames with linked X and Y-axes. Setting the X and Y-axes to be independent
allows a precise match.

Attribute Linking Within A Frame

The Within Frame page of the Set Links for Active Frame dialog (shown below) allows you to link the
following attributes:
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Axis Style

Link activation, colors, line styles, and font styles for objects associated with axes.

Gridline Style

Link activation, colors, and line styles for gridlines.

Zone/Map Color between Plot Layers

Link the color of meshes, contour lines, and other zone layers for Cartesian plots, or link the color of
lines, symbols, and other map layers for line plots.

Zone Line Pattern between Plot Layers

Link line pattern style and length for meshes, vector, and contour lines for Cartesian plots.

Settings changed on this dialog take effect immediately. You may also apply the settings to all frames or
just to selected frames using the buttons in the dialog.


Keep in mind that within-frame Linking only links attributes between similar objects
within a frame. These attributes are not linked to other frames. The Apply Settings
buttons turn on the same Within-Frame Linking properties in other frames.

Frame Deletion

Delete a frame by selecting the frame and then choosing Edit→Delete or pressing the Delete key. This
action is not undoable.
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Managing Frame Order

Frames can overlap, and when they do, one is drawn in front of the other. You can think of the frames
as a stack of papers pinned to a bulletin board. The order of frames can be managed by right-clicking a
frame name in the Frames sidebar and choosing one of the following options.

 The Frames sidebar is initially hidden. To display it, choose View→Frames Sidebar.

Bring Forward

To move a frame one step closer to the front of the frame stack, right-click its name and choose
Bring Forward from the context menu.

Send Backward

To move a frame to one step closer to the back of the frame stack, right-click its name and choose
Send Backward from the context menu.

Bring to Front

To move a frame to the front of the frame drawing order, right-click its name and choose Bring to
Front from the context menu. That frame will then appear in front of all other frames.

Send to Back

To move a frame to the bottom of the frame drawing order, right-click its name and choose Send to
Back from the context menu. That frame will then appear behind all other frames.

The context menu in the Frames sidebar also contains an option to Activate the selected frame. This
does not change the drawing order of the frame, but does make it The Active Frame.

Save Frame Style

You can save a frame’s style for later use or to share with another frame by selecting Save Frame Style
in the Frame menu. This will open the Save Style dialog, in which you can name and save the style of
your active frame as a stylesheet (with the extension .sty). Use the Load Frame Style action to retrieve
your frame style in another frame or layout.

The following data is saved:
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• All plot style information

• Text elements

• Geometries (shapes such as boxes, circles, and polylines)

• Stream positions

• Contour levels

Load Frame Style

To load a saved frame style into your active frame, select Load Frame Style in the Frame menu. With
the Load Frame Style dialog that appears, you can load a frame style saved from another frame (with
the extension .sty) to dictate the frame attributes of your active frame. This will affect only the The
Active Frame. To save a frame style, use the Save Frame Style function.

The following data is retrieved from the file and applied to the current frame:

• All plot style information

• Text elements

• Geometries (shapes such as boxes, circles, and polylines)

• Stream positions

• Contour levels

Workspace Management Options

The workspace is the region in which you can create frames. The paper layout is a subset of the
workspace and is correlated to the printer settings.


The paper is hidden by default in Tecplot Focus. Select Show Paper on Screen in the
Paper Setup dialog under the File menu to include the paper.

Paper Setup

Tecplot Focus’s representation of paper in the workspace allows you to lay out plots precisely the way
you want them printed. If you place a frame on the paper and print the resulting plot, the frame
appears in the exact relative location on the printed paper.

You can control the size, orientation, and color of your paper by going to File→Paper Setup.
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Paper Size Controls

Tecplot Focus offers the following six paper sizes:

Letter

Standard U.S. letter size, 8 1/2 by 11 inches.

Double

Standard U.S. ledger size, 11 by 17 inches.

A4

Standard European letter size, 21 by 29.7 centimeters.

A3

Standard European size, 29.7 by 42 centimeters.

Custom 1

Default is 8.5 by 14 inches.

Custom 2

Default is 8 by 10 inches.

All paper sizes may be customized using options in configuration or macro files. It is recommended
that you only change the dimensions of the Custom 1 and Custom 2 paper sizes. To change the Custom
sizes see the $!PAPER command in the Scripting Guide.

Paper Orientation Controls

Layouts can be landscape or portrait. In landscape (the default), the long axis of the paper is
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horizontal, while in portrait, the long axis is vertical. Portrait orientation uses the width of the
specified paper for the horizontal dimension, while landscape uses this for the vertical dimension. You
specify the orientation as part of paper set-up.

Screen Paper Controls

If you are creating plots for display on your screen, you can toggle-off the screen representation of the
paper and use the full workspace by deselecting Show Paper on Screen.

Dimensions (display only)

The units displayed in the Dimensions region of the Paper Setup dialog are determined by the units
established in Options→Ruler/Grid.

Paper Color Controls

You can set up your paper to show any color as a background color (the "paper fill color") on your
screen, as well as use that color when printing to a color printer. When you are printing, the paper can
be flooded with your specified fill color. (By default, the paper fill color is ignored during printing.) To
use the paper fill color when printing, select Use Paper Fill Color when Printing from the Paper
Setup dialog.

Grid and Ruler Set-Up

The workspace grid provides a convenient guide for placing objects on your paper. When placing text
or geometric shapes, you can choose to snap the anchor points of the shapes to the grid. Rulers provide
a reference length for sizing objects.

To customize the ruler/grid settings, select Ruler/Grid from the Options menu.

Workspace Grid Controls

Tecplot Focus allows you to select grid spacing from several pre-set sizes in centimeters (cm), inches
(in), or points (pt) with the Grid Spacing drop-down menu. You can also specify not to show the grid by
toggling-off Show Grid.

 The grid does not display if Show Paper on Screen or Show Grid are toggled-off.
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Workspace Ruler Controls

You can select the ruler markings from several pre-set sizes in centimeters (cm), inches (in), or points
(pt) with the Ruler Spacing drop-down menu. You can also specify not to show the ruler by toggling-off
Show Ruler. With Show Ruler toggled-on, rulers appear on the bottom and right-hand sides of the
workspace.

View Modification

Use the View menu to adjust the view of the active frame, sidebars, or toolbars, or to adjust the view of
the entire workspace. The View menu is discussed in the following subsections.

Show a Sidebar or Toolbar

You may close a sidebar by clicking its close box. Once closed, you may reopen it by choosing the
desired sidebar from the appropriate menu.

Sidebar Menu Command

Plot View→Plot sidebar

Pages View→Pages sidebar

Frames View→Frames sidebar

Quick Macro Panel Scripting→Quick Macros

You may also show or hide a sidebar or a toolbar by right-clicking any toolbar (or the menu bar) and
choosing the toolbar or sidebar you wish to show or hide from the context menu.

Redraw Frame

When Auto Redraw is toggled-off, click the Redraw button in the Plot sidebar to redraw the active
frame.

Zoom

There are two zoom modes: axis (dataset) zooming and paper zooming. To use either, first activate the
Zoom tool  from the Toolbar.

Plot Zooming

With the Zoom tool selected, drag the magnifying glass cursor to draw a box. The region within the
view box will be resized to fit into the frame according to the longest dimension of the view box. If
Snap to Grid is selected (on the Plot sidebar), you cannot make the zoom box larger than the grid area.


To return to the previous view, select Last (Ctrl-L) from the View menu or Undo
(Ctrl-Z) from the Edit menu.
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3D mouse

Tecplot Focus also supports a 3D mouse, an input device that allows zooming (and translation and
rotation) of 3D plots with a touch. You do not need to activate the Zoom tool to use the 3D mouse for
zooming. Simply push the mouse’s cap toward or away from you to zoom.

Hold the Alt key while zooming with the 3D mouse to switch the zoom method (see Input Devices
for details).

Avoid tilting the mouse cap, as this may induce unintended rotation. Hold down the Alt key to
switch between zooming by moving the data and by moving the viewer.

Paper Zooming

With the Zoom tool selected, Shift-drag the magnifying glass cursor to draw a box about the region
that you want to magnify. The plot is resized such that the longest dimension of the zoom box fits into
the workspace.


You can fit all frames to the workspace by using the Fit All Frames to Workspace
option of the View menu.

Mouse Zoom and Translation

The middle and right mouse buttons allow you to smoothly zoom and translate your plot. The middle
mouse button zooms smoothly, and the right mouse button translates (moves).

3D mouse

Tecplot Focus also supports a 3D mouse, an input device that can be used to zoom and translate 3D
plots at any time regardless of the tool or mode selected.

• Push the mouse’s cap toward or away from you to zoom. Hold the Alt key while zooming with
the 3D mouse to switch the zoom method (see Input Devices for details).

• Pull the mouse’s cap up or push it down to translate vertically.

• Move the mouse’s cap left or right to translate horizontally.

Avoid tilting or rotating the mouse when using these motions to avoid rotating the plot.

Fit Everything

View→Fit Everything (Ctrl-E) resizes 3D Cartesian plots so that all data points, and all text and
geometries positioned using grid coordinates, are included in the frame. By default, geometries use
grid coordinates, while text objects use frame coordinates, so typically this means that Fit Everything
fits geometries but not text objects, although if a text object has been set to use grid coordinates, it will
be included. Use View→Data Fit to consider only data in the resizing.


Long text strings may still extend out of the frame even if positioned using grid
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coordinates.

Fit Surfaces

View→Fit Surfaces(Ctrl-F) resizes 3D Cartesian plots so that all surfaces are included in the frame,
excluding any volume zones. If there are no surfaces plotted, View→Fit Surfaces fits all data points,
text, and geometries into the frame.

Fit to Full Size

View→Fit to Full Size (Ctrl-F) resizes non-3D plots so that all zones or lines, geometries, and text fit
within the frame.

Data Fit

View→Data Fit resizes the plot so all data points are included in the frame. Text and geometries are
not considered. The text and geometries must be set to grid coordinates to be considered in the
resizing.

Fit All Frames to Workspace

View→Fit All Frames to Workspace (Ctrl-Shift-A) resizes all frames proportionally so the frame(s)
fill the workspace either vertically or horizontally.

Nice Fit to Full Size

View→Nice Fit to Full Size (Ctrl-I) sets the axis range of 2D Cartesian, XY Line, and Sketch plot types
to begin and end on major axis increments. If axes are dependent, the vertical axis length is adjusted to
accommodate a major tick mark.

Make Current View Nice

View→Make Current View Nice (Ctrl-K) modifies the range on a specified axis of 2D Cartesian, XY
Line, and Sketch plots to fit the minimum and maximum of the variable assigned to that axis, then
snaps the major tick marks to the ends of the axis. If axis dependency is not independent, this may
affect the range on another axis.

Center

Centers the plot within the frame. Only the data is centered; text, geometry, and the 3D axes are not
considered. Neither the axes nor the plot is changed in size.

Translate/Magnify

The Translate/Magnify dialog (accessed via the View menu), allows you to move and resize your plot
within a frame. Translating using this dialog moves the image of your data with respect to the active
frame. You can translate plots in any direction within a frame.
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The following options are available in the Translate/Magnify dialog:

Up, Down, Left, Right

Use the arrows to translate (move) the image.

Increment (%)

Controls the step size for each arrow as a percentage of the workspace.

View Magnification - Factor

Change magnification using the up and down arrows to the right of the text field, or enter a value in
the text field.

View Magnification - Increment (%)

The step size for each click of the arrows in the Factor field, as a percentage of the current
magnification.

The Translate/Magnify tool  (located in the Toolbar) allows you to translate/magnify the data within
the frame or the entire workspace. Use the Shift key to translate/magnify the workspace instead of the
data.

When the Translate/Magnify tool is active, type +/- on your keyboard to increase/decrease the scale of
the image.



To use the Magnify tool on the workspace, hold the Shift key and click on the
workspace. Then, use the + or - keys on the keyboard to change the magnification of
the workspace. Single-click on the data to change the mode back to dataset
magnification.
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Last

View→Last (Ctrl-L) restores the previous view. The Last command allows you to step backward
through the resizings and repositionings of plots. Any time you change the view of a frame, either by
zooming, centering, translating, or fitting the plot, the previous view is placed in a view stack. Each
frame is allotted four view stacks, one for each plot type. Each view stack stores up to sixteen views,
including the active view.

Rotate

Available in the 3D Cartesian plot type only; calls up the Rotate dialog for image rotation. For further
information, see Three-dimensional Rotation.

3D View Details

Available in the 3D Cartesian plot type only; calls up the 3D View Details dialog for setting the view
position and angle of 3D objects. For further information, see Three-dimensional Rotation.

Copy View

Use the View→Copy View menu option to copy the active frame view to the frame view buffer, where
it can then be pasted to other frames having the same plot type. The copied view includes all the
attributes of the view that are affected by the View menu: the amount of zoom, translation and scale,
and (in 3D Cartesian plot type) the amount of rotation and perspective projection.

Paste View

View→Paste View pastes a copied view onto the active frame. When you are working with multiple
frames attached to the same dataset, it is often useful to make your view changes to one frame and
then propagate those changes to the other frames.

Edit Menu

You can duplicate frames, text, and geometries with the cut, copy and paste options of the Edit menu
(or their keyboard equivalents, Ctrl-X, Ctrl-C, and Ctrl-V). You can also cut objects from one location
and paste them into another, or throw them away completely using the Delete option.

Undo

All plot and mapping style modifications can be undone. In addition, you can undo a variety of other
plot alterations. As a rule, Tecplot Focus allows undo for reversible operations that can be restored
without significant impact on the operation’s performance. To undo an operation, select Undo from
the Edit menu, or press Ctrl-Z in the workspace.

Specifically, the Undo option is allowed for the following conditions:

• All zone and map style changes.
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• Some (though not all) frame control operations.

• Creating new frames.

• Moving and copying line maps.

• View operations.

• Some pick operations.

• Streamtrace actions.

• The following data alterations:

◦ Deleting zones and variables.

◦ Renaming datasets and zones.

◦ Creating rectangular or circular zones.

◦ Duplication zones.

◦ Processing Equations. (Except equations containing derivatives.)


Undo is unavailable for all data operations once an Undo operation has been
performed on an un-allowed item. In addition, once an operation is performed that
cannot be undone, the entire undo history for that frame is erased.

Cut

Edit→Cut or Ctrl-X removes the selected item from the plot and the active dataset (if applicable), and
stores the removed item in the Paste buffer.


Generally, the Cut, Copy, and Paste options work only within Tecplot Focus. However,
you can copy selected frames and text objects and paste them into other applications.
See Clipboard Exporting to Other Applications.

Copy

Edit→Copy or Ctrl-C stores the selected item in the Paste buffer but leaves it in your plot or the active
dataset.


Generally, the Cut, Copy, and Paste options work only within Tecplot Focus. However,
you can copy selected frames and text objects and paste them into other applications.
See Clipboard Exporting to Other Applications.

Paste

Use Edit→Paste or Ctrl-V to add the contents of the Paste buffer to the active plot. If the object is being
copied into the same frame, the new object will be overlaid directly over the original object. Use the
Selector or the Adjustor tool to move the copied item to different locations in the frame.
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Pasting from the Paste buffer is allowed only between compatible frames. Attempting
to copy an object into a frame that does not hold an appropriate data type results in
an error message.

Delete

Remove the selected item from the plot and from the active dataset. Deleted items are not stored in the
Paste buffer.


If you cut or clear the only Tecplot Focus frame in the workspace, Tecplot Focus
automatically creates a blank frame to replace it.

Send to Back

Pushes the selected item to the bottom of the active draw stack. The plot is drawn on your screen from
the bottom of the draw stack to the top; elements lying further down in the stack may be partially
obscured by elements higher up. The following types of objects may be pushed: text, geometries, 2D or
XY grid areas, and frames.

Bring to Front

Pop the selected item to the top of the active draw stack. The following types of objects may be popped:
text, geometries, 2D, or XY grid areas, and frames.

Data Structure
Tecplot Focus accommodates two different types of data: Ordered Data and Finite Element Data.

• Ordered data is a set of points logically stored in a one, two, or three-dimensional array, where I, J,
and K are the index values within the array. The number of data points is the product of all of the
dimensions within the array.

• Finite-element data is arranged in two arrays, a variable array and a connectivity matrix. The
variable array is a collection of points in 2D or 3D space that are connected into polygonal or
polyhedral units called elements. The connections between the nodes are defined by the
connectivity matrix.

Connectivity List

A connectivity list is used to define which nodes are included in each element of an ordered or cell-
based finite element zone. You should know your zone type and the number of elements in each zone
in order to create your connectivity list.

The number of nodes required for each element is implied by your zone type. For example, if you have
a finite element quadrilateral zone, you will have four nodes defined for each element. Likewise, you
must provide eight numbers for each cell in a BRICK zone, and three numbers for each element in a
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TRIANGLE zone. If you have a cell that has a smaller number of nodes than that required by your zone
type, simply repeat a node number. For example, if you are working with a finite element
quadrilateral zone and you would like to create a triangular element, simply repeat a node in the list
(e.g., 1,4,5,5).

In the example below, the zone contains two quadrilateral elements. Therefore, the connectivity list
must have eight values. The first four values define the nodes that form Element 1. Similarly, the
second four values define the nodes that form Element 2.

The connectivity list for this example would appear as follows:

ConnList[8] = {4,5,2,1,  /* nodes for Element 1 */
               5,6,3,2}; /* nodes for Element 2 */


It is important to provide your node list in either a clockwise or counter-clockwise
order. Otherwise, your cell will twist, and the element produced will be misshapen.

Ordered Data

Ordered data is defined by one, two, or three-dimensional logical arrays, dimensioned by IMAX, JMAX,
and KMAX. These arrays define the interconnections between nodes and cells. The variables can be
either nodal or cell-centered. Nodal variables are stored at the nodes; cell-centered values are stored
within the cells.

One-dimensional Ordered Data (I-ordered, J-ordered, or K-ordered)

A single dimensional array where either IMAX, JMAX or KMAX is greater than or equal to one, and
the others are equal to one. For nodal data, the number of stored values is equal to IMAX * JMAX *
KMAX. For cell-centered I-ordered data (where IMAX is greater than one, and JMAX and KMAX are
equal to one), the number of stored values is (IMAX-1) - similarly for J-ordered and K-ordered data.

Two-dimensional Ordered Data (IJ-ordered, JK-ordered, IK-ordered)

A two-dimensional array where two of the three dimensions (IMAX, JMAX, KMAX) are greater than
one, and the other dimension is equal to one. For nodal data, the number of stored values is equal to
IMAX * JMAX * KMAX. For cell-centered IJ-ordered data (where IMAX and JMAX are greater than one,
and KMAX is equal to one), the number of stored values is (IMAX-1)(JMAX-1) - similarly for JK-
ordered and IK-ordered data.
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Three-dimensional Ordered Data (IJK-ordered)

 A three-dimensional
array where all IMAX, JMAX and KMAX are each greater than one. For nodal ordered data, the
number of nodes is the product of the I-, J-, and K-dimensions. For nodal data, the number of stored
values is equal to IMAX * JMAX * KMAX. For cell-centered data, the number of stored values is (IMAX-
1)(JMAX-1)(KMAX-1).

Indexing Nodal Ordered Data

For nodal ordered data, the n-dimensional array of values are treated as a one dimensional array. For
example, given an IJK-ordered zone dimensioned by 10x20x30. To access the value at I=3, J=4, K=5 (one
based) you would use:

IMax       = 10
JMax       = 20
KMax       = 30
I       = 3
J       = 4
K       = 5
NodeIndex = I + (J-1)*IMax + (K-1)*IMax*JMax
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Indexing Cell-centered Ordered Data

For cell-centered ordered data, the index that represents the cell center is the same as the nodal index
that represents the lowest indexed corner of the cell.

For example, the figure below shows an IJ-ordered zone dimensioned 3x4.

Figure 6. An IJ-ordered zone dimensioned 3x4. Cell index numbers are based on the point number in the lowest
corner of the cell.

To access a cell-centered value for the cell in the upper right hand corner, use the following:

IMax      = 3
JMax      = 4
KMax      = 1
I      = 2
J      = 3
K      = 1
CellIndex    = I + (J-1)*IMax + (K-1)*IMax*JMax
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You’ll notice that the equations are exactly the same as with nodal data. As a result there are gaps of
unused values at IMax, JMax, and KMax that must be left unassigned.

The above equation is generic for 1D, 2D and 3D data. It simplifies for the lower dimensions.

One-dimensional Ordered Data (I, J, or K)

Values for XY Line plots are usually arranged in a one-dimensional array indexed by one parameter: I
for I-ordered, J for J-ordered, or K for K-ordered, with the two remaining index values equal to one.

At each node, N variables (V1, V2, …, VN) are defined. If you arrange the data in a table where the
values of the variables (N values) at a node are given in a row, and there is one row for each node, the
table would appear something like that shown below.

Table 1. Tableof values for I-ordered Nodal Data (typical for XY plots).

V1 V2 V3 … VN (Values at
node I = 1)

V1 V2 V3 … VN (Values at node
I = 2)

V1 V2 V3 … VN (Values at node
I = 3)

V1 V2 V3 … VN

V1 V2 V3 … VN

V1 V2 V3 … VN (Values at node
I = IMax)

See XY and Polar Line Plots for more information on XY plots.

IJK-ordered Data Plotting

In one or two-dimensional datasets, all data points are typically plotted. However, for IJK-ordered data
you can designate which surface will be plotted by using the Surfaces page of the Zone Style dialog.
You may choose to plot just outer surfaces, or you may select combinations of I, J, and K-planes to be
plotted. Refer to Surfaces for in-depth information.

Logical versus Physical Representation of Data

A family of I-lines results by connecting all of the points with the same I-index, similarly for J-lines and
K-lines. For IJ-ordered data, both families of lines are plotted in a two-dimensional coordinate system
resulting in a 2D mesh. When both the I and J-lines are plotted in a three-dimensional coordinate
system, a 3D surface mesh plot results. An example of both meshes is shown below. As you can see,
logical data points can transform into an arbitrary shape in physical space.
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Figure 7. Left, a 2D mesh of IJ-ordered data points. Right, a 3D mesh of IJ-ordered data points.

Finite Element Data

While finite element data is usually associated with numerical analysis for modeling complex
problems in 3D structures (heat transfer, fluid dynamics, and electromagnetics), it also provides an
effective approach for organizing data points in or around complex geometrical shapes. For example,
you may not have the same number of data points on different lines, there may be holes in the middle
of the dataset, or the data points may be irregularly (randomly) positioned. For such difficult cases, you
may be able to organize your data as a patchwork of elements. Each element can be independent of the
other elements, so you can group your elements to fit complex boundaries and leave voids within sets
of elements. The figure below shows how finite element data can be used to model a complex
boundary.
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Figure 8. This figure shows finite element data used to model a complex boundary.

Finite element data defines a set of points (nodes) and the connected elements of these points. The
variables may be defined either at the nodes or at the cell (element) center. Finite element data can be
divided into three types:

• Line data is a set of line segments defining a 2D or 3D line. Unlike I-ordered data, a single finite
element line zone may consist of multiple disconnected sections. The values of the variables at each
data point (node) are entered in the data file similarly to I-ordered data, where the nodes are
numbered with the I-index. This data is followed by another set of data defining connections
between nodes. This second section is often referred to as the connectivity list. All elements are
lines consisting of two nodes, specified in the connectivity list.

• Surface data is a set of triangular, quadrilateral, or polygonal elements defining a 2D field or a 3D
surface. When using polygonal elements, the number of sides may vary from element to element.
In finite element surface data, you can choose per zone to arrange your data in three-point
(triangle), four-point (quadrilateral), or variable-point (polygonal) elements. The number of points
per node and their arrangement are determined by the element type of the zone. If a mixture of
quadrilaterals and triangles is necessary, you may repeat a node in the quadrilateral element type
to create a triangle, or you may use polygonal elements.

• Volume data is a set of tetrahedral, brick, or polyhedral elements defining a 3D volume field. When
using polyhedral elements, the number of sides may vary from element to element. Finite element
volume cells may contain four points (tetrahedron), eight points (brick), or a variable number of
points (polyhedral). The figure below shows the arrangement of the nodes for tetrahedral and brick
elements. The connectivity arrangement for polyhedral data is governed by the method in which
the polyhedral facemap data is supplied.
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Polygonal surface data elements and polyhedral volume data elements are
features only available in Tecplot 360.

Table 2. Connectivity arrangements for FE-volume datasets

Tetrahedral connectivity arrangement Brick connectivity arrangement

In cell-based element types (triangular, quadrilateral, tetrahedal, or brick), points may be repeated to
achieve elements containing a smaller number of points. For example, a connectivity list of n1 n1 n1 n1
n5 n6 n7 n8 (where n1 is repeated four times) results in a brick-based pyramid element. Any of the
points could be repeated; for example, n1 n1 n3 n3 n5 n5 n7 n7 would also be a valid way to define a
pyramidal element in a brick zone.

In Tecplot Focus, each FE data zone must be composed exclusively of one element type. However, you
may use a different data point structure for each zone within a dataset, as long as the number of
variables defined at each data point is the same.

The Data Format Guide provides detailed information about how to format your FE data in Tecplot’s
text file format.

Finite Element Data Limitations

Working with finite element data has some limitations:

• XY-plots of finite element data treat the data as I-ordered; that is, the connectivity list is ignored.
Only nodes are plotted, not elements, and the nodes are plotted in the order in which they appear
in the data file.

• Index skipping in vector and scatter plots treats finite element data as I-ordered; the connectivity
list is ignored. Nodes are skipped according to their order in the data file.
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Variable Location (Cell-centered or Nodal)

Data values can be stored at the nodes or at the cell centers.

• For finite element meshes, cell-centers are the centers (centroids) of elements.

• For many types of plots, cell-centered values are interpolated to the nodes internally.

Face Neighbors

A cell is considered a neighbor if one of its faces shares all nodes in common with the selected cell, or if
it is identified as a neighbor by face neighbor data in the dataset. The face numbers for cells in the
various zone types are defined below.

Examples of face neighbors for various zone types.

A: Example of node and face neighbors for an FE-brick cell or IJK-
ordered cell.

B: Example of node and face numbering for an IJ-ordered/FE-
quadrilateral cell.
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C: Example of tetrahedron face neighbors.

The implicit connections between elements in a zone may be overridden, or connections between cells
in adjacent zones established, by specifying face neighbor criteria in the data file. Refer to TECFACE in
the Data Format Guide for additional information.

Working with Unorganized Datasets

Tecplot Focus loads unorganized data as a single I-ordered zone and displays them in XY Mode, by
default. An I-ordered zone is considered irregular if it has more than one dependent variable. An I-
ordered data set with one dependent variable (i.e. an XY or polar line) is not an irregular zone.

To check for irregular data, you can go to the Data Set Info dialog (accessed via the Data menu). The
values assigned to: IMax, JMax, and KMax are displayed in the lower left quadrant of that dialog. If
IMax is greater than 1, and JMax and KMax are equal to 1, then your data is irregular.

It is also easy to tell if you have irregular data by looking at the plot. If you are looking at irregular data
with the Mesh layer turned on, the data points will be connected by lines in the order the points
appear in the data set.

You can organize your data set for Tecplot Focus in the following ways.

• Manually order the data file using a text editor.


Use the Label Points and Cells feature from the Plot menu to see if your data set
can be easily corrected using a text editor by correcting the values for I, J, and/or
K.

• Use one of the Data→Interpolation options. See Data Interpolation.

Example: Unorganized Three-Dimensional Volume

To use 3D volume irregular data in field plots, you must interpolate the data onto a regular, IJK-
ordered zone. To interpolate your data, perform the following steps:

1. Place your 3D volume irregular data into an I-ordered zone in a data file.

2. Read in your data file and create a 3D scatter plot.
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3. From the Data menu, choose Create Zone→Rectangular. (Circular will also work.)

4. In the Create Rectangular Zone dialog, enter the I-, J-, and K-dimensions for the new zone; at a
minimum, you should enter 10 for each dimension. The higher the dimensions, the finer the
interpolation grid, but the longer the interpolating and plotting time.

5. Enter the minimum and maximum X, Y, and Z values for the new zone. The default values are the
minimums and maximums of the current (irregular) dataset.

6. Click Create to create the new zone, and Close to dismiss the dialog.

7. From the Data menu, choose Interpolate→Inverse-Distance. Kriging may also be used.

8. In the interpolation dialog, choose the irregular data zone as the source zone, and the newly
created IJK-ordered zone as the destination zone. Set any other parameters as desired (see Data
Interpolation for details).

9. Select the Compute button to perform the interpolation.

Once the interpolation is complete, you can plot the new IJK-ordered zone as any other 3D volume
zone. You may plot iso-surfaces, volume streamtraces, and so forth. At this point, you may want to
deactivate or delete the original irregular zone so as not to conflict with plots of the new zone.

Figure 9 shows an example of irregular data interpolated into an IJK-ordered zone, with iso-surfaces
plotted on the resultant zone.

Figure 9. Irregular data interpolated into an IJK-ordered zone.
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Part 2: Loading Your Data

Loading Data
Tecplot Focus can load data from files on your local machine or accessible from a network file share
using modules called loaders, each of which understands data in a particular format. A number of
loaders are provided with Tecplot Focus for commonly-used CFD and general scientific and
engineering formats as well as various Tecplot formats. See Loading Data Using a Loader.

Loading Data Using a Loader

Use the File→Load Data command to load a data file using the Load Data dialog, shown below.

Normally, this dialog works slightly differently on Windows and non-Windows platforms. The controls
at the bottom of the dialog are different. For example, this is the lower portion of the dialog as seen on
Linux.
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On Windows, you can switch to this version of the Load Data dialog by choosing Options→Use
Extended Load Data Dialog. Using this version of the dialog on Windows may be slower to navigate
depending on your network; however, you may want to try it if you regularly load multiple data files
from more than one directory.

On any platform, you may use the Load Data dialog to navigate to the file you wish to open, or simply
type or paste the filename or the full pathname of the file in the File Name field.



If the file you are loading is a Tecplot-format file, you may also load it by simply
dragging it from your file manager (e.g. Windows Explorer or Mac Finder) into the
Tecplot Focus workspace, bypassing the Load Data dialog entirely. You can also load
data files via the macro language; refer to $!READDATASET in the Scripting Guide for
details.

The Files of Type menu below the file list allows you to choose a data loader corresponding to the
format of data file that you wish to load, or you may select All Files to see all the files in the directory
and have Tecplot Focus automatically choose a loader for you if possible. When you choose a loader,
the file list changes to show only files that can be loaded by that loader.



If the name of the file you are trying to load has a non-standard extension, type the
extension in the File Name field like "*.foo", then press Enter to show all files having
this filename extension. You may also enter "*.*" to show all files regardless of their
extension, or choose All Files from the Files of Type menu to have Tecplot Focus try
to determine which loader is needed.

• If the chosen loader needs only a single file, simply navigate to and select the file you want to load
in the file list and click Open.

• If the chosen loader supports or requires loading more than one file at once, or you are choosing
from All Files or All Supported Files, you may select multiple files. On Windows (using the
standard version of the Load Data dialog), you can choose additional files by holding down Control
or Shift while clicking the second and subsequent files in the dialog, then clicking Open.

On other platforms (or on Windows using the extended version of the Load Data dialog), the Add to
List button becomes enabled. Select each file to be loaded and click Add to List to add it to the
Additional Files list. You may choose files from more than one directory. You may also remove
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selected files from the list by clicking the Remove All or Remove Selected button. Click Open to
open all the files using the loader you chose.

When using All Files or All Supported Files, all of the files should be in the same format. If the
loader for that format cannot load multiple files, you must load them individually, appending the
second and subsequent files.

• Some file formats are very flexible, so you may need to specify exactly how the data was written in
order for Tecplot Focus to load it correctly. Some loaders always display an options dialog, since
they are needed almost every time. Others only display an options dialog when you request it. On
Windows (using the standard dialog), click the menu triangle next to the Open button and choose
Open With Advanced Options instead of clicking Open after selecting your file(s). On non-
Windows platforms (or when using the extended dialog on Windows), an Advanced Options
checkbox becomes enabled and may be selected before clicking Open. The loader’s options dialog
is then displayed before loading the selected file(s).

Available file formats include:

• DEM Loader

• DXF Loader

• Excel Loader

• General Text Loader

• HDF Loader

• HDF5 Loader

• PLY Loader

• Tecplot Data Loader

• Tecplot Layout Loader

• Text Spreadsheet Loader

Loading by Position

In most CFD data formats, it is valid to have multiple variables with the same name. When loading
such a file, Tecplot Focus warns you that this situation exists and offers to load the variables by
position: each variable will be identified by the order in which it appears in the file rather than by its
name. This may make some aspects of working with the data different or more complicated.

For example, when manipulating data using equations, you must use the V# syntax to refer to such
duplicate variables, rather than the {VariableName} syntax, as the latter cannot uniquely identify the
variable. (See Data Alteration through Equations.) Macros and Python scripts may also be affected.

When possible, we advise obtaining a data file with a unique and consistent name for each variable,
for example by adjusting your solver’s configuration.
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Appending or Replacing Data

You may append new data to your dataset at any time by choosing File→Load Data. You cannot
append a grid file that contains only FE connectivity data without appending a solution file along with
it. In addition, to append a solution file you must also append a grid file at the same time. In this case,
the grid file must be loaded before the solution file.

Some loaders allow you to choose how you wish to append or replace data.

Depending on the circumstances, you may have the following choices:

Replace Data in Active Frame and Reset Style

The new data is loaded in place of the existing data. The plot styles are reset to their defaults, as if
the new data was loaded immediately after starting up Tecplot Focus.

Replace Data in Active Frame and Retain Style

The new data is loaded in place of the existing data. The plot styles in effect for the existing data are
applied to the new data as best as possible and in some cases some style settings may need to be
turned off or reassigned. The configuration option $!COMPATIBILITY USENAMESFORVARIABLEASSIGNMENTS,
when set to TRUE will make style settings match variable assignments based on the variable names,
regardless of their position in the old and new datasets. If $!COMPATIBILITY
USENAMESFORVARIABLEASSIGNMENTS is set to FALSE then the variable offsets from the old style
assignments will be used with the new data regardless of the old and new variable names. This
option works best when the incoming data is similar to the existing data.

Replace Data in All Shared Frames and Retain Style

This is the same as "Replace Data in Active Frame and Retain Style" except the same operations and
rules are applied to all frames that share the same dataset with the active frame.

Append Data to All Shared Frames

The active dataset is shared among multiple frames. Choose this option to append the newly loaded
data in all the frames. Default plot styles are used.
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Append Data to Active Frame

Choose this option to append the newly loaded data in the current frame.

Replace

When loading a layout, replaces the existing layout with the new one.

Append

When loading a layout, creates new frames for the dataset referenced in the new layout.

Cancel

Do not load the data and return to the Tecplot Focus workspace.

Loading and Combining Variables from Multiple Files

In Tecplot Focus, you can load multiple data files in two different ways:

• All at once by choosing all the files in the Load Data Files dialog.

• By appending data to the data that has already been loaded.

The Variable Load and Combine dialog appears when loading multiple data files in certain formats,
whether you load the files all at once or append new data to previously-loaded data, if the names of the
variables in the data files do not match. The dialog allows you tell Tecplot Focus which variables (if
any) have the same meanings across the files, as well as which variables should not be loaded at all.
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This feature works only with data in the following formats:

• Tecplot - text (.dat), binary (.plt), and subzone (.szplt)

• CGNS

• EnSight

• Excel

• HDF and HDF5

• Text (using the Text Spreadsheet or General Text loader)

• TRIX

• VTK

The Variable Load and Combine dialog appears only when the files you are loading do not all contain
exactly the same variable names (or, when appending, if the variable names in the file being loaded do
not exactly match those of the data already loaded). When all variable names match in the files being
loaded, this dialog does not appear; instead, Tecplot assumes that all the variables have the same
meaning in all the files.


If a file you are loading or appending has multiple variables with the same name,
Tecplot Focus asks if you want to load them by position. See Loading by Position.
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When loading by position, you cannot combine variables (and do not need to).

The dialog allows you to indicate that variables with different names have the same meaning (referred
to as combining the variables) in two different ways.

• Select variables having the same meaning, one in each list, then click Combine.

• Apply a previously-defined variable alias file that indicates which variable names have the same
meaning.

The two methods can also be used together. For example, you might first apply a variable alias file that
deals with the most common equivalent variables in your typical data sets, then clean up any
remaining variables (uncommon variables, or variables that don’t always have a well-defined
meaning) by hand.

The dialog has the following parts:

• The Available Variables list initially displays all the variables declared in the files you are loading.
As you choose variables to combine or load, they move to the Variables to Load list. Any variables
remaining in the Available Variables list when you click OK are not loaded.

• The Variables to Load list displays variables that are slated to be loaded in the current load
operation. If you are appending data, variables that have already been loaded in previous load
operations also appear here. Variables are colored according to the following rules:

Black

Variable is not combined; it is either already loaded, or will be loaded

Blue

Variable appears under the same name in multiple files and has been automatically combined

Green

Variable has different names in different files and has been combined by the user, either using
the Combine button or by applying a variable alias file

• The Add Selected button moves a variable from the Available Variables list to the Variables to Load
list, adding it to the set of variables that will be loaded in the current operation. The added
variable’s name appears in black. By default, variables that are unique to one file are not loaded.

• The Add All button moves all variables listed in the Available Variables list to the Variables to Load
list, indicating that you want to load all of them in the current operation. The variable names
appear in black.

• The Combine button combines the variable selected in the Available Variables list with the variable
selected in the Variables to Load list, indicating that the variables have the same meaning. The
variable is given a name derived from both the selected variables, and this name appears in the
Variables to Load list and is colored green. See Combining Variables Manually.

• The Remove button removes the selected variable from the Variables to Load list, if possible. If the
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variable is already part of the current data set (that is, you are appending data, and the variable is
from a previous load operation), it cannot be removed.

When removing a combined variable, all the original variables that were combined are separated
and moved back to the Available Variables list, again except for any which have already been
loaded from a previous operation.

• The Apply button applies a variable alias file to the variables being loaded, combining variables if
they are defined in the file as having the same meaning as another variable. See Creating and Using
a Variable Alias File.

• Click OK to proceed with loading after setting up the variable combining the way you want it.

Variables that have the same name are automatically combined, as this is almost always what you will
want to have happen. They appear in blue in the Variables to Load list. If you do not want this to
happen, load the files one at a time and, before loading the file with duplicate variable names, rename
the existing variables you do not want to combine with newly-loaded variables of the same name. (You
can rename variables by double-clicking them in the Data Set Information dialog.

Combining Variables Manually

To combine two variables manually, telling Tecplot Focus that they have the same meaning, you select
the first variable in the Available Variables list and the second in the Variables to Load list, then click
the Combine button. The combined variable is added to the Variables to Load list and given a name
consisting of both original variable names separated by a semicolon.

If the variables to be combined are in the Available Variables list, as may be the case when loading all
the files at once instead of appending, select one in the Available Variables list and click Add Selected
to select it to be loaded. Then combine them as above.

If there are more than two variables that have the same meaning, combine the first two, then select the
combined variable in the Variables to Load list and combine it with the next variable having the same
meaning in the Available Variables list as above.

You may combine multiple sets of variables at a time. If you select more than one variable in the
Available Variables list, and the same number in the Variables to Load list, clicking Combine combines
the first selected variable from the Available Variables list with the first selected variable from the
Variables to Load list, the second with the second, and so on.

You may not combine variables from the same file.

Creating and Using a Variable Alias File

The variable_aliases.txt file found in the Tecplot Focus installation directory lists sets of variables
that should be considered equivalent. See Custom Files loaded on Startup for information about how
variable aliases are loaded.

The variable_aliases.txt file must begin with a !VA 1 line to indicate that it is a variable alias file

78



(format version 1). On subsequent lines, the  character indicates the beginning of a comment;
everything following the on a line is ignored. Variable aliases are specified by listing the equivalent
names on a line separated by semicolons. For example:

#!VA 1
p;press;pressure
t;temp;temperature # temperature variables in Celsius
m;mach
a;alpha;aoa # angle of attack in radians
b;beta;aos # angle of sideslip in radians

Variable names found in this file are case-insensitive. Excess whitespace is ignored.

When you click Apply, Tecplot Focus combines variables as indicated in variable_aliases.txt. Where
two or more files contain variables whose names appear on the same line, these variables are
combined, and the resulting Tecplot Focus variable is given a name containing the original variable
names (as they appear in the datasets being loaded) separated by semicolons. The new variables then
appear in the Variables to Load list in the dialog.

For example, if you load two files with the variables "P" and "Pressure," and the lines shown above
appear in the variable_aliases.txt file, when you click Apply, these two variables appear in the
Variables to Load list as a single variable called either "P;Pressure" or "Pressure;P" depending on the
order in which the files were loaded.

If multiple lines in variable_aliases.txt might apply to the data sets being loaded, these conflicts are
resolved based on the order in which the files are loaded. For example, if you load three files
containing variables "M," "Mach," and "Mass," in that order, and variable_aliases.txt contains lines
equating "M" with "Mach" and also "M" with "Mass," the resulting data set would have a variable
named "M;Mach" and a second variable "Mass." Because the file containing the variable "Mach" was
loaded before the file containing the variable "Mass," "M" was combined with "Mach" when that file
was loaded and cannot also be combined with "Mass."

You may change the names of combined variables after loading the data by double-clicking the
variable in the Data Set Information dialog (Data Set → Data Set Info).

All Files and All Supported Files
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With All Files and All Supported Files, Tecplot Focus tries to automatically choose a loader based on
the names of the files you select.

With All Files, you see literally all of the files in the directory you’re browsing. With All Supported
Files, you see the files that Tecplot Focus knows it can load using any of the installed loaders, based on
the files' names, but excluding other files. Either choice allows you to load files without having to
specify in advance what loader will be used.

These options are particularly useful if you regularly work with multiple data file formats, or (in the
case of All Files) if your data files often have unconventional names, such as a nonstandard or absent
filename extension.

If the names of the selected files unambiguously indicate a single data file format, the appropriate
loader is automatically chosen and the data is loaded without further ado. If more than one loader
might be able to open the files, or if the files chosen do not have names that are recognized as
belonging to a particular loader, the Choose Loader dialog appears. This dialog may recommend one or
more loaders in a "Suggested Loaders" section at the top of the list. Choose the loader to be used, then
click OK.

All selected files must be in the same format.

DEM Loader

The DEM Loader allows you to load Digital Elevation Map files that have the same file format as the
U.S. Geological Survey’s standard DEM format. The DEM Loader will not accept Spatial Data Transfer
Standard (SDTS) formatted data.

DEM files are available on the Web for a number of states within the U.S. For more information, refer
to www.webgis.com/terr_us1deg.html

The DEM Loader first launches a multi-file selection dialog. After choosing one or more DEM files to
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load, you are presented with a simple dialog where you can set the I and J-skipping. For large DEM
files, you may want to set both of these to be 10 or more.

DXF Loader

The DXF Loader add-on can import AutoCAD® DXF™ (drawing interchange) files. When importing a
file, Tecplot Focus creates an appropriate geometry for each of the following entity types:

• Text

• Lines

• Arcs

• Circles

• Points

• Solid

• 3D faces



When importing a DXF file, no zones are created. Instead, the geometries representing
each entity type are simply added to the frame. Be aware that a typical DXF file can
contain several thousand geometries, and these are all included when you save a
layout file.

Load DXF File Dialog

The Load DXF File dialog has a variety of features. You can select any of the following:
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Import

Select any or all geometries to import: Text, Lines, Arcs, Circles, Points, Solids, 3D Faces.

Font

Select the font to use for text. (See Font Folders and Fallback for more information on how fonts
work with Tecplot Focus.)

Attach Imported Items to Zone

Specify a zone to which all imported geometries will be attached. Clicking the Select Zone button
produces a menu of zone options.

Polylines/Import as 2D

All lines and polylines are stored with three coordinates in DXF files. If you select this option, the
loader will add 2D line geometries for all lines and polylines in the DXF file (the third coordinate
will be ignored).

Polylines/Import as 3D

If you select this option, the loader will add 3D line geometries for all lines and polylines in the DXF
file. To view a 3D DXF file, create or load a 3D zone, import your DXF file, then choose Fit
Everything from the View menu.

Hide Invisible Layers

If this option is checked, objects in layers that are "off" in the DXF file will be imported with the
background color.
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DXF Loader Limitations

The DXF Loader does not create any field data. Loading a DXF file only adds geometries to your
existing frame.

Since most geometries in Tecplot Focus are 2D, best results will be obtained by loading "flat" DXF files,
such as maps.

Binary AutoCAD® DWG™ are not supported in this release.

Excel Loader

The Excel Loader can read numeric data from .xls files for Microsoft® Excel® version 5.0 or higher.

 The Excel Loader is available for Windows platforms only.

The Excel Loader is intended primarily for users who record experimental or simulation data using
Excel. Your Excel file must contain only values (no equations). We recommend the use of the Excel add-
on from the Util/Excel folder as an easier method to open Excel data with Tecplot Focus (see Excel
Add-In). Use the Text Spreadsheet loader for delimited files (Text Spreadsheet Loader).

If your spreadsheet is arranged as Table Format or Carpet Format, the Excel Loader is a point-and-click
operation. Once you have selected an Excel file to load, the Excel Loader leads you through a series of
dialogs, prompting you to specify a variety of attributes, including the data format in the Excel
spreadsheet, the variables to be read, and zone information.


Refer to Excel Add-In for instructions on loading Excel data into Tecplot Focus from
Excel.

Spreadsheet Data Formats

The Excel Loader will automatically identify blocks of data in Table Format or Carpet Format. The
loader will list blocks of data in standard notation for Microsoft Excel. For example, a block found on
worksheet sheet1, cells A1-D8, is listed as follows: (sheet1! A1:D8).

If you select a user-defined format (or if the loader did not identify any carpet or table blocks), you will
be prompted to enter the names and number of variables, and one or more zones and associated
properties. You will also need to enter the location of the field data in the spreadsheet for each zone.

Table Format

Use Table format for data that will be plotted in line plots (i.e. data with an independent and one or
more dependent variables). Many spreadsheets containing data to be plotted in 2D or 3D Cartesian
plots will also satisfy the conditions of table format.

A table formatted dataset has the following characteristics:
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• The dataset is arranged in one or more adjacent columns.

• Each column is the same length.

• Each cell contains numeric data.

• The first row is a header row containing the variable name for its corresponding column.

• The spreadsheet dataset is imported as a single I-ordered zone in POINT format with N variables,
where N is the number of columns in the table.



The block of data must be surrounded by empty cells, text-filled cells, or table
boundaries. The loader will not recognize a block of data as being in table format if
any cell adjacent to the block contains a number.

The block of data can contain no empty cells. An empty cell will prevent the loader
from recognizing the block. You can satisfy this condition by filling blank cells with
0.0.

Figure 10 shows a block of data in table format in Excel.

Figure 10. A block of data in table format.

Carpet Format

Use carpet format for spreadsheet data to be plotted in a 2D or 3D Cartesian plot. The carpet formatted
dataset, shown in Figure 11, has the following characteristics:

• The spreadsheet dataset is imported as an IJ-ordered zone. See XY and Polar Line Plots.

In Figure 11, the spreadsheet is imported as I=4 and J=4. The three variables are X, Y, and V. In the
spreadsheet cell 2B is index 1, 1, cell 3B is index 2, 1.

• The top row in the block contains the values of the X-variable, the first column of the block
contains the values of the Y-variable, and the V-values are the interior data. This format is useful if
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your dataset was generated from a function f, such that f(X, Y) = V.

• The block is a rectangular arrangement of numeric data in the spreadsheet, with a blank cell in the
upper left hand corner.

• There must be no blank cells within the block of data. An empty cell will prevent the loader from
recognizing the block. You can satisfy this condition by filling blank cells with 0.0.

• The block of data must be surrounded by empty cells, text-filled cells, or table boundaries. The
loader will not recognize a block of data as being in carpet format if any cell adjacent to the block is
filled with a number.

Figure 11. This carpet table shows values as a simple arithmetic function of X and Y.

Other Formats

The Other format option gives you a great deal of flexibility in loading data into Tecplot Focus. A series
of dialogs leads you through the process of describing your data, similar to the way you would specify
this information in a Tecplot-format ASCII file.

Default format

The Excel Loader offers a semiautomatic option that requires only that you specify the upper left
and lower right corners of your data block. Once you’ve specified those corners, it handles the data
in the same way that Tecplot Focus handles an unformatted block in an ASCII file. It assumes one
zone of I-ordered data in POINT format.

Custom format

Using the Custom format option, you can specify characteristics of your dataset. Custom format has
the following features:

• It allows you to work with spreadsheets containing blank cells or text cells.

• For XY, IJ, and IJK-ordered data, specify the boundaries of the block to load, and how many data
points there are within that block (IMax, JMax, KMax).

• For finite element data, the number of data points is implied by the number of nodes and
number of elements.

• Allows you to load blocks of cells that you delimit interactively.

• It is the only option for loading finite element, IJK-ordered, or zone data from Excel. If you want
to read data from an Excel spreadsheet into more than one zone, you must use custom format.
By default, all data read is put into a single I-ordered zone.
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Excel Loader Restrictions

A block of data is a rectangular group of numbers in the spreadsheet. The Excel Loader places the
following restrictions on blocks:

• Carpet and table format (which the loader detects and loads automatically) are narrowly defined.
All other formats must be loaded on the user-defined pathway.

• Numeric cells within each block should contain only numbers or numeric characters such as +, -,
and so forth. A cell containing X=34 is interpreted by the loader as text, because it begins with text.

• Cells containing formulas (therefore displaying calculated values) will be skipped by the loader.
You can convert the formulas to values within Excel, by pasting your table using the "Paste Special"
function, with "values only" selected.

• The spreadsheet file must have been written by Excel Version 5.0 or higher. For newer versions of
Excel (Office 2007 and later) that save in .xslx format by default, please switch to the older .xsl
format when saving your file.

General Text Loader

The General Text Loader add-on allows you to read ASCII text data files in a variety of formats. You can
specify variable and dataset title information or indicate specific places to read them from in your data
file. Instruction settings for reading a type of file can be saved and restored so they do not have to be
entered again each time a new file of the same type is loaded.

The following options are available:
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Filename

The name of the file to be loaded. This is automatically filled in with the name of the file selected in
the Load Data dialog, but may be changed using the Browse buton.

Titles

Launches the Dataset Title dialog, which allows you to specify dataset title properties.

Variables

Launches the Variable Import Instructions dialog which allows you to specify dataset variable
properties.

Data

Launches the General Text Loader: Data dialog which allows you to specify dataset field properties.

General Filters

Launches the General Text Loader: Filters dialog which allows you to specify general filters when
reading your file.
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Configuration File List

This list shows available configuration files. Configuration files can be edited using a text editor,
although this is not usually necessary and is not recommended. The format of these files is listed on
the Configuration page.

Load

Loads a single configuration file from any location.

Save

Saves a single configuration file to any location.

Rename

Renames a configuration file.

Delete

Deletes a configuration file.

New

Creates a new, untitled configuration file.

Data Preview

View Raw Data

This displays the data exactly how it looks in the file without any processing.

View Processed Data

This displays the processed and filtered data that will be loaded.

View Options

Launches the General Text Loader: View Options dialog.

Dataset Title

The Dataset Title dialog allows you to specify options for General Text Loader titles.
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Use Title

Manually enter the dataset title, rather than have General Text Loader scan the file for it.

Use line number

Enter the line number of the dataset title in the file. The General Text Loader skips white space on
the line until text, and then reads until the delimiter indicated is found. To include spaces in the
title, enclose them in double quotes.

Use first line containing keyword

Enter a keyword for the dataset title line. The title will read the first line containing this keyword
(case insensitive). General Text Loader searches for a title on this line in the following order, (unless
the delimiter is specified as fixed):

1. First, it will look for any text enclosed in double quotes. If it finds this, then the enclosed text will
be read as the title.

2. If no text in double quotes is found, the first non-white space text after the keyword ending with
the indicated delimiter will be used.

Text Delimiter

The text delimiter indicates when the end of text has been reached. You can set it to one of the
following:

Auto

Space, tab, comma, semicolon.

Fixed

Each width number of characters on the line is a token field. White space is removed from the
beginning and end of the field.
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Width

If the delimiter is fixed, enter the width of each field here.

Variable Import Instructions

The Variable Import Instructions dialog of the General Text Loader allows you to scan for the
location of the variable names in the data file, and enter which variables to load.

Scan for variable names

Specify the following:

Start line

Enter the starting line of variable names in the file.

End line

Enter the ending line of the variable names in the file. This is typically the same as the starting
line.

Delimiter

The delimiter indicates when the end of each variable name has been reached. You can set it to
one of the following:

Auto

Space, tab, comma, semicolon.
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Fixed

Each 'width=n' number characters on the line is a variable. White space is removed from the
beginning and end of the field. For example, if the line length is 60 and the width is ten, the
columns 1-10, 11-20, 21-30, and so forth, are variable names. Spaces are removed from the
beginning and end of the variable names.

Width

If the delimiter is fixed, enter the width of each field here.

Enter Variable Names

Select this option to enter a list of variable names in the dialog box. Variable names should be
separated by carriage returns.

Select Variables to Load

Launches the Variable to Load dialog.

Variables to Skip

Displays a list of variables that will be skipped.

Variables to Load

Displays a list of variables that will be loaded.

Use the Move, Move All, Remove, or Remove All buttons to edit the "Variables to Load" list.

General Text Loader: Data

The Data Import Instructions dialog of the General Text Loader allows you to specify the location of
the data names in the data file, and what data to load.
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Start Identification

First all-numeric line

Select if the data begins at the first line of a file that contains only numbers. If you have specified
multiple zones, all non-numeric lines will be skipped at the beginning of each zone.

First line after line with keyword

Select if the data begins at the first non-blank line after the line containing the specified
keyword. The keyword is case insensitive.

Start at line number

Select to specify the line number where the data begins. Blank lines are ignored in the data
section.

End Identification
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All lines up to first non-numeric line

Select if the data ends at the first non-blank line containing any text.

Stop at line number

Select to specify the line number where the data ends.

All lines up to line with keyword

Select if the data ends at the first line before the line with the specified keyword. The keyword is
case insensitive.

End of file

Select if the data ends at the end of file.

Data Identification

Point format

In this format all values of all variables are given for the first point, then the second point, etc.

Block format

In this format all values for the first variable are given, then all values for the second variable,
etc.

Data value delimiter

The data value delimiter indicates when the end of a data value has been reached. You can set it
to one of the following:

Auto

Space, tab, comma, semicolon.

Fixed

Each 'width=n' number characters on the line is a token field. White space is removed from
the beginning and end of the field. For example, if the line length is 60 and the width is ten,
the columns 1-10, 11-20, 21-30, and so on, are token fields.

Width

If the delimiter is 'fixed', enter the width of each field here.

Data Dimension

If the data dimensions are entered, General Text Loader adds zones as necessary depending on the
number of data points found in the file. There must be an equal number of data points for each
zone (equal to the product of the IJK dimensions).

Auto-Calculate IMAX

The I-dimension is calculated based on the number of data points found. J and K-max are set to
one.
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Specify Dimensions

Specify the I, J, and K-dimensions for the data. There must be enough data points found in the file
to match the indicated dimensions.

Allow Multiple Zones

If checked, General Text Loader will attempt to read more than one zone from the data file.

Zone ends on line with keyword

If Allow multiple zones is selected and Auto-calculate IMax is selected, then you must enter a
keyword here to mark the end of one zone and the beginning of the next. Zones are ended when
a line containing this text is found.

Ignore non-numeric tokens

If checked, then any non-numeric information in the data sections is ignored. If not checked,
General Text Loader displays an error if any non-numeric data is found in the data section.

General Text Loader: Filters

Use the General Filters dialog of the General Text Loader to filter the data file.

Ignore All Lines Starting With

If checked, all lines beginning with the entered string are ignored.

Ignore All Lines Containing

If checked, all lines containing the indicated text are ignored.

Ignore Character Column Position(s)

If checked, then the entered columns are ignored when scanning the file. Columns are entered as a
single number or a hyphenated range, one or more of which may be separated by commas.


If there are tabs in the data file, they are not expanded in this filter. For example, if
column 1 is a tab and you wish to skip column 2, you should enter 2, even though a
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text editor will show more than one space after expanding the tab.

Ignore Specific Lines

If checked, entered lines are ignored when scanning the file. Lines are entered as a single number
or a hyphenated range, one or more of which may be separated by commas. You may also use "end"
to specify the last line of the file.

Specify Values for Blanked Cell

If checked, you can specify a value which the loader uses for blank cells.


This option is only available if the data delimiter is a comma or semicolon. You can
change the data value delimiter using the Data Import Instructions dialog.

General Text Loader: View Options

The View Options dialog of the General Text Loader allows you to specify the data display.

General Options

Limit lines displayed

Limits the number of lines displayed in the preview window. For large files, you may want to set
this to a number less than the total number of lines. The fewer number of lines, the faster the
preview display.

Do not limit

If you select this toggle, the entire file will be displayed in preview mode.
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Auto Process

If selected, General Text Loader automatically refreshes all information about the file whenever
any loader settings are changed. For very large files (multi-megabyte), this option is not
recommended, since re-scanning a large file can be time consuming.

Processed Data

Show variable names and data

If selected, variable names and processed data will be displayed in the preview window.

Show variable names only

If selected, only variable names will be displayed in the preview window.

Show all non-processed lines

If selected, all lines which will not be loaded will be displayed in the preview window.

Show data in columns

Shows the data in columns where each column is a variable.

Show data in blocks

Shows the data in blocks where each block is a variable.

General Text Loader Configuration File

A configuration file contains all of the instructions that tell the General Text Loader how to load a
particular type of text file. This information is collected from the dialog fields and written to a file
when you click Save on the main dialog. The configuration file format is similar to the Tecplot macro
language. Configuration files for the general text loader are ASCII text files which use a command set
that can describe all loading instructions. Normally you do not need to edit these files, as they are
automatically written by the loader when you select New on the main dialog.

 Editing these configuration files by hand is not recommended.

General Text Loader CONFIGFNAME Command

When reading a dataset using General Text Loader, instead of specifying individual parameters in
$!READDATASET, you may use the CONFIGFNAME command. This consists of:

CONFIGFNAME = <string>
VERSION = <integer>
# version of the template file (default is 100)
# Note: changing the version number may cause unpredictable behavior
TITLE
{
   SEARCH = [NONE|LINE|KEYWORD] # default = NONE
     NAME = <string>
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# default = "New Dataset", ignored if SEARCH is not NONE
     LINE = <integer> # 1-based, ignored if SEARCH is not LINE
  KEYWORD = <string> # ignored if SEARCH is not KEYWORD
DELIMITER = [AUTO|TAB|SPACE|SEMICOLON|COMMA|FIXED]
    WIDTH = <integer> # Valid only if DELIMITER = FIXED
}

VARIABLES
{
    SEARCH = [NONE|LINE]
     NAMES = <string> # ignored if SEARCH is SCAN
                       # <string> is a comma separated string
    LOADED = <all|n1,n2,...nn> # list of variables to be loaded
 STARTLINE = <integer> # 1-based, ignored if SEARCH=NONE, default = 1
 {
   STARTID = [FIRSTNUMERICLINE | LINE | KEYWORD]
   {
     KEYWORD = <string> # ignored if STARTID is not KEYWORD

     ENDLINE = <integer> # 1-based, ignored if SEARCH=NONE, default = 1
   DELIMITER = [AUTO|TAB|SPACE|SEMICOLON|COMMA|FIXED]
       WIDTH = <integer> # Valid only if DELIMITER = FIXED
   }
   DATA
   {
     IGNORENONNUMERICTOKENS = <boolean> # default = TRUE
     IMPORT
     LINE = <integer>
     # 1-based, ignored if STARTIDENTIFICATION is not LINE
   }
   ENDID = [FIRSTNONNUMERICLINE | LINE | KEYWORD]
   {
     KEYWORD = <string> # ignored if ENDID is not KEYWORD
        LINE = <integer> # 1-based, ignored if ENDID is not LINE
   }
      FORMAT = [POINT|BLOCK] # default POINT
   DELIMITER = [AUTO|TAB|SPACE|SEMICOLON|COMMA|FIXED]
       WIDTH = <integer> # Valid only if DELIMITER = FIXED
 }

 DIMENSION
 {
    AUTO=<boolean> # default = TRUE
    IMAX=<integer> # ignored if AUTO = TRUE, default = 1
    JMAX=<integer> # ignored if AUTO = TRUE, default = 1
    KMAX=<integer> # ignored if AUTO = TRUE, default = 1
    USEMULTIPLEZONES = <boolean> # ignored if AUTO = TRUE, default false
    KEYWORD=<string> # ignored if USEMULTIPLEZONES = FALSE
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 }
}
GLOBALFILTERS # filters are applied cumulatively, so lines matching
# any of the criteria are filtered
{
COMMENT = <string> # ignore lines beginning with <string>
NUMBER = <integer> # ignore all lines starting with line number
<integer>
KEYWORD = <string> # ignore all containing <string> (case insensitive)
COLUMNS = <list> #<list> is a comma separated list of number ranges
# example: "1-80,100-end", etc. Must be in double quotes
ROWS = <list> # same as above
USEBLANKCELLVALUE = <boolean> # if TRUE, then the value of blank cells
is BLANKCELLVALUE
BLANKCELLVALUE = <double> # blank cell value. Ignored if
USEBLANKCELLVALUE is FALSE
}

Where <string> is a file name or file path. Settings will be loaded from the file name specified in
<string>. This command is only allowed in conjunction with the $!READDATASET command as described
below. It may not be used inside a configuration file.

For example, instead of:

$!READDATASET '"C:\test.txt" "VERSION=100 FILEEXT=\"*.txt\"
FILEDESC=\"general text\" "+""+"TITLE{SEARCH=NONE NAME=\"New
Dataset\" LINE=1 DELIMITER=AUTO WIDTH=10
}"+""+"VARIABLES{"+"SEARCH=LINE LOADED= All STARTLINE=1 ENDLINE=3
DELIMITER=SEMICOLON WIDTH=5
}"+""+"DATA"+"{"+"IGNORENONNUMERICTOKENS=TRUE
IMPORT"+"{"+"STARTID=LINE {"+"LINE=4
}"+""+"ENDID=FIRSTNONNUMERICLINE {"+"LINE=1 }"+""+"FORMAT=IJKPOINT
DELIMITER=AUTO WIDTH=1 }"+""+"DIMENSION"+"{"+"AUTO=TRUE
CREATEMULTIPLEZONES=FALSE
}"+"}"+"GLOBALFILTERS{"+"USEBLANKCELLVALUE=TRUE
BLANKCELLVALUE=0.000000 }"'
DATASETREADER = 'General Text Loader'

Using the CONFIGFNAME command, you can write:

$!READDATASET ' "myfile.dat"
"CONFIGFNAME=c:\config_files\myconfig.lgc" '
# contains all of the instructions in the example above
DATASETREADER='General Text Loader'
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Components of the Configuration File

All General Text Loader configuration files must start with the line:

#!TECPLOT_LOADGEN

Instruction Syntax

Each instruction file contains commands which describe the loading instructions.

Comments

Any text following # to the end of the line is ignored.

String Format

The <string> parameter must be enclosed in double quotes. You can include a double quote
character in the string by preceding it with a backslash \. For example:

• "This is a normal string"

• "This is a \"quote\" inside a string"

List Format

The <list> parameter type is defined as one or more number ranges, separated by commas, enclosed
in double quotes. A number range may be a single number or two numbers separated by a dash.
Optionally, you may use "end" to indicate the last valid number. For example:

• "1"

• "1,2-7,3"

• "10-end,3,2-5"

Command List

The commands in the file may appear in any order, and any command may be divided into any
number of lines (that is, all white space, including carriage returns, is ignored).

HDF Loader

The HDF Loader add-on can load 1D, 2D, and 3D Scientific Data Sets (SDS) from HDF files.[1] When a
dataset from an HDF file is imported, the file is scanned and a list of all SDS in the file is displayed in
the Scientific Data Sets to load portion of the HDF Loader dialog. Select one or more SDS to import.
Every SDS that you select must have the same dimension. A rectangular I, IJ, or IJK-ordered zone
(for 1, 2, or 3D data, respectively) is created for each SDS that you select to load.

The HDF Loader dialog has the following options:
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Scientific Data Sets to load

Select one or more SDS’s to load. Each SDS that you select must have the same rank (dimension).

I-Skip

Select the I-Skip value. A skip value of one loads every data point, a skip value of two loads every
second data point, and so on.

J-Skip

Select the J-Skip value.

K-Skip

Select the K-Skip value.

Select File

Select an HDF file.

Attributes

Displays attributes of each SDS found, such as number type, rank, label, and so on.

You may also click Select File to choose a different file.

HDF Loader Limitations

The HDF Loader can import only Scientific Data Sets from HDF files, and these are imported in a
manner similar to NCSA’s own HDF viewer. The way in which the data file is interpreted cannot be
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altered in this release of the loader.

HDF5 Loader

The HDF5 loader add-on allows you to import general HDF5 files into Tecplot Focus. The loader
provides a mechanism for importing generic data from multiple HDF5 datasets or groups. The HDF5
loader will load datasets within user selected groups, load one or more user selected datasets to one
zone, load multiple user selected datasets to multiple zones, execute macros after data has been
loaded, create implicit X, Y, and Z grid vectors as needed, sub-sample loaded data, and reference user
selected vectors for X, Y, and Z grids. Datasets must be ordered data. The HDF5 library used is version
1.12.0.

Data Selection

One or more files may be opened if all selected files have an identical hierarchy. Hierarchy information
for the selected HDF5 files is displayed in the form: /group/[group]…/dataset - the dimension of each
dataset is displayed immediately following the dataset name. In this window, one or more datasets or
groups may be selected for loading.
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Importing/Loading Data

Datasets may be loaded using one of three methods: 1) Loading Multiple Datasets to One Zone (default),
2) Loading Multiple Datasets to Separate Zones, or 3) Loading Datasets by Group.

Loading Multiple Datasets to One Zone (default)

Loading multiple datasets to one zone is the default method of importing HDF5 files. Using this
method, the HDF5 loader will create one zone with N variables, where N is the number of HDF5
datasets selected. Selected datasets may have one to three dimensions. The dimension of loaded
Tecplot Focus variables will match the I, J, and K values of the selected datasets. Variable names are
assigned the corresponding names of selected datasets. All selected datasets must have equivalent
dimensions.

To import your data, select one or more datasets from the Available Datasets window. All selected
datasets must be identical in dimension; dataset dimensions are shown immediately to the right of
dataset names in the Available Datasets window.

Loading Multiple Datasets to Separate Zones

Using this method, the HDF5 loader will create N zones, where N is the number of datasets selected in
the Available Datasets window. Each zone contains one variable per selected dataset where each
dataset must have one to three dimensions. The I, J, and K values of each Tecplot Focus zone will match
the dimensionality of each selected dataset. Variable and zone names are automatically assigned.
Dimensionality may vary between selected datasets.

To import your data using this method, select the "Load to Separate Zones" toggle. Select one or more
datasets from the Available Datasets window. One zone will be created for each selected dataset and
each zone will contain exactly one variable (unless you selected Create Implicit Grid Values or
Reference Data Grids).

Loading Datasets by Group

Using this method, the HDF5 loader will create N zones with M variables, where N is the number of
groups selected in the Available Datasets window and M is the number of datasets in each group. The
I, J, and K indices of the Tecplot Focus variables will be equivalent to the respective dimension of
selected datasets. Datasets in any selected group must be equal in dimension; however, datasets may
be unequal in dimension between groups. When selecting multiple groups, all groups must contain an
equal number of datasets and dataset names must be identical between groups. The HDF5 loader will
only load datasets within the root directory or within a subgroup, i.e., the HDF5 loader will not load
data within nested groups.

To import your data using this method, select the "Load Datasets by Group" toggle. Press Select File to
open a HDF5 file. Select one or more groups from the Available Datasets window; all groups must
contain an equal number of datasets where all datasets have identical names between groups. The
number of selected groups determines the number of zones that load into Tecplot Focus. Zone names
will match the name of the corresponding group. Variable names will match the respective dataset
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name. Each zone will include as many variables as datasets per selected groups.

Additional Options

Additional options may be specified when loading HDF5 data into Tecplot Focus. These options include:
Using Macros, Sub-Sampling Data, Referencing Data Grids, and Grid Generation.

Using Macros

Macros may be defined within a HDF5 vector and placed in any group. Each character string in the
selected vector must be a valid one-line Tecplot macro. Macros are executed in the order encountered
after all data are loaded.

To run a macro defined as a character vector in your HDF5 file, select the "Run Macros in Selected
Group" toggle. Select the macro you want to execute from the Select Macro pull-down menu. Your
macro will run after your data has been successfully loaded into Tecplot Focus.

Sub-Sampling Data

The HDF5 loader will sub-sample the first, second, and third dimensions of loaded datasets
respectively as defined by the user. The default skip-value is 1. When specifying non-unitary skip
values, the dimensionality of all selected datasets must be equivalent. Datasets will be sub-sampled
using the user defined I-Skip, J-Skip, and/or K-Skip values – skip values must be whole numbers.

To sub-sample data in the first, and/or second, and/or third dimensions of selected datasets, change the
respective I-Skip, and/or J-Skip, and/or K-Skip values located in the HDF5 loader dialog. If the skip-
values are non-unitary then selected datasets must have equivalent dimensions.

Referencing Data Grids

The HDF5 loader allows users to specify X, and/or Y, and/or Z grid vectors. Selected vectors are used for
plotting all zones. Vectors are of dimension 1 and length M. The X grid vector length must be equal to
the first dimension of selected datasets, the Y grid vector length must be equal to the second dimension
of selected datasets, and the Z grid vector length must be equal to the third dimension of selected
datasets. The number of selected grid vectors must equal the rank of selected datasets.

To define the grid vectors, first toggle off "Create Implicit Grid Values" option, then click the Reference
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Data Grids button. In the Select Refernce Grid Vectors dialog that appears, select the vector you want
to use as the corresponding grid using the menus. You MUST toggle on "Use Data Grids". The number of
grid vectors you specify must equal the rank of selected datasets.

Grid Generation

The HDF5 loader can automatically create X, Y, and Z grid vectors as necessary for selected datasets.
Grid vectors will be of length equal to the corresponding dimension.

To automatically create X, Y, and Z grid vectors, accept the default setting of "Create Implicit Grid
Values" in the HDF5 loader dialog. The grid vectors will be created upon loading your data into Tecplot
Focus.

PLY Loader

Use this loader[2] to load 3D triangular surface files with the .ply extension. This format is often used to
store surfaces generated from tessellation of 3D range measurement data. Files may be either ASCII or
binary, but must contain both vertex and face elements (sections). This loader is included in your
Tecplot Focus installation.

Tecplot Data Loader

This section describes the process for loading Tecplot-format data files with the extensions .dat for
ASCII files and .plt for binary files. Some other products that write Tecplot binary files use the
filename extension .bin or .tec, and these are also recognized by the Tecplot-Format loader. (Refer to
the Data Format Guide for information on outputting data into Tecplot Focus file format.)

There are four ways to create and work with Tecplot-format data files:

Generate a Tecplot-format ASCII data file

Read the file into Tecplot Focus and work without conversion. If the dataset is altered, save it as an
ASCII data file. This method works well for smaller datasets where the convenience of an ASCII file
outweighs any inefficiencies.

Generate a Tecplot-format ASCII data file and convert it to a binary file with Tecplot Focus

Read it into Tecplot Focus, then save it as a binary data file, then work with the binary file. Once you
have saved a binary version, you can delete the ASCII version. This works well for large datasets
where ASCII inefficiencies are noticeable. See Data File Writing.

Generate a Tecplot-format ASCII data file, then convert it to a binary file with Preplot

Preplot, a utility program included with Tecplot Focus, converts ASCII to binary Tecplot-format data
files. Once the binary file is created, delete the ASCII version to save space. This works well for
identifying problems with data files, since Preplot’s error messages include precise details. This
method also works well in batch processing, or if the ASCII data files are generated on another
machine. (See the Data Format Guide for a description of Preplot.)
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Generate a Tecplot-format binary data file

Read the binary data file into Tecplot Focus and work without conversion. You must use routines
provided by Tecplot as part of the TecIO library to write Tecplot-format binary files from C or
FORTRAN programs. (See the Data Format Guide for complete details.)

Tecplot Data File Loading

The Tecplot Data Loader (accessed via File→Load Data) allows you to load ASCII (.dat) and binary
(.plt) Tecplot-format data files. For both kinds of files, Tecplot Focus supports full data files, grid files,
and solution files, where the file types are defined as follows:

Full

Full files contain both grid and solution data. Data files produced for Tecplot products versioned
2006 and earlier are treated as full data files. Full files can be loaded in any order.

Grid

Grid files contain static data for all zones. They have at least one variable or FE connectivity; they
may contain both variables and connectivity simultaneously.

Solution

Solution files contain time-varying data for all zones in the file.

You may load more than one Tecplot format file at a time by selecting multiple files in the Load Data
dialog. In fact, this is required when loading solution data because the corresponding grid file must be
loaded at the same time.

Loading Grid and Solution Data Files

When you are loading grid and/or solution files, please keep the following in mind:

• Each solution file must be read in after the grid file it is associated with has been loaded.

• If you load multiple grid and solution files into Tecplot Focus, the order the files are listed will be
used to determine which grid is used for which solution file(s). For example, if you load a set of grid
and solution files in the following order:

◦ Grid A

◦ Solution A

◦ Solution B

◦ Solution C

◦ Grid B

◦ Solution D

Grid A will be shared for Solution Files A, B, and C. Grid B will be used for Solution File D.
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You may select multiple files to load by holding the Shift key. However, the order is
not always preserved with this method. We strongly recommend that you use the Add
to List button when loading grid and solution data to make sure the files are added in
the order you require.

• You may load a grid file with variables or variables and connectivity without loading a solution file.
However, you may not load a grid file that contains only FE connectivity data.

Tecplot Layout Loader

The Tecplot Layout loader is used for loading Tecplot layouts (.lay) and layout packages (.lpk). Layouts
include only links to the original data files; layout packages include the subset of data needed to view
the layout. See Layout Files, Layout Package Files, Stylesheets for more details on creating these files.

Usually it is most convenient to load these kinds of files using the Welcome screen, the File→Open
Layout or File→Recent Layouts commands, or double-clicking the file in your file manager (e.g.
Windows Explorer). However, you can also load layouts and layout packages by choosing File→Load
Data and selecting this loader in the Load Data dialog.

This loader has no options; simply choose the desired .lay or .lpk file, and it will be opened.

Text Spreadsheet Loader

The Text Spreadsheet Loader add-on allows you import simple data from ASCII files. Select the
delimiter and I-skip (if necessary) from the Simple Spreadsheet File Loader dialog.

the Text Spreadsheet Loader dialog has the following options:

Filename

Enter the path to the file you would like to load.

Delimiter

Choose whether your data is separated by a comma, space, or tab.
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I-Skip

Select an I-skip value. A value of 1 loads all values, a value of 2 loads every other value, and so on.

The Text Spreadsheet Loader can read ASCII files of the following format (blank lines are ignored):

Variable 1, Variable 2, ..., Variable N
datapoint1,datapoint2, ..., datapoint N
.
.
.
datapoint1,datapoint2, ..., datapointN

Here is an example of a valid ASCII spreadsheet file:

Month, Rainfall
1, 15.0
2, 21.0
3, 21.0
4, 32.0
5, 10.3
6, 5.1
7, 2.3
8, 0.2
9, 1.4
10, 8.3
11, 12.2
12, 15.4


Text Spreadsheet Loader Limitation

The first line must contain all of the variable names. See How to Create a Plot
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Part 3: Creating Plots

Plot and Data Handling

How to Create a Plot

The basic steps for creating a plot in Tecplot Focus are:

1. Define your dataset using one of the following methods:

1. Use the Load Data command from the File menu. Please refer to Loading Data for information
on working with a specific data loader.

2. Use the Open Layout command from the File menu to load linked layout or layout package
files. (See Layout Files, Layout Package Files, Stylesheets for more information on layout files.)

3. Use any combination of the options in the Create Zone submenu of the Data menu or the
Insert menu to create your datasets directly within Tecplot Focus. Zone Creation and Text,
Geometries and Images for more information.

2. Select the Plot Type (3D, 2D, XY Line, Polar Line, or Sketch) from the Plot sidebar. Refer to Field
Plots for information regarding 3D and 2D plots, XY and Polar Line Plots for information on XY
Line and Polar Line plots, and Text, Geometries and Images for information on sketch plots.

3. Toggle-on any mapping or zone layers from the Plot sidebar. The following mapping and zone
layers are available:

◦ Mesh Layer

◦ Contour Layer

◦ Shade Layer

◦ Vector Layer

◦ Scatter Layer

◦ Edge Layer

◦ Map Layer

◦ Symbols Map Layer

◦ XY Line Error Bars

◦ XY Line Bar Charts

The layers available in the Plot sidebar are dependent upon the active plot type.
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In order to view surfaces on your plot, open the Zone Style dialog, select the Surfaces
tab, and use the Surfaces to Plot drop-down menu to choose an available surface
plotting option.

The Zone Style dialog is available by either double-clicking on your plot, selecting
the Zone Style button from the Plot sidebar, or selecting Plot→Zone Style from the
Menu bar.

4. Use the options in the Plot menu (such as Blanking or Axis) to customize how your data is
displayed. Refer to Three-dimensional Plot Control or Axes for additional information.

5. Use the options in the Data menu (such as Alter→Specify Equations or Interpolate) to alter the
dataset. Refer to Data Operations for additional information.

6. [3D only] Toggle-on zone effects (Translucency and Lighting). Refer to Translucency and Lighting
for details.

7. Use the Zone Style or Mapping Style dialogs to opt zones in and out of plot layers or the entire
plot. Refer to Field Plot Modification and the Zone Style Dialog and Mapping Style and Creation,
respectively, for details.

8. [2D or 3D only] Add derived objects (Slices, Streamtraces or Iso-Surfaces). Use their respective
buttons:    to customize any derived objects.

 CFD Data Analysis features are only available in Tecplot 360.

You are not limited to working with only one plot at a time. You can create multiple plots on a single
page using frames and frame linking, and you can create multiple pages. See Frames for more
information.

Data Journaling

On occasion you may modify data prior to making a final plot. Some (but not all) of the data operations
mentioned in this chapter modify data. Tecplot Focus "journals" the data modifications you make in
the form of macro instructions as well as performing them. If you then save a layout file, the layout file
can reference the original data and include the instructions necessary to reconstruct the plot. This way,
the original data file is not modified. You can also generate a new plot using a different data file by
reusing the layout. (Layout files are text files and may be modified in an editor.)

If you perform an operation that Tecplot Focus is unable to journal, you are prompted to save the
dataset to a new file when you save a layout file. This is necessary for the layout to reproduce exactly
what you have in your plot.

The following operations are included in the data journal:

• Data alteration except for derivatives in equations.

• Creation of rectangular zones, circular zones.
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• Slice extraction of a primary slice through volume or surface zones for X, Y, Z, or arbitrary planes.

• Zone duplication and mirroring.

• Zone and variable deletion.

• Fourier transform.

Data Sharing

In order to conserve computer memory and disk space, Tecplot Focus shares variables between zones
whenever possible. Variable sharing typically occurs with any of the following scenarios:

• When a variable is calculated for two or more zones, Tecplot Focus determines if the results will be
the same in the different zones, and shares the variable where appropriate. See Equation Syntax
and Variable Sharing Between Zones.

• When zones are duplicated, all variables are shared between the source zones and their duplicates.
See Zone Duplication.

• When mirrored zones are created, the mirrored zone shares all variables with the original. See
Mirror Zone Creation.

• When a data loader supporting data sharing loads a variable that is identified for two or more
zones, that variable is shared among the specified zones. This often occurs with time dependent
data, where the physical coordinates (e.g. X, Y, and Z) are typically the same for all time steps.


If a zone is altered (independently of zones it is sharing data with), any variable that is
changed will no longer be shared.

Variable sharing and connectivity sharing (for finite element zones) can also be established in a
Tecplot data file by supplying the appropriate parameters to the TECZNE function when writing the file
(see the Data Format Guide). In addition, multiple solution files can share the same grid file.

Data Set Information

The Data Set Information dialog, accessed from the Data Set Info option on the Data menu, gives
summary information about the current dataset, including the dataset title, zone and variable names,
and the minimum and maximum values of a selected variable. You can modify the dataset title, zone,
and variable names of any dataset.

Zone/Variable Info Page

The following information is provided on the Zone/Variable Info page:
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Zone(s)

Lists all zones by number, with their titles.

Zone Type (Ordered or FE data)

Displays the type of zone selected in the Zone(s) listing. For ordered data, it is followed by the index
values for IMax, JMax, and KMax (shown below). For finite element data, it is followed by the
element type, number of points, and number of elements:

IMax (ordered data)

Displays the IMax value of the zone selected in the Zone(s) listing.

JMax (ordered data)

Displays the JMax value of the zone selected in the Zone(s) listing.

KMax (ordered data)

Displays the KMax value of the zone selected in the Zone(s) listing.

Pts (finite element data)

Displays the number of data points in the zone selected in the Zone(s) listing.

Elem (finite element data)

Displays the number of elements in the zone selected in the Zone(s) listing.

Solution Time

Displays the solution time for the selected zone (see also Time Aware).
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Time Strand

Displays the strand ID for the selected zone (see also Time Aware).

Variable(s)

Lists all variables by number, with their names.

Var Type

Displays the type of data of the selected variable in the Variable(s) field.

Var Location

Indicates if variables are located at nodes or cell-centers.

Var Status

Use the Var Status field in the dialog to determine the status of the current variable. The variable
status can indicate the variable passivity and if the variable is "loaded" or "not loaded."

Var Range - Selected Zones

Displays the Min and Max values for the selected variable in the selected zones. When working with
subzone data, one or more of the values displayed may be estimates, which is indicated by (est)
next to the affected values.

Var Range - Active Zones

Displays the Min and Max values for the selected variable for all active zones. When working with
subzone data, one or more of the values displayed may be estimates, which is indicated by (est)
next to the affected values.

 Loading subzone data is a feature only available in Tecplot 360.

Load Variables

If a variable was not initially loaded, "Not Loaded" will be displayed in Var Range portions of the
dialog. Use the Load Variables button to display the Load Variable dialog, with which you can load
any variables from your dataset that were not initially loaded.

Load Variable

The Load Variable dialog allows you to load variables into memory if they are not currently loaded.
Choose the zone containing the variables you wish to load using the Zone menu at the top of the dialog,
then select one or more variables from that zone.
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• Click once to select only a single variable

• Hold the Shift key while clicking a second variable to select a contiguous range of variables

• Hold the Control key while clicking to toggle individual variables on and off

• Hold the Control key while clicking to toggle individual variables on and off

• Press Control-A to select all variables

Click the [Load] button to load the selected variables. See Load On Demand for more information
about this function.

Data Set Page

The Data Set page provides information about your data set, including: title, filenames, number of
zones, variables, elements, and lock status.
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The following information can be found on the Data Set page:

Data Set Title

Enter a title for the current dataset, or edit an existing title. The default is the result of
concatenating the titles specified in each Title record encountered in the data files making up the
dataset.

Files or directories

Lists the names and paths of all external data files making up the current dataset. Some file formats
use directories as containers; these will list only the directory name.

Num Zones

Number of zones in the dataset.

Num Vars

Number of variables in the dataset.
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Total Elements

Total number of elements in the dataset.

Total Points

Total number of points in the dataset.

Locked By

This field will inform you if the current dataset has been locked by an add-on. Add-ons can lock a
dataset which in turn prevents you from deleting zones or deleting the last frame associated with
the dataset.

Aux Data Page

Auxiliary data is metadata attached to zones, datasets, or frames. Auxiliary data is added to the plot via
the data file.

The Auxiliary Data page has the following information:
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Show Auxiliary Data

Use the drop-down to display auxiliary data for zones, datasets, frames, or names.

Data Name/Value

Displays the names and values of any auxiliary data.

Refer to the Data Format Guide for information on creating Tecplot Focus data files that include
auxiliary data.

Color Chooser

Each attribute of your plot can be set to a different color or color type using the Color Chooser. Use the
Select Color dialog to apply contour groups, a basic color palette, or RGB coloring to the selected plot
attribute.

There are three types of color assignments:

Contour Groups

The Contour Variables (Multi 1, 2, 3, 4, 5, 6, 7, and 8) are defined in the Contour & Multi-Coloring
Details. The Contour Variables are typically used for coloring mesh, contour, vector, and scatter
layers.

RGB Coloring

Select RGB to use RGB coloring established in Plot→RGB Coloring→Variables/Range. RGB coloring
is used to illustrate the relationship between two or three variables in your dataset, by setting R, G,
and B to each of the variables.

Basic Color Palette

Use the basic color palette to apply a single, constant color to a plot attribute.

116



For example, you can create a 3D field plot with a contour layer (with colors defined by a contour
variable), an edge layer (with colors from the basic color palette), and a vector layer (with colors
defined by RGB vectors).

RGB Coloring

RGB coloring occurs when Red, Green, and Blue values are supplied at each vertex. It may be used to
create special flooding such as for Oil/Water/Gas or vector direction plots. RGB coloring may be used
for each field plot object: zone layers, the mesh or contour layer for streamtraces or iso-surfaces, or
any of the layers for slices. This affects multi-coloring for that object as well as any contour flooding.
With RGB coloring, multi-colored objects such as vectors or scatter symbols have their color
determined based on the RGB components of the field variables at their location. Multi-colored mesh
and contour lines use the average value across the mesh line.



Exported Vector-based Files Limitation in RGB Coloring. Vector-based export files
such as WMF cannot show continuous RGB flooding. Objects that use RGB flooding are
reduced to contain average cell flooding where each cell is flooded a solid color based
on the averages of the RGB values at each vertex. The user is warned before such
output is generated.

RGB Coloring Options

If your data has only two RGB variables, or if the sum of the variables is not normalized, you can adjust
the settings using the RGB Coloring Options dialog (accessed via Plot→RGB
Coloring→Variables/Range). The RGB Coloring Options dialog (shown below) has the following
options:

Mode

You can either specify all three variables or specify two of the three variables and calculate the
third. The third variable is calculated using the following formula f(R)+f(G)+f(B)=1.0 (assuming f() is
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a function that maps R,G,B values into [0,1.0]).

Variables

Assign the variables which supply the values for the color components, as specified in the RGB
Mode.

Variable Value Range

By default, it is assumed that the minimum value for any of the Channel Variables is zero, the
maximum is one, and the sum of the three variables is one at every point. If the sum is not
normalized, you can set a new minimum and maximum. For example, if your variables sum to 100
at every point, you can enter 100 in the field for Value at Maximum Intensity.

Basic Color Palette

Figure 12. The Basic Color Palette region of the Select Color dialog.

Use the Basic Color Palette to define a constant color to the selected plot attribute(s).

XY and Polar Line Plots
A line plot is the simplest type of graph you can produce with Tecplot Focus. A typical line plot includes
a dependent variable (usually the vertical axis for XY plots) and an independent variable (usually the
horizontal axis for XY plots). Each line on the line plot represents one series of data points, where each
data point is defined by its independent and dependent variable values. A series of data points is
referred to as a mapping (or map, for short).

Tecplot Focus supports two types of line plots, XY plots and Polar plots. XY plots are plotted on
Cartesian coordinates using X & Y as the independent and dependent variables (See Axis Variable
Assignment). XY plots can include line, symbols, bar and/or error bar layers. Polar plots are plotted on
polar coordinates using Theta and R values. Polar plots can include line and/or symbol layers.

An example of XY and Polar Line plots is shown below.
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Line plots are usually created from one-dimensional, I-ordered data. The data used for line plots must
have at least two variables defined at each data point. The same number of variables must be defined
at each data point.

You can also create line plots from two or three-dimensional data in the IJ or IJK-ordered structure, or
from finite element data by selecting "XY Line" from the plot type menu in the Plot sidebar. If "XY Line"
is selected, finite element data sets will be treated as I-ordered (the connectivity list is ignored), IJ-
ordered datasets will be treated as a family of J-sets of I-ordered data, and IJK-ordered datasets will be
treated as K-planes of J-families of lines. Use the Indices page of the Mapping Style dialog to select
different ranges and skip intervals for the I, J, and K-indices. See this section on ijk indices later in this
chapter for more information.

When you first create a line plot, the Create Mappings dialog appears automatically so you can choose
the mappings to be created (see Mapping Creation). Names, colors, symbol types, and line patterns are
automatically assigned to each mapping. These and other line plot attributes can be changed using the
pages of the Mapping Style dialog. To bring up the Mapping Style dialog, go to the Plot menu and
select "Mapping Style", or select the Mapping Style button on the Plot sidebar.

Mapping Style and Creation

Line plots are composed of the graphs of one or more pairs of variables (XY pairs in XY Line plots or
Theta-R pairs in Polar Line plots). These pairs and their dependency relations are referred to as
mappings. Mappings are defined for each frame; the same dataset can have a different set of mappings
in each frame it is attached to.

Mappings can include any combination of the following mapping layers:

Lines

Can be drawn as linear segments or curve that fit the data points.

Symbols

Each data point is represented by a symbol.
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Error Bars (XY Only)

Error bars are drawn for each data point. The error bar value is determined by a third variable.

Bar Charts (XY Only)

Each data point is represented by a vertical or horizontal bar.

XY Line plots can have up to five x-axes and five y-axes simultaneously. Polar Line plots can have only
one Theta-axis and only one R-axis.

Open the Mapping Style dialog by clicking the Mapping Style button on the Plot sidebar to set
attributes for lines and symbols and, in XY Line plots, bar charts and error bars. Initially, any linemaps
selected in the workspace are selected in the Mapping Style dialog. You may also double-click a line in
your plot to open the dialog with that mapping selected. You can set the style of any mapping
independently of all other mappings.



Each page of the Mapping Style dialog is divided into three color-coded regions. The
blue columns (Map Number, Map Name, and Show Map) apply to the mapping itself
and are repeated on each page. The green and orange columns represent primary and
secondary settings specific to the selected mapping page.

You can also use the line map context menu and toolbar to change some of these settings quickly and
easily by right-clicking on a line on your plot. The toolbar allows you to turn on or off the line, symbol,
and error bars for the selected line map by clicking the icons. You can also adjust the attributes of these
(for example, line color, symbol shape, or error variable) using drop-down menus to the right of each
icon.

Mapping Definitions

Existing mappings are edited with the Plot menu’s Mapping Style dialog. From the Definitions page of
the Mapping Style dialog, you can modify names, activate and deactivate mappings, assign axis
variables, assign zones, sort data points in a mapping, control the mappings appearance in the line plot
legend, and assign particular X and Y-axes to XY-line plots.
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Some settings are represented by checkboxes, which can be toggled on and off by clicking them. Other
settings require a right-click. In general, select the mapping or mappings you want to change, then
right-click the selection in the column of the setting to be edited. Most of the time this will activate a
pop-up menu; in other cases, a dialog appears. You may change mappings whether they are shown on
the plot or not (activated or deactivated).

Map Number

Displays the number of each map. This cannot be edited.

Map Name

Double-click the map name to edit it. Type Enter to complete the edit or Escape to cancel without
saving the edit.

Show Map

Each mapping can be opted in and out of a plot by toggling the checkbox or by right-clicking and
choosing one of the following options:

Activate

Turns selected mappings on.

Deactivate

Turns selected mappings off.

Show Selected Only

Turns on selected mappings, and turns off all other mappings.

Invert

Switches the current activation settings for the selected map(s).
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Axis Variables

The choice of variables is the heart of the mapping. Each mapping is defined by two variables: X
and Y in XY Line plots and Theta and R in Polar Line plots. You may change the variables assigned to
a mapping by right-clicking or double-clicking.

Zone

Each mapping uses variable values from a specified zone. If your dataset has multiple zones, specify
the zone for each mapping by right-clicking or double-clicking the displayed zone name.

The pop-up field chooser appears. Display a list of all zones by clicking the downward-pointing
arrow next to the filter field, or start typing to display a filtered list of the zones whose name
contains what you type.

Sort

By default, mappings are sorted by the order in which they occur in the data file. You can change
this order with the Sort option on the Definitions page of the Mapping Style dialog.

Choose from one of the following Sort options:

None

Default behavior of sorting by the order in the data file.

By Independent Variable

Points are sorted in ascending order of the values of the independent variable.

By Dependent Variable

Points are sorted in ascending order of the values of the dependent variable.

By Specific Variable

Select a variable from the Select Variable dialog. The points of the selected mappings are sorted
in ascending order of the values of this variable.


Only Line Segment and Parametric Spline curve types are affected by the Sort
options. Splines are always sorted by the independent variable. See Curve Types
for more information on curve types.

Which Axes

XY Line plots support five X-axes (X1-X5) and five Y-axes (Y1-Y5). Newly created mapping use the X1
and Y1-axes. You can change these assignments by right-clicking.
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The ranges and scales for each axis are defined in the Axis Details dialog (accessed via the
Plot→Axis).

Figure 13. An XY Line plot using two Y-axes.

By default, the X1 axis is placed at the bottom of your axis grid area, and subsequent X axes at the
top. Similarly, it places axis Y1 at the left of your axis grid area and subsequent Y-axes at the right.
Thus, in Figure 13, the Seattle rainfall observations are shown along axis Y1 at the left of the axis
grid area, while the error observations are shown along Y2 at the right.

You can also use multiple axes to cycle through mappings with different ranges or axis settings. You
may find it convenient to assign different mappings to different axes so that you can set axis ranges,
axis positions, or other axis attributes independently for each mapping.

Show in Legend

By default, all active mappings appear in the line legend. However, the legend only lists mappings
with identical entries once. (See Line Legend for details on the Line Plot Legend.) The Show in
Legend button has three options:

Always

The mapping appears in the legend even if the mapping is turned off (deactivated) or its entry in the
table looks exactly like another mapping’s entry.

Never

The mapping never appears in the legend.
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Auto

The mapping appears in the legend only when the mapping is turned on. If two mappings would
result in the same entry in the legend, only one entry is shown.

Selection Criteria

Enter a wildcard pattern and click Select to select one or more mappings based their name. In
wildcard patterns, most characters match themselves, but the * and ? characters have special
meaning.

Characte
r

Meaning

? Matches any single character.

* Matches any number of characters, including none.

Clear

Clear the selection and the pattern field.

Mapping Creation

To define a new mapping, select the Create Map button in Mapping Style dialog. The dialog also
appears automatically the first time you choose the XY Line or Polar Line plot type. As shown below,
the dialog is slightly different for the two plot types.

In XY Line plots, you have the following options:

X-axis Variable versus Y-axis Variable for One Zone default)

Add a single mapping with one X and one Y-variable for one zone.

X-axis Variable versus All Other Variables for One Zone

Create a new set of mappings using one variable as the X-variable and each of the other variables in
the zone as Y-variables.

Y-axis Var versus All Other Variables for One Zone

Create a new set of mappings using one variable as the Y-variable and each of the other variables in
the zone as X-variables.
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X-axis Variable versus Y-axis Variable for All Linear Zones

Define one map for each zone, with the specified X-axis and Y-axis variables. If you choose this
option, you specify only the X-axis and Y-axis variables.

The options for polar line plots are the same as above, but with respect to the Theta-axis and R-axis
variables.

Specify the mapping name and the axis variables in the bottom section of the dialog. The default name
is "Map n," where n is the number of the mapping to be created. If you are creating a mapping for one
zone, you also select the zone here.

When you first load an ordered dataset, some mappings are automatically created for you. If your
dataset has more than two variables, mappings are created that associate the first variable with each
of the other variables for the first zone only.



Selecting variables in a 3D finite element zone may require significant time, since the
variable must be loaded over the entire zone. XY and Polar line plots are best used
with linear or ordered data, or with two-dimensional finite element data. The defaults
used in the Create Mappings dialog favor the types of zones that yield good
performance.

Mapping Names

Tecplot Focus automatically assigns a name to each mapping. The nature of the name depends on the
type of data used to create the mapping. If your data has only one dependent variable, the default is to
use the zone name for the mapping. If your data has multiple dependent variables, then the default is
to use the dependent variable name for the mapping. In either case, Tecplot Focus assigns each
mapping a special name (&ZN& or &DN& that is replaced with the zone or variable name when the name
is displayed.

You can modify any mapping’s name by right-clicking the name of the mapping in the Mapping Style
dialog. A small window pops up to allow you to enter a new name for the mapping, as shown here
(note the default name of &DN& in our example; our data has multiple dependent variables, and the
name of each is used as the mapping name).
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You may add other dynamic text placeholders like &DN& to the displayed mapping name by clicking one
of the options below the edit field, then clicking + (or simply double-clicking). The placeholders will be
replaced with the indicated value when the name is displayed. By combining static text with these
placeholders, you can construct a name in any format you like.

The placeholders available in this window are:

Zone name

Adds &ZN& to the mapping name. This will be replaced with the actual name of the zone assigned to
that mapping.

Zone number

Adds &Z#& to the mapping name. This will be replaced with the actual number of the zone assigned
to the mapping.

Independent variable name

Adds &IV& to the mapping name. This will be replaced with the actual name of the independent
variable assigned to that mapping.

Independent variable number

Adds &I#& to the mapping name. This will be replaced with the actual number of the independent
variable assigned to the mapping.

Dependent variable name

Adds &DV& to the mapping name. This will be replaced with the actual name of the dependent
variable assigned to that mapping.

Dependent variable numbe

Adds &D#& to the mapping name. This will be replaced with the actual number of the dependent
variable assigned to the mapping.

Map number

Adds &M#& to the mapping name. This will be replaced with the actual number of the mapping.

X-Axis number

Adds &X#& to the mapping name. This will be replaced with the actual number of the X-axis assigned
to that mapping for XY Line plots. (This option is not available for Polar Line plots.)

Y-Axis number

Adds &Y#& to the mapping name. This will be replaced with the actual number of the Y-axis assigned
to that mapping for XY Line plots. (This option is not available for Polar Line plots.)

Map Layer

The Line map layer is available for both XY and polar line plots. Activate the layer by toggling-on
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"Lines" in the Plot sidebar. When the Lines map layer is on, the dataset is represented by a connected
line for each mapping, which may be either a simple collection of line segments connecting all the data
points, or a curve fitted to the original data.

Line Attributes

The Lines page of the Mapping Style dialog (accessed via the Plot sidebar or Plot→Mapping Style) is
shown below.

The first two columns, Map Number and Map Name, list the mapping number and the mapping name.
The Map Show field lists which mappings are currently active. These columns behave the same as the
corresponding columns on the Definitions page (see Mapping Definitions). The remaining columns of
the Lines page of the Mapping Style dialog contain specific line attributes.


In order for the changes made in the Lines page to be visible in your plot, the Lines
mapping layer must be toggled-on in the Plot sidebar.

Show Lines

This option allows you to turn off lines for selected mappings, while keeping both the selected
mappings and the Lines map layer active overall.

Line Color

Set line color for line plots. Right-clicking displays the Color Chooser.

Line Thickness

Set the thickness of lines. Right-clicking allows you to choose from preset line widths of 0.02, 0.10,
0.40, 0.80, or 1.50 percent, or enter any thickness using a dialog.

Line Pattern

Right-click to choose line patterns for line plots.
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Pattern Length

Set the pattern length for patterned lines. Pattern length is measured as a percentage of the frame
height for one complete cycle of the pattern.


For information on using the controls at the bottom of the Mapping Style dialog to
select mappings by name, see the description of these at the end of Mapping
Definitions.

Curve Types

Tecplot Focus offers a variety of curve-fits and spline fits. By specifying the curve type, you control how
the data points are connected (see Map Layer).

Set the type of curve plotted for a mapping by right-clicking the desired Curve Type entry on the
Curves page of the Mapping Style dialog.

Tecplot Focus offers the following curve types:

Line Segment (No Curve-fit)

A series of linear segments connect adjacent data points. In XY Line plots, these will be line
segments.

Linear Fit

A linear function is fit to the data points. In XY Line plots, this will be a straight line.

Polynomial Curve-fit

A polynomial of order N is fit to the data points (where 1 ≤ N ≤ 10, for N=1 a Linear Fit is done).

Exponential Curve-fit

An exponential curve-fit that finds the best curve of the form Y = eb*lnX+c (equivalent to Y=a*eb*X,
where a = ec). To use this curve type, Y-values for this variable must be all positive or all negative. If
the function dependency is set to X=f(Y) all X-values must be all positive or all negative.

Power Curve-fit

A power curve fit that finds the best curve of the form Y=e_b*lnX+c (equivalent to Y=a*Xb, where a = ec).
To use this curve type, Y-values for this variable must be all positive or all negative; X-values must
be all positive. If the function dependency is set to X=f(Y), X-values must be all positive or all
negative, and the Y-values must all be positive.

Spline

A smooth curve is generated that goes through every point. The spline is drawn through the data
points after sorting the points into increasing values of the independent variable, resulting in a
single-valued function of the independent variable. The spline may be clamped or free. With a
clamped spline, you supply the derivative of the function at each end point; with a non-clamped
(natural or free) spline, these derivatives are determined for you. In XY Line plots, specifying the
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derivative gives you control over the initial and final slopes of the curve.

Parametric Spline

Creates a smooth curve as with a spline, except the assumption is that both variables are functions
of the index of the data points. (For example in XY Line plot, ParaSpline fits x=f(i) and y=g(i) where
f() and g() are both smooth.) No additional sorting of the points is performed; the sorting specified
on the Definitions page of the Zone Style dialog is used for the order of the data points. This spline
may result in a multi-valued function (of either or both axis variables).

Extended Curve-fit

Uses a curve-fit supplied by an add-on. These curve-fits may be provided by Tecplot Focus, a third
party, or written by users. The functionality of each extended curve-fit is defined by its creator.

Linear Fit, Polynomial Fit, Exponential Fit, and Power Fit are all determined by using a least
squares algorithm. Examples of each curve-fit type are shown in Figure 14.
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Figure 14. Tecplot Focus’s curve-fit types.

The Curves page also contains fields for controlling the following attributes:

Dependent Variable

Right-click to choose how curve fits and splines are interpreted. Dependent Variable has no effect
on mappings of the Line Segment curve type.

Curve Points

Controls the number of points used to draw curve fits and splines. Right-click to choose a preset
number of points or to enter your own. Raising the number of points increases the accuracy of the
curve but also increases plotting time and the size of print files.

Curve Setting

Displays options specific to the curve type, such as weighting for curve fits or starting derivatives
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for splines. Right-click to set these options.


For information on using the controls at the bottom of the Mapping Style dialog to
select mappings by name, see the description of these at the end of Mapping
Definitions.

Linear Fit

Tecplot Focus fits the data to a linear function using the standard least-squares algorithm. It calculates
the function for which the sum of the squared differences from the data points is a minimum. For the
XY Line plot type, the linear function is a straight line.

To fit a linear function to your data, right-click in the Curve Type column on the Curves page of the
Mapping Style dialog and select "Linear Fit." Then right-click in the Curve Setting column and choose
Settings to display the Curve Fit Settings dialog, shown below.

Polynomial Order

This is shown on the dialog, but should always be "1" for a linear fit. If you change this from 1, the
curve type is changed to Polynomial Curve-fit.

To limit the points used in the mapping(s)

select "Use Only Points Within Range", and enter minimum and maximum values.

To assign a curve weighting variable

select "Use Weighting Variable", and select the variable from the drop-down. For more information
on curve weighting, see Curve-fit Weighting Variables.

Polynomial Curve-fit

Tecplot Focus uses a standard least-squares algorithm to fit data to a polynomial function. You specify
the order of the polynomial (from one to ten), and the polynomial for which the sum of the squared
differences from the data points is a minimum is calculated.

To fit a polynomial function to your data, right-click in the Curve Type column on the Curves page of
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the Mapping Style dialog and select "Polynomial Fit."Then right-click in the Curve Setting column and
choose Settings. The Curve Fit Settings dialog appears.

By default, this option fits a cubic polynomial, using all the points in the mapping and weighting them
equally.

Polynomial Order Drop Down

Select the desired polynomial order (1 to 10). An order of 2 is a quadratic polynomial, an order of 3
is a cubic polynomial, etc. If you select 1, the curve type is set to Linear Fit, as a polynomial of order
1 is a linear function. (See Linear Fit.)

To limit the points used in the mapping(s)

Select "Use Only Points Within Range", and enter minimum and maximum values.

To assign a curve weighting variable

Select "Use Weighting Variable", and select the variable from the drop-down. For more information
on curve weighting, see Curve-fit Weighting Variables.

Exponential Curve-fit

Tecplot Focus fits the data to an exponential function using the standard least-squares algorithm.

 The dependent-variable values must be either all positive or all negative.

For XY plots (where X is the independent variable)

Tecplot Focus finds the best curve of the form:

Y=eb*X+c (equivalent to Y=a*eb*X where a=ec).

Similarly when Y is the independent variable.

For Polar plots (where Theta is the independent variable)

Tecplot Focus finds the best curve of the form:
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R = ±e(bθ+c)

or

R = ±αe(b*θ)

Similarly when R is the independent variable.

To fit an exponential function to your data, right-click in the Curve Type column on the Curves page of
the Mapping Style dialog and select "Exponential Fit."

By default, this option uses all the data points in the mapping, weighting them equally.

Use the Exponential Fit Settings dialog dialog (accessed by right-clicking in the Curve Setting page on
the Curves page of the Mapping Style dialog) to specify different settings. The dialog is shown below.

To limit the points used in the mapping(s)

Select "Use Only Points Within Range", and enter minimum and maximum values.

To assign a curve weighting variable

Select "Use Weighting Variable", and choose the variable from the drop-down. For more information
on curve weighting, see Curve-fit Weighting Variables.

Power Curve-fit

Tecplot Focus fits a power function to data using the standard least-squares algorithm. The dependent-
variable values must be either all positive or all negative, and the independent values should be all
positive. Data points with zero or negative independent values are ignored.

For XY plots (where X is the independent variable)

Tecplot Focus finds best curve of the form:

Y=eb*lnX+c (equivalent to Y=a*Xb where a=ec).

Similarly, when Y is the independent variable.
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For Polar plots (where Theta is the independent variable)

Tecplot Focus finds the best curve of the form:

R = ±eb*ln(θ)+c

or

R = ±α*θb

Similarly, when R is the independent variable.

To fit a power-curve function to your data, right-click in the Curve Type column on the Curves page of
the Mapping Style dialog and select "Power Curve."

This option uses all the data points in the mapping, weighting them equally.

Use the Power Fit Settings dialog (accessed via the [Curve Settings] button) to specify different
settings. The dialog is shown below.

To limit the points used in the mapping(s)

Select "Use Only Points Within Range", and enter minimum and maximum values.

To assign a curve weighting variable

Select "Use Weighting Variable", and select the variable from the drop-down. For more information
on curve weighting, see Curve-fit Weighting Variables.

Spline

A spline is a mathematical function defined to link a specified set of points with a function that is
continuous and smooth (differentiable) at every point. The most common type of spline, the cubic
spline, is defined using a set of cubic polynomials, one for each interval between the data points.

Splines can be natural or clamped: natural splines are twice-differentiable at the end points and the
second derivative is zero at those points, while clamped splines have known first-derivatives at the
boundary points. Before plotting the spline, the data points are sorted in increasing value along the
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independent axis.


The Sort option of the Definitions page of the Mapping Style dialog has no effect on
splines.

To fit a spline function to your data, right-click in the Curve Type column on the Curves page of the
Mapping Style dialog and select "Spline." By default, this option fits a natural cubic spline.

To specify a clamped spline:

1. Right-click in the Curve Setting column on the Curves page of the Mapping Style dialog and choose
Settings.

2. In the Spline Settings dialog (shown below), select "Clamp the Spline", and enter values for the
derivative at the start and end of the spline.

Parametric Spline

The cubic spline fit assumes that the spline function is a single-valued function of the independent
variable.

Sometimes, however, you have data that curves back upon itself, but you would still like to have a
spline-like curve fit to it. Parametric splines solve this problem by presuming that both variables (X&Y
or θ&R) are functions of the data-point index. The spline is then defined by two single-valued functions
of the data-point index.

Unlike cubic splines, parametric splines are plotted in the order set in the Sort option of the Definitions
page of the Mapping Style dialog. By default, the points are unsorted, and thus the spline is drawn in
the order the data points appear in the data file. See Mapping Definitions for a discussion of sorting.

To fit a paraspline function to your data, right-click in the Curve Type column on the Curves page of the
Mapping Style dialog and choose "ParaSpline."

By default, This option fits two natural cubic splines to the data point index.

To specify a clamped spline:
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1. Select Para Spline from the Curve drop-down menu, and then select Curve Settings.

2. In the Parametric Spline Settings dialog (shown below), select "Clamp the Spline", and enter
values for the derivative at the start and end of the spline.

For the XY Line plot type, the derivatives are either dy/dx or dx/dy depending on the Function
Dependency for the mapping. Tecplot Focus calculates dx/ds and dy/ds from these values (where s is
the parametric variable). For the Polar Line plot type, the derivatives are either dR/dTheta or dTheta/dR
(depending on the Function Dependency for the mapping), and dR/ds and dTheta/ds are calculated
from these values (where s is the parametric variable). See Dependent and Independent Variables for a
full description of the Function Dependency option.

Extended Curve-fit

Tecplot Focus add-ons can provide new curve-fit types. These curve types are called extended curve-
fits. These curve-fits may be provided by Tecplot Focus, a third party, or written by users. The
functionality of each extended curve-fit is defined by its creator.

To fit an extended curve to your data:

1. Use the Curves tab of the Mapping Style dialog to select the mappings for which you want to apply
an extended curve-fit.

2. Right-click Curve Type, and select an option from the drop-down.

3. The extended curve fit options are located below the separation line (shown below).
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Extended Curve fits can also be selected by the right-click context menu on a line plot.
Simply right-click on the line you wish to change, hover over Curve Type, and a
similar drop-down menu will appear as above.

Three extended curve fit add-ons are supplied with Tecplot Focus:

Akima

The Akima spline is an alternative that exhibits less dramatic overshoots and undershoots than the
classical spline. The slopes at the end of each segment are computed using a nonlinear average of
the segment slopes.[3] The Akima spline is always unclamped. There are currently no options
available for the Akima spline.

• Extended Curve-Fit - General

• Extended Curve-fit - Stineman

Extended Curve-Fit - General

The General Curve Fit add-on fits an equation composed of a linear combination of user-specified sub-
functions to the data in the specified map. The optional parameters can be accessed by selecting the
Curve Settings option on the Curves page of the Mapping Style dialog.
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The curve fit computes (least squares) the optimal curve fit coefficients by multiplying these sub-
functions.

The following options are available:

Number of Coefficients

Specify the number of coefficients (and number of sub-functions) for the desired curve fit. The
default is three. You must specify a sub-function for each coefficient in the text fields labeled f1(x)
through fn(x), where n is the number of coefficients.

f1(x) through f8(x)

Enter the sub-functions for the curve fit using the syntax described in Data Alteration through
Equations.


In these equations use the variable x as the independent variable, even if x is
specified as the dependent variable in the Dependent Variable option of the
Mapping Style dialog.

Normalize X

Causes the curve to be fit using a normalized independent variable. In particular, the independent
variable will be translated and scaled to vary from zero at the smallest value of the independent
variable to one at the largest value of the independent variable. For most curves other than
polynomials, this option will alter the shape of the curve fit. It is useful when you get the "Rank
reduced for at least one curve fit" warning message, but otherwise is not recommended.
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Normalize Y

Causes the curve to be fit using a normalized dependent variable. In particular, the dependent
variable will be translated and scaled to vary from zero at the smallest value of the dependent
variable to one at the largest value of the dependent variable. For most curves other than
polynomials, this option will alter the shape of the curve fit. It is useful when you get the "Rank
reduced for at least one curve fit" warning message, but otherwise is not recommended.

Extended Curve-fit - Stineman

This method of interpolation generates a curve that will never have more inflection points than are
clearly required by the given set of data points. The interpolating curve passes through the data points
and exactly matches the computed slopes at those points[4]

The optional parameters can be accessed by selecting the Curve Settings option on the Curves tab of
the Mapping Style dialog.

Line Segment (No Curve-fit)

By default, a series of linear segments are drawn between each set of points for the XY Line plot type.

To turn off curve fits for your data and use linear segments between points:

1. The Curves page of the Mapping Style dialog, select the mappings you want to show as linear
segments.

2. Right-click in the Curve Type column on the Curves page of the Mapping Style dialog and select
"Line Segments."

Line Segments are plotted in the order set in the Sort option of the Definitions page of the Mapping
Style dialog. By default, the points are unsorted, and lines segments are drawn in the order the data
points appear in the data file. See Mapping Definitions for a discussion of sorting.

Dependent and Independent Variables

Every mapping has a dependent variable and an independent variable. The dependency relationship
determines the shape of your plot for most curve types. This dependency has no effect on line segment
curve types, and for parametric splines, the dependency is only used to determine starting derivatives
for clamped parametric splines. Extended curve-fits are free to use or not use this dependency
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depending on the type of curve-fit supplied.

You specify the dependency relationship between your axis variables by right-clicking in the
Dependent Variable column on the Curves page of the Mapping Style dialog.

For the XY Line plot type, the default setting is y=f(x) (you may change the value to x=f(y)). With y=f(x),
the X-axis variable is the independent variable and the Y-axis variable is the dependent variable. With
x=f(y), the Y-axis variable is the independent variable and the X-axis variable as the dependent
variable. Two polynomial curve-fits of the same data using different dependency settings are shown in
Figure 15.

Figure 15. XY Line plot type dependencies.

Similarly for Polar Line plots, the default setting is R=f(Theta) (you may change the value to Theta=f(R)).
With R=f(Theta), the Theta-axis variable is the independent variable and the R-axis variable is the
dependent variable. With Theta=f(R), the R-axis variable is the independent variable and the Theta-axis
variable is the dependent variable.

To change the dependency setting:

1. From the Curves page of the Mapping Style dialog, select the mappings to change.

2. Right-click in the Dependent Variable column on the Curves page of the Mapping Style dialog
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choose either R=f(Theta) or Theta=f(R).


For the XY Line plot type, the dependency setting determines the direction of bar
charts. To create a vertical bar chart, set the dependency to y=f(x); to create a
horizontal bar chart, set the dependency to x=f(y). See XY Line Bar Charts.

Curve-fit Weighting Variables

Linear and polynomial fits allow you to specify a weighting variable. By default each data point is
weighted equally. With the weighting variable, individual points can be given more or less weight.
Relatively larger numbers in the curve weighting variable mean more significance for a given point. If
the curve-weighting variable is zero at a data point, that data point has no effect upon the
resulting curve. Therefore if your data contains outliers that would affect the overall curve fit, adding
a zero weight at the point of the outlier will remove it from the overall curve fit calculation.

The weighting coefficients must be integers in the range of zero to 9,999. Weighting coefficients
defined as floating-point numbers are truncated. That is, a weighting coefficient of 1.99 is truncated to
1.0.

Curve Information

You can view information about curve-fits and splines by right-clicking the curve in the plot and
choosing an item from the Curve Details submenu. The available functions include

Show On Plot

Displays information about the curve directly on the plot, including the zone, the variables, the
Goodness of Fit, and other information specific to the curve type (such as the polynomial for the
Polynomial Fit type). This information is in a standard text element, and you can reposition it as
usual, or change its appearance (its font, size, and color) using the Text Details dialog. It is
automatically updated if you change the curve fit settings.

Write Curve Points to File

Write the points of the curve to a Tecplot-format data file (.dat).

Write Curve Details to File

Writes the same information displayed by Show On Plot to a text file. Note that this text file includes
some Tecplot text formatting tags such as <sup>.

Goodness of Fit

R2 is displayed in the curve details for linear, polynomial, exponential, and power curve fits. It is a
statistical calculation that measures the success of the curve-fit in modeling the variation of the data.
R2 is defined as the ratio of the sum of the squares of the regression (SSR) and the total sum of the
squares (SST).
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Where:

Identifie
r

Represents

SSR sum of the squares of the regression

SST total sum of the squares

Wi the value of the weight variable at
index i

yi the value of the dependent variable at
index i

ymean the mean value of the dependent
variable y

ycurvefit_i the value computed using the curve-fit
at the i-index value of the independent
variable (xi).

i current index number

n total number of data points


R-square can take any value between zero and one, with a value closer to one
indicating a better fit.

A fundamental error term in least-squares curve fits is the sum of the squares residual (SSE), defined
by

This is the number that is minimized when computing the curve-fit coefficients. Using the equation SST
= SSE + SSR, R2 can be related to SSE:

Using this form to compute R2, it is easier to see that an R2 closer to one (SSE=0) indicates a better
curve-fit.

Goodness of Fit Residutal Degrees of Freedom Adjustment
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One problem with R2 is that it will always indicate a good curve-fit when the number of data points, n,
equals the number of degrees-of-freedom, m. (For example, a quadratic curve-fit through three data
points.) In this case, the curve passes through all data points so SSE=0 and r-square=1. However, there
are no other data points so, in reality, no estimate can be made on the quality of the curve fit away
from the specified data points. In general, any time m (degrees-of-freedom) is close to n (number of
data points), r-square will overstate the quality of the curve fit. For this reason, we include the second
goodness-of-fit parameter: degrees-of-freedom adjusted R2:

Like the standard R2, R2
dof will vary from zero to one with values closer to one indicating a better curve

fit. R2
dof will be less than R2 when the degrees-of-freedom are close to the number of data points, but

will be nearly equal to R2 when the number of data points is significantly greater than the degrees-of-
freedom.

Symbols Map Layer

The Symbols map layer is available for both XY and polar line plots. Activate the layer by toggling-on
"Symbols" in the Plot sidebar. When the Symbols map layer is on, each data point is represented by a
symbol on the plot. For each mapping, you may choose the plotting symbol used, and whether to use
filled or plain symbols.

Symbol Attributes

Use the Symbols page of the Mapping Style dialog (shown below) to modify the attributes of the
Symbols layer.

The first two columns list the mapping number and name. The Show Map column indicates currently
active mappings. These columns behave the same as the corresponding columns on the Definitions
page (see Mapping Definitions).
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The remaining columns of the Symbols page of the Mapping Style dialog contain specific symbol
attributes: Symbol Show, Symbol Shape, Symbol Size, Symbol Spacing, Outline Color, Line Thickness,
Fill Mode, and Fill Color.


In order for the changes made on the Symbols page to be visible in your plot, the
Symbols mapping layer must be toggled-on in the Plot sidebar.

Show Symbols

Allows you to turn off symbols for selected mappings, while keeping both the selected mappings
and the Symbols map layer active overall.

Symbol Shape

Right-click and choose a symbol type. In addition to the predefined symbols, you may use any ASCII
character by selecting Character. Enter the ASCII character to use as a symbol in the Enter ASCII
Character dialog (shown below), and select a font from which to display the symbol. See Character
Indices in Tecplot 360 for further information on the symbols available in each character set.

You can change the base font in the Scatter Size/Font dialog, accessible via Plot→Symbol Font. See
Scatter Size/Font.

Symbol Size

Right-click and choose the symbol size for your line plotting symbols. Symbol size is measured as
percentage of the frame height. You can choose a preset size or enter your own.

Symbol Spacing

Right-click to specify the spacing between symbols. The spacing is specified either as a percentage of
the frame height or as a number of indices to skip. You may either enter a value or use a pre-set
value.

Draw All

Symbols are drawn at every data point.

ISkip=2, 3 or 4

Symbols are drawn every second, third, or fourth data point.
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Enter Distance=1, 2 or 3%

Symbols are drawn at the first data point and subsequently at data points that are at least one,
two, or three percent of the frame height distant from the previously plotted data point.

Enter Index

Enter an index skip between symbols.

Enter Distance

Enter a distance between symbols in frame units.

Outline Color

Right-click to choose a color using the Color Chooser.

Line Thickness

Right-click to choose the thickness of lines used to draw the plotting symbols. You may either enter a
value or use a pre-set value.

Fill Mode

Right-click to specify the Fill Mode:

None

The symbols are not filled.

Use Line Color

The symbols are filled with the same color specified in Outline Color and appear as a solid color.

Use Back Color

The symbols are filled with background color of the grid area, and appear hollow, blotting out
objects behind the symbol (such as grid lines or other mappings).

Use Specific Color

The symbols are filled with the color specified in Fill Color.

Fill Color

If the Fill Mode is set to "Use Specific Color", right-click in this column to choose the fill color in the
Color Chooser.


For information on using the controls at the bottom of the Mapping Style dialog to
select mappings by name, see the description of these at the end of Mapping
Definitions.

Enter ASCII Character

Use the Enter ASCII Character dialog to specify an ASCII character to use as a plotting symbol in
either a field scatter plot or an XY symbol plot. You enter the desired character, and then choose the
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character set from which to draw the character. See Character Indices in Tecplot 360 for further
information on the symbols available in each character set.

This dialog has one text field for specifying the ASCII character and four option buttons representing
the available character sets, as follows:

Enter Character to use as a Symbol

Enter the desired ASCII character in this text field.

Base

Select this to use the English-text character set as the source of the plotting character.

Math

Select this to use the math character set as the source of the plotting character.

Greek

Select this to use the Greek character set as the source of the plotting character.

User-defined

Select this to use the user-defined character set as the source of the plotting character. See Custom
Character and Symbol Definition.

XY Line Error Bars

In the XY Line plot type, you can assign one or more variables to be used to compute error bars for
another variable. Each mapping can be associated with only one error bar variable. If you want to
assign multiple error bar variables to a mapping, create a copy of the mapping for each error bar
variable.

An example plot with error bars is shown in Figure 16.
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Figure 16. An XY Line plot with symbols and error bars.

You can use any variable in your dataset as an error bar variable. However, for them to be meaningful,
they should have the same units as the axis along which they are drawn.

NOTE: If error bar values are not included in your original dataset, you may create error variables
using Tecplot Focus’s data manipulation utilities. For example, if you know that the values of some
measured variable are accurate only to within ten percent, you may create a new variable to use as the
error bar variable by multiplying the measured variable by "0.10" via Data→Alter→Specify
Equations. See Data Operations.

Select Variable

Use the Select Variables dialog to choose:

• A single variable, as when assigning a variable to the X or Y-axis in an mapping. The text and labels
will vary with the particular action being performed, but the operation of the dialog is the same in
all cases. Select a variable from the drop-down of the dataset’s variables and select OK.

• Two variables, as when assigning 2D axis variables or choosing 2D vector components. The text
and labels will vary with the particular action being performed, but the operation of the dialog is
the same in all cases. For each of the two variables required, select a variable from the drop-down
of the dataset’s variables.
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• Three variables, as when assigning 3D axis variables or choosing 3D vector components. The text
and labels will vary with the particular action being performed, but the operation of the dialog is
the same in all cases. For each of the three variables required, select a variable from the drop-down
of the dataset’s variables.

Error Bar Attributes

You can modify most of the attributes with which error bars are drawn—their color, their thickness,
their spacing, and the width of the endpoint crossbars. You can make these changes from the Error
Bars page of the Mapping Style dialog (shown below).


In order for the changes made on the Error Bars page to be visible in your plot, the
Error Bars mapping layer must be toggled-on in the Plot sidebar.

The first two columns list the mapping number and name. The Show Map column indicates currently
active mappings. These columns behave the same as the corresponding columns on the Definitions
page (see Mapping Definitions). The other settings are:

Show Error Bars

Indicates whether error bars are displayed for this mapping.

Error Bar Variable

Right-click or double-click to choose the error bar variable.

Error Bar Type

Right-click to choose from seven types of error bars.

Up

Extends upward for positive values (and downward for negative values) of the error bar
variable.
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Down

Extends downward for positive values (and upward for negative values) of the error bar
variable.

Left

Extends to the left for positive values (and to the right for negative values) of the error bar
variable.

Right

Extends to the right for positive values (and to the left for negative values) of the error bar
variable.

Horizontal

Extends left and right.

Vertical

Extends up and down. (This is the default value.)

Cross

Extends up, down, left, right.



Although the values are called Left, Right, Up and Down, the direction is
determined by the direction of positive values in your plot. If you reverse the
direction of an axis (using the Reverse Axis Direction option on the Range page of
the Axis Details dialog), the error bars point in the opposite direction.

Error Bar Spacing

Right-click to specify the spacing between error bars. The spacing is specified either as a percentage
of the frame height or as a number of indices to skip. You may either enter a value or use one of the
following pre-set values:

Draw All

Error bars are drawn at every data point.

ISkip=2, 3 or 4

Error bars are drawn every second, third or fourth data point.

Distance=1, 2, or 3%

Error bars are drawn at the first data point and subsequently at data points that are at least one,
two or three percent of the frame height distant from the previously plotted data point.

Error Bar Color

Right-click to specify the error bar line color in the Color Chooser.
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Error Bar Size

Right-click to specify the size of the crossbar. Crossbar size is measured as a percentage of frame
height. You may either choose a preset value or enter an exact value yourself.

Line Thickness

Right-click to specify the line thickness of the error bars. The error bar line thickness is measured as
a percentage of frame height.


For information on using the controls at the bottom of the Mapping Style dialog to
select mappings by name, see the description of these at the end of Mapping
Definitions.

XY Line Bar Charts

A bar chart is an XY Line plot that uses vertical or horizontal bars placed along an axis to represent
data points. You can create bar charts by activating the Bars map layer on the Plot sidebar.

Bar Chart Attributes

The style of the bar chart is controlled on the Bar Charts page of the Mapping Style dialog, shown
below.

The first two columns list the mapping number and name. The Show Map column indicates currently
active mappings. These columns behave the same as the corresponding columns on the Definitions
page (see Mapping Definitions).

Show Bars

Toggle on or off the bar chart for this mapping.
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Bar Direction

Right-click to change between vertical or horizontal bars.

Changing the direction of the bars changes the dependent variable attribute used for line curves
(either y=f(x) or x=f(y)), and vice versa. By default, all mappings use y=f(x) and appear as vertical bar
charts. If a mapping uses horizontal bars, the mapping will also use x=f(y) for curve fits. Of course,
this only matters if you plot bars and curve-fits for the same mapping. For more information about
dependency, see Dependent and Independent Variables.

To modify other attributes (Bar Size, Outline Color, Line Thickness, Fill Mode, Fill Color) on the Bars
page, follow the same procedures used to set Symbol Attributes.


For information on using the controls at the bottom of the Mapping Style dialog to
select mappings by name, see the description of these at the end of Mapping
Definitions.

I, J, and K-indices

Each mapping can show either I, J, or K-varying families of lines. By default, Tecplot Focus displays the
I-varying family of lines. Figure 17 shows the family of I-varying lines for Zone 1 of the data.

Figure 17. A family of I-varying lines for the cylinder data.

You can change the family of lines using the Indices page of the Mapping Style dialog as shown below.
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The first two columns list the mapping number and name. The Show Map column indicates currently
active mappings. These columns behave the same as the corresponding columns on the Definitions
page (see Mapping Definitions).

You can also choose which members of the family are drawn (and using which data points), by
specifying index ranges for each of I, J, and K. The index range for the varying index tells Tecplot Focus
which points to include in each line, and the index ranges for the other indices tell Tecplot Focus which
lines in the family to include. Thus, you may use this option for selecting a subset of an I-ordered zone
to plot.

Varying Index

To choose the varying index, and thus specify the family of lines to be drawn, right-click the Varying
Index column and choose the desired family (I, J, or K-varying). K-varying is only available if the
mapping is using an IJK-ordered zone.

Index Ranges

By default, the entire range of points is plotted in your mapping. For IJ- and IJK-ordered data, you
may want to specify an index range to limit the number of lines drawn. Or, for any type of data, you
may want to limit the points drawn to a select range. Right-click and choose Enter Range to specify
the range.

Enter a starting index in the Begin field, an ending index in the End field, and a skip factor in the Skip
field. A skip of one means "use every point in the range," a skip of two means "use every other point,"
and so on.


For information on using the controls at the bottom of the Mapping Style dialog to
select mappings by name, see the description of these at the end of Mapping
Definitions.
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Line Legend

You can generate a legend that shows the line and symbol attributes of the mappings. In XY Line plots,
this legend includes the bar chart information. The legend can be positioned anywhere within the line
plot frame.

The mappings that are shown in the legend are selected on the Definitions page of the Mapping Style
dialog. By default, all mappings are shown, but Tecplot Focus removes redundant entries.

To include the line plot legend, open the Line Legend dialog (accessed via the Plot menu) and toggle-
on "Show Line Legend".

The Line Legend dialog has the following additional options:

Show Mapping Names

Toggle-on or off to include mapping names in the legend.

Text

Format the text for the legend by choosing a color, font, and size. (See Font Folders and Fallback for
more information on how fonts work with Tecplot Focus.)
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Position

The legend is automatically placed for you. You may specify the position of the legend by entering
values in the X (%) and Y (%) text fields. Enter X as a percentage of the frame width and Y as a
percentage of the frame height.

Line Spacing

Spacing between items in the legend as a multiple of the font size.

Anchor

You may also specify the anchor location of the legend using the Anchor Alignment dialog. By
default, the legend is anchored in the top right.

Legend Box

Choose No box, Outline, or Fill mode. If the legend box mode is Outline or Fill, the box attributes
may be changed with the following controls:

Line Thickness

Specify the line thickness as a percentage of frame height.

Box Color

Choose a color for the legend box outline.

Fill Color

Choose a color for the legend box fill (Fill mode only).

Margin

Specify the margin between the legend text and legend box as a percentage of the text height.

Select Font

Use the Select Font dialog for your font preferences.
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The available options are:

Font

Choose a typeface from the drop-down. Some typefaces also have bold, italic, or bold/italic variants
listed.


Not all fonts have Bold and/or Italic variants. For fonts that do not have these
styles, the B and/or I buttons may have no effect.

Size by

Choose to size fonts by points or percentage of frame height, or in certain cases by axis percentage.

Height

Select font height from the drop-down.

Specify Number Format


Not all fonts have Bold and/or Italic variants. For fonts that do not have these styles,
the B and/or I buttons may have no effect.

Format

Choose the format for numbers in the legend from the drop-down:
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Integer

Display the number as an integer; if the exact value is not an integer, it is truncated.

Float

Display the number as a floating-point number. The value is shown to the number of decimal
places specified in the Precision field.

Exponent

Display the number using FORTRAN exponential format (for example, 1.0125E + 02). The number
of decimal places is specified using the Precision field.

Best Float

Display the number as a floating-point number, with its exact form determined by Tecplot Focus.

Range Best Float

Tecplot Focus selects the best floating-point representation of the tick mark labels, taking into
account the range of values on the axis. (Available only for axis labels.)

Superscript

Display the number in scientific notation, using a number times a power of ten. The number of
decimal places shown is specified using the Precision field.

Custom

Not a number format at all, Custom specifies that a set of custom labels (specified by number in
the Custom Set field) should be used in the contour legend. The first label in the set is used for
the value one, the second label for two, and so on. All non-integer numbers are rounded to the
nearest integer. If the number of levels exceeds the number of custom labels, the labels are
reused cyclically as needed. For example, if you have defined the custom labels Mon., Tue, Wed,
Thu, Fri, Sat, and Sun, then a value of eight would display Mon, nine would display Tue, and so
on.

Time/Date

You can specify a Time/Date format for your labels by selecting Time/Date from the Format drop-
down menu. See Time/Date Format Options for more information on specifying your labels in
Time and/or Date format.

Precision

(Float, Exponent, or Superscript only) - Enter the number of decimal places each number is to show.

Custom Set (Custom only)

Enter the number of the set of custom labels. You define custom label sets as records in standard
Tecplot-format data files.

Show Decimal on Whole Numbers

When this toggle is checked, whole numbers include a trailing decimal (that is, the number 2 is
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displayed as 2).

Remove Leading Zeros

When this toggle is checked, leading zeros are removed from numbers (that is, 0.25 is displayed as
.25).

Show Sign on Negative Numbers

When this toggle is checked, negative numbers show the negative sign. When unchecked the
negative sign will be removed (that is, -1.43 is displayed as 1.43). This is useful if you have specified
a special prefix or suffix for negative values.

Prefix and Suffix

You can specify a custom prefix and/or suffix for numbers in Tecplot Focus using the Prefix/Suffix
text fields. Tecplot Focus allows you to specify separate prefixes and suffixes for zero values and
negative values as well.

Field Plots
Field plots are 2D Cartesian or 3D Cartesian plots. The axes in a field plot are all independent variables.
In Tecplot Focus, field plots can be created using any combination of the following zone layers:

• Mesh Layer

• Contour Layer

• Vector Layer

• Scatter Layer

• Shade Layer

• Edge Layer

By default, 2D and 3D field plots are initially displayed with Mesh and Edge zone layers:

Figure 18. A 2D mesh and edge plot.

3D field plots may be enhanced with lighting effects and translucency (Translucency and Lighting).
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Bounding boxes are displayed in 3D plots for volume-only zones when the plot
contains only such zones and the zones themselves are not otherwise visible due to
having no style. These bounding boxes may be turned off in the Options menu.

Field plots may also contain any combination of the following objects (which are derived from the
values in the dataset):

• Iso-Surfaces

• Slices

• Streamtraces

This chapter discusses the plot attributes that are common to all of the plot layers.

Field Plot Modification and the Zone Style Dialog

Once you have loaded your data, you can modify field plot attributes using the Zone Style dialog or the
context toolbar.

The context toolbar appears above the context menu when you right-click a zone in your field plot.
This toolbar allows you to turn on or off the grid, contour, vector, shade, edge, and translucency layers
for the selected zone(s). Additionally, you may adjust frequently-used style settings for each layer using
the drop-down menu to the right of each, for example selecting a color for the grid (or choosing a
variable by which to color it).

The Zone Style dialog may be opened by clicking the Zone Style button in the Plot sidebar or from the
Plot menu. Initially, any zones selected in the workspace are selected in the Zone Style dialog. You may
also double-click any zone in your plot to open the dialog with that zone selected.



Field plots containing transient data work slightly differently from static datasets in
the Zone Style dialog. If a zone contains no data at the current time step, that entire
line in the Zone Style dialog is grayed out. See Time Aware for more information on
working with transient datasets.

The following pages are available in the Zone Style dialog, each representing a plot layer:

Mesh

See Mesh Layer.

Contour

See Contour Layer.

Vector

See Vector Layer.
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Scatter

See Scatter Layer.

Shade

See Shade Layer.

Edge

See Edge Layer.

Points

See Points.

Surfaces

See Surfaces.

Volume

See Derived Volume Object Plotting. (3D only)

Effects

See Translucency and Lighting.

The values in the Zone Style dialog can be modified in place. For example, some settings, such as Show
Zone, are represented by checkboxes, and can simply be clicked to toggle their state. Other settings
allow you to right-click to display a context menu or other method for changing them. These allow you
to change the setting for multiple zones at once by selecting the desired zones (hold down Shift or
Control while clicking), then right-clicking in the column for the setting you wish to change.



Each page of the Zone Style dialog is divided into three color-coded regions. The blue
columns apply to the zone itself and are the same on all pages of the dialog. The green
and orange columns represent primary and secondary settings specific to the
corresponding plot layer.

The following attributes in the Zone Style dialog apply to the zone in general and appear on all pages
of the dialog.

Zone Number

The number of each zone.

Zone Name

The name of each zone. Strands are indicated by an "*" after the name.


For transient data, the first zone of the strand applicable to the current time step is
displayed in the Zone Name and Zone Number columns.
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Group Number

Displays the zone’s group number. Double-click to change the number.

Show Zone

By default, all zones are displayed. Turn zones or groups of zones on or off by toggling the
checkboxes in this column on or off.

Select Zones by Pattern

Enter a wildcard pattern in the Selection criteria text box and click Zones or Groups to select one
or more zones based their name or group number. Selecting Zones will match the selection criteria
with the Zone Name while selecting Groups will match the selection criteria with the Group
Number. In wildcard patterns, most characters match themselves, but the * and ? characters have
special meaning.

Character Meaning

? Matches any single character.

* Matches any number of characters, including none.

Clear

Clear the selection and the Selection criteria field.

The remaining columns in the Zone Style dialog are dependent upon the active page and are discussed
in their corresponding sections.

Points

You may select the source for the data points used to plot vectors and scatter symbols from the Points
page of the Zone Style dialog (shown below).
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For information on using the controls at the bottom of the Zone Style dialog to select
zones by name, see the description of these at the end of Field Plot Modification and
the Zone Style Dialog.

Figure 19 shows a plot where zone 1 is plotting scatter symbols only on one plane (J=5) and zone 2 is
plotting all symbols.

Figure 19. A plot showing two zones set to show only J-planes equal to five, with scatter symbols plotted on the
surface in zone 1 and all symbols in zone 2.

Points to Plot

Right-click to select how the points are plotted:

Nodes on Surfaces

Draws only the nodes that are on the surface of the zone.

All Nodes

Draws all nodes in the zone.

All Connected

Draws all the nodes that are connected by the node map. Nodes without any connectivity are not
drawn.

161



Cell Centers Near Surfaces

Draws points at the cell centers which are on or near the surface of the zone.

All Cell Centers

Draws points at all cell centers in the zone.

Index Skip

Right-click to specify the skip intervals for the I, J, and K-indices. The menu options are as follows:

No Skip

Set the I, J, and K-skip intervals to one; plot all points or vectors.

Enter Skip

Specify I, J, and K-skip intervals on the Enter Index Skipping dialog.

Enter Index Skipping

Use this dialog to enter the skip intervals for the I, J, and K indices.

A skip value of 1 for an axis indicates that every data point along this access will be used; a skip value
of 2 indicates every second data point, a skip value of 3 indicates every third data point, and so on.


For irregular and finite element data, only the I-Skip has an effect. I-skip will allow
you to skip through nodes in the order they are listed in the data file.

Surfaces

There are many ways to divide volume data for plotting. One way to view volume data is to select
surfaces from part of the data. In Tecplot Focus you may choose which surfaces to plot for volume
zones from the Surfaces page of the Zone Style dialog (accessed by double-clicking on a zone via the
Plot sidebar, or via Plot→Zone Style.
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For information on using the controls at the bottom of the Zone Style dialog to select
zones by name or by group number, see the description of these at the end of Field
Plot Modification and the Zone Style Dialog.

Right-click in the Surfaces to Plot column to choose one of the following:

None

None of the volume zone surfaces are plotted (edges still appear). This is the default Surfaces setting
for your plot.

Boundary Cell Faces

Plots all surfaces on the outside of the volume zone. This includes:

IJK-ordered data

The minimum and maximum I, J, and K-planes are plotted.

Finite element volume data

All faces that do not have a neighbor cell (according to the connectivity list) are plotted.

If blanking is turned on, the boundary cells in the blanked region will not be drawn and you will be
able to see the interior of the volume zone. Figure 20 shows plots of a volume zone with Surfaces to
Plot set to "Boundary Cell Faces": without blanking, with value blanking, and with IJK-blanking. See
Blanking for information on working with Blanking.
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Figure 20. Boundary Cell Face plotting without blanking, with value-blanking, and with IJK-blanking.

Exposed Cell Faces (default)

This setting is similar to the "Boundary Cell Faces" setting, unless value blanking is active. When
value blanking is used, the outer cell faces between blanked and non-blanked cells and the outer
surfaces of the data are drawn. Figure 21 shows a plot of a volume zone with Surfaces to Plot set to
"Exposed Cell Faces" with and without value blanking. See Blanking for information on working
with Blanking.
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Figure 21. Examples of plots where Surfaces to Plot has been set to Exposed Cell Faces with (left) and
without (right) value-blanking.

Planes Settings (I, J, K, IJ, JK, IK, and IJK-planes)

Plots the appropriate combination of I, J, and/or K-planes. The planes are determined by the Range
for each plane, which can be set by right-clicking in a range column. These settings are available
only for IJK-ordered data. Figure 22 shows a number of examples of plotting I, J, and K-planes.
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Figure 22. Examples of plotting I, J, and K-planes.

Every Surface (Exhaustive)

This setting will plot every face of every cell in volume data. It is not recommended for large
datasets. Unless the surfaces are translucent, the plot will appear the same as the Exposed Cell Faces
setting.

Ranges

The Range for I, J, or K Planes options allow you to specify the ranges for the corresponding
planes. Right-click in the appropriate Range column to enter the range as the beginning plane,
the ending plane (0 indicates the maximum index, -1 the next highest, and so on) and the skip
factor in the Enter Range dialog. Use a skip factor of two to display every other plane, a skip
factor of three to display every third plane, and so on.

Enter Range

The Enter Range dialog allows you to specify the I, J, or K index range in the Mapping Style or Zone
Style window or when performing an integration.
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Specify the beginning and end of the range. You may specify 0 to represent the maximum index, -1 to
represent the next highest, and so on.

You may also specify a skip value. A skip value of 1 considers every point in the range; 2 considers
every other point, and so on.

Derived Volume Object Plotting

The Volume page of the Zone Style dialog allows you to specify whether or not to show streamtraces,
iso-surfaces, or slices for the selected zone(s). Right-click in the appropriate column to choose yes or no.
Figure 23 shows a plot with two zones where streamribbons and an iso-surface have been excluded
from zone 2.
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Figure 23. A plot where streamribbons and an iso-surface have been excluded from zone 2.

Time Aware

For transient datasets, you can use the Tecplot Focus interface to display your data at a given time or to
animate your data over time. The zones loaded into Tecplot Focus can be linked to a specific solution
time, and the active solution time is used to determine which zones are displayed.

For the following definitions, consider the following fictitious dataset:

Table 3. Sample Time Aware Dataset

Zone Time StrandID

1 n/a n/a

2 0.0 2
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Zone Time StrandID

3 0.18 3

4 0.22 1

5 0.25 2

6 0.28 1

7 0.32 3

8 0.38 2

9 0.42 1

10 0.52 1

11 0.57 2

12 0.58 3

13 0.62 1

14 n/a n/a

Transient zones

Zones associated with time. The transient zone(s) displayed in the current frame are dependent
upon the current solution time. Zones 2-13 in Table 3 are transient zones.

Static zones

Zones not associated with time. They are displayed regardless of the current solution time. Zones 1
and 14 from Table 3 are static.

Current Solution Time

The value that determines which transient zones are displayed in the current frame.

Strand

A series of transient zones that represent the same part of a dataset at different times. Zones 2, 5, 8,
and 11 in Table 3 all have the same StrandID and therefore, they are part of the same strand.

StrandID

An integer value defined for each transient zone. The StrandID of a given zone is determined by the
data loader.


Changes made in the Zone Style dialog to any zone in a given StrandID are
propagated to all zones with that StrandID. See also Field Plot Modification and the
Zone Style Dialog.

Relevant Zone

Only "relevant zones" are plotted at a given solution time. Tecplot provides two different policies for
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determining what zones are relevant at any given solution time. Please refer to $!GlobalTime
TransientZoneVisibility macro command in the Scripting Guide for more information. The default
option is, ZonesAtOrBeforeSolutionTime. The rules for the different transient zone visibility options
are as follows:

ZonesAtOrBeforeSolutionTime

For each strand at a given solution time, the zones shown are those that are at the solution time,
within a tolerance. Except for the very first or last time step, if no zones exist at the given
solution time, zones shown are those from the first prior solution time showing zones.

ZonesAtSolutionTime

For each strand at a given solution time, the zones shown are those that are at the solution time,
within a tolerance.

Static zones are always considered relevant. Refer to Figure 24.

Figure 24. An illustration of how relevant zones are determined (based on the data in the figure using the
default transient zone visibility, ZonesAtOrBeforeSolutionTime). For a given solution time, the relevant zones
ONLY are displayed in the plot. NOTE: static zones are always considered relevant zones.

t = .2s

The red-colored transient zones and both static zones are plotted. NOTE: no zones from the first
strand are represented because the strand is not defined at that time.

t = .4s

The green-colored transient zones and both static zones are plotted.

t = .6s

The blue-colored transient zones and both static zones are plotted. NOTE: no zones from the second
and third strands are represented because the strands are not defined at that time.

Data Point and Cell Labels

Field Plots

You can label all or some of the data points or nodes in your field plots with either the index
value(s) of the data point or the value of some specified variable at each point. You can also label
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each cell or element of the data with its index (which for finite element data is its element number).

Line Plots

You can label all or some of the data points or nodes in your line plots with either the index of the
data point, the value of the dependent variable at the point, or both the values (X&Y or Theta & R) for
the data point. For example, Figure 25 shows an XY Line plot with each data point labeled with its X-
Y value pair.

Figure 25. An XY-line plot with data labels.

To add data labels to your plot, go to Plot→Label Points and Cells dialog (accessed via the Plot menu).
The Label Points and Cells dialog has the following options:
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Show Node Labels

Toggle-on to show node labels. Select either Index Value or Variable Value.



*[This feature is only available in Tecplot 360]*

Index values are not displayed for subzone data sets (.szplt) since these values
cannot currently be reliably determined with this file format.

Show Cell Labels

Toggle-on to show cell labels. Select either Index Value or Variable Value.

Index Skip

If labeling by index values, select an index skip.

Color Text by Zone/Map

Toggle-on and choose the color, font, font size, and number format for the labels.

Include Text box

Toggle-on "Include Text Box" to include a box around each label.

Three-dimensional Plot Control

You can view any type of data as a 3D plot by selecting 3D Cartesian from the plot type drop-down
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menu in the Plot sidebar. IJK-ordered data and finite element volume data are displayed in 3D
automatically.

Three-dimensional plots can be manipulated with the following controls, which can be accessed via
the Plot menu:

Reset 3D Axes

Reset the 3D axis sizes and the 3D origin of rotation.

Three-dimensional Axis Limits

Control the data and axis aspect ratios for 3D plotting.

Three-dimensional Orientation Axis

Control the optional 3D orientation axis, which displays the current orientation of the three axes in
the workspace.

Light Source

Control the light source position, as well as the intensity of the light, the background light, and the
surface color contrast. See Three-dimensional Light Source for more details.

Advanced 3D Control

Specify the default lift fraction for 3D lines, symbols, and tangent vectors, as well as the 3D sorting
algorithm for the plot.

The following controls can be accessed via the View menu.

The Rotate Dialog

Control the 3D orientation of the plot.

Three-dimensional View Details

Set the specifications for parameters affecting the 3D display of your plot, including the perspective,
field of view, angular orientation of the plot, and view distance.

Reset 3D Axes

By default, the 3D axes are calculated to fit the data. If you alter your data to expand or contract the
overall data size, the axes will not automatically adjust to the new size. Use the Reset 3D Axes option
(accessed via the Plot menu) to reset the axes to fit the data.


The Reset 3D Axes option also resets the 3D origin. If you have modified your 3D
origin using the 3D Rotate dialog (see The Rotate Dialog for details), the Reset 3D
Axes option will reset it to approximately the centroid of the data.
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Three-dimensional Axis Limits

In a 3D plot, whenever you read a data file, manipulate the values of variables assigned to the axes, or
change variables assigned to the axes, Tecplot Focus examines the data and determines how to plot it.
The data may require scaling in one or more axis directions, a change of the axis dependency, an
adjustment of the space between the data and the axis box, and/or an adjustment of the shape of the
axis box.

Because there are many valid forms in which the data could be plotted, by using the 3D Axis Limits
dialog (accessed via the Plot menu), you can input information to help Tecplot Focus determine how to
automatically configure the plot the way you want.



Aspect Ratio

Ratio of the range of the variable assigned to one axis (multiplied by the axis size
factor) and the range of the variable assigned to another axis (multiplied by the
axis size factor).

Data Aspect Ratio Limit

When the data aspect ratio of any two axes exceeds the Data Aspect Ratio Limit, Tecplot Focus
automatically rescales the longer axis so that the new data aspect ratio is equal to the Data Aspect
Ratio Reset value.

If your plots are usually unscaled (such as plots of real physical objects), you should set the data
aspect ratio maximum to a large number like 30. Use a smaller number for evenly scaled axes.

Axes Aspect Ratio Limit

Works similarly to the Data Aspect Ratio Limit, except Axes Aspect Ratio Limit attends to the shape
and size of the axes box.

Three-dimensional Orientation Axis

174



The 3D orientation axis is a representation of your axes that immediately shows you the orientation.
By default, all 3D plots show the 3D orientation axis in the upper right of the frame.

Using the 3D Orientation Axis dialog under the Plot menu, you can control whether the 3D
orientation axis is shown in your plot, and if so, its color, size, line thickness, and the position of the
axis origin. You can also position the 3D orientation axis by simply clicking on it and dragging the axis
to the desired location in the frame.

Advanced 3D Control

Lift Fractions

The lift fraction is the fraction of the distance from the 3D origin of the object to your eye. If you
specify lift fractions for 3D lines, tangent vectors, or scatter symbols, plotted objects of the
appropriate type are lifted slightly towards you so that they lie on top of surface elements.

Perform Extra 3D Sorting

For some 3D plots (i.e. plots with translucency), Tecplot Focus uses a painter’s algorithm. A quick
sorting algorithm is used by default. The data objects are divided into smaller objects. The smallest
object is usually a cell, finite element, vector, or scatter symbol. These objects are sorted based upon
the distance from viewer, starting with the objects farthest from the viewer and working forward.
This does not detect problems such as intersecting objects. If the "Perform Extra 3D Sorting" check
box is selected, a slower, more accurate approach is used to detect problems for you.
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There are instances when Tecplot Focus cannot sort correctly. For example, consider elements A, B,
and C, where element A overlaps part of element B which overlaps part of element C which
overlaps part of element A. Since Tecplot Focus draws only whole elements, one of these elements
will be drawn last and each will cover (incorrectly) a portion of another element. If this occurs
while printing or exporting, choosing an image format will often resolve the problem


All of the settings in the Advanced 3D Control dialog are specific to the current
frame.

The Rotate Dialog

You may rotate your 3D plots using the 3D Rotate dialog accessible via View→Rotate. The 3D rotation
tools located in the toolbar are discussed in Three-dimensional Rotation.

The 3D Rotate dialog has the following options:

Rotate around

• Click the + or - buttons next to an axis to rotate the plot incrementally around that axis.

• The Rotation Step field specifies the increment by which each click of the + or - button rotates the
plot.
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Center of Rotation

X

the X-axis. Enter a value in the text field, or use the increase or decrease arrows at the right to
specify a value.

Y

Rotation of the eye/origin ray about the Y-axis. Enter a value in the text field, or use the increase
or decrease arrows at the right to specify a value.

Z

Rotation of the eye/origin ray about the Z-axis. Enter a value in the text field, or use the increase
or decrease arrows at the right to specify a value.

Reset

Use this drop-down to set the center of rotation to be the Center of Data (the center of the
bounding box of the data) or Center of View (the point hit by a probe at frame coordinates 50%,
50%).


Center of View can result in an error if there is no data in the center of the
frame. In this situation, the center of rotation will not move.

Spherical Angles

Eye origin view. The angular orientation of the plot is defined by three spherical rotation angles:

 (Psi)

Tilt of eye origin ray away from Z-axis. (Range –720 to 720.)

 (Theta)

Rotation of the eye origin ray about the Z-axis. (Range –720 to 720.)

 (Alpha)

Twist about the eye origin ray. (Range –720 to 720.)

The eye origin ray is a line from the origin of the 3D object to your eye. The eye origin ray is
perpendicular to the plane of the computer screen. These angles define a unique view. These angles
are shown in Figure 26.
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Figure 26. 3D angles and 3D projection.

Preset Angles

Specify one of four pre-defined orientations: the XY-Plane, the YZ-Plane, the XZ-Plane; or a default
orientation with a Psi=60, Theta=225, and Alpha=0).

Rotate About the Viewer Position

In addition to the rotation capabilities described above, you may also use the Alt key and mouse to
rotate about the viewer (instead of rotating the object). Although you may use this feature while in
orthographic projection, it is best suited for when perspective projection is being used. The Alt key and
your middle mouse button may be used to simulate fly-through type motion. You may move closer to
the object using the Alt key and middle mouse button, then turn your head using the Alt key and left
mouse button.

Three-dimensional View Details

Use the 3D View Details dialog (accessed via the View menu) to control a variety of parameters
affecting the display of 3D plots.
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Use Perspective

Sets Tecplot Focus’s projection type. If selected, Tecplot Focus draws the current frame with
perspective projection. If not selected, Tecplot Focus draws the current frame with orthographic[5]

projection. (Range is 0.1 to 179.9.)

Field of View (deg)

Sets the amount of the plot (in terms of spherical arc) in front of the viewer that may be seen.
Zooming in or out of a 3D perspective plot changes this number and the viewer’s position.

Maintain Object Size During Field of View Changes

If selected, Field of View changes result in the viewer’s position being moved so that approximately
the same amount of the plane is visible after the change.

If not selected, Field of View changes do not change the viewer’s position and result in the entire
plot appearing to grow or shrink.

View Width

Sets the amount of the plot (in X-axis units) in front of the viewer that may be seen. Zooming in or
out of a 3D orthographic plot changes this number, but not the viewer’s position. Not available
when using perspective.

Viewer Position

Change the viewer’s relation to the image by resetting the X, Y, or Z-location, or by changing the
view distance.

Three-Dimensional Zooming and Translating

Just as in all other plots, you may zoom and translate your plot using the mouse. This may be done
using either the Zoom or Translate tools. For most tools, you may also use your middle and right mouse
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buttons (or Ctrl+right mouse button) to zoom and translate.

When the plot projection is orthographic, zooming by dragging with the middle mouse button
magnifies the plot. When the plot projection is perspective, zooming by dragging with the middle
mouse button changes the viewer angle, making the plot appear larger or smaller. If you want to
change the viewer’s position by moving closer to or further away from an object, hold the Alt key
down while using the middle mouse button or while using the 3D mouse.


Working with very large datasets may result in slow zooming, rotating, and
translating. See Performance Dialog for further information on plot approximation if
zoom, rotate, or translate performance is poor.

Mesh Layer and Edge Layer
When working with two or three-dimensional field plots, Tecplot Focus allows you to interactively add
or subtract any combination of plot layers. These layers can be applied to any set of zones in the active
data set. This chapter discusses the Mesh Layer and the Edge Layer.

Mesh Layer

Toggle-on "Mesh" in the Plot sidebar to add a mesh layer to your plot. The mesh plot layer displays the
lines connecting neighboring data points within a zone. For I-ordered data, the mesh is a single line
connecting all of the points in order of increasing I-index. For IJ-ordered data, the mesh consists of two
families of lines connecting adjacent data points of increasing I-index and increasing J-index. For IJK-
ordered data, the mesh consists of three families of lines, one connecting points of increasing I-index,
one connecting points of increasing J-index, and one connecting points of increasing K-index. For finite
element zones, the mesh is a plot of every edge of all of the elements that are defined by the
connectivity list for the node points. See Data Structure for an in-depth description of ordered (IJK) and
finite element data structures.

Mesh Layer Modification
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Once you have loaded your data, you can modify your mesh plot attributes using the Mesh page of the
Zone Style dialog (accessed via the Plot sidebar or Plot→Zone Style). As discussed in Field Plot
Modification and the Zone Style Dialog, the changes made using the first four (blue) columns apply to
the entire plot, while changes in the other columns apply to the active plot layer.


In order for the changes made on the Mesh page to be visible in your plot, the Mesh
layer must be turned on. You can turn on the Mesh layer using the checkbox in the
Plot sidebar.

Show Mesh

Checkbox that determines whether the mesh is visible for each active zone.

Mesh Type

Right-click to choose wire frame, overlay, or hidden line. See Mesh Types below.

Mesh Color

Right-click to choose the mesh color using the Color Chooser.

Line Pattern

Right-click to choose the line pattern for the mesh.

Pattern Length

Right-click to choose the pattern length in percentage of frame height. You may choose a preset
pattern length or enter your own.

Line Thickness

Right-click to choose the mesh line thickness. You may choose a predefined setting or enter your
own.

 For information on using the controls at the bottom of the Zone Style dialog to select
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zones by name, see the description of these at the end of Field Plot Modification and
the Zone Style Dialog.

Mesh Types

Tecplot Focus has three distinct mesh types:

Wire Frame

Wire frame meshes are drawn below any other zone layers on the same zone. In 3D Cartesian plots,
no hidden lines are removed. For 3D volume zones (finite element volume or IJK-ordered), the full
3D mesh (consisting of all the connecting lines between data points) is not generally drawn because
the sheer number of lines would make it confusing. The mesh drawn will depend upon your choice
of "Surfaces to Plot" on the Surfaces page of the Zone Style dialog. See Surfaces for further details.
By default, only the mesh on exposed cell faces is shown.

Overlay

Similar to Wire Frame, mesh lines are drawn over all other zone layers except for vectors and
scatter symbols. In 3D Cartesian plots, the area behind the cells of the plot is still visible (unless
another plot type such as contour flooding prevents this). As with Wire Frame, the visibility of the
mesh is dependent upon your choice of "Surfaces to Plot" on the Surfaces page of the Zone Style
dialog. See Surfaces for further details.

Hidden Line

Similar to Overlay, except hidden lines are removed from behind the mesh. In effect, the cells
(elements) of the mesh are opaque. Surfaces and lines that are hidden behind another surface are
removed from the plot. For 3D volume zones, using this plot type obscures everything inside the
zone. If you choose this option for 3D volume zones, then choosing to plot every surface (using the
Surfaces page of the Zone Style dialog) has the same effect as plotting only exposed cell faces, but is
much slower.


The opaque surfaces created by Hidden Line are not affected by the Lighting Zone
effect (there is no light source shading). However, it is affected by translucency.

Figure 27 shows the available mesh plot types, along with the effects of choosing Overlay and Wire
Frame in combination with contour flooding.
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Figure 27. Mesh plot types.
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Edge Layer

An edge plot layer displays the connections of the outer lines (IJ-ordered zones), finite element surface
zones, or planes (IJK-ordered zones). The Edge layer allows you to display the edges (creases and
borders) of your data. Zone edges exist only for ordered zones or 2D finite element zones. Three-
dimensional finite element zones do not have boundaries.

Edge Layer Modification

You can control the following attributes from the Edge page of the Zone Style dialog:


In order for the changes made on the Edge page to be visible in your plot, the Edge
layer must be turned on. You can turn on the Edge layer using the checkbox in the Plot
sidebar.

Show Edges

Checkbox that determines whether the edges are visible for each active zone.

Edge Type

Right-click to choose borders and/or creases. See Edge Types below.

Edge Color

Right-click to choose the edge color using the Color Chooser.

Line Thickness

Right-click to choose the edge line thickness. You may choose a predefined setting or enter your
own.

Index Borders

Right-click to choose whether to show the corresponding index border: None, Min Only, Max Only,
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or Both (Min and Max).


For information on using the controls at the bottom of the Zone Style dialog to select
zones by name, see the description of these at the end of Field Plot Modification and
the Zone Style Dialog.

Edge Types

There are two types of edges in Tecplot Focus: creases and borders. An edge border is the boundary of
a zone. An edge crease appears when the inside angle between two cells is less than a user-defined
limit. The inside angle can range from 0-180 degrees (where 180 degrees indicates coplanar surfaces).
The default inside angle for determining an edge crease is 135 degrees. You can change the crease
angle by going to Plot→Edge Details.


For 2D plots, only edge borders are available, and for FE-volume zones, only edge
creases are available.

You can change the Edge Type using the Edge Type column on the Edge page of the Zone Style dialog.

Edge Display

For IJ-ordered zones, the available edges are the lines I=1, I=IMax, J=1, and J=JMax.

When the Surfaces to Plot option is set to "Boundary Cell Faces", "Exposed Cell Faces", or "Every
Surface" for IJK-ordered zones, the edges of the surface areas form a "box" that contains the data.
Surfaces to Plot can be set on the Surfaces page of the Zone Style dialog.

When the Surfaces to Plot option on the Surfaces page of the Zone Style dialog is set to one of the
planes options, such as I, J, or K-planes, for IJK-ordered zones the edges are the edges of each plane (I, J,
or K-plane). By default, all available edges are drawn when the Edge layer is active. You can specify
which of the available edges are plotted using the Zone Style dialog.

Contour Layer
Contour plots can be used to show the variation of one variable across the data field. To add a contour
layer to your plot, toggle-on "Contour" in the Plot sidebar.


Contour plots can only be plotted with organized data, such as IJ-ordered, IJK-ordered,
or FE-data. Refer to Working with Unorganized Datasets for information on
organizing your dataset.

Additional options can be set on the Contour & Multi-Coloring Details (accessed via  to the right of
Contour in the Plot sidebar or Plot→Contour/Multi-Coloring) and the Contour page of the Zone Style
dialog.
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An example of each contour plot type is shown in Figure 28.

Figure 28. Contour plot types.
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Contour plots for streamtraces, iso-surfaces, and slices are controlled by their
respective details dialogs and are not discussed here. (Refer to Rod/Ribbon Page, Iso-
Surface Contour and Shade and Contour Page, respectively.)

Contour Layer Modification

You can modify the following attributes of your contour plot using the Contour page of the Zone Style
dialog.


In order for the changes made on the Contour page to be visible in your plot, the
Contour layer must be active. You can turn on the Contour layer in the Plot sidebar.

Show Contour

Toggle-on to show the contour for the selected zone(s).

Contour Type

Right-click to choose the contour plot type:

Lines

Draws lines of constant value of the specified contour variable.

Flood

Floods regions between contour lines with colors from a color map.

The distribution of colors used for contour flooding may be banded or continuous. When banded
distribution is used for flooding, a solid color is used between contour levels. If continuous color
distribution is used, the flood color will vary linearly in all directions. See Contour & Multi-Coloring
Details for details.
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Both Lines and Flood

Combines the above two options.

Average Cell Flood

Floods cells or finite elements with colors from a color map according to the average value of the
contour variable over the data points bounding the cell. If the variables are located at the nodes,
the values at the nodes are averaged. If the variables are cell-centered, the cell-centered values
are averaged to the nodes and the nodes are then averaged.

Go to Data→Data Set Info to determine whether the variables are nodal or cell-centered.

Primary Value Flood

Floods cells or finite elements with colors from a color map according to the primary value of the
contour variable for each cell. If the variable is cell centered, the primary value is the value
assigned to the cell. If the variable is node located, the primary value comes from the lowest index
node in the cell.

If the variables are located at the nodes, the value of the lowest indexed node in the cell is used.
When plotting IJK-ordered, FE-brick or FE-tetra cells, each face is considered independently of the
other faces. You may get different colors on the different faces of the same cell.

If the variables are cell-centered, the cell-centered value is used directly. When plotting I, J, or K-
planes in 3D, the cell on the positive side of the plane supplies the value, except in the case of the
last plane, where the cell on the negative side supplies the value.

Go to Data → Data Set Info to determine whether the variables are nodal or cell-centered.

Flood By

Right-click to select either a contour group (C1, C2, C3, C4, C5, C6, C7, or C8) or assign variables to the
RGB color map. For contour groups, the associated variable is shown in this column and the menu
next to the group number. See Contour Groups and RGB Coloring for more information. Applicable
only when the contour type includes a flood.

Lines By

Right-click to select which contour group identifies the contour lines (the variable associated with
each contour group is also shown). Applicable only when the contour type includes lines.

Line Color

Right-click to choose the contour line color using the Color Chooser.

Line Pattern

Right-click to choose the line pattern for the mesh.

Pattern Length

Right-click to choose the line pattern length as a percentage of frame height. You may choose a
preset pattern length or enter your own.
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Line Thickness

Right-click to choose the contour line thickness. You may choose a predefined setting or enter your
own.

Line Color

Coose the contour line color.

Use Lighting (3D only)

Turn on or off the lighting effects. See Translucency for more information on lighting effects.

Options such as contour labels, contour legends, and special settings for contour bands or contour lines
are set by the selected contour group (see Contour Groups).


For information on using the controls at the bottom of the Zone Style dialog to select
zones by name, see the description of these at the end of Field Plot Modification and
the Zone Style Dialog.

Contour & Multi-Coloring Details

Opening the Contour & Multi-Coloring Details dialog from Plot→Contour/Multi-Coloring or from
the Plot sidebar lets you specify:

• Contour Groups

• Contour Levels and Color

• Contour Bands

• Contour Lines

• Contour Labels

• Contour Legend

Contour Groups

The Contour & Multi-Coloring Details dialog is shown below. This dialog is divided into five pages.
The controls at the top for choosing a contour group and variable are available regardless of what page
of the dialog is displayed.
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Variable

Assign a variable from your dataset to the active Contour Group (1, 2, 3, 4, 5, 6, 7, or 8). The variable
selected here will be contoured subject to the controls in the dialog.

1, 2, 3, 4, 5, 6, 7, 8

Use the 1, 2, 3, 4, 5, 6, 7, and 8 buttons to specify attributes for a specific contour group. Each contour
group has its own settings for the contour attributes established in the dialog.

The Contour Group Variables (1-8) can be used to color contour, mesh, scatter, or vector zone layers, as
specified in the Color Chooser dialog and the Flood By and Lines By columns on the Contour page of
the Zone Style dialog.
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Contour Levels and Color

A contour level is a value at which contour lines are drawn, or for banded contour flooding, the border
between different colors of flooding. Adjust contour levels using the Levels and Color page of the
Contour & Multi-Coloring Details dialog (accessed via the Plot sidebar or the Plot menu, or from the
Contour Page of the Slice Details dialog).

From the Levels and Color page of the dialog, you can add, subtract, and rearrange contour levels
using the top part of the dialog. The bottom part of the dialog allows you to choose or modify the color
map to be used for coloring the contour variable.

The minimum and maximum value of the contour value is also displayed here. When the contour
variable is calculated from subzone data, one or more of the values displayed may be estimates, which
is indicated by (est) next to the affected values.
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Contour Level Addition

You can add new levels in one of three ways:

• Enter a value in the text field in the Levels and Color page of the Contour & Multi-Coloring Details
dialog and click Add Level to propagate it to the Levels list on the left.

• Add a new range of contour levels to the existing set by clicking Set Levels, then using the Enter
Contour Levels dialog as described in New Contour Level Specification.

• Choose  from the Toolbar, then click at any location in the contour plot where you would like to
add a new contour level. Tecplot Focus adds a new contour level that goes through the specified
point. By holding down the mouse button you can drag and interactively position the new contour
level until you release the button.

Contour Level Removal

You can remove contour levels by:

• Selecting one or more contour levels on the Levels and Color page of the Contour & Multi-
Coloring Details dialog, then clicking Remove Selected Levels.

• Selecting  from the Toolbar, then clicking any contour line in your contour plot. Tecplot Focus
deletes the specified contour level, or the nearest contour level to the specified point.

Contour Level Adjustment

You can interactively adjust a contour level with the  tool from the Toolbar. Hold down the Control
key, then click-and-drag the contour level you want to adjust. Move the contour to the desired location
and release the mouse button. The new value of the contour level can be viewed on the Levels and
Color page of the Contour Details dialog.

New Contour Level Specification

You may specify a new set of contour levels by clicking the Set Levels button on the Levels and Color
page of the Contour Details dialog. This button calls up the Enter Contour Levels dialog.
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You can create contour levels in two ways:

Exact levels

Specify the levels exactly using one of three methods.

Min, Max, and Number of Levels (default)

Enter a minimum and maximum level value, together with the number of levels to be
distributed equally throughout the range.

The Reset Range drop-down menu, available with this method, allows you to reset the Min and Max
values to the contour variable’s minimum and maximum, optionally excluding the effects of
blanking.

Min, Max, and Delta

Enter a minimum and maximum level value together with a delta (step-size between levels).

Exponential Distribution

Enter a minimum and maximum level value together with the number of levels to be distributed
exponentially throughout the range.
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Approximate levels

Enter the number of contour levels you want and let Tecplot Focus choose their values. The values
chosen will be "nice" levels based on the values of the current contour variable.

Contour Coloring

You can choose a built-in color map, edit an existing color map, or create a new color map in the Levels
and Contour page.

The built-in color maps cannot be changed. When you begin to modify a built-in color map by moving,
adding, or removing control points, the built-in color map is automatically and immediately copied to a
custom color map. The copy is given a name ending with the word "modified" and a number, and it is
this copy to which further changes apply. Custom color maps can be edited, renamed, or deleted using
the gear icon next to the color map menu.

You can create a new color map, then, by first choosing a built-in color map that is close to the color
map you want to create (if none is particularly close, any will do) and beginning to modify it. You can
then give it a proper name by clicking the gear icon and choosing Rename Custom Color Map.

Custom color maps are automatically saved with layouts. You can also use them in other plots by using
the export and import functions on the gear menu.

Color Map Control Points

You can control how colors are distributed across the color map here.

194



Adjust a control point

Drag the diamond-shaped control points horizontally to control the intervals between them. The
color gradations in the color map will be stretched or compressed as necessary as you move the
control points.

Create a new control point

Right-click a part of the color map where there is not yet a control point, then choose Add Control
Point to create a control point there. The control point’s left and right colors will initially be set to
the colors in effect at the clicked location.

Change the control point colors

Right-click a control point to change its left (primary) or right (secondary) color by choosing Set
Control Point Color, then choosing the color to be set from the submenu. The Color Chooser
appears to let you choose the color to be used. The colormap will consist of a gradient of color
between one control point’s right color and the next control point’s left color. (The first and last
control points have only right and left colors, respectively.)

Delete a control point

Right-click a control point and choose Remove Control Point to delete it.

Color Map

Select the color map to use for contour coloring. The default is "Sequential - Viridis", a perceptually
linear color map from blue to yellow.

Click the gear menu to the right of the Color Map menu to rename or delete a color map, or to
import or export custom color maps.

Exporting Custom Color Maps

Saves all custom color maps as a .map file. These can be imported to other projects to maintain
consistency.

Import Color Maps

Opens a browser window to import a .map file.

Custom color maps may also be created by using the $!CREATECOLORMAP command in a macro,
configuration, layout, map, or stylesheet file.


When exporting, all the color maps that aren’t one of Tecplot’s original set of 45 build-
in, immutable, color maps are saved into one .map file.

A short example for loading custom color maps is shown below. Custom color maps may also be loaded
via the $!INCLUDEMACRO command. The $!GLOBALCONTOUR command in the script below assigns a color
map to one of the eight contour layers. For more information see the Scripting Guide

$!INCLUDEMACRO "|MACROFILEPATH|/Macaw.map"
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$!GLOBALCONTOUR 1 COLORMAPNAME = 'Sequential - Macaw'
$!GLOBALCONTOUR 2 COLORMAPNAME = 'Sequential - Macaw'
$!GLOBALCONTOUR 3 COLORMAPNAME = 'Sequential - Macaw'
$!GLOBALCONTOUR 4 COLORMAPNAME = 'Sequential - Macaw'
$!GLOBALCONTOUR 5 COLORMAPNAME = 'Sequential - Macaw'
$!GLOBALCONTOUR 6 COLORMAPNAME = 'Sequential - Macaw'
$!GLOBALCONTOUR 7 COLORMAPNAME = 'Sequential - Macaw'
$!GLOBALCONTOUR 8 COLORMAPNAME = 'Sequential - Macaw'


For Tecplot Focus 2017 R3 and later, the $!CREATECOLORMAP macro command is allowed
in the configuration file. This allows users to define their own color maps and select
the default for each contour group. See the Scripting Guide for more information.

Color Distribution Methods

Banded

A solid color is assigned for all values within the band between two levels. (See Contour Bands.)

Continuous

The color distribution assigns linearly varying colors to all multi-colored objects or contour
flooded regions. You can vary the default assignment of colors by entering a "Min" or "Max"
value for Color Map Endpoints. You may reset the endpoints to the contour variable’s min/max
(considering the effects of blanking), the contour variable’s min/max excluding the effects of
blanking, or to the contour level’s min/max using the Reset menu to the right of these fields.

Approximate Continuous

Causes each cell to be flooded using interpolation between the RGB values at each node. When
the transition from a color at one node to another node crosses over the boundary between
control points in the color spectrum, approximate flooding may produce colors not in the
spectrum. Leaving this option unchecked is slower, but more accurate.

Color Cutoff

Lets you specify a range within which contour flooding and multi-colored objects (such as scatter
symbols) are displayed.

Color Map Adjustments

The following optional adjustments are applied to the color map generated by the above settings.

Reversed Color Map

You can reverse the color map by toggling on "Reverse". Two plots, one with the color map going
in the default direction and one with the color map reversed, are shown in Figure 29.
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Figure 29. Left: Flooded contour plot with default settings. Right: Flooded contour plot with a reversed
colormap.

Repeat Cycles

You may choose to cycle the color map. This is useful if you have data where there is a great deal
of activity in multiple ranges of the contour variable, and you want to cycle through all colors in
each region. A plot with the color map cycled twice is shown in Figure 30.

Figure 30. Left: Flooded contour plot with default settings. Right: Flooded contour plot with the color map
cycled two times.

Rename Color Map

The Rename Color Map dialog allows you to enter a new name for a user-defined color map. This name
will appear throughout Tecplot Focus.

You may not give a custom color map the same name as a built-in color map.


When renaming a color map, spaces will be removed from the beginning and end of
the new name.

Contour Bands

When Coloring Distribution for a group is set to "Banded" (via the Levels and Color page of the
Contour & Multi-Coloring Details dialog), you may customize the color bands on the Bands page of
the dialog.
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The Bands page of the Contour Details dialog has the following options:

Include Zebra Shading

This effect colors every other band with a specific color (or no color at all).

Override Band Colors

Specific contour bands can be assigned a unique basic color. This is useful for forcing a particular
region to use blue, for example, to designate an area of water. You can define up to 16 color
overrides.

Override

Specifies which override is being edited.
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Active

Toggle this checkbox to turn the override on or off.

Color

Select the color for the override using the Color Chooser.

Minimum, Maximum

Choose the range which will be overridden to the specified color.

Contour Lines

The contour line settings determine how contour lines are drawn for all zones in the active frame’s
dataset. The settings are established on the Lines page of the Contour & Multi-Coloring Details dialog.
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Use Zone Line Pattern

For each zone, draw the contour lines using the line pattern and pattern length specified in the
Contour page of the Zone Style dialog.


*[This feature is only available in Tecplot 360]* If you are adding contour lines
to polyhedral zones, the patterns will not be continuous from one cell to the next.
The pattern will restart at every cell boundary.

Skip to Solid

Draw  dashed lines between each pair of solid lines, where  is an integer you enter in the text field
Number of Dashed Lines to Draw between Solid Lines.

Dashed Negative Lines

Draw lines of positive contour variable value as solid lines and lines of negative contour variable
value as dashed lines.

Contour Labels

Contour labels are labels that identify particular contour levels either by number or by value. You can
place contour labels interactively, or have Tecplot Focus create them for you automatically. You can
also have Tecplot Focus create and save a set of contour labels automatically, then interactively add
contour labels to this saved set.

 The contour plot type must be lines or lines and flood in order to use Contour labels.

Contour labels may be configured in the Labels page of the Contour & Multi-Coloring Details dialog
or with the Add Contour Label mouse mode tool from the Toolbar. You can modify the following
options using the Labels page of the Contour Details dialog.

200



Show Labels

Toggle-on "Show Labels" to include contour labels in your plot. You can then label the contour levels
by selecting either Use Contour Number or Use Contour Value.

Label Format

Use the midsection of the dialog to customize label color, font, and fill settings. (See Font Folders and
Fallback for more information on how fonts work with Tecplot Focus.)

Generate Automatic Labels (with each Redraw)

At each Redraw, Tecplot Focus creates a new set of contour labels. At any time, you can deselect the
"Generate Automatic Labels" (with each Redraw) check box, and Tecplot Focus retains the last set of
labels generated.
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Align Labels with Contour Line

Use the Spacing field to specify the spacing of the contour labels along the contour line, as a
percentage of the frame. Use the Level Skip field to specify a skip value between the contour levels
to be labeled.

Align Next User-Positioned Label

If the "Align Next User-Positioned Label" is selected, the next label is aligned with the contour line.
Otherwise, the label is written with normal, upright text.

Number Format

Use the Number Format button to specify the number formatting of the Contour labels. See Specify
Number Format for more details.

Clear All Contour Labels

When "Generate Automatic Labels" is deselected, you can click this button to erase the current set of
contour labels.

Contour Legend

To include a contour legend, select the Legend page of the Contour & Multi-Coloring Details dialog
for the appropriate contour group.
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The following options are available:

Show Contour Legend

Select this option to show the contour legend on your plot.

Alignment

Select Vertical or Horizontal.

Anchor

Specify which part of the legend is anchored in the selected position using the Anchor Alignment
dialog.

Position

X (%) and Y (%) as percentages of the frame width and height. (You can also move the legend
interactively.)
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Legend Box

Displays the Legend Box dialog to adjust the appearance of the box around the legend, or turn it off
entirely.

Separate Color Bands

Select this check box to separate the color bands in the legend with black lines. Use this option to
visually separate similar colors. If this box is not selected, similar adjacent colors may tend to blur
together.

Resize Automatically

Automatically skips some levels to create a reasonably sized legend.

Include Color Cutoff Levels

Color bands and labels for levels affected by Color Cutoff are shown in the legend.

Label Continuous Colors Position

If you have selected "Continuous Color Distribution" on the Levels and Color page of the Contour
Details dialog, you have three options for placement of labels on the legend:

Contour Levels

This option places one label for each contour level. See Contour Levels and Color.

Specified Increment

Enter a value in the Increment text field.

Color Map Divisions

Places one label for each control point on the color map.

Level Skip

Enter the number of levels between numbers on the legend. This also affects the number of levels
between contour labels on the plot. Skipping levels on the contour legend compresses the color bar
(if one appears); it does not change the spacing between text entries on the legend.

Line Spacing

Enter the spacing between contour legend numbers. This does not change the number of entries in
the legend, so a large value here creates a large legend. Use Level Skip to reduce the number of
entries in the legend.

Text Color

Affects the color of all text in the legend.

Number Format

Adjust the format of numbers in the legend. See Specify Number Format for more details on
numeric formatting
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Number Font

Choose the font used for numbers in the legend, including size and variety (boldface or italic). See
Font Folders and Fallback for more information on how fonts work with Tecplot Focus.

Show Header

Toggle-on to display the contour legend header text.

Header Text

Allows selection of content displayed in the legend header.

Use Variable Name

The legend header will display the variable name assigned to the contour group.

Use Text

The legend header will display text entered into the text field next to the options widget. The
text can contain dynamic text (See Dynamic Text for information on dynamic text) and
formatted using tags (See Text Details for information text formatting tags).

Use LaTeX

The legend header will display a processed LaTeX expression. See LaTeX Expressions for
information on LaTeX formatting.

Header Format

Adjust the font and height for the legend header or the legend labels, including font size and
variety (boldface or italic). (See Font Folders and Fallback for more information on how fonts
work with Tecplot Focus.)


Not all fonts have Bold and/or Italic variants. For fonts that do not have these
styles, the B and/or I buttons may have no effect.

Anchor Alignment

The Anchor Alignment dialog allows you to specify the anchor point, or fixed point, of the object. As
the box grows or shrinks, the anchor location is fixed while the rest of the box adjusts to accommodate
the new size. There are nine possible anchor points, corresponding to the left, right, and center
positions on the headline, midline, and baseline of the box.
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Legend Box

The Legend Box dialog appears when you click the Legend Box button in the Legend page of the
Contour Details dialog.

Box Type

Choose (left to right) No Box, Outline, or Fill. If you choose Outline or Fill, the following options
control the appearance of the box.

Line Thickness

Specify the line thickness as a percentage of frame height.

Box Color

Choose a color for the legend box outline.

Fill Color

Choose a color for the legend box fill (Fill mode only).

Margin

Specify the margin between the legend text and legend box as a percentage of the text height.

Extract Contour Lines

Normally, contour lines are derived from the dataset "on the fly" and do not add any data to the
dataset. To extract existing contour lines to Tecplot zones, allowing you to retain them even if the
contour details are changed, go to Data→Extract→Contour Lines. Your data will be altered by the
creation and naming of new zones.
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Using the Extract Contour Lines dialog, you have the following options:

Create a separate zone for each contour level

A new zone will be created for each contour line plotted. The number of new zones will equal the
number of contour levels. The created zones are FE-line segment type zones.

Create a separate zone for each independent line segment in each zone

With this option you may create many more zones than there are contour levels. New I-ordered line
segment zones are created in each source zone for each topologically independent contour line.

After generating the zones, we recommend you activate the Mesh Layer when plotting the new zones.

Vector Layer
You can create vector plots by activating the Vector layer in the Plot sidebar, and specifying the vector
component variables. Vector plot attributes can be modified using the Vector page of the Zone Style
dialog.
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Figure 31. A vector plot of the cylinder data (with the edge layer also active)

Vector Variables

When you activate the Vector zone layer (via the Plot sidebar), Tecplot Focus checks to see whether
vector components have been assigned for the current dataset in the current plot type. If you have not
assigned vector components, the Select Variables dialog, shown here, will be launched.

Choose variables by selecting the desired U, V, and W (3D only) variables from their respective drop-
downs. You may select any of the current dataset’s variables as any component. You can change the
component variables at any time by choosing Vector→Variables from the Plot menu.

Once you have selected the Vector check box in the Plot sidebar and have chosen your vector
components, your vector plot will appear. If vectors are not visible, refer to Definition Page.
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Vector Plot Modification

You can modify your vector plot attributes using the Vector page of the Zone Style dialog. You can
control any of the following attributes from the Vector page of the Zone Style dialog.


In order for the changes made on the Vector page to be visible in your plot, the
Vector layer must be active (toggled on in the Plot sidebar).

Show Vector

Toggle-on to show the vector for a particular zone.

Vector Type

Select from the following options:

Tail at Point (default)

Draws the tail of the vector at the data point.

Head at Point

Draws the head of the vector at the data point.

Anchor at Midpoint

Positions the midpoint of the vector at the data point.

Head Only

Draws the head of the vector at the data point and does not draw a tail.

Figure 32 shows examples of each of the vector plot types.
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Figure 32. The Vector plot types: tail at point, head at point, anchor at midpoint, and head only.

Vector Tangents

Toggle-on to display only the tangent component of vectors, not both tangent and normal
components. Tangent vectors are drawn on 3D surfaces only where it is possible to determine a
vector normal to the surface. A plot where multiple surfaces intersect each other using common
nodes is a case where tangent vectors are not drawn because there is more than one normal to
choose from. An example of this would be a volume IJK-ordered zone where both the I and J-planes
are plotted. If tangent vectors cannot be drawn, then regular vectors are plotted instead.
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Figure 33. Comparison of the Vector Tangent options. A) vectors are drawn with both the normal and tangent
components. B) vectors are drawn with only the tangent components.

Head Style

Right-click to choose an arrowhead style for the vectors. Figure 34 displays the available styles.

Plain (default)

Line segments drawn from the head of the vector.

Filled

Filled isosceles triangles with apex at the head of the vector.

Hollow

Hollow isosceles triangles with apex at the head of the vector.
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Figure 34. Arrowhead types for vector plots (plain, filled and hollow).

Line Color

Right-click to choose the vector color in the Color Chooser dialog

Line Pattern

Right-click to choose the vector line pattern.

Pattern Length

Right-click to choose the vector line pattern length as a percentage of frame height. You may
choose a preset length or enter an exact number.

Line Thickness

Right-click to choose the vector line thickness as a percentage of frame height. You may choose a
preset thickness or enter an exact number.
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If your data consists of a dense mesh of points, a vector plot may be too crowded to
be of much use. You can "thin" the plot by plotting only a certain subset of the data
points with the Index Skip attribute from the Points page of the Zone Style dialog.


For information on using the controls at the bottom of the Zone Style dialog to select
zones by name, see the description of these at the end of Field Plot Modification and
the Zone Style Dialog.

Use the Vector Details dialog to adjust other Vector layer settings, including length scaling,
arrowhead appearance, and reference vector. See Vector Details.

Vector Details

The Vector Details dialog (Plot→Vector→Details) lets you specify the length of vectors and the
appearance of arrowheads. You can also display a reference vector. on your plot. These settings are all
global to the current frame.


In order for most changes made on the Vector Details dialog to be visible in your plot,
you must have the Vector layer toggled on in the Plot sidebar, and the vectors of at
least one zone must be visible (see Vector Plot Modification).

The Vector Details dialog has three pages:

• Definition Page

• Arrowhead Page

• Reference Vector Page

Definition Page

The Definition page of the Vector Details dialog allows you to change the vector variables, adjust the
length of displayed vectors, and use even vector spacing.
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The Definition page of the Vector Details dialog has the following options:

Vector variables

Select the variables for U, V, and W (3D only) vector variables. Selecting new vector variables will
update the plot if any vectors are displayed.

Vector length

The following option are available for the length of the vector:

Relative (grid units/magnitude)

Specify the vector length as the number of grid units per unit of vector magnitude.

Relative (cm/magnitude)

Specify the vector length as the number of centimeters per unit of vector magnitude.

Uniform (%)

Specify the vector length as a percentage of frame height.

Reset Length

For relative vector length, the default is based on the size of the longest vector. Click Reset
Length to change the vector length to a relative vector length with the scale factor expressed in
grid units per unit of vector magnitude. Not available when Uniform is selected.
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For either of the "Relative" options for vector length, the value you specify is a scale factor that is
multiplied by the vector magnitude to determine the length of the vector.



Since 3D vectors are plotted in the plane of the screen, a 3D vector’s length will
depend on both the vector length settings and the orientation of the vector. The length
may be distorted more if the length setting is Relative and the 3D projection is
Perspective.

Use even vector spacing

Select to turn on even spacing for vectors based on grid units of X, Y, and Z (3D only). Turning on
even vector spacing (with vectors displayed) will selectively remove some of the vectors in the plot
to approximately enforce the display intervals specified in the spacing controls. This is useful for
clarifying areas of the plot that are cluttered with an excess number of vectors. When turned on, the
initial values of spacing, specified in grid units, are set to attempt to display a maximum of 40
vectors in each direction across the frame based on current view. This default number of vectors
can be changed in Tecplot’s configuration file, tecplot.cfg; refer to the VECTORDEFAULTSPACINGCOUNT
option of the $!FRAMESETUP macro command.

Reset Spacing

Resets the spacing intervals to these default values. Selecting new axis variables will also reset
the vector spacing values.

Arrowhead Page

You can specify arrowhead sizes as either a fraction of the vector length or in frame units (that is, as a
percentage of the frame height). By default, Tecplot Focus specifies size as a fraction of the vector
length.
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The Arrowhead page of the Vector Details dialog has the following options:

Angle (deg)

The arrowhead angle is the angle that one side of the arrowhead makes with the vector, i.e. the
apex angle is twice the arrowhead angle. To specify the arrowhead angle, enter a value from 1 to 90,
or choose a value from the drop-down, indicated by the down-arrow button.

Size arrowhead by

Fraction of Length

Enter a decimal value from zero to ten.

Frame Units (%)

Enter a percentage value from zero to 100.

Reference Vector Page

A reference vector is a vector of specified magnitude placed on the plot as a visual measure of vector
length.
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The Reference Vector page of the Vector Details dialog has the following options:

Show Reference Vector

Toggle-on to include a reference vector in your plot.

Frame Position

Enter the coordinates of the starting point of the reference vector, as a percentage of the frame
width (X) and frame height (Y).

Angle (deg)

Enter the orientation of the vector in degrees from horizontal, or choose a value from the drop-
down.

Magnitude

Enter the magnitude of the reference vector. The units correspond to those of the vector
components.

Color

Choose a color with the Color Chooser. Multi-color and RGB coloring are not available.

Line Thickness (%)

Enter the desired line thickness, or choose a value from the drop-down.

Reset Magnitude

Resets the magnitude of the reference vector based on the average vector magnitude.
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Show Reference Vector Label

Toggle-on to include the magnitude of the reference vector in the label. Select and modify any of the
following options:

Font

Choose or enter the name of the font to be used for the label. Click the B or I buttons to select the
bold and/or italic variety of the font. (See Font Folders and Fallback for more information on how
fonts work with Tecplot Focus.)

Size

Enter the size and choose units either of frame height percentage or points.

Number Format

Click to specify how the number will be formatted using the Specify Number Format dialog. See
Specify Number Format for a discussion of this dialog.

Color

Choose a color with the Color Chooser. Multi-color and RGB coloring are not available.

Offset (%)

Choose the spacing between the label and the reference vector as a percentage of frame height.

A plot with a reference vector is shown here. The units for the reference vector were added using a
text object (see Text).
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Figure 35. Reference Vector with Units Added

Scatter Layer
Scatter plots are plots of symbols at the data points in a field. The symbols may be sized according to
the values of a specified variable, colored by the values of the contour variable, or may be uniformly
sized or colored. Unlike contour plots, scatter plots do not require any mesh structure connecting the
points, this allows you to make scatter plots of irregular data.

To add a scatter layer to your plot, activate the "Scatter" toggle in the Plot sidebar. You can modify your
Scatter plot using the Scatter page of the Zone Style dialog and the Scatter submenu of the Plot menu.

Scatter Plot Modification

Once you have loaded your data, you can modify your scatter plot attributes using the Scatter page of
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the Zone Style dialog. You can control any of the following attributes for a zone or group of zones from
the Scatter page of the Zone Style dialog.


For information on using the controls at the bottom of the Zone Style dialog to select
zones by name, see the description of these at the end of Field Plot Modification and
the Zone Style Dialog.


In order for the changes made on the Scatter page to be visible in your plot, the
Scatter layer must be turned on in the Plot sidebar.

Show Scatter

Right-click to choose whether or not to show the scatter layer for the highlighted zone(s).

Symbol Shape

Right-click to choose one of the following symbol shapes:

• Square (default)

• Delta

• Gradient

• Left Triangle

• Right Triangle

• Diamond

• Circle

• Cube (rendered as a square in 2D)

• Sphere (rendered as a circle in 2D)

• Octahedron (rendered as a diamond in 2D)
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• Point

• Character - Use a specified ASCII character from a selected font (as specified in the Enter ASCII
Character dialog). See also Text.


3D scatter symbols should only be used if your dataset is on the order of thousands
of points. If your dataset is large (e.g. millions of points), try using 2D scatter
symbols instead for better interactive performance.

Scatter Size

Right-click to select the symbol size either by a constant percentage of the frame height or from a
variable in the dataset. For constant size, you may choose a preset size or enter one of your own.
(See Scatter Size/Font for complete instructions for sizing scatter symbols by variable.)

Outline Color

Right-click to choose a color from the Color Chooser. Besides a constant color, you can also choose:

Multi

Each symbol is colored according to the value of the selected contour variable at that data point.
Choose a contour group at the bottom of the Color Chooser dialog.

RGB

Each symbol is colored according to the values at that data point for the variables assigned to
RGB. Click the RGB button at the bottom of the Color Chooser dialog.

Line Thickness

Right-click to choose the thickness of the scatter outlines for each highlighted zone(s), either a preset
from the menu or by entering your own value.

Fill Mode

The 3D symbol shapes, Cube, Sphere, and Octahedron are filled with the line color, but the other
shapes have other fill modes available. Right-click to choose:

None (default)

Unfilled symbols.

Use Specific Color

Uses the color shown in the Fill Color column.

Use Line Color

Matches outline color.

Use Background Color

Matches frame color.
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Fill Color

Right-click to select a fill color using the Color Chooser.



Spheres, Cubes, and Octahedrons are always light-source shaded. Spheres are
Gouraud shaded, and Cubes and Octahedrons are Panel shaded. Cube edges are
aligned with X, Y, and Z-axes. Octahedrons are oriented so one vertex points in the Z-
direction and one vertex points in the X-direction. For best appearance of 3D shapes,
adjust the Light Source to use Specular Highlighting. Scatter Size and Line Thickness
are not available for the point symbol. Points are always one pixel in size.



If your data consists of a dense mesh of points, a scatter plot may be too crowded to be
of much use. You can "thin" the scatter plot by plotting only a certain subset of the
data points with the Index Skip attribute from the Points page of the Zone Style
dialog. The Point scatter symbol allows for quick viewing and panning in 3D plots. It is
also a useful tool for identifying features in volume zones.

Scatter Size/Font

Use the Scatter Size/Fonts dialog (accessed via Plot→Scatter→Size/Font in 2D/3D or Plot→Symbol
Font in line plot modes) to choose the base font used for ASCII character symbols and the scatter-size
variabjle used to scale scatter symbols. This dialog is also available by right-clicking a scatter size in the
Scatter page of the Zone Style dialog and choosing Select Variable. The Scatter Size/Font dialog is
shown below:

The following options are available:

ASCII Symbol Font

Select a font from the drop-down and optionally a bold and/or italic style. (See Font Folders and
Fallback for more information on how fonts work with Tecplot Focus.) For XY and Polar line plots,
this is the only option available.


Not all fonts have Bold and/or Italic variants. For fonts that do not have these styles,
the B and/or I buttons may have no effect.
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Scatter-size Variable

Select a variable from the drop-down of the dataset’s variables. If the Scatter Size field is set to "Size
by Variable" on the Scatter page of the Zone Style dialog, this variable is used to calculate the
scatter symbol size at each data point. The actual size of each symbol is determined by multiplying
the value of the variable at each point by the Size Multiplier. If the Scatter Size field is not set to
"Size by Variable", this field has no effect.

Size Multiplier

Enter the scale factor that multiplies the values of the Scatter-size Variable to size the scatter
symbols. If the Scatter Size field on the Zone Style dialog is not set to "Size by Variable", this field
has no effect. The Size Multiplier multiplied by the scatter variable value gives the size of the scatter
symbol at a point, in units, specified by the following option buttons:

Grid Units/Magnitude

Select this to express the Size Multiplier in terms of grid units per unit of variable magnitude.

Cm/Magnitude

Select this to express the Size Multiplier in terms of screen centimeters per unit of variable
magnitude.

Recalculate Size

Select to reset the Size Multiplier to Tecplot Focus’s initial value.

Scatter Legends

To include the scatter legend, select "Scatter Legend" from the Scatter sub-menu of the Plot menu.
Select the following options in the Scatter Legend dialog.
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Show Scatter Legend

Toggle-on to include a scatter legend in the plot.

Show Zone Names

Toggle-on to include zone names in the legend.

Text

Format the text for the legend by choosing a color and font, and specifying the text height. (See Font
Folders and Fallback for more information on how fonts work with Tecplot Focus.) Click the (…)
button to display the Select Font dialog.

Position

Specify the location of the anchor point of the legend by entering values in the X (%) and Y (%) text
fields. Enter X as a percentage of the frame width and Y as a percentage of the frame height.

Legend Box

Select the type of box to draw around the legend (No Box, Outline, or Fill). If you choose Outline or
Fill, format the box using the following controls:

Line Thickness

Specify the line thickness as a percentage of frame height.

224



Box Color

Choose a color for the legend box outline.

Fill Color

Choose a color for the legend box fill (Fill mode only).

Margin

Specify the margin between the legend text and legend box as a percentage of the text height.

Shade Layer
Although most commonly used with 3D surfaces, shade plots can also be used to flood 2D plots with
solid colors, or to light source shade the exterior of 3D volume plots. In 3D plots, zone effects
(translucency and lighting) cause color variation (shading) throughout the zone(s). Shading can also
help you discern the shape of the plot.

Toggle-on "Shade" in the Plot sidebar to add shading to your plot. Use the Shade page of the Zone Style
dialog to customize shading. Refer to Translucency for information on translucency and lighting zone
effects.


Shade plots require IJ or IJK-ordered, or finite element data. I-ordered, or irregular
data cannot be used to create shade plots.

Shade Layer Modifiction

You can modify your shading attributes using the Shade page of the Zone Style dialog (accessed via the
Plot sidebar or Plot→Zone Style).


In order for the changes made on the Shade page to be visible in your plot, the Shade
layer must be turned on in the Plot sidebar.

You can control any of the following attributes from the Shade page of the Zone Style dialog:
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Show Shade

Turns the shade layer on or off for each active zone.

Shade Color

Right-click to select the shade color using the Color Chooser. In 2D Cartesian plots, only solid zone
flooding is available (i.e. no lighting effects).

Use Lighting

(3D only) Turns the lighting zone effect off or on. When "no" is selected, the shade color is used to
uniformly color the zone. Refer to Translucency for information on translucency and lighting zone
effects.


For information on using the controls at the bottom of the Zone Style dialog to select
zones by name, see the description of these at the end of Field Plot Modification and
the Zone Style Dialog.

Translucency and Lighting
You can enhance the shade and contour zone layers in 3D plots using Translucency and Lighting
Effects (referred to collectively as the "3D zone effects"). The 3D zone effects for streamtraces, slices,
and iso-surfaces can be activated using their respective dialogs (accessed via the Plot menu or the Plot
sidebar).


For changes related to lighting or translucency to be visible, the desired effect must be
toggled-on in the Show Effects section of the Plot sidebar.

The Effects page of the Zone Style dialog, which controls translucency and lighting effects, is shown
below.
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For information on using the controls at the bottom of the Zone Style dialog to select
zones by name, see the description of these at the end of Field Plot Modification and
the Zone Style Dialog.

Translucency

Turn on the translucency zone effect by toggling-on "translucency" in the Show Effects region of the
Plot sidebar. When a zone is translucent, you may view objects inside or behind the zone. You can
control the translucency of a zone using the Surface Translucency attribute in the Effects page of the
Zone Style dialog. The level of translucency may be set to a value between 1 (nearly solid) and 99
(nearly invisible). There are nine pre-set percentages ranging from 10 to 90. You may also use the
"Enter" option to define a percentage of your own. An example of a translucent plot is shown in Figure
36.
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Figure 36. An example of a plot using translucency.

All surfaces in 3D Cartesian plots may be made translucent. A different translucency may be assigned
to individual zones, and may also be assigned to derived objects such as slices, streamtrace ribbons or
rods, and iso-surfaces. Use the Effects page of the Zone Style dialog to change translucency settings for
zones.


The Translucency toggle-switch on the Plot sidebar applies only to zones, not to slices,
streamtraces, or iso-surfaces. Translucency for those objects is controlled through
their respective dialogs.


Translucency will only appear on your screen or in exported bitmap images.
Translucent objects appear opaque in printouts and in exported vector images. See
Hard Limits for more details.
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Blanking

The Use Value Blanking column on the Effects page of the Zone Style dialog enables you to constrain
the display of each zone - that is, instruct whether each zone should obey or ignore any blanking
settings present in the plot. To constrain a zone to obey value blanking, select the zone, toggle-on the
Use Value Blanking checkbox. To learn more about blanking, see Blanking.

Lighting Effects

There are two types of lighting effects: Paneled and Gouraud. Right-click in the Lighting Effect column
of the Effects page to choose either Paneled or Gouraud shading for the selected zone(s).

Paneled

Within each cell, the color assigned to each area by shading or contour flooding is tinted by a shade
constant across the cell. This shade is based on the orientation of the cell relative to your 3D light
source.

Gouraud

This plot type offers smoother, more continuous shading than Paneled shading, but it also results in
slower plotting and larger print files. Gouraud shading is not continuous across zone boundaries
unless face neighbors are specified in the data.[6] Gouraud shading is not available for finite element
volume zones when blanking is active; the zone’s lighting effect reverts to Paneled shading in this
case.

If IJK-ordered data with Surfaces to Plot is set to Exposed Cell Faces, faces exposed by blanking will
revert to Paneled shading.

Figure 37 shows two shade plots. The one on the left uses a Paneled lighting effect and the one on the
right uses a Gouraud lighting effect.
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Figure 37. A comparison of the paneled (left) and Gouraud (right) lighting effects.

Three-dimensional Light Source

The light source is a point of light infinitely far from the drawing area. You can open the Light Source
dialog (shown below) by selecting the button ( ) next to Lighting effect toggle the Plot sidebar, or by
selecting "Light Source" from the Plot menu.

230



The Light Source dialog has the following options:

Intensity (%)

Controls the amount of lighting effect produced by the directional light source. An intensity of 100
produces the maximum contrast between lit and unlit areas, and fully lit areas use the full surface
color. Lesser values produce less contrast between lit and unlit areas, and fully lit areas use darker
colors. An intensity of zero means the light source produces no contrast between lit and unlit areas,
and all areas are black.

Background Light (%)

Controls the amount of lighting effect applied to all objects regardless of the light source position. A
background light of zero means that areas unlit by the directional light source receive no lighting at
all and are entirely black, while areas lit by the directional light source get only the effect of that
light. Larger values produce more lighting effect in areas not lit by the directional light source,
making these areas show some of the surface color. A background light of 100 means that all areas
are lit by the maximum amount, and areas unlit by the directional light source use the full surface
color


Intensity and Background Light are cumulative; they can add up to more than 100 and
result in colors lightened beyond the base surface color. For example, reds will
become pink and grays will become white.

Surface Color Contrast (%)

Controls the contrast of the color of the light source shaded surfaces before applying lighting effects.
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A surface color contrast of 100 means that light source shaded surfaces use the full surface color for
applying lighting effects. Lesser values mean that the surface color is blended with progressively
more white, making light source shaded surface colors lighter. A surface color contrast of zero
means that colors are pure white before applying lighting effects (the plot will only be shades of
gray).

Include Specular Highlights

Turns on/off specular highlight for all light-source shaded objects in the plot, adding the semblance
of reflected light to 3D shaded or flooded objects.

Intensity (%)

Controls intensity of specular highlights (that is, the amount of reflected light, which controls the
amount of whiteness at the peak of the highlight).

Shininess

Controls shininess of specular highlight (that is, roughly the size and spread of specular
highlight).

Lighting Optimizations

Some combinations of lighting type and plot style may result in very slow redrawing of plots.
Tecplot Focus provides lighting optimizations to avoid such conditions and instead draws a similar,
but less computationally-intensive plot. These optimizations are on by default. Turn them off if you
need to see the exact effects you have specified. You may want to turn off the graphics cache before
turning off those optimizations for plots with large amounts of data. (See Graphics Cache for
information on the graphics cache.)

Moving the Light Source

You may move the light source interactively by clicking the  sun button next to the lighting effect
toggle in the Plot sidebar. With the light source tool active, click or drag in the workspace to position
the light source in 3D space. Choose another tool from the toolbar or sidebar to exit this mode.

Slices
You can add slices to volume and surface zones in your plot in order to view X, Y, or Z planes within
your data. With IJK-ordered data, you can also add slices on the I, J, or K planes. It is also possible to
create slices with arbitrary orientations.

Slices can include lighting effects, contours, meshes, and more. To customize these and other attributes
of slices, use the Slice Details dialog, accessible in the Plot sidebar or the Plot menu, or use the
context menu and context toolbar.

The context toolbar appears above the context menu when you right-click a slice in your plot. This
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toolbar allows you to turn on or off the grid, contour, vector, shade, edge, and translucency layers for
the selected slice(s). Additionally, you may adjust frequently-used style settings for each layer using the
drop-down menu to the right of each, for example selecting a color for the grid (or choosing a variable
by which to color it).

Tecplot Focus includes a simple interactive method for creating slices. Select the Slice tool in the
toolbar or in the Plot sidebar to activate a crosshair cursor, then click in a volume or surface zone to
"drop" a slice into that zone. You can then drag the slice to change its position. Refer to Slice Tool for
more information on working with the Slice tool.

For additional control, additional slices, or another way to insert slices derived from the dataset, use
the Definition page of the Slice Details dialog. You can open the Slice Details dialog by clicking the

 button next to the Slices toggle in the Plot sidebar or by choosing Slices from the Plot menu.

Interactively created slices are derived from the dataset and are defined by a constant X, Y, or Z
location (or constant I, J, or K indexes, for IJK ordered zones). Tecplot Focus considers this type of slice
as part of your plot’s style and does not add it to the dataset unless you extract it to a zone (using
Data→Extract→Slices).

Interactively Created Slices

Use the Slice Details dialog to customize interactively created slices (that is, slices derived from your
dataset). Click the  button next to the Slices checkbox in the Plot sidebar, or select Slices from the
Plot menu, to launch the Slice Details dialog. To add slices to your plot in the dialog, toggle-on Show
Group  in the Slice Details dialog.

The Slice Details dialog includes the following pages: Slice Definition Page, Contour Page, Vector Page,
Other Page, and Animate Page.


You must toggle-on Show Group  in order for the changes made in the Slice Details
dialog to be visible in your plot.

Slice Groups

Up to eight different slice groups can be set. Each slice group can use different slice planes or different
ranges for the same slice plane. Changing the settings in the Slice Details dialog allows you to make
the appearance of each slice group unique. The slice group is specified using the numbers at the top of
the Slice Details dialog


You must toggle-on Show Group  (where ) in order to include the Slice group in
your plot.

Slice Definition Page

Use the Definition page of the Slice Details dialog to customize the position of the active slice group
(accessed via the Plot sidebar or Plot→Slices).

233



You can toggle-on Show Start/End Slices and use the Start slider to move the first (start) slice, or type
in the slice position. Activate the last (end) slice and move it with the End slider.

The following options are available:

Slice Location

Select which plane the slice is drawn on (X, Y, Z, I, J, or K). You may also choose Arbitrary to place
the slice on an arbitrary plane; see Arbitrary Slice Orientation.

Show Primary Slice

Toggle-on to include the primary slice (first slice placed) in your plot. Use the slider or the text field
to position the primary slice.

Show Start/End Slices

Toggle-on to include start and end slices in your plot. Use the corresponding sliders or text fields to
position the slices.

Show Intermediate Slices

Toggle-on to show intermediate slices evenly distributed between the start and end slices.
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Num Slices

Enter the number of intermediate slicing planes in the text field. (Range 1-5000.)

Range for all Sliders

Click the gear icon next to Show Primary Slice to reveal a flyout dialog that sets the range of the
sliders.

Min, Max, Step Size

Specify the start, end, and step for the slider range.

Reset Slider Range

Automatically selects the min/max of values based on Slice location or the min/max of the non-
blanked values based on Slice location. Non-blanked Min/Max is disabled for I-, J-, and K-Planes.

Slice Through

Choose to slice through volume zones, surface zones, or the surfaces of volume zones.

Obey Source Blanking

When active, slices are subject to any blanking used for the data. When inactive, slices are
generated for blanked and unblanked regions. See also Blanking.

Show solid plane while dragging

Toggle-on to show a solid-colored plane in place of the slice while dragging. Since the data within
the slice does not need to be drawn to the screen, this can make dragging noticeably faster and
smoother, particularly with large data sets.


The Show solid plane while dragging checkbox is a global setting that applies to
all slice groups, not just the selected group. It is not available if the slice plane is I, J,
or K.

Extract Slices

Select the Extract Slices button to open the Extract Slices dialog. See Extracting Slices to Zones for
more information.
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Arbitrary Slice Orientation

To orient slices in an arbitrary direction, choose Arbitrary from the Slice Location menu. As with
other slices, you may specify origin points for a primary slice and/or for start and end slices. Slices pass
through the indicated origin point(s), so you can easily align the edge of a slice or group of slices along
some other feature of the plot, such as an axis. If intermediate slices are activated, they are drawn
equally spaced between the slices defined by the start and end origins.

An arbitrarily-oriented slice may be manipulated interactively. When the slice tool is active, a slice-
normal interactor appears in the plot.

• Drag the far end of the interactor to change where the normal points and thus the orientation of
the slice(s).

• Drag the near end of the slice normal to move the origin point of the slice.

• If multiple slices are active, you may click a slice to move the normal to that slice.


Interactive orientation of arbitrary slices is not available with scaled axes or
perspective view. In these cases, the interactor does not appear.

You may adjust the orientation of the slice in small increments using the + and - buttons for the X, Y,
and Z axes to rotate the slice a step at a time around an axis.

With an arbitrary slice, you may also:

Orient a Slice by Specifying a Normal

Click the gear icon to enter a normal vector in a flyout dialog.

Orient a Slice by Entering Three Points

Click the Three Points button to specify three points on the cutting plane using the Enter 3 Points
dialog.

Orient a Slice by Probing Three Points

Click the  three-point probe icon on the Definition page of the Slice Details dialog to specify three
points on the cutting plane by clicking the plot.

Orient a Slice by Specifying a Normal
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Click the gear icon to reveal a flyout dialog that lets you choose the orientation of the slice by
numerically specifying its normal. A normal vector is established between the slice origin and the
specified coordinates, and the slice is oriented perpendicular to this vector, as shown below.

Figure 38. Arbitrarily-oriented slices in a unit cube. 0, 0, 0 is at back corner; the black dot is the specified
normal. Left: normal at 0, 1, 1. Right: normal at 1, 1, 1.

You can also adjust the step value by which the + and - buttons rotate the slice in this flyout.

Orient a Slice by Entering Three Points

You can orient a slice by specifying the coordinates of three points on a plane. These points must form
a triangle; they cannot be coincident or collinear.

Click the 3 Points button in the Slice Details dialog to open the Enter 3 Points dialog, shown here,
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then enter the X, Y, and Z coordinates of the three points. When you click Apply, the origin and normal
vector of the slice are recalculated so that the slice plane passes through all three specified points. (The
third entered point is used as the slice origin.)


The values in the Enter 3 Points dialog are not updated when the slice orientation is
adjusted using the other available methods.

In this dialog, you may also click the  three-point probe button to Orient a Slice by Probing Three
Points.

Orient a Slice by Probing Three Points

In the Slice Details dialog or the Enter 3 Points dialog, click the  three-point probe button, then
click three points in your plot. The X, Y, and Z coordinates of the three points are collected in the Enter
3 Points dialog. After the third point is clicked, the slice’s origin and normal are recalculated so that
the cutting plane passes through all three clicked points. The third point is used as the slice’s origin.


The probe tool keyboard shortcuts may be used when clicking to change the points
selected, for example choosing the nearest data point by holding the Control key while
clicking. See Probe Tool for other shortcuts.

Contour Page

Use the Contour page to control the contour attributes of the active slice group (determined by the
number buttons on the top of the page).
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The following options are available:

Show Contours

Select this check box to show contours.

Contour Type

Select the contour type from the drop-down. Lines, Flood, Lines and Flood, Average Cell Flood, and
Primary Value Flood are available.

Flood by

If you chose contour flooding, select the contour group by which to flood, or RGB flooding.

 Icon

Use this button to bring up the Contour & Multi-Coloring Details dialog.

Contour Lines by

If you chose contour lines or lines and flood, select the contour group by which to draw the lines.
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 Icon

Use this button to bring up the Contour Details dialog.

Line Color

Choose the line color in the Color Chooser. Multi-Color will color the slice contour lines based on
the contour group variable.

Line Thickness

Specify the line thickness as a percentage of the frame width. You may enter a value in the text
field, or choose one of the values in the drop-down.

Use Lighting Effect

Select this check box to enable the lighting effect drop-down menu where you may choose "Paneled"
or "Gouraud" shading. See Lighting Effects for more details on lighting effects.

Use Translucency

Select this check box to enable the surface translucency text field, where you may set the surface
translucency from one (opaque) to 99 (translucent).

Vector Page

Use the Vector page of the Slice Details dialog to control the vector attributes of the active slice group
(determined by the group number buttons on the top of the page).
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The following options are available:

Show Vectors

Select this check box to show vectors.

Tangent Vectors

Select to use tangent vectors for your slices. See Vector Plot Modification for more information.

Line Color

Choose the line color from the Color Chooser. Multi-color will color vectors based on the contour
group variable. If no contour variable is set for the selected contour group, the Contour Details
dialog will appear.

Line Thickness

Specify line thickness as a percentage of the frame height. You may enter a value in the text field, or
choose one of the values in the drop-down.

Vector Type

Use this drop-down to set the vector type for your slices. Choose from Tail at Point, Head at Point,
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Anchor at Midpoint, and Head Only.

Vector Head Style

Use this drop-down to set the vector head style for your slices. Choose from Plain, Filled, and
Hollow.

Vector Details…

Opens the Vector Details dialog to adjust Vector length, spacing, arrowheads, etc.

Other Page

The Other page of the Slice Details dialog controls the mesh, shade, and edge attributes of the active
slice group. (The active slice group is determined by the group number buttons on the top of the page.)

The following options are available:

Show Mesh

Select this check box to show mesh lines.
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Color

Choose the line color in the Color Chooser. Multi-color will color meshes based on the contour
group variable. If no contour variable is set for the selected group when selecting Multi-color, the
Contour Details dialog will appear.

Line Thickness

Specify the mesh line thickness as a percentage of the frame width. You may enter a value in the
text field, or choose one of the values in the drop-down.

Show Shade

Select this check box to show shading on the slice when Show Contour has not been selected or is
set to Lines on the Contour page of this dialog.

Color

Choose the shade color from the Color Chooser. Multi-color and RGB coloring are not
available—use flooded contours for multi-color or RGB flooding.

Use Lighting Effect

Select this check box to enable the lighting effect drop-down, where you may choose "Paneled" or
"Gouraud" shading.

Use Surface Translucency

Select this check box to enable the surface translucency text field, where you may set the surface
translucency from one (opaque) to 99 (translucent). By default, slice translucency is toggled-on at
10 percent when your plot is loaded.

Show Edge

Select this check box to show selected edge lines on all slices.

Color

Choose the edge color from the Color Chooser. Multi-color and RGB coloring are not available.

Line Thickness

Specify the edge thickness as a percentage of the frame width. You may enter a value in the text
field, or choose one of the values in the drop-down.

Surface Generation Method

Determines how the surface is generated.

Auto

Auto selects one of the surface generation algorithms best suited for the zones participating in
the slice generation. "All Polygons" is used if one or more of the participating zones is polytope,
otherwise slices use "Allow Quads".

243



Allow Quads

Allow Quads can produce quads or triangles, and the resulting surface more closely resembles
the shape of the volume cells from the source zone. Since the quads are not arbitrarily divided
into triangles, no biases are introduced, and the resulting surface may appear smoother. This
method is preferred when the source zone is FE-Brick or IJK-Ordered and the surface is aligned
with the source cells.

All Triangles

All Triangles is an advanced algorithm that can handle complex saddle issues and guarantees
that there will be no holes in the final surface. As the surface is composed entirely of triangles, it
can be delivered more efficiently to the graphics hardware.

All Polygons

All Polygons is similar to the "All triangles" method except that all interior faces generated as a
result of triangulation that are not part of the original mesh are eliminated. This preserves the
original mesh of the source zones on the resulting slice.

Animate Page

See Slice Animation.

Extracting Slices to Zones

Normally, slices are derived from the dataset "on the fly" and do not add any data to the dataset. To
extract slices to Tecplot zones, allowing you to retain them even if the slice details are changed, use
Data→Extract→Slices.

In most cases it is not necessary to extract slices to zones, as it is possible to apply most style options
directly to a slice. When you need to display multiple sets of slices in various directions, or simply want
to "freeze" a slice for some other reason, you may wish to extract at least some of the slices to zones.
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Extracting slices has the following options:

Group

Select between an individual group extraction or all active groups extraction, where active means
slices visible on the screen.

Slice Group

Select from the dropdown menu which group is extracted to a zone.

All Active Slice Groups

Extracts slice groups that are set to active.

Time

Specify between extracting a slice for all solution times or the current solution time.

Current Solution Time

Extract a slice for the active solution time.

All Solution Times

Extract a slice for each solution time.

Create a zone for each

Specify how each slice is extracted into single or multiple zones.

Slice

Extracts each slice to a single zone.
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Connected Region

Extracts each slice to its connected regions. Connected regions are defined by zone boundaries
and areas of disconnected meshes.

Resulting 1D Zone Type

Only active when the slice source is not a volume.

I-ordered If Possible

Creates an I-ordered zone for each slice zone that is a single connected region.

FE Line Segment

Creates all extracted linear zones as FE-LineSeg zones.

Values in the extracted slice are nodal unless Contour Type is set to Primary Value flood on the Contour
page of the Slice Details dialog. In this case, the value location for the extracted slice is the same as for
the source zones.

Streamtraces
A streamtrace is the path traced by a massless particle placed at an arbitrary location in a steady-state
vector field. Streamtraces may be used to illustrate the nature of the vector field flow in a particular
region of the plot.

 Calculating particle paths and streaklines is a feature only available in Tecplot 360.

Because streamtraces are dependent upon a vector field, you must define vector components before
creating streamtraces in Tecplot Focus. However, it is not necessary to activate the Vector zone layer to
use streamtraces.

To add streamtraces to your plot, toggle-on "Show Streamtraces" in the Streamtrace Details dialog or
in the Plot sidebar and use either the Add Streamtrace tool  in the toolbar or the Plot sidebar, or the
Create Streams button on the Position page of the Streamtrace Details dialog, to specify the location
of your streamtraces.

When working with the Add Streamtrace tool, click to add individual streamtraces, or drag to seed a
rake (group) of streamtraces.

To create streamtraces with a format other than Surface Line, select a format from the "Create
Streamtraces with Format" drop-down menu on the Position page of the Streamtrace Details dialog.

If you are drawing a rake on concave 3D volume surfaces using the Add Streamtrace tool, hold down
the Shift key to draw the rake outside of the data.

There are two main categories of streamtraces:
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Surface line streamtraces (or streamlines)

Surface streamtraces are confined to the surface on which they are placed. They can be placed in
zones displayed as a 2D or 3D surface, or on a displayed boundary of a 3D zone, such as the K=1 face
of an IJK-ordered zone. If you try to place surface streamtraces in the interior of a zone displayed as
a 3D volume, an error message appears, and no streamtraces are drawn. See Lines Page. When
surface streamtraces are placed on a no-slip boundary surface, they will propagate according to the
flow field very near the surface (see Surface Streamtraces on No-slip Boundaries for more
information).

Volume streamtraces

Volume streamtraces can be created in 3D volume zones only (IJK-ordered or FE-volume zones). See
Rod/Ribbon Page. Volume streamtraces are subdivided into three categories:

• Volume Lines, or volume streamlines.

• Volume Ribbons, or streamribbons.

• Volume Rods, or streamrods.


If you have added streamtraces to your plot, but cannot see them, go to the Volume
page of the Zone Style dialog and verify that Show Streamtraces is set to "Yes". Refer
to Derived Volume Object Plotting for details.

Streamtrace Details Dialog

You can control the style of your streamtraces using the Streamtrace Details dialog (accessed via
Plot→Streamtraces or the  button to the right of the Streamtraces checkbox in the Plot sidebar).
These style attributes affect all streamtraces in the active frame, including those already placed. They
do not affect extracted streamtrace zones, discussed in Streamtrace Extraction as Zones, because these
are ordinary ordered zones, and not streamtraces.


In order for the changes made on the Streamtrace Details dialog to be visible in your
plot, you must have Show Streamtraces toggled on in the dialog, or Streamtraces
toggled on in the Plot sidebar.

The Streamtrace Details dialog has seven pages:

• Placement Page

• Lines Page

• Rod/Ribbon Page

• Animate Page

• Term Line Page

• Integration Page
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The dialog includes a checkbox at the top to globally turn the display of streamtraces on or off. This is
available on all pages of the dialog and is the same as the corresponding checkbox in the Plot sidebar.

Placement Page

Use the Placement page of the Streamtrace Details dialog (accessed via the Plot sidebar or
Plot→Streamtraces) to control the next streamtrace or streamtrace rake to be placed.


Alternatively, you can add streamtraces using the Add Streamtrace tool . See also
Add Streamtrace.

The following options are available:

Create Streamtraces with Format

Choose the format for the next streamtrace from the drop-down. The options are as follows:

Surface Line

Two-dimensional and 3D surface streamlines. Surface lines are confined to the surface upon
which they are placed, which may be surface zones or displayed boundaries of volume zones. If
placed in the interior of a 3D volume zone (such as on a slice through the zone), these
streamtraces are not plotted.

248



Volume Line

Three-dimensional volume streamline plotted through 3D space. The streamline path is
integrated in three dimensions within the 3D volume field.

Volume Ribbon

Three-dimensional volume streamtrace with a defined thickness that twists in accordance with
the local stream-wise vorticity of the vector field: a streamribbon. When you select this option,
you should also check the ribbon width on the Rod/Ribbon page of the Streamtrace Details
dialog. The width affects all streamtraces, including those already placed. The default width is
automatically calculated based on the extent of your data, but it may still be too large. The center
of the streamribbon is a 3D volume streamline. The streamribbon rotates about this streamline
in accordance with the local vector field. Streamribbons have an orientation at each step.

Volume Rod

Three-dimensional volume streamtrace with a defined thickness and a polygonal cross-section: a
streamrod. The cross-section of a streamrod rotates around a volume streamline in accordance
with the local stream-wise vorticity. The center of the streamrod is a regular 3D volume
streamline. Streamrods have an orientation at each step. As with streamribbons, you should
check the rod width on the Rod/Ribbon page of the Streamtrace Details dialog, as well as the
number of rod points (three, by default). The number of points indicates the cross-sectional
shape of the rod. Three is an equilateral triangle; four, a square; five, a regular pentagon; and so
forth. Like the width parameter, the number of points applies to all streamrods, including those
already placed.

Seed Streamtraces

Choose the method for seeding the streamtraces. This will determine the options available in the
central portion of the dialog.

Using Streamtrace Placement Tool

Click on the plot to seed a stream at the clicked point. Click and drag to seed a rake (a series of
streamtraces) of the specified number of equally-spaced points along the path.

On Surfaces of Active Zones

Tecplot Focus randomly distributes the specified number of seed points on the active zones.

On Surfaces of Selected Objects

Tecplot Focus randomly distributes the specified number of seed points on the surfaces of the
selected objects.

By Entering XYZ Positions

Specify the placements of the seed point or rake numerically by entering XYZ coordinates in the
position fields, which appear when you choose method of placing streamtraces.

By Entering IJK Positions

Same as above, except you enter IJK coordinates in the position fields. In this case you must also
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choose a zone.

Direction

Select the stream integration direction from the following options:

Forward

Select for forward integration from the starting point.

Backward

Select for backward integration from the starting point. When the streamlines are calculated
backwards, the arrowheads still point in the forward direction.

Both

Select for both forward and backward integration from the starting point. (For streamribbons
and streamrods, you should avoid this option.)

Number of Seed Points

Enter the number of seed points here. When placing streamtraces using XYZ or IJK positions, this
field is available only when creating a rake; the specified number of streamtraces will be created at
equal intervals between the start and end points of the rake.

Position fields

(Only for XYZ or IJK Positions) - Specify the position of the start point, or the range of the rake
(series of streamtraces), in IJK or XYZ coordinates.

Zone (Only for IJK)

Select from the drop-down the zone for which the I, J, (and K) indices are being specified.

Create Rake

Select to identify the starting position as the start of a rake and to activate the Rake Ending
Position fields.

Streamtrace Start Position

Specify the starting position for a single streamtrace, or (if "Create Rake" is selected) the
beginning of a rake of streamtraces. There are two or three fields, labeled either X, Y, (and Z) or I,
J, (and K). Enter the desired value in each field, or use the up and down arrows to increase or
decrease the values.

Rake End Position

(Only if Create Rake is selected) - Specify the end position for a rake of streamtraces. There are
two or three fields, labeled either X, Y, (and Z) or I, J, (and K). Enter the desired value in each
field, or use the up and down arrows to increase or decrease the values.

Create Streamtraces

Click to seed the streamtrace or rake of streamtraces. Not available when using the streamtrace
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placement tool; click on the plot instead.

Number of Streamtraces

(Information only) - The number of streamtraces currently placed.

Delete Last

Select to delete the last streamtrace or rake placed.

Delete All

Select to delete all streamtraces in the current plot.


1, 2, 3, 4, 5, 6, 7, 8, 9 - When the Streamtrace tool is selected, press 1-9 to change the
number of streamtraces to add when placing a rake of streamtraces.

Lines Page

Surface streamtraces or streamlines are confined to the surface on which they are placed. They can
only be placed in zones displayed as a 2D or 3D surface. If you try to place streamlines in a zone
displayed as a 3D volume, an error dialog appears, and no streamlines are drawn. The following
attributes may be set with the Lines page of the Streamtrace Details dialog. You cannot customize
streamtraces using the Lines page until after at least one streamtrace has been drawn.
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Show Paths

Toggle-on to include streamtraces in your plot.

Line Color

Select the color for all streamtraces in the Color Chooser. You may set the color to Multi-color to
color the streamtraces by the chosen contour group variable in the same manner as color flooding.
(If the contour variable is not currently defined, the Contour Variable dialog appears so that you
can define it.) You can use the Multi-color option, for example, to color the streamtraces by the local
temperature or by the velocity magnitude. You can also specify RGB coloring.

The following attributes affect surface and volume streamlines:

Line Thickness

Enter a value, or choose a pre-set value for the streamline thickness (as a percentage of the frame
height for 2D lines and as a percentage of the median axis length for 3D surface lines and volume
lines), or choose a pre-set value from the drop-down menu.

Arrows

Toggle-on Show Arrowheads on Lines to display arrowheads along all streamlines (surface and
volume) in the active frame. Arrows are not shown on volume ribbons or volume rods. You can also
control the following attributes of the displayed arrows:

Arrowhead Size

Either enter a value for the arrowhead size (as a percentage of the frame height), or choose a
pre-set value from the drop-down menu.

Arrowhead Spacing

Enter the distance between arrowheads in terms of Y-frame units. A value of ten percent will
space arrowheads approximately ten percent of the frame height apart from each other along
each streamline.

Rod/Ribbon Page

The following attributes may be set with the Rod/Ribbon page of the Streamtrace Details dialog. They
affect volume ribbons and volume rods only. You cannot customize streamtraces using the Rod/Ribbon
page until after at least one streamtrace has been drawn.
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Show Paths

Toggle-on to include streamtraces in your plot.

Rod/Ribbon Width

Enter a width for the volume ribbons and volume rods. The width is expressed in grid units. If you
want two sets of streamtraces with different widths, you must create them individually by creating
a set of streamtraces with a specific width, extracting the set as a zone, and then configuring a new
set of streamtraces with the second width. See Streamtrace Extraction as Zones.

Rod Points

Volume rods have a polygonal cross-section; this parameter tells Tecplot Focus what that cross-
section should be. (Three is an equilateral triangle, four is a square, five is a regular pentagon, and
so on.) If you want two sets of volume rods with different cross-sections, you must create one set
and then extract the set as a zone, then configure a new set of streamtraces with the second cross-
section. See Streamtrace Extraction as Zones.

Show Mesh

Toggle-on to display a mesh.

Color

Select a mesh color in the Color Chooser, or choose a custom color or multi-color.
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Line Thickness

Select a line thickness from the drop-down menu, or enter your own number in the text field.

Show Contour Flood

Toggle-on to display contour flooding.

Flood by

Select which contour group to flood by. Use this button  to display the Select Contour Variables
dialog.

Show Shade

Toggle-on to display shading.

Color

Select a shade color in the Color Chooser. Multi-color and RGB coloring are not available (use
contour flooding instead).

Use Lighting Effect

Toggle-on to enable the lighting effect drop-down menu, from which you can select "Paneled" or
"Gouraud" shading.

Use Surface Translucency

Toggle-on to enable the surface translucency text field, where you can set the surface
translucency from one (nearly opaque) to 99 (nearly transparent).

Timing Page

Use the Timing page of the Streamtrace Details dialog (accessed via the Plot sidebar or
Plot→Streamtraces) to control timed markers for streamlines, and timed dashes for all types of
streamtraces. Stream markers are drawn at time locations along streamlines. The spacing between
stream markers is proportional to the magnitude of the local vector field.

Stream markers are symbols plotted along streamtrace paths to identify the positions of particles at
certain times. Figure 39 shows a plot with both streamtrace markers and dashes.
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Figure 39. Streamtrace markers (top), dashes (bottom), and both (middle).

The spacing between stream markers is proportional to the magnitude of the local vector field. You can
adjust the spacing between stream markers by specifying the time interval (or delta) between stream
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markers. Increasing the delta time will increase the space between stream markers and vice versa. The
actual spacing is the product of the local vector magnitude and the specified delta.

You may also select the shape of your stream marker using the pre-set list under the Shape drop-down
menu on the Timing page of the Streamtrace Details dialog. Selecting "Other" from the list activates
the Enter ASCII Character option, where you may enter an ASCII character to be used as your stream
marker.

To place stream markers or dashes along your streamtraces, open the Timing page of the Streamtrace
Details dialog (accessed via the Plot sidebar or the Plot menu).

The Timing page has the following options:

Show Markers

Toggle-on to include stream markers. Stream markers are only available for streamlines (surface
and volume). Specify the size, color, and shape of the markers in the fields provided. The default
marker shape is a sphere (in 3D plots) or a circle (2D).

Show Dashes

Toggle-on to include stream dashes. The lengths of the dashes and the spaces between the dashes
are controlled by the value of Delta. Enter a value into the Dash Skip field to control the number of
time deltas used for the "off" sections of the streamtraces.
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Time Start

Enter the time at which the first marker should be drawn. A start time of zero means that the first
marker is drawn at the starting point. A start time of 2.5 means that the first stream marker is
drawn 2.5 time units downstream of the starting point.

Time End

Enter the time after which no more stream markers are drawn.

Time Anchor

Enter the time that a dash is guaranteed to start, provided the start and end time surround the dash.

Time Delta

Enter the time interval that measures the time between stream markers. The actual distance
between markers is the product of this number and the local vector magnitude. Click Reset Delta to
reset this to the default value.

Animate Page

The Animate page controls animation of streamtraces.

You may specify the number of steps per cycle, the number of cycles, and the destination for animation
(the screen or a file). Click the Animate button to begin animation and see Animation for further
details.
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Term Line Page

A streamtrace termination line is a polyline that terminates any streamtraces that cross it. The
termination line is useful for stopping streamtraces before they spiral or stall. Figure 40 shows the
cylinder data with some streamtraces terminated by a 2D streamtrace termination line.

Figure 40. A streamtrace termination line drawn through surface streamlines.

Streamtraces are terminated whenever any of the following occur:

• The maximum number of integration steps is reached.

• Any point where the streamtrace passes outside the available data.

• The streamtrace reaches a point where the velocity magnitude is zero.

You control the streamtrace termination line from the Term Line page of the Streamtrace Details
dialog.
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From the Term Line page, you can control the following attributes of the termination line:

Active Termination Line

Toggle-on to activate the termination line and terminate any streamtraces that cross it. Toggle-off
this option and redraw the plot to view unterminated streamtraces.

Draw Stream Term Line

Click to draw the termination line on the plot. This is the same as choosing the  button on the
toolbar. Click the individual points on the plot that make up the termination line, then double-click
to end the line construction.

Show Termination Line

Toggle-on to display the termination line. Toggle-off this option and redraw the plot to display
terminated streamlines (if the termination line is active), but not the termination line itself.

Color

Choose the color of the termination line in the Color Chooser.

Line Pattern

Choose the pattern for the termination line.

Pattern Length

The length of the pattern as a percentage of frame height.
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Line Thickness

The thickness of the termination line as a percentage of frame height.

You can select a termination line with the Selector or Adjustor tool. This allows you to interactively
move the line (with the Selector), modify the line (with the Adjustor), or delete the line (with either
tool).


Only one termination line can exist at any one time in a given frame. If you draw a
second termination line, the first one is automatically deleted.

Termination Lines in the Eye Coordinate System

The streamtrace termination line is drawn in the grid coordinate system, which in 2D Cartesian plots
moves with the data as you zoom and translate. In 3D Cartesian plots, the termination line is drawn in
what is known as the eye coordinate system. Grid coordinates align with the eye coordinate system,
therefore the termination line moves with the data as you zoom and translate, but remains fixed when
you rotate the plot.

When you rotate a 3D dataset after drawing a streamtrace termination line, streamtraces previously
terminated by the termination line may be terminated at different places, or not terminated at all if the
rotated streamtrace no longer intersects the termination line. Figure 41 shows a 3D volume plot with
streamribbons and a streamtrace termination line. This figure illustrates how the termination points
vary as the plot is rotated. Notice that the termination line, being rendered in the eye coordinate
system, remains in place on the screen as the plot is rotated.
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Figure 41. Rotating Volume streamtraces with a termination line in the eye coordinate system.

Integration Page

Tecplot Focus uses an adaptive step-size, trapezoidal integration algorithm to calculate streamtraces.
This creates the streamtrace by moving it in a series of small steps from the starting point in the
direction of (or in opposition to) the local vector field. Each step is only a fraction of a cell or element.
Tecplot Focus automatically adjusts the step size based on the local cell shape and vector field
variation.

You can control the streamtrace integration by modifying the following parameters in the Integration
page of the Streamtrace Details dialog:
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Step Size

Enter the initial and maximum step size Tecplot Focus uses while integrating through the vector
field as a decimal fraction of the local cell or element width. A typical value (and the default) is 0.25,
which results in four integration steps through each cell or element. The value for Step Size affects
the accuracy of the integration. Setting Step Size too small can result in round-off errors, while
setting it too large can result in truncation errors and missed cells.

Max Steps

Enter the maximum number of steps before the streamtrace is terminated. This prevents
streamtraces from spinning forever in a vortex, or from wandering into a region where the vector
components are very small, very random, or both. If you choose a small Step Size, you should enter
a larger Max Steps.

Minimum Step Size

The smallest step size for Tecplot Focus to use. Setting this too small results in integration problems.
Setting this greater than or equal to the Step Size results in a constant step size.

Obey Source Zone Blanking

When active, streamtraces are generated for non-blanked regions only. When inactive, streamtraces
are generated for both blanked and unblanked regions.

During the integration, a streamtrace is terminated if any of the following conditions occur:

262



• The maximum number of integration steps (Max Steps) have been taken.

• Any point the streamtrace passes outside the available data.

• The streamtrace reaches a point where the velocity magnitude is zero.

• The streamtrace crosses the stream termination line.

When there is a small gap between the zones, streamtraces will terminate at a zone boundary even if
there is an adjacent zone into which the streamtraces should proceed. Specifying face neighbors in the
data file to connect the zones can reduce this issue. Increasing the minimum integration step size can
also ameliorate this problem.

Surface Streamtraces on No-slip Boundaries

A no-slip boundary is the boundary of a volume zone whose vector variables are either passive or are
zero throughout the boundary. The boundary may be either a displayed boundary of a volume zone
(included in the zone’s Surfaces to Plot setting in the Zone Style dialog), or a surface zone that resides
on the boundary of a volume zone. In the latter case, the surface zone’s nodes must coincide with
nodes on the exterior of one or more volume zones. For either case, blanked regions of the surface are
not considered when determining whether a boundary is a no-slip boundary. That is, if value blanking
or IJK blanking is enabled, then only the non-blanked portion of the surface is examined to determine
if it is a no-slip boundary.

When surface streamtraces are placed on a no-slip boundary, they propagate according to the normal
gradient of tangential velocity (proportional to shear stress) at the surface, calculated using vector
variable values from the nearby interior of the volume zone. If the solution is unsteady, only volume
zones in the currently displayed solution time will be used. If the boundary is a surface zone, then
corresponding volume zones needn’t be displayed in the current plot (they may be turned off in the
Zone Style dialog), but preference will be given to volume zones that have non-zero velocity, and that
are active (not turned off in the Zone Style dialog).

If you extract a surface streamtrace, the velocity component variables in the resulting zone (which
would normally be set to zero because the velocity on the surface is zero) are replaced with the
gradient of the tangential velocity that was used to calculate the streamtrace.

Streamtrace Extraction as Zones

Normally, streamtraces are derived from the dataset "on the fly" and do not add any data to the
dataset. To extract existing streamtraces to zones, allowing you to retain them even if streamtrace
settings are changed, choose Extract→Streamtraces from the Data menu.
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If you want all streamtraces of a given format extracted to a single zone, select the toggle-on
"Concatenate common streamtraces into one zone" in the Extract Streamtraces dialog. If you select
this option, Tecplot Focus extracts all surface lines into one zone, all volume lines into another, all
volume ribbons into a third, and all volume rods into a fourth. Tecplot Focus uses FE zones (FE-Line
segment for streamlines and FE-Quad for rods and ribbons). If you do not select this option, and timing
is not turned on to show dashes, each streamtrace is extracted into its own ordered zone (I-Ordered for
streamlines and IJ-Ordered for rods and ribbons).

After you have extracted your streamtraces, you will still see the original streamtraces, which may
obscure the plotted streamtrace zones. Once you have extracted the zones, you can delete the original
streamtraces by selecting Delete All on the Position page of the Streamtrace Details dialog. If timed
dashes are active, all extracted streamtraces will be finite element zones. Otherwise, all extracted
streamline zones are I-ordered, and extracted volume ribbon and volume rod zones are IJ-ordered.

Streamtrace Errors

Streamtraces will not appear under the following conditions:

• Unorganized data (I-ordered zones). Refer to Working with Unorganized Datasets for information
on organizing unorganized data.

• Zero-valued vectors. Refer to Vector Layer for information on working with vectors.

• The streamtrace was placed outside of the data. If you are drawing a rake on a concave 3D volume
surfaces, hold down the Shift key to draw the rake outside of the data.

• Inappropriate integration step size. Refer to the Integration Page for information on integrating
streamtraces.

Iso-Surfaces
An iso-surface displays a constant value of the contour variable as a surface on your plot. Iso-surfaces
require that the data set contains volume zones (IJK-ordered, brick, tetrahedral, or polyhedral (360
Only) zones). You can modify iso-surfaces in the Iso-Surface Details dialog, which you can access by
selecting the  button next to the Iso-surfaces toggle in the Plot sidebar. Or you can open the Iso-
Surface Details dialog by selecting "Iso-Surfaces" from the Plot menu. Finally, you may right-click an
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iso-surface in your plot and use the context menu and toolbar to make quick changes to its settings.

The context toolbar appears above the context menu when you right-click an iso-surface. This toolbar
allows you to turn on or off the grid, contour, shade, and translucency layers for the selected iso-
surface(s). Additionally, you may adjust frequently-used style settings for each layer using the drop-
down menu to the right of each, for example selecting a color for the grid (or choosing a variable by
which to color it).


To view changes made in the Iso-surface Details dialog in your plot, you must have
"Iso-surfaces" toggled on in the Plot sidebar.

Iso-Surface Groups

You can work with up to eight different iso-surface groups in Tecplot Focus. Zone layers or other
objects that reference the same group for an attribute show the same plot style for that attribute. Each
iso-surface group has its own settings for the attributes set in the Iso-surface Details dialog. Refer to
the following sections for details on each attribute. Choose the desired group number from 1-8 at the
top of the dialog, then toggle-on the "Show Group n" checkbox to include the corresponding iso-surface
group in your plot.


If you have added iso-surfaces to your plot, but cannot see them, go to the Volume
page of the Zone Style dialog and verify that Show Iso-surfaces is set to "Yes". Refer to
Derived Volume Object Plotting for details. ls.

Iso-Surface Definition

Use the Definition page of the Iso-Surface Details to control Tecplot Focus’s rendering of iso-surfaces.
Tecplot Focus applies the attributes set on this page (and on every page of the dialog) to the Iso-Surface
group selected at the top of the dialog next to the Show Group toggle.
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The Definition page of the dialog includes the following controls:

Show Group n

Select this check box to display iso-surfaces, where n can be 1-8.

Define Iso-Surfaces using

Use this drop-down menu to select the desired contour group. Use the nearby  button to display
the Contour & Multi-Coloring Details dialog, where you can define contour groups. (See Contour &
Multi-Coloring Details.)

Draw Iso-Surfaces at

Use this drop-down menu to have Tecplot Focus draw iso-surfaces at:

Contour Group Levels

Go to the Contour & Multi-Coloring Details dialog (accessed with the  button) to alter the
Contour Levels. Refer to Contour Levels and Color for details.

At Specified Value(s)

Specify up to three values of the contour variable at which to draw iso-surfaces.
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Contour Variable Min/Max

Indicates the minimum and maximum values of the contour variable. When the contour variable is
calculated from subzone data, one or more of the values displayed may be estimates, which is
indicated by (est) next to the affected values.

 Loading subzone data is a feature only available in Tecplot 360.

Surface Generation Method

Determines how the surface is generated.

• Auto selects one of the surface generation algorithms best suited for the zones participating in
the iso-surface generation. "All Polygons" is used if one or more of the participating zones is
polytope, otherwise iso-surfaces use "All Triangles" unless the iso-surface is defined by a
coordinate variable in which case "Allow Quads" is used.

• Allow Quads can produce quads or triangles, and the resulting surface more closely resembles
the shape of the volume cells from the source zone. Since the quads are not arbitrarily divided
into triangles, no biases are introduced, and the resulting surface may appear smoother. This
method is preferred when the source zone is FE-Brick or IJK-Ordered and the surface is aligned
with the source cells.

• All Triangles is an advanced algorithm that can handle complex saddle issues and guarantees
that there will be no holes in the final surface. As the surface is composed entirely of triangles, it
can be delivered more efficiently to the graphics hardware.

• All Polygons is similar to the "All triangles" method except that all interior faces generated as a
result of triangulation that are not part of the original mesh are eliminated. This preserves the
original mesh of the source zones on the resulting iso-surface.

Obey Source Zone Blanking

When active, iso-surfaces are generated for non-blanked regions only. When inactive, iso-surfaces
are generated for blanked and unblanked regions. unblanked regions.

Iso-Surface Contour and Shade

The Contour and Shade page of the Iso-Surface Details dialog controls the contour and shade style
settings for all iso-surfaces. (These styles act independently of the style assigned to zones by the Zone
Style dialog.) Tecplot Focus applies the attributes set on this page (and every page of the dialog) to the
Iso-Surface group selected at the top of the dialog next to the Show Group toggle.

267



The Contour and Shade page of the dialog includes the following controls:

Show Contour

Toggle-on "Show Contour" to display contours on iso-surfaces.

Contour Type

Select the contour type from the drop-down. Lines, Flood, Lines and Flood, Average Cell Flood,
and Primary Value Flood are available.

Flood by

If you chose contour flooding, select the contour group by which to flood the contours, or select
RGB flooding. Use the nearby  button to bring up the Contour & Multi-Coloring Details
dialog, where you can define contour groups. (See Contour & Multi-Coloring Details.)

Contour Lines by

If you chose contour lines, select the contour group by which to draw lines. Use the nearby 
button to display the Contour & Multi-Coloring Details dialog to define contour groups.

Line Color

If you chose contour lines, click Line Color to select a line color in the Color Chooser.
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Line Thickness

If you chose contour lines, select a contour line thickness from the drop-down menu, or enter
your own number in the text field.

Use Lighting Effect

Toggle-on to enable the lighting effect selected in the Light effect drop-down menu.

Show Shade

Toggle-on to display shading on iso-surfaces.

Color

Select a shade color using the Color Chooser.

Use Lighting Effect

Toggle-on to enable the lighting effect selected in the Light effect drop-down menu.

Effects

Lighting Effect

Select between Paneled or Gouraud shading.

Use Translucency

Toggle-on to enable the surface translucency text field, where you may set the surface
translucency from 1 (nearly opaque) to 99 (nearly transparent). ly transparent).

Iso-Surface Mesh and Vector

The Mesh and Vector page of the Iso-Surface Details dialog controls the mesh and vector style settings
for all iso-surfaces. (These styles act independently of the style assigned to zones by the Zone Style
dialog.) Tecplot Focus applies the attributes set on this page (and every page of the dialog) to the Iso-
Surface group selected at the top of the dialog next to the Show Group toggle.
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The Mesh and Vector page of the dialog includes the following controls:

Show Mesh

Toggle-on "Show Mesh" to display the mesh on iso-surfaces.

Color

Select a mesh color in the Color Chooser.

Line Thickness

Select a mesh line thickness from the drop-down menu, or enter a number in the text field.

Show Vectors

Toggle-on "Show vectors" to display the vectors on iso-surfaces.

Tangent Vectors

Select to use tangent vectors for your iso-surfaces. See Vector Plot Modification for more
information.

Line Color

Choose the line color from the Color Chooser. Multi-color will color vectors based on the contour
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group variable. If no contour variable is set for the selected contour group, the Contour Details
dialog will appear.

Line Thickness

Specify line thickness as a percentage of the frame height. You may enter a value in the text field,
or choose one of the values in the drop-down.

Vector Type

Use this drop-down to set the vector type for your iso-surfaces. Choose from Tail at Point, Head at
Point, Anchor at Midpoint, and Head Only.

Vector Head Style

Use this drop-down to set the vector head style for your iso-surfaces. Choose from Plain, Filled,
and Hollow.

Vector Details…

Opens the Vector Details dialog to adjust Vector length, spacing, arrowheads, etc. c.

Iso-Surface Animation

Refer to Iso-surfaces Animation.

Iso-Surface Extraction

Normally, iso-surfaces are derived from the dataset "on the fly" and do not add any data to the dataset.
To extract existing iso-surfaces to Tecplot zones, allowing you to retain them even if the contour
variable is changed, select Extract→Iso-Surfaces from the Data menu.

When you click Extract, one new iso-surface zone is created for each iso-surface visible in your plot. All
of the variables in the dataset are interpolated from the 3D volume zones to the data points of the iso-
surfaces.

Iso-surface zones are FE-surface quadrilateral element-type zones, regardless of the original 3D
volume zone types. The mesh of the iso-surfaces is derived from the mesh of the original zones so that,
in regions where the original mesh was coarse, the iso-surface mesh is coarse, and where the original
mesh was fine, the iso-surface mesh is fine.
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After creating the new iso-surface zones, it is often a good idea to turn off or
reconfigure the current settings for iso-surfaces because the new zones will occupy
the same physical space as the original iso-surfaces.

Axes
Tecplot Focus automatically enables the axes for 3D, 2D, XY, and Polar plot types. There are five distinct
sets of axes, one for each plot type. When the axes are generated, the axis labels, position, spacing, and
tick mark labels are created. You can adjust any of these settings by using the Axis Details dialog
(accessed via the Plot menu). Each page of the Axis Details dialog controls a different aspect of the
axis, and each page is available for each axis.

Axis Display

Use the "Show Axis" toggle in the Axis Details dialog to turn on an axis display. By default, displaying
an axis shows the axis line, tick marks, tick mark labels, and title for the axis. It is possible to disable
any of these components separately, including the axis line.

To edit an axis from the Axis Details dialog, use the axis buttons ([X], [Y], [R], etc.) at the top of the
dialog to indicate which axis you are working with. To edit a different axis, select a different axis
button.

Axis Variable Assignment

For 2D and 3D Cartesian plots, Tecplot Focus initially assigns the first and second variables in the
dataset to the X- and Y-axes, respectively. For 3D axes, the third variable in the dataset is assigned to
the Z-axis.

To change variable assignments for 2D and 3D axes, select "Assign XY" or "Assign XYZ" from the Plot
menu. For line plots, assigning axis variables is part of defining the mappings. See XY and Polar Line
Plots for more information.

The axis range may be modified using the Range page of the Axis Details dialog, accessed via the Plot
menu or by right-clicking an axis in a plot. See Axis Range Options for XY and 2D/3D Plots and Axis
Range Options for Polar Plots

When working with axis ranges, please keep the following definitions in mind:
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Axis Range

Specifies the minimum and maximum data values displayed along the axis. The range for an axis
fits the value of the first variable assigned to that axis. If you deactivate the current layer and
activate another layer, it may be necessary to reset the axis range.

Axis Length

Specifies the physical length of the axis on the screen or paper.

Axis Scale

Specifies the ratio of the axis length to the axis range.

Axis Range Options for XY and 2D/3D Plots

This section discusses the options for XY Line, 2D Cartesian, and 3D Cartesian plots that can be found
on the Range page of the Axis Details dialog.

The Range page has the following options:

Show Axis

Toggle-on this checkbox to show the selected axis (n) on the plot. Use the buttons [X], [Y], etc. to the
right of this checkbox to select the axis to show.
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Min

Enter the minimum value of the axis range.

Max

Enter the maximum value of the axis range.

Reset Range

Reset the Max and Min fields by selecting one of three options from the drop-down menu:

Reset to Nice Values

Sets the range to slightly larger than the current axis variable range in order to begin and end
the axis at major axis increments.

Set to Variable Min/Max

Sets the range to the minimum and maximum variable values, considering the effects of
blanking.

Make Current Values Nice

Rounds the axis range to the nearest major axis increment.

Preserve axis length when changing range

If toggled-on, and your axes are Independent, changes to the X to Y Ratio will affect the axes' range,
but not their scale. Toggle-off to change both the axis range and axis scale simultaneously. See
Figure 42.

Use log scale

The X and Y axes of 2D or XY Line plots can have a linear scale (default) or logarithmic scale. When
"Auto Spacing" is selected with logarithmic scale, large numbers are displayed in scientific notation
(i.e., 3.48x105). It is strongly recommended that you use "Auto Spacing" with log axes. Navigate to the
Ticks or Labels page of the dialog, and toggle-on "Auto Spacing" to use this option.

Reverse axis direction

Toggle on to display the axis from high to low rather than from low to high. Not available for 3D
Cartesian plots.

Dependency

Select whether to set the axes as dependent upon or independent of each other. For XY Line or 2D
Cartesian, select "Independent" or "Dependent".


When a logarithmic scale is being used in an XY Line plot, the axes must be
independent.

For 3D Cartesian, select from one of the following options:
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Independent

All axes are independent.

XY Dependent

The X and Y axes are dependent upon each other. The Z axis is independent.

XYZ Dependent

Changing the scale on any axis results in a proportional change in scale on the other two axes, so
that the specified X to Y Ratio and X to Z Ratio are preserved.

Ratios (For 2D and 3D plots only)

2D Plots

If "Dependent" is selected, enter the X to Y Ratio.

3D Plots

If "XY Dependent" is selected, enter the X to Y Ratio.

3D Plots

If "XYZ Dependent" is selected, enter the X to Y Ratio and the X to Z Ratio.

Automatically Adjust Axis Range to Nice Values

Automatically adjusts the axis ranges to the nearest major axis increments.

Size Factors (For 2D and 3D plots only)

If the axes are XY-dependent, changing the X or Y size factor changes the other. If the axes are XYZ-
dependent, changing one size factor changes the other two.

Reset Size/Dependency

Resets the Dependency controls to their defaults.

Figure 42. Preserving length versus preserving scale while changing range (left); preserving length versus
preserving scale while changing range in a Polar Line plot (right).
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Axis Range Options for Polar Plots

Polar axes are different from any other axis type due to their cyclical nature. Each polar axis (Theta
and R) has very different settings, unlike XY or XYZ axes. For the Theta-axis you can change the Theta
Mode, Theta Period, and Theta Value on Circle Right; for the R-axis you can change the origin; and for
both axes you can clip the data to the axes.

Show Axis

Toggle-on this checkbox to show the selected axis on the plot. Use the buttons Theta, R, etc. to the
right of this checkbox to select an axis.

Min

Enter the minimum value of the axis range.

Max

Enter the maximum value of the axis range.

Reset Range

Reset the Max and Min fields by selecting one of three options from the drop-down menu.
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Reset to Entire Circle

Sets the range of Theta to encompass an entire circle.

Reset to Nice Values

Sets the range to slightly larger than the current axis variable range in order to begin and end
the axis at major axis increments.

Set to Var Min/Max

Sets the range to the minimum and maximum variable values.

Make Current Values Nice

Rounds the axis range to the nearest major axis increment.

Preserve length when changing range

If toggled-on, changes to the Theta to R Ratio will affect the axes' range, but not their scale. Toggle-
off to change both the axis range and axis scale simultaneously. See Figure 42 for an illustration of
the difference.

Use log scale

The R axis can have a linear scale (default) or a logarithmic scale. When "Auto Spacing" is selected
with logarithmic scale, large numbers are displayed in scientific notation (i.e., 3.48x105). It is
strongly recommended that you use "Auto Spacing" with log axes. Navigate to the Ticks or Labels
page of the dialog, and toggle-on "Auto Spacing" to use this option.

Reverse axis direction

Toggle on to display the axis from high to low rather than from low to high. Not available for 3D
Cartesian plots.

Clip Data to axis

For Polar Line plots, it is possible to have data that extends beyond the edges of the axes. Use this
feature to eliminate data drawn outside of the range of the axes. Clipping data can be set
independently for each axis. To activate or deactivate clipping, toggle "Clip Data to Axis" on or off.
This feature is illustrated in Figure 43.
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Figure 43. An example of clipping polar data to an axis.

Theta Mode

By default, the Theta-axis is expressed in degrees mode with a range of 0 to 360. For the Theta axis,
you can plot the angles in units of Radians, Degrees, or Arbitrary (where arbitrary sets the Theta
range to the maximum and minimum values of the Theta-axis variable).

To set the Theta Mode, choose from the following options:

• 0 - 360 Degrees

• -180 – 180 Degrees

• 0 – 2Pi Radians

• Pi-Pi Radians

• Fit to Var Min/Max

Selecting any of these options changes the Theta Mode, resets the Theta-axis range, and resets the
Theta Period. When the Theta Mode is Radians, Tecplot Focus draws Theta labels as fractional units
of Pi.

Theta Period

The Theta Period specifies the Theta range that is required to create a complete circle. If your Theta
Mode is "Degrees", the Theta Period is forced to 360; for "Radians", the period is 2 Pi; for "Fit to Var
Min/Max", the period can be set to any value.

Theta Value on Circle Right

The "Theta Value on Circle Right" setting changes the orientation of the Theta-axis. By default, this
value is zero, which means that the value zero (or equivalent value, 360 degrees, 720 degrees, and
so forth) is displayed on the right hand side of the circle. You can change this value to change the
orientation of the axis.

R-origin

The R-origin specifies what value of R is represented at the center of the axis. The effect of changing
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the R-origin is displayed in Figure 44.

Figure 44. An example of changing the R-origin from a range of 0.3 to 0.6 on a polar plot.

Axis Grid Options

You control the gridlines and precise dot grid from the Grid page of the Axis Details dialog, as shown
below. On this page, you can customize the line pattern, pattern length, line thickness, and gridline
color for Gridlines and Minor Gridlines.

Gridlines

Match the spacing of tick marks.

Minor Gridlines

Subdivisions of Gridlines.

The spacing of Gridlines is controlled by the tick mark spacing; see Tick Mark Options for more
information.
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Gridlines, Minor Gridlines

To activate Gridlines or Minor Gridlines, toggle-on "Show" under these headings on the Grid page.
Both kinds of gridlines have the following options:

Line Pattern

From the Line Pattern drop-down menu, choose one of the following line patterns: Solid, Dashed,
DashDot, Dotted, LongDash, or DashDotDot.

Pattern Length (%)

(Theta axis only) Select a pattern length from the drop-down menu, or enter in your own.

Thickness (%)

Select a line thickness from the drop-down menu, or enter your own as a percentage of frame
height.

Gridline Color

Select the color of your gridlines using the Color Chooser.

Gridline Draw Order

For all axes except 3D, you may specify a gridline draw order. Gridlines may be drawn either
first, before any of the other plotting layers, or last, so they overlay any plotting layers.
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Gridline Cutoff (R%)

(Theta axis only) Select the point along the R-axis where you want to stop drawing Theta lines.


In a Polar Line plot, the abundance of gridlines at the center may obscure data.
You can specify a gridline cutoff along the R-axis of Polar plots on the Grid page
of the Axis Details dialog for the Theta-axis.

Show Precise Dot Grid

The precise dot grid is a set of small dots drawn at the intersection of every minor gridline. In line
plots, the axis assignments for the first active mapping govern the precise dot grid. The precise dot
grid option is disabled for the 3D Cartesian plots and Line plots when either axis for the first active
line mapping uses a log scale.

Tick Mark Options

Tick marks can be placed on each axis and labeled with either numbers or text strings. You can define
your tick marks and their placement using the Ticks page of the Axis Details dialog. You can define the
tick mark labels using the Label page of the Axis Details dialog.

Show Ticks On

For each plot type, you can display tick marks at different sections of the axis.(This description also
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applies to Labels and Titles.)

Sketch, XY Line, and 2D Cartesian axes allow tick marks to be displayed in the following areas:

Axis Line

The line that represents the specified axis.

Grid Border Bottom

By default, the axis line and grid border left/bottom are in the same position. Grid Border Bottom
is the lower left-most position of the grid as defined by the viewport settings on the Area page of
the Axis Details dialog.

Grid Border Top

Grid Border Top is the top right-most position of the grid as defined by the viewport settings on
the Area page of the Axis Details dialog.

3D Cartesian axis tick marks can be displayed in the following areas:

Axis Line

The line that represents the specified axis.

Opposite Edge

The complimentary line that is opposite the axis line.

Polar R-axis tick marks can be displayed in the following areas:

Axis Line

The line that represents the R-axis.

All R-axes

Only available if "Draw Axis in Both Directions" or "Draw Perpendicular Axis" is toggled-on for
the R-axis. The All R-axes setting will draw tick marks on the additional axes that are drawn.

Grid Border Start

Start point of the polar grid area.

Grid Border End

End point of the polar grid area.


Grid Border Start and Grid Border End are only available if the polar plot does
not form a complete circle. If the data forms a complete circle, there is no start
or end point on which to draw the ticks.

Polar Theta-axis tick marks can be displayed in the following areas:
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Axis Line

The line that represents the Theta-axis.

Inner Circle

Only available if the minimum (Min) value on the R-axis is greater than the R-origin (Max) value.
The Min and Max values are located on the Range page of the Axis Details dialog (see Axis
Range Options for Polar Plots). When this is the case, the center of the polar plot is a circle rather
than a single point; therefore, ticks can be drawn on the inner circle.

Outer Circle

The outer edge of the polar grid area.

Major Tick Mark Length and Thickness

Tick mark length and thickness can be set independently for major and minor tick marks using the
Length and Thickness fields o.

Number of Minor Ticks Length and Thickness

To specify the number of minor tick marks, you must first toggle-off "Auto Spacing" at the bottom of
the page. The number of minor tick marks can be set in the "Number of Minor Ticks" text field in
the Minor Ticks section of the dialog. You may also set their length and thickness.


There is not a separate control for showing minor tick marks. To hide minor tick
marks, enter zero in the "Number of Minor Ticks" text field.

Tick Mark and Label Spacing

You can control tick mark and label spacing directly, or use "Auto Spacing" (the default) to calculate
an optimal spacing for tick marks and tick mark labels. As you change views, particularly in
zooming, Tecplot Focus recalculates the spacing. With "Auto Spacing" selected, Tecplot Focus also
calculates the number of minor tick marks for you.

Spacing values are shared between tick marks and tick labels. You can change the spacing by
adjusting the Auto Spacing, Spacing, and Anchor controls at the bottom of the page under "Tick
Mark and Label Spacing".

Tick Mark Label Options

From the Labels page of the Axis Details dialog, you can specify the label attributes for the tick marks
of each axis.
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Show Labels On

Toggle-on the appropriate options for label display. The available options are dependent on plot
type.

For Sketch, XY line, and 2D Cartesian line plots, choose from:

Axis Line

When toggled-on, axis labels will display on the selected axis line.

Grid Border Bottom

When toggled-on, axis labels will display on the bottom of the grid.

Grid Border Top

When toggled-on, axis labels will display on the top of the grid.

For 3D Cartesian line plots, choose from:

Axis Line

When toggled-on, axis labels will display on the selected axis line.
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Opposite Edge

When toggled-on, axis labels will display on the opposite edge of the plot.

For Polar Line plots, choose from:

Axis Line

When toggled-on, axis labels will display on the selected axis line.

Inner Circle

When toggled-on, axis labels will display on the inner edge of the polar grid area. (Only available
if the minimum value on the R-axis is greater than the R-Origin value.)

Outer Circle

When toggled-on, axis labels will display on the outer edge of the polar grid area.

Color and Font

Select the color and font in which you want your labels to appear. (See Font Folders and Fallback for
more information on how fonts work with Tecplot Focus.)

Number Format

Choose how the numbers should be formatted for axis labels using the Specify Number Format
dialog.

Offset from Line (%)

Enter the offset of the tick mark labels from the axis.

Orient Labels

Select from the following additional options for label display:

At Angle

Labels oriented at the angle specified in the Angle drop-down menu.

Parallel

Labels are parallel to the axis.

Perpendicular

Labels are perpendicular to the axis.

Angle (deg)

If Orient Labels is set to "At Angle", specify the orientation of the tick mark labels relative to the
axis. The angle is measured in degrees counter-clockwise from the axis.

Show Label as Axis Intersection

[2D, XY, and Polar Only] - Toggle-on to draw a label at the point where two axes intersect. Use this
toggle if you have axis labels that are colliding, or are stacked on top of one another at the
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intersection of two axes.

Erase Behind Labels

Toggle-on to include a rectangle (with the color of the frame background) behind the label to
increase the visibility of the label.

Label Skip

Specify the interval between tick mark labels.

Tick Mark and Label Spacing

You can control tick mark and tick mark label spacing directly, or use Auto Spacing (the default) to
calculate an optimal spacing for tick marks and tick mark labels. As you change views, particularly
in zooming, Tecplot Focus recalculates the spacing. With Auto Spacing selected, Tecplot Focus also
calculates the number of minor tick marks for you.

Spacing values are shared between the tick marks and tick labels. You can change the spacing by
adjusting the Auto Spacing, Spacing, and Anchor controls at the bottom of the Ticks or Label pages
of the Axis Details dialog.

Axis Title Options

An axis title is a text label that identifies the axis. By default, Tecplot Focus labels each axis with the
name of the variable assigned to that axis.

286



From the Title page of the Axis Details dialog, you can specify the following attributes for each axis
title:

Show Title On

For any plot type, you can specify where to show the axis title. Toggle-on "Axis Line" to show the
axis title directly on the corresponding axis. The remaining available options are dependent upon
plot type.

For 3D

Opposite Edge.

For 2D, XY Line or Sketch

Grid Border Bottom or Grid Border Top.

For Polar Line plots

Inner Circle or Outer Circle.

Color and Font

Select the color and font in which you would like your axis to appear. (See Font Folders and Fallback
for more information on how fonts work with Tecplot Focus.)
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Offset from Line

Prevents Tecplot Focus from printing your axis title directly on top of the axis. You may specify a
positive or negative offset from one side or the other of the axis. An offset of zero prints the edge of
the axis title on the axis.

You may also adjust the axis title offset using the Adjustor  tool from the Toolbar (not available
for 3D Cartesian plots).

Position along Line

Specify the start position of the axis title as a percentage of axis length.

Title

Choose one of the following display options:

Use Variable Name

The legend header will display the variable name assigned to the contour group.

Use Text

The legend header will display text entered into the text field next to the options widget. The text
can contain dynamic text (See Dynamic Text for information on dynamic text) and formatted
using tags (See Text Details for information text formatting tags).

Axis Line Options

The actual axis line is shown by default whenever the axis is shown. However, you can hide the axis
line without turning off the axis as a whole. To show or hide the axis line, select the Lines page of Axis
Details dialog (accessed via the Plot menu).
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The options in this dialog vary depending on the plot type and, for some plot types, the axis selected.
All of the available options are described below, but not all will be available at any one time.

Show Axis Line

Toggle-on or off to display or hide an axis line.

Color

Select the color of your axis line using the Color Chooser.

Thickness

Select the thickness of your axis line.

Show Line on Opposite Edge

(3D Cartesian only) - Toggle-on or off to draw a line on the opposite edge from the selected axis line.

Show Grid Border

Turning on the grid border draws a border around your grid. Toggle-on or off to display or hide the
borders of your grid. Not available for 3D Cartesian plots.

Color

Select the color of your grid border.

289



Thickness

Select the thickness of your grid border.

Align Axis With

Select what part of your plot with which you would like to align your axis. Not available for 3D
Cartesian plots.

Sketch, XY line, and 2D Cartesian plots, choose from Axis Value, Bottom, Top, or Viewport. If you
choose Axis Value (e.g. Y Value), enter the desired value in the text field. For Bottom or Top, enter
the offset from the bottom or top. For Viewport, enter the position within the viewport.

Polar plots (Theta-axis), choose from R Value, Inner Circle, or Outer Circle. When aligning with an
R Value, you may enter an R-axis Value to specify the position of the axis line. When aligning with
the inner or outer circle, specify an offset. With a zero offset, the axis line is on the inner or outer
circle, a positive offset moves the axis line outside the grid area. A negative offset moves the axis
line within the grid area.

Polar plots (R-axis),choose from Theta Value, Inner Circle, or Outer Circle. When aligning with a
Theta Value, you may enter a Theta axis value to specify the position of the axis line. When aligning
with the inner or outer circle, specify an offset. With a zero offset, the axis line is on the inner or
outer circle, a positive offset moves the axis line outside the grid area. A negative offset moves the
axis line within the grid area.

Theta Value

Align the R-axis with a specific Theta B=Value. The axis is limited to the grid area.

Grid Border Start

Align the R-axis with the start of the grid border. The axis is limited to the grid area.

Grid Border End

Align the R-axis with the end of the grid border. The axis is limited to the grid area.

Specific Angle

Align the R-axis with a specific screen angle. The axis is limited to the grid area.

Top of Grid Area

Align the R-axis with the top of the grid area. The axis may be drawn outside the grid area.

Bottom of Grid Area

Align the R-axis with the bottom of the grid area. The axis may be drawn outside the grid area.

Left of Grid Area

Align the R-axis with the left side of the grid area. The axis may be drawn outside the grid area.
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Right of Grid Area

Align the R-axis with the right side of the grid area. The axis may be drawn outside the grid area.

Theta-Axis Value

Specify a Theta-axis value to specify the position of the axis line.

Offset (%)

Enter the offset of the line from the axis.

Angle

Enter the angle of the line from the axis.

Draw Axis in Both Directions

In addition to setting the alignment of the R-axis, you may choose to extend the R-axis by drawing
an axis line perpendicular or parallel to the existing axis line.

Toggle-on "Draw Axis in Both Directions" to extend the axis line so that it spans the width of the grid
area.

Draw Perpendicular Axis

Toggle-on "Draw Perpendicular Axis" to draw an axis line perpendicular to the main axis line.

Show Viewport Border

(Polar line plots only) Toggle-on "Show Viewport Border" to show the viewport border. The
viewport border is defined on the Area page of the Axis Details dialog.

Color

Select the color of your viewport border.

Thickness

Select the thickness of your viewport border.

Show Line on Opposite Edge

(3D Cartesian only) - When toggled-on, axis lines will display on the opposite edge of the plot.

Color

Select the color of your grid border.

Thickness

Select the thickness of your grid border.

Show Axis Box

(3D Cartesian only) Toggle-on "Show Axis Box" to display all edges of all axes.
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Auto 3D Edge Assignment

(3D Cartesian only) - Toggle-on "Auto 3D Edge Assignment" to place the three axis lines so they will
not interfere with the drawing of the plot. If toggled-off, you have the option to place the line at any
pair of edges, such as Y-Minimum & Z-Minimum, Y-Maximum & Z-Minimum, Y-Minimum and Z-
Maximum, or Y-Maximum & Z-Maximum. The available pairs depend on the axis selected to edit.

Grid Area Options

The grid area of your plot is the area defined by the axes. From the Area page of Axis Details, you
control whether the grid area or viewport are color-filled. The Area page is shown below.

 The Area page has the following options, some of which may not be
available depending on plot type and, for Polar line plots, the selected
axis:

Fill Grid Area

For Sketch, XY Line, and 2D Cartesian plots, you can alter the size of the grid area by changing the
extents of the viewport. (For these plot types, the viewport and grid area are synonymous.) Click the
Color button to select the color using the Color Chooser.
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For 3D Cartesian and Polar Line plots, the grid area is altered by changes to the axis ranges.

3D Cartesian options:

Fill Behind Axes

Select this option to fill the area behind the axes (your grid area) with a specific color.

Fill Color

Select the color with which to fill your grid area in the Color Chooser.

Use Light Source Shading

Select this option to light source shade the axis planes.

3D Axis Box Padding

Enter the minimum distance from the data to the axis box. Lowering this value does not
immediately affect the appearance of the plot, since the existing axes still meet the new
constraint; you can use Reset Range on the Range page see Axis Range Options for XY and
2D/3D Plots to force the plot to redraw.

Polar Line options:

Fill Grid Area

Select this option to fill the grid area with a specified color.

Fill Viewport

Select this option to fill the viewport area with a specified color.

Viewport Position (%)

Select the position of the Viewport. The Viewport is the percentage of the entire plot area occupied
by the plot grid. Select the location (as a percentage of the entire plot area) in which to place the
Left, Right, Top, and Bottom borders of your grid area.

Time/Date Format Options

The Specify Number Format dialog is available for all plot types, including Sketch. You can use this
dialog to display your axis labels in a number of different formats, including Time/Date format. The
Specify Number Format dialog can be accessed by going to the Plot→Axis→Label or the
Plot→Axis→Range page, and selecting the [Number Format] button. See Specify Number Format for
more information on the Specify Number Format dialog.

You can also display elapsed time, instead of absolute time, on any axis. To do this, the original
time/date data in your data file must indicate the elapsed time.)
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To specify your axis label using Time/Date format, select "Time/Date" from the Type drop-down menu.
Data is read forward from December 30, 1899. Tecplot Focus also accepts negative values to support
dates back to January 1, 1800.

You can format your labels by entering the available Time/Date codes in the Format field. When
entering a format, any combination or subset of the Time/Date formula may be used.


If you use "m" immediately after the "h" or "hh" code or immediately before the "ss"
code, Tecplot Focus displays minutes instead of the month.

Use the following formula and table to enter your Time/Date codes:

Time Date Formula:

years-months-days hours:minutes:seconds

Time/Date Codes:

Time/Date Code Display Format

Years yy 00-99

yyyy 1800-9999
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Time/Date Code Display Format

Months 1 mmmmm first letter of the month

m 1-12

mm 01-12

mmm Jan-Dec

mmmm January-December

Days [d] 2 total number of elapsed days

d 1-31

dd 01-31

ddd Sun-Sat

dddd Sunday-Saturday

ddddd S,M,T,W,T,F,S

Hours 3 [h] total number of elapsed hours

h 0-23 or 1-12

hh 00-23 or 1-12

AM/PM AM or PM

A/P AM or PM as "A" or "P"

Minutes [m] total number of elapsed minutes

m 0-59

mm 00-59

Seconds s 0-59

ss 00-59

.0 Tenths

.00 Hundredths

.000 Thousandths

1 Codes can be entered as upper or lower case letters; however, letters will be displayed as shown in
the display format. Numbers that cannot be formatted as a time or date will be displayed as asterisks.

2 Total number of elapsed days, hours, and minutes are valid for time values greater than or equal to
zero, and equal to or less than 1,000,000 days.

3 If you enter "AM/PM" or "A/P" in your Time/Date format, the "h" and "hh" hour codes are expressed
using a 12-hour clock. Otherwise, hours are expressed in military time (24 hour clock).

 Placing a backslash in front of a y, m, d, or s in the Time/Date formula will keep it from
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being processed as part of the formula. All characters not part of the Time/Date
formula will appear as entered.

For example, "\year yyyy" will appear as "year 2008", as the backslash keeps the first y
from being processed as part of the formula.

Examples

To display the time and date on your plot as a "Sat-Jan-05-2008", enter the following code:

ddd-mmm-dd-yyyy

To display the time and date on your plot as a "1-3-08", enter the following code:

m-d-yy

To display the time and date on your plot as a "9:30:05 AM", enter the following code:

h:mm:ss AM

To display an elapsed time, such as "3:10:15", enter the following code:

[d]:hh:mm

Microsoft Excel Support

Tecplot Focus supports Microsoft Excel (except for Mac Excel "1904" format) Time/Date number strings,
with the exception of AM/PM time specifications, long day names, and long month names. This support
allows you to create number formats in Excel and import them for use with your Tecplot Focus plots,
or vice versa.


Time/Date number strings can be transferred from Excel to Tecplot Focus from Mar 1,
1900 forward.

Loading Time/Date Data

You can load time/date data into Tecplot Focus in the same way as any other data point. The following
methods load time/date data as a floating-point number. (After loading, use
Plot→Axis→Labels→Number Format to change the axis format to a time/date display.) The following
methods can be used to load time/date data into Tecplot Focus.
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Excel Macro (add-on)

This add-on offers more options to load data from Excel. Although it requires installation into Excel,
after installing, this method enables quick and simple data loading from Excel into Tecplot Focus.
Refer to Excel Add-In for details.

Text Spreadsheet Loader

For loading delimited files, use this loader. Refer to Text Spreadsheet Loader for instructions.
Time/date data included in this format must be represented by the floating point number used by
Excel and Tecplot Focus. (See the Data Format Guide for more information on this
formatting.)[xxxxxxxxxxxxxxxxx placeholder for data format guide]

Text, Geometries and Images
You can enhance any plot, or create a drawing from scratch, using Tecplot Focus’s text and drawing
tools. Tecplot Focus provides tools for creating polylines, circles, ellipses, squares, rectangles, and text.
You can also insert BMP, JPEG, or PNG images to enhance your plot.

A plot that contains only these add-on elements and no plotted data is referred to as a sketch and can
be created with the Sketch plot type. Figure 45 shows a sketch created with Tecplot Focus drawing
tools.

Figure 45. A sketch created with Tecplot Focus.

Text

To add text to your plot or sketch, either select the Text tool  from the Toolbar or Text from the
Insert menu. Click anywhere in a frame to indicate the location of the text. Use the Text Details dialog
to enter and modify text and its formatting. To create additional text elements, you may click in the
Tecplot Focus workspace at the desired location of the next text element while the dialog is open.

You can edit existing text by first choosing the Selector tool,  then double-clicking the text element to
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open the Text Details dialog. Alternatively, right-click the text element and many of the text attributes
can be changed in the context menu as well as selecting Text Details.

Text Details

The Text Details dialog has the following options:

Text Entry Field

Type the desired text in this box. Text will appear in your plot as you type.

You can embed Greek, Math, and User-defined characters into English-font strings by enclosing
them with text formatting tags, together with the keyboard characters. See Custom Character and
Symbol Definition for more information on defining your own characters.

The text formatting tags and their effects are as follows (format tags are not case sensitive and may
be either upper or lower case):

<b>…</b>

Boldface

<i>…</i>

Italic

<verbatim>…</verbatim>

Verbatim

<sub>…</sub>

Subscripts

<sup>…</sup>

Superscripts
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<greek>…</greek>

Greek font.

<math>…</math>

Math font.

<userdef>…</userdef>

User-defined font.

<helvetica>…</helvetica>

Helvetica font.

<times>…</times>

Times font.

<courier>…</courier>

Courier font.


Not all fonts have Bold and/or Italic variants. For fonts that do not have these
styles, the <b> and/or <i> tags may have no effect.

Embedding and escaping special characters work only in English-font text; they have no effect in text
created in Greek, Math, or User-defined character sets.

You can produce subscripts or superscripts by enclosing any characters with <sub>…</sub> or <sup>…
</sup>, respectively. Tecplot Focus has only one level of superscripts and subscripts; expressions
requiring additional levels, such as , must be created by hand using multiple Tecplot Focus text
strings. If you alternate subscripts and superscripts, Tecplot Focus positions the superscript directly
above the subscript. Thus, the string a<sub>b</sub><sup>c</sup> produces . To produce consecutive
superscripts, enclose all superscript characters in a single pair of tags. The string x<sup>(a+b)</sup>
produces  in your plot.

To insert a tag into text literally, precede the first angle bracket with a backslash ("\"). To insert a
backslash in the text, just type two backslashes ("\\"). In ASCII input files, the number of backslashes
must be doubled (two to precede a special character, four to create a backslash) because the Preplot
program also requires a backslash to escape special characters.


To produce more elaborate math expressions use latex expressions instead. See LaTeX
Expressions.

Font

Select a font for the text. (See Font Folders and Fallback for more information on how fonts work
with Tecplot Focus.) You may click the B and I buttons as shortcuts for selecting a bold, italic, or bold
italic variation of the chosen font.
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Not all fonts have Bold and/or Italic variants. For fonts that do not have these
styles, the B and/or I buttons may have no effect.

Size

Select a character height unit from the drop-down menu, then enter the size in the associated field:

Points

Specify character height in points. One point is 1/72nd of an inch.

Frame%

Specify character height as a percentage of frame height.

Grid

Specify character height in grid units. (Available only when Position By is set to Grid.)

X/Y Position

Choose the position of the text element’s anchor point (see Anchor button).

Position by

Choose to position the text using the frame or grid coordinate system.

Macro function

Enter the name of the macro function to be linked to this text object. See Linking Text and
Geometries to Macros for more information. To run the linked macro function, hold down Control
while right-clicking the text object in the workspace. (On Mac, hold down Command while right-
clicking.)

Color

Select a color for the text using the Color Chooser.

Angle (deg)

Specify the orientation of the text relative to the axis. The angle is measured in degrees counter-
clockwise from horizontal. Horizontal text is at zero degrees; vertical text is at 90 degrees. You can
either enter an angle in degrees, or select from one of the preset angles in the drop-down.

Line Spacing

Enter the line spacing when multiple lines of text are entered: 1 for single-spacing, 2 for double-
spacing, etc. Fractional values are permitted.

Text Box

Opens the Text Box dialog to specify the appearance of the box around the text (if any). See Text Box
for more information.
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Anchor

Choose how the text is aligned with the anchor point. As new text is added, the text expands away
from the anchor point chosen in the Anchor Alignment dialog.

Font Folders and Fallback

Tecplot Focus supports TrueType (.ttf) and OpenType (.otf) fonts. Fonts installed in the standard
folder for fonts on your operating system (for example, C:\Windows\Fonts on a Windows computer)
appear in the font selection menu in the Select Font dialog and in other places where you choose a
font.

If the fonts you want to use with Tecplot Focus are installed in other folders, or if your operating
system does not have a default system location for fonts, you can edit the tecplot.cfg file in your
Tecplot Focus installation directory, using Notepad or another text editor, to indicate the directories
where the fonts you want to use are installed. Add a line like one of the following:

$!Interface FontPath = ' "/font/path" '
$!Interface FontPath = ' "C:\Windows\Fonts" "C:\More Fonts" '
$!Interface FontPath = ' "/first/path/" "/second/path" "/third/path" '

Replace the paths with the paths to the folders that contain the fonts you wish to use, taking special
note of the single quote marks that wrap the entire list of folders and the double quotes around each
folder’s path. You can use just one or several font folders. As shown in the second example, if you wish
to use your computer’s standard fonts as well as fonts from other folders, you must manually specify
the standard font folder along with the others.

If you open a layout that specifies a font that Tecplot Focus does not have access to on your system, the
text "falls back" to Times. If the layout specifies a style you do not have (for example, a bold version of
a font you have but which does not include a bold version on your system), the correct font is used, but
the style (boldface, in this case) is not displayed.

It is possible to choose a font by typing its name directly into the font selection field in the Text Details
dialog and other places where a font can be chosen, instead of choosing the desired font from the
provided menu. If the font you specify in this way is not available to Tecplot Focus on your system, the
text will appear as Times on your computer. However, the name you typed is recorded when you save
a layout, and the text appears in the correct font if the layout is later opened on a computer on which
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the font is available.

Text Box

Use the Text Box dialog (accessed via the Text Box button in the Text Details dialog) to control the
appearance of a box around the text. The following options are available:

None

Select this option to specify that no box is drawn around the text.

Outline

Select this option to specify an outline box around the text. The box is not filled, so any underlying
Tecplot Focus object can still be seen.

Filled

Select this option to specify a filled box around the text. A filled box is opaque; if you place it over
another Tecplot Focus object, the underlying object cannot be seen.

Line Thickness (%)

Specifies the thickness of the text box as a percentage of the frame width.

Box Color

Select the box outline color from the Color Chooser dialog.

Fill Color

Select the box fill color from the Color Chooser dialog.

Margin

Specify the margin as a percentage of the text character height.
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Special Characters

Tecplot Focus supports Unicode text encoding. Your operating system should provide ways to enter
Unicode text in non-English character sets, and any Unicode characters you can enter using these
methods will display and print correctly in Tecplot Focus.

If your system does not have the ability to enter Unicode text, characters in the ordinal range 160-255
provide support for most of the major European languages. The following table shows the characters
in this range supported by Tecplot Focus. Note that the two right-hand columns represent the extended
European characters. Text formatting tags for Greek, Math, or User-defined characters work only with
characters in the range 32-126 and is not available for the extended European characters. If your
system is configured for European text entry, the European characters should appear and print
automatically with no additional setup.
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Figure 46. Character Indices in Tecplot Focus.
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If your keyboard is not configured to produce a specific character, you can generate it by including the
sequence nnn in your text, where nnn is from the character index table found in the table. For example,
if your keyboard will not generate the é and you want to show the word "latté," enter:

latt\233

Custom Characters

You can create symbols, characters, and even custom fonts for use in Tecplot Focus. See Custom
Character and Symbol Definition for further instructions.

Dynamic Text

You can add special placeholders, called dynamic text, that change with the data or the display
environment. For example, you can add a date placeholder that Tecplot Focus will replace with the
current date at each redraw. Similarly, you can add a zone name or variable name placeholder.

For placeholders that represent an attribute of a Tecplot Focus object of which Tecplot Focus supports
multiple instances (such as a frame, a dataset, or a zone), the placeholder by default refers to the
current or active instance: for example, to the active frame if the placeholder refers to an attribute of
frames. If there is no obvious default or active instance, the placeholder by itself usually refers to the
first instance.

For such placeholders, you may specify the desired instance of the referenced type of object by
enclosing an index in square brackets immediately following the placeholder name. For example,
&(AUXZONE[3]:BC) refers to the zone auxiliary data named BC in the third zone.

In most cases, the index may also be written as ACTIVEOFFSET=n to specify the nth active instance of an
object type. For example, &(ENDSLICEPOS[ACTIVEOFFSET=2]) refers to the end position of the second active
slice group.

*[This feature is only available in Tecplot 360]* For placeholders that represent the minimum or
maximum value of a variable, the text (est) is appended to the displayed value if it is an estimate
calculated from variables in a subzone data file.

The complete list of placeholders is as follows:

Variables Notes

&(AUXDATASET:name) The value of the named auxiliary data attached to
the dataset.

&(AUXFRAME:name) The value of the named auxiliary data attached to
the frame.

&(AUXPAGE:name) The value of the named auxiliary data attached to
the page.
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Variables Notes

&(AUXVAR[nnn]:name) The value of the named auxiliary data attached to
variable nnn.

&(AUXLINEMAP[Q]:name) The value of the named auxiliary data attached to
linemap Q, where Q, can be a simple integer n, in
which case it represents the nth linemap or Q can
be the expression ACTIVEOFFSET=n in which case it
represents the nth active linemap.

&(AUXZONE[Q]:name) The value of the named auxiliary data attached to
linemap Q, where Q, can be a simple integer n, in
which case it represents the nth fieldmap or Q can
be the expression ACTIVEOFFSET=n in which case it
represents the nth active fieldmap.

&(AXISMAXn) Maximum value of the current n-axis range,
where n is one of: A[7], R, X, Y, or Z.

&(AXISMINn) Minimum value of the current n-axis range,
where n is one of: A[7], R, X, Y, or Z.

&(BYTEORDERING) Displays the platform’s byte ordering (INTEL or
MOTOROLA).

&(DATE) The current date, in the format dd Mmm yyyy.

&(DATASETFNAME[nnn]) Filename of the nnnth file associated with the
current dataset. If nnn is omitted, then all dataset
filenames are shown, separated by new lines.

&(DATASETTITLE) The current dataset title.

&(ENDSLICEPOS[Q]) The position of the ending slice plane. If Q is an
integer then that represents the nth slice group. If
Q is ACTIVEOFFSET=n then that represents the nth

active slice group

&(EXPORTISRECORDING) Returns "YES" if recording is active, otherwise
returns "NO".

&(FRAMENAME) The frame name.

&(INBATCHMODE) Returns a value of 1 if the software is in batch
mode, 0 if interactive.

&(ISDATASETAVAILABLE) Returns a value of 1 if a dataset exists for the
current frame, 0 if nonexistent.

&(ISOSURFACELEVEL[nnn]) The value of the contour variable on the nnnth iso-
surface for the first iso-surface group.
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Variables Notes

&(ISOSURFACELEVEL[Q][nnn]) The value of the contour variable on the nnnth iso-
surface for the iso-surface group represented by
Q. If Q is an integer then that represents the nth

isosurface group. If Q is ACTIVEOFFSET=n then that
represents the nth active isosurface group

&(LAYOUTFNAME) The name of the current layout file.

&(LOOP) Innermost loop counter.

&(MACROFILEPATH) Path to the folder containing the most recently
opened macro file.

&(MAXn) Maximum value of the n variable, where n is one
of: A[7], R, X, Y, or Z. For 2D or 3D Cartesian plots,
the value is calculated from all active zones. For
line plots, the value is calculated from the zone
assigned to the first active linemap.

&(MAXB) Maximum value of the blanking variable for the
first active constraint. For 2D or 3D Cartesian
plots, the value is calculated from the active
zones. For line plots, the value is calculated from
the zone assigned to the first active linemap.

&(MAXC) Maximum value of the contour variable for
contour group 1. For 2D or 3D Cartesian plots, the
value is calculated from the active zones. For line
plots, the value is calculated from the zone
assigned to the first active linemap.

&(MAXI), &(MAXJ), &(MAXK) [I, J, K]-dimension of the first active zone. For
finite-element zones, MAXI is the number of
nodes, MAXJ is the number of elements, and
MAXK is the number of nodes per element (cell-
based) or total number of faces (face-based) of the
first active finite-element zone.

&(MAXS) Maximum value of the scatter sizing variable of
the active zones.

&(MAXU), &(MAXV), &(MAXW) Maximum value of the variable assigned to the [X,
Y, Z]-vector component of the active zones.

&(MAXVAR[nnn]) Maximum value of variable nnn.
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Variables Notes

&(MINn) Minimum value of the n variable, where n is one
of: A[7], R, X, Y, or Z. For 2D or 3D Cartesian plots,
the value is calculated from all active zones. For
line plots, the value is calculated from the zone
assigned to the first active linemap.

&(MINB) Minimum value of the blanking variable of the
first active blanking constraint. For 2D or 3D
Cartesian plots, the value is calculated from all
active zones. For line plots, the value is calculated
from the zone assigned to the first active linemap.

&(MINC) Minimum value of the contour variable of contour
group 1. For 2D or 3D Cartesian plots, the value is
calculated from all active zones. For line plots, the
value is calculated from the zone assigned to the
first active linemap.

&(MINS) Minimum value of the scatter sizing variable for
the active zones.

&(MINU), &(MINV), &(MINW) Minimum value of the variable assigned to the [X,
Y, Z]-vector component for the active zones.

&(MINVAR[nnn]) Minimum value of variable nnn.

&(NUMFRAMES) Number of frames.

&(NUMPAGES) Number of pages.

&(NUMPROCESSORSUSED) Number of processors used. This may be different
than the total number on the machine because of
the $!Limits MaxAvailableProcessors
configuration file command, or because of a
product limitation.

&(NUMVARS) Number of variables in the current dataset.

&(NUMXYMAPS) Number of XY-linemaps assigned to the current
frame.

&(NUMZONES) Number of zones in current dataset.

&(OPSYS) Displays the current operating system.
1=Linux/Macintosh, 2=Windows.

&(PAPERHEIGHT) The paper height (in inches).

&(PAPERWIDTH) The paper width (in inches).

&(PLATFORM) The platform type (e.g. LINUX or WINDOWS).
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Variables Notes

&(PLOTTYPE) Plot type of the current frame: 0 for Sketch, 1 for
XY Line, 2 for Cartesian 2D, 3 for Cartesian 3D,
and 4 for Polar Line.

&(PRIMARYSLICEPOS [Q]) The primary slice position. If Q is an integer then
that represents the nth slice group. If Q is
ACTIVEOFFSET=n then that represents the nth active
slice group

&(PRINTFNAME) The name of the current print file.

&(SLICEPLANETYPE[Q]) The type of the slice plane (X, Y, Z, I, J or K-planes).
If Q is an integer then that represents the nth slice
group. If Q is ACTIVEOFFSET=n then that represents
the nth active slice group

&(SOLUTIONTIME) The current solution time.

&(SOLUTIONTIME[Q]) Solution time of Q. If Q is an integer nnn then this
represents the solution time for zone nnn. If Q is
ACTIVEOFFSET=n then this represents the solution
time for the first zone associated with the nnnth

active fieldmap. &(SOLUTIONTIME[5]) displays
the solution time of the 5th zone.
&(SOLUTIONTIME[ACTIVEOFFSET=3]) displays
the solution time of the first zone in the 3rd active
fieldmap.

&(STARTSLICEPOS[Q]) The position of the starting slice plane. If Q is an
integer then that represents the nth slice group. If
Q is ACTIVEOFFSET=n then that represents the nth

active slice group

&(STRANDID[n]) The strandID of zone n.

&(STREAMSTARTPOS[nnn]) Starting position (X, Y, Z) of the nnnth streamtrace.

&(STREAMTYPE[nnn]) Type (Surface Line, Volume Line, Volume Ribbon,
Volume Rod) of the nnnth streamtrace.

&($string) The value of the system environment variable
string.

&(TECHOME) Path to the home directory.

&(TECPLOTVERSION) Displays the version number.

&(TIME) The current time, in the format hh:mm:ss.

&(VARNAME[nnn]) The variable name of variable nnn.
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Variables Notes

&(ZONEMESHCOLOR[Q]) Color of the mesh for zone represented by Q. If Q
is an integer nnn then this represents the mesh
color for zone nnn. If Q is ACTIVEOFFSET=n then this
represents the mesh color for the first zone
associated with the nnnth active fieldmap.

&(ZONENAME[Q]) The name of the zone represented by Q. If Q is an
integer nnn then this represents the name of zone
nnn. If Q is ACTIVEOFFSET=n and this is a field plot
then this represents the name of the first zone
associated with the nnnth active fieldmap. If Q is
ACTIVEOFFSET=n and this is a line plot then this
represents the name the zone associated with the
nnnth active linemap.

The placeholders should be typed exactly as shown, although the index or offset parameters shown
must be replaced with the actual index or offset you wish to use.

You can, of course, embed the dynamic text strings in text records in a Tecplot-format data file, as in
the following example:

TEXT CS=FRAME HU=POINT T="&(DATE)"

Environment Variables

System environment variables can be accessed directly from Tecplot Focus by using &($string), where
string is the name of the desired environment variable. Using environment variables within Tecplot
Focus can add another degree of flexibility by taking advantage of your customized environment. If an
environment variable is missing, the environment variable name itself will appear on the screen. Note
that all environment variables are treated as text strings.

Formatting Numbers and Strings

If you want a dynamic text string to be formatted in a specific way, you may include C-style formatting
strings in the macro variable specification.

The syntax for including a format string is:

&(DynamicTextString%formatstring)

The formatstring should be in the following format. Note that the flags, the width, and the precision are
all optional; only the specifier is required. The square brackets [] are not a part of the format string.
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[flags][width][.precision]specifier

The following are available as flags:

- Left-justify (default is right justification)

+ Precede positive numbers with + sign (default is sign only for negative numbers)

space A blank space will be written in place of the sign if the number is positive

0 Left-pads numbers with zeroes to fill the specified width (rather than spaces)

The width specifies the minimum number of characters to be printed. If the dynamic text string is
shorter than this length, it is padded with spaces. The string is not truncated if it is longer than this
length.

The precision specifies the following:

character strings The maximum number of characters to be printed.

integer values The minimum number of digits printed; the number will be padded with leading
zeroes to fulfill this requirement.

floating-point
values

The number of digits to be printed after the decimal point.

When no precision is specified, the default is 1. When printing a character string value in a fixed-width
field, then, you will want to specify the same value for both the width and the precision to achieve the
desired result (otherwise you will print a maximum of 1 character due to the default precision of 1).

The following letters may be used as the specifier:

s string of characters

d signed integer

e scientific notation with a lowercase "e"

E scientific notation with an uppercase "E"

f floating point

g use %e or %f, whichever is shorter

G use %E or %f, whichever is shorter

u unsigned integer, written out in decimal format

o unsigned integer, written out in octal format

x unsigned integer, written out in hexadecimal (where a - f are lowercase)

X unsigned integer, written out in hexadecimal (where A - F are uppercase)
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Example 1

To display the message Maximum contour value is: xxxxxx where xxxxxx only has two digits to the right
of the decimal place. You would use:

Maximum contour value is: &(MAXC%.2f)

If |MAXC| currently has a value of 356.84206 then the resulting string would show:

Maximum contour value is: 356.84

Example 2

If, in the above example, you wanted to use exponential format you could use:

Maximum contour value is: &(MAXC%12.6e)

Here the result would be:

Maximum contour value is: 3.568421e+02

Formatting Dates and Times

For dynamic text strings that represent a date and/or time, such as &(SOLUTIONTIME), the following may
be used:

yy Two-digit year ("09")

yyyy Four-digit year ("2009")

m Month number ("3", "12"), or minute if preceded by hours token

mm Zero-padded two-digit month ("09") or minute if preceded by hour token

mmm Abbreviated month ("Oct" for October)

mmm
m

Full month ("October")

mmm
mmm

Single-letter month ("O")

d Day of month ("9", "10")

dd Zero-padded two-digit day of month ("09")

ddd Abbreviated day of week ("Sun" for Sunday)
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dddd Spelled-out day of week ("Sunday")

ddddd Single-letter day of week ("S")

h Hour ("7", "11")

hh Zero-padded two-digit hour ("07")

s Seconds ("5", "22")

ss Zero-padded two-digit seconds ("04")

.0, .00,

.000
Milliseconds to 1, 2, or 3 digits

am/p
m, a/p

AM/PM indicator. All times are 24-hour unless an AM/PM indicator is included in the format
string, in which case 12-hour formatting is used.

[d],
[h],
[m]

Elapsed days, hours, or minutes.

\- Escapes (removes the special meaning of) the following character. May be used if your format
string includes static text containing any of the above tokens.

Example:

Here is a date and time format string for a solution time:

"Recorded on &(SOLUTIONTIME%dddd dd-mmm-yyyy at hh:mm:ss am/pm)"

The result would be similar to:

Recorded on Monday 14-Sep-2009 at 04:31:42 PM"

LaTeX Expressions

LaTeX is a computer language designed for typesetting. The most popular use of LaTeX is math and
Greek fonts for technical purposes. Use the LaTeX option of the Text Details dialog (accessed via the
LaTeX Box button in the Text Details dialog) to switch between normal and LaTeX text.
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The following options are available:

Generate LaTeX

Renders the LaTeX output based on the current text field.

Size

Select a character height unit from the drop-down menu, then enter the size in the associated field.
LaTeX size commands are still valid and will resize relative to the Size value:

Points

Specify character height in points. One point is 1/72nd of an inch.

Frame%

Specify character height as a percentage of frame height.

Grid

Specify character height in grid units. (Available only when Position By is set to Grid.)

LaTeX

Switches between regular and LaTeX output in the text field.

X/Y Position

Choose the position of the text element’s anchor point (see Anchor button).

Position by

Choose to position the text using the frame or grid coordinate system.

Anchor

Choose how the text is aligned with the anchor point. As new text is added, the text expands away
from the anchor point chosen in the Anchor Alignment dialog (See Text Details for a complete image
of the Anchor Alignment dialog).
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Macro function

Enter the name of the macro function to be linked to this text object. See Linking Text and
Geometries to Macros for more information. To run the linked macro function, hold down Control
while right-clicking the text object in the workspace. (On Mac, hold down Command while right-
clicking.).

A few requirements are needed before LaTeX outputs can be generated. In order to generate LaTeX
outputs, see LaTeX Setup for more information on how to install recommended LaTeX engines.

LaTeX Examples

Example 1: Mathematical Symbols

LaTeX allows for easy configuration symbol production. The example below shows how to create
simple vector and square root symbols:

$$\vec a =\sqrt 2$$

The dollar signs denote the start of an equation. The output is shown below:

Example 2: Mathematical Formula

In LaTeX, syntax is crucial to produce a correct output. Each symbol has its own syntax. The formula
for Kirchhoff’s current law, for example, is used like so:

Kirchhoff's current law\ldots
\begin{equation}
\sum_{k=1}^{n} I_k = 0 \; .
\end{equation}

Notice in Figure 47 below how the begin and end equations separate the equation from regular text.
LaTeX changes paragraph spacing as well as symbols.

Figure 47. Kirchhoff’s Current Law in LaTeX

 To prevent equation numbering, use the \begin{equation*}…\end{equation*} syntax.
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Example 3: How to add summations in inline text versus display style

Note the difference in typsetting style between inline text style and display style equations.

\noindent
This is the inline text style:
$\lim_{n \to \infty} \sum_{k=1}^n \frac{1}{k^2} = \frac{\pi^2}{6}$.
\newline\noindent
And this is display style:
$$lim_{n \to \infty} \sum_{k=1}^n \frac{1}{k^2} = \frac{\pi^2}{6}$$
or
\begin{equation*} \lim_{n \to \infty} \sum_{k=1}^n \frac{1}{k^2} = \frac{\pi^2}{6}
\end{equation*}

Figure 48. Inline text versus display style

Example 4: Sizing and Accented Phrase

LaTeX allows for easy alphabetical accents. The following example shows the variety of accented
phrases that can be accomplished by LaTeX typesetting. The phrase:

\huge ?`D\'onde est\'a el avi\'on? \\

Is easily converted to non-English symbols. In LaTeX, these symbols are converted inline with other
text allowing fluid transitions between both.
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Figure 49. Multi-lingual phrases in LaTeX

Example 4: Color, Sizing, and Text Boxes

LaTeX allows for easy customizability with certain keywords. Some keywords and formatting are
dependent on packages that do not come preinstalled with your LaTeX engine. The following example
uses the xcolor package to show custom formatting. To initialize xcolor in the preamble, add the
following to the end of the preamble in the tecplot_latex.mcr file:

\usepackage{xcolor}

Now your Tecplot Focus installation will be ready to use the xcolor package. Use the following phrases
as an example for color, size, and text box formatting:

\fcolorbox{red}{gray!20}{\color{red} Colors are fun} but \ldots \\
\emph{\small sometimes they are not ideal} \\
{\color{blue}\framebox{This might be better.} \\
But \colorbox{orange}{whatever you do,} \\
\color{black}don't make a {\huge Big Deal} about it.

This example shows three different text boxes each with different parameters. \fcolorbox allows for a
colored frame as well as a background. \framebox has a transparent background and takes the frame
color of whichever color is currently being used. \colorbox creates a highlight in the color specified.
The output is shown below:

Figure 50. LaTeX Color, Sizing, and Text Boxes
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Additional Examples

Example 5: Color with Equations

Example of LaTeX color with equations. See Example 4: Color, Sizing, and Text Boxes for information
about xcolor package.

$\color{white}\overline{u^\prime v^\prime}$

Figure 51. Overline LaTeX with color

Example 7: Complex Fractions

$\frac{T - T_\infty}{T_f - T_\infty}$
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Figure 52. Complex LaTeX fraction

Example 8: Simple Inline Equation

\textbf{Normalized Mean Velocity, $\overline{W}/U_\infty$}

Figure 53. Inline LaTeX Equation

Additional LaTeX Resources

See this page for greek letter and math symbol syntax: www.overleaf.com/learn/latex/
List_of_Greek_letters_and_math_symbols

For more examples on LaTeX use, syntax, or concepts check Tobias Oetiker’s PDF, The Not So Short
Introduction to LaTeX.

Many frequently asked questions can also be found on the TeX StackExchange website:
tex.stackexchange.com/

Geometries

Geometries in Tecplot Focus are simply lines and shapes, including polylines (a set of line segments),
circles, ellipses, rectangles, and squares. Images are also considered geometries. Character Indices in
Tecplot 360 shows some examples of geometries.
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Figure 54. Sample Geometries

Geometry Creation

Geometries are created by drawing them in a frame using tools from the Toolbar or the Insert menu.
(There is no tool for inserting an image; to insert an image, choose Insert→Image/Georeferenced
Image).

Polyline

A polyline is a single geometry consisting of one or more line segments. Add a polyline to your plot by
using the  button from the Toolbar or by selecting Insert→Polyline. To draw the polyline, move the
mouse (without dragging) to the desired end point of the first line segment, then click the left mouse
button. Move the pointer to the next end point, click, and so on. After placing the last segment, double-
click on the final end point, right-click, or press Escape on your keyboard. To draw a horizontal or
vertical line segment, press the H or V keys, respectively, while drawing the segment. After you place
the segment’s end point, the horizontal or vertical restriction is lifted. To lift the horizontal or vertical
line segment restriction without placing the end point, press A on your keyboard. You can draw
unconnected line segments in a single polyline; press U on your keyboard to "lift the pen." You can then
move the pointer to the start of the next line segment.

Table 4. Table Keyboard Shortcuts for Polylines

A Allow translation of polyline segments in all directions.

H Restrict translation of current polyline segment to horizontal.

U Pen up, while drawing polyline.

V Restrict translation of current polyline segment to vertical.
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Circle

Add a circle to your plot by using the  button from the Toolbar or by selecting Insert→Circle. To
draw the circles, click at the desired center point of the circle; drag the mouse until the circle is the
desired radius, then release.

Ellipse

Add an ellipse to your plot by using the  button from the Toolbar or by selecting Insert→Ellipse. To
draw the ellipse, click at the desired center point of the ellipse; drag the mouse until the ellipse is the
desired size and shape, then release.

Square

Add a square to your plot, using the  button from the Toolbar or by selecting Insert→Square. The
anchor point of the square is either the lower left-hand corner or the upper right corner of the square.
Drag the mouse to the right of the anchor to create a square with the anchor at lower left; drag the
mouse to the left to create a square with the anchor at upper right. Release when the square is the
desired size.

Rectangle

Add a rectangle to your plot, using the  button from the Toolbar or by selecting Insert→Rectangle.
To draw the rectangle, drag the mouse until the rectangle is the desired size and shape. In contrast to
squares, rectangles can propagate in any direction.

Images

Tecplot Focus can import images from JPEG, BMP, and PNG files. These images can be used as logos or as a
backdrop to your plot. To add an image to your plot, choose Insert→Image/Georeferenced Image and
browse to the desired image file. When you insert an image, the image is initially centered in the frame
at a preset size. It can be resized by dragging its handles (at the corners and at the midpoints of its
edges) when it is selected.

Images cannot be included in data files. When you save a data file, even if you indicate that you wish
to include geometries, any images in the plot are not saved.

In layout and style sheet files, the image is referenced from its original location. This reference can be
a relative reference or an absolute (as with data files). See Layout Files, Layout Package Files,
Stylesheets for details.

Images are included in layout package files.

Georeferenced Images

Georeferenced images can be added if they are paired with world files. Valid world files include .bmpw,
.bpw, .jpgw, .jgw, .pgw, .pngw, .wld. When a world file is selected in the Insert Image File loader, it will
automatically look for a corresponding image file of the same name.
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World files supply information about the image’s coordinate system including the location, scale, and
rotation of the image on a defined coordinate system. For more information about how each line in a
world file represents the coordinate system, see this Wikipedia World File article.

Georeferenced Image Dialog

Displays information about the georeferenced image and allows the georeferenced image to be moved.

File Name

Displays the path of the original georeferenced image file.

Resolution

Displays the original resolution of the georeferenced image in pixels.

Z Position

Enter the Z-coordinate of the anchor position of the georeferenced image.

Z min

Displays the minimum value of the Z-coordinate.

Z max

Displays the maximum value of the Z-coordinate.

Show in all Frames with the Same Data

Toggle-on this option to display the geometry in all frames sharing the active frame’s dataset.

Geometry Details

Use the Geometry Details dialog to specify attributes of polylines, circles, ellipses, squares, rectangles,
and images. To access the Geometry Details dialog, first choose the  Selector tool, then double-click
the geometry or image, or right-click it and choose Geometry Details or Image Details from the context
menu. From the context menu the line and fill attributes can be changed easier than selecting
Geometry Details.

The following options are available for most types of geometries (the line-related options are not,
however, available for images):

Line Color

Select a color for the geometry from the Color Chooser.

Line Pattern

Select the desired pattern (Solid, Dashed, Dotted, LongDash, or DashDotDot).

Pattern Length (%)

Specify the length of the line pattern as a percentage of the frame width.
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Line Thickness (%)

Specify the thickness of the line as a percentage of the frame width.

Fill with Color

Toggle-on to fill a circle, ellipse, square, rectangle or line segment polygon. Then select a color for
the fill using the Color Chooser.

Clipping

Clipping displays only the portion of an object that falls within a specified region of the plot. If you
have specified your geometry position in the Frame coordinate system, the geometry will be clipped
to the frame: any portion of the geometry that falls outside the frame is not displayed. For this
reason, the clipping options are not available for geometries using frame coordinates.

If you have specified the Grid coordinate system, you can choose to clip your geometry to the frame
or the viewport. The size of the viewport depends on the plot type as follows:

3D Cartesian

The viewport is the same as the frame, so viewport clipping is the same as frame clipping. This
option is therefore unavailable in 3D Cartesian plots.

2D Cartesian/XY Line

The viewport is defined by the extents of the X and Y-axes. You can modify this with the Area
page of the Axis Details dialog.

Polar Line/Sketch

By default, the viewport is the same as the frame. You can modify this with the Area page of the
Axis Details dialog.

Draw Order

Geometries can be drawn either before the data, or after the data. If a geometry is drawn before the
data, the plot layers, such as mesh, contour lines, etc. will be drawn on top of the geometry. If a
geometry is drawn after the data, the geometry will be drawn last, obscuring the data.


You can place text and geometries in any order you like. Tecplot Focus draws all
geometries first, in the order in which they were placed, then all text. Use the Send to
Back and Bring To Front commands on the Edit menu to reorder objects.

Attach to Zone/Map

Toggle-on Attach to Zone/Map to attach the geometry to a particular zone or mapping by entering
the number of the zone or mapping. Geometries that are attached to an inactive or non-existent
zone are not displayed.

Show in all Frames with the Same Data

Toggle-on this option to display the geometry in all frames sharing the active frame’s dataset.
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Macro Function

Specify the name of the macro function to be linked to the geometry. See Linking Text and
Geometries to Macros for more information. To run the linked macro function, hold down Control
while right-clicking the geometry in the workspace. (On Mac, hold down Command while right-
clicking.)

Coordinate System

Specify the coordinate system for the geometry (Frame or Grid). When created, screen objects
default to the grid coordinate system. Changing the coordinate system automatically converts
position and size fields so that the geometry will remain in the same place at the same size in the
current view.

Frame

The geometry is always displayed at constant size and position when you zoom in or out of the
plot.

Grid

The geometry resizes and moves with the data grid. However, the geometry remains fixed when
you rotate the plot. Changing the center of rotation may cause the geometry to move.

X, Y

Enter the X and Y-coordinates of the anchor position of the geometry (in frame units if the
coordinate system is frame; in grid units if the coordinate system is grid). This point is the center for
a circle, the upper left corner for a rectangle, etc.

The following fields are specific to a single geometry type:

Polyline

The Arrowhead Style options control the appearance of an arrowhead on the polyline.

Attachment

Choose the end or ends of the polyline by selecting the appropriate check boxes.

Style

Plain, filled, or hollow.

Size(%)

Specify the size of the arrowhead as a percentage of frame height.

Angle

Specify the angle the arrowhead makes with the polyline.

Circle

Controls the radius and precision of approximation of the circle:
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Radius

Set the radius of the circle (in coordinate system units, Frame or Grid).

Number of Sides

Enter the number of polylines used to approximate the circle.

Ellipse

Controls the shape and precision of approximation of the ellipse:

Horizontal Axis

Set the horizontal axis of the ellipse (in coordinate system units, Frame or Grid).

Vertical Axis

Set the vertical axis of the ellipse (in coordinate system units- Frame or Grid).

Number of Sides

Enter the number of polylines used to approximate the ellipse.

Square

Controls the size of the square:

Size

Set the size of the square (in coordinate system units, Frame or Grid).

Rectangle

Controls the size and shape of the rectangle:

Width

Set the width of the rectangle (in coordinate system units, Frame or Grid).

Height

Set the height of the rectangle (in coordinate system units, Frame or Grid).

Image

Displays information about the image and allows the resizing method to be set.

File Name

Displays the path of the original image file.

Resolution

Displays the original resolution of the image in pixels.

Filter

The Resize filter determines how the image is resized to fit the screen. The following filters are
available:
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Fast (textures) (default)

Tecplot Focus uses OpenGL textures to resize the image. This is the fastest option (given
sufficient graphics space). However, the accuracy of the image may suffer, especially when
reducing an image to a size much smaller than it was before.

Pixelated

Choose this option when the image is much larger than its original size and you want to see
the individual pixels. This option is slower than the Fast (textures) for increasing the size of
images.

Smooth

There are seven smooth options, all producing slightly different effects. These options are
slower than the Fast (textures), but produce better effects for highly reduced images. In
general, use the Smooth (Lanczos2) option unless you have specific image processing needs.


The resize filter has no effect on vector-based output, only on the screen and for
exported images.

Three-dimensional Line Geometries

Three-dimensional line geometries cannot be created interactively; they must be created in a data file
or using an add-on. In order to display 3D geometries, you must either include at least one zone in the
data file with the 3D geometries or read the 3D geometries in, using the Add to Current Data Set
option, after having first read a dataset into the frame.

Linking Text and Geometries to Macros

Each text or geometry you create, or image you insert, can be linked to a macro function. This macro
function is called when you hold down the Control key (Command key on Mac) and click the right
mouse button on the text or geometry or image. Macro functions are specified with the Macro Function
field in the Geometry Details dialog or in the Text Details dialog (accessed by selecting your object
and right-clicking.

In order to be attached to a text or geometry object, the macro function must be a "retained" macro
function. A macro function is "retained" via either of the following scenarios:

• running a macro file that contains the required macro functions

• including it in your tecplot.mcr file (which is run at startup, kmaking it a special case of the
preceding scenario)

In both cases, the macro function is defined using the $!MACROFUNCTION macro command. Refer to the
Scripting Guide for additional information.
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Part 4: Data Manipulation

Blanking
Blanking allows you to exclude specific portions of zones from being plotted (in other words,
selectively display certain cells or data points) based on variable values. In 3D, the result is analogous
to a cutaway view.

Blanking settings apply only to the active frame, but Value Blanking settings for multiple frames may
be synchronized using frame linking. Refer to Frame Linking for more information on linking.
Blanking results for volume zones depend upon the Surfaces to Plot setting on the Surfaces page of the
Zone Style dialog (See Surfaces for more details).

In the following discussions, the term "cell" is used. In I-ordered datasets, a cell is the connection
between two adjacent points. In IJ-ordered datasets, a cell is the quadrilateral area bounded by four
neighboring data points. In IJK-ordered datasets, a cell is the six-faced (hexahedral) volume bounded
by eight neighboring data points. For finite element datasets, a cell is equivalent to an element.

The forms of blanking are as follows:

Value Blanking

Cells (or portions of cells) of selected zones or line plot mappings are excluded based on the value of
the value blanking variable at the data point of each cell or at the point where each cell intersects a
constraint boundary.

IJK Blanking

Cells of one IJK-ordered zone are included or excluded based on the index values. (IJK-ordered
zones only)

All types of blanking may be used in a single plot. They are cumulative: cells blanked from any of the
options do not appear. Value Blanking and Depth Blanking affect selected zones of all types, while IJK
Blanking affects a single IJK-ordered zone.

In general, all types of blanking affect all field layers, zones, and all other plot attributes except for
edge layers. with the following exceptions:

Table 5. Plot attributes not affected by blanking.

Type of Blanking Attribute Not Blanked

Value Blanking Edge Layer

IJK Blanking • Derived Objects[8] (slices, streamtraces, or iso-surfaces)

• Finite-element zones

• Unstructured/Unorganized zones *[This feature is only available in
Tecplot 360]*
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Value Blanking

Value blanking allows you to selectively eliminate or trim cells (only) and elements from Line and 3D
field plots. For each active constraint, you specify a value blanking variable, a constant value or
another variable, and a conditional statement telling Tecplot Focus to blank that region in relation to
the specified variable or constant.

Value Blanking for Field Plots

To include value blanking in your plot, go to the Plot menu and select Blanking→Value Blanking. The
Value Blanking dialog has the following options:

Include Value Blanking

Toggle-on to include value blanking.

Note that it is possible to edit the settings in the Value Blanking dialog without actually activating
blanking. This can make it faster to set up blanking since the plot won’t need to redraw after every
change of settings.

Blank entire cells when

Select one of the following blanking styles:

All corners are blanked

Cells are removed from the plot if all of their data points satisfy one or more of the active
blanking constraints.
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Any corner is blanked

Cells are removed from the plot if any of their data points satisfy one or more of the active
blanking constraints.

Primary value is blanked

Cells are removed from the plot based on the primary value for a cell. The primary value for the
cell is dependent upon the zone type and the variable value location, as outlined in the following
table.

Zone Type Value Location Source of Primary Value

Ordered Cell Centered Cell value

Finite element Cell Centered Cell value

Ordered Nodal Lowest indexed corner in the cell

Finite element Nodal First node in the connectivity list for the cell

Refer to the Zone/Variable Info Page of the Data Set Information dialog to determine the Zone Type
and Value Location.

Constraint

You can establish up to eight value blanking constraints. Click a numbered button here to choose
the constraint to be added or changed.

Active

Toggle-on to activate the chosen constraint.

Blank when

For each constraint, set the following parameters:

• Select the variable to use for value blanking.



It is often convenient to create a new variable for use as the value blanking
variable. This allows you to manipulate its values without changing any other part
of the plot. You can create a new variable using the Specify Equations dialog
(accessed via Data→Alter). See Equation Syntax.

• Specify an operation to describe how the blanking variable will be compared to the constant or
variable following it.

• Choose to compare the blanking variable to either another variable or to a constant. If you are
comparing to a variable, select the variable; if comparing to a constant, enter the constant.

Show Constraint Boundary

Toggle-on to display a line that separates the region of your data that is blanked from the region
which is not blanked. Set the appearance of this line using the following controls:
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Color

Select the color of the boundary in the Color Chooser.

Line Pattern

Select the line pattern for the boundary.

Pattern length

Select the length of the pattern as a percentage of frame height.

Line thickness

Select the width of the boundary line as a percentage of frame height.


Value Blanking has no effect on edges of an ordered zone. If the edge is turned on,
the edge of the entire zone (without value blanking) is plotted.

The following figure illustrates the various value blanking modes for plots.
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Figure 55. The effects of the different value blanking options in field plots for a constraint where a variable is
less than or equal to zero. The dark shading indicates the areas that are not blanked. Clockwise from upper left:
Blank cell when primary value is blanked. Blank cell when all corners are blanked. Trim cells along
mathematical constraint boundary.  Blank cell when any corner is blanked.

Value Blanking Settings for Individual Zones

Using the Effects page of the Zone Style dialog (accessed via the Plot menu or the Plot sidebar), you
can turn value blanking on and off for individual zones. Simply highlight the zone(s), and toggle the
checkbox in the Use Value Blanking column.

Value Blanking for Line Plots

For line plots, value blanking excludes data points from consideration in the resulting plot. The settings
are the same as for Value Blanking for Field Plots, except that you cannot choose the behavior of
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blanking relative to cells, as this does not apply to line plots.

As alternatives or adjuncts to value blanking, you can use the Indices page of the Mapping Style dialog
to limit index ranges per mapping. The Curves page can provide another form of blanking by allowing
you to limit the range of the independent variable for individual mappings.

Figure 56 shows two plots. The original data for the plots contain some "bad" data points. The bad data
points were identified as those with a Y-value greater than 0.6. The plot on the left uses all data points,
including the bad data points, to draw a curve. The plot on the right has filtered out the bad data points
by using value blanking, where all points are removed if Y → 0.6. Blanking does not necessarily have to
be on the independent or dependent variable.

Figure 56. XY Line plots showing the effect of value blanking.

IJK Blanking

IJK Blanking is available for 2D and 3D ordered zones, in the 2D and 3D Cartesian plot types. IJK
Blanking removes a selected portion of one IJK-ordered zone from the plot. This allows you to create
cutaway plots: plots showing the exterior of some dataset with a section "cut away" to show the
interior, such as the plot shown in Figure 57.


To use IJK-blanking, you must have a 2D or 3D IJK-ordered zone, and the current plot
type must be 2D or 3D Cartesian. Unlike Value Blanking, which operates on all zones
within a single frame, IJK Blanking can only be used on a single zone within a frame.
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Figure 57. A cutaway plot created with IJK Blanking.

To use IJK-blanking, select Blanking→IJK Blanking from the Plot menu.This option is available only
when your data set has at least one IJK ordered zone.
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The Use IJK Blanking checkbox at the top of this dialog turns IJK blanking on or off. The Definition
page has the following options.

Use IJK Blanking

Toggle-on to include IJK Blanking in your plot.

Zone

Select the zone to which to apply IJK Blanking by clicking in the displayed list of IJK ordered zones.
You may select only one zone.

If your data set has many zones, it is useful to filter the zone list. Type part of a zone name and
press Enter (or click the filter button next to the zone name field) to display only the zones having a
name containing the entered text.

Domain

Specify the domain of the IJK Blanking by choosing one of the following options:
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Interior

Cells within the specified index ranges are blanked. Those outside are plotted. This creates a
"hole" in the zone. The left side of Figure 58 shows an ordered zone with IJK Blanking with
Interior domain.

Exterior

Cells outside the specified index ranges are blanked. Those inside are plotted. Exterior plots a
sub-zone of the zone. The right side of Figure 58 shows an ordered zone with IJK Blanking with
Exterior domain.

Figure 58. IJK Blanking with Interior domain (left) and Exterior domain (right).

Select IJK ranges using

Specify the format in which you will specify the index ranges by selecting one of the following
option buttons:

Index Value

Specify the I, J, and K-index ranges using absolute index values.

Percent of Max

Specify the I, J, and K-index ranges as start and end percentages of the maximum index. For
example, you could blank the middle third of a dataset by setting the start percentage to 33.3 and
the end percentage to 66.6.



When you save a layout, macro, or stylesheet, the IJK Blanking index ranges are
stored as the percentage of the maximum index regardless of how you chose to
enter them. This way, one layout can easily be used for data sets containing zones
of various sizes.

For information on using the Animation page, see IJK Blanking Animation.
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Blanking Settings for Derived Objects

You can opt to turn blanking on or off for derived objects (iso-surfaces, streamtraces, or slices) in their
respective Details dialogs.

Iso-surfaces

The option is located on the Style page of the Iso-surface Details dialog (click the  button to the
right of Iso-Surfaces in the Plot sidebar). Refer to Iso-Surface Contour and Shade for details.

Streamtraces

The option is located on the Integration page of the Streamtrace Details dialog (click the  button
to the right of Streamtraces in the Plot sidebar). Refer to Integration Page for details.

Slices

The option is located on the Definition page of the Slice Details dialog. Refer to Definition Page for
details.

Data Operations
Plots in Tecplot Focus rely on the datasets attached to each frame. You can modify, create, transform,
interpolate, duplicate, and delete the data in the current dataset using the Data menu. You can also use
the data operation capabilities of Tecplot Focus to create plots of analytical functions. By using layout
files, macros, and/or equation files, you can create complex data operations that can be repeated on
different datasets.

Changes to the dataset within Tecplot Focus do not affect the original data file(s). You can save the
modified data by choosing Write Data from the File menu. When you save a layout file, a journal of
data operations is saved and those operations are repeated when the layout file is read at a later time.
If the data in the file has changed, or the data file is overwritten with new data, the operations are
applied to the new data. Alternatively, any datasets that have been modified are also saved to data files
(see Layout Files and Layout Package Files for details).

Data Alteration through Equations

Use Data→Alter→Specify Equations (or click the  toolbar button) to alter data in existing zones.
The dialog allows you to change the values of entire variables or specific data points. You can also use
this dialog to create new variables.

Changes made to the dataset in the Specify Equations dialog are not made to the original data file. You
can save the changes by saving a layout file or writing the new data to a file. Saving a layout file will
keep your data file in its original state, but use journaled commands to reapply the equations.


Variables defined in your data file, or variables you create yourself, are referenced in
equations by surrounding them with curly braces, like {RPM}. This syntax must be used
even when first defining a variable, for example {RPM} = {RPS} * 60 to define a new
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RPM variable from an existing RPS variable. Variable and function names provided by
Tecplot Focus do not require the braces.

The Specify Equations dialog has the following options and fields:

Equation(s)

Enter the equation(s) using the syntax described in Equation Syntax.

Data Set Info

Opens the Data Set Info dialog (see Data Set Information).

Ignore divide by zero errors

When activated, suppresses the error dialog and returns the largest or smallest possible value
depending on the sign of the dividend when a divide by zero condition occurs. 0/0 will return 0.

FE derivative method

Select the preferred method to use for computing finite-element derivatives. The default is Moving
Least Squares. If Green-Gauss is selected, an information icon will appear to the right of the
selector. Hovering the mouse over this icon will display the following information about when the
calculation will fall back to the Moving Least Squares method.



The Green-Gauss method will be preferred for calculating derivatives of finite
elements. The calculation will fall back to Moving Least Squares for polygonal or
polyhedral elements or higher order elements. Moving Least Squares will also be
used for second or higher order derivatives.
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Save Equations

Save all equations in the Equation(s) field to a text file with an .eqn format.

Load Equations

Load an equation file previously saved.

Zones to Alter

Select which zones to alter. You can manually select the zones in the list (holding Shift when clicking
to create a range, or Control to toggle individual zones on or off). You may use the buttons below the
list to select all zones, all active zones, or no zones.



When creating a new variable, if all zones are not selected, Tecplot will create a
passive variable as a placeholder for any zones that are not included in the data
alteration since all zones in a dataset must have the same number of variables.
Passive variables effectively return zero for every point or cell value, do not
consume any memory, and can be replaced at any time with other data alterations.

Index Ranges

Select the index ranges to alter in the selected zones. You may skip this step if you want to apply the
equation to all points of the selected zones. Use the special value 0 or Mx to specify the maximum
index. You can also use the values Mx-1 (to specify the index one less than the maximum index), Mx-
2, and so forth.

For Ordered Data, the I-Index, J-Index, and K-index options correspond to the I, J, and K values in
the dataset. For finite element data, the I-Index corresponds to the range of nodes and the J-Index
corresponds to the cell-centered values. The K-index has no bearing on finite element data.

The Skip field indicates the increment between indices. 1 means apply the calculation to every data
point, 2 means to every other data point, 3 to every third point, and so on. When creating a new
variable, the new variable’s value is set to zero at any index value that is skipped.

New Var Data Type

(if applicable) - Select the data type of the new variable. The following data types are available:

Auto

Tecplot Focus assigns the data type based upon the variables used in the right-hand side of the
equation.

Single

Four-byte floating point values.

Double

Eight-byte floating point values.
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Long Int

Four-byte integer values.

Short Int

Two-byte integer values.

Byte

One-byte unsigned integer values (can contain values from zero to 255).

Bit

Either zero or one.

New Var Location

(if applicable) - Select the location of the new variable. The options are:

Auto

(default) - "Auto" is set to node unless all variables in the equation are located at the cell center.

Node

Stores variable with nodal information. (see Indexing Nodal Ordered Data).

Cell-Center

Stores variable with nodal information. (see Indexing Cell-centered Ordered Data).

Compute

Click the Compute button to alter the data. If an error occurs during the alteration (because of
division by zero, overflow, underflow, etc.), an error message is displayed, all of the zones are
restored to their previous state as of the beginning of processing that equation, and processing
stops. The results of equations that have been successfully processed, however, are retained.

For example, if you enter three equations, and the second contains an error, the final state is the
result of processing only the first equation. The second equation is rolled back due to the error, and
the third is not processed at all.


Every time you hit the [Compute] button, the equations are calculated. Be sure to
remove previously computed equations before computing new ones.

Equation Syntax

You can enter multiple equations in the Equation(s) text field of the Specify Equations dialog. Each
equation occupies one line of the text field as demarcated by the Enter key (not necessarily by where
they wrap in the text field). The equations are applied in order to all specified zones and data points.

Tecplot Focus equations have the following form:
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LValue = F(RValue1, RValue2, RValue3,…)

Where:

F() - A mathematical expression.

LValue - An existing or new variable.

RValueN - A value (such as a constant, variable value, or index value).

If LValue already exists in the dataset of the active frame, the equation is used to modify that variable.
(The same variable may be used on the right side of the equation to refer to the pre-calculation value
and thereby modify it based on its original value.) If the variable does not already exist, the equation is
used to create a new variable as a function of existing variables.

There may be any number of spaces within the equation. However, there cannot be any spaces
between the letters of intrinsic-function names nor in variables referred to by name. (See Equation
Operators and Functions.)

Equation Variables and Values

A variable is specified in one of the following ways:

Its order in the data file

A variable may be referenced according to its order in the data file, where V1 is the first variable in
the data file, V2 is the second, and so forth.

To create a new variable using this specification, you must specify the number of the next available
variable (i.e. if there are 5 variables in the dataset), the new variable must be called V6. You will
receive an error message, if you attempt to assign an invalid variable number.


You can confirm the number and order of variables in the data file in the Data Set
Information dialog (choose Data→Data Set Info). The variables in the dataset are
listed on the right-hand side of the page.

By its name

To reference a variable by its name, enclose the name with curly braces ({ and }). For example, to
set V3 equal to the value of the variable named R/RFR, you can enter:

V3 = {R/RFR}

Variable names are not case sensitive. Leading and trailing spaces are also not considered.
However, spaces within the variable name are significant.

If two or more variables have the same name, the first variable is used when the variable is
referred to by name. So, if both V5 and V9 are named R/rfr, V5 is used.
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The curly braces can also be used on the left-hand side of the equation. In this case, if a variable
with that name does not exist, a new variable is created with that name for all zones.

By a letter code

Variables and index values may be referenced by the following letter codes:

I Depends on the data type and the new variable’s ‘New Var Location’ value:

• Ordered data:

◦ If ‘New Var Location’ is set to ‘Node’, I is the I index number of a node.

◦ If ‘New Var Location’ is set to ‘Cell center’, I is the lowest I index associated with the
cell.

• FE data:

◦ If ‘New Var Location’ is set to ‘Node’, I is the node index number.

◦ If ‘New Var Location’ is set to ‘Cell center’, I is 1.

J Depends on the data type and the new variable’s ‘New Var Location’ value:

• Ordered data:

◦ If ‘New Var Location’ is set to ‘Node’, J is the J index number of a node.

◦ If ‘New Var Location’ is set to ‘Cell center’, J is the lowest J index associated with the
cell.

• FE data:

◦ If ‘New Var Location’ is set to ‘Node’, J is 1.

◦ If ‘New Var Location’ is set to ‘Cell center’, J is the element number.

K Depends on the data type and the new variable’s ‘New Var Location’ value:

• Ordered data:

◦ If ‘New Var Location’ is set to ‘Node’, K is the K index number of a node.

◦ If ‘New Var Location’ is set to ‘Cell center’, K is the lowest K index associated with
the cell.

• FE data:

◦ If ‘New Var Location’ is set to ‘Node’, K is 1.

◦ If ‘New Var Location’ is set to ‘Cell center’, K is 1.

X The variable assigned to the X-axis. In XY-plots, all active mappings must have the same X-
variable in order for this variable name to be valid.

Y The variable assigned to the Y-axis. In XY-plots, all active mappings must have the same Y-
variable in order for this variable name to be valid.

341



Z The variable assigned to the Z-axis (if in 3D Cartesian).

A The variable assigned to the Theta-axis for Polar plots. For this variable to be valid, the plot
type must be set to Polar Line. In addition, all active mappings must have the same Theta-
variable.

R The variable assigned to the R-axis for Polar plots. The plot type must be Polar Line, and all
active mappings must have the same R-variable for this variable name to be valid.

U The X-component of vectors (if defined).

V The Y-component of vectors (if defined).

W The Z-component of vectors (if defined).

B The value-blanking variable for the first active constraint (if applicable).

C The contour variable for contour group 1 (if defined in the Contour Details dialog).

S The scatter-sizing variable (if defined in the Scatter Size/Font dialog).

SOLU
TIONT
IME

The current solution time.

ZONE
NUM

The current zone number.

Letter codes may be used anywhere on the right-hand side of the equation. Do not enclose them in
curly braces.

Those letter codes representing variables (all letter codes except I, J, and K) may be used on the left-
hand side of the equation as well.

The variables referenced by the letter codes are for the current frame.

Equation Operators and Functions

Binary Operators

In an equation, the valid binary operators are as follows:

+ Addition

- Subtraction

* Multiplication

/ Division

** Exponentiation

Binary operators have the following precedence:
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** Highest precedence

*,/

+,- Lowest precedence

Operators are evaluated from left to right within a precedence level.

Functions

The following functions are available. Arguments may be variables, constants, expressions, other
functions.

SIN(X) Sine of X (must be specified in radians)

COS(X) Cosine of X (must be specified in radians)

TAN(X) Tangent of X (must be specified in radians)

ABS(X) Absolute value of X

ASIN(X) Arcsine of X (result given in radians)

ACOS(X) Arccosine of X (result given in radians)

ATAN(X) Arctangent of X (result given in radians)

ATAN2(A,B) Arctangent of A/B (result given in radians)

SQRT(X) Returns the positive square root of X

LOG(X), ALOG(X) Natural logarithm (base e) of X. Both forms are
equivalent.

LOG10(X), ALOG10(X) Logarithm base 10 of X. Both forms are
equivalent.

EXP(X) Exponentiation (base e); EXP(X)=

MIN(A, B) Minimum of A or B

MAX(A, B) Maximum of A or B

SIGN(X) Returns -1 if X is negative, +1 otherwise

ROUND(X) Round X to the nearest integer

TRUNC(X) Remove fractional part of X

RAND(N) Returns random number between 1 and N
inclusive, different for each element in the
variable

Conditional Expressions

Conditional expressions may be written using the IF function.
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IF(P,T,F)

If the predicate expression P is true (has a non-zero value), returns the value of expression T, otherwise
returns the value of expression F. Both T and F are fully evaluated regardless of the value of P; there is
no "short-circuiting."

The predicate expression may include comparison and Boolean operators, as summarized in the
following table.

Operat
or

Description Example

== Equal To {A} = IF(X==2.0, 3, 4) assigns to variable A: 3 if X equals 2.0,
otherwise 4

!= Not Equal To {A} = IF(X != Y,Z,2) assigns to variable A: Z if X does not equal Y,
otherwise 2

> Greater Than {A} = IF(X > 1.0, 4, 5) assigns to variable A: 4 if X > 1.0, otherwise 5

>= Greater Than or Equal
To

{A} = IF(X >= Y, 4, Z) assigns to variable A: 4 if X >= Y, otherwise Z

< Less Than {A} = IF(X < Y, 4, Z) assigns to variable A: 4 if X < Y otherwise Z

<= Less Than or Equal To {A} = IF(X <= Y, 4, Z) assigns to variable A: 4 if X <= Y, otherwise Z

&& Logical AND {A} = IF(X < Y && X > 3, 8,9) assigns to variable A: 8 if X < Y AND X >
3, otherwise 9

|| Logical OR {A} = IF(X == 2 || X > 3, 5,6) assigns to variable A: 5 if X == 2 OR X >
3, otherwise 6

These operators are valid only within the first argument of an IF function. They may not be used
elsewhere in an expression. For example, {A} = X > 1 is invalid. Instead, use {A} = IF(X > 1, 1, 0) or
similar.

Python-style operator chaining (such as A < B < C) is not supported. Although this construction is
syntactically valid, it will not produce the expected result. Use A < B && B < C instead.

&& has a higher precedence than (will be evaluated before) ||. When in doubt, use parentheses.

Derivative and Difference Functions

The derivative functions can be called in the same manner as intrinsic functions. Derivative and
difference functions can be calculated with respect to the following variables:

Variable Definition Restricted to:

x, y, z variable assigned to the x-axis, y-axis or z-axis, respectively XY Line[9], or 3D
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Variable Definition Restricted to:

a variable assigned to the theta-axis Polar Line

r variable assigned to the radial-axis Polar Line

i, j, k index range Ordered Zones

The complete set of first and second-derivative and difference functions are listed below:

Type Function Calls Applicable Variables

First Order ddx, ddy, ddz, dda, ddr x, y, z, a, or r

Second Order d2dx2, d2dy2, d2dz2, d2da2,
d2dr2

x, y, z, a or r

Second-Order (cross derivatives) d2dxy, d2dyz, d2dxz, d2dar xy, yz, xz, or ar

The derivative function ddx is used to calculate ; d2dx2 calculates .

Type Function Calls Applicable Variables

First Order ddi, ddj, ddk i, j, or k

Second Order d2di2 d2dj2, d2dk2 i, j, or k

Second Order (cross derivatives) d2dij, d2djk, d2dik ij, jk, or ik

The difference functions ddi, d2di2, and so forth, calculate centered differences of their argument with
respect to the indices I, J, and K based on the indices of the point. For example:

For ordered zones, spatial derivative functions are calculated using the chain rule with difference
functions. For example:

or:

The spatial derivatives of indices, such as ddx(i), are calculated from their inverses, such as ddi(x),
using standard curvilinear coordinate transformations.

For finite-element zones, spatial derivatives can be calculated using either the Moving Least-Squares
technique or the Green-Gauss method. For Moving Least-Squares, the variable at a particular node or
cell center is assumed to vary quadratically in space about that point, and least-squares is used with all
nodes surrounding the point to fit a polynomial function, whose coefficients then become the first and
second derivatives of the variable. The Green-Gauss method uses surface intergals to compute
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derivatives and can give a better estimate of derivates for highly stretched and/or skewed grids. Note
that there are limitations on when Green-Gauss will be used (see FE derivative method).

Boundary Values

Boundary values for first-derivative and difference functions (ddx, ddy, ddz, ddi, ddj, and ddk) of ordered
zones are evaluated in one of two methods: simple (default) or complex [10]

For simple boundary conditions, the boundary derivative is determined by the one-sided first
derivative at the boundary. This is the same as assuming that the first derivative is constant across the
boundary (i.e., the second derivative is equal to zero).

For complex boundary conditions, the boundary derivative is extrapolated linearly from the
derivatives at neighboring interior points. This is the same as assuming that the second derivative is
constant across the boundary (i.e. the first derivative varies linearly across the boundary).

For second-derivatives and differences (d2dx2, d2dy2, d2dz2, d2dxy, d2dyz, d2dxz, d2di2, d2dj2, d2dij, d2dk2,
d2djk, and d2dik), these boundary conditions are ignored. The boundary derivative is set equal to the
derivative that is one index in from the boundary. This is the same as assuming that the second
derivative is constant across the boundary.


You can create your own derivative boundary conditions by using the index range
and the indices options discussed previously.

The use of derivative and difference functions is restricted as follows:

• Derivatives and differences for IJK-ordered zones are calculated for the full 3D volume. The IJK-
mode for such zones is not considered.

• If the derivative cannot be defined at every data point in all the selected zones, the operation is not
performed for any data point.

• Derivative functions are calculated using the active frame’s axis assignments. Be careful if you
have multiple frames with different variable assignments for the same dataset.

• Derivatives at the boundary of two zones may differ since Tecplot Focus operates on only one zone
at a time while generating derivatives.

Auxiliary Data

You may use auxiliary data containing numerical constants in equations. The syntax for using
auxiliary data in equations is:

AUXZONE[nnz]:Name
AUXDATASET:Name
AUXFRAME:Name
AUXVAR[nnv]:Name
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AUXLINEMAP[nnm]:Name

Where:

nnz = the zone number(s)
nnv = the variable number(s)
nnm = the line map number(s)
Name = name of the auxiliary data

For example, a dataset auxiliary data constant called Pref would be referenced using AUXDATASET:Pref.
Equations using this auxiliary data might appear as:

{P} = {P_NonDim} * AUXDataSet:Pref

Zone Number Specification

By following a variable reference with square brackets ([ and ]), you can specify a specific zone from
which to get the variable value.

The zone number must be a positive integer constant less than or equal to the number of zones. The
zone specified must have the same structure (I, IJ, or IJK-ordered or finite element) and dimensions
(IMax, number of nodes) as the zone(s) the equation(s) will be applied to.


If you do not specify a zone, the zone modified by the left-hand side of the equation is
used.

Zone specification works only on the right-hand side of the equation.

Index Specification

By following a variable reference with parentheses, you can specify indices for ordered data only.
Indices can be absolute or an offset from the current index.

Index offsets are specified by using the appropriate index i, j or k followed by a + or - and then an
integer constant. Any integer offsets may be used. If the offset moves beyond the end of the zone, the
boundary value is used. For example, V3(i+2) uses the value V3(IMAX) when I=IMax-1 and I=IMax. V3(I-
2) uses the value of V3(1) when I=1 or I=2.

Absolute indices are specified by using a positive integer constant only. For example, V3(2) references
V3 at index 2, regardless of the current i index.

If the indices are not specified, the current index values are used.
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Variable Sharing Between Zones

For zones with the same structure and index ranges, you can set a variable to be shared by specifying
that the variable for those zones have the values from one zone. For example, if zones 3 and 4 have the
same structure and you compute V3=V3[3] for zones 3 and 4, V3 will be shared.

 Subsequent alteration of the variables may result in loss of sharing.

Equation Restrictions

The zone and index restrictions specified in the Specify Equations dialog can be overridden on an
equation by equation basis. To specify restrictions for a single equation add the colon character (:) at
the end of the equation followed by one or more of the following:

Equation Restrictor Comments

<Z=<set>> Restrict the zones.

<I=start[,end[,skip]]> Restrict the I-range.

<J=start[,end[,skip]]> Restrict the J-range.

<K=start[,end[,skip]]> Restrict the K-range.

<D=datatype> Set the data type for the variable on the left hand side. This only
applies if a new variable is being created.

<V=valuelocation> Set the value location (NODAL or CELLCENTERED) for the variable
on the left hand side. Only applicable if a new variable is being
created.

For example, to add one to X in zones 1, 3, 4, and 5:

X=X+1:<Z=[1,3-5]>

The following example adds one to X for every other I-index. Note that zero represents the maximum
index.

X=X+1:<I=1,0,2>

The next example creates a new variable of type Byte:

{NewV}=X-Y:<D=Byte>
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Macros and Equations

Tecplot Focus allows you to put your equations in macros. A macro with just equations in it may be
referred to as an equation file, and in fact equation files saved using the Save Equations button are
macro files with an .eqn extension. An equation in a macro file is specified using the $!ALTERDATA macro
command. Equation files may also include comment lines and must start with the comment #!MC 1410,
like other macro files. If you are performing complex operations on your data, and/or the operations
are repeated frequently, equation files can be very helpful.

You can create equation files from scratch using an ASCII text editor, or you can create your equations
interactively by using the Specify Equations dialog and then save the resulting equations. The
standard file name extension for equation files is .eqn.

For example, you might define an equation to compute the magnitude of a 3D vector. In the Specify
Equations dialog, it would have the following form:

{Mag} = sqrt(U*U + V*V + W*W)

In a macro file, it would have the following form:

#!MC 1410
$!ALTERDATA
EQUATION = "{Mag} = sqrt(U*U + V*V + W*W)"

The interactive form of the equation must be enclosed in double quotes and supplied as a value to the
EQUATION parameter of the $!ALTERDATA macro command.

To read an equation file, select Load Equations on the Specify Equations dialog. In the Load
Equation File dialog, select an equation file that contains a set of equations to apply to the selected
zones of your data. The equations in the equation file will be added to the list of equations in the
dialog. All equations are applied to your data when you click Compute.

Equations in equation files may be calculated somewhat differently depending on whether the
computation is done from within the Specify Equations dialog or by running the equation file as a
macro. When loaded into the Specify Equations dialog, equations that do not contain zone or index
restrictions use the current zone and index restrictions shown in the dialog. When processed as a
macro file, the equations apply to all zones and data points. To include zone and index restrictions, you
must include them in the equation file as part of the $!ALTERDATA command.

Refer to the Scripting Guide for more information on working with the $!ALTERDATA command.

Equation Examples

In the following equation, V1 (the first variable defined in the data file) is replaced by two and a half
times the existing value of V1:
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V1 = 2.5*V1

The following equation sets the value of a variable called Density to 205. A new variable is created if a
variable called Density does not exist.

{Density} = 205

In the next equation, the values for Y (the variable assigned to the Y-axis) are replaced by the negative
of the square of the values of X (the variable assigned to the X-axis):

Y = -X**2

The following equation replaces the values of V3 with the values of V2 rounded off to the nearest
integer. A new variable is created if there are only two variables currently in the data set.

V3 = round(V2)

In the following equation, the values of the fourth variable in the data set are replaced by the log (base
10) of the values of the third variable.

V4 = ALOG10(V3)

Suppose that the third and fourth variables are the X and Y-components of velocity and that there are
currently a total of five variables. The following examples create a new variable (V6) that is the
magnitude of the components of velocity.

V6 = (V3*V3+V4*V4)**0.5

or

V6 = sqrt(V3**2+V4**2)

You can also accomplish the above operation with the following equation (assuming you have already
defined the vector components for the active frame):

{Mag} = sqrt(U*U + V*V)
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The following equation sets the value of a variable named diff to the truncated value of a variable
named depth subtracted from the existing value of depth:

{diff} = {depth} - trunc({depth})

In the next equation, C (the contour variable) is set to the absolute value of S (the scatter-sizing
variable), assuming both C and S are defined:

C = abs(S)

In the following example, a new variable is created (assuming that only seven variables initially
existed in the data file). The value for V8 (the new variable) is calculated from a function of the existing
variables:

V8 = SQRT((V1*V1+V2*V2+V3*V3)/(287.0*V4*V6))

The above operation could have been performed in two simpler steps as follows:

V8 = V1*V1+V2*V2+V3*V3
V8 = SQRT(V8/(287.0*V4*V6))

The following equation replaces any value of a variable called TIME that is below 5.0 with 5.0. In other
words, the values of TIME are replaced with the maximum of the current value of TIME and 5.0:

{TIME} = max({TIME},5)

The following equation creates variable V4 which has values of X at points where X<0; at other points, it
has a value of zero (this does not affect any values of X):

V4 = min(X,0)

Another example using intrinsic functions is shown below:

V8 = 55.0*SIN(V3*3.14/180.0) + ALOG(V4**3/(v1+1.0))

You can also reference the I, J, and K-indices in an equation. For example, if you wanted to cut out a
section of a zone using value blanking, you could create a new variable that is a function of the I and J-
indices (for IJ-ordered data). Then, by using value-blanking, you could remove certain cells where the
value of the value-blanking variable was less than or equal to the value blanking cut-off value.
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Here is an example for calculating a value-blanking variable that is zero in a block of cells from I=10 to
30, and is equal to one in the other cells:

V3 = min((max(I,30)-min(I,10)-20),1)

The following equation replaces all values of Y with the difference between the current value of Y and
the value of Y in zone 1. (If zone 1 is used for the data alteration, the new values of Y will be zero
throughout that zone.)

Y = Y - Y[1]

The following equation replaces the values of V3 (in an IJ-ordered zone) with the average of the values
of V3 at the four adjacent data points:

V3 = (V3(i+1,j)+V3(i-1,j)+V3(i,j+1)+V3(i,j-1))/4

The following equation sets the values of a variable called TEMP to the product of the values of a
variable called T measured in four places: in zone 1 at two index values before the current data point,
in the current zone at an absolute index of three, in zone 4 at the current data point, and in the current
zone at the current data point.

{TEMP} = {T}[1](i-2) * {T}(3) * {T}[4] * {T}

Indices may be combined with zone specifications. The zone is listed first, then the index offset. For
example:

V3 = V3 - V3[1](i+1)
Y = Y[1] - Y[2](1) + Y(1,j+3) + Y

Referencing variables by letter code:

V3 = I + J
V4 = cos(X) * cos(Y) * cos(Z)
{Dist} = sqrt(U*U + V*V + W*W)
{temp} = min(B,1)

Specifying the Zone number for a given variable:

V3 = V3 - V3[1]
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X = ( X[1] + X[2] + X[3] ) / 3
{TempAdj} = {Temp}[7] - {Adj}
V8 = V1[19] - 2*C[21] + {R/T}[18]

Data Smoothing

You can smooth the values of a variable of any zone (2D or 3D) or 1D line map (plotted in either XY or
Polar) to reduce "noise" and lessen discontinuities in data.

Smoothing can be used after inverse-distance interpolation to reduce the artificial peaks and plateaus
this type of interpolation can produce. Each pass of smoothing shifts the value of a variable at a data
point towards an average of the values at its neighboring data points.



Zones must be mesh-based to be smoothed. If your data consists of disconnected
points, see Inverse-Distance Interpoation and Irregular Data Point Triangulation for
possible approaches to converting it to a form suitable for use with the Tecplot Focus
smoothing feature.

To smooth data in Tecplot Focus, select Alter→Smooth from the Data menu.

The Smooth dialog has the following options:

Zone

Specify the zone to smooth from the Zone drop-down. The zone should not intersect itself.

For a given plot type, the dimension of the zone must be less than or equal to the dimension of the
plot type. That is, in 3D Cartesian plots, volume, surface and line zones may be smoothed, while in
2D Cartesian plots, volume zones cannot be smoothed.

Variable

Select the variable to smooth. For line plots, the variable must be a dependent variable for an active
mapping for that zone.
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Number of Passes

Specify the number of smoothing passes to perform. The default is 1. A greater number of passes
results in greater smoothing, but takes more time.

Coefficient

Specify the relaxation factor for each pass of smoothing. Enter a number between zero and one
(exclusively). Large numbers flatten peaks and noise quickly. Small numbers smooth less each pass,
rounding out peaks and valleys rather than eliminating them.

Boundary

Select the boundary conditions by which to smooth from the Boundary drop-down.

Fixed

The points at the boundary are not changed in value. For finite element data, only fixed
boundary conditions may be used.

First Order

The points at the boundary are smoothed based on the assumption that the first derivative
normal to the boundary is constant. This will tend to cause contour lines of the smoothed
variable to be perpendicular to the boundary.

Second Order

The points at the boundary are smoothed based on the assumption that the second derivative
normal to the boundary is constant. This option may overextrapolate derivatives at the
boundary.

Smooth

Click to perform smoothing. While the smoothing is underway, the progress is displayed in the
status bar. A Stop button displayed in the status bar allows you to interrupt the operation.

Smoothing Method

Tecplot Focus uses the Jacobi method with the Coefficient used as a relaxation factor (always < 1, so it’s
under-relaxed). For ordered zones, Tecplot Focus does this in generalized curvilinear coordinates,
which has the effect of length- (or area- or volume-) weighting a node’s neighboring values. For the
fixed boundary condition, boundary values remain unchanged. For first-order boundaries, the
boundary values are relaxed toward the neighboring interior values, and for second-order boundaries,
they are relaxed toward a constant slope (zero curvature) relative to the two neighboring interior
points. For finite-element zones, Tecplot Focus relaxes each value toward the inverse-distance
weighted average of its neighbors. Only the fixed boundary condition is available for FE zones.

Limitations of Smoothing

• Finite element zones cannot be smoothed with anything other than Fixed boundary conditions.

• Tecplot Focus uses the active frame’s axis assignments to determine the variables to use for the
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coordinates in the smoothing, and also to determine whether the smoothing should be done with
XY Line, Polar, and 2D or 3D Cartesian plot types. Be sure to select the correct frame if you have
multiple frames with different variable assignments for the same dataset.

• Any axis scaling is ignored while smoothing.

• For I-ordered or finite element line segment zones, the active frame can be in the XY Line, or 3D
Cartesian plot types. In XY Line, the variable must be the dependent variable of one active mapping
for that zone.

• For IJ-ordered, finite element triangle, or finite element quadrilateral zones, the active frame can
be a 2D or 3D Cartesian plot type, but you cannot smooth the variables assigned to the X and Y-axes
in Cartesian.

• For IJK-ordered, finite element tetrahedral, or finite element brick zones, the plot type must be 3D
Cartesian, and you cannot smooth the variables assigned to the X, Y, and Z-axes. The IJK-mode is
ignored. The zone is smoothed with respect to the entire 3D volume.

• Smoothing does not extend across zone boundaries. If you use a boundary condition option other
than Fixed (such that values along the zone boundary change), contour lines can be discontinuous
at the zone boundaries.

• Smoothing is performed on all nodes of a zone, and disregards value blanking.

Fourier Transform

The Fourier transform feature (Data→Fourier Transform) allows you to transform one-dimensional
ordered linear data into the frequency domain. One or more dependent variables in the data set are
taken to be a representation of some function of a single independent variable, such as time, and this
function is decomposed into its constituent sine waves. Variables are added to the data set to indicate
these waves' frequency in Hertz, phase, and amplitude in each selected zone, and an XY of the
resulting amplitudes is created in a new frame.

The dependent variables for a Fourier transform must be single-valued. The independent variable
domain need not be constantly spaced; data will be resampled linearly if necessary.

The resulting frequency, amplitude, and phase variables (three for each dependent variable) are stored
in Fourier transform result zones, one for each source zone. The result zones are given the name
"Fourier Transform" followed by text indicating the source zone, independent variable, and window
function used to calculate them. Result zones are assigned new time strands using the same groupings
as the source zones if they belong to time stands; otherwise the resulting zones are static.

The result variables in the result zone are given the names Frequency, Amplitude and Phase followed
by text indicating the dependent variable involved in the calculation. If the independent variable is
non-uniform, Frequency is a uniform interpolation of the original data.

Newly-created zones are assigned passive variables for all variables that previously existed in the
dataset, and all previously-existing zones are assigned passive variables for all new variables created
by the Fourier transform.
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Independent Variable

The variable used as the frequency domain. If this variable’s spacing is non-uniform, this variable is
used in conjunction with each dependent variable for interpolation to create a uniform frequency
for the Fourier transform.

Dependent Variables

Choose the dependent variables to be transformed. Each will appear on the resulting XY plot as its
own linemap.

Source Zones

Choose the zones for which the transform should be calculated.

Window Function

A function applied to the dependent variables before performing the transform (but after
interpolation) to taper the data. Rectangular, triangular, Hann, and Hamming filters are provided.

Plot Placement

Where to initially place the result plot of the transform showing the distribution of frequencies in
the data. The plot can be moved and resized as desired afterward.

In corner of source frame

A new frame is created for the frequency plot in the upper right corner of the frame containing
the data being transformed.
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Tile with existing frames

All frames, including the new one, are adjusted to the same size and arranged on the paper in a
grid.

Include Conjugates

For purely real numbers, fully half of the results of the Fourier transform are conjugates (values
with the same real part but opposite imaginary parts, which behave identically in situations where
a real number is required). Toggling-off this option will allow the transform to be performed
approximately twice as fast. as only one conjugate is calculated.

Obey Source Zone Blanking

If value blanking is active and this option is toggled-on, value blanking is applied to the values of
both independent and dependent variables before interpolation is performed. If data values
eliminated by blanking cause the data to be non-uniform, the values are interpolated appropriately.
All blanked data values up to the first non-blanked value, and all blanked data values after the last
non-blanked value, are ignored, providing a way to constrain the domain of the transform.

Replace Zones/Variables by Name

If either or both are toggled-on, the results of the transform are stored in existing result zones
and/or variables, based on their names, if such zones and/or variables exist. Otherwise, new result
zones and/or variables are created.

You may also access this feature by right-clicking a line map and choosing Fourier Transform from the
context menu. In this case, the line map you click defines the independent and dependent variable
used. All other settings are taken from last values entered in the dialog; the dialog does not appear.

Axial Rotation

The Axial Rotation dialog, available from the Alter submenu of the Data menu, allows you to rotate
one or more 2D or 3D zones using the right-hand rule. The variables rotated are the spatial variables
(X, Y, and, for 3D zones, Z) and the vector variables assigned using Plot → Vector → Variables. For 3D
zones, you may also choose the axis of rotation.
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The Axial Rotation dialog has the following options:

Rotation Angle

The angle by which the data should be rotated. May be specified in degrees or radians using the
drop-down menu to the right of the entry field.

Axis

For 3D zones, choose the axis around which rotation should occur. Not available for 2D zones,
which are always rotated about a notional axis perpendicular to the zone.

Origin

For rotation around a point other than (0, 0) or (0, 0, 0), enter the location of the origin using the X,
Y, and (for 3D zones) Z fields.

Zones to Rotate

Click, Control-click, and/or Shift-click in the zone list to select one or more zones.

Select by Time Strand For transient data, if this checkbox is toggled on, the zones in the Zones to
Rotate list are grouped by time strand, so that selecting a zone selects all the zones in that time strand.



Using a macro, it is possible to rotate around arbitrary axes rather than just X, Y, and
Z, and to specify exactly which variables, if any, should be rotated as spatial variables
and which as vector variables, including no spatial variables at all, or multiple vector
variables. See $!ROTATEDATA in the Scripting Guide.
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Zone Creation

The Create Zone submenu of the Data menu allows you to add data to your plot. The menu has the
following options:

• Rectangular Zone Creation

• Circular or Cylindrical Zone Creation

• Zone Duplication

• Mirror Zone Creation

Rectangular Zone Creation

Creating a rectangular zone is often the first step in interpolating irregular data into an ordered grid

Tecplot Focus allows you to create a new ordered rectangular zone with the dimensions in the I, J and
K-directions you specify. This is done either with the Create Rectangular Zone tool (only) or the
Create Rectangular Zone dialog. The zone that you create has the same number of variables as other
zones in the dataset.

To create a rectangular zone, select Create Zone→Rectangular from the Data menu.

The Create Rectangular Zone dialog has the following options:

Dimensions

Enter the number of data points in the I, J and K-directions.

• To create an I-ordered zone, enter 1 for both the J and K-dimensions.

• To create an IJ-ordered zone, enter 1 for the K-dimension. The z-axis variable will equal ZMin
throughout the created zone.

• To create an IJK-ordered zone, enter a K-dimension greater than one.
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Coordinates

Enter the start and end points of the physical coordinates (X,Y and Z).

Create

Select the [Create] button to create the zone.

Tecplot Focus uniformly distributes the data points in the I, J and K directions. Any variable not
assigned to an axis is set to zero.

By using the Specify Equations dialog under the Data→Alter menu, you can modify the X, Y, and Z-
coordinates, and the values of the other variables as well, by using equations or Equation files. See
Data Alteration through Equations.

Circular or Cylindrical Zone Creation

Tecplot Focus allows you to create a new ordered circular or cylindrical zone with the dimensions in
the I, J, and K-directions you specify. The I-dimension determines the number of points on each radius
of the zones. The J-dimension determines the number of points around the circumference. The K-
dimension determines the number of layers in the zone, creating a cylinder.

You create a circular or cylindrical zone with the Create Circular Zone dialog (accessed via
Data→Create Zone, or with the Create Circular Zone tool (only). The zone that you create has the
same number of variables as other zones in the dataset.

If you have no current dataset, Tecplot Focus creates one with two or three variables, depending on the
K-dimension. If you specify K=1, the dataset is created as IJ-ordered, and has two variables. If you
specify K > 1, the dataset is created as IJK-ordered, and has three variables.

To create a circular zone select Create Zone→Circular from the Data menu.
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The Create Circular Zone dialog has the following options:

Dimensions

Enter the dimensions of your circular zone:

Radial (I)

Specify the number of points the radial direction (I)

Circumferential (J)

Specify the number of points in the circumferential direction (J)

Top to Bottom (K)

Specify the number of points for the height of the cylinder (K). Set K equal to one to create a
circular zone.

Coordinates

Radius

Enter the length of the radius.

X-Origin and Y-Origin

Enter the coordinates for the zone center

ZMin and ZMax

Enter the minimum and maximum Z-coordinates. For a circular zone (where K=1), the Z variable
is set to ZMin for all points.
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Create

Select the Create button to create the zone.

For IJ-ordered, Tecplot Focus creates a zone in which I-circles are connected by J-radial lines. For 3D
(K→1), Tecplot Focus creates a K-layered cylindrical zone having I-circles connected by J-radial planes.
All other variables are set to zero These two scenarios are shown below

Using the Alter option from the Data menu, you can modify the X-, Y-, and Z-coordinates, and the
values of the other variables as well, by using equations or equation files. See Data Alteration through
Equations.

Zone Duplication

To create a full duplicate of one or more existing zones, select Create Zone→Duplicate from the Data
menu. In the Create Duplicate Zone dialog, select the source zone(s). Each duplicate zone has the
same name as its source zone.


After a zone is duplicated, all variables in the newly created zone(s) will be shared
with their corresponding source zone(s).

Mirror Zone Creation

To create a duplicate zone that is the mirror image of an existing zone, select Create Zone→Mirror
from the Data menu.

 You can only create mirrored zones along one of the standard axes (2D) or the plane
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determined by any two axes (3D).

The Create Mirror Zone dialog has the following options:

Source Zone(s)

Select the Sources Zone(s).

Mirror Axis

Specify the axis () or axis plane (3D) to mirror about.

Create

Select the [Create] button to create the zone.

Each mirror zone has a name of the form "Mirror of zone sourcezone", where sourcezone is the
number of the zone from which the mirrored zone was created.


The variables in the newly created zone(s) are shared with their corresponding source
zone(s), except for the coordinate and velocity normal to the symmetry plane.

Axial Duplication

The Axial Duplication dialog, available from the Create Zone submenu of the Data menu, allows you
to create sucessively-rotated duplicates of one or more 2D or 3D zones using the right-hand rule. For
example, if your data set contains a simulation of one blade of a turbine, and there are thirty blades in
the full turbine, you can create 29 duplicates, each rotated twelve degrees from the previous, to be able
to visualize the entire turbine.

The variables rotated are the spatial variables (X, Y, and, for 3D zones, Z) and the vector variables
assigned using Plot → Vector → Variables. For 3D zones, you may also choose the axis of rotation.
Streamtraces are not duplicated; place streamtraces after zone duplication.
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The Axial Duplication dialog has the following options:

Define Angle Between Instances

Contains two interdependent fields, Angle and Segments, which are used to specify how many
duplicates are in a full 360° rotation of the zone.

The number of segments is determined by dividing the angle into 360,° and the angle is calculated
by dividing the number of segments into 360°. Editing one automatically updates the other. You may
choose to specify (or calculate) the angle in ethier degrees or radians.

Offset Angle

The additional amount by which the first duplicate should be rotated; may be specified in degrees
or radians. For example, if you specify an angle between instances of 20° and an offset of 40°, the
first duplicate will be made at 60°, the second at 80°, the third at 100°, and so on.

This field may be used, for instance, when you have already created some duplicates and want to
create additional duplicates that do not overlap the ones you have already created. In the example
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just given of angle 20° and offset 40°, perhaps you have already created two duplicates (at 20'° and
40°) and wish to create additional duplicates. In this case, offset of 40° specifies that the last existing
duplicate is at 40° and that new duplicates should be created in the next "slot" beyond that, at 60°.

Full or Partial Duplication

Choose to create as many new zones as are necessary for a full rotation by choosing Full 360° (this
will result in the number of duplicates entered or calculated in the Define Angle Between
Instances, less the original zone(s) being duplicated) or create a specified number of rotated
duplicates.

Axis

For 3D zones, choose the axis around which rotation should occur. Not available for 2D zones,
which are always rotated about a notional axis perpendicular to the zone.

Origin

For rotation around a point other than (0, 0) or (0, 0, 0), enter the location of the origin using the X,
Y, and (for 3D zones) Z fields.

Zones to Duplicate

Click, Control-click, and/or Shift-click in the zone list to select one or more zones.

Select by Time Strand

For transient data, if this checkbox is toggled on, the zones in the Zones to Duplicate list are grouped
by time strand, so that selecting a zone selects all the zones in that time strand

Add Zones to Existing Strands

For transient data, adds the duplicate zones to the same time strand as the original zones if toggled
on. Otherwise, the duplicate zones are assigned new strand IDs if the soruce zones belonged to
strands, otherwise they are made static.



Using a macro, it is possible to rotate around arbitrary axes rather than just X, Y, and
Z, and to specify exactly which variables, if any, should be rotated as spatial variables
and which as vector variables, including no spatial variables at all, or multiple vector
variables. See $!AXIALDUPLICATE in the Scripting Guide.

Data Extraction from an Existing Zone

You may create new zones by extracting (or interpolating) data from existing zones in a number of
ways. Derived objects, such as contour lines, FE-boundaries, iso-surfaces, slices, or streamtraces may
be extracted to be independent zones. You may also extract data using a specified slice plane, discrete
points, points from a polyline, or points from a geometry.

The procedures for extracting derived objects are discussed in the chapters related to those objects. For
details see Contour Layer, Streamtrace Extraction as Zones, and Iso-Surface Extraction. Extracting
slices, both derived and arbitrarily defined, is described in Extracting Slices to Zones.
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Subzone Extraction

To create a subzone of an existing ordered zone, select Extract→Subzone from the Data menu.

 Subzone extraction is available for ordered zones only.

The Extract Subzone dialog has the following options:

Source Zone

Select the source zone (ordered zones only).

Index Range from Source Zone

Specify the desired subzone as a range of I, J, and K-indices. You may use the special value 0 or Mx to
indicate the maximum of that index, and the values Mx-1 to represent one index less than the
maximum, Mx-2 for two less than the maximum, and so forth.

Extract

Select the Extract button to create the zone. Each extracted subzone is given the name "Subzone."

Data Point Extraction

You may create an I-ordered zone by extracting data points from the current dataset along a polyline
that lies within the edges of a zone with connectivity. To extract points along a polyline:

1. If necessary, create the polyline geometry using the  polyline tool. Click each of the points in the
polyline, then double-click the last point (or press Escape) to finish the polyline. You may also
extract points along an already-existing polyline.

2. Right-click the polyline geometry in the workspace and choose Extract Points from the context
menu to open the Extract Data Points dialog.
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3. Use the Extract Data Points dialog to control how data points are extracted. The dialog has the
following options:

Extract regular points along geometry

Select this option to extract the specified number of points distributed uniformly along the
geometry.

Number of points to extract

Enter the number of points to extract. This field is available only if you are extracting regular
points along a geometry.

Extract only points which define geometry

Select this option to extract only the endpoints of the segments in the geometry.



Any necessary interpolation is performed using the same method used in probing.
The spatial interpolation method is piecewise-linear by default. Cells are, in effect,
divided by adding nodes at their center and face centers, until all cell pieces are
tetrahedral. The extra nodes are calculated by arithmetically averaging the
variable values at all nodes (for the cell-center node) or all face nodes (for the face-
center nodes). Within each of these sub-cells, variables are interpolated linearly.

From triangular faces, linear interpolation is used to determine the value of the
extracted points. On quadrilateral faces, a point of the center of mass of the
quadrilateral is created and assigned a value equal to the average of the four
corners. The surface is then broken down into four triangles using this center
point and the four corners, and the extracted point value is interpolated linearly
on the face of the triangle that surrounds it.

If a surface utilizes cell-centered values, the nodal values at the corners are
interpolated, then the extracted points are interpolated from those nodal values.

Volume interpolation, piece-wise by default, calculates to first-order accuracy. For
second-order accuracy (tri-linear interpolation), add the following line to your
tecplot.cfg file:

$!INTERFACE DATA {VOLUMECELLINTEROPLATIONMODE = TRILINEAR}
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4. If you created a new polyline for the extraction operation, you may wish to delete it by again right-
clicking it, then choosing Delete from the context menu.

Zone Deletion

In any dataset with more than one zone, you can delete any unwanted zones. To delete a zone, select
Delete→Zone from the Data menu. You cannot delete all zones; if you attempt to delete all zones, the
lowest numbered zone is not deleted.

Variable Deletion

To delete a variable, select Delete→Variable from the Data menu. The Delete Variable dialog is
shown below.

When deleting a variable, keep in mind that deleting a variable removes it from all zones. You cannot
delete a variable used in a Calculate-on-demand function.

 Calculate-on-demand function feature only available in Tecplot 360.
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Data Interpolation

In Tecplot Focus, interpolation refers to assigning new values for the variables at data points in a zone
based on the data point values in another zone (or set of zones).

For example, you may have a set of data points in an I-ordered zone that are distributed randomly in
the XY-plane. This type of data is sometimes referred to as unordered, ungridded, or random data. In
Tecplot Focus, it is referred to as irregular data. Using data in this form, you can create mesh plots and
scatter plots, but you cannot create contour plots, light-source shading, or streamtraces.

In Tecplot Focus, you can interpolate the irregular I-ordered data onto an IJ-ordered mesh, and then
create contour plots and other types of field plots with the interpolated data. You can also interpolate
your 3D, I-ordered irregular data into an IJK-ordered zone and create 3D volume plots from the IJK-
ordered zone. You can even interpolate to a finite element zone.

The accuracy of the interpolation will depend on your data, the density of the destination grid, how
well the grid fits the area of your unorganized zone and the settings used for interpolation.

There are three types of interpolation available:

Linear Interpolation

Interpolate using linear interpolation from a set of finite element, IJ-ordered, or IJK-ordered zones
to one zone.

Inverse-Distance Interpoation

Interpolate using an inverse-distance weighting from a set of zones to one zone.

Kriging

Interpolate using Kriging from a set of zones to one zone.

Linear Interpolation

Use the Linear Interpolation dialog to interpolate data from one or more ordered or finite element
zones onto a destination zone. Irregular I-ordered data cannot be used for the source zones in linear
interpolation; you may be able to first create a finite element zone from an irregular, I-ordered zone by
using triangulation. (See Irregular Data Point Triangulation.)

Linear interpolation finds the values in the destination zone based on their location within the cells of
the source zones. The value is linearly interpolated to the destination data points using only the data
points at the vertices of the cell (or element) in the source zone(s).

To perform linear interpolation:

1. Read the dataset to be interpolated into Tecplot Focus (the source data).

2. Read in or create the zone onto which the data is to be interpolated (the destination zone).

3. From the Data menu, choose Interpolate→Linear.
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4. From the Linear Interpolation dialog, select the zones to be interpolated from those listed in the
Source Zone(s) scrolled list.

5. Select which variables are to be interpolated from those listed in the Variable(s) scrolled list.

6. Select the destination zone into which to interpolate. Existing values in the destination zone will be
overwritten.

7. Outside Points - Optionally, choose how to treat points that lie outside the source-zone data field.
You have two options:

◦ Do Not Change - Preserves the values of points outside the data field. Do Not Change is
appropriate in cases where you are using one interpolation algorithm inside the data field, and
another outside.

◦ Constant - Sets all points outside the data field to a constant value that you specify.

8. Click the [Interpolate] button to perform the interpolation.

9. While the interpolation is proceeding, a working dialog appears showing the progress of the
interpolation


If you select [Cancel] during the interpolation process, the interpolation is terminated
prematurely. The destination zone will be left in an indeterminate state, and you
should redo the interpolation.
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Inverse-Distance Interpoation

Inverse-distance interpolation averages the values at the data points from one set of zones (the source
zones) to the data points in another zone (the destination zone). The average is weighted by a function
of the distance between each source data point to the destination data point. The closer a source data
point is to the destination data point, the greater its value is weighted.

In many cases, the source zone is an irregular dataset—an I-ordered set of data points without any
mesh structure (a list of points). Inverse-distance interpolation may be used to create a 3D surface or a
3D volume field plots of irregular data. The destination zone can, for example, be a circular or
rectangular zone created within Tecplot Focus Zone Creation).

To perform inverse-distance interpolation in Tecplot Focus, use the following steps:

1. Read the dataset to be interpolated into Tecplot Focus (the source data).

2. Read in or create the zone onto which the data is to be interpolated (the destination zone).

3. From the Data menu, choose Interpolate→Inverse Distance.

4. From the Inverse-Distance Interpolation dialog, select the zones to be interpolated from those
listed in the Source Zone(s) list.

5. Select which variables are to be interpolated from those listed in the Variable(s) list.

6. Select the Destination Zone into which to interpolate. Existing values in the destination zone will
be overwritten.

7. [OPTIONAL] Enter the minimum distance used for the inverse-distance weighting in the Minimum
Distance text field. Source data points which are closer to a destination data point than this
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minimum distance are weighted as if they were at the minimum distance. This tends to reduce the
peaking and plateauing of the interpolated data near the source data points.

8. [OPTIONAL] Enter the exponent for the inverse-distance weighting in the Exponent text field.


The exponent should be set between 2 and 5. The algorithm is speed-optimized for
an exponent of 4, although in many cases, the interpolation looks better with an
exponent of 3.5.

9. [OPTIONAL] Select the method used for determining which source points to consider for each
destination point from the Point Selection drop-down. There are three available methods, as
follows:

Nearest N

For each point in the destination zone, consider only the closest n points to the destination point.
These n points can come from any of the source zones. This option may speed up processing if n
is significantly smaller than the entire number of source points.

Octant

Like Nearest N above, except the n points are selected by coordinate-system octants. The n
points are selected so they are distributed as evenly as possible throughout the eight octants.
This reduces the chances of using source points which are all on one side of the destination
point.

All

Consider all points in the source zone(s) for each point in the destination zone.

10. Click Interpolate to perform the interpolation.


If you select the Cancel button during the interpolation process, the interpolation is
terminated prematurely. The destination zone will be left in an indeterminate state,
and you should redo the interpolation.

Inverse-distance interpolation ignores the IJK-mode of IJK-ordered zones. All data points in both the
source and destination zones are used in the interpolation.


Tecplot Focus uses the active frame’s axis assignments to determine the variables to
use for coordinates in interpolation. However, axis scaling is ignored.

The Inverse-Distance Algorithm

The algorithm used for inverse-distance interpolation is simple. The value of a variable at a data point
in the destination zone is calculated as a function of the selected data points in the source zone (as
defined in the Point Selection drop-down, accessed via Data→Interpolate→Inverse-Distance).

The value at each source zone data point is weighted by the inverse of the distance between the source
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data point and the destination data point (raised to a power) as shown below:

where  and  are the values of the variables at the destination point and the source point,
respectively, and  is the weighting function defined as:

D in the equation above is the distance between the source point and the destination point or the
minimum distance specified in the dialog, whichever is greater. E is the exponent specified in the
Exponent text field.

Smoothing may improve the data created by inverse-distance interpolation. Smoothing adjusts the
values at data points toward the average of the values at neighboring data points, removing peaks,
plateaus, and noise from the data. See Data Smoothing for information on smoothing.


Kriging and Inverse Distance Interpolation Improvements

For better results with 3D data, try changing the range of your Z-variable to one
similar to the X-range the Y-range. Also, set Zero Value to 0.05.

Kriging

Kriging is a more complex form of interpolation than inverse-distance. It generally produces superior
results to the inverse-distance algorithm but requires more computer memory and time.

To perform kriging in Tecplot Focus, perform the following steps:

1. Read the dataset to be interpolated into Tecplot Focus (the source data).

2. Read in or create the zone onto which the data is to be interpolated (the destination zone).

3. From the Data menu, choose Interpolate→Kriging
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4. From the Kriging dialog, select the zones to be interpolated from those listed in the Source Zone(s)
scrolled list.


Tecplot Focus uses the active frame’s axis assignments to determine the variables
to use for coordinates in kriging. However, any axis scaling is ignored.

5. Select which variables are to be interpolated from those listed in the Variable(s) scrolled list.

6. Select the destination zone into which to interpolate. Existing values in the destination zone will be
overwritten.

7. In the Range text field, optionally enter the distance beyond which source points become
insignificant for the kriging. The value is stated as the fraction of the length of the diagonal of the
box which contains the data points. A range of zero means that any point not coincident with the
destination point is statistically insignificant; a range of one means that every point in the dataset is
statistically significant for each point. In general, values between 0.2 and 0.5 should be used.

8. In the Zero Value text field, optionally enter the semi-variance at each source data point on a
normalized scale from zero to one. Semi-variance is the certainty of the value at a data point. A
value of zero means that the values at the source points are exact. Greater values mean the values
at the source points have some uncertainty or noise. Zero is usually a good number for the zero
value, and it causes the interpolated data to fit closely to all the source data points. Increasing the
zero value results in smoother interpolated values that fit increasingly more to the average of the
source data.

9. Select the overall trend for the data in the Drift drop-down. This can be Linear (default), None, or
Quadratic.
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If the Drift is set to Linear or Quadratic, Tecplot Focus requires that the points
selected be non-collinear (non-coplanar in 3D). To avoid this limitation, set Drift to
None. Alternatively, you can eliminate coincident points by Irregular Data Point
Triangulation before you interpolate.

10. Select the method used for determining which source points to consider for each destination point
from the Point Selection drop-down. There are three available methods, as follows:

Nearest N

For each point in the destination zone, consider only the closest n points to the destination point.
These n points can come from any of the source zones.

Octant (default)

Like Nearest N above, except the n points are selected by coordinate-system octants. The n
points are selected so they are distributed as evenly as possible throughout the eight octants.
This reduces the chances of using source points which are all on one side of the destination
point.

All

Consider all points in the source zone(s) for each point in the destination zone. In general, you
should not use the All option unless you have very few source points



The Point Selection option is very important for kriging, because kriging involves
the computationally expensive inversion and multiplication of matrices. The
computational time and memory requirements increase rapidly as the number of
selected source data points increases.

11. Click Interpolate to begin kriging. While kriging is proceeding, a progress bar appears in the status
bar, along with a Stop button that can be clicked to interrupt the operation.


If you interrupt the kriging process, the destination zone is left in an indeterminate
state, and you should redo the kriging or delete the destination zone.

The Kriging Algorithm

For a detailed discussion of the kriging algorithm refer to: Davis, J. C., Statistics and Data Analysis in
Geology, Second Edition, John Wiley & Sons, New York, 1973, 1986.


Kriging and Inverse Distance Interpolation Improvements#: For better results with 3D
data, try changing the range of your Z-variable to one similar to the X-range the Y-
range. Also, set Zero Value to 0.05.
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Irregular Data Point Triangulation

Triangulation is a process that connects data points to form triangles. You can use triangulation to
convert irregular I-ordered datasets into a finite element surface zone. Triangulation is one of the two
options for creating field plots from irregular data. The other is interpolation, discussed in Data
Interpolation. Triangulation preserves the accuracy of the data by creating a finite element surface
zone with the source data points as nodes and a set of triangle elements. Triangulation works best for
irregular data.

To triangulate 2D data, make sure your plot is in 2D Cartesian mode and select 2D Triangulation from
the Data menu. The 2D Triangulation dialog has the following options:

Source Zone(s)

Select the zone or zones to triangulate from the list.

Use Boundary Zone(s)

Toggle-on to specify a boundary zone for the triangulation. Select the boundary zone or zones from
the list. The boundary zones define the boundaries in the triangulation region. If you do not include
boundary zones, Tecplot Focus assumes the data points lie within a convex polygon and that all
points in the interior can be connected.

Include Boundary Points

Toggle-on to include the points in the boundary zones in the triangulated zone.

Triangle Keep Factor

This factor is used to define which triangles on the outside of the triangulated zone are "bad" and
not included in the triangulation.
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At the completion of triangulation, Tecplot Focus attempts to remove bad triangles from the outside
of the triangulation. The keep factor is a description of the shape of the triangle between zero (three
collinear points) and 1.0 (an equilateral triangle). Typical settings are values between 0.1 and 0.3;
settings above 0.5 are not permitted. Bad triangles will not be removed if removing the triangle
strands a data point.

Triangulate

Click the Triangulate button to perform the triangulation.

After triangulating your data, you can use the resulting finite element surface zone to create plots.
Generally, you turn off the original zone(s) and plot the new zone only, but you can, for example, plot a
scatter plot of the original zone(s) along with the contours of the new zone.

Data Spreadsheet

All ordered and finite element data can be viewed using Tecplot Focus’s data spreadsheet (accessed via
Data→Spreadsheet). The data may be modified within the spreadsheet in order to change the plots
Tecplot Focus produces.



Changes to the spreadsheet do not immediately alter the original data file stored on
disk. However, saving the plot of altered data as a layout file will save the changes in
the data journal. You have the option of overwriting your original data file or creating
a new file with the altered data.

The spreadsheet displays Tecplot Focus’s data differently depending on the type of zone being
examined. An example of the Data Spreadsheet dialog for a finite element zone is shown here; note
the X, Y, and Z variables.
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I-ordered and finite element datasets are displayed with each zone’s variable displayed in a column. IJ-
ordered datasets are displayed in the spreadsheet with I along the rows and J along the columns. IJK-
ordered datasets are displayed one plane at a time: selecting the K-plane displays I along the rows and
J along the columns, selecting the J-plane displays I along the rows and K along the columns, and
selecting the I-plane displays J along the rows and K along the columns. With IJK-ordered data, the slice
of interest can be selected by entering a specific index or using the up and down arrows provided.

If a variable is not needed in your plot, it may not currently be loaded into memory. In this case, "Not
Loaded" is displayed in every cell of that variable’s column. Using the variable in your plot will cause it
to be loaded. Click the Load Variables button to open the Load Variable dialog and load any variables
you wish to view and edit in the spreadsheet.

To change the data spreadsheet’s display format, select the desired format (Integer, Float, Exponent, or
Best Float) from the Format drop-down menu. When Float or Exponent is selected, you may also
specify the precision in the Precision field. These options do not affect the actual data, only how it is
displayed.

To modify data:

1. In the Data Spreadsheet dialog, select a zone and variable to modify. Use the menu at the top of
the dialog to choose the zone, then find the column representing the desired variable.

2. If the variable is shared with another zone or zones, the Alter in all Shared Zones toggle is
enabled. Select this toggle to keep the variable shared as you modify data, propagating changes to
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the other zones that share the variable. If this toggle is not selected, the variable will be changed in
the selected zone and no longer shared with any other zones. See also Data Sharing.

3. Select the value of interest from the spreadsheet by finding its row. This will highlight and expand
the value to its full precision.

4. To replace the highlighted value, simply enter the new value. The value is instantly replaced with
the new digits entered.

5. To modify only a few digits from a highlighted value, double-click the cell to switch to edit mode.
Click again or use the arrow keys to position the edit cursor at the desired position. Make any
desired modifications to the existing value such as inserting or deleting digits.

6. To undo a modification of a given cell before you have committed it, press Escape. To commit a
modification, press Enter, Tab, or Shift-Tab to move to the next cell, or simply select on another cell.

Probing Plots
The Probe tool  allows you to select a location in your plot and view the values of all variables at
that location in the Probe sidebar. You can also view information about the dataset itself while
probing. With the Probe At dialog (accessed via Data→Probe At), you can specify the location of the
probe as a set of spatial coordinates X, Y, and Z, one of the polar coordinates Theta and R, or as a set of
I, J, and K-indices. You select one or more locations in the data field where information is to be
collected, and the resulting information is displayed in the Probe sidebar.

When you probe with the mouse, you can probe in either of two modes: Interpolate or Nearest Point.
In Interpolate mode (accessed by a single mouse click) the value returned is the linearly interpolated
value for the specified locations. In Nearest Point mode, accessed by Control-click, the value returned is
the exact value at the closest data point in the field.


If Tecplot Focus appears to be unloading variables that you are trying to Probe, you
may need to adjust your memory threshold in Options→Performance→Misc. Refer
to Load On Demand for additional information (360 Only).

Field Plot Probing with the Mouse

The most direct method of probing is to use the Probe tool . Click at any point in your plot to probe
in Interpolate mode, which displays the Probe sidebar with information interpolated for that point.
Control-click at any location to probe in Nearest Point mode, which will obtain probe information for
the data point closest to the crosshair cursor and display it in the Probe sidebar.

The following table shows the information returned for each type of probe action for field plots. (All
mouse click operations are using the left mouse button.)
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Probe Action Information Returned

Click If the pointer is over a valid cell, the value returned is the interpolated field
values from all nodes in the cell.

2D Cartesian plots - If multiple cells are candidates, the cell from the
highest-numbered zone is used.

3D Cartesian plots - The closest cell in a zone, slice, iso-surface or
streamtrace is selected. If multiple cells are candidates, the cell closest to
the viewer is used, with priority given to surfaces drawn with mesh, flooded
contours, or shading. Translucent zone surfaces are excluded from probing
priority.

Control-Click If the pointer is over a valid cell, the field value from the nearest node in
the cell is returned. If multiple cells are candidates:

• 2D Cartesian plots - The cell from the highest number zone is used

• 3D Cartesian plots - The cell closest to the viewer is used. If the pointer is
not over any cell, then the field values from nearest data point (as
measured in distance on the screen) are returned.

Shift-Control-Click Return the field values from the nearest point on the screen (ignoring
surfaces, zone number or depth of the point).

This is useful in 3D for probing on data points that are on the back side of a
closed surface without having to rotate the object.

In 2D this is useful for probing on data points for zones that may be
underneath other zones because of the order in which they were drawn.

Alt-Click

(3D only)

Same as Click except ignore zones while probing. (Probe only on
streamtraces, iso-surfaces, or slices.)

Alt-Control-Click Same as Control-Click except ignore zones while probing. (Probe only on
streamtraces, iso-surfaces, or slices.)

Alt-Control-Shift-Click Same as Shift-Control-Click except ignore zones while probing. (Probe only
on streamtraces, iso-surfaces, or slices.)

The probe results are displayed in the Probe sidebar. To copy data from the Probe sidebar, select the
range of cells to be copied by dragging (or by clicking a start position, then Shift-clicking an end
position), then right-click and choose Copy from the context menu.
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Interpolate mode does not work for I-ordered data displayed in a 2D or 3D Cartesian
plot; if you probe such data you will always get the error message "Point is outside of
data field," because Tecplot Focus cannot interpolate without a field mesh structure.
You should instead use the Nearest Point mode in such situations.

Field Plot Probing by Specifying Coordinates and Indices

Use the Probe At dialog for precise control over your probe location, probing using I, J, and K-indices,
or probing inside a 3D volume. You can launch the Probe At dialog from the Data menu.

Probe at Position

To probe at a specified location using spatial coordinates (in Interpolate mode), launch the Probe At
dialog via the Data menu or the Probe sidebar.
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The Position page of the Probe At dialog has the following options:

Enter Coordinates

Enter the X, Y, and Z-coordinates of the desired probe location.

Probe Within Volume [DEFAULT]

If the zone you are probing is a 3D volume zone, toggle-on Probe Within Volume to ensure that the
probe is performed at the indicated point. If you specify a position within a 3D volume zone and the
Probe Within Volume is not selected, Tecplot Focus probes at the surface of the zone nearest to the
user.

Probe

Select the [Probe] button to perform the probe. The Probe sidebar will display the interpolated
values for the specified location.


If the entered location is not within a cell, Tecplot Focus will return the closest surface
to the entered location along the line-of-sight ray.

Probe at Index

To probe at a specified location using dataset indices (in Nearest Point mode), launch the Probe At
dialog (accessed via the Data menu or the Probe sidebar) and select the Index page (shown below).
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The Index page of the Probe At dialog has the following options:

Mapping/Zone

Select the desired zone or mapping from the drop-down.

I, J, K

Enter the I, J, and K-indices of the desired probe location. (For finite element and I-ordered data, you
can enter only the I-index. For IJ-ordered data, you can enter both I- and J-indices. For IJK-ordered
data, you can enter I, J, and K-indices.)

Probe

Select the [Probe] button to perform the probe. The Probe sidebar will display interpolated values
for the specified location.

Probe Sidebar

You can view probed data in the Probe sidebar, which appears automatically when probe results need
to be displayed. It can also be opened from the Data menu.

The Probe sidebar initially appears docked on the right side of the workspace, but it can be docked to
the left side as well, or combined with other sidebars. It may also be "torn off" from the workspace and
dragged anywhere on any of your displays.

You can choose what the Probe sidebar displays via the tabs along its side. (The tabs may appear on
either the right or left side of the sidebar depending on where it is docked.) Available tabs are:

Variable Values

Examine values of all variables at any selected location.

Cell Center Values

Examine values of all variables at the center of the clicked-on cell.
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Zone and Cell Information

Report characteristics of any location in a data field. The characteristics reported include the indices
of the selected cell or point, the zone number, the dimensions of the zone, and the type of zone
(ordered or finite element).

Face Neighbor

Examine neighboring cells of the clicked-on cell.

The display formatting of variable values can be selected in the Variable Values or Cell Center Values
tabs. Select Integer, Float, Exponent, or Best Float from the Format drop-down menu. Floating-point
precision can be specified in the Precision field when either the Float or Exponent format is selected.
These options do not affect the actual data, only how it is displayed.

To copy data from the Probe sidebar, select the range of cells to be copied by dragging (or by clicking a
start position, then Shift-clicking an end position), then right-click and choose Copy from the context
menu.

Variable Values

Choosing the Variable Values tab in the Probe sidebar lists every variable in the current dataset,
together with its value at the specified probe point. The zone name and number and the current
solution time (if the data set contains transient data) also appear.
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The Probe At button opens the Probe At dialog (see Field Plot Probing by Specifying Coordinates and
Indices). Click the Load Variables button to open the Load Variable dialog and load any variables you
wish to view when probing.

Cell Center Values
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Choosing the Cell Center tab in the Probe sidebar lists the value of every variable in the current
dataset at the center of the cell that was selected. The Zone name and number and the current solution
time (if the data set contains transient data) are also displayed.

The Probe At button opens the Probe At dialog (see Field Plot Probing by Specifying Coordinates and
Indices). Click the Load Variables button to open the Load Variable dialog and load any variables you
wish to view when probing.

Zone and Cell Information

Choosing the Zone/Cell Info tab in the Probe sidebar lists the following information about any probed
data point, regardless of the format of the data.
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The following information appears:

• The number and name of the probed zone.

• The format of the zone, either ordered or one of the finite element formats (FE-Triangle, FE-Quad,
FE-Tetra or FE-Brick).

• The Current Solution time of the probed point.

For ordered zones, the following additional information is displayed:

• I-Max - Maximum I-index of the zone.

• J-Max - Maximum J-index of the zone.(J-Max is one for I-ordered data.)

• K-Max - Maximum K-index of the zone. (K-Max is one for IJ-ordered data).

• Plane - Shows the type of plane. I, J, or K displays the index of the point at the principal data point
of the cell containing the probed point. (If the point is probed using Control-click for Nearest Point,
the label reads "I,J or K-Index.")

• Face Plane - The I, J, or K-plane that is probed.
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• Face Indices - The planes that are not mentioned in Face Plane, these are the other faces that are
showing in 3D, or are the axes in 2D.



*[This feature is only available in Tecplot 360]*

Index values are not displayed for subzone data sets (.szplt) since these values
cannot currently be reliably determined with this file format.

For cell-based finite element zones (FE-Triangle, FE-Quad, FE-Tetra or FE-Brick), the following
additional information is displayed:

• Total Pts - Total number of points in the zone.

• Total Elems - Total number of elements (cells) in the zone.

• Node Num - Number of the probed node. This field is filled in only if the point is probed using
Control-click for Nearest Point.

• Elem Num - Number of the probed element.

• Node 1 - 8 - Number of the node defining Node 1-8 of the cell.

• Node 4 - FE-Quad, FE-Tetra, and FE-Brick only.

• Node 5-8 - FE-Brick only.

The Probe At button opens the Probe At dialog (see Field Plot Probing by Specifying Coordinates and
Indices).

Face Neighbor

Choosing the Face Neighbor tab in the Probe sidebar displays cells that neighbor the selected cell.
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The Probe At button opens the Probe At dialog (see Field Plot Probing by Specifying Coordinates and
Indices).

A cell is considered a neighbor if one of its faces shares all nodes in common with the selected cell, or if
it is identified as a neighbor by face neighbor data in the dataset. The current solution time is also
displayed.

For ordered (IJ or IJK) zones, cell numbers are defined by the index value of the first node

where, i, j, and k are the i, j, and k values for the location of the first node.

Because the number of nodes in each direction is one greater than the number of cells in that
direction, there is no cell to correspond with the last point in each row. In the example below, there is
no cell numbered "3", yet the first cell in the second row is numbered "4". As you define face neighbors,
it may help you to think of a "ghost cell" at the end of each row (where I = MaxI) and at the end of each
column in 3D (where J = MaxJ).

389



For FE zones, the cells are numbered in the order that they appear in the connectivity list. In the
following example "7 8 19 11" is the cell number 2:

Example connectivity list of 3 cells:
2 4 8 19
7 8 19 11
1 2 4 5

Line Plot Probing with the Mouse

You may probe XY and Polar Line plots in much the same way you probe field plots. You can use the
probe mouse mode to obtain interpolated variable values at any given location, or obtain exact values
from a specified (X, Y) or (Theta, R) data point. When you probe an XY Line plot in the standard mode,
Tecplot Focus displays a vertical or horizontal line, depending on whether you are probing along an X-
or a Y-axis. When you probe a Polar Line plot, a radial line or a circle is displayed depending on
whether you are probing along the Theta- or R-axis. In either case, the probe is performed along the
displayed line (or circle).

To probe in interpolate mode: activate the probe tool and click anywhere on your plot. Axis variable
values of all active mappings that lie along the probe line are interpolated and displayed in the Probe
sidebar.

To probe in Nearest Point mode, activate the probe tool and Control-click anywhere on your plot.
When you Control-click, Tecplot Focus displays the exact X and Y, or Theta and R-values of the data
point closest to the location clicked.
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Line Plot Probing in Interpolate Mode

Interpolate mode is the standard probe mouse mode in line plots just as for field plots. For XY Line
plots, you can probe along any of Tecplot Focus’s five X-axes, or along any of Tecplot Focus’s five Y-
axes. By default, probing is performed along the X1 axis. For Polar Line, probing is done along the
Theta-axis by default.



In Polar Line plots, many combinations of Theta- and R-values can result in the same
point on the screen. When using the mouse in Interpolate mode to probe along the
Theta-axis, Tecplot Focus uses the Theta-value within the current Theta-axis range to
determine the corresponding R-values reported in the Probe sidebar. This behavior
may result in no probe information shown for a mapping that has Theta-values
entirely outside the current Theta-axis range, even though the mapping crosses the
probe line on the screen. (For example, probing along the Theta-axis in interpolate
mode misses a mapping representing only Theta-values several cycles outside the
current Theta-axis range.) Similarly, when using the mouse in Interpolate mode to
probe along the R-axis, Tecplot Focus uses the R-value within the current R-axis range
and may miss mappings that are shown on the plot but have R-values different from
the R-axis range.

To enter the Probe Interpolate mode, choose Probe At from the Data menu. the Probe At dialogs for
XY and Polar Line plots are shown below:

Select the button corresponding to the axis you want to probe along, then enter the position. Click
Probe to perform the probe.

The Probe sidebar appears if it is not already visible, For interpolated values, the Probe sidebar lists
every active mapping and the interpolated value the opposing axis variable for that mapping. The
value along the probed axis is listed at the bottom of the Probe sidebar.

In the Probe sidebar, the probe value is dashed (---) if the probe is out of range for the mapping. The
probe value is gray (inactive) if the mapping is not using the specific axis which you are probing (for
example, you probe the X1 axis and the mapping uses the X2 axis). This will only happen in XY Line
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plots with multiple X or Y-axes.

By default, each mapping is shown on a single line, which allows display of about the first ten
characters of the mapping name and seven significant digits of the variable value.

X-Value, Y-value

X, Y-value of the nearest data point to the probe position.

I, J, of K-Index

I, J or K-index of the nearest data point to the probe position.

Map

Number and name of the nearest map to the probe position.

Zone

Number and name of the nearest zone to the probe position.

I, J, or K-Max

Maximum I, J or K-index of the current zone.

X or Y-Axis

X or Y-axis associated with the current map.



*[This feature is only available in Tecplot 360]*

Index values are not displayed for subzone data sets (.szplt) since these values
cannot currently be reliably determined with this file format.

Line Plot Probing in Nearest Point Mode

Nearest Point probe mode provides the exact X and Y or Theta and R-values of the data point closest
on the screen to the probed location, together with information on the mapping and the zone to which
the probed point belongs. If a data point is common to multiple mappings, the probe returns
information on the highest numbered mapping. For example, if a data point is plotted as part of two
mappings, numbered 1 and 2, the probe results are displayed for mapping 2.

To enter the Probe Nearest Point mode select the Probe tool,  from the Toolbar and Control-click
at the desired probe location. The nearest point is calculated from the actual location of the cross-hair
and is independent of the axis you were probing along.

The following information about the nearest data point is displayed in the Probe sidebar:

• X or Theta-value.

• Y or R-value.

• I, J, or K-index.
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• The number and name of the mapping associated with the data point.

• The number and name of the zone referenced in the mapping.

• The maximum I, J, and K-indices of the zone.

• For XY Line plots, the X-axis and Y-axis associated with the mapping.

Data Editing

Using the Adjustor tool, you can actually modify the coordinates of your data with the mouse. See
Adjustor Tool for more information.


If you attempt to double-click, but move the mouse between clicks, you may find that
you have moved your data point.
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Part 5: Final Output

Output
Tecplot Focus provides a variety of formats for you to output and export your complete plots. This
chapter discusses saving your settings using layout files or stylesheets, preparing plots for web
publishing, and writing data files to a file.

For information on exporting or printing your completed plot(s), please refer to: Exporting Plots or
Printing, respectively.

Layout Files, Layout Package Files, Stylesheets

Tecplot Focus has three different types of files for storing plot information:

Stylesheets (.sty)

Stylesheets store information about a single frame and do not include any information about the
data used by the frame.

Layout Files (.lay)

Layout files store information about all the frames in the workspace, including identification of, and
links to, the data used by each frame.

Layout Package Files (.lpk)

Layout package files are an extension to layout files where data and an optional preview image are
included.

Layout and layout package files are the preferred method for saving the style of your plot. They save a
complete picture of the workspace and are quick-and-easy to load and save. Stylesheets contain the
style of a single frame in Tecplot Focus.

Creating Layouts and Stylesheets for Tecplot Focus

If you are working with stylesheets or layouts in Tecplot 360 that you wish to share with Tecplot Focus
users, please be aware that the following features are not available in Tecplot Focus:

• Any aspect of the CFD Analyzer (i.e. options available from the Analyze menu in Tecplot 360)
including integration

• Data files loaded using a loader not available in Tecplot Focus

• Data files that contain polygonal or polyhedral zones or more than 5 million data points.

• Versions of Tecplot Focus prior to Tecplot Focus 2016 R1 do not support more than one slice group
or more than one contour group. This limitation does not apply to newer versions.

If any of the above items are included in your stylesheet or layout file, it will not load in Tecplot Focus.
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However, stylesheets and layouts created by Tecplot Focus will load in either product.

Working with Layout Files from Previous Releases

If you are working with layout files from previous releases of Tecplot 360, Tecplot Focus, or their
precursor called simply Tecplot, please note the following:

• 2016 and later releases of Tecplot Focus can load a maximum of 5 million data points.

Exporting Backward Compatible Data Files

While Tecplot Focus layouts and layout package files are not backward compatible, you do have the
option to export data files written in one version of Tecplot Focus to be read by an earlier version. To
do this, use the Write Data Options dialog as described in Data File Writing.

Stylesheets

Stylesheets are useful when:

• Pre-processing must be done to a dataset prior to attaching a style. You may need to load a
dataset and run some equations or do interpolation or zone extraction before assigning a style.
The style may reference objects or variables that do not exist in the original data and it is
necessary to assign the style after they are created.


Tecplot Focus’s data journaling capabilities together with layout files eliminate this
situation in many cases.

• Switching styles on large datasets. You may want to load a large dataset and generate two full
page plots. Each plot has a different style. By using a stylesheet for the second plot you avoid
having to reload the dataset.

• Copying the style of one frame to another frame in the same layout.

• Saving just part of a frame’s style, such as just the contour levels.

A stylesheet includes the following attributes (see Figure 59):

• Type of plot (a 2D contour plot in 2D or an XY Line plot)

• Colors used

• Current view of the data

• Axes display

• Text and geometry
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Figure 59. Some of the items considered part of the frame style.

 To learn how to use a stylesheet, see Save Frame Style and Load Frame Style.

Layout Files

A plot often consists of multiple frames or even multiple datasets. Layout files allow you to capture all
the information on the plot. Layout files include instructions on how to create the data used in the plot,
the frame layout and dataset attachments, axis and plot attributes, the current color map, and so forth.

Figure 60 shows a layout with four frames. The frame in the upper left-hand corner is attached to
dataset 1. The two frames on the right are both attached to dataset 2. The frame in the lower left is not
attached to a dataset.
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Figure 60. Layout of four frames using two datasets.

If a frame defined in a layout file requires an attached dataset, the data files necessary to build the
dataset are referenced in the layout file. These data files can be referenced using absolute paths or
relative paths. When using relative paths on Windows operating systems, the data files must be on the
same drive as the layout file.

A layout file may also contain the data journal; a set of macro commands which alter the data or create
new data. The data journal commands replicate the data modifications made to the original data (in
files) during prior Tecplot Focus sessions. Not all data operations are supported by the data journal. For
more information, see Data Journaling.

In addition to storing the individual style of each frame, layout files record:

• Page layout information (including the size and orientation of the paper).

• Color spectrum information, including the color maps in use.

To include the field data with a layout, use a layout package file. For more information, see Layout
Package Files.

Layout Package Files

Layout package files allow you to transmit raw data, along with style information in a single file. With
layout package files the view can be changed, different plot types tested, and so forth.

Layout package files have the same properties as standard layout files. (See Layout Files). Layout
package files also contain all data associated with frames in the layout, and an optional preview image
of the Tecplot Focus workspace. An extension of .lpk is used.
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Working with Layout and Layout Package Files

New Layout

File→New Layout creates a new layout in your workspace after removing any existing frames and
resetting the paper setup to the default configuration. Anything not saved before this action will be
lost.

Layout Saving

Save layout files using the Save Layout (Control-S) or Save Layout As (Control-W) options under the
File menu.

The Save Layout dialog has the following options:

Save As Type

Choose "Linked Data" (*.lay) or "Packaged Data" (*.lpk)

Use Relative Path (Linked Layout Only)

By default, Tecplot Focus saves the name of the data files used in the layout with their relative file
paths. To save your layout using absolute file paths, toggle-off Use Relative Path.

Include Preview Image (Layout Package Files Only)

Toggle-on Include Preview Image to include a preview image with the file.

After saving the layout file, you will be asked how to handle any dataset changes. See Dataset Changed
for more information.
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Dataset Changed

In Tecplot Focus, layout files contain references to the data files in use. The datasets are not copied
directly into the layout file. Therefore, if you make changes to the dataset using Tecplot Focus and wish
to save the layout, Tecplot Focus will ask you whether you want to create new data files reflecting the
changes made. If you answer in the affirmative, Tecplot Focus prompts you for a file name under
which to save the changed data. (If your layout has multiple datasets, Tecplot Focus prompts you for a
file name for each modified dataset.) The new data is then referenced in the layout instead of the
original.

Layout File Opening

Open layout files using the Open Layout (Control-O) option from the File menu. You can also access
this function by choosing File→Load Data and selecting Tecplot Layout Loader from the file type
menu.

Data Override

When opening a layout you are given the opportunity to override the data source instructions for the
layout file. This allows you to apply a given layout to different data. The data overriding capability is
supported for Tecplot’s native loaders as well as any loaders which contain both the macro command
keyword STANDARDSYNTAX and keywords beginning with FILELIST_ or FILENAME_. See Using a Loader for a
complete list of loaders and their macro command keywords.

To use layout override, toggle-on the Data override checkbox within the Load Data dialog, then open
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your desired linked layout (.lay) file. This will open the Override Layout Data dialog.

On the left panel, you will see the datasets contained in the selected layout file. When selecting a
dataset, you will see the linked files pertaining to that dataset on the right panel. To change the data
files associated with a given dataset, highlight the dataset on the left panel and select Replace Data…
where you can choose new data to supply. New data must be of the same type as the original dataset.

Data File Writing

You can write out the dataset in the active frame in various Tecplot file formats, including backward-
compatible binary formats. You must choose which zones and variables of the data to write, as well as
the format for the saved file (if applicable).

To write the dataset in the active frame to a file, choose Write Data from the File menu. The Write
Data dialog appears to let you name the file and to choose its format from the following:

• Tecplot Binary Data Writer (current) - Use the current Tecplot binary file format, the best choice for
small to moderately-sized data sets. Files are saved with the filename extension .plt.

• Tecplot Binary Data Writer (older) - Several previous versions of the Tecplot binary format are
supported if you need to exchange data with users of older version of Tecplot products.

• Tecplot ASCII Data Writer - Uses the Tecplot ASCII data format. You will generally not want to use
this loader except in very limited circumstances, as it is much slower to load than binary format
and does not support load-on-demand. Files are saved with the filename extension .dat.
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• Tecplot Subzone Data Writer - Write data in the Tecplot Subzone (.szplt) format. This format is
intended for large data files; it loads the least amount of data needed for each operation, and loads
data only when needed, improving interactive performance. Files are saved with the filename
extension .szplt.

 The Tecplot Subzone Data Writer is a feature only available in Tecplot 360.

When writing data in Tecplot binary or ASCII format, the Write Data Options dialog appears with the
following options:

Details to Save

Specify which record types you want to include in the data file by selecting the appropriate
checkboxes. By default, all record types present in the active frame’s dataset are selected. These
details include:

Text, Geometries, Custom Labels

Choose extra items to include in the datafile.

401



Field Data

Select this detail to save zone data.

Data Linkage (If Possible)

Save the variable and connectivity sharing between zones existing in the dataset, reducing its
size and loading time.

Generated Face Neighbor Information

Automatically save the face neighbor information generated by Tecplot Focus for finite element
zones. This increases the dataset size and loading time, but improves performance after loading.

Zone/Geometry Format

For ASCII, choose to write the file in POINT format or BLOCK format (BLOCK is required if any variables
are cell-centered).

Zone(s)/Variable(s)

Select the zones and variables to include.

Associate Layout with Newly Saved Data File

If activated, Tecplot Focus replaces internal references to loaded data with a reference to the new
file. When you later save a layout, this layout file will refer to the new file, not to the original data
file.

Printing
Printing your plot is the process of sending the plot image to an output device, print spooler, or a file.
Typically the output device is a printer, but it may be a plotter, film recorder, file or typesetter. If you
are creating files for use in another program, you should use Tecplot Focus’s Export option (accessed
via the File menu) to create your files—Export includes all the supported print file types, as well as
several standard graphics formats. See Exporting Plots for complete details.

Plot Printing

To print a plot, select "Print" from the File menu.
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Tecplot Focus supports the standard printer drivers for the supported operating systems.

The Print dialog has the following options:

Format

Indicates the printer chosen to print the plot. You can choose a different printer in the Print Setup
dialog.

Print Setup

Calls up the Print Setup Dialog in which you can choose a printer and other printing settings.

Color

Select this check box for color output; deselect the check box for monochrome output.

Render Type

Vector

Select this option to create print output using the drawing commands of the printer. The printer
renders the plot, yielding higher resolution, but some plot options are not available.


Vector graphics formats do not support: Translucency, Contour flooding with
Gouraud shading, Contour flooding using the continuous color distribution
method

Image

Select this option to create print output using an image. Rendering is done by Tecplot Focus at
the specified resolution, usually less than the printer’s resolution. However, all plot options are
available.


To preserve quality of color in your plot (translucency, contour flooding with
Gouraud shading, or continuous contour flooding), select the Image render type. 
To preserve the quality of text in your plot, select the Vector render type.
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Force Extra Sorting for all 3D Frames

This option is available when the Vector option has been selected and overrides the setting in the
Advanced 3D Control dialog. If this check box is not selected, Tecplot Focus will choose sorting
algorithms based on the advanced 3D options that were chosen for each frame. When printing 3D
plots in a vector graphics format, Tecplot Focus must sort the objects so that it can draw those
farthest from the screen first and those closest to the screen last. By default, Tecplot Focus uses a
quick sorting algorithm. This is not always accurate and does not detect problems such as
intersecting objects. If Extra Sorting is selected, Tecplot Focus uses a slower, more accurate
approach that detects and resolves such problems.

Resolution (dpi)

Available when the Image option is selected. Enter the resolution in terms of dpi in the text field.
Larger resolutions may result in an out-of-memory condition, or produce very large files. Lower
resolutions may yield less-attractive output images.

 Control-P is the shortcut command for the Print dialog.

Setup

You can set various parameters relating to the paper, including paper size and orientation, using the
Paper Setup dialog or the Print Setup dialog. A change to your paper settings in either the Paper
Setup dialog or the Print Setup dialog will automatically update the other.

Printing Setup for Windows

Print Setup Dialog

On Windows platforms, use the Print Setup dialog to set up your paper. The Print Setup dialog is
accessed via the Print dialog (accessed via the File menu) and has the following options:
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Figure 61. Print Setup Dialog

Printer

Choose the printer and set its properties.

Paper

Specify the paper size and source tray using the following drop-downs:

Size

Select the paper size. The choices are printer-dependent.

Source

Choose a paper tray from the drop-down.

Orientation

Specify one of the following options:

Portrait

The horizontal axis of the plot is aligned with the short side of the paper.

Landscape

The vertical axis of the plot is aligned with the short side of the paper.

By default, Tecplot Focus uses the standard Windows print drivers. You can choose to use Tecplot’s
print drivers by adding the following line to your tecplot.cfg file:
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$!INTERFACE USETECPLOTPRINTDRIVERS=YES

If you use Tecplot’s print drivers, you will use the Print Setup dialog for subsequent printing.

Paper Setup Dialog

To adjust the paper size, orientation, and background color for your plots, select the Paper Setup
option from the File menu. The current settings for these options are reflected in the representation of
the paper in the workspace. (To view the paper, select the "Show Paper on Screen" check box in either
the Paper Setup dialog or the Ruler/Grid dialog (accessed via the Options menu). This check box is
selected by default.)

The Paper Setup dialog, in contrast with the Print Setup dialog on Windows platforms, offers you
only six paper sizes. These may not be compatible with the paper sizes your printer supports. You
cannot select from multiple paper trays with the Paper Setup dialog. You may set screen display
options and fill colors with the Paper Setup dialog.

The following options are available in the Paper Setup dialog:

Size

Choose the size of the paper from the following six selections:

• Letter (8.5 x 11 inches).

• Double (11 x 17 inches).

• A4 (21x 29.7 cm).

• A3 (29.7 x 42 cm).

• Custom 1 (8.5 x 14 inches).
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• Custom 2 (8 x 10 inches).

On Windows systems, paper size Custom 2 is overwritten with the size selected in Print Setup if that
size does not exist in Tecplot Focus.

You can customize all six paper sizes in the configuration file, as well as their hard-clip limits. The
hard-clip limits are the lines on the edges of the paper that show where your printer cannot print. You
can set the hard-clip limits to larger values for use as guides in placing your plots on the paper.

Orientation

Choose the paper orientation. You have two options: Portrait and Landscape. In Portrait orientation,
the long axis of the paper is aligned with the vertical axis of the plot. In Landscape orientation, the
long axis of the paper is aligned with the horizontal axis of the plot.

Paper Fill Color

Select a color to use for the paper background. This color is used to display the paper in the
workspace. You can select the check box Use Paper Fill Color when Printing to have Tecplot Focus
print this background color on the hard-copy as well.

Printing Setup for Linux

The Print Setup dialog on Linux operating systems includes a field for entering a spool command,
along with startup and mopup strings. Contact your system administrator if you have any questions
about how to set up these commands.

Spool Command

Printers on Linux systems are accessed via print spoolers that manage the print queue. Typically
you use either the lp or lpr commands to send files to the print spooler. There may be command-
line options that need to be set on your system, as well, such as a flag to specify a particular printer.

In the Spooler Cmd text field, enter the appropriate spool command for your system, using the @
symbol to represent a file name.

For example, suppose you routinely use the following spool command to print a file named
myfile.ps: "lpr -m -r myfile.ps". The appropriate spooler command to enter in the Spooler Cmd
field is then "lpr -m -r @".

 When printing to a spooler, Tecplot Focus creates temporary files with names of
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the form tp??????, where the ?'s are randomly generated characters. Tecplot Focus
does not delete these temporary files automatically; commands to do so should be
included in your spool command. In our example, the -r flag says to remove the
file when done.

Startup and Mopup Strings

A startup string is an initialization string that sets up your output device to accept the plot created
by Tecplot Focus. A mopup string is a reset signal that tells your output device that the special
output has ended. For most devices no startup or mopup strings are needed.

Enter the appropriate startup string or mopup string in the appropriate text field. Special characters
are generated by using Macro Codes (such as "%E" for the escape character and "^nnn" for any ASCII
character with a decimal ordinal value of nnn). Check your printer documentation for the
appropriate strings.

Extra Precision

For PostScript output, you can control the numerical precision used in your print files. Print files
contain numbers that define sizes and positions of pieces of the plot on the output paper. These
numbers are defined as integers between zero and about 8,000. Usually, this provides sufficient
resolution for most output devices. Occasionally, you may need more resolution. For example,
printing to a high-resolution output device like a Linotronic typesetter may require more precision;
making print output with very small cells or elements may also require more precision.

To increase the precision of the output, increase the value in the Extra Precision field of the Print
Setup dialog. You specify one Extra Precision value for all formats that supports precision control.
The precision is defined as the number of digits to the right of the decimal. Normally, precision is
zero. The disadvantage of setting precision high is that the print files increase in size. The higher the
Extra Precision setting, the larger your print files, but the more accurate the plot.The maximum
setting for the precision is eight.

Exporting Plots
The Export dialog, accessible from the File menu, can be used to create files for export to other
applications. Tecplot Focus can export files in variations of three types: vector graphics, image, and
movie file formats.

Tecplot Focus exports the following vector formats:

EPS Export

Vector or image graphics in a special type of PostScript file designed for inclusion in other
applications.

PostScript (PS) Export

Vector or image graphics suitable for direct printing, but usually unsuitable for import into other
applications. It is recommended that you use the Encapsulated PostScript (EPS) format for
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importing into other applications.

WMF Export

Vector graphics to import into various Windows applications.

Tecplot Focus exports the following image formats:

BMP Export

Image in Windows Bitmap format.

JPEG Export

JPEG files are very small for their resolution and quite common on the internet, but they do involve
some loss of image quality that may affect certain plot images.

PNG Export

Also common on the internet, PNG images have a high image quality but larger file size than JPEG.

TIFF Export

Image in Tagged Image File Format.

Tecplot Focus can also export animations to various movie file formats. For more information on
exporting animations, see Animation. Tecplot Focus can also export animations to sequenced image
files. See Sequenced Image Files for more information.

Certain image formats support anti-aliasing, a feature that smooths jagged edges on text, lines and
edges. This feature is discussed at the end of this chapter. See Antialiasing Images.

Tecplot Focus can also export images directly to the clipboard instead of to a file. See Clipboard
Exporting to Other Applications for more information.

Performance Tips

If exporting is taking an unusually long time, or you get an error message saying that the image cannot
be exported, the most likely cause is that the image width you are trying to export is too large. Selecting
a smaller image width should speed up the export process.

For an image export size of Length x Width, the file size for an uncompressed true color image is
approximately Length x Width x 3. Memory requirements to export such an image can be up to twice
this size.

For 256 color images, the maximum file size is approximately Length x Width, but is usually less since
all 256 color image files are compressed. However, the memory requirements for exporting are the
same as they are for a true color uncompressed image.

Anti-aliasing can dramatically increase the memory and time requirements of image export, since a
large image is rendered first and then downsized to the final image dimensions. Furthermore, some
graphics card drivers may not report an error if they cannot allocate enough memory for this
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operation, instead producing a black image or other rendering issues. See Antialiasing Images.

Layout Packages

As an alternative to exporting image and vector representations of plots, Tecplot Focus supports the
Packaged Data layout format, or layout packages. A layout package (exported from Tecplot Focus as an
.lpk file rather than as a .lay file) contains the data needed for the layout, and only that data. You can
reload the resulting file into Tecplot Focus for viewing and rotation. The plot will appear visually
identical to the original plot, although you cannot manipulate the variables and other plot elements as
in the source plot.

By streamlining the elements included in the exported file, the Packaged Data export reduces the size
of the resulting LPK to an average of 25% of the original file size (although the reduction varies greatly
depending on what the original layout includes).

To export your current (3D Cartesian) plot with the Tecplot Viewer export format, choose Save Layout
As from the File menu. In the dialog that appears, select Packaged Data as the format, and click OK.

To reduce the file size, the lightweight file includes only the following.

• Data for only the current surfaces and lines drawn for the current plot

• Derived elements (such as slices and iso-surfaces) as zones

• The variables necessary to draw each zone (For example, if an iso-surface displays a contour flood,
only the spatial variables and the contour variable data will be output to the file for that iso-
surface’s zone)

• Text, geometries, custom labels, and all visible data elements displayed on your plot

The following restrictions apply.

• Only the active frame of a 3D Cartesian plot may be exported

• Only the current time step of a transient data set may be exported

• The plot must include at least one zone, slice, streamtrace, or iso-surface

• Several plot features will not be reflected in the exported plot:

• Finite element volume zones with the Contour or Shade layer enabled and a "Surfaces to Plot"
setting other than "None" or "Boundary Faces" will not display.

• Volume zones with the Scatter layer enabled and a "Points to Plot" setting other than "Nodes on
Surface" or "Cell Centers Near Surfaces" will not display.

• Finite element volume zones with the Scatter layer enabled and a point index I-Skip other than one
(1) may render scatter symbols in different locations.

• IJK blanking of ordered zones will not display.

• Streamtrace arrowheads may render at different locations and with different sizes.
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Saving the Exported File

When saving an exported file, the Select Exported File dialog appears. Navigate to the directory where
you want to save the file and name it as desired, then click Save. The standard filename extension for
the type of file being exported is automatically added to the name entered when appropriate.

Vector Graphics Format

Vector export files have device-independent resolution and thus can be easily resized, but they have
the same limitations as vector print output. Table 6 provides a summary of the advantages and
disadvantages of using vector graphics file formats.

Table 6. Advantages and Disadvantages of Vector Graphics format

Advantages Disadvantages

Resolution Independent (can be re-sized over and
over to any size)

Does not support translucency

Always journal quality (suitable for publication) Lines can appear different than on screen

Small file sizes for XY and 2-D output Very large 3D output files

Not Web-friendly

Can be manipulated in third-party programs, but
those programs are usually more expensive

Needs a PostScript printer for proper output

EPS Export

Encapsulated PostScript file (EPS) are PostScript files with additional commands that another program
can use to determine the size of your plot. After you import your EPS file into another program, you
can position it and usually resize it before printing.


If you try to send an EPS directly to a printer, it may not be positioned correctly on the
paper. Import the EPS to a word processor or page layout software to position it on
the page. Use the PostScript export format to create files to send directly to a printer.
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The Export dialog for EPS format has the following options:

Color

Mark the checkbox to output in color. Otherwise output will be in grayscale.

Region

Choose to export only the current frame, the smallest rectangle containing all frames, or the full
work area.

Render Type

If you choose Vector, the individual PostScript commands required to draw the image are saved. If
you choose Image, a bitmap image is embedded in the file.

Vector mode generally results in a smaller file, and such graphics remain smooth when enlarged,
but Image mode can accurately represent translucency or smooth color gradations, like other
bitmap formats. In most cases, however, a TIFF, BMP, or PNG is a better choice than an Image EPS,
as such files are more widely compatible.

When printing a vector EPS file to a non-PostScript printer, only a low-resolution preview image
may be printed, depending on the operating system and print drivers. On Windows platforms, you
must specify that the printer is a PostScript printer to print vector EPS files at their full quality. In
most cases, Image mode EPSs will be printed correctly on any printer.

If you choose the Image render mode, the following option is available:
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Resolution

Enter the resolution of the image in dots per inch. Larger values create more accurate plots, but
result in larger file sizes.

If you choose the Vector render mode, the following options are available:

Extra Precision

Specify the number of decimal places to specify the size and position parameters in the vector-
based EPS output. Larger values create more accurate plots, but result in larger file sizes.

Force Extra Sorting for All 3D Frames

Toggle on to use extra sorting in all 3D frames. Overrides the setting in the Advanced 3D Control
dialog. If selected, Tecplot Focus uses a slower, more accurate approach that detects and resolves
problems with how, for example, intersecting objects are rendered.

EPS Preview Image Settings

Tecplot Focus provides the following options for the preview image:

Type

The type of the preview image, or None.

None

No preview image information is included. If your application will not use such information,
this minimizes the file size. However, the graphic will appear blank in most applications; it
will appear correctly only when printed.

TIFF

Include a monochrome or grayscale TIFF preview image. This is the most common preview
image format. You may specify an image depth for the preview image in the Depth drop-
down.

EPSIV2

Include a monochrome (one bit per pixel) Encapsulated PostScript Version 2 preview image.
This is also a common preview image type in EPS files.

FrameMaker

Include a monochrome preview image compatible with older versions of Adobe®
FrameMaker®. This preview image type is rarely necessary, as newer versions of
FrameMaker support TIFF previews.

Depth

Specifies the number of shades of gray for the preview by how many bits of information is used
per pixel. The larger the number of bits per pixel, the larger the resulting file, but the larger the
number of shades available. Your options are:
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On/Off

One bit per pixel using an on/off strategy. All background pixels are made white (on), and all
foreground pixels, black (off). This setting creates smaller files and is good for images with
lots of background, such as line plots and contour lines.

1 Bit/Pixel

One bit per pixel using gray scale values of pixels to determine black or white. Those pixels
that are more than 50 percent gray are black; the rest are white. This setting creates small
files that might be useful for a rough draft or a preview image.

4 Bit/Pixel

Four bits per pixel resulting in sixteen levels of gray scale. This setting generates fairly small
image files with a fair number of gray levels. This setting works well for most preview image
purposes.

8 Bit/Pixel

Eight bits per pixel resulting in 256 levels of gray. This setting is useful for full image
representation, but the files generated by this setting can be large.

Width,Height

The size of the preview image.



When using a Render Type of Image, these preview image width, height, and depth
values are separate from the characteristics of the EPS image itself. The EPS image
size is determined by the Resolution setting and the depth is determined
automatically.

Performance Tips If exporting is taking an unusually long time, or you get an error message saying
that the image cannot be exported, the most likely cause is that the image width you are trying to
export is too large. Selecting a smaller image width will greatly speed up the export process.

For an image export size of Length x Width, the file size for an uncompressed true color image is
approximately Length x Width x 3. Memory requirements to export such an image can be up to twice
this size.

For 256 color images, the maximum file size is approximately Length x Width, but is usually less since
all 256 color image files are compressed. However, the memory requirements for exporting are the
same as they are for a true color uncompressed image.

PostScript (PS) Export

The Export dialog allows you to export plots in PostScript (PS). This format is usually used for printing
directly to a printer or print spooler. It is recommended that you use the Encapsulated PostScript (EPS)
format for importing into, for example, page layout or illustration applications. See EPS Export for
details.
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The Export dialog for the PostScript format has the following options:

Color

Mark the checkbox to output in color. Otherwise output will be in grayscale.

Region

Choose to export only the current frame, the smallest rectangle containing all frames, or the full
work area.

Render Type

If you choose Vector, the indivdual PostScript commands required to draw the image are saved. If
you choose Image, a bitmap image is embedded in the file.

Vector mode generally results in a smaller file, and such graphics remain smooth when enlarged,
but Image mode can accurately represent translucency or smooth color gradations, like other
bitmap formats. If you choose the Image render mode, the following option is available:

Resolution

Enter the resolution of the image in dots per inch. Larger values create more accurate plots, but
result in larger file sizes.

If you choose the Vector render mode, the following options are available:

Extra Precision

Specify the number of decimal places to specify the size and position parameters in the vector-
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based EPS output. Larger values create more accurate plots, but result in larger file sizes.

Force Extra Sorting for All 3D Frames

Toggle on to use extra sorting in all 3D frames. Overrides the setting in the Advanced 3D Control
dialog. If selected, Tecplot Focus uses a slower, more accurate approach that detects and resolves
problems with how, for example, intersecting objects are rendered.

WMF Export

WMF (Windows Metafile) is a Microsoft vector graphics format widely accepted by Windows
applications. Since WMFs are vector graphics, they can be easily resized by the importing application
without the introduction of visual artifacts, but they cannot accurately represent plots with
translucency or smooth color gradations.

Selecting WMF from the Export Format drop-down displays WMF options:

Color

Mark the checkbox to output in color. Otherwise output will be in grayscale.

Region

Choose to export only the current frame, the smallest rectangle containing all frames, or the full
work area.

Force Extra Sorting for All 3D Frames

Toggle-on to use extra sorting in all 3D frames. Overrides the setting in the Advanced 3D Control
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dialog. If selected, Tecplot Focus uses a slower, more accurate approach that detects and resolves
problems with how, for example, intersecting objects are rendered.

Image Format

Image output has the advantage of accurately representing translucency and smooth color gradations,
but with the disadvantage of generally being larger than vector output, particularly when a high image
resolution is specified, as may be necessary for printing. Image files are sometimes called raster or bit-
mapped. Table 7 provides a summary of the advantages and disadvantages of image file formats.

Table 7. Advantages and Disadvantages of Image file formats

Advantages Disadvantages

Looks like the screen image, or better Resolution-dependent (starts to lose quality if
enlarged too much)

Adjustable export size For professional-quality printing, images will be
very large

Supports translucency

Relatively small file size

Easily managed by presentation packages

Web friendly

Easily manipulated in inexpensive 3rd party
programs

Prints on any printer

Exporting Images with a Specific DPI

A characteristic of image files is a dots-per-inch setting (DPI), which interacts with the pixel dimensions
of the image to determine how large it will be printed. To customize the DPI of your exported image,
first set the width of the frame to the size of the image that you wish to export, using the Edit Active
Frame dialog (accessible by selecting "Edit Active Frame" from the Frame menu). Next, when actually
exporting the image, multiply the frame width (in inches) by the desired DPI, and enter that number in
the Enter Width field of the Export dialog.

For example, to export a 4 inch by 6 inch image at 300 DPI, set the frame dimensions to 4 inches by 6
inches, and then when exporting, enter a width of 1200 (4 times 300).

BMP Export

BMP (Bitmap) is an image format, and thus accurately represents plots with translucency and smooth
color gradations. Although it originated on Windows, it is widely accepted on other platforms by many
applications. However, it does not perform any compression, so file sizes are larger than more modern
formats such as JPG and PNG.
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BMP is always exported in color. The BMP export options are shown below.

Region

Choose to export only the current frame, the smallest rectangle containing all frames, or the full
work area.

Use Width of Image on Screen

Select this option to generate an image file the same size as the current plot on the screen.

Enter Width

Select this option to specify a width (in pixels) for the generated image. A larger width increases the
quality of your image. However, the greater the width you specify, the longer it will take to export
the image and the larger the exported file.

Antialiasing

Select this option to smooth jagged edges in the image. See Antialiasing Images for details.

Supersample Factor

Control the amount of antialiasing used in the image. See Antialiasing Images for details.

Convert to 256 Colors

Select this option to generate an image with only 256 colors (down from a possible 16 million
colors). Tecplot Focus selects the colors. This option can help reduce file size, but the results may be
suboptimal; using it with transparency, smooth color gradations, or antialiasing may result in poor
image quality.
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Performance Tips

If exporting is taking an unusually long time, or you get an error message saying that the image cannot
be exported, the most likely cause is that the image width you are trying to export is too large. Selecting
a smaller image width will greatly speed up the export process.

For an image export size of Length x Width, the file size for an uncompressed true color image is
approximately Length x Width x 3. Memory requirements to export such an image can be up to twice
this size.

For 256 color images, the maximum file size is approximately Length x Width, but is usually less since
all 256 color image files are compressed. However, the memory requirements for exporting are the
same as they are for a true color uncompressed image.

JPEG Export

JPEG (Joint Photographic Experts Group) is an image format, and thus accurately represent plots with
translucency and smooth color gradations. However, JPEG is a highly-compressed, "lossy" format,
meaning the exported file may not be identical to the plot. This can result in poor image quality for
some types of images. The advantage of JPEG is very small file sizes and near-universal acceptance on
the Internet.

JPEG supports different levels of compression, and Tecplot Focus allows you to control the image
quality (and thus, inversely, the file size).

JPEG images are always exported in color. When you select JPEG in the Export dialog, you have the
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following options:

Region

Choose to export only the current frame, the smallest rectangle containing all frames, or the full
work area.

Use Width of Image on Screen

Select this option to generate an image file the same size as the current plot on the screen.

Enter Width

Select this option to specify a width (in pixels) for the generated image. A larger width increases the
quality of your image. However, the greater the width you specify, the longer it will take to export
the image and the larger the exported file.

Antialiasing

Select this option to smooth jagged edges in the image. See Antialiasing Images for details.

Supersample Factor

Control the amount of antialiasing used in the image. See Antialiasing Images for details.

Encoding

Choose an encoding method for the JPEG file.

Standard

Encodes a JPEG one line at a time, starting at the top line. In most Web browsers, this means
nothing appears until the image has been completely loaded.

Progressive

Encodes the JPG in two passes, first at lower quality and then at higher quality. In a Web
browser, this means that a lower-quality version of the image appears quickly, then is replaced
with a larger version of the image when the file has been completely loaded.

Given the same Quality level,Standard encoded JPEG files generally look better than equivalent
Progressive encoded JPEG files. However, they have a larger file size.

Quality

Select the quality of JPEG image. Higher quality settings produce larger files and better looking
exported images. Lower quality settings produce smaller files. A quality setting of around 75 is
usually optimal; settings much below this may visibly degrade image appearance, while higher
settings usually do not provide much visible improvement but create larger files.

Performance Tips

If exporting is taking an unusually long time, or you get an error message saying that the image cannot
be exported, the most likely cause is that the image width you are trying to export is too large. Selecting
a smaller image width will greatly speed up the export process.
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For an image export size of Length x Width, the file size for an uncompressed true color image is
approximately Length x Width x 3. Memory requirements to export such an image can be up to twice
this size.

PNG Export

PNG (Portable Network Graphics) is an image format, and thus accurately represent plots with
translucency and smooth color gradations. Unlike JPEG images, PNGs can exactly represent a plot
without losing any nuance.

PNG images are always exported in color. When you select PNG in the Export dialog, you have the
following options:

Region

Choose to export only the current frame, the smallest rectangle containing all frames, or the full
work area.

Use Width of Image on Screen

Select this option to generate an image file the same size as the current plot on the screen.

Enter Width

Select this option to specify a width (in pixels) for the generated image. A larger width increases the
quality of your image. However, the greater the width you specify, the longer it will take to export
the image and the larger the exported file.
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Antialiasing

Select this option to smooth jagged edges in the image. See Antialiasing Images for details.

Supersample Factor

Control the amount of antialiasing used in the image. See Antialiasing Images for details.

Convert to 256 Colors

Select this option to generate an image with only 256 colors (down from a possible 16 million
colors). Tecplot Focus selects the colors. This option can help reduce file size, but the results may be
suboptimal; using it with transparency, smooth color gradations, or antialiasing may result in poor
image quality.

Performance Tips

If exporting is taking an unusually long time, or you get an error message saying that the image cannot
be exported, the most likely cause is that the image width you are trying to export is too large. Selecting
a smaller image width will greatly speed up the export process.

For an image export size of Length x Width, the file size for an uncompressed true color image is
approximately Length x Width x 3. Memory requirements to export such an image can be up to twice
this size.

For 256 color images, the maximum file size is approximately Length x Width, but is usually less since
all 256 color image files are compressed. However, the memory requirements for exporting are the
same as they are for a true color uncompressed image.

TIFF Export

TIFF (Tagged Image File Format) is an image format, and thus accurately represent plots with
translucency and smooth color gradations. Tecplot Focus generates both color and gray-scale TIFF
images.
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When you select TIFF in the Export dialog, you have the following options:

Color

Mark the checkbox to output in color. Otherwise output will be in grayscale.

Region

Choose to export only the current frame, the smallest rectangle containing all frames, or the full
work area.

Use Width of Image on Screen

Select this option to generate an image file the same size as the current plot on the screen.

Enter Width

Select this option to specify a width (in pixels) for the generated image. A larger width increases the
quality of your image. However, the greater the width you specify, the longer it will take to export
the image and the larger the exported file.

Antialiasing

Select this option to smooth jagged edges in the image. See Antialiasing Images for details.

Supersample Factor

Control the amount of antialiasing used in the image. See Antialiasing Images for details.

Convert to 256 Colors

Select this option to generate an image with only 256 colors (down from a possible 16 million
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colors). Tecplot Focus selects the colors. This option can help reduce file size, but the results may be
suboptimal; using it with transparency, smooth color gradations, or antialiasing may result in poor
image quality.

Grayscale Depth

For grayscale images, this specifies the number of shades of gray by how many bits of gray-scale
information is used per pixel. The larger the number of bits per pixel, the larger the resulting file.
Your options are:

On/Off

One bit per pixel using an on/off strategy. All background pixels are made white (on), and all
foreground pixels, black (off). This setting creates small files and is good for images with lots of
background, such as line plots and contour lines.

1 Bit/Pixel

One bit per pixel using gray scale values of pixels to determine black or white. Those pixels that are
more than 50 percent gray are black; the rest are white. This setting creates small files that might be
useful for a rough draft or a preview image.

4 Bit/Pixel

Four bits per pixel resulting in sixteen levels of gray scale. This setting generates fairly small image
files with a fair number of gray levels. This setting works well for most preview image purposes.

8 Bit/Pixel

Eight bits per pixel resulting in 256 levels of gray. This setting is useful for full image representation,
but the files generated by this setting can be large.

Antialiasing Images

Antialiasing smooths jagged edges on text, lines, and edges of image output formats by the process of

supersampling. A large intermediate image is rendered and then reduced to the final image size. Each
pixel on the final image is created from multiple rendered pixels. The width and height of the
intermediate image are the width and height of the final image times some scale factor. This scale
factor is called the Supersample Factor. You can use values from 2 to 16. Factors greater than 3 are
seldom necessary. Large scale factors take a lot more time and memory. Some graphics cards limit the
dimensions of rendered images to a maximum of 2048x2048 or 4096x4096 pixels, and thus Tecplot
Focus cannot antialias if the intermediate image would be larger than this limit. Some graphics drivers
do not report an error in such situations, instead producing blank or garbled images.

Antialiasing uses many colors. If you are exporting with the Convert to 256 Colors option activated,
antialiasing works for plots with a very limited selection of colors (like a red mesh on a black field).
Otherwise, antialiasing to 256 colors wastes time and may decrease plot quality.

Using animation formats can amplify the antialiasing and 256-color problem, as the same 256 colors
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must generally be used for colors in all frames of the animation. For these formats, try a test animation
of a few steps with antialiasing on before creating the entire animation.

Clipboard Exporting to Other Applications

In general, the Cut, Copy, and Paste commands on the Edit menu work only within Tecplot Focus.
However, it is possible to copy the plot in a frame to the clipboard as an image using the following
procedure:

1. With the  selector tool active, click the frame border to select the frame. Black dots appear at the
frame’s corners and at the midpoints of its edges.

2. From the Edit menu, choose Copy.

An image of the frame’s plot is now on your system clipboard and can be pasted into documents in
other applications. Note that the image captures the plot exactly as it appears on the screen, including
its size.

Text may be copied and pasted into other applications using a similar procedure. Select the text object,
choose Edit→Copy, then paste the text into the other application.
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Part 6: Scripting

Macros
Tecplot Focus provides two methods of scripting or automating your workflow: macros and batch
processing. This chapter focuses on the Tecplot Focus menu options for recording and playing back
macros. The Scripting Guide describes the Tecplot Focus macro language in detail.

Macros are very useful for performing repetitive operations such as setting up frames, reading in data
files and layout files, manipulating data, and creating plots. Macros can also be used to drive Tecplot
Focus batch jobs. For information on batch processing, see Batch Processing.

Macro Creation

Tecplot Focus’s Macro Recorder records a macro as you perform a sequence of actions interactively.
Macros can be recorded in either Tecplot (.mcr) or PyTecplot Python (.py) format. PyTecplot Python
scripts run outside of Tecplot Focus, and may be run from either the command line or any Python IDE.
See the PyTecplot Guide for more information.

After recording your macro, you can edit your macro file with a plain text editor to remove redundant
operations, compress repetitive actions into loops, replace references to files with variable names, and
otherwise modify the macro to make it more generic and flexible.

To record a macro with the Macro Recorder dialog, select "Record Macro" or "Record PyTecplot" from
the Scripting menu. Specify a macro file name in the Write Macro File (.mcr) or Write Script (.py)
dialog and click Save to initiate the recording. The Macro Recorder dialog remains open during the
recording session.



PyTecplot is a feature only available in Tecplot 360.

Auto Redraw is disabled during macro recording. If necessary, you can manually
redraw your plot by clicking the Redraw button in the Plot sidebar.

While recording macros, you can use any of the following buttons on the Macro Recorder dialog to
add specific macro commands to your macro:
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Insert "Pause"

Adds a "pause" command to the macro. When you play a macro including a pause command,
Tecplot Focus displays a message box when it reaches the pause command, and waits for you to
click OK before continuing to process the macro.

Insert "Graphics Off"

Adds a "graphics off" command to the macro. When you play a macro containing a "graphics off"
command, Tecplot Focus stops displaying graphics in the workspace from the "graphics off"
command until a "graphics on" command is encountered.

Insert "Graphics On"

Adds a "graphics on" command to the macro.

Insert Raw Command

Brings up a dialog in which you can enter any valid Tecplot macro command. For example, you can
add $!LOOP 10 at the start of a section you want to repeat 10 times, then $!ENDLOOP at the end. See the
Scripting Guide for information on the Tecplot Focus macro language.

Stop Recording

Select when you have completed the sequence of actions you want recorded.

The commands in a macro file typically rely on Tecplot Focus being in a particular state. It is a good
practice to use commands at the start of a macro that force Tecplot Focus into a known state. For
example, the $!NEWLAYOUT command deletes all data sets and frames and creates a single empty frame
with a default size and position.


Macros are more likely to be forward compatible (i.e. work with future releases of
Tecplot Focus) if the macro begins with a new layout or stylesheet. Refer to the
Scripting Guide for more information.
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Macro Functions

When editing a macro file in a text editor, you can add macro function definitions and macro function
calls. Macro functions have the following form:

$!MACROFUNCTION
NAME = functionname
.
.
.
$!ENDMACROFUNCTION

Between $!MACROFUNCTION and $!ENDMACROFUNCTION, you can include any legal macro command except
$!MACROFUNCTION.

For example, the following macro function turns on the Contour zone layer, turns off the Mesh zone
layer, sets the contour plot type to Both Lines and Flood for zones 1, 2 and 3, then chooses gray scale
color mapping:

$!MACROFUNCTION
  NAME = "graycontour"
  RETAIN = Yes
  $!FIELDLAYERS SHOWCONTOUR = YES
  $!FIELDLAYERS SHOWMESH = NO
  $!FIELDMAP [1-3] CONTOUR{CONTOURTYPE = BOTHLINESANDFLOOD}
  $!GLOBALCONTOUR 1 COLORMAPNAME = "Grayscale"
  $!REDRAW
$!ENDMACROFUNCTION

The RETAIN parameter tells Tecplot Focus to retain the macro function definition for use in subsequent
macro calls; this allows you to define a macro function once in some macro you load every time you
run Tecplot Focus, and continue to use it throughout your Tecplot Focus session.

Use the $!RUNMACROFUNCTION macro command to call your macro function. For example, to call the
"graycontour" macro function defined above, use the following macro command:

$!RUNMACROFUNCTION "graycontour"

You can use the $!RUNMACROFUNCTION command within other macro functions; calls may be nested up to
ten deep.

To access parameters from within a macro function use "|n|", where n is the parameter number (do
not include the double quotes). For example, the following function uses two parameters for the
assignments to SHOWCONTOUR and SHOWMESH:
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$!MACROFUNCTION
  NAME = "AssignContourAndMesh"
  $!FIELDLAYERS SHOWCONTOUR = |1|
  $!FIELDLAYERS SHOWMESH = |2|
$!ENDMACROFUNCTION
.
.
.
$!RUNMACROFUNCTION "AssignContourAndMesh" (YES,NO)

Linking to Geometries

Each geometry you create can be linked to a macro function. This macro function is called whenever
the user holds down the control key and clicks the right mouse button on the geometry. Macro
functions are specified with the Link to Macro function field in the Geometry dialog. Only one macro
function may be specified for each geometry.

The macro function must be defined in a macro file using the $!MACROFUNCTION instruction as described
in Macro Functions. The macro file containing the variable must then be executed so that the function
is loaded into memory and available for use in the current Tecplot Focus session.

A convenient way to handle this is to record a macro that opens the layout that contains the linked
objects and then edit this macro using a text editor to also include the necessary macro functions. You
can also simply include the macro functions in your tecplot.mcr file.

Macro Playback

Once you have created a macro file, you have four methods in Tecplot Focus for playing it back:

From the command line

You can play a macro when Tecplot Focus is launched by including the name of the macro file on
the command line, i.e.:

tecplot mymacro.mcr

If your macro file does not have the .mcr extension, run Tecplot Focus with the macro file by
including the -p flag on the command line, such as:

tecplot -p mymacro.mmm

From the Tecplot Focus interface

You can play a macro from within Tecplot Focus by using the "Play Macro/Script" option on the
Scripting menu.
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Using the Macro Debugger

Use the Macro Debugger (accessed via Scripting→View/Debug Macro) to open, inspect, step
through, and debug your macro file. See Macro Debugger for more information.

Using the Quick Macro Panel

The Quick Macro Panel (accessed via the Scripting menu) allows you to quickly play a macro
function by clicking on the button in the panel that is linked to that macro function. See Quick
Macro Panel for more information.



On Windows operating systems, you can also launch Tecplot Focus and run a
macro by dragging and dropping a macro file onto the Tecplot Focus icon.
However, in this case, the macro file must have the .mcr extension. Otherwise, the
file will be treated as an ASCII data file.

Quick Macro Panel

The Quick Macro Panel, accessible by selecting "Quick Macros" from the Scripting menu, is a sidebar
for playing your favorite or frequently-used macros. It initially appears docked to the right side of the
main Tecplot Focus window, but like the other sidebars, it can be dragged out of the workspace to
become a floating window, or docked with one or more other sidebars to suit your working habits. (See
Sidebars for more information on working with sidebars.)

This panel comes with a number of useful macro functions already defined. To run any of these
macros, select it in the list, then click the Play button, or simply double-click the macro name.

The Quick Macro Panel is linked to a special macro file that should contain only macro function
definitions ($!MACROFUNCTION instructions). The macro definitions having SHOWINMACROPANEL = TRUE
appear in the Quick Macro Panel. Other functions may defined in this file without this flag; these can
be called by the macro(s) displayed in the panel. You may also use the $!INCLUDEMACRO instruction to
include macro instructions from other files into the quick macro file.

For information on how to load a quick macro file, see Custom Files loaded on Startup.
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Macro Debugger

Use the Macro Debugger, accessed via Scripting→View/Debug Macro, to step through and debug a
macro file. This dialog allows you to add and delete breakpoints, view and set watch variables, and
view the call stack.

The Macro Debugger displays the text of the currently loaded macro file at the top of the dialog in the
Macro Source area. The black arrow  marks the line about to be executed; it moves to the next
command after the current command is executed. Below this is a second area (ExpandedView)
showing the complete command about to be executed, as many macro commands are lengthy and may
not be readable in their entirety in the Macro Source area.

The Macro Debugger has the following buttons in its toolbar:
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 Load a Macro file

Loads a macro file using the Open Macro dialog, in which you can specify which macro file to load.
Tecplot macro files typically have the extension .mcr. Once you have loaded a macro file, it stays
loaded in the Macro Debugger until you load a different one.

 Continue

Plays the macro without stopping after each step, until the macro finishes or the Macro Debugger
encounters a breakpoint.

Step buttons

These three related buttons help you step through your macro line by line, pausing after each
instruction has been processed. Checking the values of variables after each step is very helpful in
finding and fixing problems. These buttons have slightly different functions, described below.

 Step Into

Executes the current macro command. When a $!RUNMACROFUNCTION command is
encountered, the Macro Viewer steps into the called function, so it too can be executed line by
line.

 Step Over

Executes the current macro command. When a $!RUNMACROFUNCTION command is encountered, the
entire function is processed as a single operation, instead of allowing you to step through it line
by line.

This is useful for functions that you have already verified to be working correctly and/or do not
wish to step through, especially long ones.

 Step Out

Executes the rest of the current function at full speed, rather than line by line, until the end of
the function ($!ENDMACROFUNCTION) is encountered, then resumes single-stepping at the line after
the $!RUNMACROFUNCTION instruction that called the function.

This is useful when you have verified that a function is working correctly, and don’t need to
continue stepping through it (especially in functions with loops) or have accidentally stepped
into a function you don’t want to step through.

 Reset

Stops the running macro, if any, and resets the macro to start running at the beginning again.

If your macro relies on Tecplot Focus being in a particular state when it starts processing (that is, it
does not begin with loading or creating a layout), make sure Tecplot Focus is in this state before you
click Reset. Otherwise, the results of the macro may not be what you expect.


A convenient way to handle state with macro resets is to save a layout before
beginning debugging, then reload this layout if you need to reset.
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The Macro Debugger has the following three areas at the bottom of the dialog. Watch Variables and
Breakpoints share the same space; use the provided tabs to switch between them.

Watch Variables

Displays the values of selected macro variables as you step through the code, and allows you to add
and remove variables to be watched. See Watching Variables.

Breakpoints

Displays the breakpoints set in your macro and allows you to delete any or all of them easily. See
Using Breakpoints.

Call Stack

Displays all function calls currently executing. When one function calls another, which calls
another, and so on, this area displays the name of all these functions in the order they were called.
The name main represents the top-level script (instructions outside of any functions).

Watching Variables

The Watch Variable panel at the bottom of the Macro Debugger allow you to set variables to be
displayed while your macro runs. You can add a variable to be watched by choosing it from the pop-up
menu here. To stop a variable from being watched, click it in the list of watched variables, then click
the delete (trash) icon.

Using Breakpoints

A breakpoint is a point in your code where you wish to pause execution, usually just before some
macro instructions you are having trouble with. Using the Continue button, your macro runs at full
speed until it reaches a breakpoint. You can then inspect variables or the call stack and see the next
several lines to be executed, then step through the macro a line at a time using the appropriate Step
buttons in the toolbar to see how they behave.
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Breakpoints are shown as red discs to the left of each line of code in the Macro Source field. To set a
breakpoint at a particular line of your macro, click to the left of that line. A red disc appears next to
that line to indicate that execution will pause just before that line is executed. You can remove the
breakpoint by clicking again.

The Breakpoints area at the bottom of the Macro Debugger dialog display information about where
each breakpoint is set: the function it’s in ("main" if it’s outside a function), its line number, and the
macro command. You can delete breakpoints from this area by selecting them and clicking Delete
Selected Breakpoints. (This is the fastest way to delete all breakpoints.)

Batch Processing
You can run Tecplot Focus in batch mode to create plots without displaying any graphics to the screen.
This saves time when processing multiple files for printing or export. In batch mode, Tecplot Focus can
be executed locally on your workstation computer or remotely using a terminal (Linux only).

Batch Processing Setup

1. Create a macro file to control the batch processing. You may do this either by using
Scripting→Record Macro and recording a Tecplot Focus session, or by using any text editor. See
Macros.

2. Create layout and stylesheet files, as necessary.

3. Prepare data files.

4. Debug the macro file by running Tecplot Focus while not in batch mode.


Macros are more likely to be forward compatible (i.e. work with future releases) only
if the file is started with a layout or stylesheet. Refer to the Scripting Guide for more
information.

When you launch Tecplot Focus in batch mode, you provide the name of a macro file to execute. The
minimal command to launch Tecplot Focus in batch mode is as follows:

434



tecfocus -b -p mymacrofile.mcr

The -b flag instructs Tecplot Focus to run in batch mode and the -p tells Tecplot Focus to run the
filename that follows (mymacrofile.mcr in this case).


The -p flag can be omitted if the macro file uses the .mcr extension (thus in the
example above it could be omitted).

Batch Mode and Linux

See Tecplot Focus Command Line for information on batch mode command line arguments for Linux.
If you have any issues with running in batch mode, see the Rendering and Export Troubleshooting
guide for more information.

Batch Mode and Windows

Under Windows, invoking Tecplot Focus from the command line or in a .bat file returns immediately
rather than waiting for the application to finish working, as is normal on Linux and Mac.

When using batch mode, however, you generally want to wait until Tecplot Focus has finished one
operation before proceeding with the next. To do this, precede the command with start /wait. For
example:

start /wait tecfocus -b -p mymacrofile.mcr

Batch Mode and Mac

When running batch mode on a Mac, the full path to the executable must be called:

"/Applications/Tecplot Focus 2025 R1/Tecplot Focus 2025 R1.app/Contents/MacOS/Tecplot
Focus 2025 R1" -b mymacro.mcr

If you are running many files in batch mode, it may be helpful to set up an alias for the full executable
path. To set up an alias, type the following in ~/.bashrc:

alias tecfocus='"/Applications/Tecplot Focus 2025 R1/Tecplot Focus 2025
R1.app/Contents/MacOS/Tecplot Focus 2025 R1"'

With the alias defined, running macros in batch mode becomes easier. Simply add the -b flag followed
by the macro you wish to use:
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tecfocus -b mymacro.mcr

For more information on setting an alias and running Tecplot from the command line in Mac see the
Installation Guide.

Batch Processing Using a Layout File

Combining layout files with batch processing is both powerful and flexible, and is also the
recommended procedure. With layout files, you can organize a plot using one or more frames in a
single file. The layout file manages datasets and can be altered on the fly, either on the command line
or within a macro that loads the layout file.



The layout file must contain a $!READDATASET macro instruction compatible with the
data being loaded. The easiest way to create such a layout is to load a file similar to
the file(s) you wish to process into Tecplot Focus, then set up the plot as desired and
save the layout. The filename specified in the layout’s $!READDATASET instruction will
be overridden by the filename specified on the command line (see below).

For example, to do the following sequence of tasks in batch mode:

• Load a data file from a user-supplied file name.

• Create a specific style of plot.

• Create a PostScript file of the plot.

You can set up the batch script as follows:

1. Obtain a representative data file to be plotted.

2. Create a layout of the style of plot you want. (For this example, name the file batch.lay).

3. Use a text editor to create the following macro (For this example call this macro batch.mcr):

#!MC 1410
$!EXPORTSETUP
  EXPORTFORMAT = PS
  PRINTRENDERTYPE = VECTOR
$!PRINTSETUP
  PALETTE = MONOCHROME
$!EXPORT
  EXPORTREGION = CURRENTFRAME
$!Quit

4. Use the following command to run the job in batch mode:
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tecfocus -b -p batch.mcr -y psoutput.ps batch.lay mydatafile

tecfocus -b Launches Tecplot Focus in batch mode

-p Tells Tecplot Focus to use the following macro file. (Note: This is not needed if the
macro file uses the .mcr extension).

batch.mcr Macro file

-y Tells Tecplot Focus to use the following export file

psoutput.ps Export file

batch.lay Layout file to use

mydatafile Data file to use; overrides the file specified in the layout

Multiple Data File Processing

In Batch Processing Using a Layout File, we set up Tecplot Focus to process a user-supplied data file (or
files) and create a single output file. If the above procedure is to be repeated for a large number of
input files (one at a time), you can do this by using a loop: either outside Tecplot Focus in the operating
system using your shell’s looping constructs, or within Tecplot Focus using the flow-of-control
commands in the Tecplot macro language.

Looping Outside Tecplot Focus

The following examples show the command files for launching Tecplot Focus in an operating system
loop on two different operating systems. Tecplot Focus processes five data files named dnn.plt and
creates ten output files named dnn.out where nn goes from 1 to 10.

Looping Outside Tecplot Focus (Linux)

Create a shell script with the following commands:

#!/bin/sh
n=1
while test $n -le 10
do
  tecfocus -b -p batch.mcr -y d$n.out batch.lay d$n.plt
  n=`expr $n+1`
done

Looping Outside Tecplot Focus (Windows)

Create a batch file with the following commands:
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for %%f in (d1 d2 d3 d4 d5 d6 d7 d8 d9 d10)
do tecfocus -b -p batch.mcr -y %%f.out batch.lay %%f.plt

Looping Inside Tecplot Focus

In Looping Outside Tecplot Focus we set up Tecplot Focus to process multiple data files using the shell
to do the looping. There are two drawbacks to this procedure:

• The shell languages are not portable between different operating systems.

• Tecplot Focus must be repeatedly started and stopped to process each dataset.

A more efficient approach is to loop through the data files inside Tecplot Focus. Here, the layout file
and the data files are all named within the macro. The command line in this example is simple, as
follows:

tecfocus -b -p batch.mcr

Where the macro batch.mcr contains:

#!MC 1410
$!EXPORTSETUP EXPORTFORMAT = PS
$!PRINTSETUP PALETTE = MONOCHROME
$!LOOP 10
  $!OPENLAYOUT "batch.lay"
    ALTDATALOADINSTRUCTIONS = "d|LOOP|.plt"
  $!EXPORTSETUP PRINTRENDERTYPE = VECTOR
  $!EXPORTSETUP EXPORTFNAME = "d|LOOP|.out"
  $!EXPORT
    EXPORTREGION = CURRENTFRAME
$!ENDLOOP
$!QUIT

The $!OPENLAYOUT command loads in batch.lay but replaces the data file referenced in the layout with
the file names in the ALTDATALOADINSTRUCTIONS sub-command. The $!EXPORTSETUP command is used in
two places. Initially it is used to set the export format. Later it is used just to change the name of the file
to export to. The $!EXPORT command does the actual exporting.


If you want to make many different plots using the same dataset, stylesheets will be
more efficient than layout files.
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Batch Processing Diagnostics

Each time Tecplot Focus is run in batch mode, it creates a file defined by the name in the BATCHLOGFILE
environment variable, or, if the environment variable is not defined, by a file named batch.log in the
directory where Tecplot Focus was started. If the name given in the BATCHLOGFILE environment variable
is a relative path, the directory name where Tecplot Focus was started is prefixed. A running
commentary on actions performed in Tecplot Focus, as well as warning and error messages, are sent to
the batch.log file.
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Part 7: Advanced Topics

Animation
Tecplot Focus provides a variety of methods for creating animated plots and exporting them to movie
or sequences of static image files files for playback at a later time. The basic animation methods
available include:

Animation Tools

Create animations using the Animate menu, the Slice Details dialog, or the Streamtraces dialog. The
animation can be viewed within Tecplot Focus or exported to a movie file.

Movie File Creation with Macros

Use a macro to perform multiple, repetitive changes, and write each image to a movie file.

Animation Tools

Use a built-in animation tool to have Tecplot Focus cycle through your data, automatically displaying
zones, slices, or streamtraces one after the other. The following plot elements may be animated using
the dialogs in the Animate menu:

• Time Animation

• IJK-plane Animation

• IJK Blanking Animation

• Iso-surfaces Animation

• Mapping Animation

• Slice Animation

• Streamtrace Animation

• Zone Animation


When you need a particular size for your animation image, such as 300 by 250 pixels,
first resize your frame to the desired width and height. Then export only the active
frame.

Time Animation

To animate over time, simply press the play  button in the Plot sidebar or in the Time Animation
Details dialog. (This dialog can be launched from the Animate menu or by clicking the  button
above the Solution Time slider in the Plot sidebar.) The active frame will be animated from the current
time step to the last time step. The current Solution Time determines which transient zones are
displayed in the active frame. The slider control can be used to interactively change the Current
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Solution Time.

 This option is available for transient field plot data only.

The Time Animation Details dialog has the following options:

Starting Time

Enter the value of the first solution time to include in the animation. If the Solution Time entered
does not exist, the nearest Solution Time less than the entered time is used, or the first solution time
if no such time exists. The default value is the first Solution Time. The value of the first Solution
Time in the dataset is displayed in Min.

Ending Time

Enter the value of the last Solution Time to include in the animation. If the Solution Time entered
does not exist, the nearest Solution Time less than the entered time is used. The default value is the
last Solution Time. The value of the last Solution Time in the dataset is displayed in Max.

Time Step Skip

Enter the skip number between time steps. A value of 2 results in every other time steps being
animated, a value of 3 animates every 3 time steps, and so on.

Number of Steps

Displays the number of time steps in the data between the Start Time and the End Time.
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Animation direction

Select the direction for the animation: forward, backward, loop (forward repeatedly), or bounce
(forward, then backward, then forward, then backward…).

Current Step

This field displays the time step for the active frame of the animation. The field is updated while an
animation is in progress.

Go To

Use the Go To button to jump to the animation step entered in the Current Step field.

Slider

The slider can be dragged to change the current solution time. The following buttons may also be
used.

• - Jumps to the value in Start Time.

•  – Moves one step toward the value in Start Time.

•  – Plays the animation as specified by the Animation direction field. The Play button
becomes a Pause button while the animation is playing.

•  – Moves toward the value in End Time.

•  – Jumps to the value in End Time.

Click the filmstrip icon to export the animation to a file. See Animation Export. Note that some of
the settings in this dialog (such as direction and speed) do not apply when exporting to a file.
Instead, you may add these effects later using a video editor, if desired.

Limit Animation Speed to

Toggle-on to limit the animation speed to the value specified in the text box.

For strands with no zones at the current solution time

Determines what is shown when no zones with a given Strand ID exist at the current solution time,
within a small time tolerance:

• Show zones at or before solution time (default)- Show zones for the closest prior solution time
where the zone with that Strand ID does exist.

• Show zones only at solution time: Only show zones for the current solution time.

Note that, in addition to the above setting, the fieldmap must be active for it to be shown.

IJK-plane Animation

Use the Animate IJK-Planes dialog to display all or a specified subset of the IJK-planes in the current
dataset, one at a time. You can choose to animate either the I, J, or K-planes.
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To animate IJK-planes, select "IJK-planes" from the Animate menu. The Animate IJK-Planes dialog has
the following options:

Planes to Animate

Specify the set of planes to animate: I, J, or K-planes.

Initial Index, End Index, Index Skip

Specify an Initial Index (the first plane you want to display), an End Index (the last plane you want
to display), and an Index Skip in the fields provided. A skip of 1 displays every index, 2 displays
every other index, etc.

Animation direction

Select the direction for the animation: forward, backward, loop (forward repeatedly), or bounce
(forward, then backward, then forward, then backward…).

Current Index

Displays the number of the current plane index, which can be edited. Click Go to Index after
editing to move to the chosen step.

Slider

The slider can be dragged to change the current plane index. The following buttons may also be
used.

• - Jumps to the first index.
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•  – Moves one step toward the first index.

•  – Plays the animation as specified by the Animation direction field. The Play button
becomes a Pause button while the animation is playing.

•  – Moves toward the last index.

•  – Jumps to the last index.

Click the filmstrip icon to export the animation to a file. See Animation Export. Note that some of
the settings in this dialog (such as direction and speed) do not apply when exporting to a file.
Instead, you may add these effects later using a video editor, if desired.

Limit Animation Speed to

Toggle-on to limit the animation speed to the value specified.

Figure 62 shows an example of animating I-planes in an IJK-ordered zone.

Figure 62. An animated sequence of I-planes.


To restore the workspace back to its normal view after the IJK animation, go to
Edit→Undo Style Change.

IJK Blanking Animation

Use the Animation page of the IJK Blanking dialog (Plot→Blanking→IJK Blanking) to animate a
sequence of Tecplot Focus renderings, starting with an initial set of blanked IJK indices and proceeding
in a series of interpolated steps to a final set of blanked IJK indices.
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To animate a sequence of IJK blankings, you must first turn on IJK blanking using the checkbox at the
top of the IJK Blanking dialog. For more information on initially setting up IJK blanking, see IJK
Blanking.

The Animation page of the IJK Blanking dialog has the following settings:

Starting Index (% of Max)

Specify an initial set of blanked IJK-indices in the text fields. Enter a range of indices for: I, J, and K
(index values are entered as percentages of the maximum index).

Ending Index (% of Max)

Specify a final set of blanked IJK-indices. Enter a range of indices for each: I, J, and K.

Animation direction

Select the direction for the animation: forward, backward, loop (forward repeatedly), or bounce
(forward, then backward, then forward, then backward…).
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Number of Steps

Specify the number of steps. The minimum is two.

Current Step

Displays the number of the current step, which can be edited. Click Go to Step after editing to move
to the chosen step.

Slider

The slider can be dragged to change the current step. The following buttons may also be used.

• - Jumps to the first step.

•  – Moves one step toward the first step.

•  – Plays the animation as specified by the Animation direction field. The Play button
becomes a Pause button while the animation is playing.

•  – Moves toward the last step.

•  – Jumps to the last step.

Click the filmstrip icon to export the animation to a file. See Animation Export. Note that some of
the settings in this dialog (such as direction and speed) do not apply when exporting to a file.
Instead, you may add these effects later using a video editor, if desired.

Limit Animation Speed to

Toggle-on to limit the animation speed to the value specified in the field.

Iso-surfaces Animation

Use the Animation page of the Iso-surface Details dialog to define iso-surfaces to animate either on
screen or to a file. You can reach this page directly by choosing "Iso-Surfaces" from the Animate menu,
or you can open the Iso-Surfaces Details dialog from the Plot menu or Plot sidebar and click the
Animation tab.
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Starting Value

The starting iso-surface value for the animation.

Ending Value

The ending iso-surface value for the animation.

Animation direction

Select the direction for the animation: forward, backward, loop (forward repeatedly), or bounce
(forward, then backward, then forward, then backward…).

Number of steps

The range defined by the Starting and Ending value fields above is divided into the specified
number of steps for the animation.

Current Step

Indicates the active step of the animation. You can jump to a specific step by entering the desired
value and clicking Go to Step.

Current Value

Displays the iso-surface value at the current step.
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Slider

The slider can be dragged to change the current step. The following buttons may also be used.

• - Jumps to the first step.

•  – Moves one step toward the first step.

•  – Plays the animation as specified by the Animation direction field. The Play button
becomes a Pause button while the animation is playing.

•  – Moves toward the last step.

•  – Jumps to the last step.

Click the filmstrip icon to export the animation to a file. See Animation Export. Note that some of
the settings in this dialog (such as direction and speed) do not apply when exporting to a file.
Instead, you may add these effects later using a video editor, if desired.

Limit Animation Speed to

Toggle-on to limit the animation speed to the value specified in the field.

Mapping Animation

Use the Animate Mappings dialog to display all or a specified subset of the XY or Polar Line mappings
defined in the active frame, one at a time.

To animate mapping, select "Mappings" from the Animate menu. The Animate Mappings dialog has
the following options:

Start Map

Specify the first line mapping you want displayed.
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End Map

Specify the last line mapping you want displayed.

Map Skip

Specify the number of maps to skip per step.

Animation Mode

Select whether to animate forward, backward, loop (forward, then back to the beginning for
another pass forward), or bounce (forward, then backward, then forward, then backward…).

Current Map

Indicates the map currently displayed. You may jump to a different map by editing the value in the
text box and clicking Go to Map.

Slider

The slider can be dragged to change the current step. The following buttons may also be used.

• - Jumps to the first map.

•  – Moves one step toward the first map.

•  – Plays the animation as specified by the Animation mode field. The Play button becomes a
Pause button while the animation is playing.

•  – Moves toward the last map.

•  – Jumps to the last map.

Click the filmstrip icon to export the animation to a file. See Animation Export. Note that some of
the settings in this dialog (such as direction and speed) do not apply when exporting to a file.
Instead, you may add these effects later using a video editor, if desired.

Limit Animation Speed to

To limit the animation speed, toggle on the checkbox and enter a frame speed value in the text box.

Slice Animation

To animate slices, choose Animate→Slices. You may also get to this feature by opening the Slice
Details dialog from the Plot menu or the Plot sidebar and choosing the Animate page.
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Specify a Starting Value, an Ending Value, and the Number of Steps in the fields provided.



Only the primary slice of the current slice group (specified on the Position page) is
changed during animations. The start and end slice and any intermediate slices of the
current slice group are unchanged. It is possible that the animated primary slice will
overlap the start slice, end slice, or an intermediate slice. The animation will proceed,
without changing those values.

For arbitrary slices, the start and end origin positions are specified in XYZ coordinates. Arbitrary slices
are oriented using the normal defined on the Definition page of the Slice Details dialog (see Arbitrary
Slice Orientation). The slice’s origin point is moved between the start and end origins specified here; at
each step of the animation, the slice is drawn through the origin point and oriented against the normal.

After choosing the starting and ending positions and the number of steps, you can animate on the
screen or export the animation to a file using the following options:

Animation Direction

Select whether to animate forward, backward, loop (forward, then back to the beginning for
another pass forward), or bounce (forward, then backward, then forward, then backward…).
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Current Step

Indicates the active step of the animation. This may be edited to jump to a specific step. Click the Go
to Step button to display the entered time step in the workspace.

Current Value or Origin

Displays the value being varied (e.g. X for an X-plane slice) at the current step. For arbitrary slices,
shows the XYZ coordinates of the slice origin (through which the slice will be drawn) at the current
step.

Slider

The slider can be dragged to change the current step. The following buttons may also be used.

• - Jumps to the first step.

•  – Moves one step toward the first step.

•  – Plays the animation as specified by the Animation direction field. The Play button
becomes a Pause button while the animation is playing.

•  – Moves toward the last step.

•  – Jumps to the last step.

Click the filmstrip icon to export the animation to a file. See Animation Export. Note that some of
the settings in this dialog (such as direction and speed) do not apply when exporting to a file.
Instead, you may add these effects later using a video editor, if desired.

Limit Animation Speed

Toggle-on to limit the animation speed to the value specified in the text field.

Streamtrace Animation

To animate your streamtraces, choose Animate→Streamtraces. You may also access this feature by
opening the Streamtrace Details dialog from the Plot menu or the Plot sidebar and switching to the
Animate page.


When you animate streamtraces, timing markers are automatically turned on. You
can change the appearance of these markers in the Streamtrace Details dialog. See
Timing Page for details.

Specify the number of steps per cycle and the number of cycles in the fields provided on the Animate
page of the Streamtrace Details dialog.
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Click the Play button to view the streamtrace animation on the screen, or click the filmstrip icon to
export the animation to a file. See Animation Export.

Zone Animation

To animate zones, select "Zones" from the Animate menu. From the Zone Animation Details dialog,
specify the animation mode, Start Zone, End Zone, and Zone Skip in the fields provided.
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You can animate to a file or "On Screen". (See also Animation Export.)

Use the Mode drop-down menu to select one of the following two options:

Step by Number

Animate all zones from the first zone to the last zone with a skip specified in the Zone Skip field. A
Zone Skip of 1 animates all zones.

Group Step by Number

Animate zones in groups (as specified by the Group Size field). For example, a Group Size of 2 will
animate all zones in groups of 2 (i.e. zones 1 and 2, followed by zones 3 and 4, and so on).

The following fields are also available:

Starting zone

The first zone in the animation.

Ending zone

The last zone in the animation.

Zone Skip or Group Size

The label on this field changes depending on the setting of the Mode drop-down menu, described
previously. Decides the increment for switching zones (for Step by Number) or the size of the zone
group (for Group Step by Number).

Animation Mode

Select whether to animate forward, backward, loop (forward, then back to the beginning for
another pass forward), or bounce (forward, then backward, then forward, then backward…).
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Current Zone

Indicates the zone displayed. This may be edited to jump to a specific zone; click Go to Zone after
editing.

Slider

The slider can be dragged to change the current step. The following buttons may also be used.

• - Jumps to the first zone.

•  – Moves one step toward the first zone.

•  – Plays the animation as specified by the Animation Mode field. The Play button becomes a
Pause button while the animation is playing.

•  – Moves toward the last zone.

•  – Jumps to the last zone.

Click the filmstrip icon to export the animation to a file. See Animation Export. Note that some of
the settings in this dialog (such as direction and speed) do not apply when exporting to a file.
Instead, you may add these effects later using a video editor, if desired.

Limit Animation Speed

Toggle-on to limit the animation speed to the value specified in the text field.

 The Animate Zones dialog is not available for transient datasets.

Movie File Creation with Macros

The Tecplot macro language expands the capabilities of the standard animation features. The macro
commands allow you to do anything you can do interactively—and more. You can also use loops to
repeatedly rotate 3D objects, cycle from one active zone to another, and so on, to create your movie.
See Macros for further information about the Tecplot macro language.

A typical macro file for making movies has the following form:

#!MC 1410
... optional commands to set up the first image
$!EXPORTSETUP
  EXPORTFORMAT = AVI
  EXPORTFNAME = "mymovie.avi"
$!EXPORTSTART
  EXPORTREGION = CURRENTFRAME
$!LOOP 50
  ... commands to set up next image
  $!REDRAWALL
  $!EXPORTNEXTFRAME
$!ENDLOOP
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$!EXPORTFINISH

For example, the following macro file can be used to animate zones:

#!MC 1410
#
# Set up Export file type and file name.
#
$!EXPORTSETUP
  EXPORTFORMAT = AVI
  EXPORTFNAME = "C:\temp\timeseries.avi"
#
# Begin Animating
#
$!LOOP |NUMZONES|
  #
  # The |Loop| variable is equal to the current
  # loop cycle number.
  #
  $!ACTIVEFIELDZONES = [|Loop|]
  $!REDRAWALL
  #
  # This series of $!IF statements ensures
  # that a new AVI file will be created when
  # the macro is started.
  #
  $!IF |Loop| == 1
    $!EXPORTSTART
      EXPORTREGION = CURRENTFRAME
  $!ENDIF
  $!IF |Loop| != 1
    $!EXPORTNEXTFRAME
  $!ENDIF
$!ENDLOOP
$!EXPORTFINISH

Advanced Animation Techniques

Text Changes

There may be times when you want to include information in your animation which tells viewers
about the time step, current zones, or a mapping. There are two ways this can be done.
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Using Dynamic Text

The best way to do this is to add dynamic text to your text box. See Dynamic Text.

Attaching Text to Zones

This method works best if you are animating zones. First, create several text strings in your data file,
and use the ZN= parameter to attach each text string to a zone or mapping. You should have a separate
text string for each zone that will be used in your animation. For example

ZONE T= "Temp. distribution, Distance = 0.5 m" I=51, J=51 F=POINT
.
.
.
.....list of variable values........
.
.
.
TEXT X=70, Y=90, T= "Distance = 0.5 m", F=COURIER, CS=FRAME, H=2, ZN=1
ZONE T= "Temp. distribution, Distance = 1.0 m" I=51, J=51 F=POINT
.
.
.
.....list of variable values........
.
.
.
TEXT X=70, Y=90, T= "Distance = 1.0 m", F=COURIER, CS=FRAME, H=2, ZN=2

You can also use Tecplot Focus’s dynamic text feature (see Dynamic Text) to insert a zone name into
your text strings. For example:

ZONE T= "Distance= 1.0 m" I=51, J=51 F=POINT
.
.
.
.....list of variable values....
.
.
.
TEXT X=70, Y=90, T= "&(ZONENAME:2)", F=COURIER, CS=FRAME, H=2, ZN=2

Multiple Frame Animation

Synchronized animation of plots in multiple frames requires the use of a macro. Macros can use the
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$!FRAMECONTROL commands to switch between each frame. The following template demonstrates how
this is done with a layout where each frame contains a similar plot:

#!MC 1410
##Set the number of images (movie frames) in the animation.
$!VARSET |NumCycles| = 10
$!EXPORTSETUP
  EXPORTFORMAT = RASTERMETAFILE
  EXPORTSETUP EXPORTFNAME = "2frames.rm"
  BITDUMPREGION = ALLFRAMES
.
.....Insert commands to set up first frame, if necessary.
.
## Outer loop
$!LOOP |NumCycles|
  ## Inner loop cycles through each frame in the current layout.
  $!LOOP |NumFrames|
    .
    .....Insert commands here to change the plot in the active frame.
    .
    ## Push the top (active) frame to the back.
    $!FrameControl MoveToBottomByNumber
      Frame = |NumFrames|
    #
    ## Activate new top frame
    $!FrameControl ActivateTop
  $!EndLoop
  $!IF |Loop| == 1
    $!EXPORTSTART
      EXPORTREGION = CURRENTFRAME
  $!ELSE
    $!EXPORTNEXTFRAME
  $!ENDIF
$!ENDLOOP
$!EXPORTFINISH

Animation Export

When you choose to animate to a file in a dialog with animation options, the Export dialog appears.
Choose the desired export format from the menu at the top of the dialog, then set the options as
desired. Two different types of export formats are available:

• Movie formats (e.g. mpeg-4), which produce a single file for a given animation.

• Sequenced image formats (e.g. png etc.), which produce a sequence of static image files for a given
animation. See Sequenced Image Files.
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Most of the available formats share a set of similar options, which are described here.

Region

Select the region of the workspace to animate.

Current Frame

Captures only the active frame.

All Frames

Captures the smallest rectangular area containing all frames.

Work Area

Captures the workspace.

Use Width of Image on Screen

Select this option to generate an image file the same size as the current plot on the screen.

Enter Width

Select this option to specify a width (in pixels) for the generated image. A larger width increases the
quality of your image. However, the greater the width you specify, the longer it will take to export
the image and the larger the exported file.

Antialiasing

Select this option to smooth jagged edges in the image. The image is rendered at a higher resolution
than that at which it will eventually be displayed, then reduced in size.
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Supersample Factor

Control the amount of antialiasing used in the image. The higher this number, the larger the
temporary image used for antialiasing will be, and the more time may be required.

Animation Speed (frames/sec)

Enter a value in the text field to set your animation’s speed in frames per second.

The following sections describe any settings unique to specific formats, as well as providing additional
useful information about each format (references, viewers, etc.).

• AVI Files

• Flash Files

• MPEG-4 Files

• Raster Metafiles

Performance Tips

If exporting is taking an unusually long time, or you get an error message saying that the animation
cannot be exported, the most likely cause is that the width of the image you are trying to export is too
large. Choosing a smaller width may greatly speed up the export process. Note that antialiasing
multiplies the image’s width and height by the entered supersampling factor, so choosing a lower
factor also speeds up export.

For an export size of Length x Width, with a supersampling factor of SSF, the size of an uncompressed
true color frame is approximately Length x SSF x Width x SSF x 3. Memory requirements to export
such a frame can be up to twice this.

AVI Files

AVI format is an older video format for Windows platforms, and is widely compatible with Windows
applications. Below are some applications that can be used to view and/or edit AVI files:

Windows Media Player

A standard movie viewer included with Windows distribution. More information is available at
support.microsoft.com/en-us/windows/windows-media-technologies-ebf04fdc-dc47-9944-c160-
ae22d8413116

QuickTime

Included with Mac, Apple’s QuickTime can play AVI files and export them to other formats as
necessary.

VideoLan Client (VLC)

Free player that supports many video formats, including AVI, on Windows, Mac, Linux, and several
other platforms. www.videolan.org/vlc/
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Adobe® Premier®

A powerful tool for professional digital video editing. More information is available at
www.adobe.com/products/premiere.html.

AVI Export Options

For options common to all supported export formats, see Animation Export.

Flash Files

Adobe® Flash® is a popular tool for creating interactive Web content, including animations and
movies. The Flash product is not required to create Flash-format movies using Tecplot Focus, nor to
view them. Flash files have a filename extension of .swf and are therefore also widely referred to as
SWF files.

Playback

• Flash movies can be played in several freely distributed Flash players. For example, Swiff Player is
a stand-alone player for Windows that enables Flash users to easily play their Flash movies.

• You can play Flash movies using the QuickTime software included with Mac.

• There are several tools at download.com that can help manage, browse, convert, and display all
kinds of Flash files on your computer.
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Flash in PowerPoint

The easiest way to insert and SWF into Microsoft® PowerPoint® presentations is to download
ShowRoom, a Microsoft PowerPoint add-in that incorporates a free Flash player formerly called Swiff
Point Player. It’s from the same developer as the standalone Swiff Player described under Playback,
above. (Some other features of ShowRoom are not free of charge, but these need be paid for only if you
want to use them.)

A secondary option is to play it in a PowerPoint presentation using a Microsoft ActiveX control and the
Macromedia Flash Player. To run the Flash file, you add an ActiveX control to the PowerPoint slide and
create a link from it to the Flash file. You also have the option of embedding the Flash file in the
presentation; see:

https://support.office.com/en-us/article/Play-an-Adobe-Macromedia-Flash-animation-in-a-presentation-
3b681b8e-6ca9-413f-b41a-eb748babc588

Flash on the Web

Flash files can be inserted into Web documents using Web design tools such as Adobe®
Dreamweaver® (although this is only one such tool). You can also create Web documents by writing
HTML directly in a text editor.

Once inserted in a Web page, Flash movies play directly within your browser, assuming the Flash plug-
in is installed. (Most browsers on today’s desktop operating systems come with the Flash plug-in pre-
installed; if your browser did not, you can easily install it.) An outside media player is not needed to
launch the animation.

Flash Export Options
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The following options are unique to Flash files. For options common to all supported export formats,
see Animation Export.

Image Type

Choose an image type. Your options are:

True Color

Select this option to create twenty-four-bit images with lossless (ZLIB) compression.

JPEG

Select this option to create twenty-four-bit images with lossy compression. This produces smaller
files than True Color, and the images will be of lower quality.

256 Colors

Select this option to reduce each image to 256 colors and compress it with ZLIB.

Optimize for Speed

For True Color or 256 Colors image types, select this option to create the output as quickly as
possible. This reduces the compression level and results in larger files. It does not affect playback
speed.

Optimize for File Size

For True Color or 256 Colors image types, select this option to produce the smallest possible files.
This setting does not affect playback speed.
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MPEG-4 Files

MPEG-4 is the modern ISO standard for video playback. MPEG-4 files can be played by a wide variety
of computer software, portable devices, and set-top boxes. We suggest:

QuickTime

Included with Mac, Apple’s QuickTime can play MPEG-4 files and export them to other formats as
necessary.

Windows Media Player

A standard movie viewer included with Windows distribution. More information is available at
support.microsoft.com/en-us/windows/windows-media-technologies-ebf04fdc-dc47-9944-c160-
ae22d8413116.

VideoLan Client (VLC)

Free player that supports many video formats, including MPEG-4, on Windows, Mac, Linux, and
several other platforms. www.videolan.org/vlc/

MPEG-4 export does not have any options besides the ones that apply to all animation export formats;
see Animation Export.

Windows Media (WMV) Files

Windows Media Video (WMV) files are widely supported by Windows applications, including Windows
Media Player and Microsoft Office (PowerPoint, etc.). They may also be played on Macintosh computers
using Microsoft’s free Windows Media Components for QuickTime.

WMV export does not have any options besides the ones that apply to all animation export formats; see
Animation Export.

Raster Metafiles
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Raster Metafile is a NASA-defined standard format for storing bitmap images and may contain one or
more images, allowing it to be used for animations. The format is defined in the following reference:

Taylor, N., Everton, E., Randall, D., Gates, R., and Skeens, K., NASA TM 102588, Raster Metafile and
Raster Metafile Translator. Central Scientific Computing Complex Document G-14, NASA Langley
Research Center, Hampton, VA. September, 1989.

Raster Metafiles support only 256-color images (Tecplot Focus selects the best colors). Plots with many
colors may have poor results when exported as Raster Metafiles when compared to exports as true-
color formats. Using Raster Metafiles for animations with transparency or smooth color gradients may
result in poor image quality.

When you select Raster Metafile in the Export dialog, you have the following additional options:

Use Multiple Color Tables

Select this check box to create a Raster Metafile with a separate color table each step in the
animation. If this check box is not selected, Tecplot Focus scans all steps in the animation and
creates one color table for the entire animation. Multiple color tables can provide better per-step
image quality for the animation, but may result in flicker during playback.

Sequenced Image Files

With sequenced image formats, Tecplot will produce separate image files (e.g. png, tiff, etc.) with a
sequence number appended to the body of the filename. For example, if you specify to output to
"mymovie.png", the following files will be generated:
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mymovie_000001.png
mymovie_000002.png
... and so on.

Note that every time an animation is exported with sequenced image files the files will be numbered
starting at 1 and incrementing by 1. Even if you are doing something like a J-Planes animation and are
starting at a J-Plane other than 1.

The following image file formats are available when generating animations: BMP, JPEG, PNG, and TIFF.
All settings for these formats when making animations is the same as are available when exporting a
single image (via the File/Export dialog). See the corresponding section for each format:

BMP: BMP Export
JPEG: JPEG Export
PNG: PNG Export
TIFF: TIFF Export

Customization
This chapter discusses how custom files are loaded on startup, how to manually open those files via the
command line, the customizations that can be made by editing the Tecplot Focus configuration file, and
customizations that can be made using the Options menu.

Custom Files loaded on Startup

On startup, Tecplot Focus will load certain configuration files. These files are editable and can be
placed in different locations depending on preference. The different files types are as follows:

• tecplot.add (Add-on Loading)

• tecplot.cfg (Configuration Files)

• tecplot.fnt (Custom Character and Symbol Definition)

• tecplot.mcr (Quick Macro Panel)

• tecplot_latex.mcr (LaTeX Expressions)

• variable_aliases.txt (Creating and Using a Variable Alias File)

When Tecplot Focus first launches, it looks for the above tecplot* files in the following locations, in the
order listed below. Tecplot* specifies any of the above filenames.

• The file tecplot* specified on the command line. (See Loading custom files via the Command Line.)

• The file tecplot* in the current working directory.

• The file tecplot* in your home directory when using -h flag on the command to set the home
directory.
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• The file tecplot* in the Users home directory. On Mac and Linux, the tecplot* file must be preceded
by a period in the users home directory. For example, .tecplot.add.

• The file tecplot* in the Tecplot Focus installation directory.

The first file found in the above search order is used; others are ignored even if they exist. To see what
tecplot* files are being loaded, in Focus go to Help→About Tecplot Focus (on Mac, Tecplot
Focus→About Tecplot Focus) and look for the files in the Runtime environment.

Loading custom files via the Command Line

You can specify a different custom file by adding an option flag in front of the custom file name to the
command line when launching Tecplot Focus.

The following command starts Tecplot Focus and installs the custom file specified at startup.

tecfocus -flag tecplot*

Where -flag is the flag of the certain file you want to load. Refer to the table below for the correct flag
to be used.

-addonfile filename Supply a custom list of addons via the tecplot.add file.

-c cfgfile Use cfgfile for the configuration instead of the default configuration file,
tecplot.cfg.

-f fontfile Use fontfile instead of the default font file, tecplot.fnt.

-p scriptfile Use scriptfile like tecplot_latex.mcr instead of the default, tecplot_latex.mcr.

-qm quickpanelfile *[This feature is only available in Tecplot 360]* Place the macro functions
in quickpanelfile in the Quick Macro Panel, instead of using the macros from
the default file, tecplot.mcr.

To see an example of any of these files, open the file in the your Tecplot Focus installation.

Configuration Files

A Tecplot Focus configuration file is a special type of macro file that Tecplot Focus reads on start up.
Use customized configuration files to override any or all of Tecplot Focus’s factory default settings.


You can create a configuration file from scratch using any plain text editor, or by
editing a copy of an existing configuration file.


A configuration file should include only those options for which you want to override
defaults.

See Custom Files loaded on Startup for information on how it is loaded.
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Editing Configuration File

You are not limited to merely customizing those settings that appear in an existing configuration file.
Most settings that can be modified by the $!Field, $!LineMap,or $!Interface macro commands can be
changed in the configuration file directly. The $!LIMITS macro command can be used in the
configuration file only.

The simplest way to do this is to create a layout or macro with the settings you want, then copy and
paste the appropriate commands into your configuration file. See the Scripting Guide for complete
details on macro commands.

SetValue Commands

SetValue Commands are macro commands used to specify the value of a given plot attribute. You may
add SetValue commands to your tecplot.cfg file to override any of Tecplot Focus’s default settings. For
example, suppose you want your 2D axes to appear cyan. You can add this preference to your
configuration file as follows:

1. Using the Tecplot Focus interface, create a 2D plot with cyan axes while either recording your steps
as a macro, or else save the resulting plot as a Tecplot layout.

2. Edit the resulting macro or layout, scanning for the lines that set the 2D axis colors. The following
example shows the commands that specify the X- and Y-axis details in a layout of a 2D plot with
cyan axes:

$!TWODAXIS XDETAIL{RANGEMIN = -3}
$!TWODAXIS XDETAIL{RANGEMAX = 15}
$!TWODAXIS XDETAIL{GRIDLINES{SHOW=YES}}
$!TWODAXIS XDETAIL{AUTOGRID=NO}
$!TWODAXIS XDETAIL{GRSPACING = 5}
$!TWODAXIS XDETAIL{GRIDLINES{COLOR = CYAN}}
$!TWODAXIS YDETAIL{GRIDLINES{SHOW = YES}}
$!TWODAXIS YDETAIL{GRIDLINES{COLOR = CYAN}}

3. Discard everything but the lines that actually set the color:

$!TWODAXIS XDETAIL{GRIDLINES{COLOR = CYAN}}
$!TWODAXIS YDETAIL{GRIDLINES{COLOR = CYAN}}

4. Paste the resulting lines into your configuration file.

Plot Default Setting - FIELDMAP and LINEMAP

A single $!FIELDMAP command can be included to set plot defaults. The zone cannot be specified in the
configuration file, and the command is not effective for values set dynamically by Tecplot Focus, such
as Mesh Color. In the example below, the default contour type is Flood, scatter symbol shape is Delta,
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and scatter size is 1.8.

$!FIELDMAP CONTOUR{CONTOURTYPE = FLOOD}
$!FIELDLAYERS SHOWSCATTER = YES
$!FIELDMAP SCATTER{SYMBOLSHAPE{GEOMSHAPE = DEL}}
$!FIELDMAP SCATTER{FRAMESIZE = 1.8}

In the same way as above, a single $!LINEMAP command can be added for line mapping defaults. In the
example below, XY and Polar Line mappings will have a dashed line pattern, and symbols will be filled
circles.

$!LINEMAP LINES{LINEPATTERN = DASHED}
$!LINEPLOTLAYERS SHOWSYMBOLS = YES
$!LINEMAP SYMBOLS{SYMBOLSHAPE{GEOMSHAPE = CIRCLE}}
$!LINEMAP SYMBOLS{FILLMODE = USELINECOLOR}

Override Automatic View→Fit

When loading a 3D plot, Tecplot Focus automatically fits the plot to the frame. To revert to the old
Tecplot Focus behavior, which used a fixed zoom factor, remove the # from the following line in your
tecplot.cfg file:

#$!FrameSetup Initial3DScale = 0.7

Interface Configuration

The many members of the $!INTERFACE macro help you configure Tecplot Focus’s user interface and
graphics drawing capabilities. Although some of these commands can be executed in any macro, the
best place to put these is in the Tecplot Focus configuration file: tecplot.cfg. Below are a few
examples. Refer to the Scripting Guide for a complete listing.

General Interface Configuration Options

$!INTERFACE followed by:

MOUSEACTIONS {MIDDLEBUTTON {SIMPLEDRAG=ZOOMDATA}}

Specify the action of the middle mouse button click and drag. Several other options for the middle
and right mouse buttons are listed in the Scripting Guide. These commands can only be executed in
the Tecplot Focus configuration file.

USESTROKEFONTSONSCREEN = (YES, NO)

If set to YES, all text drawn in the work area will be drawn using Tecplot Focus’s internal stroke
fonts. If set to NO, the native True Type fonts will be used instead.
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USESTROKEFONTSFOR3DTEXT = (YES, NO)

If set to YES, all 3D text drawn in the work area will be drawn using Tecplot Focus’s internal stroke
fonts. 3D text consists of ASCII scatter symbols and node and cell labels when the active plot type is
3D Cartesian. For 3D text, this setting overrides the setting of USESTROKEFONTSONSCREEN. If set to NO,
TrueType fonts will be used instead.

OpenGL-Specific Configuration Options

Several options are available to further tune Tecplot Focus to operate with the OpenGL capabilities of
your platform. To assign values to these parameters you must use the $!INTERFACE OPENGLCONFIG
command. A complete list of these options is given in the Scripting Guide.

$!INTERFACE OPENGLCONFIG followed by:

{ALLOWHWACCELERATION = (YES, NO)}

In some cases, bugs in OpenGL drivers cause problems in Tecplot Focus. In these situations, Tecplot
Focus will typically behave better if this options is set to NO. However, Tecplot Focus will also be
slower.

{SCREENRENDERING {DOEXTRADRAWFORLASTPIXEL = (YES, NO)}}

Some OpenGL implementations use an optimization for line drawing that omits the last pixel in the
line. Set this to YES to change all line drawing to force the last pixel to be drawn. This setting applies
only to drawing on the screen.

{SCREENRENDERING {STIPPLEALLLINES = (ALL, CRITICAL, NONE)}}

Set to ALL to make all lines drawn using stippling. Set to CRITICAL to use stippling for stroke and user-
defined fonts. Set to NONE to disable stippling. This setting applies only to drawing on the screen.

{SCREENRENDERING {MAXMULTISAMPLES = <integer>}}

Specifies the number of multisamples to be used for antialiasing displayed images. The default is 4.
A value of 0 may be used for faster rendering (with some roughness in the display). Higher values
may be used at some cost in performance.

{IMAGERENDERING {DOEXTRADRAWFORLASTPIXEL = (YES, NO)}}

Some OpenGL implementations use an optimization for line drawing that omits the last pixel in the
line. Set this to YES to change all line drawing to force the last pixel to be drawn. This setting applies
only to exporting images from Tecplot Focus.

{IMAGERENDERING {STIPPLEALLLINES = (ALL, CRITICAL, NONE)}}

Set to ALL to make all lines drawn using stippling. Set to CRITICAL to use stippling for stroke and user-
defined fonts. Set to NONE to disable stippling. This setting applies to exporting images from Tecplot
Focus.

{IMAGERENDERING {MAXMULTISAMPLES = <integer>}}

Specifies the number of multisamples to be used for antialiasing exported images. The default is 4.
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{PRETRANSLATEDATA = (AUTO, ON, OFF)}

Applies a translation to data before sending it to OpenGL for rendering, reducing jitter when data is
far from the origin but has small differences between data points. The default is AUTO, which applies
the translation automatically when appropriate.

Default Temporary Directory

Tecplot Focus writes out a number of temporary files. To tell Tecplot Focus where to place these files,
put the following macro command in the tecplot.cfg file

$!FILECONFIG TEMPFILEPATH = "tempfilepath"

where tempfilepath is the new path. The default path is system dependent.

Performance Dialog

Use the Rendering Settings page of the Performance dialog (accessed via the Options menu) to adjust
the Plot Approximation and Graphics Cache. Use the Miscellaneous Settings page of the Performance
dialog (accessed via the Options menu) to adjust Data I/O, Load On Demand, Variable Derivation, and
Status Information.

Rendering Settings

The Rendering page of the Performance dialog has the following options:
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Auto Redraw

When selected, Tecplot Focus will automatically redraw the plot whenever style or data changes.
Some users prefer to turn this option off while changing multiple style settings, and then manually
pressing Tecplot Focus’s [Redraw] button on the Plot sidebar to see the full plot.

 Auto-redraw can be interrupted with a mouse click or key press.

Plot Approximation

Approximate Plots for Better Speed

An approximate plot may be used when manipulating the plot to improve interactive performance.
This feature is most useful on older, slower hardware and defaults to off. Approximate plots may
also be used for non-active frames. The degree of detail of the approximation is controlled by the
following settings:

Automatic

When the time to render (in seconds) is above the set threshold, Tecplot Focus will render the
approximate plot for style, data, and interactive view changes, followed immediately by the full
plot. This option provides for good interactive performance with the final plot always displayed
in the full representation.

Non-Active Frames Always Approximated

When only one frame exists, this option is equivalent to automatic mode. If more than one frame
exists, the active frame is set to automatic mode while the other frames are approximated.

All Frames Always Approximated

When the number of data points is above the point threshold, Tecplot Focus will render the
approximate plot in any frame. To see the full representation press the Redraw button on the
Plot sidebar.

Approximate Frames when Time (in seconds) to Render is Above

Use this value to determine when to automatically turn on plot approximation for all frames. All
frames will be approximated when the time to render the plot (all frames) while doing interactive
view changes (rotation, translation, scaling) is greater than the supplied value. This setting does not
apply when using the "All Frames Always Approximated" mode.

Approximate Plot as % of Full Plot

This value controls the percentage of geometric detail represented by the approximate plot. The
larger the percentage the more closely the approximation represents the original plot. However, the
interactive performance is reduced. This number should be adjusted until there is a balance
between good interactive performance and sufficient detail. Typically, the percentage should be set
to be less than or equal to 50. If values larger than 50% are needed to provide sufficient detail,
consider not using approximate plots.
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Graphics Cache

Tecplot Focus uses OpenGL to render plots. OpenGL provides the ability to cache graphic instructions
for rendering and can re-render the cached graphics much faster. This is particularly true for
interactive manipulation of a plot. However, this performance potential comes at the cost of using
more memory. If the memory need is too high, the overall performance could be less.

Use one of the following Graphics Cache modes to optimize your computer’s performance:

Cache All Graphics

When selected, Tecplot Focus assumes that there is enough memory to generate the graphics cache.
If this is valid, Tecplot Focus’s rendering performance will be optimal for interactive manipulation
of plots.

Cache Only Lightweight Graphics Objects

Lightweight objects include approximate plots and some other minor items, but do not include full
plots. This is a good setting for memory constrained problems. Consider using this option in
conjunction with the "Plot Approximation" mode set to "All Frames Always Approximated".

Do Not Cache Graphics

Consider using this option when memory is very limited. If you intend to interact with the plot, also
consider setting the "Plot Approximation" mode set to "All Frames Always Approximated".



In order to optimize animation, graphics caching is temporarily disabled during
animations that include zones, line mappings, time, or blanking elements. Graphics
caching is not altered during animations that include slices, streamtraces, or iso-
surfaces.

High Quality Font Usage

Tecplot Focus supports high quality TrueType fonts and can use any TrueType font installed on your
system. (See Font Folders and Fallback for more information on how fonts work with Tecplot Focus.)

Tecplot Focus has three high quality font modes:

When Possible (Default setting for Windows)

Tecplot Focus uses available TrueType fonts for any size text. This produces the best rendering
quality; however, performance is slower for large amounts of text.

For Large Characters Only

Tecplot Focus uses the TrueType fonts for large characters only. Small characters will use Tecplot
Focus’s built-in stroke fonts. This is a good blend of quality and performance. However, small
characters may not have the same appearance as large characters.

Never

Tecplot Focus never uses TrueType fonts.

472



Best Practices For Rendering Performance

The factory settings in the Performance dialog are designed for moderately-sized data and
occasionally may need to be adjusted to optimize Tecplot Focus’s rendering performance. For example,
if you are doing a lot of interactive work with your data, you may wish to turn on Plot Approximation
to make these operations more responsive. If you do not have much spare memory, you may wish to
turn off the Graphics Cache, or set it to "Cache only Lightweight Graphics Objects."


The size of the data isn’t the only factor when rendering in Tecplot Focus. If your plot
includes slices or iso-surfaces, you may also need to adjust your plot approximation
mode and graphics cache settings.

If you are using Plot Approximation, adjust the "Approximate Plot as % of Full Plot" value to give an
acceptable balance between interactive performance and plot detail.

Miscellaneous Settings

The Miscellaneous page of the Performance dialog has the following functions:

Data I/O

Use Memory Mapped I/O

When toggled-on, Tecplot Focus will use system level memory mapping functions to map Tecplot
Focus variables directly over block data in a binary data file or layout package file. Doing this at the
system level generally provides the best available performance for loading the data.
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The advantage of mapping variable data is that Tecplot Focus will only load the variable when it is
needed, not when initially opening the file (but see also Load On Demand in this dialog). In addition,
the mapped variable data can be shared between other Tecplot Focus sessions running on the same
machine, saving memory. Memory mapped I/O is most useful when there are a large number of
data points to load from a file and they are not all being used by Tecplot Focus at the same time.
Only variable data that is in a binary block format (the default for .plt files generated by Tecplot
Focus) can be memory mapped.

Load On Demand

With load-on-demand activated, Tecplot Focus generates plots faster and using less memory by only
loading data that is needed for the plot. If changes to the plot style require additional variables to be
loaded, Tecplot Focus will automatically load them, and if necessary, unload variables that are no
longer used. Tecplot Focus’s ability to automatically load and unload variables on demand allows you
to examine data that is much larger than the physical or virtual memory of your computer.


This setting does not affect reading data in Tecplot Subzone (.szplt) format, also
known as SZL. SZL data is always loaded on demand, and in the smallest possible
amount, which may be less than a full zone’s worth of a variable.

For large datasets, only the zones and variables currently in use will be loaded. However, for small
datasets, some other zones and variables may be loaded for you (based on the Memory Threshold).

Unload Strategy

Specifies how to manage unloading variables and other load-on-demand resources.

Auto Unload

This strategy attempts to keep Tecplot Focus’s memory use within the defined Min and Max
Memory Thresholds. Tecplot Focus uses these values to determine when and how much it should
unload. This is the best option for exploring data as Tecplot Focus only unloads if and when
the memory threshold has been exceeded; if the threshold is not exceeded, data loaded on-
demand remains available in memory if you need it again.

Minimize Memory Use

This strategy is used if more aggressive unloading of variables and other load-on-demand
resources is required. This option is best suited for animating through a very large number
of time steps, where each time step consumes a significant part of the computer’s available
physical and virtual memory.

Never Unload

This strategy disables the unloading capability of load-on-demand while still preserving the
ability to load variables on demand.


Most users should select either the "Auto Unload" or "Minimize Memory Use"
options.
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Memory Threshold (%) [Auto Unload ONLY]

When Tecplot Focus uses at least the maximum percentage of the available physical and virtual
memory, it will attempt to unload variables and other load-on-demand resources until the available
physical and virtual memory is at or below the specified minimum percentage.

Variable Derivation

When Tecplot Focus needs to create a nodal variable from a cell centered variable, it uses a prescribed
derivation method. Tecplot Focus provides two such derivation methods: fast and accurate.

Fast (Linear)

When selected, Tecplot Focus uses simple averaging to derive a nodal variable from a cell centered
one.

Accurate (Laplacian)

When selected, Tecplot Focus uses Laplacian interpolation to derive a nodal variable from a cell
centered variable.

Status Information

Use the following controls in the Status Line region of the Performance dialog to customize what is
displayed in the status line:

Show Status Line

Turn this preference on/off to control the display of status messages.


If you are remotely displaying Tecplot Focus on an X terminal, updating the status
line can slow down processing. If this is the case, turn off the Show Status Line
control.

Show Continuous State Messages

Turn on this control to receive context-sensitive commentary in the status line.

Show Continuous Running Coordinates

Turn on this control to display the coordinates of your mouse cursor in the status line.

Show Tool Tips

Use this option to turn tool tips on or off.

Custom Character and Symbol Definition

Generally, you will use TrueType fonts for displaying text on your screen and for printing. However,
you can configure Tecplot Focus to use stroke fonts instead using the settings on the Rendering page of
the Performance dialog (see High Quality Font Usage) for adding the USESTROKEFONTSONSCREEN and
USESTROKEFONTSFOR3DTETXT macro commands to your configuration file (see Interface Configuration).
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Stroke fonts define characters to be displayed on the screen using a set of straight lines (called strokes,
naturally). Stroke fonts, if enabled, are also used in exported images (however, vector printing and file
formats may use TrueType or PostScript fonts).

The stroke fonts are faster to draw than TrueType fonts, which can be important if you create plots
with a lot of complex text. Another advantage of the stroke fonts is that you can redefine or modify the
strokes that make up the characters, as they are stored in a plain text file called tecplot.fnt, which can
be modified using an editor. For information on how to load a custom font file, see Custom Files loaded
on Startup.

The Font File is structured as follows:

#!FF 4
CharCellHeight
Stroke command set for Helvetica Font
Stroke command set for Greek Font
Stroke command set for Math Font
Stroke command set for User-Defined Font
Stroke command set for Times Font
Stroke command set for Times Italic Font
Stroke command set for Courier Font

The file type and version are on the first line ("FF" refers to Font File). CharCellHeight is the interline
spacing (the height of a capital M plus some vertical space) in the units of a two-dimensional
coordinate system used to define the stroke-font characters. The baseline of the characters is at zero.
Before Tecplot Focus uses the character definitions, they are normalized by the character cell height.

Following the character cell height, there are seven sets of stroke commands, one set for each font as
shown above. Each stroke command set consists of definitions for the characters in the font. Each font
has a base set of 96 characters (character indices 32 to 127). Some fonts also include an extended set of
characters (character indices 160 to 255). The extended characters are needed to complete the
character sets for most of the common European languages.

All seven stroke command sets must be present, and each must have at least one character defined.
Each stroke command set begins with the definition for a space (character index 32). After that,
characters within a stroke command set may be defined in any order. If a character is not defined in
the Font File, it is drawn as a blank.

Each character in a stroke command set is defined as follows:

CharIndex NumCommands CharWidth
Command1
Command2
Command3
.
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.

.
CommandNumCommands

CharIndex is the character index that ranges from 32 to 127 and 160 to 255 for each font (see Character
Indices in Tecplot 360 for the matching of the character index to the English, Greek, Math, and
standard User-Defined font characters). NumCommands is the number of stroke commands defining
the character that follows. CharWidth is the character width, which determines the spacing of the
characters.

A command may be in one of the following forms:

• m x y

• d x y

• mr dx dy

• dr dx dy

Where:

• A command that begins with an m is a move command.

• A command that begins with a d is a draw command.

• Commands mr and dr are relative move and relative draw commands.

• The x and y are the absolute coordinates within the character cell.

• The dx and dy are the relative coordinates with respect to the previous location (increments from
the position attained by the previous command).

• All coordinates are specified as integers.

Figure 63 shows an example of a character cell and the commands used to define the lowercase letter
"y". The height of the character cell is 48.
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Figure 63. Defining a user-defined character.

Figure 64 shows a symbol being defined. Symbols should generally be centered about (0, 0) so that they
are drawn centered on the point they mark (an exception might be an arrow symbol or similar, where
you want the arrow’s tip to indicate the marked point). The font file included with Tecplot Focus
contains many User-Defined font stroke commands. Most of these are for creating extra plotting
symbols, accessible when you use the Symbol Type "Other", enter an ASCII character, and specify the
User-Defined font.
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Figure 64. Defining a user-defined plotting symbol.

Add-Ons
Add-ons are a way to extend the basic functionality of Tecplot Focus. They are executable modules
designed to perform specific tasks. A number of add-ons are available that load data in a variety of
formats, allow advanced editing, or extend Tecplot Focus’s capabilities.

Add-ons are external programs that attach themselves to Tecplot Focus and are accessed through the
Tecplot Focus interface. When Tecplot Focus launches, it goes through various initialization phases,
including the processing of the tecplot.cfg file, the loading of the Tecplot Focus stroke font file
(tecplot.fnt), and the initialization of the graphics. After completing this, Tecplot Focus looks for add-
ons.

Add-on Loading

You can load add-ons by several different methods: using the Drag-and-Drop Method, editing the
Tecplot.add File, using the Specifying Add-Ons on the Command Line, or by Specifying a Secondary
Add-On Load File.


Add-ons created for versions of Tecplot Focus prior to Tecplot Focus 2014 R1 will not
work with Tecplot Focus 2025 R1.
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Drag-and-Drop Method

The easiest method for loading an add-on for a single use is the drag-and-drop method. This method
loads the add-on for the current session of Tecplot Focus (rather than every subsequent launch of
Tecplot Focus).

To use this method, find the library file of the add-on you wish to load in the bin subdirectory of your
Tecplot Focus installation. Select the library, and, while holding down the mouse button, drag the
library into the Tecplot Focus window. Then release the mouse button to "drop" the add-on into Tecplot
Focus. The add-on will be loaded and made available immediately.

This action will load the add-on only for the rest of the current Tecplot Focus session. The next time
you close and reopen Tecplot Focus, you will need to load the add-on again if you wish to in the new
session.

Tecplot.add File

Every time Tecplot Focus launches, it reads a file called tecplot.add from the Tecplot Focus home
directory and loads all add-ons indicated in that tecplot.add file.

The tecplot.add file contains multiple $!LoadAddOn commands that load add-ons into Tecplot Focus. This
special macro file accepts only $!LoadAddOn macro commands, which require this syntax:

$!LoadAddOn "libname"

In this example, libname represents the name of an add-on’s shared object library file. The libname
must be enclosed in quotes.

To unload an add-on (that is, to prevent Tecplot Focus from loading that add-on when launching),
comment out the appropriate line in tecplot.add by adding a pound ("#") symbol in front of the load
command. For example, the pound ("#") symbol at the beginning of the following line will prevent the
Auxiliary Data Editor add-on (libname "tecutiltools_editauxdata") from loading:

# $!LoadAddOn "tecutiltools_editauxdata"

To load an add-on that does not load automatically, remove the pound ("#") symbol from in front of the
$!LoadAddOn command that includes the libname of the add-on you wish to load. If the tecplot.add file
does not list the libname of the add-on you wish to load, add a $!LoadAddOn command followed by the
libname of that add-on.

For information on loading the tecplot.add file, see Custom Files loaded on Startup.

Libname

Special rules govern how the libname name is specified in the tecplot.add file. In all cases, the filename
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extension is omitted. If you assign libname to the basename of the shared object library, then Tecplot
Focus will do the following:

Linux

The shared library to load will come from the file specified by Install-Directory
/lib/lib+basename.so.

Windows

Tecplot Focus will search for the add-on basename.dll in the following directories (in this order):

• The directory where the Tecplot Focus executable resides.

• The Windows system directories.

• The directories in your PATH environment variable.

When using V7ActiveX style add-on libraries on Windows, Tecplot Focus connects to the add-on via the
libname entry in the registry.

If an absolute path name is used in libname, then on Windows platforms, .dll is appended and on Mac
and Linux platforms, .so is appended

Specifying Add-Ons on the Command Line

You can also instruct Tecplot Focus to load a particular add-on by including the following option when
running Tecplot Focus from the command line:

-loadaddon <libname>

where <libname> is the full name (including path and extension) of an addon and -loadaddon can be
omitted if the filename given uses the standard library extension for your operating system (.dll for
windows and .so for Mac and Linux).

You may also load more than one addon from the command line.

After add-ons are loaded, Tecplot Focus re-processes all command line arguments not processed earlier
(for graphics and add-on initialization). This allows a data loader add-on to be used to load data
specified on the command line.

Specifying a Secondary Add-On Load File

You may also instruct Tecplot Focus to load a different list of add-ons by naming a second add-on load
file using one of the following methods:

• Include -addonfile addonfilename on the command line.

• Set the environment variable TECADDONFILE.
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Both of these methods tell Tecplot Focus the name of an additional add-on load file to process (which
itself contains $!LoadAddon commands). This secondary file will be processed after the main tecplot.add
file.

Add-ons included in the Tecplot Focus distribution

Your Tecplot Focus installation includes the add-ons listed following (alphabetically) and described in
Working with Add-ons. Some of these load automatically with your installation; others require you to
load the add-on by uncommenting the appropriate line from your tecplot.add file (located in your
Tecplot Focus home directory), or by any of the other methods described in Add-on Loading.

• Advanced Quick Edit

• Auxiliary Data Editor

• Create Multiple Frames

• Extend Macro

• Extend Time Macro

• Extract Over Time

• Key Frame Animator

• Measure Distance

• Multi-Frame 3D

• Solution Time and Strand Editor

• Tensor Eigensystem

• Time Series

• Write Data as Formatted Text

Working with Add-ons

The default Tecplot Focus installation includes the add-ons discussed in this section. To load or unload
them, use the methods described in Add-on Loading.

Advanced Quick Edit

The Advanced Quick Edit add-on, with the libname tecutiltools_advqet, loads automatically, and
causes the "Advanced Quick Edit Tool" to appear in the Tools menu. This add-on allows you to make
rapid changes to text and geometries selected in the active frame.

To enable this add-on, uncomment the line with $!LoadAddon "tecutiltools_advqet" in your Tecplot.add
File or use one of the other methods to load addons described in Add-on Loading.

To use this add-on, select "Advanced Quick Edit Tool" in the Tools menu to open the Advanced Quick
Edit Tool dialog.
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Controls in the Advanced Quick Edit Tool dialog are active only when you have one or more text
and/or geometries selected. Some controls are specific to either text or geometries, while others apply
to both. If the selected objects are a mix of text and geometries, the controls that apply only to
geometries will affect the specific geometries you have selected. Similarly, controls that apply
specifically to text will only affect text, even if the selected objects are a mix of text and geometries.

The Advanced Quick Edit Tool dialog includes the following options:

Geometry Coordinate System

Change selected geometries to the Frame or Grid coordinate system by selecting the appropriate
button in the Coord Sys/Char Height region of the dialog. Changing the coordinate system in this
dialog will modify each geometry’s anchor position and size so that it appears visually unchanged
in your plot.

Text Coordinate System and Character Height Units

Change the position coordinate system and character height units of all selected text by selecting the
appropriate button in the Coord Sys/Char Height region of the dialog. There are four valid
combinations: [Frame/Frame], [Frame/Point], [Grid/Grid], and [Grid/Frame]. Changing a coordinate
system in this dialog will modify each text object’s anchor position and character height so that it
appears visually unchanged in your plot.
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Text Box Margin

Change the text box margin of all selected text with the [Text Box Margin] button.

Text Line Spacing

Change the line spacing of all selected text by using the [Text Line Spacing] button.

Text Anchor Location

Change the text anchor location for all selected text by selecting one of the nine possible anchor
points from the button grid located in the Text Anchor Location region of the dialog.

Text and Geometry

Change the scope of all selected text and geometries by selecting either [Local] or [Global] scope.
Objects with local scope appear only in the frame in which they were originally created. If the
objects are defined as having global scope they will appear in all "like" frames, that is, those frames
using the same data set as the one in which the objects were originally created.

Text and Geometry Zone or Map Attachment

Change the zone or map with which the selected text or geometries are associated by selecting Zone
Attachment [Select]. This calls up the Attachment Selection dialog. The Attachment Selection
dialog lists zone names or numbers when Tecplot Focus is in the 2D or 3D Cartesian or Sketch plot
types, and mappings when Tecplot Focus is in the XY Line plot type. The "<Unattach Object>" entry
dissociates each selected text or geometry from its zone or map.

Auxiliary Data Editor

The Auxiliary Data Editor add-on loads automatically with Tecplot Focus. This add-on enables you to
edit auxiliary data within Tecplot Focus and journal the results into the saved layout file. To enable this
add-on, uncomment the line with $!LoadAddon "tecutiltools_editauxdata" in your Tecplot.add File or
use one of the other methods to load addons described in Add-on Loading.



Auxiliary data are name-value pairs associated with a data set, frame, line map, page,
variable, or zone, which Tecplot Focus stores as text strings. You can view all auxiliary
data included in your layout in the Data Set Information dialog (by going to
Data→Data Set Info).

To use this add-on, select "Auxiliary Data" from the Data menu to open the Edit Auxiliary Data dialog.
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The Edit Auxiliary Data dialog contains the following controls:

Show auxiliary data

In the drop-down menu at the top of the dialog, select the level at which you wish to view, add or
delete auxiliary data. Choose from Zones, Variables, Line Maps, Active Frame, Active Page, Data Set,
Layout, or Everything.

Auxiliary data box

In the box in the middle of the dialog, all auxiliary data for the selected level will display. You can
select any item in this box to edit it or delete it, with the [Edit] button or [Delete] button,
respectively.

Add auxiliary data

With the [Add] button, you can add auxiliary data at any of the available locations (zone, variable,
etc.).

Edit auxiliary data

With the [Edit] button, you can edit any existing auxiliary data. First select the item you wish to edit
in the Auxiliary data box, and then select the [Edit] button.

Delete auxiliary data

Use the [Delete] button to delete any existing auxiliary data. Select the item you wish to delete in the
Auxiliary data box, and then select the [Delete] button.

You can view auxiliary data on the Aux Data page of the Data Set Information dialog (accessible by
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going to Data→Data Set Info).

Tecplot Focus will journal all added or edited auxiliary data to layout and packaged layout files when
you save your layout or packaged layout file after editing the auxiliary data.

Macro Commands

You can add auxiliary data using the $!EXTENDEDCOMMAND macro, with the following syntax:

$!EXTENDEDCOMMAND
  COMMANDPROCESSORID = 'Aux Data Editor'
  COMMAND = '<operator> Name = <string> Value = <string> Location = <location>
LocationIndex = <int>'

Where:

Command Entity Notes

<operator> Choose one of Add or Delete

Name = <string> For <string> use an alphabetic character followed by zero or additional
alphanumeric characters and underscores (no spaces)

Value = <string> Only used with the Add operator. For <string> use the value to assign to the
named data piece. Surround the value with quotation marks if it has spaces

Location = <location> For <location> use one of: Zone, Var, Frame, Page, DataSet, LineMap, or
Layout.

LocationIndex = <int> For <int> provide the integer value representing which Zone, Var, Frame, or
LineMap to which Tecplot Focus attaches the auxiliary data. If adding
auxiliary data to a Page or DataSet, do not indicate a LocationIndex.

Following is an example of a macro command adding an auxiliary data piece named "TestID" with the
value of "Sequence 23, test 2" to the first zone.

$!EXTENDEDCOMMAND
  COMMANDPROCESSORID = 'Aux Data Editor'
  COMMAND = 'Add Name = TestID Value = "Sequence 23, test 2" Location = Zone
LocationIndex = 1'

Adding Auxiliary Data

The Add Auxiliary Data dialog enables you to add auxiliary data at any of several levels. To reach this
dialog, select the [Add] button in the Edit Auxiliary Data dialog. Data added in the Add Auxiliary
Data dialog will subsequently appear in the Edit Auxiliary Data dialog, in the Auxiliary Data display
box. The Add Auxiliary Data dialog has the following controls:
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Location

Choose the level at which to add the data from the Location drop-down menu. You can choose to
add it at the zone, variable, line map, active frame, active page, layout, or dataset level.

Number

When the Location indicates "Zone", "Variable", or "Line Map", the Number box will activate for you
to specify the Zone Number, Variable Number, or Line Map number at which to add the auxiliary
data.

Name

Enter the name of your data in the Name box.

Value

Enter the value of your data in the Value box.

Select the OK button in the Add Auxiliary Data dialog to finish adding a piece of auxiliary data to the
selected location.

Create Multiple Frames

Use the Create Multiple Frames add-on to make a set of new frames with uniform size and spacing
within the active frame.

To enable this add-on, uncomment the line with $!LoadAddon "tecutiltools_mulframe" in your
Tecplot.add File or use one of the other methods to load addons described in Add-on Loading.

To use this add-on, select Create Multiple Frames in the Tools menu. This will open the Create
Multiple Frames dialog.

The Create Multiple Frames dialog has the following options:

Frames Across

Enter the number of frames to be displayed in each row of frames.

Frames Down

Enter the number of rows of frames.

487



Space Between Frames

Enter the amount of space to display between each frame in each direction, in paper ruler units.

Select the [Create] button to create the multiple frames as specified.

See Frame Creation for information on creating a single frame.

Extend Macro

The Extend Macro add-on, libname "tecutilscript_extendmcr", extends the Tecplot macro language to
include additional commands. To enable this add-on, uncomment the line with $!LoadAddon
"tecutilscript_extendmcr" in your Tecplot.add File or use one of the other methods to load addons
described in Add-on Loading.

You may use the Extend Macro add-on by adding the following function call to your macro file:

$!EXTENDEDCOMMAND COMMANDPROCESSORID='extendmcr' COMMAND='command option'

The commands supported by the add-on are listed in the following table


When specifying a macro variable name in an Extend Macro command, you should
not surround the variable name with vertical bars. For example, ZONENUM rather
than |ZONENUM|.

Table 8. Command Options for Extend Macro

Command Notes

QUERY.ZONENAMEBYNUM nnn VVV Get the string for zone nnn and assign to variable
VVV.

QUERY.VARNAMEBYNUM nnn VVV Get the string for variable nnn and assign to
variable VVV

QUERY.ZONENUMBYNAME "zonename" VVV Get the number of zone named zonename and
assign to variable VVV
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Command Notes

QUERY.VARNUMBYASSIGNMENT assignment VVV Get the number of variable by assignment and
assign to variable VVV. VVV may have any of the
following values:

• X, Y or Z - Variable assigned to the X, Y or Z-
axis.

• U, V or W - Variable assigned to be the U, V or W-
vector component.

• C Variable assigned to contours.

• S Variable assigned to scatter sizing.

• B Variable assigned to the first constraint for
value-blanking.

QUERY.DATASETTITLE VVV Get the string for the dataset title and assign to
variable VVV

STRING.LENGTH StrSource VVV Get the length of string StrSource and assign to
variable VVV.

STRING.FINDPATTERN StrSource StrPattern VVV Get the sub-string from StrSource starting at
pattern StrPattern and going to the end of
StrSource. Returns "NOTFOUND" if not found.

STRING.SUBSTRING StrSource start end VVV Get the sub-string from StrSource starting at
position start and ending at position end. Put the
result in VVV.

QUERY.ACTIVEZONES VVV Get the set of active zones and put the result in
VVV.
Note: The set string does not include any blank
spaces. If zones 2, 4, 6, 7 and 8 are active, VVV
would have the string "2, 4, 6-8."

QUERY.MAPNAMEBYNUM nnn VVV Returns a string (the name of the map) for map
number nnn and places it in variable VVV. The
active plot must be XY-Line or Polar-Line.

QUERY.ISADDONLOADED commandprocessorid
VVV

Return "YES" in VVV if Add-on
commandprocessorid is loaded, otherwise return
"NO"

QUERY.FILEEXISTS "filename" VVV If the file exists, VVV will be "YES" otherwise VVV
will be "NO"

QUERY.ISZONEACTIVE ZZZ VVV Test to see if zone ZZZ is active. If so, VVV is set to
"YES"," otherwise it is set to "NO"
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Command Notes

QUERY.LINEMAPZONEASSIGNMENT nnn VVV Get the zone number assigned to line map nnn
and put the result in VVV.

QUERY.ACTIVELINEMAPS VVV Get the set of active line maps and put the result
in VVV.
Note: The set string does not include any blank
spaces. If linemaps 2, 4, 6, 7, and 8 are active, VVV
would have the string "2,4,6-8."

QUERY.ISLINEMAPACTIVE nnn VVV Test to see if line map nnn is active. If so, VVV is
set to "YES", otherwise it is set to "NO." VVV is set
to "INVALID" if nnn ⇐0.

FILE.APPENDSTRING "FileName" "String" Appends the given string to the indicated file,
creating the file if necessary. FileName may be a
relative path from Tecplot’s working directory or
an absolute path.

FILE.APPENDLASTERROR "FileName" Appends the last error message, if any, to the
indicated file, creating the file if necessary.
FileName may be a relative path from Tecplot’s
working directory or an absolute path. If no
Tecplot errors have occurred, this command will
have no effect.

If you have declared macro variables and would like to use them with the Extend Macro add-on, you
can do so by surrounding the command call with single quotes and the macro variable with double-
quotes.

For example:

$!VarSet |ZoneName| = "Unknown"
$!EXTENDEDCOMMAND
  COMMANDPROCESSORID = "extendmcr"
  Command = 'query.zonenamebynum 1 "ZoneName"'
$!RemoveVar |ZoneName|

Refer to the Scripting Guide for additional information on working with Tecplot Focus’s macro
language.

QUERY.DATASETTITLE

The following example, uses the QUERY.DATASETITLE command to place the title of the dataset at a
specific position on the plot.
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$!VARSET |ZNUM| = "blank"

$!EXTENDEDCOMMAND COMMANDPROCESSORID='extendmcr'
  COMMAND='QUERY.DATASETTITLE ZNUM'

$!ATTACHTEXT
  XYPOS
  {
    X = 5
    Y = 90
  }

  TEXT = "Title is: |ZNUM|"

QUERY.VARNAMEBYNUM

The following example uses QUERY.VARNAMEBYNUM to place the name of variable 2 at a specific
position on the plot.

$!VARSET |VNAME| = "X"

$!EXTENDEDCOMMAND COMMANDPROCESSORID = 'extendmcr'
  COMMAND='QUERY.VARNAMEBYNUM 2 VNAME'

$!ATTACHTEXT
  XYPOS
  {
    X = 5
    Y = 85
  }

  TEXT = "Var 2 is: |VNAME|"

QUERY.ZONENAMEBYNUM

The following example uses QUERY.ZONENAMEBYNUM to place the title of Zone 1 at a specific position
on the plot.QUERY.ACTIVEZONES

$!VARSET |ZNAME| = "HELLO"

$!EXTENDEDCOMMAND COMMANDPROCESSORID = 'extendmcr'
  COMMAND='QUERY.ZONENAMEBYNUM 1 ZNAME'

$!ATTACHTEXT
  XYPOS
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  {
    X = 5
    Y = 80
  }
  TEXT = "Zone is: |ZNAME|"

QUERY.ACTIVEZONES

The follow example uses QUERY.ACTIVEZONES to display a list of the active zones.

$!VARSET |ZNUMS| = "blank"

$!EXTENDEDCOMMAND COMMANDPROCESSORID='extendmcr'
  COMMAND='QUERY.ACTIVEZONES ZNUMS'

$!ATTACHTEXT
  XYPOS
  {
    X = 5
    Y = 70
  }
  TEXT = "Active zones are: |ZNUMS|"

Refer to the Scripting Guide for additional information on working with Tecplot Focus’s macro
language.

Extend Time Macro

The Extend Time Macro add-on simplifies the macro interface by allowing you to use a simple loop to
query the number of solution times in the dataset and advance the time step. This differs from the
native Tecplot macro language as it does not require that you know the solution time of your data.

This add-on uses a different algorithm than Tecplot Focus for sorting the solution times. Because
Tecplot Focus combines time steps that are sufficiently close together, the number of time steps
reported by this add-on may differ from the number of time steps reported by Tecplot Focus.

To enable this add-on, uncomment the line with $!LoadAddon "tecutilscript_extendtimemcr" in your
Tecplot.add File or use one of the other methods to load addons described in Add-on Loading.

Macro Processing

The Extend Time Macro add-on can be invoked from the macro language by using the following
commands:

This command retrieves the number of time steps. This number is returned in the macro variable VVV.
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$!EXTENDEDCOMMAND COMMANDPROCESSORID='extend time mcr'
  COMMAND='QUERY.NUMTIMESTEPS VVV'

This command sets the solution time at time step nnn. The acceptable value range number for nnn is: 1
- NumTimeSteps.

$!EXTENDEDCOMMAND COMMANDPROCESSORID='extend time mcr'
  COMMAND='SET.CURTIMESTEP nnn'

This command retrieves the solution time at time step nnn. This number is returned in the macro
variable VVV.

$!EXTENDEDCOMMAND COMMANDPROCESSORID='extend time mcr'
  COMMAND='QUERY.TIMEATSTEP nnn VVV'

The following is a sample loop that uses the Extend Time Macro add-on:

$!EXTENDEDCOMMAND COMMANDPROCESSORID='extend time mcr'
  COMMAND='QUERY.NUMTIMESTEPS NUMTIMESTEPS'
$!LOOP |NUMTIMESTEPS|
  $!EXTENDEDCOMMAND COMMANDPROCESSORID='extend time mcr'
    COMMAND='SET.CURTIMESTEP |LOOP|'
  $!EXTENDEDCOMMAND COMMANDPROCESSORID='extend time mcr'
    COMMAND='QUERY.TIMEATSTEP |LOOP| CURTIME'
  $!PAUSE "Current time is: |CURTIME|"
$!ENDLOOP

See also: Extract Over Time, Solution Time and Strand Editor, Extend Macro, Time Series, and Time
Aware.

Extract Over Time

The Extract Over Time add-on, extracts iso-surfaces, streamtraces, and points from polyline geometries
in transient data. The resulting zones are assembled into a new strand with proper solution times set
for each zone.

 To save a layout file, you must also save a data file when using this add-on.

To enable this add-on, uncomment the line with $!LoadAddon "tecutiltools_extractovertime" in your
Tecplot.add File or use one of the other methods to load addons described in Add-on Loading.

To use this add-on, go to Data→Extract and select one of the following menu options.
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Extract Slices Over Time

This option has moved to the Extract Slices dialog. See Extracting Slices to Zones. The macro, below,
can still be used.

Extract Polyline Over Time

Extracts a polyline geometry to a zone for each solution time. It allows you to define the number of
points along the polyline to extract. It has the following requirements:

• The frame must be in 2D or 3D.

• Only a single polyline can be selected.

• The data must be transient.

• The polyline must be positioned over an existing zone.

Extract Iso-Surfaces Over Time

Extracts an iso-surface to a zone for each solution time. It has the following requirements:

• The frame must be in 3D.

• The frame must contain one or more iso-surfaces.

• The data must be transient.

Extract Streamtraces Over Time

Extracts a set of streamtraces to a zone for each solution time. It has the following requirements:

• The frame must be in 2D or 3D.

• The frame contains one or more streamtraces

• The data must be transient.

After extracting, the new strand is available and may be animated or saved to a file.

Macro Processing

The Extract Over Time add-on can be invoked from the macro language by using the following
commands:

Extract What Command

Slices $!EXTENDEDCOMMAND COMMANDPROCESSORID='Extract Over Time'
COMMAND='ExtractSliceOverTime'
Note: Prefer using the $!EXTRACTSLICES macro command instead. See the Scripting
Guide for more details on this command.

Iso-Surfaces $!EXTENDEDCOMMAND COMMANDPROCESSORID='Extract Over Time'
COMMAND='ExtractIsoSurfaceOverTime'
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Extract What Command

Streamtraces $!EXTENDEDCOMMAND COMMANDPROCESSORID='Extract Over Time'
COMMAND='ExtractStreamOverTime'

Geometries $!EXTENDEDCOMMAND COMMANDPROCESSORID='Extract Over Time'
COMMAND='ExtractGeomOverTime'
Optionally, you may specify the number of points to extract by using the following
format:
$!EXTENDEDCOMMAND COMMANDPROCESSORID='Extract Over Time'
COMMAND='ExtractGeomOverTime:nnn'
Where nnn >= 2. If this condition is not met when the macro is played back, the
action will silently fail and your macro will continue processing.

See also: Extend Time Macro, Solution Time and Strand Editor, Extend Macro, Time Series, and Time
Aware.

Extract Precise Line

The Extract Precise Line add-on (libname: tecutiltools_extractpreciseline) allows you to extract
points along a line to a new zone or to a Tecplot ASCII data file. You specify the precise X, Y, and Z
coordinates of the start and the end points of the line, along with the number of points along this line
to extract.

To use the Extract Precise Line add-on, choose Data→Extract→Extract Precise Line.

Start, End X/Y/Z

Enter the X, Y, and Z coordinates of the start and end points of the line.
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Number of Points

The number of points between the start and end points to be extracted. (The start and end points
themselves are always extracted and this number does not include them.)

Extract To

Whether to extract to a zone or a file. If extracting to a file, you must also specify an output file path
in the File Name field.

Extract From

Choose whether to extract from the surface the line passes across or the volume it passes through.

When extracting from a surface in 3D, extraction is view-dependent: the specified line is projected
from the plane of the screen onto the surface being extracted. Changing the view (e.g. rotating) will
change the points extracted.

File Name

The path of the file to extract to. You may type the path, paste it, or click the … button to open the
Write Tecplot ASCII File dialog and navigate interactively.

Click Extract to perform the extraction.

Macro Processing

There is no macro command syntax specific to this add-on. Instead, it records an $!EXTRACTFROMPOLYLINE
command. See the Scripting Guide for more details on this command.

Key Frame Animator

With this add-on, you can easily animate a smooth progression through two or more specified views
(key frames) and export them as an AVI, Flash, or Raster Metafile animation.

To enable this add-on, uncomment the line with $!LoadAddon "tecutiltools_keyframe" in your
Tecplot.add File or use one of the other methods to load addons described in Add-on Loading.

To use this add-on, first create a layout and use the 3D Cartesian mode to view your plot. Then select
"Key Frame Animation" in the Animate menu to open the Key Frame Animation dialog.

 You must be in 3D Cartesian mode to use the Key Frame Animator add-on.
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To create a key frame animation using this dialog, follow these general steps:

1. Rotate and/or zoom the plot to the initial view for the animation, and select the [Append] button in
the dialog. If you wish, you may change the name of the view (key frame) by selecting the frame
("View 1") in the Key Frame box and editing the name in the View Name field of the dialog (for
example, "End of Airfoil").

2. Rotate and/or zoom the plot to the next view you wish your animation to include, and select the
[Append] button to add that view to the end of the animation. Or you can select the [Insert] button
to insert a view above the selected one in the list. These key frames are snapshots of the view in
Tecplot Focus, so limit rotations to 180 degrees or less between key frames, or the animation may
not rotate as you expect.

3. Continue to rotate and/or zoom and select [Append] or [Insert] to add additional key frames to your
animation, if desired.

4. When finished adding key frames, select [Animate All] to perform a complete animation of your
views, or [Animate Selected] to animate only the views selected in the Key Frame box. Tecplot
Focus will interpolate all views in between your views to create an animation.

5. To export an animation, change the Destination from "On Screen" to "To File". Then select the
[Animate All] or [Animate Selected] to open the Export Options dialog. You can choose to export
the file as AVI, Flash, or Raster Metafile. Refer to Exporting Plots for details on exporting your file.

The Key Frame Animation dialog includes these controls:
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Append

The [Append] button adds the current view in the active frame to the list.

Insert

Use the [Insert] button to insert the current view above the currently selected view in the key frame
list.

Update

The [Update] button replaces the view selected in the list with the current view in Tecplot Focus.
This also re-captures the current solution time.

Apply

Use the [Apply] button to display the selected view as the current view of your plot.

Delete

Select the [Delete] button to delete the selected key frame from the list.

Clear

Use the [Clear] button will delete all key frames from the list.

View Name

Use the View Name field to rename the view selected in the key frame list. By default, Tecplot Focus
names the views as "View 1", "View 2", etc.

Frame Count

The Frame Count box sets the number of frames drawn by Tecplot Focus between the selected view
and the next view in the animation.

Destination

In the Destination drop-down menu, choose whether to animate the key frames On Screen or To
File.

Animate All

Select [Animate All] to animate through all the key frames in the list.

Animate Selected

Select [Animate Selected] to animate only the selected views. This allows you to refine a subset of
animation without performing the complete animation.

Animation Customizations

The Key Frame Animator add-on includes additional capabilities in customized File and Options
menus at the top of the Key Frame Animation dialog. These menus give you the following additional
options:
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File→Open/Save Animation

In the File menu, you can save an animation that you have created, or you can open an animation
that you have previously saved. An animation file stores settings and all key frames, and defaults to
the name animation.keyframe. The ability to save and load animation files enables you to keep track
of created animations without having to recreate them.

Options

In the Options menu, each choice is a toggle except for "Time Animation Options" (which opens the
Time Animation Options dialog). Select an option from this menu to turn on that preference. When
an option is toggled-on, a checkmark will appear next to that option in the Options menu.

Animate Time Concurrently

Select this option to animate time when animating the key frames, as specified in the Time
Animation Options dialog.

Animate Streamtraces Concurrently

If streamtraces display as markers or dashes in your plot, enable "Animate Streamtraces
Concurrently" to animate streamtrace markers or dashes concurrently with key frame
animation.

Fade In/Fade Out

Toggle-on "Fade In" and/or "Fade Out" to fade lighting intensity and background lighting during
the start and/or end of the key frame animation. The fade will last either 30 frames or the first
ten percent of all frames, whichever is shorter. Fade In and Fade Out work best with a black
background and without any plot features that do not have light sensitivity (mesh lines, edge
lines, etc.).

Time Animation Options

With the Time Animation Options dialog (opened by selecting "Time Animation Options" in the
Options menu), you can specify additional options for animating your key frames. Choose to animate
the frames by any of the following methods.

Forward

With "Forward" selected, Tecplot Focus will display the earliest solution time in the first key frame,
and will progress solution time throughout key frame animation so that the latest solution time
displays with the final frame of the animation.

Loop

With "Loop" selected, the solution time will progress as in the "Forward" option, except that the
complete cycle of solution times displays multiple times over one key frame animation cycle. Set the
number of solution time cycles to display in the Num Cycles box.

Bounce

With "Bounce" selected, the solution time will progress forward during animation, until the solution
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time cycle completes. The solution time will then decrement in equal intervals until the initial
solution time displays. Specify the number of times to repeat this bounce in the Num Cycles box.

As Captured

Select "As Captured" to link each key frame with the solution time that the frame displayed when
that frame was added to the key frame list. During the key frame animation, the solution time will
vary in equal intervals between successive pairs of key frames so that each key frame displays the
linked solution time.

See Also: Key Frame Animator.

Export Animation Options

In the Key Frame Animation dialog, when animating a set of key frames, you can export your
animation by selecting "To File" from the Destination drop-down menu. Then select either [Animate
All] or [Animate Selected] to launch the Export Options dialog. In this dialog, you can customize the
export settings for your animation. Then select OK to select file location and export your animation.

The Export Options dialog includes the following export settings for your animation:

Format

Select the format of your exported file.

Region

Select the portion of your workspace that you wish to export. You can export the Active Frame, All
Frames, or the entire Work Area.

Width

Choose the width of the exported animation. You can use the default width of image on screen, or
enter your own dimensions.

Animation Speed

Enter a number to indicate how quickly you would like your animation to progress, in units of
frames per second.

Antialiasing

Toggle-on "Antialiasing" to use antialiasing in your exported animation. For more information on
antialiasing, refer to Antialiasing Images.

Image Type

If exporting as Flash, choose the type of image on which to base your animation.

Optimize

With the two Optimize choices at the bottom of the dialog, you can choose to optimize your
animation for either faster speed or smaller file size.
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Macro Processing

To invoke the Key Frame Animator from the macro language, use the following commands:

Save Animation File:

$!EXTENDEDCOMMAND
  COMMANDPROCESSORID = 'Key Frame Animation'
  COMMAND = 'Animate AnimationDestination=<animationdest>'

In this command, use either OnScreen or ToFile for the <animationdest>.

Open Animation Settings File:

$!EXTENDEDCOMMAND
  COMMANDPROCESSORID = 'Key Frame Animation'
  COMMAND = 'OpenSettingsFile FileName = <string>'

Save Animation Settings File:

$!EXTENDEDCOMMAND
  COMMANDPROCESSORID = 'Key Frame Animation'
  COMMAND = 'SaveSettingsFile FileName = <string>'

Use the $!ExportSetup commands to set up the necessary parameters for exporting to file (i.e., to set
format, filename, etc.)

Note that the $!ExportSetup parameter EXPORTFNAME, which controls the export file name, can accept
intrinsic macro variables such as SOLUTIONTIME, FRAMENAME, and LAYOUTFNAME. For example, if you wish to
save a .png image, that tracks the frame name and solution time it came from, the macro command
below is valid if the supplied intrinsic variables exist:

$!EXPORTSETUP EXPORTFNAME = 'path/to/output/directory/|FRAMENAME|-|SOLUTIONTIME|.png'

See Also: Key Frame Animator.

Measure Distance

The Measure Distance add-on provides two menu items on the Tools pull-down menu, which are
available only in 3D and 2D cartesian plots.

To enable this add-on, uncomment the line with $!LoadAddon "tecutiltools_measuredistance" in your
Tecplot.add File or use one of the other methods to load addons described in Add-on Loading.
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The Tools menu items are:

Measure Distance

Choose this command from the Tools menu, then click two points on your plot. After the second
click, a dialog appears indicating the coordinates of the two points, the differences in their
coordinates, and the linear distance between the two points.

In three dimensions, the distance measured is the shortest distance between the different points
selected and does not follow the surfaces. In two dimensions, the distance is in the 2D plane.

Measure Angle

Choose this command from the Tools menu, then click three points on your plot. After the third
click, a dialog appears indicating the distance from point 1 to point 2, the distance from point 2 to
point 3, and the angle in radians and degrees.

In three dimensions, the angle measured is the angle between vectors 1-2 and 2-3 in the plane
defined by points 1,2, and 3. In two dimensions the angle is in the 2D plane.

Multi-Frame 3D

The Multi-Frame 3D add-on adds two menu items to the Frame pull-down menu: Tile Frames and 3D
Multi-Frames. Each command displays a small dialog giving you options for managing the frames in
your plot.

To enable this add-on, uncomment the line with $!LoadAddon "tecutiltools_multiframe3d" in your
Tecplot.add File or use one of the other methods to load addons described in Add-on Loading.

Tile Frames

The Tile Frames dialog lets you quickly arrange multiple frames on a page in a variety of layouts.
Clockwise from upper left, these are:

Square

Frames are made as close to square as possible and arranged in a grid with approximately equal
numbers of rows and columns.
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Wrap

The first frame is displayed in a larger size and the rest of the frames are wrapped around the right
and bottom edge. The size of the main frame depends on the number of additional frames that need
to be wrapped around the page.

Horizontal

Equal-size horizontal frames are stacked vertically.

Vertical

Equal-sized vertical frames are arranged horizontally.

When frames are resized, no attempt is made to re-fit the data to them. If a frame’s aspect ratio
changes, data may no longer fit the frame as it did before tiling.

3D Multi-Frames

The 3D Multi-frames dialog, available only when the active frame is in 3D Cartesian mode, creates
three additional frames displaying top (XY), front (XZ), and side (YZ) views of the 3D frame.

You may choose from five options for arranging the frames. Four of these options use a large frame for
the original 3D frame and place the top, front, and side views along the top, bottom, or side of the large
frame. For these views, the slider chooses the size of the large frame from 25% to 75% of the paper
area. A grid arrangement giving equal prominence to all four frames is also provided. The button with
the red X is for deleting the auxiliary frames (they may also be deleted manually).

When the new frames are created, the data and styles are shared with the original frame, and the new
views are fit to their frames. The program also links field layer toggles, such as Mesh, Contour,
Lighting, and so forth, so that a change in one frame is automatically reflected in the others.

Macro Processing

To tile frames using the Tecplot macro language, use the following command.

$!EXTENDEDCOMMAND
  COMMANDPROCESSORID = 'Multi Frame Manager'
  COMMAND = 'TILEFRAMESSQUARE'
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The command can be TILEFRAMESSQUARE, TILEFRAMESVERT, TILEFRAMEZHORIZ, or
TILEFRAMESWRAP.

To generate the top/front/side frames from a 3D view, use the following command.

$!EXTENDEDCOMMAND
  COMMANDPROCESSORID = 'Multi Frame Manager'
  COMMAND = 'MAKEFRAMES3D ARRANGE=LEFT SIZE=25'

ARRANGE may be LEFT, TOP, RIGHT, BOTTOM, or TILE, and the first four accept the SIZE parameter,
which indicates a percentage of the paper size and can be 25-75.

To delete the top/front/side frames, use the following command.

$!EXTENDEDCOMMAND
  COMMANDPROCESSORID = 'Multi Frame Manager'
  COMMAND = 'DELETEFRAMES3D'

Solution Time and Strand Editor

The Solution Time and Strand Editor add-on allows you to modify the strand and solution time values
from the user interface. This helps when loading a series of data files that do not have a solution time
or strand ID. Adding the solution time simplifies both animating and setting component styles.

To enable this add-on, uncomment the line with $!LoadAddon "tecutiltools_strandeditor" in your
Tecplot.add File or use one of the other methods to load addons described in Add-on Loading.

To access this add-on, select Edit Time Strands from the Data menu. The dialog has the following
options:
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Zones to Edit

In the Zones to Edit box, select a set of zones to edit.

Data Specifications

Toggle-on "Multiple Zones Per Time Step" in order to select grouping by time step or strand. Use this
Data Specifications region of the dialog to specify how the add-on groups zones.

Strand ID

In the Time Strand region of the dialog, toggle-on "Assign Strands" to assign strand IDs.

Solution Time

In the Solution Time region of the dialog, toggle-on "Assign Solution Time" to assign the solution
time using one of the following options:

Single Value

The Single Value option assigns the specified solution time to all selected zones.

Constant Delta

The Constant Delta option applies a constant delta between zones (or groups of zones, depending
on the Data Specification settings).

Automatic

The Automatic option attempts to determine the solution time for each zone in this order:

• Examines the Common.Time auxiliary data attached to the zone.
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• Tries to read a number from the zone name.

• Tries to find a dataset variable that contains the time value. If found, uses the minimum
value of this variable for that zone.

• If an existing solution time is defined for the zone, the Automatic option uses it.

• If all previous efforts fail, the Automatic option will fall back to use the Constant Delta option.

Tensor Eigensystem

The Tensor Eigensystem enables you to calculate the eigenvalues and eigenvectors of a 3-by-3
symmetric tensor whose components are stored in your data set. The add-on calculates for each node
in the data set and stores the results as new data set variables.

To enable this add-on, uncomment the line with $!LoadAddon "tecutiltools_tensoregn" in your
Tecplot.add File or use one of the other methods to load addons described in Add-on Loading.

To use this add-on, select "Tensor Eigensystem" from the Tools menu to open the Tensor Tools dialog.

In the Tensor Tools dialog, select variables from your data set to represent the 6 components of the
tensor. Toggle-on "Sort by Eigenvalue" to sort the results by the eigenvalues, and/or toggle-on "Save
Eigenvectors" to store the calculated eigenvectors in addition to the calculated eigenvalues, which the
calculation always saves. Then select OK to perform the calculation.

Tecplot Focus will store the eigenvalues of the tensor as variables EgnVal1, EgnVal2, and EgnVal3 in
your data set. If you choose to save the eigenvectors as well, they are stored as variables EgnVec11
through EgnVec33. If you toggled-on "Sort by Eigenvalue", the eigenvalues and their corresponding
eigenvectors will be sorted largest-to-smallest at each grid node. The association of EigenValue to
EigenVector is as follows:

EigVal1 → EgnVec11, EgnVec21, EgnVec31

EigVal2 → EgnVec12, EgnVec22, EgnVec32

EigVal3 → EgnVec13, EgnVec23, EgnVec33
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*[This feature is only available in Tecplot 360]* A common use of Tensor Eigensystem is to visualize
vortex cores in a flow solution. You can do this by the following method:

1. Calculate Velocity Gradient in Analyze→Calculate Variables

2. Calculate the symmetric tensor S2 + Ohm-2 with Data→Alter→Specify Equations (see below for
an equation file to perform this)

3. Use the Tensor Eigensystem dialog to calculate the sorted eigenvalues

4. Display an iso-surface of Lambda-2, the middle of the three eigenvalues, which is negative in the
vicinity of a vortex core

The following equation file calculates the required symmetric tensor components of S2 + Ohm-2 from
the velocity gradient for step 2 above. Save the below to a text file, then load it into the Specify
Equations dialog by selecting "Load Equations" and selecting the file.

#!MC 1100
$!ALTERDATA EQUATION = '{s11} = {dUdX}'
$!ALTERDATA EQUATION = '{s12} = 0.5*({dUdY}+{dVdX})'
$!ALTERDATA EQUATION = '{s13} = 0.5*({dUdZ}+{dWdX})'
$!ALTERDATA EQUATION = '{s22} = {dVdY}'
$!ALTERDATA EQUATION = '{s23} = 0.5*({dVdZ}+{dWdY})'
$!ALTERDATA EQUATION = '{s33} = {dWdZ}'
$!ALTERDATA EQUATION = '{Omga12} = 0.5*({dUdY}-{dVdX})'
$!ALTERDATA EQUATION = '{Omga13} = 0.5*({dUdZ}-{dWdX})'
$!ALTERDATA EQUATION = '{Omga23} = 0.5*({dVdZ}-{dWdY})'
$!ALTERDATA EQUATION = '{s2o2_11} = {s11}**2 + {s12}**2 + {s13}**2 - {Omga12}**2 -
{Omga13}**2'
$!ALTERDATA EQUATION = '{s2o2_12} = {s11}*{s12} + {s12}*{s22} + {s13}*{s23} -
{Omga13}*{Omga23}'
$!ALTERDATA EQUATION = '{s2o2_13} = {s11}*{s13} + {s12}*{s23} + {s13}*{s33} +
{Omga12}*{Omga23}'
$!ALTERDATA EQUATION = '{s2o2_22} = {s12}**2 + {s22}**2 + {s23}**2 - {Omga12}**2 -
{Omga23}**2'
$!ALTERDATA EQUATION = '{s2o2_23} = {s12}*{s13} + {s22}*{s23} + {s23}*{s33} -
{Omga12}*{Omga13}'
$!ALTERDATA EQUATION = '{s2o2_33} = {s13}**2 + {s23}**2 + {s33}**2 - {Omga13}**2 -
{Omga23}**2'


Remember that the Tensor Eigensystem add-on can only analyze 3-by-3 symmetric
tensors (not 2-by-2, anti-symmetric, or non-symmetric tensors).

Macro Processing

To invoke the tensor eigensystem add-on with a macro, use the following syntax.
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$!EXTENDEDCOMMAND
  COMMANDPROCESSORID = 'Tensor Eigensystem'
  COMMAND = 'T11VarNum = <varref>\nT12VarNum = <varref>\nT13VarNum =
             <varref>\nT22VarNum = <varref>\nT23VarNum = <varref>\nT33VarNum =
             <varref>\nSortEgnV = <Boolean>\nSaveEgnVect = <Boolean>'

Where <varref> can be an integer or the variable name contained within double quotes.

Time Series

The Time Series add-on, extracts a single point over time and plots the result in a new frame as an XY
Line Plot. The solution time of the time series plot’s frame is linked to that of its parent, and a marker
gridline is added to show the current solution time. If a nearest-point probe is performed (using
Control-click), you may follow a particular node through time, or through an XY(Z) location.

To enable this add-on, uncomment the line with $!LoadAddon "tecutiltools_timeseries" in your
Tecplot.add File or use one of the other methods to load addons described in Add-on Loading.



When tracking a node through time, each zone must have the same node map (or a
shared node map)

This add-on may not work as expected when there are multiple zones in the same
strand at the same solution time.

To use the Time Series add-on, choose one of the following menu options from the Tools menu:

Probe To Create Time Series Plot

This option sets the mouse mode to probe. You can use either the mouse or the Probe At dialog to
probe a point. The probed location will be sampled over time (for transient data) and a resulting XY
Line Plot will be created. If a nearest point probe is done (Control-click), a dialog appears to ask if
you want to track the node or the XY(Z) location through time. If you track the node, it is important
that your data has the same node map for each zone through time.

Send Time Series Data To New Frame

This option creates a new frame for each point extracted. By default, the frame used for the time
series data is reused to avoid creating an excess of frames.

See also: Extract Over Time, Extend Time Macro, Solution Time and Strand Editor, Extend Macro, and
Time Aware.

Write Data as Formatted Text

The Write Data as Formatted Text add-on enables you to write data from an XY Line Plot to a text file in
*.csv format (for comma separated data) or in *.txt format (for any other data separators).
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To enable this add-on, uncomment the line with $!LoadAddon "tecutildataio_excsv" in your Tecplot.add
File or use one of the other methods to load addons described in Add-on Loading. To use it, select
"Write Data As Formatted Text" from the Tools menu. This will open the Write Data as Text File
dialog.

The Write Data as Text File dialog includes the following options:

Choose Frames

Use the Choose Frames region of the dialog to specify which frames to include in the text file.
Choose from the following options:

Active Frame

Select to include the active frame only.

Selected Frames

When "Selected Frames" is active, the box to the right will become sensitive. Use the Shift and
Control keys to select multiple items in the list.

All Frames

Select "All Frames" to include data from all frames in the text file.

Choose Zones

Toggle-off the "All" option to select a subset of zones to include the in text file. Because different
frames may have different zones, this option is available only when "Active Frame" is selected in the

509



Choose Frames region of the dialog.

Choose Variables

Toggle-off the "All" option to select a subset of variables to include in the text file. Because different
frames may have different variables, this option is available only when "Current Frame" is selected
in the Choose Frames region of the dialog.

Value Separator

Use the Value Separator options to specify the delimiter to use in the text file.

Change Variable Format

Click to launch the Change Format dialog. If you choose not to change the variable format, values
will be written in the "best" format, except variables named "Time" or "Date."

Other Text

Toggle-on any of the options in the Other Text region of the dialog to include the desired values in
the text file.

Change Format

Use the Change Format dialog (accessible using the Change Variable Format button in the Write Data
as Text File dialog) to change the format for one or more variables. To change the format for all
variables simultaneously, toggle-on Select All Variables.

Choose a new format with the Select Format section of the dialog. Available formats are Best Float,
Integer, Float, and Exponent. "Best Float" automatically selects either regular floating point or scientific
notation depending on the value and uses as many digits as are necessary to represent the value.
"Float" and "Exponent" use standard and scientific notation, respectively.
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When you have chosen "Float" or "Exponent," you may use the Width.Precision box to specify the
width and precision of your new variable format using a C-style numeric formatting specifier (see
examples following). Width refers to the total number of characters (including the decimal point;
numbers are space-padded on the left if necessary), while Precision refers to the number of places
beyond the decimal point. Precision is a hard limit, while Width is a soft limit: the specified number of
digits of precision are always used, but numbers are not cut off if they do not fit in the specified width
(see second example following). Leading zeroes are not displayed, except for one immediately
preceding a decimal point (that is, for values between -1 and 1).

For example, a Width.Precision of 10.2 yields:

Month,Seattle Rainfall,Dallas Rainfall,Miami Rainfall,Error 1,
1.00, 4.30, 4.00, 4.00, 0.20,
2.00, 4.50, 4.00, 4.10, 0.22,
3.00, 4.00, 3.50, 4.50, 0.24,
4.00, 4.20, 3.40, 4.20, 0.24,

While a Width.Precision of 3.2 yields:

Month,Seattle Rainfall,Dallas Rainfall,Miami Rainfall,Error 1,
1.00,4.30,4.00,4.00,0.20,
2.00,4.50,4.00,4.10,0.22,
3.00,4.00,3.50,4.50,0.24,
4.00,4.20,3.40,4.20,0.24,
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Part 8: Appendices

Command Line Options

Tecplot Focus Command Line

The general form of the Tecplot Focus command line is:

tecfocus [options] [layoutfile] [datafiles] [macrofile]


Most Tecplot Focus command line options are available for Windows operating
systems, not just Linux and Mac. To use them, start Tecplot Focus from the Run
command or at the command prompt (cmd.exe).

Under Windows, invoking Tecplot Focus from the command line or in a .bat file returns immediately
rather than waiting for the application to terminate. If you are using Tecplot Focus to convert files or
run a macro, you probably want to wait until Tecplot Focus has finished one operation before
proceeding with the next. Otherwise, the next step may be working with partially-written data. To do
this, invoke it with start /wait tecfocus followed by the desired options.

Where:

layoutfile

File with extension *.lay or *.lpk. See also Layout Files, Layout Package Files, Stylesheets.

datafiles

One or more data files. If both a layout file (*.lay only) and data files appear on the command line,
Tecplot Focus substitutes the data files referenced in the layout file with the data files listed in the
command line.

macrofile

Macro file name. See also Macros.

options

one or more of the following:

-addonfile filename Supply a custom list of addons via the tecplot.add file.

-b macrofile Run in batch mode.

-c cfgfile Use cfgfile for the configuration instead of the default configuration file,
tecplot.cfg.
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-convert *[This feature is only available in Tecplot 360]* Loads all the specified
data files, and runs specified macros in a restricted batch mode in which the
only permitted options are reading data files (in any supported format) and
writing SZL files. Does not use a license key. See also -o.

-display computername Display on computer computername (Linux only). The target system must
have X-server capability with the GLX extension.

-datafile filename Load data file filename.

-debug dbugfile Send debug information to the file dbugfile. Information is displayed to aid
in debugging a new configuration file, macro file, or binary data file. You
may specify the minus sign ("-") for dbugfile to send the debug output to the
"standard output" (Mac/Linux only).

-f fontfile Use fontfile instead of the default font file, tecplot.fnt.

-h homedir Use homedir for the home directory instead of the default home directory.

--help Open help message for command-line flags.

-loadaddon "
addonname"

Load an add-on named addonname.

-m colormapfile Use colormapfile as the initial color map file.

--max-available
-processors numprocs

Restrict the number of processors (processor cores) employed by Tecplot
Focus to the numprocs specified. Some tasks can be performed in parallel, so
using all available processors greatly increases performance of those tasks.
By default, Tecplot Focus uses all processors available on the machine to
provide the best performance in most cases. Assign a value less than the
total number of available processors to limit the number of processors used
by Tecplot Focus to the assigned number.

--mesa

-mesa (deprecated)

Linux Only – Use a version of the OpenGL rendering library which uses
software rendering (using CPU) rather than hardware rendering (using the
GPU and installed/native drivers). Use this flag in situations when a
graphics card and/or driver do not exist or it is not working. For assistance
troubleshooting see the Troubleshooting Appendix in the User’s Manual.
Mesa libraries are used for both on- and off-screen rendering, if you are
only working in batch use --osmesa. Mesa may be slower and lower quality
on-screen rendering than hardware rendering (using the GPU) but will be
reliable.

For Windows - copy the opengll32.dll from the bin\mesa directory to the bin
directory in order to use mesa rendering.

--mesa-swrast

--osmesa-swrast

Linux Only – Use when the standard versions of mesa and osmesa libraries
conflict with default libraries. Use these options only as a last resort. They
cannot be used with regular --mesa or --osmesa commands.

-nobanner Do not show the opening banner (i.e. splash screen).
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-nobatchlog Suppress creation of the file batch.log during batch mode operation.

-nostdaddons Do not load the add-ons listed in the tecplot.add file.

-notoolbar Run with the toolbar deactivated.

-nowelcomescreen Do not display the Welcome Screen at startup (it may still be opened after
launch from the View menu)

-o outputfile.szplt *[This feature is only available in Tecplot 360]* Writes the specified SZL
file from the data loaded from other files (including macros) specified on
the command line, then exit. Does not require a license key. See also the
-convert command.

--osmesa Linux Only – Use a version of the OpenGL rendering library which is
designed for off screen export using software rendering (using CPU) where
there is no X server connection. OSMesa is automatically used when
running in batch mode without an X server connection. Also use this flag if
Focus or PyTecplot crash in batch mode.

-p scriptfile Play the macro commands in the file scriptfile.mcr.

-q *[This feature is only available in Tecplot 360]* Use quick playback mode.
Ignores delay and pause commands.

-qm quickpanelfile *[This feature is only available in Tecplot 360]* Place the macro functions
in quickpanelfile in the Quick Macro Panel, instead of using the macros from
the default file, tecplot.mcr.

-quiet Turns off all standard-out messages (Linux only).

-r printfile Set the filename for routing Print Files to printfile.

-s stylefile Use stylefile as a stylesheet for the first frame (*.sty).

-showpanel *[This feature is only available in Tecplot 360]* Open the Quick Macro
Panel upon startup.

--use-openssl Linux Only - Force the use of supplied OpenSSL libraries instead of installed
system libraries. For systems with unusual OpenSSL configurations, this
may enable the Load Remote Data option in the file menu (the SZL Client
add-on).

--use-sys Use the libraries from the bin/sys sub-folder below the tecplot home
directory when running Tecplot. The sys sub-folder contains the version of
libstdc++ that was used to build Tecplot and may be required when running
older Linux systems. (Linux only).

-v *[This feature is only available in Tecplot 360]* Display the version
number.

-y exportfile Set the filename for export files to exportfile.

-z Display macro commands in the Macro Viewer. This allows you to see
macro commands prior to their launch.
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Command Line Input Result

tecfocus Run Tecplot Focus without pre-loading any data files

tecfocus ex1.plt Run Tecplot Focus loading the data file ex1.plt as the first
dataset

tecfocus ex1.plt ex2.plt ex3.plt Run Tecplot Focus loading the data files ex1.plt, ex2.plt, and
ex3.plt as the first dataset

tecfocus -h /usr/myhome -c
/usr/myhome/myset.cfg

Run Tecplot Focus using /usr/myhome as the Tecplot Focus
home directory and loading the Tecplot Focus configuration
file /usr/myhome/myset.cfg

tecfocus sumtr1.lay Run Tecplot Focus using layout file sumtr1.lay

tecfocus calc.lay temp.plt Read a Tecplot Focus layout file calc.lay and replace the
first dataset referenced in the layout file with the data file
temp.plt.

tecfocus -p a.mcr Run Tecplot Focus and play a macro called a.mcr

tecfocus infile.dat -o outfile.szplt Reads infile.dat, writes outfile.szplt in batch mode. Does
not require a license.

tec360 -convert conversion.mcr *[This feature is only available in Tecplot 360]* In batch
mode, run the macro file conversion.mcr which may contain
instructions only to read files and write them in .szl format.
Does not require a license.

Using Command Line Options in Windows Shortcuts

All of the command line options that can be entered at the DOS or WCommand prompt by using the
Run command can also be used in a Windows shortcut.

If you frequently run Tecplot Focus using the same command line flags, it may be useful to create a
shortcut on your Windows desktop that launches Tecplot Focus with the desired command line flags.
Here’s how this can be done:


This process may vary slightly in different supported versions of Windows. The
Windows 7 dialogs are shown here.

1. Right click any blank space on your Windows desktop.

2. Select New→Shortcut from the resulting Menu.
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3. In the Create Shortcut dialog, type the location of the Tecplot Focus executable, along with any
command flags you want to specify. An example command line is:

"C:\Program Files\Tecplot Focus 2025 R1\bin\focus.exe" -p C:\Me\mymacro.mcr

You may also click the Browse button to choose the executable using an Open dialog, instead of
typing the path.

4. Click Next.

5. Select a name for your shortcut, then click Finish.

6. A new shortcut icon will be placed on your Windows desktop.

Changing Shortcuts

You can alter an existing shortcut by doing the following:

1. Right-click on the shortcut icon you want to change and select Properties.

2. On the Shortcut page, modify the command line by changing the setting for Target. To change the
working directory that Tecplot Focus runs under, change the Start in location.
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Exit Codes

Upon completing execution, Tecplot Focus returns an exit code, which can be used in scripts to
determine whether a problem occurred. This exit code is 0 (success) if execution completed without
error, or 1 (error) if execution was terminated by an error.

Tecplot Focus Utilities
The following utilities are included with the Tecplot Focus distribution:

• Excel Add-In - Allows you to load Excel spreadsheet data directly into Tecplot Focus from inside
Microsoft Excel.

• LPK View - A utility to catalog, preview or unpack a layout package file into its component data and
layout files.

• Preplot - A utility to convert an ASCII data file into a Tecplot binary file.

• Pltview - A utility to view the header information for a Tecplot binary file.
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Excel Add-In

The Excel Add-In provides a convenient way to load data directly from your Microsoft Excel
spreadsheet into Tecplot Focus. When loaded, it adds a Tecplot section to the Add-Ins ribbon, which
contains a button that lets you open the highlighted region of the spreadsheet in Tecplot Focus. (In
older versions of Excel, previous to the ribbon user interface, this command appears on the Tools
menu and as a button in the toolbar.)



The Excel Add-In is available on Windows platforms only and requires Microsoft
Excel be installed. Visual Basic for Applications, a component of Microsoft Office, must
also be installed; if you receive an error about the workbook having lost its VBA
project, make sure that Visual Basic for Applications is installed by using the Programs
and Features dialog (Add/Remove Programs in older versions of Windows) to modify
your Microsoft Office installation. Visual Basic for Applications can be found under
the Office Shared Features heading in the Office installer.

The Excel add-in features:

Highlight and Plot

It’s easy to plot just a portion of your data. Click in the upper left cell of the region or highlight the
entire region, and then click on the Tecplot button in the Add-Ins ribbon or toolbar or on the Tecplot
option in Excel’s Tools menu.

Multiple Zones

The Excel Add-In makes loading multiple zones much easier. Highlight the entire region and then
click on the Tecplot button in the Add-Ins ribbon or toolbar or on the Tecplot option in Excel’s Tools
menu. If your zones are separated by blank rows or columns, the add-in will automatically detect
them and load them into Tecplot Focus.

Formulas

The highlighted region of the spreadsheet can contain formulas, or can be created entirely with
formulas.

The first time you use the Excel Add-In, you will be prompted to choose the Tecplot Focus executable to
be launched from Excel. This will be the tecfocus.exe file in the bin folder of your Tecplot Focus
installation. Your choice will be remembered and you will not be asked again unless the Excel Add-In
cannot find the previously-chosen executable. A button in the Tecplot section of the Excel ribbon (or
the Tools menu), Find Tecplot, will allow you to choose a different Tecplot Focus executable if you have
upgraded or wish to use the Excel Add-In with more than one installed version of Tecplot Focus.

A Read Me file, located in the Util/Excel directory, further describes installation and use of this add-in.

As an example, let’s say you have 3D data obtained by drilling a number of wells and measuring
contaminant concentrations of various chemicals at different depths. Your data is in an Excel
spreadsheet, and you want to load the data into Tecplot Focus to get a visual representation of the
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contamination. The data has nine variables and twenty-seven zones. A small part is shown in Figure
65.

Figure 65. The beginning well data displayed in Excel.

 Make sure you have a blank row separating the zones in your Excel spreadsheet.

Perform the following steps to import your data and visualize the contaminant plumes:

1. Starting with the top left-hand cell, highlight all twenty-seven zones and nine variables.

2. Click on Tecplot in Excel’s Add-Ins ribbon. The menu option launches Tecplot Focus with the
selected data loaded.

3. Switch to 3D Cartesian plot mode to see the location and measurement depths of the well samples.
The resulting plot is shown in Figure 66.

Figure 66. The Excel well data plotted in Tecplot Focus.
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Your wells have different depths, so the number of measurements are not the same for each well
(there are only three measurements at well five).

LPK View

As a convenience a command line utility, lpkview, is provided to catalog and unpack layout packages.
In its simplest form (when no options were included), the utility to unpack the preview image (if
present), the layout, and all associated data files into the directory in which the utility was run.

For example:

lpkview myplot.lpk

might unpack the following files in the current directory:

myplot.png
myplot.lay
myplot_1.plt
myplot_2.plt
myplot_3.plt

Tecplot Focus determines the names for unpacked files when the package is created. Tecplot Focus
eliminates name conflicts within the package by appending unique numbers to non-unique names.
However, no attempt is made by lpkview to ensure that names are unique with other files located in
the directory where the items are unpacked.

The utility’s syntax is as follows:

lpkview [[-t] | [-ild] | [[-c <preview command>] -p]] filename

Brackets ([]) surround optional parameters and the vertical bar (|) separates one mutually exclusive
set of options from another. The options are described as follows:

-t Show table of contents.

-i Extract image (for example, a Portable Network Graphics or .png format).

-l Extract layout.

-d Extract data.

-c Specify preview command. The executable must be in a directory specified in the PATH or else a
complete pathname. In the specified command, %s is substituted with the path of the temporary
preview image exported by lpkview. (Mac/Linux only)

-p Preview image using the command specified with -c. (Mac/Linux only)
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Option -t may not be used with any other options, and options -i, -l, and -d may not be used with
options -c and -p. If no command line options are specified -i, -l, and -d are assumed by default.

Preplot

The Preplot executable included in the standard Tecplot Focus installation converts Tecplot format
ASCII data files to binary data files. The following options are available:

-d Turn on debug echo. Use -d2, -d3, -d4 for more detailed debug information.

-foreignplt Reverse the bytes of the output binary data file (generally not required).

-iset [zone],
[start], [end],
[skip]

Create the binary data file using only the specified range and skipping for the I-
index. The zone parameter specifies which zone this option affects; if not
specified, all zones are affected. The start parameter is the starting I-index; the
default is one. The end parameter is the ending I-index; the default is the last
index value. The skip parameter specifies the I-interval, that is, the distance
between indices; one means every index is used, two means every other index,
and so on.

For example, -iset 1, 3, 7, 2 indicates that for zone 1 only I-index values of 3, 5,
and 7 are used. Only one -iset option is allowed per zone.

-jset [zone],
[start], [end],
[skip]

Same as -iset above, except with respect to the J-index.

-kset [zone],
[start], [end],
[skip]

Same as -iset above, except with respect to the K-index.

-zonelist
start[:end[:skip]]
, …

Specify the zones to process. You may supply more than one specification. By
default Preplot processes all zones.

Pltview

Pltview is a command line utility to examine the header information for binary Tecplot data files. It is
included in your Tecplot Focus distribution and installed in the bin directory. To run pltview:

1. Launch the Command Prompt

2. Navigate to the bin directory of your Tecplot Focus installation.

3. in the command prompt, type:

pltview "fullpath/filename.plt"

You must enter the full path for your file.
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4. The command prompt will display:

◦ File Name

◦ File Version

◦ File Type

◦ Data Set Title

◦ Number of Zones

◦ Number of Variables

◦ Variable Names

◦ Auxiliary Data

◦ I, J and K Max for each ordered zone

◦ Total number of Nodes, Elements, Faces, as well as the element type, for each finite element
zone

An example session using the pltview utility is shown here.

Shortcuts

Keyboard Shortcuts


On some platforms, Num Lock may interfere with some keyboard shortcuts. If
shortcuts don’t work, try toggling Num Lock.

Rotate Tools

Alt-Click-and-drag Rotate about the viewer position using the active Rotate tool.

Middle-click-and-
drag

Smoothly zoom in and out of the data.
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Right-click-and-
drag

Translate the data.

Control-right-click-
and-drag (Mac:
Command-right-
click-and-drag)

Rotate about the rotation origin (any tool may be active).

C Move the rotation origin to the probed point, ignoring zones.

O Set the center of rotation.

R Switch to Rollerball rotation.

S Switch to Spherical rotation.

T Switch to Twist rotation.

X Switch to X-axis rotation.

Y Switch to Y-axis rotation.

Z Switch to Z-axis rotation.

Contour Add Tool

Alt-click Place a contour line by probing on a streamtrace, slice, or iso-surface.

Click Place a contour line.

Control-click Replace the nearest contour line with a new line.

Click-and-drag Move the new contour line.

- Switch to the Contour Remove tool.

Contour Remove Tool

Click Remove the contour line nearest to the probed location.

+ Switch to the Contour Add tool.

Geometry Polyline Tool

A Allow translation of polyline segments in all directions.

H Restrict translation of the current polyline segment to horizontal.

U End the current polyline at last clicked point and start a new one.

V Restrict translation of current polyline segment to vertical.

Probe Tool
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Click If the pointer is over a single valid cell, the interpolated field values from all
nodes in the cell are returned.

If multiple cells are candidates, the action is dependent upon the plot type:

• For 2D, the cell from the highest number zone is used.

• For 3D, the cell closest to the viewer is used.

Control-click If the pointer is over a single valid cell, the field values from the nearest node in
the cell are returned.

If multiple cells are candidates, the action is dependent upon the plot type:

• For 2D, the cell from the highest number zone is used.

• For 3D, the cell closest to the viewer is used.

If the pointer is not over any cell, then the field values from nearest data point
(as measured in distance on the screen) are returned.

Shift-Control-click The field values from the nearest point on the screen are returned (ignoring
surfaces, zone number, and depth of the point).

This is useful in 3D for probing on data points that are on the back side of a
closed surface without having to rotate the object. In 2D, this is useful for
probing on data points for zones that may be underneath other zones.

Alt-click Probe only on streamtraces, iso-surfaces, or slices.

If multiple cells are candidates, the action is dependent upon the plot type:

• For 2D, the cell from the highest number zone is used.

• For 3D, the cell closest to the viewer is used.

Alt-Control-click Probe only on streamtraces, iso-surfaces, or slices.

If multiple cells are candidates, the action is dependent upon the plot type:

• For 2D, the cell from the highest number zone is used.

• For 3D, the cell closest to the viewer is used.

If the pointer is not over any cell, then the field values from nearest data point
(as measured in distance on the screen) are returned.

Alt-Control-Shift-
click

Probe only on streamtraces, iso-surfaces, or slices. The field values from the
nearest point on the screen are returned.

X, Y

T, R

When probing, press X or Y in XY Line to switch dependencies, or R or T in Polar
Line.
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Slice Tool

+ Turn on start/end slices, or increment the number of intermediate slices.

- Turn off start/end slices, or decrement the number of intermediate slices.

Click If no slices are displayed for the current slice group, place the primary slice.
Otherwise, move the closest displayed start, end, and primary slice from its
current position to the clicked position.

Alt-click Place the start, end, or primary slice (whichever is closer to the click position) on
the nearest derived object (streamtrace, slice or iso-surface).

Control-click Place the start, end, or primary slice (whichever is closer to the click position) on
the nearest data point.

I, J, K Switch to slicing constant I, J, or K-planes, respectively. Available for ordered
zones only.

X, Y, Z Switch to slicing constant X-, Y-, or Z-planes, respectively.

A Switch to arbitrary slice mode.

1-8 Switch between slice groups.

Streamtrace Placement tools (3D Cartesian plots only)

D Change the streamtrace style to streamrods.

R Change the streamtrace style to streamribbons.

S Change the streamtrace style to surface lines.

V Change the streamtrace style to volume lines.

1-9 Change the number of streamtraces to be added when placing a rake of
streamtraces.

Translate Tool

- Reduce the magnification of the data.

+ Increase the magnification of the data.

Drag Translate the data.

Shift-drag Translate the paper.

Shift - - Reduce the magnification of the paper.

Shift - + Increase the magnification of the paper.

Zoom Tool

Click Center the zoom around the location of your click.
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Control-click Center the zoom around the location of your click and zoom out.

Drag Draw a box to set the frame view.

Selector Tool

Click Select the frontmost object at the clicked location.

Control-click Select the next object behind the currently selected object ("dig").

Shift-click Multiple selection. Click the first object, then shift-click subsequent objects to add
them to the selection

Alt-click Ignore zone objects when selecting.

Selected Object Options

- Reduce the size of the object. If multiple objects are selected, all object positions
will be shifted towards the first object selected.

+ Increase the size of the object. If multiple objects are selected, all object positions
will be shifted away from the first object selected.

Delete Delete selected object(s).

Control-C Copy selected object(s) to the clipboard.

Control-V Paste selected object(s) from the clipboard.

Control-X Cut selected object(s) to the clipboard, deleting them from the plot.

Time Navigation

Home Jump to start.

Left Arrow Step backward.

Space bar Play or pause animation.

Right Arrow Step forward.

End Jump to end.

Other Keyboard Operations

Control-F Fit Surfaces (3D Only) - Resize plot so that all surfaces are included in the frame,
excluding any volume zones.

Fit to Full Size (2D, XY, Polar, Sketch) - Fit the entire plot into the frame (including
data, text and geometries).

Control-E Fit Everything (3D Only) - Resizes plot so that all data points, text, and geometries
are included in the frame.
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Control-L Last - Restore the last frame view.

Control-O Open a layout file.

Control-P Print.

Control-Q Exit.

Control-R Redraw the current frame.

Control-S Save the current layout to its file.

Control-W Save the current layout to a specified file.

Extended Mouse Operations

The middle and right mouse buttons are powerful tools you may use to immediately zoom and
translate your data without having to switch to the Zoom or Translate tools on the Toolbar. This
advanced mouse/keyboard functionality is available when using any 3D rotate, Contour, Geometry
(except Polyline), Probe, Slice, Streamtrace Placement, Translate, Zoom, or Zone Creation tools. If you
have a two button mouse use the Control key in conjunction with the right mouse button to achieve
middle mouse button capabilities.

The following table lists all of the capabilities of the middle and right mouse buttons, when the active
mouse tool is the "Selector"  or the "Adjustor". 

Action Middle Button[11] Right Button

Click Redraw. If the pointer is in the
active frame, Tecplot Focus will
redraw the active frame.
Otherwise, redraw all frames.

Switch from the current tool to
the Selector.

Drag Smoothly zoom in or out. An
upward motion zooms out. A
downward motion zooms in.

Translate.

Alt-Drag In 3D Cartesian plots, move the
viewer further from (upward
motion) or closer to (downward
motion) the object. In all other
plot types, this behaves like the
Drag action

Smoothly zoom in or out. An
upward motion zooms out. A
downward motion zooms in.

The above actions (and other mouse gestures) are configurable by editing your tecplot.cfg file. Find
the $!INTERFACE MOUSEACTIONS command and look for the MIDDLEBUTTON or RIGHTBUTTON section within
that command.
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License Management

Entering Your License

The first time you launch Tecplot Focus after a fresh installation, you will be prompted to enter your
license information:

You will also see this dialog if Tecplot Focus cannot validate your license information (for example,
because your evaluation license has expired, or because the network license server is not available).
Additionally, you may change your license information at any time from the Help menu.



Tecplot products store their license configuration file in a platform-specific location.
Each Tecplot product has its own license configuration file.

Windows: C:\Users\<username>\AppData\Local\Tecplot
Linux: ~/.local/share/data/tecplot
Mac: ~/Library/Application Support/Tecplot

The above directories are specific to the individual workstation users. If you want all
users of the computer to use the same license configuration for a given Tecplot
product, you may move the license configuration file to the product installation
directory after initial license setup.
To prevent users from editing the license configuration, you may then change the
permissions on the license file to be writable only by an administrator or root user.
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How you install your license information depends on what type of license you have.

• If you wish to evaluate the product before purchasing, you may obtain an Evaluation license with
a single click. See Evaluation License Setup.

• If you have an Activation Code for a Single-User license and have Internet access, you enter the
activation code. See Single-User License Setup Using An Activation Code.

• If you have a License File for a Single-User license, you select the license file. See Single-User
License Setup Using A License File.

• If you have a Network license, you specify the server name and port number of the RLM license
server on your network. Network License Setup.

• If you have a License File for a Single-User license, you select the license file. See Single-User
License Setup Using A License File.

Evaluation License Setup

To obtain a time-limited evaluation license key so you can try the product before purchasing, make
sure the "Evaluation" license type is selected in the Licensing dialog, then click Begin Evaluation. The
product evaluation period begins. You will see a notice on the product’s Welcome Screen indicating
when your evaluation license will expire.

This procedure requires an active Internet connection. If for some reason you cannot fully evaluate
Tecplot Focus on an Internet-connected computer, or if you need additional time to complete your
evaluation, contact Tecplot Support for a time-limited single-user license file, which may then be
installed using the instructions in Single-User License Setup Using A License File.
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Single-User License Setup Using An Activation Code

If you received an activation code for your product, allowing it to be activated over the Internet, follow
the instructions below. If you received a license key file, or if the workstation you have installed the
product on does not have Internet access, see Single-User License Setup Using A License File.

To activate the product, simply enter or paste your activation code in the field provided. Then click
Activate.

The license key corresponding to your activation code is downloaded to your computer, and Tecplot
Focus uses that license.

Single-User License Setup Using A License File

You will need the license file sent to you by Tecplot as an e-mail attachment. Please save it to a file on
your computer in an easy-to-find location, such as the Desktop.


If you do not have your license file, or have lost it, click Request License in the
Licensing dialog for instructions on how to obtain it.
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1. Make sure the "License File" option is selected in the Licensing dialog.

2. Click Open License File. A file browser appears. Select the license file e-mailed to you, then click
Open.
Alternatively, you can Copy and Paste the contents of the license file to the available field.
The message "Status: Valid" appears in the Current License Information panel at the upper right.

3. Click OK to save the license information.

Tecplot Focus now uses the chosen license.

If your license requires a USB license security key ("dongle"), make sure it is connected to your
computer before launching Tecplot Focus. It must remain connected while the product is running.

Network License Setup
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To use a network license, you or your system administrator must first install the Reprise License
Manager (RLM) version 11 or newer and the license key for your product on a network server. (See the
installation instructions included with the RLM download.) Once this has been accomplished, follow
these steps:

1. Make sure the "Network" license type is selected in the Licensing dialog.

2. Enter the server name (you may use a hostname or IP address) and port number of the license
server in the fields provided.

3. Click OK to save the license information.

Tecplot Focus will now use a license obtained from the license server.

If the product is unable to obtain a license key, an error message will appear, and you should verify
that you have specified the correct network license information.

License Roaming
Network license users who need to use Tecplot Focus while not connected to the same network as their
license server (for example, while traveling) can use license roaming. License roaming allows you to
use the product without access to the license server for a limited period of time. The roaming license is
considered "in use" by the server continuously until it expires or is returned.

To manage license roaming, choose License Roaming from the Help menu. The License Roaming
dialog appears.
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Starting Roaming



If you are on a mac then there is one more requirement before you can begin
roaming. That being the folder "/Library/Application Support/Reprise" must be
writable by all users. If this is not the case you must do the following using a login that
has sudo privileges:

sudo mkdir -p "/Library/Application Support/Reprise"
sudo chmod 777 "/Library/Application Support/Reprise"

To start roaming, choose the expiration date for the roaming license using the pop-out calendar that
appears when you click the roaming expiration date. Your license will expire at the end of that day, at
midnight.


To account for time zones, we suggest roaming for a day longer than you think you
need when you will be traveling.

Click Begin Roam to obtain the roaming license and begin roaming.



The license server administrator and the license key may restrict the maximum
amount of time users may roam and/or the total number of licenses that may roam at
a given time. Additionally, only one instance of Tecplot Focus may be run while
roaming.

While roaming, the license status is noted as Roaming in the Licensing dialog, and the expiration date
of the roaming session is also shown. You may not change license information while roaming.
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When you are getting close to your roaming license’s expiration date, a notification appears in the
Welcome Screen at startup.


Do not upgrade Tecplot Focus while roaming. If you do, your license may no longer
work correctly. Set the RLM_ROAM environment variable to -100 before launching to
rectify this situation (see RLM_ROAM).

Ending Roaming

Your roaming license expires automatically at the end of the day (that is, midnight) on the day you
selected when you began roaming. After this date, your computer must be able to connect to the
network license server to run Tecplot Focus.

You may also end roaming early and make your license available for other users. To do this, you must
first connect your computer to a network that allows you to reach the license server. Then choose
License Roaming from the Help menu and click the End Roam button in the License Roaming dialog.

RLM_ROAM

You can initiate roaming from the command line by setting the RLM_ROAM environment variable to the
number of days you wish to roam, then starting Tecplot Focus from that command line session. The
roaming session expires at the end of the day after the number of days specified (for example, if it is
noon Tuesday, and you set RLM_ROAM to 2, the roaming license expires at the end of the day Thursday).
RLM_ROAM may also be set to the special value today to have the roaming license expire at the end of the
current day (the value 0 means that no changes to roaming will be made).

If RLM_ROAM is set permanently (for example, using the System Properties in Windows), the license
roaming will be refreshed each time you run Tecplot Focus while connected to the network. If
RLM_ROAM is 1, for example, each time you start Tecplot Focus, the roaming license is refreshed to
expire at midnight the following day. This allows you to easily take your computer home with you any
night and continue using Tecplot Focus while disconnected from the license server, without needing to
explicitly roam each day.

You may end a roaming session early by setting RLM_ROAM to 1 before launching Tecplot Focus.

 If you are having trouble ending your roaming early (a common cause is upgrading
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Tecplot Focus while roaming), try setting RLM_ROAM to -100 before launching Tecplot
Focus. The roaming license will be forcibly removed from your workstation, and
Tecplot Focus will begin requesting a regular license from a license server at each
startup. At this point you can obtain a fresh roaming license, if desired. The
reservation for your previous roaming license will, however, continue to be held on
the license server that issued it until it expires.

LaTeX Setup
A few requirements are needed before LaTeX outputs can be generated. The first is to have a LaTeX
engine installed. LaTeX distributions are largely free and available on many different operating
systems. For installation recommendations, see the LaTeX Project page.

The second requirement is to have the tecplot_latex.mcr file correctly configured in your installation
directory. Each LaTeX engine will come configured with different ways to parse commands. Details of
how to configure it can be found in the tecplot_latex.mcr file. The default settings have been tested
with MiKTeX and TeXLive engines. If using the default install options for MiKTeX, the amscls and
zhmetrics packages will also need to be installed.

For information on how to load a custom tecplot_latex.mcr file, see Custom Files loaded on Startup.

Troubleshooting

Rendering and Export Troubleshooting

As a software with high graphical and rendering requirements, Tecplot Focus has a few alternative
libraries and configurations which allow use on machines which have limited graphics hardware.
Some example cases where these configurations may be needed include use on HPC systems, X-Display
or other remote desktop solutions.

Sample Interactive Rendering and Export Test

Try these steps. If you have any problems check the OS specific section below.

1. Start Focus

2. sample data:

a. Create data from: Data → Create → Create Rectangular Zone.

b. Select defaults to create the zone

c. Turn on contour checkbox on the plot sidebar.

3. Try interacting with the plot:

a. <Ctrl> + right mouse drag to rotate the plot

b. click to display the context menu
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c. click and drag to select multiple objects in the plot.

4. Go to File → Export, use default PNG settings and select a place to save a sample image. Once export
is complete, ensure that the image was created as expected.

Linux Troubleshooting for Interactive Rendering and Export

The following is a set of tests to determine what are the best set of rendering command line options for
a Linux system. Run each test in order and STOP when a test was successful.

1. Run tecfocus without any additional command line arguments and step through the sample test
above. If everything is successful and performant continue to use Tecplot Focus this way.

2. If any of the sample steps failed:

a. Ensure your graphics drivers are up to date. If you are using native Linux drivers (usually
nouveau) try installing drivers supplied by your graphics card manufacturer.

b. If you are on the most up to date drivers, try tecfocus --mesa, then repeat the sample test above.
Mesa uses software rendering and will be slower than using graphics hardware but will be the
most reliable software rendering option. See the --mesa option in Command Line Options for
additional information.

If you struggled following these steps or none of these solutions worked, contact support@tecplot.com.

Linux Batch Mode Troubleshooting

On some systems with limited graphics resources Tecplot Focus may crash in batch mode. If this occurs
run tecfocus –b --osmesa.

If you are running PyTecplot scripts in batch mode you will also need to use the osmesa libraries. For
example:

tecfocus-env --osmesa -- python myscript.py

To run these with PyTecplot see the environment setup section of the pytecplot installation notes.

tecplot.azureedge.net/products/pytecplot/docs/install.html#environment-setup-batch-only

 PyTecplot is a feature only available in Tecplot 360.

Windows Troubleshooting

When remoting to or running on some windows systems, either in rendering the work area or during
export, you may encounter an error similar to:
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This error indicated that the graphics drivers on the machine are not sufficient. In this case, find the
mesa version of the OpenGL library in C:\Program Files\Tecplot\Tecplot Focus 2022
R2\bin\mesa\opengl32.dll and copy it to the bin directory C:\Program Files\Tecplot\Tecplot Focus 2022
R2\bin. This will enable software rendering for the Windows version of Tecplot Focus.

Note that in some cases this same error is presented when exporting images with larger extents. If you
are seeing this error exporting images know that in most cases super sample factors larger than 3
show no increase in render quality. As such, try with smaller width and do not go over 3 for a super
sample factor.

Mac Troubleshooting

Most, if not all Mac systems, have stricter hardware and software requirements for running MacOS. As
such Tecplot Focus does not currently supply any alternative rendering libraries or options today.
Contact support@tecplot.com if you need assistance.

Glossary
The following terms are used throughout the Tecplot Focus User’s Manual and are included here for
your reference.

2D Plotting in two dimensions. Line plots of one or more variables (XY and
Polar Line plots) are not considered.

2D Cartesian Plot A plot displaying a 2D scattering of points, surfaces, or volumes using two
orthogonal axes.

3D Plotting in three dimensions. Three-dimensional plotting can be subdivided
into 3D surface and 3D volume.

3D Cartesian Plot A plot displaying a 3D scattering of points, surfaces, or volumes using three
orthogonal axes.
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3D Sorting The process that Tecplot Focus uses to determine which surface to plot first.
In this process, the cells are sorted relative to the viewer and plotted
beginning with the farthest point away and ending with the closest. Sorting
is used when printing 3D plots or rendering translucent 3D objects on the
screen.

3D Surface Three-dimensional plotting confined to a surface. For example, the surface
of a wing.

3D Volume Three-dimensional plotting of data that includes interior data points of a
volume, as well as those on the surface. For example, the vector field
around a wing.

Active Zone A zone that is displayed in the active plot, as determined in the Zone Style
dialog.

Add-on Any component or program which provides additional functions to Tecplot
Focus.

ADK Add-on Developer’s Kit designed to create add-ons for use with Tecplot
Focus.

Anchor point The fixed point of an object on the plot.

Antialiasing The process of removing or reducing the jagged distortions in curves and
diagonal lines.

ASCII Data File A data file composed of code in a human-readable and editable format,
using the ASCII character set encoding.

Aspect Ratio The ratio of lengths of the sides of an object. In the 3D Cartesian plot type,
the ratio is that of the longest side to the shortest side.

Auxiliary Data Metadata attached to zones, datasets, and frames.

Banded Contour
Flooding

A field plot where the region between contour lines is filled with a constant
color that corresponds to each variable.

Bars Mapping Layer Mapping Layer (XY line plots only) where bars are used to depict the
relationship between the dependent and independent variables.

Binary Data File A data file composed of machine-readable data. This type of file is created
by converting ASCII data files with Preplot, or by directly creating them
from an application.

Blanking A feature of Tecplot Focus that excludes certain cells and points from a plot.

Block A data file format in which the data is listed by variable. All the point values
of the first variable are listed first, then all the point values of the second
variable, and so forth.
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Boundary Cell Faces A set of un-blanked cell faces in a 3D volume zone which have only one
neighboring volume cell. In contrast, interior cell faces have two
neighboring volume cells, one on either side, which share the face. For an
IJK-ordered zone the boundary cell faces are on the exterior of the zone.
That is, the first and last I-planes, the first and last J-planes, and the first and
last K-planes. For a finite element 3D volume zone, boundary cell faces are
on the exterior of the zone and the surface of any voids within the zone.

Bounding Box of Data The smallest rectangular box, aligned with the coordinate axes, which
completely encloses all data points.

Brick An element type of finite element volume data composed of eight node
points arranged in a hexahedron-like format. This element type is used in
3D volume plotting.

Carpet Plot A 3D surface plot where a variable is plotted in the third dimension and is
singular-valued with respect to the independent variables.

Cartesian Plot A 2D or 3D plot of some variable by location on a single plane using two
axes (or in a volume using three axes).

Cell Either an element of finite element data, or the space contained by one
increment of each index of IJK or IJK-ordered data.

Cell-centered Values Values located at the center of the cell (assumed to be the centroid).

Code Generator Add-on that generates style value code for any style changes made in the
Tecplot Focus user interface.

Coordinate Any of a set of numbers used in specifying the location of a point on a plot.

Configuration File File (tecplot.cfg) containing Tecplot Focus defaults. See Configuration Files.

Color Map A color spectrum used to plot contour flooding and multi-colored objects.

Connectivity List The portion of a finite element data file which defines the elements or cells
by listing the relationships between points. The number of points per cell is
determined by the element type.

Continuous Contour
Flooding

A field plot where a color is assigned to each point in a mesh, based upon
the contour variable and the color map. Each face is filled with colors
interpolated between the corner nodes. This results in a smooth variation of
color over the surface.

Contour A field plot type that plots iso-valued lines, or color flooding based on the
values of a specified variable.

Curve Type The function used to fit the data points in an XY-plot.

Custom Labels Text strings contained within a data file or text geometry file which define
labels for your axes or contour table. You may select Custom Labels
anywhere you can choose a number format, the result is the text strings in
place of numbers.
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Cutaway Plot A 3D volume plot where a portion of a 3D volume zone is cut-away by
blanking to reveal the interior.

Cutting Plane A planar surface used to slice 3D volume or surface zones.

Data File A file that contains data used for plotting in Tecplot Focus.

Data Format The type of zone data as specified by the format parameter in a Tecplot data
file, such as BLOCK or POINT.

Data Loader A Tecplot Focus add-on which allows you to read non-Tecplot data files.

Data Point An XYZ-point at which field variables are defined.

Data Smoothing A process that shifts the value of a variable at a data point towards an
average of the values at its neighboring data points to reduce "noise" and
lessen discontinuities in data.

Dataset A set of one or more zones. A dataset may be plotted in one or more frames.
However, a single frame may only plot one dataset. A dataset may be
created by loading one or more data files.

Dependent An axis mode requiring the axes to maintain a fixed ratio to one another.

Depth For image export, the number of bits stored per pixel.

Depth Blanking A blanking option which excludes cells in a 3D plot, based upon their depth
into the image. Cells closer than a plane of a certain depth, as well as cells
further than a plane of another depth, may be blanked.

Derived Volume Objects Graphic objects which are visible in the plot and created from zone data,
but are not zones, i.e. an Iso-Surface, a Slice, or a Streamtrace.

Display List A group of OpenGL commands that have been stored for subsequent
execution. Using a display list can, depending upon the hardware involved,
dramatically speed up graphics rendering. Using display lists also requires
more memory.

Draw Level A draw behavior setting for modifying the image quality and rendering
speed during various operations, such as rotation. Options vary from Trace
(a simplified wire-frame mesh which is rendered quickly) to Full.

Dynamic Text Special placeholders added to text that change with the data or the display
environment.

Edge A 2D or 3D field plot option. Plotting the edge of a zone plots the connection
of all outer lines (IJ-ordered zones), finite element surface zones, or planes
(IJK-ordered zones).
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Element Type The form of individual elements in a finite element zone. There are four
types of cell-based finite element zones: Triangle and Quadrilateral (finite
element surface types), and Tetrahedron and Brick (finite element volume
types). For cell-based finite elements, the element type of a zone determines
the number of nodes per element and their orientation within an element.
There are two types of face-based finite element zones: polygonal (2D) and
polyhedral (3D). For face-based elements, the number of nodes per element
is variable.

Error Bars Mapping
Layer

XY Line mapping layer where a second dependent variable (error) is used to
show the accuracy of the first dependent variable, typically used in
conjunction with the Bars Mapping Layer.

Exposed Cell Faces The set of those cell faces in 3D volume zones that have only one un-blanked
neighboring volume cell. By comparison, interior cell faces have two
neighboring cells, one on either side, which share the face. The exposed cell
faces include boundary cell faces and interior cell faces exposed by
blanking. (One of the neighboring cells has been blanked.)

Extended Curve-fit A Tecplot Focus add-on which extends Tecplot Focus’s XY-plot curve-fitting
capabilities.

Eye Coordinate System Coordinate system aligned with the Grid coordinate system so that objects
that are drawn move with the data as you zoom and translate, but remain
fixed when you rotate the plot.

Extra 3D Sorting Perform extra work to resolve hidden surface problems encountered during
3D sorting.

Face Neighbor A neighboring cell whose faces share all nodes in common with the selected
cell.

FE An abbreviation for finite element (a common means of arranging data for
calculations, often referred to as "unordered" or "unstructured").

FEA *[This feature is only available in Tecplot 360]* An abbreviation for finite
element analysis.

Fence Plot A plot of planes of a 3D data field.

FE Surface A finite element zone of the element type Triangle or Quadrilateral, or
Polygon  (360 Only). These zones are used for 2D and 3D surface plots.

FE Volume A finite element zone of the element type Tetrahedron or Brick, or
Polyhedron  (360 Only). These zones are used for 3D volume plots.

Field Map A collection of zones for 2D and 3D field plots. A common style can be easily
applied to all zones in the selection.
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Field Plot Includes 2D Cartesian and 3D Cartesian plot types. Generally used to display
the spacial relationship of data. Mesh, Contour, Vector, Scatter, and Shade
are all considered field plots. XY and Polar Line plots and the Sketch plot
type are not field plots.

File Path A way to specify the directory for Tecplot Focus to locate a given file. For
instance, a linked layout saved with an absolute file path contains the
complete directory structure to load the associated file starting with the root
directory or (on Windows) the drive letter.

Finite Element A type of data point ordering. Data is arranged by listing the data points
(called nodes), and then listing their relationships (called elements). The
element type of the zone determines the number of nodes which are
contained in each element, as well as the exact relationship of nodes within
an element. There are six different element types supported by Tecplot
Focus: Triangle, Quadrilateral, Brick, Polygonal (360 Only), and
Polyhedral. (360 Only) See also Connectivity List and node].

Font Modifier The modifier used to embed Greek, Math, or User-Defined characters in a
text string.

Frame Area within the workspace where sketches and plots are created. The
workspace shows a page at a time, and each page can contain multiple
frames.

Frame Coordinate
System

Coordinate system fixed to the frame that does not change when the plot is
zoomed, translated, or rotated.

Gouraud Shading Shading used to achieve smooth lighting on low-polygon surfaces by
linearly interpolating a color or shade across a polygon.

Grid Area One or more rectangular regions defined and bounded by the grid axes.

Grid Axes An axis option which displays the coordinates of the grid along the various
spatial dimensions.

Grid Coordinate System The grid coordinate system consists of two dimensional physical
coordinates that are aligned with the coordinate system used by the plot
axes.

Gridline A set of lines drawn from one or more axes that extend from the tick marks
on an axis across the grid area.

Grid Point In 2D, the intersection of gridlines.

Hidden Line Mesh type where mesh lines that appear behind other plot layers are not
drawn.
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I-Ordered A type of data point ordering where each point is listed one at a time (that
is, by one index). Used mainly in XY plots. In 2D or 3D, this type of data point
ordering is sometimes called irregular, and is only useful for scatter plots,
or for interpolating or triangulating into 2D, 3D surface, or 3D volume
zones. (This type of data can also be used for 2D or 3D vector plots if
streamtraces are not required.)

IJ-Ordered A type of data point ordering where the points are arranged in an array
used for 2D and 3D surface plotting.

IJK-Blanking A feature to include or exclude portions of an IJK-ordered zone based on
index ranges.

IJK-Ordered A type of data ordering where the points are arranged in a 3D array. Used
for 3D volume plotting as well as 2D and 3D surface plotting.

Image Format Any of the raster or bit-mapped graphic formats supported by Tecplot Focus.

Inactive Zone A zone loaded into Tecplot Focus which does not appear in the plot. A zone
can be deactivated using the Zone Show option on any page of the Zone
Style dialog.

Independent Axis mode allowing each axis to have a range that is not affected by the
ranges of any other axis or axes.

Interpolate To assign new values for the variables at data points in one zone based on
the data point values in another zone (or set of zones).

Interpolate Mode When probing is activated using a single mouse click, the value returned is
linearly interpolated from all nodes in the cell. See also: Nearest Point Mode.

Internal Macro Variable A read-only macro variable which allows you to access certain key values in
Tecplot Focus. For example, $NUMVARS gives the number of variables.

I-Plane In an ordered zone, the connected surface of all points with a constant I-
index. In reality, I-planes may be cylinders, spheres, or any other shape.

Irregular Data Points which have no order, or at least no order which can be easily
converted to IJK or IJK-ordering.

Iso-Surface A surface within a 3D zone where the contour variable has a constant value
at all locations.

Journal Log of data manipulation/creation/deletion instructions.

J-Plane In an ordered zone, the connected surface of all points with a constant J-
index. In reality, J-planes may be cylinders, spheres, or any other shape.

Kriging A technique to interpolate the value of a random field at an unobserved
location from observations of its value at nearby locations.

K-Plane In an IJK-ordered zone, the connected surface of all points with a constant
K-index. In reality, K-planes may be cylinders, spheres, or any other shape.
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Layout File A specialized macro file with extension .lay which preserves a plot created
within Tecplot Focus. When the layout is opened, it restores Tecplot Focus to
the state it was in when the layout file was saved.

Layout Package File A binary layout file with the .lpk extension which has the data embedded in
the file.

Line Map A set of points from a single zone where one variable is assigned to an X-
axis and another is assigned to a Y-axis. You can define many XY-maps for
an XY-plot.

Macro A file containing a list of instructions, called macro commands, which can
duplicate virtually any action performed in Tecplot Focus.

Macro Command An instruction given to Tecplot Focus in a macro file. Macro commands
always start with a dollar sign and then an exclamation mark. For example,
$!Redraw refreshes a plot view.

Macro File A file which contains a series of macro commands. Macro files are run from
the command line, or through the Play option of the Scripting menu.

Macro Function A self-contained macro sub-routine.

Macro Variable A holding place for numeric values in a macro file. There are two types of
macro variables: user-defined (you set and retrieve the value), or internal
(Tecplot Focus sets the value and you may retrieve it).

Map Layer One way of displaying a line mapping, such as with line, bars, symbols, and
so forth. One mapping may be displayed with one or more layers.

Median Axis In 3D, the grid axis which when scaled is not the shortest nor the longest
axis.

Menu Bar The top bar of the Tecplot Focus screen used to select menu options.

Mesh A 2D or 3D field plot type which plots connections between data points.

Multi-Colored Any Tecplot Focus object which is colored by the value of the contouring
variable. Multi-colored objects may include mesh, scatter symbols, vectors,
contour lines, and streamtraces.

Nearest Point Mode When probing is activated using a Control+click, the value returned is the
precise value of the closest data point. See also: Interpolate Mode.

Node A point in finite element data.

Number Format The style of numbers to display for a data or axis label; exponent, integer,
float, and so forth.

OpenGL A graphics library for high-end 3D graphics. It commonly takes advantage of
hardware acceleration for 3D rendering.

Ordered Data A type of data point organization which consists of a parameterized series
of points. There are seven types of ordered data: I, J, K, IJ, JK, IK, and IJK-
ordered. I, IJ, and IJK-ordered are the most common.
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Orthographic Projection A plot view in which the shape of the object is independent of distance.This
is used for displaying physical objects when preserving the true lengths is
important.

Overlay Mesh type where mesh lines are drawn over all field-plot layers, except for
vector and scatter layers.

Pick Select an item in the plot area by clicking on it with the mouse.

Plot Type Determines the type of plot which is displayed in a frame. For example, 2D
Cartesian plot, 3D Cartesian plot, XY Line plot, Polar Line plot, or Sketch
plot.

PLOT3D A plotting package developed by NASA.

Polar Line Plot A plot of radius versus angle, or vice versa. The polar axes are the radial
axis (by default zero at the origin) and theta axis (by default zero for any
data on the right running horizontal line).

Polygonal *[This feature is only available in Tecplot 360]* A 2D, face-based finite
element type. The number of nodes per element is variable. That is, a single
polygonal zone may contain triangular, quadrilateral, hexagonal, …, etc.
elements.

Polyhedral *[This feature is only available in Tecplot 360]* A 3D, face-based finite
element type. The number of nodes per element is variable. That is, a single
polyhedral zone may contain tetrahedral and brick (and other) elements.

Polylines *[This feature is only available in Tecplot 360]* A shape composed of one
or more joined line segments. May be closed (i.e., a polygon) or open.

Polytope The generalization to any dimension of "polygon" in two dimensions,
"polyhedron" in three dimensions, and "polychoron" in four dimensions

Pop Bring selected geometries or text to the top of the viewstack.

Precise Dot Grid The points of intersection of the imaginary lines extending from the X- and
Y-axes' tick marks.

Primary Corner The point in an ordered zone’s cell that has the minimum index values for
that cell, or the first listed node of a finite element cell.

Probe To obtain interpolated values of the dataset variables at a specified location
by clicking on a point in the data region.

Push Send selected geometries or text to the bottom of the viewstack.

Quadrilateral An element type of finite element surface data which is composed of four
node points arranged in a quadrilateral. Used in 2D and 3D surface plotting.

Quick Macro Panel A user-defined panel accessed from the Scripting menu which allows quick
access to your macro functions.

Rake A line along which a number of streamtraces may be seeded.
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RGB Color Flooding The assignment of color based on Red, Green, and Blue components defined
at field data locations.

Ribbon (See Streamribbon.)

Richardson
Extrapolation

A sequence acceleration method, used to improve the rate of convergence of
a sequence.

Rod (See Streamrod.)

Scatter A 2D or 3D field plot type which plots a symbol at each data point.

SDK A Tecplot software development kit, providing a library that integrates
visualization capabilities into an application.

Shade Plot A 2D or 3D field plot type which plots solid color or colors with lighting
effect over the cells of the data.

Sharing Variable sharing allows a single storage location to be used by more than
one party. For example, if the X-variable is shared between zones five and
seven, only one storage location is created. The storage is not freed by
Tecplot Focus until the number of parties accessing the data is reduced to
zero. Variables and connectivity information may be shared.

Sidebar A movable, dockable panel (by default located on the left side of the Tecplot
Focus window) which provides quick access to frequently-used
functionality. Tecplot Focus includes multiple sidebars: Plot, Frames, Pages,
Probe, and Quick Macro.

Sketch Plot A plot which displays only text and geometries, not any data-derived
elements.

Slice A set of data created by the intersection of a plane with 3D zones.

Snap-to-Grid Lock any object on the screen to the closest grid point. The position and size
of the object will be affected by changes to the grid.

Snap-to-Paper Lock any object on the screen to the underlying paper. The position and size
of the object will not be affected by changes to the grid.

Sorting The process of resolving hidden-surface problems during display of a 3D
plot.

Specular Highlights Highlights with qualities similar to those of a smooth reflecting surface such
as metal, where light is reflected so intensely from some points that the plot
appears white (or the color of the light) at those points.

Status Line The bar located at the bottom of the Tecplot Focus screen which provides
"hover" help for tools and acts as a progress bar during calculations.

Strand A series of transient zones that represent the same part of a dataset at
different times.

Stream Particle traces through a vector field.
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Stream Format The type of streamtraces being placed in Tecplot Focus. For example,
Surface Line, Volume Line, Volume Ribbon, or Volume Rod.

Streamline A 2D or 3D line which is parallel to the vector field along its entire length.
For a steady state vector field, this is the same as a simple particle trace
which marks the path of a massless particle in the vector field.

Streamribbon A particle trace with a width which not only follows the flow field (its center
being a regular streamline), but which also twists with the vorticity of the
vector field.

Streamrod A particle trace with a polygonal cross-section and a width which not only
follows the flow field (its center being a regular streamline), but which also
rotates with the vorticity of the vector field.

Streamtrace Any type of particle trace: streamlines, streamribbons, or streamrods.

Streamtrace
Termination Line

A polyline that terminates any streamtraces that cross it.

Streamtrace Zone Any streamtrace which has been extracted to form a new zone.

Stylesheet A type of file which contains the definition of how the plot in a single frame
is to be plotted. The stylesheet does not contain any zone data but does
contain information about views, axes positions, zone attributes, and so
forth.

Supersampling Factor When antialiasing an image for export, the factor Tecplot Focus uses when
creating an intermediate image that is then resized down to the final image
size. The larger the value, the smoother the resulting image at the cost of
performance. Values of more than 3 are seldom necessary.

Surface Line A type of 3D streamline which is confined to remain on a 3D surface. Also
used to refer to streamlines.

Symbols Mapping Layer Line plot where symbols are used to depict the relationship between the
dependent and independent variables.

Tecplot Toolbox The Tecplot Toolbox is a convenience library that provides alternate method
for communicating with the Tecplot Engine.

Time/Date A type of axis label format with which you can label axes by using a
multitude of codes that can display data in years, months, days, hours,
minutes, and seconds.

Toolbar The bar at the top of the Tecplot Focus workspace.

Tetrahedron An element type of finite element volume data which is composed of four
node points arranged in a tetrahedron. (Used in 3D volume plotting.)

Transient Data Data that has a time component in addition to a spatial coordinate.
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Translucency A property allowing you to see through an object to areas within or beyond
it. In Tecplot Focus you may vary the amount of translucency, controlling
the extent that an object closer to you obscures an object it overlays.

Triangle An element type of finite element surface data which is composed of three
node points. (Used in 2D and 3D surface plotting.)

Unordered or
Unorganized Data

(See Irregular Data.)

Value-Blanking A feature of Tecplot Focus used to trim or eliminate cells based on one or
more user-defined constraints for variable values.

Variable One of the values defined at every data point in a dataset.

Vector Layer A field plot showing the direction and or the magnitude of vector quantities.

Volume Line A type of 3D streamline which is not confined to remain on a surface and
may travel through 3D volume data.

Volume Zone Any zone that is IJK-ordered, finite element tetrahedron, or finite element
brick.

Vorticity The measurement of the tendency of a vector field to rotate about a point.
(Also called "curl.")

Wire Frame Mesh type where mesh lines are drawn behind all other plot layers.

Workspace The portion of your screen where you can create Tecplot Focus frames. This
includes but is not limited to the region covered by the displayed paper.

XY-Dependent A 3D axis mode where X and Y are fixed (dependent), but Z is free to vary in
ratio (independent).

XY Line Plot Plots one variable assigned to one axis versus another variable assigned to
another axis. Log plots, bar charts, and curve fitted lines are all examples of
XY Line plots.

Zone A subset of a dataset which is assigned certain plot types. Zones may be
activated (plotted) or deactivated (not plotted). Each zone has one type of
data ordering: I, IJ, IJK, or finite element. Zones are typically used to
distinguish different portions of the data. For example, different
calculations, experimental versus theoretical results, different time steps, or
different types of objects, such as a wing surface versus a vector field
around a wing.

Zone Layers One way of displaying a 2D or 3D plot’s dataset. The plot is the sum of the
active zone layers, which may include mesh, contour, vector, shade, scatter
and edge.
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Functional Limits

Hard Limits

The following hard limits are designed into Tecplot Focus. Your workstation’s memory may, however,
not always be sufficient to allow the product to reach these limits.

Table 9. Hard limits for Tecplot Focus

Item Limit

Maximum number of data points per data set Quintillions (limited by memory)

Maximum number of data points per zone Quintillions (limited by memory)

Largest floating point absolute value 10150

Smallest non-zero floating point absolute value 10-150

Maximum number of datasets 2048

Maximum number of zones More than 2 billion

Maximum number of variables More than 2 billion

Maximum number of frames 2048

Maximum number of pages 2048

Maximum number of macro variables 400

Maximum number of value blank constraints 8

Maximum number of contour groups 8

Maximum number of geometries Limited only by memory

Maximum number of polylines per line
geometry[12]

50

Maximum number of points per circle or ellipse 720

Maximum number of custom label sets Limited only by memory

Maximum number of custom labels per set 5000

Minimum frame width or height 0.1 inches

Maximum frame width 500 inches

Maximum streamtraces per frame 32,000

Maximum number of streamtrace steps 10,000

Maximum number of color map overrides 16

Maximum preview width for EPS files 1024

Maximum preview height for EPS files 1024
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Item Limit

Maximum number of user-defined color map
control points

50

Maximum number of raw user-defined color map
entries

800

Maximum number of characters in variable name 128

Maximum number of characters in zone title 128

Maximum number of characters in dataset title 256

Maximum number of views per view stack 16

Maximum number of characters in an auxiliary
data string

32,000

Line length limit in ASCII .dat files (character
limit per line)

32,000

Table 10. Hard Limits for plot styles

Item Limit

Printing Gouraud shaded plots with continuous
flooding

On screen or exported bitmap image only

Printing plots with translucency On screen or exported bitmap image only

Soft Limits

The following soft limits may be changed by editing your Tecplot Focus configuration file. The
configuration file, tecplot.cfg, is installed in your Tecplot Focus home directory.

Table 11. Soft limits for Tecplot Focus

Limit Soft Limit Hard Limit Macro Parameter

Points per line[13] 20000 Quintillions MAXPTSINALINE

Contour levels 150 5,000 MAXNUMCONTOUR

Characters per text label 16,000 100,000 MAXCHRSINTEXTLABELS

Picked objects 1500 More than 2
billion

MAXNUMPICKOBJECTS

Load on demand - min threshold 0.3 0[14] *[This feature is only available
in Tecplot 360]*
LODTHRESHOLDMINFRACT

550



Limit Soft Limit Hard Limit Macro Parameter

Load on demand - max threshold 0.7 1 *[This feature is only available
in Tecplot 360]*
LODTHRESHOLDFRACT

Available processors 0[15] 64 MAXAVAILABLEPROCESSORS
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Third-Party Trademarks

Trademarks not owned by Tecplot, Inc. are used in this software and documentation to indicate compatibility with, or to describe use of Tecplot products with, particular products
not owned by Tecplot, Inc. No endorsement by any third party of any Tecplot product (or vice versa) is intended.

3D Systems is a registered trademark or trademark of 3D Systems Corporation in the U.S. and/or other countries.

Mac, Macintosh, Mac OS, and Mac OS X are registered trademarks or trademarks of Apple, Incorporated in the U.S. and/or other countries.

Reflection-X is a registered trademark or trademark of Attachmate Corporation in the U.S. and/or other countries.

EnSight is a registered trademark or trademark of Computation Engineering Internation (CEI), Incorporated in the U.S. and/or other countries.

EDEM is a registered trademark or trademark of DEM Solutions Ltd in the U.S. and/or other countries.

Exceed, Exceed 3D, and Hummingbird, are registered trademarks or trademarks of OpenText Corporation in the U.S. and/or other countries.

Konqueror is a registered trademark or trademark of KDE e.V. in the U.S. and/or other countries.

VIP and VDB are registered trademarks or trademarks of Halliburton in the U.S. and/or other countries.

ECLIPSE FrontSim is a registered trademark or trademark of Schlumberger Information Solutions (SIS) in the U.S. and/or other countries.

Debian is a registered trademark or trademark of Software in the Public Interest, Incorporated in the U.S. and/or other countries.

X3D is a registered trademark or trademark of Web3D Consortium in the U.S. and/or other countries.

X Window System is a registered trademark or trademark of X Consortium, Incorporated in the U.S. and/or other countries.

ANSYS, Fluent and any and all ANSYS, Inc. brand, product, service and feature names, logos and slogans are registered trademarks or trademarks of ANSYS Incorporated or its
subsidiaries in the U.S. and/or other countries.

LS-DYNA is a registered trademark or trademark of Livermore Software Technology Corporation in the U.S. and/or other countries.

MSC/NASTRAN is a registered trademark or trademark of MSC.Software Corporation in the U.S. and/or other countries.

NASTRAN is a registered trademark or trademark of National Aeronautics Space Administration in the U.S. and/or other countries.

3DSL is a registered trademark or trademark of StreamSim Technologies, Incorporated in the U.S. and/or other countries.

SDRC/IDEAS Universal is a registered trademark or trademark of UGS PLM Solutions Incorporated or its subsidiaries in the U.S. and/or other countries.

Star-CCM+ is a registered trademark or trademark of CD-adapco in the U.S. and/or other countries.

Reprise License Manager is a registered trademark or trademark of Reprise Software, Inc. in the U.S. and/or other countries.

Python is a registered trademark or trademark of Python Software Foundation in the U.S. and/or other countries.

Abaqus, the 3DS logo, SIMULIA and CATIA are registered trademarks or trademarks of Dassault Systèmes or its subsidiaries in the U.S. and/or other countries. The Abaqus runtime
libraries are a product of Dassault Systèmes Simulia Corp., Providence, RI, USA. © Dassault Systèmes, 2023

FLOW-3D is a registered trademark or trademark of Flow Science, Incorporated in the U.S. and/or other countries.

Adobe, Flash, Flash Player, Premier, and PostScript are registered trademarks or trademarks of Adobe Systems, Incorporated in the U.S. and/or other countries.

AutoCAD and DXF are registered trademarks or trademarks of Autodesk, Incorporated in the U.S. and/or other countries.

Ubuntu is a registered trademark or trademark of Canonical Limited in the U.S. and/or other countries.

Helvetica Font Family and Times Font Family are registered trademarks or trademarks of Linotype GmbH in the U.S. and/or other countries.

Linux is a registered trademark or trademark of Linus Torvalds in the U.S. and/or other countries.

ActiveX, Excel, Microsoft, Visual C++, Visual Studio, Windows, Windows Metafile, Windows XP, Windows Vista, Windows 2000 and PowerPoint are registered trademarks or
trademarks of Microsoft Corporation in the U.S. and/or other countries.

Firefox is a registered trademark or trademark of The Mozilla Foundation in the U.S. and/or other countries.
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Netscape is a registered trademark or trademark of Netscape Communications Corporation in the U.S. and/or other countries.

SUSE is a registered trademark or trademark of Novell, Incorporated in the U.S. and/or other countries.

Red Hat is a registered trademark or trademark of Red Hat, Incorporated in the U.S. and/or other countries.

Courier is a registered trademark or trademark of Monotype Imaging Incorporated in the U.S. and/or other countries.

Qt is a registered trademark or trademark of Digia Plc in the U.S. and/or other countries.

Zlib is a registered trademark or trademark of Jean-loup Gailly and Mark Adler in the U.S. and/or other countries.

OpenGL is a registered trademark or trademark of Silicon Graphics, Incorporated in the U.S. and/or other countries.

JPEG is a registered trademark or trademark of Thomas G. Lane in the U.S. and/or other countries.

HDF5 (Hierarchical Data Format 5) Software Library and Utilities Copyright 2006 by The HDF Group.

NCSA HDF5 (Hierarchical Data Format 5) Software Library and Utilities Copyright 1998-2006 by The Board of Trustees of The University of Illinois.

NetCDF Software Library Copyright © 2018 Unidata

Third-Party Copyrights and License Statements

LAPACK Copyright © 1992-2022 The University of Tennessee and The University of Tennessee Research Foundation. All rights reserved. Copyright © 2000-2022 The University of
California Berkeley. All rights reserved. Copyright © 2006-2022 The University of Colorado Denver. All rights reserved. Redistribution and use in source and binary forms, with or
without modification, are permitted provided that the following conditions are met: Redistributions of source code must retain the above copyright notice, this list of conditions and
the following disclaimer. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer listed in this license in the
documentation and/or other materials provided with the distribution. Neither the name of the copyright holders nor the names of its contributors may be used to endorse or
promote products derived from this software without specific prior written permission. The copyright holders provide no reassurances that the source code provided does not
infringe any patent, copyright, or any other intellectual property rights of third parties. The copyright holders disclaim any liability to any recipient for claims brought against
recipient by any third party for infringement of that parties intellectual property rights. THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

VisTools and VdmTools © 1992-2009 Visual Kinematics, Inc. All Rights Reserved.

CTK, The Common Toolkit Copyright © CTK Project. Licensed under the Apache License, Version 2.0 (the "License"). You may obtain a copy of the License at github.com/commontk/
CTK/blob/master/LICENSE. Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the license.

NCSA HDF & HDF5 (Hierarchical Data Format) Software Library and Utilities Contributors: National Center for Supercomputing Applications (NCSA) at The University of Illinois,
Fortner Software, Unidata Program Center (netCDF), The Independent JPEG Group (JPEG), Jean-loup Gailly and Mark Adler (gzip), and Digital Equipment Corporation (DEC).
Conditions of Redistribution: 1. Redistributions of source code must retain the above copyright notice, this list of conditions, and the following disclaimer. 2. Redistributions in
binary form must reproduce the above copyright notice, this list of conditions, and the following disclaimer in the documentation and/or materials provided with the distribution. 3.
In addition, redistributions of modified forms of the source or binary code must carry prominent notices stating that the original code was changed and the date of the change. 4. All
publications or advertising materials mentioning features or use of this software are asked, but not required, to acknowledge that it was developed by The HDF Group and by the
National Center for Supercomputing Applications at The University of Illinois at Urbana-Champaign and credit the contributors. 5. Neither the name of The HDF Group, the name of
the University, nor the name of any Contributor may be used to endorse or promote products derived from this software without specific prior written permission from the
University, THG, or the Contributor, respectively. DISCLAIMER: THIS SOFTWARE IS PROVIDED BY THE HDF GROUP (THG) AND THE CONTRIBUTORS "AS IS" WITH NO WARRANTY
OF ANY KIND, EITHER EXPRESSED OR IMPLIED. In no event shall THG or the Contributors be liable for any damages suffered by the users arising out of the use of this software,
even if advised of the possibility of such damage. Copyright © 1998-2006 The Board of Trustees of The University of Illinois, Copyright © 2006-2008 The HDF Group (THG). All Rights
Reserved.

libpng version 1.6.37 - April 14, 2019. Copyright © 2018-2019 Cosmin Truta. Copyright © 1998-2002,2004,2006-2018 Glenn Randers-Pehrson. Copyright © 1996-1997 Andreas Dilger.
Copyright © 1995-1996 Guy Eric Schalnat, Group 42, Inc.

Authors and maintainers: libpng versions 0.71, May 1995, through 0.88, January 1996: Guy Schalnat. libpng versions 0.89, June 1996, through 0.96, May 1997: Andreas Dilger. libpng
versions 0.97, January 1998, through 1.6.35, July 2018: Glenn Randers-Pehrson. libpng versions 1.6.36, December 2018, through 1.6.37, April 2019: Cosmin Truta

COPYRIGHT NOTICE, DISCLAIMER, and LICENSE

PNG Reference Library License version 2. Copyright © 1995-2019 The PNG Reference Library Authors. Copyright © 2018-2019 Cosmin Truta. Copyright © 2000-2002, 2004, 2006-2018
Glenn Randers-Pehrson. Copyright © 1996-1997 Andreas Dilger. Copyright © 1995-1996 Guy Eric Schalnat, Group 42, Inc.

QsLog 2010 Copyright © 2010, Razvan Petru. All rights reserved. QsLog Copyright © 2010, Razvan Petru. All rights reserved. Redistribution and use in source and binary forms, with
or without modification, are permitted provided that the following conditions are met: Redistributions of source code must retain the above copyright notice, this list of conditions
and the following disclaimer. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation
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and/or other materials provided with the distribution. The name of the contributors may not be used to endorse or promote products derived from this software without specific
prior written permission. THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING,
BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
OF THE POSSIBILITY OF SUCH DAMAGE.

libssh2 Copyright © 2004-2007 Sara Golemon <sarag@libssh2.org→. Copyright © 2005,2006 Mikhail Gusarov <dottedmag@dottedmag.net→. Copyright © 2006-2007 The Written
Word, Inc. Copyright © 2007 Eli Fant <elifantu@mail.ru→. Copyright © 2009-2014 Daniel Stenberg. Copyright © 2008, 2009 Simon Josefsson. All rights reserved. Redistribution and
use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: Redistributions of source code must retain the above
copyright notice, this list of conditions and the following disclaimer. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the
following disclaimer in the documentation and/or other materials provided with the distribution. Neither the name of the copyright holder nor the names of any other contributors
may be used to endorse or promote products derived from this software without specific prior written permission. THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS
AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR
BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

NetCDF Library Copyright 1993-2017 University Corporation for Atmospheric Research/Unidata

Portions of this software were developed by the Unidata Program at the University Corporation for Atmospheric Research. Access and use of this software shall impose the following
obligations and understandings on the user. The user is granted the right, without any fee or cost, to use, copy, modify, alter, enhance and distribute this software, and any
derivative works thereof, and its supporting documentation for any purpose whatsoever, provided that this entire notice appears in all copies of the software, derivative works and
supporting documentation. Further, UCAR requests that the user credit UCAR/Unidata in any publications that result from the use of this software or in any product that includes
this software, although this is not an obligation. The names UCAR and/or Unidata, however, may not be used in any advertising or publicity to endorse or promote any products or
commercial entity unless specific written permission is obtained from UCAR/Unidata. The user also understands that UCAR/Unidata is not obligated to provide the user with any
support, consulting, training or assistance of any kind with regard to the use, operation and performance of this software nor to provide the user with any updates, revisions, new
versions or "bug fixes." THIS SOFTWARE IS PROVIDED BY UCAR/UNIDATA "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL UCAR/UNIDATA BE LIABLE FOR ANY SPECIAL, INDIRECT
OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR
OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE ACCESS, USE OR PERFORMANCE OF THIS SOFTWARE.

Portions of this software are copyright © 2023 The FreeType Project (www.freetype.org). All rights reserved.

FTGL - OpenGL font library
Copyright © 2001-2004 Henry Maddocks <ftgl@opengl.geek.nz>
Copyright © 2008 Ãric Beets <ericbeets@free.fr>
Copyright © 2008 Sam Hocevar <sam@zoy.org>

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without
restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the
Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
IN THE SOFTWARE.

ZeroMQ Copyright © 2007-2021 ZeroMQ Project

OpenSSL library version 1.1.1q 5 Jul 2022
Copyright © 1998-2022 The OpenSSL Project
Copyright © 1995-1998 Eric A. Young, Tim J. Hudson

OpenGL Mathematics (GLM) Copyright © 2005 - G-Truc Creation. Refer to pub/glm/copying.txt for license information.

FFTW Copyright Notice. The software [or "Portions of the software"] incorporated herein is Copyright ©2011, Massachusetts Institute of Technology ("MIT"). All Rights Reserved. The
name "MIT" (alone or as part of another name) or any logos, seals, insignia or other words, names, symbols or devices that identify MIT or any MIT school, unit, division or affiliate
may not be used to endorse or promote products derived from this software without specific prior written permission.

Asciidoctor
Copyright © 2012-present Dan Allen, Sarah White, Ryan Waldron, and the individual contributors to Asciidoctor.
Refer to pub/asciidoctor/license.txt for license information

Lunr
Copyright © 2013 by Oliver Nightingale
Refer to pub/lunr/license.txt for license information

[1] The HDF Loader uses the public-domain HDF API code library from the National Center for Supercomputing Applications (NCSA),
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University of Illinois, Urbana-Champaign.

[2] Copyright for Third Party Library. This loader utilizes a modified version of a library written by Greg Turk while at Stanford
University. The copyright for this library is: Copyright © 1994 The Board of Trustees of The Leland Stanford Junior University. All rights
reserved. Permission to use, copy, modify and distribute this software and its documentation for any purpose is hereby granted without
fee, provided that the above copyright notice and this permission notice appear in all copies of this software and that you do not sell
the software. The software is provided "as is" and without warranty of any kind, express, implied or otherwise, including without
limitation, any warranty of merchantability or fitness for a particular purpose.

[3] For details, see Lancaster, Peter and Salkauskas, Kestutis "Curve and Surface Fitting, An Introductin", 1986, Academic Press.

[4] For more information see Russell W. Stineman’s "A Consistent Well-behaved Method of Interpolation" in the July, 1980, issue of
Creative Computing.

[5] With orthographic projection, the shape of the objects is independent of distance. This is sometimes an "unrealistic" view, but it is
often used when preserving true dimension is important (such as in drafting).

[6] Refer to the Data Format Guide for details regarding face neighbors.

[7] A represents the theta (or angle) axis variable in Polar Line plots.

[8] Derived Objects can opt in or out of blanking. (See Blanking Settings for Derived Objects.)

[9] If you have multiple x-axes or y-axes in an XY line plot, the variables assigned to the x and y-axis in the first available mapping will
be used.

[10] Use the $!INTERFACE DATA {DERIVATIVEBOUNDARY = method} setting the configuration file tecplot.cfg to select the method to use. Set
method to SIMPLE or COMPLEX.

[11] Mac users can simulate a click of the middle button by holding down the Control key on the keyboard while clicking the right
mouse button. Hold any additional keys (such as Alt/Option) along with Control to invoke extended mouse operations.

[12] A polyline is a continuous series of line segments, and can be a subset of a line geometry.

[13] Points per line is the limit on the number of points allowed in the following: line segment geometries, stream termination lines,
and contour lines. For line segment geometries, this is the total number of points used in all polylines contained in the geometry.

[14] LODTHRESHOLDMINFRACT may not be less than 0 (the given hard limit is the lower bound, not the upper limit as with the other
hard limits).

[15] If MAXAVAILABLEPROCESSORS is 0, Tecplot Focus queries the hardware for the number of processors and uses that value.
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