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1 

Introduction

Tecplot 360 EX allows you to interactively explore, visualize, and analyze your CFD data, and then 
communicate your results. With Tecplot 360 EX, you can produce high-quality plots for reports, papers, 
presentations, videos, or web sites.

The user documentation for Tecplot 360 EX includes these resources:

• Getting Started Manual (this document) - Highlights how to work with key features through a 
tutorial revolving around data files similar to those you might use.

• User’s Manual - Complete documentation of all Tecplot 360 EX features.

• Scripting Guide - Information on working with Tecplot 360 EX macros and a full syntax 
reference.

• Quick Reference Guide - A handy reference for all the little details of using Tecplot 360 EX, 
such as text placeholders, keyboard shortcuts, and much more.

• Data Format Guide - Tecplot data formats and how to write them.

• Installation Guide - How to install Tecplot 360 EX on your machine. 

• Release Notes - Information on the latest Tecplot 360 EX features along with platform-specific 
notes.

This manual includes four tutorials to help you get started with Tecplot 360 EX. For in-depth information 
on any of the topics covered in the Getting Started Manual, please refer to the User’s Manual which is 
included in your Tecplot 360 EX installation directory or on our website at: https://www.tecplot.com/
documentation/.

https://www.tecplot.com/documentation/
https://www.tecplot.com/documentation/
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1 - 1   Before You Start the Tutorials
Before beginning a tutorial from this guide, we suggest you read through Chapters 1 and 2 of the User’s 
Manual to introduce yourself to the Tecplot 360 EX user interface and familiarize yourself with the 
product’s basic concepts of operation. It may be helpful to have Tecplot 360 EX open while reading these 
chapters so you can experiment a little.

• Chapter 1 - Introduction. Covers the Welcome Screen, supported input devices, the Tecplot 360 
EX workspace, the menu bar and global toolbar, context menus and toolbars, and sidebars. 
Reading this chapter will orient you to the main user interface controls of Tecplot 360 EX, 
making it easier to find what you’re looking for when you are working on the tutorial.

• Chapter 2 - Using the Workspace. Covers data hierarchy, coordinate systems, frames, 
workspace management, view modification, and the Edit menu. You will get practice with 
many of these concepts in the pages that follow. You may want to review Chapter 2 again after 
completing the tutorial.

1 - 2   Tutorials In This Guide
This Getting Started Guide is divided into tutorials, each of which contains a series of exercises covering 
various aspects of the topic at hand. The tutorials are designed so you can do them in any order you like, 
but within a tutorial, it is best to go through the exercises in order if possible (though we do try to provide 
guidance on how to pick up in midstream).

The tutorials are:

• External Flow - Using the Onera M6 wing model, covers loading the data, producing a basic 
plot, slicing, streamtraces, isosurfaces, probing, and comparing simulated and experimental 
data (including normalizing the data).

• Understanding Volume Surfaces - Uses the DuctFlow data set as an example of how Tecplot 
360 EX renders volume surfaces using Surfaces to Plot.

• Transient Data - Uses a wind turbine data set with 127 time steps to understand how transient 
(time-based) data is structured and how to produce animated contour plots, extract data over 
time for analysis, and calculate and visualize additional variables using the Tecplot 360 EX  
analysis tools.

• Finite Element Analysis - Uses a transient FEA dataset of a connecting rod created with LS-
DYNA to explore multiple ways to visualize the maximum Von Mises Stress of the rotating 
rod.

All of the tutorials in this guide have datasets located in the Getting Started Bundle. A few datasets are 
located in the example folder in the installation directory, OneraM6Wing and DuctFlow.plt as well as the 
Getting Started Bundle. 

Dive in and master the view!

https://tecplot.azureedge.net/data/360GettingStarted.zip
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2 

External Flow

The Onera M6 wing is a standard design for basic studies of 3D flows at high Reynolds numbers from low 
to transonic speeds (that is, local supersonic flow, shocks, and turbulent boundary layer separation). The 
wing was tested by NASA in a wind tunnel at four different Mach numbers and various angles of attack. 
This is now a classic CFD validation case for external flows because it has a simple geometry, complex 
flows, and because it includes experimental data against which a CFD solution can be validated.1

This tutorial uses the Onera M6 data set as your entry into Tecplot 360 EX, introducing basic operations at 
first (loading data and manipulating the view) and progressing to more intermediate and then advanced 
operations. We chose this data set because you may already be familiar with it (and if you’re not, it’s 
straightforward to understand).

The Onera M6 data set is in the OneraM6wing folder inside the Getting Started Bundle.

This tutorial is divided into three segments. We have provided a layout file for the end of each segment, so 
you can check your work. There is also a macro included to generate an enhanced version of one of the 
plots in the third segment, and a layout showing its results. The segments are:

A video version of this tutorial is available on the Web at https://www.tecplot.com/category/tecplot-360-
videos/external-flow/. The videos may have minor differences from the printed version of the tutorial in 
this manual, but they end up in the same places.

1. For more about the Onera M6 wing, see https://turbmodels.larc.nasa.gov/onerawingnumerics_val.html

Number and Level Title and Description

1 - Beginner
Loading and Manipulating Data - Load the Onera M6 simulation data set into Tecplot 
360 EX and create a contour plot, along the way discovering how to rotate a 3D plot, 
view and color a mesh, set up contour groups and color maps, and display a legend.

2 - Intermediate
Exploring a CFD Solution - Further explore and understand the Onera M6 simulation 
data set by adding slices, streamtraces, and iso-surfaces, and by probing data.

3 - Intermediate
Comparing a CFD Simulation with Experimental Data - Create a coefficient of pressure 
(Cp) plot comparing simulated data with experimental data, including normalizing the 
dimensions of the simulation data set.

https://www.tecplot.com/category/tecplot-360-videos/external-flow/
https://www.tecplot.com/category/tecplot-360-videos/external-flow/
https://turbmodels.larc.nasa.gov/onerawingnumerics_val.html
https://tecplot.azureedge.net/data/360GettingStarted.zip
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2 - 1   Loading and Manipulating Data

Step 1  Launch Tecplot 360 EX and Load the Data Set
Start Tecplot 360 EX from the Start menu (Windows), by typing tec360 in a terminal window (Linux), or by 
double-clicking the application icon in the Applications folder (Mac). The Tecplot 360 EX Welcome Screen 
appears, as shown here. (We will show the Windows version of Tecplot 360 EX in this document, but the 
product looks substantially the same on other platforms.)

The Welcome Screen appears each time you launch Tecplot 360 EX and gives you easy access to layouts 
you have recently worked with, along with quick links to documentation and other resources to help you 
get the most out of the product.

To begin loading the Onera M6 data, click Load Data at the top of the Welcome Screen. (You may also 
choose Load Data from the File drop-down menu in the menu bar, or click the folder icon, second from 
the left, in the toolbar. These alternate methods are convenient when the Welcome Screen isn’t visible.) 
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The Load Data dialog appears.

Navigate to your Tecplot 360 EX installation folder, then the examples folder, then the OneraM6wing folder. 
Then double-click the OneraM6_SU2_RANS.plt file to open it in Tecplot 360 EX. (If you can’t see this file, 
choose All Files in the menu at the bottom of the dialog.) The data file is opened and a 3D plot of the 
Onera M6 wing appears in the Tecplot 360 EX workspace, as shown here.
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Step 2  Rotate the Wing
To rotate the view of the wing, hold down the Control key on the keyboard (Command on Mac), then hold 
down the right mouse button in the Tecplot 360 EX workspace and move the mouse to rotate the wing.

You’ll notice that the range of rotation is not very great, making it hard to make significant changes to the 
view of the wing. This is because the rotation origin (the point around which rotation is performed) is not 
set anywhere near the wing. To change this, simply place the mouse pointer in the approximate center of 
the wing on the screen, then press the lowercase letter O (for origin) on the keyboard.

Then hold down the Control key (Command on Mac) and drag with the right mouse button again. You’ll 
see it is now much easier to rotate the wing, since it rotates around its center.

Step 3  View Information About the Data Set
To see information about the Onera M6 data set, choose Data Set Info from the Data 
drop-down menu (left). The Data Set Information dialog, shown here, appears.

This dialog provides a wealth of information about the data set. The two lists at the top of the dialog show 
you the names of the zones and the variables in the data set.

The zones in this data set are:

• FluidVolume - the air around the wing

• WingSurface - the surface of the wing itself

You may wish to explore the other information in the dialog, which is divided into three pages. Click the 
Help button for more information about the information displayed on any page of the dialog. When 
you’re finished, close the Data Set Information dialog.
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Step 4  Disable Bounding Box for Fluid Volume Zone
As you rotated the wing in step 2, you may have noticed a dashed orange line swoosh by in the plot. We 
have caught a glimpse of it here.

This is the bounding box of the FluidVolume zone, which represents the air around the wing. This zone 
does not have any style (that is, visual appearance) so it would normally be invisible. Tecplot 360 EX adds 
the dashed orange line so that you know it’s there and can see its dimension.

Choose Fit Everything from the View menu to see the full 
extent of the volume zone (see right). The wing is a tiny part of 
the data set! Choose View>Last to return to the previous view.

The bounding box does not add anything to the plot we’re 
making, so let’s turn it off. Choose Show Bounding Boxes for 
Enabled Volume Zones with No Style from the Options 
menu. The dashed orange line disappears.
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Step 5  View the Mesh Using the Context Toolbar
To view the mesh for the WingSurface zone, right-click on the wing in the Tecplot 360 EX workspace. A 
context toolbar appears, as shown here.

From left to right on this toolbar are buttons that allow you to turn on and off the mesh, contours, vectors, 
shade, edge, and translucency. Click the first button to display the mesh for the WingSurface zone, as 
shown here.
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Step 6  Change the Mesh Color
The top portion of the Plot sidebar lets you turn the layers of your plot on 
and off. The Zone Style button in this sidebar (left) opens the Zone Style 
dialog, shown here. 

The Mesh Color column (right most green column) displays the color of the 
mesh for each zone, including WingSurface. Right-click the black color 
swatch to display the Color Chooser.

The Color Chooser lets you choose a single solid color, or, using the 1-8 buttons at the bottom of the dialog, 
you may choose to have the mesh colored using a contour, such as a gradient based on the value of some 
variable. (These numbers actually refer to Tecplot 360 EX’s eight contour groups, which associate variables 
and color maps. We will look at contours in more depth shortly.) 
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For now, let’s choose a blue color for the mesh.

Close the Zone Style dialog, so that the wing surface is visible again.

Scenic Detour: Context Menu and Toolbar
Try right-clicking the wing. A context menu and toolbar appears, 
allowing you to make many of the same changes you can make in the 
Zone Style dialog—without needing to pull up the dialog. Here we are 
using the drop-down menu to the right of the mesh icon (the first icon 
on the toolbar) to choose the mesh color.

If you are changing the styles of many zones at once, it still makes sense 
to pull up the Zone Style dialog. For many other situations, the context 
menu and toolbar are faster.

We will use this context menu again in later steps.
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Step 7  Set Up Contour Groups and Color Maps
The Onera M6 data contains a number of variables we might be interested 
in visualizing. Let’s set up color maps so that we can see them as contours 
on the surface of the wing. First activate the Contour layer in the Plot 
sidebar (right), then click the  button next to the Contour checkbox to 
open the Contour & Multi-Coloring Details dialog, seen here.

At the top of the dialog is a drop-down menu for choosing a variable. Next to this are eight numbered 
buttons, which specify the contour group you are editing. Each contour group has its own settings for this 
dialog. The contour group provides a way to associate a variable with a color map and other settings. The 
color map specifies how the zone will be colored according to the value of the specified variable.

For our tutorial, we will set up two contour groups. The first will display density with the Large Rainbow 
color map. The second will display the pressure coefficient using the Magma color map.

First, move the dialog so you can see most of the plot and the dialog at the same time.

1. Make sure contour group 1 is set at the top of the Contour & Multi-Coloring Details dialog.

2. Make sure the Density variable is chosen in the drop-down menu at the top of the dialog.

3. From the drop-down menu under the color map preview, choose Large Rainbow.

4. Click Continuous for the Color Map Distribution Method.

The dialog should appear as shown above. You should have noticed the plot changing as you made each 
change in the dialog, since the wing surface is already using contour group 1 by default.

Next, we’ll set up contour group 2 for the Pressure_Coefficient variable.

1. Click 2 at the top of the Contour & Multi-Coloring Details dialog to choose contour group 2.

2. Choose the Pressure_Coefficient variable in the drop-down menu at the top of the dialog.

3. From the drop-down menu under the color map preview, choose Magma.
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4. Click Continuous for the Color Map Distribution Method.

5. We also need to change the levels for the color map. Click the Set Levels button, then, in the 
Enter Contour Levels dialog, change the Minimum level to -1 and the number of levels to 21, 
as shown here.

6. Click OK to close the Enter Contour Levels dialog.

The Contour & Multi-Coloring Details dialog should now appear as shown here.
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Step 8  Change Contour Group on Plot
Now that we’ve set up our contour groups, close the Contour & 
Multi-Coloring Details dialog. Ensure the Contour layer is checked 
on the Plot sidebar.

Now, we can change the contour variable displayed on the wing by 
right-clicking the wing, clicking the drop-down menu next to the 
contour icon in the context menu, and choosing contour group 2 
(C2: Pressure Coefficient).

The plot so far is shown below.
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Step 9  Format Legend
That contour legend is useful, but it overlaps our plot. Double-click the legend title to open the Legend 
page of the Contour & Multi-Coloring Details dialog, shown here.

This is the same dialog we just closed a moment ago, just a different page. You can also get to it by clicking 
the  button next to Contour in the Plot sidebar, or by choosing Plot>Contour/Multi-Coloring from the 
Tecplot 360 EX menu bar.

In the Contour & Multi-Coloring Details dialog:

1. Change the alignment to horizontal

2. Turn on automatic resizing

The desired settings are shown above. Close the dialog after changing these settings.
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Using the mouse, you may now drag the legend to the bottom of the plot. The final plot is shown here.

A Tecplot 360 EX layout (.lay) file containing a snapshot of the final result of this tutorial segment is in 
OneraM6wing/finallayouts/ExtenalFlowVideo1.lay in the examples folder in your Tecplot 360 EX installation 
folder. You can compare this with your result to see how you did.

You might even try save a layout of your own work. Choose File>Save Layout from the Tecplot 360 EX 
menu bar, then navigate to the folder in which you want to save the layout, name it, and click Save.
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2 - 2   Exploring a CFD Solution
This segment of the External Flow tutorial covers slicing, streamtraces, iso-surfaces, and probing. These 
are tools you’ll frequently use to get a closer look at the volume data in your solution.

We’ll continue from where we left off at the end of the previous segment, with the coefficient of pressure 
visible on the surface of the wing. If you have closed Tecplot 360 EX since completing that segment, you 
can load the provided layout file OneraM6wing/finallayouts/ExtenalFlowVideo1.lay in the examples folder in 
your Tecplot 360 EX installation folder, and continue from there.

Step 1  Add a Slice
To add a slice, toggle on the Slices checkbox in the Plot sidebar. A slice 
appears through the volume zone. 

As we determined in the first segment of this tutorial, the volume zone is 
much larger than the wing. The slice through that zone, therefore, 
dominates the plot. That’s why the screen suddenly fills with a nearly solid 
color (yellow in our plot; it might be green or a different color in yours).

The Density legend appears because this slice is using contour group 1.

To move the slice with the mouse, first click the slice tool in the Plot 
sidebar, next to the Slices checkbox.
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Then click the surface of the wing. (You probably can’t see the wing at first, with the slice in front of it, but 
you can still click it even though you can’t see it.) The slice moves to pass through the point that you 
clicked. You can see the slice at various positions in the following images.

You can also drag the mouse on the surface of the wing to fine-tune the slice location. A blue-gray preview 
plane shows where the slice will be when you release the mouse button.



25

Step 2  Set Slice Details
Click the  button next to the Slices in the Plot sidebar to launch the Slice Details dialog.

Let’s spend a moment on the Slice Details dialog:

• There are eight buttons across the top, just 
as with the Contour Details dialog. This 
isn’t a coincidence: Tecplot 360 EX supports 
eight slice groups, just as it supports eight 
contour groups. Each slice group uses the 
same normal and style, but can have its own 
positions. Various other settings are also 
unique to each slice group. 

These numbered buttons tell Tecplot 360 EX 
what slice group you want to edit.

• You can manually change the slice 
orientation to a specific plane. Currently it 
is set to the X plane, which is the default. A 
Y plane slice is more useful here, since it 
shows the wake behind the wing. So let’s 
change that. 

The dialog also lets you choose an arbitrary 
slice orientation, though we won’t use this 
capability in this tutorial.

• You can see that you can set up multiple 
slices by specifying a start slice, an end slice, 
and some number of intermediate slices. 
You can also choose what kind of data you 
want to slice through.

You can leave the Slice Details dialog open while you experiment with dragging the slice around. Notice 
that the slice position field in the dialog updates as you move the slice in the plot. (Most dialogs in Tecplot 
360 EX can be left open while you work, updating whenever you change a plot by other means.)
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Step 3  Show Contours
With the Slice Details dialog still open, let’s take a quick 
detour to the Contour page of this dialog, which allows 
you to specify how the slice itself will be colored. 

This ties back to the contour groups we discussed in the 
previous segment of this tutorial (see “Set Up Contour 
Groups and Color Maps” on page 18). As a refresher, a 
contour group ties a color map to a variable, thereby 
establishing how an object in your plot will be colored 
based on the values of the selected variable.

On the Contour page of the Slice Details dialog, we can 
choose the contour group to be used for the slice, which 
in turn determines the color map and the variable used 
for the contouring. Flooding best represents continuous 
values, so we’ll use the Flood By drop-down menu to 
choose the Pressure group.

If the variable we want to use isn’t listed on the Flood By 
drop-down menu, we’ll want to go to the Contour and 
Multi-Coloring Details dialog to set it up. Conveniently, 
that dialog can be accessed right from the Slice Details 
dialog by clicking the gear icon next to the Flood By 
drop-down menu. Try it now if you like, just to see it’s 
the same dialog, then close the Contour and Multi-
Coloring Details dialog.

As shown here, we’ll contour our slice by Pressure, which is contour group 7.
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Scenic Detour - Creating Multiple Slices
Slices are great, so let’s add more of them! We don’t need to do this for the plot we’re trying to make, which 
is why this section is labeled as a detour. You can skip it if you want.

1. On the Definition page of the Slice Details dialog, turn off Show Primary Slice and turn on 
Show Start/End Slices.

2. Rotate the plot so that you are looking nearly, but not quite, straight down on the wing from 
above. The slice, being perpendicular to the view, should be close to a line. 

Reminder: To rotate the plot, hold down the Control key (Command on Mac) 
and hold down the right mouse button while moving the mouse. Hit “o” (the 
lowercase letter O) to set the origin of rotation to the mouse location.

Notice the orientation axis in the upper right corner of the plot, which makes it 
easy to tell when the plot’s Z axis is pointing at you.

3. Using the Start slider, set the starting slice location to 0.

4. Set the ending slice location to the wing tip, around 1.16. 

5. Turn on the Show Intermediate Slices checkbox and set the number of slices to 
4. A total of six slices are shown.
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Here’s what the Slice Details dialog should look at this point, along with the plot.
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Step 4  Prepare for Streamtraces
Streamtraces are a useful tool for visualizing the flow around a 
surface. We’ll try out three different types of streamtraces: 
volume lines, volume ribbons, and surface lines.

We only need a single slice for this, so if you followed the 
multiple-slice detour, go back to the Slice Details dialog, turn 
off Show Start/End Slices, and turn Show Primary Slice on. 

We want our slice at the tip of the wing; that’s where the 
pressure differential can cause vortex shedding. Enter 1.18 for 
the primary slice’s location in the Slice Details dialog to place it 
close to the wing’s tip.

The Slice Details dialog should now look as shown here. You 
can close the dialog at this point, as we won’t need it for a 
while.

Now, rotate the wing so that the tip is pointing almost directly 
at us. (Hold Control, or Command on Mac, while dragging 
with the right mouse button.) The orientation axis in the upper 
right corner of the plot will help you get the wing pointed the 
right way. It should look roughly like the image below.

What are we looking at here? The green-blue background is our slice, and it’s hiding most of the wing at 
this point, so we only see the wing tip.
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Last but not least, we can specify the vector variables that describe the velocity of the flow around the 
wing. If we don’t do it in advance, Tecplot 360 EX will prompt us to choose the variables as we begin 
adding our streamtraces. However, just so we know where the feature is, let’s do it ourselves now.

Choose Plot>Vector>Variables from the menu bar. The Select Variables dialog appears. We actually don’t 
have velocity values in our data, but we do have momentum, and the vector field for momentum is the 
same as for velocity. (Momentum is just velocity times density. In the next segment of this tutorial, you’ll 
learn a technique you could use to calculate true velocity values.)

Therefore, for our purposes, we can use the momentum variables. So choose Momentum U, Momentum V, 
and Momentum W for the U, V, and W vector variables, respectively.  

When the Select Variables dialog appears as shown here, click OK.

Step 5  Seed Streamtraces
Turn on the Streamtraces checkbox in the Plot sidebar, then 
click the Streamtrace tool button, as shown here.

You can now place a line with the mouse and seed 
streamtraces evenly along the line. To place the line, click and 
hold the mouse button at the starting point, drag to the end 
point, and release the mouse button. Try drawing a roughly 
vertical line along the leading edge of the wing, as shown here.
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Tecplot 360 EX creates streamtraces showing the flow around the wing, as shown below. The streamtraces 
are generated by simulating the release of massless particles at the slice surface at equally-spaced points 
along the line (called “seeding”) and calculating their path of travel based on the vector variables that 
describe the flow.
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Some of the streamtraces are behind the slice. To see the streamtraces better, let’s change the slice to be 40% 
transparent. To do this, right-click the slice and choose 40 from the right-most drop down menu in the 
context toolbar.

Now, rotate the plot in three dimensions to better see the streamtraces and the wing. A possible result is 
shown below.



33

Step 6  Seed Volume Ribbons
By default, streamtraces are simple lines with arrowheads. Ribbons can allow us to see the flow better 
because they show local twist using a 2D surface. Here’s how to switch to volume ribbons.

1. Open the Streamtrace Details dialog by clicking the  button next to Streamtraces in the 

Plot sidebar. Make sure the Placement page is active using the tabs at the top of the dialog.

2. Click Delete All in the Streamtrace Details dialog to remove the existing streamtraces.

3. Change the drop-down menu at the top of the dialog to Volume Ribbon.

4. Click the streamtrace tool button next to Streamtraces in the Plot sidebar. Leave the 
Streamtrace Details open, but move it out of the way. 

5. As before, drag out a line along the leading edge of the wing to seed the streamtraces and 
create the ribbons.
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The plot should look something like this with the ribbons.

Let’s change them from white to a more attention-grabbing color. We can do this on the Rod/Ribbon page 
of the Streamtrace Details dialog.
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Near the bottom of this dialog, under the Show Shade checkbox, click the button next to Color. Then, in 
the Color Chooser, click the red swatch.

The plot with red ribbons is shown below:

Step 7  Adjust Rotation and Lighting
You can adjust the direction of the lighting to make the ribbons 
stand out more. To do this, click the sun toolbar icon in the Plot 
sidebar.



External Flow

36

Click or drag around the plot to move the light. As you do so, you will find spots where the ribbons catch 
a highlight. You can also try rotating the plot to get the best view.

Step 8  Surface Streamtraces
So far, we’ve been looking at flow through the air around the wing: volume streamtraces and ribbons. We 
can also visualize the flow across the surface of the wing.

Just to be clear, these streamtraces will be calculated using the momentum data from the volume zone 
around the wing. The wing surface zone does not actually contain momentum or velocity data. The data 
file we provide for this tutorial has the zones set up to make this work correctly.

We used the slice to specify a plane on which we could draw a line to seed 
streamtraces in a volume. When creating surface streamtraces, we just seed 
directly on the surface. So click the Slices checkbox in the Plot sidebar to 
turn off the slice.

Next, let’s delete the ribbons we’ve created by clicking Delete All on the 
Placement page of the Streamtrace Details dialog. Then choose “Surface 
Line” at the top of the dialog.



37

Let’s rotate the wing again so that we can see across it. (Last reminder: hold Control, or Command on Mac, 
while dragging with the right mouse button.) We’re going for an angle something like this.

As always, you can use the orientation axis in the upper right corner of the plot to help you stay oriented.
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Now, just as we did before when seeding from the surface of our slice, we choose the streamtrace tool in 
the Plot sidebar, then drag a line across the wing surface, parallel to the leading edge. After Tecplot 360 EX 
creates the streamtraces, we end up with something like this:

We made our streamlines thicker so you can see them more easily. For extra credit, figure out how to make 
yours thicker, too. (The setting you need is on the Lines page of the Streamtrace Details dialog.)

We’re done with streamtraces for now. Turn off the Streamtraces checkbox in the Plot sidebar when you’re 
done to hide the streamtraces and show just the wing.

Step 9  Create Iso-Surfaces
Iso-surfaces are great way to visualize a constant value of a contour variable as a surface. In other words, 
you specify a value, and the iso-surface shows you where the specified variable has that value. 

Let’s use it to visualize the shockwave as the wing passes the speed of 
sound. We do this by creating an iso-surface at Mach 1.

1. Turn on the Iso-Surfaces checkbox in the Plot sidebar.
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2. Click the  button next to Iso-Surfaces to open the Iso-Surface Details dialog.

Now, we need to choose a contour group that associates the Mach variable with a color map. 
However, if you expand the Define Iso-Surfaces Using dropdown menu, you will see we don’t 
have one. So we need to create one.

3. Click the gear icon next to this menu to open the Contour and Multi-Coloring Details dialog, 
which we’ve seen before.

4. Click the 3 button at the top of this dialog to define the third contour group.

5. Using the menu at the top of the dialog, choose the Mach variable.
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6. Choose the Large Rainbow color map. Here’s how it should look.

7. Close the Contour and Multi-Coloring Details dialog.

8. Back in the Iso-Surface Details dialog, choose contour group 3 from the Define Iso-Surfaces 
Using menu, then enter a value of 1 in the Value 1 field.
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The plot is shown here. We’ve rotated the wing to get a better view.

This iso-surface shows us where the air is moving at Mach 1 around the wing. Try adjusting the Value 1 
field using the arrows next to the numeric entry field and watch the plot change in response.

It is often instructive to show more than one iso-surface at more than one value. Let’s add a second iso-
surface at Mach 1.2. To do this, change the Draw Iso-Surfaces At menu to “2 Specified Values” and enter 
1.2 in the Value 2 field. 
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The dialog options are shown here.

Where’s the second iso-surface? Well, it’s closer to the wing than the first one, so it is hidden. Let’s make 
the iso-surfaces partly transparent so we can see the second one inside the first (and also, dimly, the wing 
surface inside the second).

To do this, right-click the iso-surface in the plot, then turn on transparency by clicking the rightmost icon 
in the toolbar. Our iso-surfaces are both in the same group, so they both become transparent.
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Now you can see the Mach 1.2 iso-surface inside the Mach 1 iso-surface. Rotate the plot and see! This is the 
shock surface where the transition between subsonic and supersonic is happening. Here’s our final iso-
surface plot.
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Step 10  Probe Data
The last exploration technique we’ll explore is probing. Probing shows the values of all variables at a 
location you click in the plot. Simply choose the Probe tool from the toolbar at the top of the screen.

Now, click points of interest in your plot. The Probe sidebar, which pops out along the right edge of the 
screen, displays the variable values at each clicked location. 

You can also copy variable names, values, or both from the probe 
results by selected the desired information and right-clicking, or by 
pressing Control-C (Command-C on Mac OS X).

As with any sidebar, you can move the Probe sidebar to another 
edge of the workspace, combine it with another sidebar, or even 
tear it off and move it outside the main Tecplot 360 EX window—to 
a different monitor, if you want.

As before, a Tecplot 360 EX layout (.lay) file containing a snapshot 
of the final result of this tutorial segment is in OneraM6wing/
finallayouts/ExtenalFlowVideo2.lay in the examples folder in your 
Tecplot 360 EX installation folder.
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2 - 3   Comparing a CFD Simulation with Experimental Data
In this segment, we’ll be creating a classic Coefficient of Pressure (Cp) plot using both simulated and 
experimental data. To do this, we’ll first append the experimental data, which was gathered via pressure 
taps along the wing in a wind tunnel. Then we’ll extract a slice and create an XY line plot in a new frame.

The experimental data is normalized in both the span and chord directions: the Y direction is normalized 
by b (the span) and the X direction is normalized by c (the chord). The simulation data is not normalized, 
so part of our work will be to adapt the experimental data so that it can be compared to the simulation.

Step 1  Load Layout
We’ll be continuing from where we left off with segment 1 of this tutorial, not from segment 2. Load the 
layout OneraM6wing/finallayouts/ExtenalFlowVideo1.lay in the examples folder in your Tecplot 360 EX 
installation folder and follow along.

Step 2  Append Experimental Data
Choose File>Load Data from the Tecplot 360 EX menu, then open the experimental data file. This is a 
Tecplot ASCII file named Onera_Experimental.dat and can be found OneraM6wing folder in your Tecplot 
360 EX examples directory. (If you can’t see this file, choose All Files in the menu at the bottom of the 
dialog.)1

If you used All Files, the Choose Loader dialog appears after you 
select the file to ask what format the data is in. Choose “Tecplot Data 
Loader” and click OK.

Next, Tecplot 360 EX asks whether you want the new data to replace 
the existing data, or to append the new data.

In the Load File(s) dialog, click Append data to active frame. 

Step 3  Variable Load and Combine
The Variable Load and Combine dialog should appear after appending the data. This dialog gives the user 
options to combine certain variables as well as the option to not add certain variables. Variables that are 
automatically combined are colored blue. Manually combined variables are colored green. Anything else 
is colored black. Notice that Pressure_Coefficient has been automatically combined.

1. The experimental data file we’ve included is a slightly modified version of data provided by NASA. For more 
information, see  https://turbmodels.larc.nasa.gov/onerawingnumerics_val.html

https://turbmodels.larc.nasa.gov/onerawingnumerics_val.html
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For this example, we will load all of the variables from the Experimental dataset. Select Add All and then 
select OK to close the Variable Load and Combine dialog.

To verify that the data was loaded correctly, open the 
Data Set Information dialog by choosing Data>Data 
Set Info from the menu. Notice the seven new 
zones: Section 1 - 0.2, Section 2 -0.44, and so on. 
These zones contain the experimental data from the 
pressure taps placed along the wing.

You’ll also notice several new variables, starting at 
variable #19: TapNumber, X/L, Y/b, Z/L, and Cp 
Error.

Step 4  Normalize Y to Y/b
We want to compare the experimental data with our 
simulation data at a pressure tap location. However, 
the experimental data is, as we mentioned, 
normalized: instead of using a Y that ranges from 0 
to the span length, as in the simulation data, it uses a 
Y over b (Y/b) that ranges from 0 to 1.
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If we open the Data Spreadsheet dialog (Data>Spreadsheet), choose our WingSurface zone, and scroll 
over to see the “Y/b” variable, we can see that our simulation data does not contain this information. It is 
only in the experimental data set.

However, if you use the Zone menu to switch to one of the experimental data zones, such as “Section 1 - 
0.2,” you will see that it has values for this variable.
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Therefore, we will need to calculate this variable for our simulation data. We can do this using an 
equation.

Close the Data Spreadsheet dialog, then open the Specify Equations dialog by choosing 
Data>Alter>Specify Equations. We know that the span of the wing, b, is 1.19 from publicly-available 
information about the Onera M6 model. So, in the Equation(s) field, enter:

{Y/b} = {y}/1.19

We only want to calculate this variable in our simulation zones, since it already exists in our experimental 
zones, so make sure only FluidVolume and WingSurface are selected in the Zones to Alter list. (Hold 
down the Control key, or Command on Mac, while clicking zones to toggle them on and off.) The Specify 
Equations dialog should appear as shown below.

Click Compute to calculate the Y/b value for our simulation zones.

Finally, let’s check our work by probing at the wing tip.

1. Click the Probe tool in the Tecplot 360 EX toolbar.

2. Click at the tip of the wing.

3. Observe the Y/b value in the Probe sidebar.

We should expect a value of 1 for Y/b. However, since the wing 
tip is beveled, the Y/b value will actually be slightly greater than 
1. Everything is exactly as it should be. Mission accomplished!
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Step 5  Extract Slice from Simulation Data at Pressure Tap Location
Let’s go ahead and change the Y axis to Y/b. Choose Plot>Assign XYZ 
from the Tecplot 360 EX menu bar. Then, in the Select Variables dialog, 
choose “Y/b” for the Y-axis variable, as shown here. Click OK. to save 
this change.

The wing may rotate in the workspace when you change the Y variable. 
This is normal.

Our experimental data contains information only at the locations of the 
pressure taps on the wing. For this example, we’ll compare the 
simulation data with the experimental data from the pressure tap at Y/b = 
0.65. We will create a slice of the simulation at this location and extract that slice to a new zone. 

All the simulated surface data along the wing at the location of the pressure tap, in other words, will be 
copied into a new two-dimensional zone. Here’s how.

1. Turn on slices in the Plot sidebar.

2. Open the Slice Details dialog by clicking  next to Slices in 

the Plot sidebar.

3. In the Slice Details dialog:

• Change the Slice Location to Y-Planes

• Make sure Show Primary Slice is enabled

• Enter the value 0.65 for the location of the primary slice. 

• Set Slice Through to “Surface 
Zones.”

A band appears on the surface of the 
wing at the location of our slice, as shown 
below.
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4. Choose the Extract Slices button to extract this slice to a new zone. (Or by selecting 
Data>Extract>Slices).

5. In the Extract Slice dialog, leave all of the default values and click Extract to proceed with the 
slice extraction.

6. Close the Extract Slice dialog and the Slice Details dialog.

Our new slice zone is zone 10 and is named “Slice Y=0.65.” You can verify this in Data Set Information, if 
you like.

Step 6  Normalize Slice’s X to X/L
Now we can normalize the X dimension of our slice to the chord, in order to match the experimental data. 
We’ll do this using the same Specify Equations dialog we used to normalize the Y dimension. In the 
experimental data, this is stored as the variable X/L. (If you’re curious, you can verify this in the Data 
Spreadsheet dialog, as we did previously with Y/b.)

The equation we’ll need is:

{X/L} = ({x} - MINX) / (MAXX - MINX)

There’s a twist that we need to address before we actually perform this calculation. The equation uses the 
MAXX and MINX intrinsic variables. These variables are provided by Tecplot 360 EX and refer to the 
maximum and minimum values of X in all active zones. We want the maximum and minimum X for just 
our slice, so as to calculate the chord, so we need to temporarily deactivate all other zones while we 
perform this calculation.

So open the Zone Style dialog by clicking the Zone Style button in the Plot sidebar.



51

Right-click the Show Zone checkbox for the extracted slice zone and choose Show Selected Only.

The checkboxes next to all zones except the slice zone toggle off. Your plot also disappears; don’t panic!

Now, choose Data>Alter>Specify Equations and enter our equation in the Equation(s) field. For 
convenience, here it is again:

{X/L} = ({x} - MINX) / (MAXX - MINX)

Since we need this calculation only for the slice, make sure our new slice zone, listed at the bottom of the 
Zones To Alter list as “10: Slice Y=0.65” is the only zone selected. 

Now you’re ready to click Compute.

After the calculation is complete, go back to the Zone Style dialog and turn the disabled zones back on by 
selecting all rows (Control-A, or Command-A on Mac, is a handy keyboard shortcut for this), then 
toggling on the Show checkboxes for any disabled zone. This toggles on all selected zones.

You can now close both the Zone Style and Specify Equations dialogs.

Step 7  Create XY Plot of Slice
We’re ready to create an XY plot of the slice. We’ll put it in its own frame: frames are the Tecplot 360 EX 
way of showing multiple plots on a page.
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First, click the frame tool in the Tecplot 360 EX toolbar.

Next, use it to draw the new frame in the workspace. The placement and size don’t matter, since we’ll have 
Tecplot 360 EX set it up nicely for us in a moment. Click and hold the mouse button somewhere in your 
plot, then drag down and to the right to create the frame. Release the mouse button when a rectangle is 
visible in the plot. 

The new frame might look something like this.

Next, choose Frame>Tile Frames in the Tecplot 360 EX menu bar. The Tile dialog appears, as shown here.
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Click the bottom right button in the Tile Frames dialog to stack the frames on top of each other in the 
workspace. Then close the Tile dialog. 

Your plot now looks something like this.

Now, using the drop-down menu at the top of the Plot sidebar, change from 
Sketch to XY Line.

The Create Mappings dialog appears. In this dialog, we’ll set the X-Axis to 
our X/L variable, our Y-Axis to Pressure_Coefficient, and the Zone to our 
extracted slice zone. The desired settings are shown here.
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Click OK to create the plot, which is shown here.

If you’re familiar with Cp plots, you’ll notice something odd about our current plot! The problem is that 
the Y axis is reversed from what it should be. Fortunately, this is easily corrected.

1. Choose Plot>Axis from the menu bar to open the Axis Details dialog.

2. Click Y1 at the top to choose the Y axis.

3. Toggle on the Reverse Axis Direction checkbox.

4. When the settings are as shown here, close the Axis Details dialog.
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Our plot now looks like this. Much better!

Step 8  Plot Experimental Data
We’re in the home stretch now! Let’s add the experimental data to our plot. First, open the Mapping Style 
dialog by clicking the Mapping Style button in the Plot sidebar.

A line map is the Tecplot 360 EX way of associating (mapping) a variable with a visual style for each line in 
your plot. Tecplot 360 EX created our first line map for us when we switched to XY Line mode. The 
Mapping Style dialog is used to manage the line maps in our XY Line plot.

We want to show both the simulation and experimental data in our plot, so we’ll need to create a second 
line map for the experimental data. The easiest way to do this is to copy the existing simulation data line 
map and modify it to display the experimental data.

1. Click the first row in the Mapping Style table to select the first line map.

2. Click the Copy Map button at the bottom of the dialog. A second line map appears in the 
table.

3. Right-click the Zone field in the second row of the table, then choose zone 5, “Section 3 - .65”, 
as the zone for the second line map. This is the experimental data for the pressure tap at 0.65 
along the wing, corresponding to the position of the slice we’ve taken of the simulation zone.

4. Toggle on the Show Map checkbox for the second map.
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5. Double-click the name of each mapping and enter an appropriate name. Especially with 
complex line plots with many mappings, giving your mappings good names will make it 
much easier to make changes to the plot. We named them as follows:

• Map 1: CFD Simulation: Y/b = 0.65

• Map 2: Experimental: Y/b = 0.65

The Mapping Style dialog and the plot should now appear as shown here.

As you can see, there’s a slight problem here: both the simulation and the experimental data have the same 
appearance, making it impossible to distinguish them. We can address this by using different colors for 
the two zones. 

Additionally, the simulation data is continuous, while the experimental data, having been measured at 
specific points along the wing, is discrete. Therefore, we will display the experimental data using a symbol 
at each measurement location rather than as a line. 

Finally, we have uncertainty information for the experimental data, which we can display using error bars. 

All of these appearance changes can be managed using the Mapping Style dialog. Let’s get to it.

1. Change to the Lines page of the Mapping Style dialog using the tabs at the top of the dialog, 
then toggle off the Show Lines checkbox for the Experimental mapping.

2. Also on the Lines page, right-click the line thickness for the CFD Simulation map and change 
it to 0.40% to make it thicker.
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The Lines page should appear as follows.

3. Change to the Symbols page of the Mapping Style dialog. You’ll 
note that all settings are grayed out here. To use the Symbols 
settings, we must enable the Symbols of our plot by toggling on 
the Symbols checkbox on the Plot sidebar.

4. Now that the Symbols settings are available in the Mapping 
Style dialog, turn the symbols off for our CFD Simulation map.

5. Right-click the Outline Color for the Experimental map and 
choose a blue using the Color Chooser.

6. The symbols are way too big, so right-click the Symbol Size for this map and change it to 1.0. 
The Symbols page should look as follows.

Scenic Detour - Line Map Context Menu and Toolbar
Earlier in this tutorial sequence, we suggested you right-click on your 3D plot to 
discover a quick way to make changes to your zone style—without a trip to the 
Zone Style dialog. Try right-clicking on a line in your plot to reveal the line map 
context menu and toolbar (shown at right). Then try to do the next step, adding 
error bars, using the context menu rather than the Mapping Style dialog.
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Step 9  Add Error Bars
The experimental data includes an error variable calculated from data NASA provides about the Onera 
M6 wing, namely that the measurement error for the pressure taps was found to be ±0.02. Let’s add error 
bars to the plot to visualize this information.

1. Change to the Error Bars page of the Mapping Style dialog. As with the Symbols page, all the 
Error Bars settings are initially grayed out. So we will need to toggle on Error Bars in the Plot 
sidebar to enable the Error Bars layer, which makes these settings available in Mapping Style.

2. With the Error Bar settings available in the Mapping Style dialog, toggle on Show Error Bars 
for the Experimental map.

3. Right-click the Error Bar Variable for this map and choose variable 23, “Cp Error.”

4. Right-click the Error Bar Color for the map and choose the same blue you earlier chose for the 
map’s symbols.

The Error Bars page should now look as follows.

You can now close the Mapping Style dialog. The plot should look as follows.
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Step 10  Final Polishing
As a finishing touch, we can add a legend to the plot. Choose 
Plot>Line Legend from the Tecplot 360 EX menu to open the Legend 
dialog, then toggle on the Show Line Legend checkbox.

Let’s also choose View>Nice Fit to Full Size to make the plot look a 
little less crowded against the axes. 

The final plot (including both frames) is shown below.

Naturally, a Tecplot 360 EX layout package (.lpk) file containing a snapshot of the final result of this tutorial 
segment is in OneraM6wing/finallayouts/ExtenalFlowVideo3.lpk in the examples folder in your Tecplot 360 EX 
installation folder.
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2 - 4   Next Steps
This concludes the External Flow tutorial for Tecplot 360 EX. At this point, you may wish to dig in to the 
User’s Manual or Help (Help>Tecplot 360 EX Help) for more details on the product in general or on 
specific features you’ve used in this tutorial.

We regularly create videos to introduce users to features of the product, not just introductory topics for 
new users, but also for advanced users and to highlight new features in the latest release. You can find 
these on our Web site at https://www.tecplot.com/category/tecplot-360-videos/?product=360 or on our 
YouTube channel at https://www.youtube.com/user/tecplot360/.

https://www.tecplot.com/category/tecplot-360-videos/?product=360
https://www.youtube.com/user/tecplot360/
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3 

Understanding Volume Surfaces

This tutorial shows an example of how Tecplot 360 EX renders volume surfaces using Surfaces to Plot. For 
this tutorial, we will be using the duct flow dataset which can be found in the Getting Started Bundle.

This tutorial contains only one segment. The level of complexity is shown below.

A video version of this tutorial is available on the Web at www.tecplot.com/blog/2016/03/04/
understanding-volume-surfaces/. The videos may have minor differences from the printed version of the 
tutorial in this manual, but they end up in the same place.

Number and Level Title and Description

1 - Beginner
Understanding Volume Surfaces - Load the Duct Flow dataset and understand how 
Tecplot views volume surface data.

https://www.tecplot.com/2016/03/04/understanding-volume-surfaces/
https://www.tecplot.com/2016/03/04/understanding-volume-surfaces/
https://tecplot.azureedge.net/data/360GettingStarted.zip
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3 - 1   Understanding Volume Surfaces

Step 1  Launch Tecplot 360 EX and Load the Data Set
Start Tecplot 360 EX from the Start menu (Windows), by typing tec360 in a terminal window (Linux), or by 
double-clicking the application icon in the Applications folder (Mac). We will show the Windows version 
of Tecplot 360 EX in this document, but the product looks substantially the same on other platforms.

To begin loading the surface plot data, click Load Data at the top of the Welcome Screen. (You may also 
choose Load Data from the File drop-down menu in the menu bar, or click the folder icon, second from 
the left, in the toolbar. These other methods are convenient when the Welcome Screen isn’t visible.) 

The Load Data dialog appears.

Navigate to the examples/SimpleData directory located in the installation folder of Tecplot and select the 
DuctFlow.plt file. After opening this file, you’ll see a 3D Cartesian plot like the one below.
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Step 2  Surfaces to Plot and the Zone Style dialog
Currently we are looking at an empty box surrounded by orange dashed lines. These lines represent the 
boundary of the volume zones with no style applied. To understand what we are looking at, let’s look at 
the Surface tab of the Zone Style dialog:

• Open the Zone Style dialog from the Plot sidebar.

• Select the Surfaces tab located at the top and notice the Surfaces to Plot heading.

For performance reasons, the default option for Surfaces to Plot is set to “none” on volume zones. When 
you have a volume zone where youʹd like to see the surface data then change this option. Note that if 
surface zones are in the dataset, they would be shown in the Zone Style dialog as “N/A”.

Step 3  Contours and Surface Data
Now let’s turn on Contour from the Plot sidebar. To show contours, however, 
Tecplot 360 EX must represent this on some sort of surface. Since this data 
only contains volume zones, a Question dialog appears asking to display the 
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surfaces of volume zones. Alternatively, enabling the mesh, contour, shade, vector or scatter layer option 
on the plot sidebar will ask you if you want surfaces turned on for active zones. 

Turning on the surfaces of volume zones can be a resource-heavy operation as it requires loading the 
entire volume zone and calculating which cells represent the outer surface.

Clicking “Yes” on the Question dialog allows Tecplot 360 EX to change the Surfaces to Plot option in the 
Zone Style dialog. The volume surfaces will now be contoured by the first variable that is not an axis 
variable.

Step 4  Changed Surfaces to Plot in the Zone Style Dialog
If the Zone Style dialog was closed previously, open it again by clicking the Zone Style dialog in the Plot 
sidebar.

Navigating to the Surfaces tab, you’ll see that the Surfaces to Plot heading has changed to “Boundary cell 
faces” which allows us to see the contour of surfaces of exposed boundary cells.
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Next Steps

The resulting plot should look similar to what is shown below. Since we did not change the Contour 
variable, the plot is displaying the U Vector variable.

3 - 2   Next Steps
This concludes the Volume Surfaces tutorial for Tecplot 360 EX. At this point, you may wish to dig in to the 
User’s Manual or Help (Help>Tecplot 360 EX Help) for more details on the product in general or on 
specific features you’ve used in this tutorial.

We regularly create videos to introduce users to features of the product, not just introductory topics for 
new users, but also for advanced users and to highlight new features in the latest release. You can find 
these on our Web site at https://www.tecplot.com/category/tecplot-360-videos/?product=360 or on our 
YouTube channel at https://www.youtube.com/user/tecplot360/.

https://www.tecplot.com/category/tecplot-360-videos/?product=360
https://www.youtube.com/user/tecplot360/
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4 

Transient Data

This tutorial uses a vertical-axis wind turbine data set to explore the transient (time-based) capabilities of 
Tecplot 360 EX. This data set comprises 127 time steps and 254 separate files in Fluent format—each time 
step has two files, one for the geometry and one for the data. These files are sizable (over a gigabyte 
compressed), so they are not included with your Tecplot 360 EX installation. Instead, download the  
Getting Started Bundle and unzip the compressed data to a convenient location.

This tutorial is divided into four segments. We have provided a layout file for the end of each segment, so 
you can check your work. The segments are:

A video version of this tutorial is available on the Web at https://www.tecplot.com/2016/03/25/transient-
series-video-1-introduction-transient-data/. The videos may have minor differences from the printed 
version of the tutorial in this manual, but they end up in the same places.

Number and Level Title and Description

1 - Beginner
Loading and Exploring Transient Data - Load the wind turbine simulation data set and 
see how it is organized inside Tecplot 360 EX. Add streamtraces and create an on-screen 
animation of the data set.

2 - Intermediate
Extracting Data - Use Tecplot 360 EX tools and techniques to reduce the amount of data 
that needs to be analyzed, making it easier to understand.

3 - Expert
Frequency Analysis Using Fourier Transform - Perform a Fourier transform to extract 
frequency domain information from the simulation and analyze the sources of pressure 
variations.

4 - Expert
Calculations and Contour Cutoff - Calculate a new variable by using the Tecplot 360 EX 
CFDA Analyzer. Use the Contour Color Cutoff property to isolate a region of interest in 
the plot.

https://www.tecplot.com/2016/03/25/transient-series-video-1-introduction-transient-data/
https://www.tecplot.com/2016/03/25/transient-series-video-1-introduction-transient-data/
https://tecplot.azureedge.net/data/360GettingStarted.zip
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4 - 1   Loading and Exploring Transient Data

Step 1  Launch Tecplot 360 EX and Load the Data Set
Start Tecplot 360 EX from the Start menu (Windows), by typing tec360 in a terminal window (Linux), or by 
double-clicking the application icon in the Applications folder (Mac). We will show the Windows version 
of Tecplot 360 EX in this document, but the product looks substantially the same on other platforms.

To begin loading the wind turbine data, click Load Data at the top of the Welcome Screen. (You may also 
choose Load Data from the File drop-down menu in the menu bar, or click the folder icon, second from 
the left, in the toolbar. These other methods are convenient when the Welcome Screen isn’t visible.) The 
Load Data dialog appears.

Navigate to the windturbineblades folder where you extracted the data files. Select all the files in this 
directory, for example by clicking the first one and then clicking the last one while holding the Shift key, 
then click Open. (If you can’t see the files, choose All Supported Files in the menu at the bottom of the 
dialog.)
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Opening all these data files will take a moment; when Tecplot 360 EX is finished, you’ll see a 2D Cartesian 
plot like the one below.
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Step 2  Get A Good Look
What exactly are we looking at here? This is the full 2D fluid domain, representing the wind turbine’s 
blades and the air surrounding them. Let’s get a better view:

• Display the mesh by turning on the Mesh checkbox in the Plot 
sidebar. The mesh is a collection of interlinked triangles; these 
are the individual cells that were used in the simulation.

• Zoom in. Click the Zoom tool on the toolbar, then use the 
mouse to draw a rectangle around the center of the plot. 
Repeat this two or three times until you see a plot like the one 
below.

So we can see this is a cross-section of a three-bladed vertical wind turbine. The white areas are the blades, 
as you can intuit from their airfoil shape. You can even infer the direction of rotation: counterclockwise.

You may also zoom by placing the mouse pointer in the frame to be zoomed, holding the 
mouse’s middle button or scroll wheel, and moving the mouse up and down.
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Step 3  Dive into Data Set Info
Let’s take a closer look at the data we’ve loaded. Choose Data 
Set Info from the Tecplot 360 EX Data menu to open the Data 
Set Information dialog, shown here.

From here, we can see that there are more than a thousand 
zones in this data set. Each zone represents a region of the 
simulation at a particular point in time.

The number of zones may seem like a lot if you’re not used to 
working with transient data, but if you do the math, this is 
only nine zones per time step. And indeed, if you look at the 
zone list here, you can see that the zone names repeat every 
nine entries: zone 1 and zone 10 are both named dom-1, zone 2 
and zone 11 are both named dom-5, and so on. 

So we have:

• 1143 total zones

• 127 time steps

• 9 zones per time step

If you click through the zones while keeping an eye on the Time Strand field in the panel below the zone 
list, you will discover that the zones that have the same names also have the same time strand. Time 
strands are how Tecplot 360 EX links the zones representing the same region throughout time.

You can also see the solution time of each zone above the time strand as you click on in the zone list. As 
you would expect, zones 1-9 have the same solution time, as do zone 10-18, and so forth. Thus, each set of 
nine zones represents the same point in time.

Step 4  Time Strands in the Zone Style Dialog
Let’s close the Data Set Information dialog and open the Zone Style dialog (below) by clicking the Zone 
Style button in the Plot sidebar.

Here you’ll see nine entries: one for each time strand. (The asterisk next to each zone number indicates that 
it’s not a single zone, but a group of zones having the same time strand.) In this way, the Zone Style dialog 
let you make changes to the “same zone” throughout time all at once, as you’ll usually want to do, instead 
of having to make those changes separately at each time step. So although there are technically hundreds 
of zones in the data, Tecplot 360 EX lets you style them as though there were only nine.

We’re done with the Zone Style dialog, so close it.



71

Step 5  Visualizing a Contour Plot
Right-click the plot to display the context toolbar and menu, as shown here. These allow you to make 
changes to the selected zone. 

From left to right, the icons are Mesh, Contour, Vector, Shade, and Edge. Click the first icon to turn off the 
Mesh layer, then the second icon to turn on the Contour layer. (You can do this in the Plot sidebar if you 
prefer.)

Now your screen should be showing you something like the plot below:
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Step 6  Visualize the Flow With Streamtraces
Tecplot 360 EX can help visualize the flow through the wind turbine by 
adding streamtraces. In the Plot sidebar, turn on the Streamtraces 
checkbox (shown on the right).

The Select Variables dialog appears to choose the variables that represent 
velocity through the fluid; the defaults that Tecplot 360 EX has chosen 
are correct, so just click OK.

After you’ve accepted the vector variables, choose the streamtrace tool in 
the main toolbar, or in the Plot sidebar next to the Streamtraces checkbox.

You are now ready to add streamtraces to your plot, a process called 
seeding. It is convenient to seed a number of equally-spaced points along 
a line, which is referred to as a rake. 

To do this, click in the plot near the top blade of the turbine, then hold the 
mouse button while dragging down between the two lower blades. 
Tecplot 360 EX seeds ten streamtraces at equally-spaced points along the 
line you placed Tecplot 360 EX calculates the path of a massless particle 

forward and backward from each seeded point and draws the path on the plot. 

You may seed additional streamtraces by placing additional rakes in the same way, or seed individual 
points by clicking. A Tecplot 360 EX layout (.lay) file containing a snapshot of the final result of this 
tutorial segment is in WindTurbineBlades/FinalLayouts/transient_1.lay in the Getting Started bundle.
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Step 7  Animate Your Plot
Click the Play button in the Plot sidebar to see how pressure and fluid flow 
change as the wind turbine blades rotate. (Just as we deduced earlier from 
the blade shape, the turbine turns counterclockwise.)

Scenic Detour: Animation Speed
The animation speed can be limited in the Time Animation 
Details dialog, which can be reached by clicking the  button 
next to the animation controls in the Plot sidebar.

The maximum animation speed is limited by the speed at which 
Tecplot 360 EX can draw an individual frame, which depends a 
lot on how fast your computer is and how much of the data has 
already been loaded into memory. However, you can keep 
animations from going too fast by clicking the Limit Animation 
Speed checkbox and entering the desired number of frames per 
second.
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4 - 2   Extracting Data
In this exercise, we will cover extraction techniques that helps you visualize details about your data at a 
particular location, allowing you to focus on exactly what you want to learn. First, we’ll extract data at a 
single time step to a line plot. Then we’ll extract data at a single point over time into a time series plot.

But before we get started, turn off the streamlines you added at the end of the last exercise by turning off 
the Streamtraces checkbox in the Plot sidebar and return to the first time step of the data. Your plot should 
look something like this again:

Save a layout at this point to make it easy to return this exact place for the next exercise.

Step 1  Create a Vertical Line
To draw the line along which we will extract the pressure data, first 
click the polyline geometry tool in the Tecplot 360 EX toolbar. A 
geometry is a shape that appears on your plot. This particular geometry 
tool can be used to create both lines and polygons, hence the name 
polyline.

The line we want to draw is in roughly the same place as the rake we placed for creating streamtraces in 
the previous lesson. But the polyline tool, since it can be used to create both simple lines and more 
complex shapes, works differently from that tool.

To place the line:

• Click and release the mouse button with the pointer positioned just under the topmost blade 
of the turbine. With the polyline tool, you don’t drag the mouse with the button held down.
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• Press the V key on the keyboard to constrain the line to vertical. Now you don’t need to worry 
about making the line perfectly vertical; Tecplot 360 EX does that for you.

• Move the mouse down to the bottom of the green area. You will notice that a vertical black line 
follows the pointer. No matter how you move the mouse horizontally, the line stays put.

• Double-click the mouse to end the creation of the line. (If you had single-clicked, you would 
then be able to move the mouse and create an additional line segment attached to the first.)

The line should look roughly like this on the plot. We have made our line thicker so you can see it better. 
You don’t have to do the same, but if you have a moment, see if you can figure out how.

Step 2  Extract the Line Over Time
 Let’s see how pressure changes along our line over time by creating an 
animated plot of the Y coordinate vs. pressure. To do that, choose Extract 
Polyline Over Time from the Extract submenu of the Data menu.

You will be asked for the number of points to be extracted along that line. The default value, which should 
be 100, is fine.

If we were interested only in a single time-step, we 
could right-click the line and choose Extract Points 
from the context menu.
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Tecplot 360 EX will take just a moment to go through all the 
time steps and extract the data along this line. You can open the 
Data Set Information dialog and see a new zone for each time 
step, named “Extracted Points,” that were created beginning 
with zone number 1144 and ending with zone number 1270.  

Each new zone is assigned the correct solution time and given a 
time strand to connect it to the others, just as we saw when we 
inspected the data in our file earlier. 

That’s 127 new zones in all, which matches the number of time 
steps in the file. All of these new zones are assigned to time 
strand 10, which makes sense because, previously, there were 
nine variables per time step and thus nine time strands. You can 
also see that each of the new zones has the same variable names 
as the previously-existing zones. 

So, as we expect, we have extracted the data along the line over 
time.
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Step 3  Create A Line Plot of Pressure
Let’s see what the pressure looks like along our extraction line by 
creating a line plot. We can display this line plot side-by-side 
with the contour plot and even animate them together.

First, choose the New Frame tool in the Tecplot 360 EX toolbar. 
Then hold the mouse button down and drag out a rectangle on the plot. It doesn’t matter where; we will 
resize and reposition it in the next step. Your new frame might look something like this.
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Let’s get that new frame into position. Choose Tile Frames from the Frame menu, 
then click the bottom-right button. This will stretch both frames to the width of the 
workspace and position them one above the other, as seen here.

Let’s go ahead and zoom out that top frame a bit and reposition it so that 
we can see the whole wind turbine. To do this, we will use the Zoom and 
Translate tools in the toolbar. 

• Choose the Translate tool and drag the plot in the top frame so 
that it is centered

• Choose the Zoom tool, then hold down the Control key while clicking the plot to zoom out one 
step.

The top frame should look more like this now:

Now we’ll turn our attention to the bottom frame, where we’ll create a line plot of pressure along the line 
we placed on the plot earlier.
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• Choose the selector (arrow) tool from the Tecplot 360 EX toolbar and click the bottom frame to 
select it.

• Change the plot mode to 2D Cartesian using the menu at the 
top of the Plot sidebar.

You might think to use an XY Line plot for this kind of data, and 
normally you could, but XY Line plots don’t have the transient 
capabilities of 2D Cartesian plots.

In the bottom frame, you’ll see a gray circle very similar to the 
plot that appeared when we first opened this data set.

• Use the Zone Style dialog to turn off all zones except for the 
Extracted Points zone. Click the Zone Style button in the Plot 
sidebar, then right-click in the Show Zone column of the last 
zone listed and choose Show Selected Only.

Note that this zone has an asterisk by its number, indicating that it has a time strand, as we 
have previously seen in the Data Set Information dialog. Thus, when we make only this zone 
visible, it is the only zone visible at all time steps.

Close the Zone Style dialog after doing this.

• To assign variables to the axes, choose Assign XY from the 
Plot menu, then selecting the Y and Pressure variables for the 
X and Y axes as shown here.

Your line plot still looks very blank at the moment.

• Activate the Mesh checkbox in the Plot sidebar to see the line. 

It’s all scrunched up along the left side of the plot because the 
axes aren’t set up properly. We’ll take care of that next.
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• Choose Axis from the Plot menu to open the Axis Details dialog. Change the Dependency 
radio button for the X axis to Independent, as shown here.

We’ll let Tecplot 360 EX choose the range for the axis. Leaving the Axis Details dialog open,  
choose Data Fit from the View menu in the main Tecplot 360 EX window. (You can also just 
press Control-F.)

• The Data Fit operation also set a range for the Y axis, but it did so only considering the Y-axis 
range of the first time step. The range of Pressure at the first time step is not representative of 
all time steps, so we will manually specify an appropriate Y-axis range. 

Change to the Y axis using the button at the top of the Axis Details dialog, then enter -100 and 
-30 as the minimum and maximum.

• Close the Axis Details dialog.
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The plot in the bottom frame should now look a lot like this:

Step 4  Link the Time Steps and Animate the Plot
If you try animating the plot by pressing the Play button on the Plot 
sidebar, you will notice that only the active frame animates. To get 
both frames animating together, we will link them so they always 
display the same time step.

To do this, choose Frame Linking from the Frame menu to open the 
Set Links for Active Frame dialog.

On the Between Frames page, mark the Solution Time checkbox, then click the Apply Settings to All 
Frames of this Group button. Close the dialog and try animating again!

Scenic Detour: Add Solution Time Caption
It would be nice to be able to see what the solution time is right on the plot, without having to look at the 
Plot sidebar. This might be of particular utility if you were exporting a video. To do this:

• Click the Add Text tool in the Tecplot 360 EX toolbar.

• Click on the plot where you want the text to appear. 

This displays the Text Details dialog, where you can enter text 
and choose its formatting.
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• In the Text Details dialog, enter Solution Time: &(SOLUTIONTIME)

The text starting with an ampersand is a dynamic text placeholder. Tecplot 360 EX replaces it 
with the current solution time when displaying it in the plot.

• Click Accept to close the Text Details dialog.

Animate again and watch the solution time change!

Step 5  Time Series Plot
We have seen how to create a line plot showing the pressure along a line at each time step. Using 
animation, we can show how that changes over time. Now we’ll reduce the dimensionality even further by 
creating a single line plot showing how pressure varies at a single point.

To create this time series plot, choose Probe to Create Time Series Plot from the Tools menu, then click as 
close to 0, 0 as you can get on the contour plot (top frame). Hint: the X and Y coordinates of the mouse 
cursor are displayed in the bottom right corner of the Tecplot 360 EX workspace.

After you click, Tecplot 360 EX spends a moment gathering the pressure value for that point for all time 
steps, then displays the time series plot in a new frame overlapping the contour plot.
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When you animate, a moving vertical line appears in this plot to indicate the current time step.

All three plots (the contour plot, the pressure line plot, and the time series plot) animate at the same time.

Try using the Tile Frames tool we used earlier to find a good arrangement for your three frames. You’ll 
probably need to re-position and zoom out on the contour plot again.
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4 - 3   Frequency Analysis Using Fourier Transform
As we can see from the time series plot we just created, pressure varies over time and appears to do so as a 
wave. In this exercise, we’ll analyze the fundamental frequency of the pressure waves in the data using a 
Fourier transform, and see how this varies when changing the probe location.

Before starting, let’s delete the middle frame (which shows the pressure along the 
line). First, choose the selector tool (shown on right) in the toolbar, if it isn’t already 
selected. Then click the edge of the middle frame to select it, then press the Delete 
key on your keyboard.

Finally, re-tile the frames by choosing Tile Frames from the Frame menu. You may want to zoom in a little 
the contour plot and/or re-center it. The plot should look something like this.
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Frequency Analysis Using Fourier Transform

Step 1  Fourier Transform
Select the bottom frame (containing the time series plot) with the selector (arrow) tool, then choose Fourier 
Transform from the Data menu. The Discrete Fourier Transform dialog, shown here, appears.

In this dialog, choose Pressure as the dependent variable and make sure the Time Series Plot Zone is 
selected as the source zone. Using the Plot Placement drop-down menu, choose to tile the new frame with 
existing frames. Leave everything else the same. Click Transform to perform the Fourier transform.

A new frame appears, showing Frequency (Solution Time)-1 on the X axis and Amplitude (Pressure) on the 
Y axis.

Looking at this plot, we can easily see that there is a low-frequency spike at around 5 Hz and a higher-
frequency spike at about 77 Hz. This matches what we see in the time series plot: a lower-frequency (high-
period) wave overlaid by a higher-frequency (low-period) wave. The combination makes the time series 
plot look a little jagged.

From watching the animation, we can attribute the lower-frequency pressure changes to the movement of 
the blades. However, we don’t have an obvious explanation for the higher-frequency changes.
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Before going further, let’s have a quick look at what the Fourier Transform actually did to our data set by 
popping into Data Set Information (choose Data Set Info from the Data menu). Make sure that the Fourier 
plot frame is selected.

As you can see, Tecplot 360 EX has created a new Fourier Transform zone based on the Time Series Plot 
and added three new variables starting with variable 37. (The other zone and the first 36 variables were 
created when we generated the time series plot.) 

The new variables are the frequency, amplitude, and phase output from the Fourier transform. We only 
selected Pressure as our dependent variable in the transform, but if we had selected more, there would be 
three new variables for each one we selected.

Step 2  Re-Analyzing at a New Position
Let’s see if we can find out what’s causing the higher-frequency changes. To do this, we’ll re-probe well 
outside the turbine, near the left inlet. Then we’ll create a new time series plot and re-do the Fourier 
transform.
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Frequency Analysis Using Fourier Transform

Zoom out the contour plot so that you see most or all of the fluid domain surrounding the turbine. The 
blades will be very small in the center of the plot. At right you’ll see we’ve zoomed all the way out. The 
mouse pointer is placed roughly where we’ll be probing.

Now choose Probe to Create Time Series Plot from the Tools menu again, and click close to the indicated 
position on the plot. A new time series plot is created.

Right away, you can see that this plot has less obvious order in it.
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Since our Fourier transform plot was calculated from the data in the old time series plot, it disappears. But 
we can re-create it easily. Simply right-click the line in the time series plot to display the context menu and 
toolbar. Then choose Fourier Transform from the menu.

A new Fourier transform plot is created using the options previously set in the Discrete Fourier Transform 
dialog. It looks something like the plot below.

Here, the main frequency is the one we previously saw at around 77 Hz. The lower frequency around 5 Hz 
is no longer there, indicating that we are probing far enough away to avoid the effects of the turbine 
blades. We can conclude that the 77 Hz frequency is an input boundary condition. 

A Tecplot 360 EX layout (.lay) file containing a snapshot of the final result of this tutorial segment is in 
WindTurbineBlades/FinalLayouts/transient_2.lay in the Getting Started bundle.

Your Turn
Try analyzing other variables, such as Turbulent Viscosity. By probing near where vortices are shed, you 
can see how changes in turbulent viscosity are solely due to the motion of the turbine blades. We will 
delve into this in more detail in the next exercise.
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Calculations and Contour Cutoff

4 - 4   Calculations and Contour Cutoff
Tecplot 360 EX’s CFD analysis tools have many tricks up their sleeve. One of the most important is the 
ability to calculate commonly-needed variables that are not actually present in the data set. Why have 
your solver calculate, say, vorticity magnitude (and expend disk space storing these values) when it can be 
easily derived from values already in the data set? 

Furthermore, Tecplot 360 EX can calculate these values on demand, so no time is spent on calculating them 
unless and until we choose to visualize them. This means that until we use vorticity magnitude in a plot, it 
does not need to be calculated at all. And even when the variable is being used in a plot, it will not be 
calculated for a given time step until we actually view that time step. (Once calculated, however, the value 
remains in memory, so returning to a time step usually won’t require it to be calculated a second time.) So, 
if we will be looking at only ten or fifteen time steps in our data set, using calculate-on-demand will save 
us around 90% of the time we might have spent calculating vorticity magnitude.

In this exercise, we’ll calculate Vorticity Magnitude using the Tecplot 360 EX CFD analysis tools. Then 
we’ll adjust the contour color cutoff to isolate interesting regions of the plot.

We’ll only need the contour plot for this exercise. You can delete the frames containing the time series and 
Fourier plots you created in the previous exercise and re-tile so that the contour plot frame fills the 
workspace. Re-zoom and re-center as needed.

Step 1  Set Field Variables
Before we can calculate the new variable, we must make sure that the baseline variables are assigned in the 
Field Variables dialog. To open this dialog, choose Field Variables from the Analyze menu.

Tecplot 360 EX has chosen defaults that match what it thinks you want to do:

• X Velocity and Y Velocity have been chosen as the convective variables U and V.

• Pressure and Density have been chosen as the corresponding state variables.

For this data set, these defaults are correct, so you can just click OK. For other data sets, you may need to 
choose different variables.
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Step 2  Calculate Vorticity Magnitude
To calculate vorticity magnitude, just choose Calculate Variables from the Analyze menu. This displays 
the Calculate dialog.

Click the Select button to choose the variable to be calculated. This 
displays the Select Function dialog.

As you can see, there are literally dozens of variables that Tecplot 
360 EX can calculate for you. Choose Vorticity Magnitude in the list 
then click OK to return to the Calculate dialog. The default options 
in the Calculate dialog are acceptable (note that the Calculate on 
Demand checkbox is checked!) so go ahead and click Calculate.

Tecplot 360 EX sets up calculate-on-demand for Vorticity Magnitude 
and adds the variable to the data set, and tells us that’s what it has 
done via an alert. 

We can now close the Calculate dialog.

Step 3  Show Vorticity Magnitude on Contour Plot
To actually show our newly-calculated variable on our plot, open the 
Contour Details dialog by clicking the  button next to the Contours 
checkbox in the Plot sidebar. The Contour Details dialog appears.
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Calculations and Contour Cutoff

In the Contour Details dialog:

• Choose Vorticity Magnitude from the menu at the top of the 
dialog.

• Click the Set Levels button to display the Enter Contour 
Levels dialog, shown at right.

In this dialog:

• Choose “Exact levels” for the level creation mode.

• Choose “Min, max and number of levels” for the range 
distribution.

• Enter 0, 50, and 21 as the minimum, maximum, and 
number of levels.

When the dialog is as shown, click OK.

You may now move the Contour Details dialog to the side to get a good 
look at the plot. However, leave it open; we will have need for it again 
soon.
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The contour plot should now look something like this.

Step 4  Adjust Cutoff
This plot is good, but we can make it better by only coloring areas with vorticity above a critical value, 
improving the impact of locations of higher vorticity.

Back in the Contour Details dialog, set the contours to cut off below a value of 7. This field is in the lower 
right portion of the dialog.

This makes our vortices stand out by eliminating all contouring below 7. You might experiment with 
slightly lower and higher values to see more or less. Now we must remove the legend as it is overlapping 
a region of interest on our plot.
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Calculations and Contour Cutoff

Step 5  Polishing the Plot
One last trip to the Contour Details dialog. Switch to the 
dialog’s Legend page, change the alignment to horizontal, 
and activate the Resize Automatically checkbox.

You can close the Contour Details dialog. Switch to the 
Selector arrow tool, select the legend by clicking on the 
box around it, and drag the legend to the top center of the 
plot.

Using the translation tool in the toolbar, move the wind 
turbine blades a little to the left, so we can see more of the 
vortices being shed.

You can see our final vorticity plot below.

A Tecplot 360 EX layout (.lay) file containing a snapshot of the final result of this tutorial segment is in 
WindTurbineBlades/FinalLayouts/transient_3.lay in the Getting Started bundle.

You can also translate a plot by holding 
down the right mouse button and 
dragging. This works when any tool is 
active.
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Step 6  Animate It
Click the Play button in the Plot sidebar to begin animating the plot.

You’ll notice that the first time through, the animation is a little slow. This 
is because Vorticity Magnitude is a calculate-on-demand variable, as we 
discussed earlier. It takes a moment to calculate this variable the first time 
each time step is plotted. 

After the first time through, theK animation will repeat. Since the Vorticity Magnitude variable has 
already been calculated for each time step, it does not need to be calculated again, and the animation 
moves much more quickly and smoothly the second and subsequent times through.

4 - 5   Next Steps
This concludes the Transient tutorial for Tecplot 360 EX. At this point, you may wish to dig in to the User’s 
Manual or Help (Help>Tecplot 360 EX Help) for more details on the product in general or on specific 
features you’ve used in this tutorial.

We regularly create videos to introduce users to features of the product, not just introductory topics for 
new users, but also for advanced users and to highlight new features in the latest release. You can find 
these on our Web site at https://www.tecplot.com/category/tecplot-360-videos/?product=360 or on our 
YouTube channel at https://www.youtube.com/user/tecplot360/.

https://www.tecplot.com/category/tecplot-360-videos/?product=360
https://www.youtube.com/user/tecplot360/
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5 

Finite Element Analysis

This tutorial uses a transient FEA dataset of a connecting rod created with LS-DYNA. The connecting rod 
data contains 32 time steps with 32 different variables from the LS-DYNA program of a rod rotating about 
a point. The data may be downloaded from the Getting Started Bundle.

The Finite Element Analysis tutorial contains three different segments. The segments will explore multiple 
ways to visualize the maximum Von Mises Stress of the rotating rod. We have provided a layout file for 
the end of each segment, so you can check your work. The overall difficulty, description, and features used 
in each segment are shown below: 

A video version of this tutorial is available on the web at: https://www.tecplot.com/category/tecplot-360-
videos/finite-element-analysis/. The videos may have minor differences from the printed version of the 
tutorial in this manual, but they cover the same material. The third segment of this tutorial is not in the 
video series as it contains few visual steps and is better explained in writing.

Number and 
Level

Title and Description Features Used

1 - Intermediate

Calculating Von Mises Stress Along a Surface - 
Calculate the Von Mises stress of the connecting 
rod data set and contour to find areas of high 
stress.

• Animation

• Color Cutoff

• Contour

• FEA Post-Processing

• Value Blanking

• 3D Multi Frames

2 - Intermediate
Data Alter with If Statements - Use an if statement 
to calculate where a stress threshold is being 
crossed.

• Data Alter

• Zone Style

3 - Intermediate
Plot Maximum Stress Over Time - Use a macro to 
plot Maximum Stress over time and link solution 
times between frames. 

• Frame Linking

• Macro Commands

• XY Plotting

https://www.tecplot.com/category/tecplot-360-videos/finite-element-analysis/
https://www.tecplot.com/category/tecplot-360-videos/finite-element-analysis/
https://tecplot.azureedge.net/data/360GettingStarted.zip
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5 - 1   Calculating Von Mises Stress Along a Surface
This section will calculate the Von Mises stress of the connecting rod data set and contour to find areas of 
high stress.

Step 1  Load the Data Set
To begin loading the connecting rod data, select Load Data at the top of the Welcome Screen. (You may 
also choose Load Data from the File drop-down menu in the menu bar, or click the folder icon, second 
from the left, in the toolbar. These other methods are convenient when the Welcome Screen isn’t visible.) 
The Load Data dialog appears.

Navigate to the downloaded and extracted ConnectingRod folder, open the menu on the bottom right of the 
dialog, and select All Supported Files. Load the D3PLOT file.
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Your loaded data only shows an orange dotted box, select Contour on the Plot sidebar, select Yes on the 
question dialog that appears, and your plot should look similar to the above picture. Refer to Section 3 - 1 
“Understanding Volume Surfaces” on page 62 to learn about the Surfaces to Plot option.

Step 2  Slow Animation down
Press the play button, , on the plot sidebar and notice the machine parts in motion. If the animation is 
too fast, press the  button above the animation slider and select the checkbox next to “Limit animation 
speed to”, limiting the animation to 12 frames per second. 

The resulting animation is now slower the next time the play button is pressed. Close the Time 
Animation Details window.
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Step 3  Calculate Von Mises stress
Open the Data Set Information window by selecting Data>Data Set Info... and notice how the data is 
configured. Each Zone pertains to a different time step and has the same variables. In the variables box, 
notice that the stress components for each direction are included in the dataset (variables 10-15) thus 
allowing the ability to calculate the Von Mises stress.

Next, select Tools>FEA Post-Processing to open the “FEA Post-Processing Window”. Under the Derive 
Variables section derive “Von Mises Stress/Strain” from “Stress” (the Stress variables shown below). 
Click Add to Data Set. Now on the Data Set Information page, Von Mises Stress appears as variable 33. 
Close the FEA Post-Processing dialog and close the Data Set Information dialog.
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Step 4  Contour by Von Mises Stress
To begin contouring, select the  button next to the Contour checkbox on the 
plot sidebar to open the Contour & Multi-Coloring Details dialog. Currently, X 
Acceleration is the contour variable of the first contour group. Change the 
contour group variable to Von Mises Stress by selecting the drop-down box at 
the top of the dialog. 

Tecplot 360 EX allows up to eight contour groups, each with their own contour 
variable and levels. This allows multiple contour surfaces to be plotted at the 
same time. In this tutorial, only one contour surface needs to be plotted. 

Next, select the Set Levels... button and change the minimum level to be 0, maximum level to be 900, and 
the number of levels to be 21. The resulting Enter Contour Levels dialog should look like the picture 
below. Select OK. Close the Contour & Multi-Coloring Details dialog for now.
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Step 5  Isolate the Connecting Rod
Currently, the crankshaft and cylinder are in the way of viewing the connecting rod. Since the data set 
consists of one zone and many time steps, Value Blanking will allow the connecting rod to be seen more 
clearly. Select Plot>Blanking>Value Blanking from the toolbar to open the Value Blanking window. 
Under the Blank when section change the blanking constraints to be when Von Mises Stress is equal to 0. 
Select both the Include Value Blanking checkbox as well as the Active checkbox to enable the current 
blanking constraint. Now only the connecting rod is shown. Close the Value Blanking dialog. 

The resulting plot isolates the connecting rod because the Von Mises stress contour values are equal to 
zero on the crankshaft and cylinder. Though the parts still exist in the data set, they do not give helpful 
information. In the Value Blanking dialog, multiple constraints can be enabled at once to confine the plot 
view to very specific areas. For this situation, only one constraint was needed.
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Step 6  Identify the Critical Failure Threshold
When clicking the play button again, the Von Mises Stress ranges between 0 and 900 at different steps in 
the cycle. The values of interest are when the Von Mises Stress exceeds 800. This is the critical failure 
threshold. To highlight the critical failure threshold, turn on Color Cutoff located in the Contour & Multi-
Coloring Details dialog and cutoff below 800. Close the Contour & Multi-Coloring Details dialog.

Now when playing the animation, there are two steps that are above the critical failure threshold. Turning 
on translucency by the checkbox on the plot sidebar can give a better view of the part.
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Step 7  3D Multi Frames
Visualization can be further improved by selecting the 3D Multi Frames option. Select Frame>3D Multi 
Frames then select the top left option and three extra frames will appear. These frames are extra 
orthographic projections of the connecting rod and are created automatically. Notice when the play button 
is pressed again, the frames are automatically linked to each other and all frames animate together.

A Tecplot 360 EX layout (.lay) file containing a snapshot of the final result of this tutorial segment is in 
ConnectingRod/FinalLayouts/connecting_rod_1.lay in the Getting Started bundle.
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5 - 2   Data Alter with If Statements
This section will use an if statement to calculate where a stress threshold is being crossed.

If you have continued from the previous section, be sure to return your screen to one frame. This can be 
done quickly by selecting Frame>3D Multi Frame and selecting the icon with the red x (on the bottom 
right). The screen should now only display one frame.

If you have not completed the previous section, calculate the Von Mises stress (see Step 3 Calculate Von 
Mises stress), and turn on Value Blanking for Von Mises Stress equal to zero (see Step 5 Isolate the 
Connecting Rod). 

Step 1  Specify an Equation
Select Data>Alter>Specify Equations from the menu bar to launch the Specify Equations dialog. Type the 
following equation into the text field: {maxStress} = IF ({Von Mises Stress}>800, 0, 1).

Press the Compute button at the bottom and an Information popup will appear, “Data alteration 
successful.” Click OK and close the Specify Equations dialog.

Step 2  Contour It
Open the Contour & Multi-Coloring Details dialog again by selecting the  button next to Contour on 
the plot sidebar. Change the contour variable to be the variable just created, maxStress. Check that the 
Contour settings looks similar to the image below. Remember to remove the color cutoff if it was set in the 
previous section.
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If your data does not contain the amount of contour levels as the above picture, select the Set Levels 
button. This will bring up the Enter Contour Levels dialog. Set the Level Creation mode to “Exact Levels” 
and set the minimum, maximum, and delta to 0.05, 0.95, and 0.05, respectively. See Step 4 Contour by 
Von Mises Stress for more information.

Now the regions where the threshold of 800, specified in the if statement, are revealed. However, Tecplot 
360 EX is not only plotting 0 and 1, as expected. By default, Tecplot 360 EX will interpolate values between 
cell values. Close the Contour & Multi-Coloring Details dialog.
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Step 3  Flood by Primary Cell Value
To minimize interpolation by contouring, open the Zone Style dialog located on the plot sidebar. Select 
the Contour tab and set the Contour Type to “Primary value flood”. 

Close the Zone Style dialog and notice that the resulting plot contains only yellow and blue. The blue 
cells occur when the Von Mises stress threshold is met or being exceeded. 
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5 - 3   Plot Maximum Stress Over Time
This section will use a macro to plot Maximum Stress over time and link solution times between frames. 

Step 1  Load the Macro
If you are continuing from the previous section, return the Contour variable back to Von Mises Stress (see 
Contour by Von Mises Stress for more information). Then, click Scripting>Play Macro/Script... and the 
“Open Macro” dialog will appear. Navigate to the connecting rod folder again and select 
PlotMaxContourOverTime.mcr.

After selecting Open, the macro will automatically run, creating an XY plot of the maximum value of Von 
Mises stress at each time step. When the play button is pressed, a marker line follows over the XY plot to 
track the solution time.

A Tecplot 360 EX layout (.lay) file containing a snapshot of the final result of this tutorial segment is in 
ConnectingRod/FinalLayouts/connecting_rod_2.lay in the Getting Started bundle.

Step 2  Macro Breakdown: Create a Zone
This first portion of the macro file takes the first contour variable and finds its name. Then, the macro finds 
the number of time steps in the transient data and creates a zone.

# Get the variable name of the contour variable (limited to Contour 
Group #1)
$!EXTENDEDCOMMAND 
  COMMANDPROCESSORID='extendmcr'
  COMMAND='QUERY.VARNUMBYASSIGNMENT "C" ContourVarNum'
$!EXTENDEDCOMMAND 
  COMMANDPROCESSORID='extendmcr'
  COMMAND='QUERY.VARNAMEBYNUM |ContourVarNum| ContourVarName'
#
# Create a new zone that represents the MAXC value
# over time.  MAXC returns the maximum value of the
# variable which is assigned to Contour Group #1. See
# the scripting guide for more detail on MAXC.
#
$!EXTENDEDCOMMAND 
  COMMANDPROCESSORID='Extend Time MCR'
  COMMAND='QUERY.NUMTIMESTEPS NUMTIMESTEPS'
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To begin, the first two extended commands in conjunction get the variable name by extracting the variable 
number by the variable defined in Contour Group 1, then using that to extract the name. The script will 
then use this as part of the new zones name. 

The script then determines the number of time steps using the ‘QUERY.NUMTIMESTEPS’ which is then 
used to create an I-ordered zone (rectangular zone where J = K = 1) dimensioned by the number of time 
steps. 

Using the $!VARSET command, a new internal macro variable is created based on the total number of 
zones. Since the new zone is the last zone created, its index is equal to the maximum number of zones. 
Then the zone is renamed using the Contour variable name found earlier.

Step 3  Macro Breakdown: Alter Variables
The next step is to populate the zone created in step 2 with the maximum value of Von Mises Stress. The 
key to this process is using the |MAXC| intrinsic variable which returns the maximum value of the 
currently active zones.

$!CREATERECTANGULARZONE 
  IMAX = |NUMTIMESTEPS|
  JMAX = 1
  KMAX = 1
  X1 = 0
  Y1 = 0
  Z1 = 0
  X2 = 1
  Y2 = 0
  Z2 = 0
$!VARSET |TimeZone| = |NUMZONES|
$!RENAMEDATASETZONE
  ZONE = |TimeZone|
  Name = "Max |ContourVarName| over Time"

Places where vertical bars are used indicate the use of a macro variable. These 
can be defined by an intrinsic variable (see Scripting Guide), the 
$!VARSETCOMMAND, or specific $!EXTENDEDCOMMAND calls.

$!LOOP |NUMTIMESTEPS|
 $!EXTENDEDCOMMAND 
    COMMANDPROCESSORID='Extend Time MCR' 
    COMMAND='SET.CURTIMESTEP |LOOP|'
 $!EXTENDEDCOMMAND 
    COMMANDPROCESSORID='Extend Time MCR' 
    COMMAND='QUERY.TIMEATSTEP |LOOP| SolutionTime'
  # Instead of creating new variables, we just reuse variables
  # #1 and #2. This keeps the dataset a little cleaner, but if we
  # really wanted to create new variables we could do so using
  # the $!ALTERDATA command
  # Variable #1 represents Solution Time
  $!SETFIELDVALUE
    ZONE = |TimeZone|
    VAR = 1
    INDEX = |LOOP|
    FIELDVALUE = |SolutionTime|
  # Variable #2 represent the Max Contour Value
  $!SETFIELDVALUE
    ZONE = |TimeZone|
    VAR = 2
    INDEX = |LOOP|
    FIELDVALUE = |MAXC|
$!ENDLOOP

../doc/360_scripting_guide.pdf
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This portion of the macro loops through all time steps activating the current time step though 
‘SET.CURTIMESTEP’ which ensure that only the zone in current time are active and used in the |MAXC| 
calculation. 

Also in the loop, the $!SETFIELDVALUE command is used to set the point value for the specified variable 
and zone. In this case we are setting the solution time extracted by the ‘QUERY.TIMEATSTEP’ and the 
|MAXC| value to the zone created in step 2. 

In preparation for creating a new XY plot the macro performs some simple actions to clean up the plot.

First, the newly created zoneʹs field map is removed from showing the original plot, since it may affect 
how it is displayed. Then Frame linking is turned on and the frame is brought to the top.

Step 4  Macro Breakdown: Create XY Plot
The next step is to create a new XY plot for the newly created zone with a marker which indicates the 
current time step of the 3D plot. 

The XY position and dimensions are provided to create a new frame. This new frame automatically 
becomes the new active frame. For this reason, changing the plot type and other commands called after 
the $!CREATENEWFRAME command only affect the newest frame and not the original. 

|LOOP| when inside a loop is an intrinsic variable to return the value of the 
current loop count.

# We deactivate the zone we just created because we don't want it
# to display in the current plot.  We'll show it in a new frame instead.
$!ACTIVEFIELDZONES -= [|TimeZone|]
# Turn on Time linking because we'll be turning on the
# Solution Time axis marker on the following XY frame and
# we want that marker to update as we animate over time.
$!LINKING BETWEENFRAMES {LINKSOLUTIONTIME = YES}
# Make sure the active frame is at the top of the frame stack.  This
# ensures that the new frame we create below will inherit this dataset
$!FRAMECONTROL MOVETOTOPACTIVE

# Now plot the new zone in an XY plot
$!CREATENEWFRAME 
  XYPOS
    {
    X = 1.3947
    Y = 4.6447
    }
  WIDTH = 8.1217
  HEIGHT = 3.2862
$!PLOTTYPE = XYLINE
$!DELETELINEMAPS 
$!CREATELINEMAP 
$!LINEMAP [1]  NAME = 'Max |ContourVarName| Over Time'
$!LINEMAP [1]  ASSIGN{ZONE = |TimeZone|}
$!ACTIVELINEMAPS += [1]
$!VIEW FIT
$!XYLINEAXIS XDETAIL 1 {TITLE{TITLEMODE = USETEXT}}
$!XYLINEAXIS XDETAIL 1 {TITLE{TEXT = 'Solution Time'}}
$!XYLINEAXIS YDETAIL 1 {TITLE{TITLEMODE = USETEXT}}
$!XYLINEAXIS YDETAIL 1 {TITLE{TEXT = 'Max |ContourVarName|'}}
# Show the solution time axis marker in the XY frame. We turn
# on solution time frame linking to ensure the line updates when
# we animate in the other frame.
$!LINKING BETWEENFRAMES {LINKSOLUTIONTIME = YES}
$!XYLINEAXIS XDETAIL 1 {MARKERGRIDLINE{SHOW = YES}}
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By default, when the plot type is changed to XY Line, line maps are automatically created. The 
$!DELETELINEMAPS command must be called in order to create custom line maps. In this case, only one 
line map is needed. The name and zones are assigned to the newly created line map and it is then 
activated. By default, line maps will use the first two variables of each zone, hence why only the first two 
variables were edited in step 3.

To clean up the plot for presentation, the title is set using the XYLINEAXIS commands. The final two lines 
ensure that the new frame is linking solution time with the previous one and create a marker line to track 
the current solution time between both frames.

5 - 4   Next Steps
This concludes the Finite Element Analysis tutorial for Tecplot 360 EX. At this point, you may wish to dig 
in to the User’s Manual or Help (Help>Tecplot 360 EX Help) for more details on the product in general or 
on specific features you’ve used in this tutorial.

We regularly create videos to introduce users to features of the product, not just introductory topics for 
new users, but also for advanced users and to highlight new features in the latest release. You can find 
these on our Web site at https://www.tecplot.com/category/tecplot-360-videos/?product=360 or on our 
YouTube channel at https://www.youtube.com/user/tecplot360/.

https://www.tecplot.com/category/tecplot-360-videos/?product=360
https://www.youtube.com/user/tecplot360/


 Part 2  Internal 
Combustion Engines
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6 

Internal Combustion Engines

This tutorial uses a transient CONVERGE dataset of a single cylinder engine. The data may be 
downloaded from the Getting Started Bundle.

The Internal Combustion Engine tutorial contains three different sections. The first section is general 
Tecplot knowledge of loading the data and changing plot styling. The second section is more objective-
based and each segment will be individual. We have provided a layout file alongside the data for the end 
of each segment, so you can check your work. The overall difficulty, description, and features used in each 
segment are shown below: 

Number and 
Level

Title and Description Features Used

1 - Beginner
Load the CONVERGE single cylinder data set into 
Tecplot 360 EX.

• Data Loading

• Zone Style

2 - Intermediate
Adding plot styling and derived objects to create 
an animation plot and exporting to a movie file.

• Slices

• Zone Style

• Iso-surfaces

• Scatter

3 - Beginner
Load a CONVERGE-specific data file and set up 
an XY Plot.

• Data Loading

• XY Plot

https://tecplot.azureedge.net/data/360GettingStarted.zip
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6 - 1   Loading and Manipulating Data

Step 1  Launch Tecplot 360 EX and Load the Data Set
Start Tecplot 360 EX from the Start menu (Windows), by typing tec360 in a terminal window (Linux), or by 
double-clicking the application icon in the Applications folder (Mac). The Tecplot 360 EX Welcome Screen 
appears, as shown here. (We will show the Windows version of Tecplot 360 EX in this document, but the 
product looks substantially the same on other platforms.)  

The Welcome Screen appears each time you launch Tecplot 360 EX and gives you easy access to layouts 
you have recently worked with, along with quick links to documentation and other resources to help you 
get the most out of the product. 
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To begin loading the data, click Load Data at the top of the Welcome Screen. (You may also choose Load 
Data from the File drop-down menu in the menu bar, or click the folder icon, second from the left, in the 
toolbar. These alternate methods are convenient when the Welcome Screen isn’t visible.) 

Navigate to your Tecplot 360 EX Getting Started Bundle folder then the Internal Combustion Engine (ICE) 
folder. Select all of the .plt files and select Open. The data files are opened and a 3D plot of the Combustion 
Engine appears in the Tecplot 360 EX workspace, as shown here:

https://tecplot.azureedge.net/data/360GettingStarted.zip
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Step 2  Disable Bounding Box for Fluid Volume Zone 
You may have noticed a dashed orange line when you first loaded your example file. This is the bounding 
box of the grid volume zone, which represents the air within the engine. This zone does not have any style 
(that is, visual appearance) so it would normally be invisible. Tecplot 360 EX adds the dashed orange line 
so that you know it is there and can see its dimension. You can choose to hide this line. From the Options 
menu, select “Show Bounding Boxes for Enabled Volume Zones with No Style”. The dashed orange line 
disappears.

Step 3  Hide Exhaust Ports
Since most of the data of interest lies within the cylinder, hide the exhaust zones by right-clicking the 
visible zones and selecting ʺHideʺ. 

Try to hide as many of the exhaust port zones as possible. After hiding, the plot should look something 
like this. Do not worry if there are a few zones still active.
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Exploring the Data Set

6 - 2   Exploring the Data Set 
For this segment, we will be continuing from where we left off. If you have closed Tecplot 360 EX since the 
first segment, you can load the provided layout file in ICE/finallayouts/ICE_GS1.lay 

Step 1  Adding a Slice 
To add a slice, toggle on the Slices checkbox in the Plot sidebar. A slice 
appears through the volume zone but may be hidden by surfaces. To 
be able to see the slice through the middle of our engine we must turn 
on Translucency in the Plot Sidebar as well.

From there the slice can be moved by selecting the slice interactor tool 
to place the slice interactively. The interactor tool can move the slice 
by clicking or dragging to a desired location. This can also be 
achieved by selecting the  button next to the Slices checkbox. For 
now, leave the slice in its default location. The Slice details dialog 
appears with the current Slice location and orientation.  

The Slice Details dialog displays the exact slice position.
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Step 2  Set Slice Styles 

Setting the Contour 
If you have the Slice Details dialog still open, navigate to the Contour tab. You will see our slice is being 
contoured by ʺmassʺ as this is the variable currently assigned to Contour Group 1. To change the variable 
in Slice Group 1, click the  button next to ʺContourʺ on the Plot sidebar. This will open the Contour 
Details dialog. This dialog can also be opened by selecting the gear icon next to the Flood By field on the 
Slice Details dialog.
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Exploring the Data Set

To change the variable of Contour Group 1, select the ʺ1ʺ button at the top of the Contour Details dialog 
and select the dropdown list that currently displays mass. Select temp for now. Close the Contour Details 
dialog. 

Back in the Slice Details dialog, you should see the variable under the Contour tab change to temp as well. 
The contour group changed successfully!
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Turning on the Mesh 
We also want to see the mesh of our slice so we will turn that on as well. Right-click the slice on your 
screen to open the context menu and select the Mesh option. Shown below: 

The slice mesh can also be turned on via the Other tab of the Slice Details dialog.Select the magnifying 
glass in the toolbar to zoom in for a better look.

Using the Forward, Back, and Play buttons on the Plot Sidebar, see how the plot changes over time. 

Step 3  Showing Spray Parcels 
The slice gives a good indication of the temperatures in the cylinder through time. However, the slice is 
not the only tool at our disposal. This data set also contains spray information that may be beneficial for 
our visualization of the engine. To follow along, be sure your Solution Time in the Plot sidebar is set to the 
first time step. 

Open the Zone Style dialog from the plot sidebar and scroll to the bottom of the Zone list. There you will 
see a zone called ʺSprayʺ. We want to style this zone to our specifications. To do this, check the Scatter 
checkbox from the Plot sidebar.
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Exploring the Data Set

The plot will update with scatter symbols for every zone. This is not what we want though. We only want 
to show the scatter symbols for the ʺSprayʺ zone. In the Zone Style dialog, select the Scatter tab and 
highlight every zone except the ʺSprayʺ zone, right-click the ʺShow Scatterʺ column and select No. 

Step 4  Changing Spray Parcel Size 
Now the ʺSprayʺ zone is the only one showing a scatter plot but displaying as same sized squares. In the 
Scatter tab, right click the symbol shape and change it to Sphere. 

Then we also want to change the symbol size, right click the column for Symbol Size and select the ʺSelect 
Variableʺ option. 
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This will open the Scatter Size/Font menu.

We want to have the Scatter symbols sized by their radius, from the scatter symbol variable dropdown 
menu, select the variable DP_radius. However the plot still hasnʹt updated yet. Finally right-click the 
symbol size dropdown menu again and select the DP_radius variable. Your Zone Style should look like 
this and the plot should show scatter spheres sized by radius. 

Step 5  Changing Spray Parcel Color 
The spray has differing size but it still does not give us much information. Contouring the scatter symbols 
by temperature would be helpful. Open the Zone Style dialog again to the Scatter tab. Scroll down to the 
ʺSprayʺ zone and then scroll to the right to the Outline Color. Right-click the Outline Color and the Color 
Chooser menu will appear. 

Select Multi 2. This corresponds to the Contour & Multi-Coloring group 2. To change the variable of group 
2, we will go back to the Contour Details dialog accessed by the  button on the sidebar next to the 
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Exploring the Data Set

Contour toggle. For the parcels, we want the color to be contoured by DP_temp. Now you can see how the 
parcels change temperature and size through time.

You’ll notice after changing the Parcel color that two contour legends appear on screen. This is because the 
parcels are colored by DP_temp while the slice is contoured by temp. Since both contours are in reference to 
temperature, we can update the contour levels of both contour groups. 

First remove the legend on contour group 2 by right-clicking the legend and selecting Hide. Then in the 
Levels and Color tab and select the Set Levels button. Enter the level information like below:

Now repeat with group 1. This will update temp and DP_temp to the same scale.
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NOTE: Spheres of Parcel spray can be graphically intensive for some systems. If that is the case, use Point 
shapes or circles. Points cannot be resized but can use colors much like Spheres. 

Scenic Detour – Setting Default Scatter style in the Configuration File 
If typical workflows include scatter on a single zone changing the default style can save many clicks.

These commands will change the default values for Scatter to ʺoffʺ and the shape to ʺPointʺ. This is 
especially helpful in situations like our example where we only want to turn on one zoneʹs Scatter points. 
Note that color contours cannot be set in the configuration file. 

The tecplot.cfg file, located in the installation folder, is able to set a default scatter shape and state for 
simplicity. Open the file in a text editor of your choosing and add the following lines to your configuration 
file:  

$!FieldMap Scatter{
  Show = No
  SymbolShape{GeomShape = Point}
}
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Exploring the Data Set

Step 6  Creating an Iso-surface 
For this next step we will use iso-surfaces to visualize a flame front during the ignition phase of our 
engine. Be sure the slice created in steps 1 and 2 is turned off by unchecking Slices on the sidebar but keep 
the spray turned on, optionally, with the Point scatter shape. Your data should look something similar to 
this: 

Next, we will turn on the Iso-surface option from the Plot sidebar. Select the checkbox next to ʺIso-
Surfacesʺ and then the  button (similar to how we opened the Slice details dialog). This will open the 
Iso-surface Details dialog. 
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Since we want to visualize a flame front, use the variable temp set to Contour Group 1. Also select the 
Contour tab on the Iso-surface Details dialog and verify the Iso-surface is being contoured by temp as well. 

Back on the details page, set the value of the Iso-surface to be 2000, which represents the flame front.

Pressing the play button on the Plot sidebar to animate through the flame front propagation.
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Exploring the Data Set

Step 7  Using 3D Multi Frames 
Our visualized data is starting to come together. However, it can be convenient to view data from multiple 
angles. This will give a better understanding of the data from all sides. This can be easily done by selecting 
Frame > 3D Multi Frames. For this example, we will use the top-left option. 

This will give us orthogonal views of our data set and we can derive a better understanding of our data 
throughout time. 
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Step 8  Export to Movie File 
Now that we have our plot set up as we want it, letʹs export our final product to a movie file. Select the   
button next to the Solution Time to open the Time Animation Details dialog.

This dialog displays more advanced animation options than the Plot sidebar. 

From the Time Animation details dialog, select the ʺExport to Fileʺ button next to the VCR buttons. This 
will open up the Animation Export dialog. The default animation export is MPEG-4. Because of the 3D 
Multi Frames in our workspace, ensure the region is ʺAll Framesʺ. 

You can also choose to export a larger image width than your current view. This is especially helpful if the 
movie is going to be displayed on a high-resolution screen. For this example, we want our final product to 
be viewed on a 4K resolution display so we will enter a width of 4096. Select OK and save the final file. 
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Loading Cell Averaged Output Files (CONVERGE)

6 - 3   Loading Cell Averaged Output Files (CONVERGE)
This section will use data time history exported from CONVERGE. Although somewhat specific to 
CONVERGE users, it will show genearal time history capabilities. If you are continuing from the previous 
segment, select File > New Layout to clear the previous plot.

Step 1  Loading the data 
Load area_avg_flow.out from the ICE directory of the Getting Started Guide Bundle. Select File > Load 
Data. Once prompted, select the CONVERGE Output Loader. 

Selecting OK will load the plot in XY Line type. 

Step 2  Add Multiple Y Axes 
The plot by default is in XY Line mode which contains pre-loaded XY Line maps. Select the Mapping Style 
button on the Plot Sidebar to see which Mappings are available. You can see that this file was loaded with 
many variables premade vs. the Crank Angle. For this example, cange the plot to show Avg_Temp and 
Mass_Flow_Rate by Crank Angle. Turn off the default map for Crank vs Cycle Number. Turn on Map numbers 
2 and 5.
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Notice how the plot automatically merges both lines to one Y Axis. The min/max values of Mass_Flow_Rate 
and Avg_Temp are very different, so putting one of the mappings in a second Y axis will help.

Select the Mapping Style button again on the Plot Sidebar. Scroll to the right to the ʺWhich Y-Axisʺ column 
and right click the Avg_Temp row. Then select Y2 as the Y-Axis. The plot will automatically update. 

Finally close the Mapping Style dialog to see the final plot. If your plot doesn’t automatically update to the 
new axis bounds, select Ctrl+F (or use View > Fit to Full Size). 
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Loading Cell Averaged Output Files (CONVERGE)

 

To increase the line thickness, right-click the line to bring up the right-click context menu and update the 
the thickness as desired. For black and white printing, consider changing one of the lines to dashed.

Step 3  Add Grid Lines 
Select Plot > Axis to open the Axis Details menu (or double click on the axis). From the Axis Details menu, 
you can see the different tabs to update the plot axes. Notice the X1, Y1, X2 ... buttons, these control the 
axis being acted on. For now, we want to update the X1 Grid Lines. Select the Grid tab to update the grid 
lines for the X1 axis. Select the Y1 button as well to update the Grid options for Y1. In our case, Y1 is the 
Mass_Flow_Rate.  
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Select the Show checkboxes under Gridlines and Minor Grid Lines. Notice how the Major Tick labels have 
the Solid gridlines and the Minor Tick labels have the Dotted Gridlines. 

Next select the Y2 button to edit the Grid Lines for Avg_Temp. Like before, show the Gridlines but this 
time leave the Minor Gridlines off. Also notice that there are no distinguishing differences between the 
major gridlines. For that reason, we want to update the Gridlines color to “Blue”. 

Step 4  Update Axis Labels 
Next, we want to update the Axis Labels to be spaced more cleanly. For Avg_Temp, the axis labels are 
spaced well with 100 points between each step so Y2 will not need to be updated. However, we will 
update Y1 to a better distribution. From the Axis Details dialog select the Labels tab.

Deselect the Auto Spacing option at the bottom to give us control of the Label Spacing. Then in the 
Spacing field, update the number to 0.025. Close the Axis Details dialog. 
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Next Steps

The final plot is shown below: 

6 - 4   Next Steps
This concludes the Internal Combustion Engine tutorial for Tecplot 360 EX. At this point, you may wish to 
dig in to the User’s Manual or Help (Help>Tecplot 360 EX Help) for more details on the product in general 
or on specific features you’ve used in this tutorial.

We regularly create videos to introduce users to features of the product, not just introductory topics for 
new users, but also for advanced users and to highlight new features in the latest release. You can find 
these on our Web site at https://www.tecplot.com/category/tecplot-360-videos/?product=360 or on our 
YouTube channel at https://www.youtube.com/user/tecplot360/.

https://www.tecplot.com/category/tecplot-360-videos/?product=360
https://www.youtube.com/user/tecplot360/


 Part 3  Ocean 
Modeling
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7 

Ocean Modeling

This tutorial uses a transient FVCOM NetCDF data set of the Boston harbor. The data may be downloaded 
from the Getting Started Bundle.

This data set was provided by UMASS Chen’s lab. The original data is located here.

The FVCOM NetCDF data file must have nv (element to node connectivity), siglev (sigma level), h 
(depth), zeta (surface elevation), (lon,lat) or (x, y) coordinates for Tecplot to be able to load. Tecplot 360 is 
not able to deal with FVCOM NetCDF data without the above variables. 

The overall difficulty, description, and features used in each segment are shown below: 

Number and 
Level

Title and Description Features Used

1 - Beginner
Load the Boston example dataset and inspect the 
data.

• Data Loading

• Data Set Information

2 - Intermediate
Adding plot styling and value blanking to create 
an animation plot and exporting to a movie file.

• Contours

• Zone Style

• Axis Scaling

• Value Blanking

3 - Intermediate
Visualize surface vector fields and insert a 
georeferenced image.

• Vectors

• Georeferenced Image

• Stratification

4 - Advanced
Links to advanced topics available on the Tecplot 
website.

• PyTecplot

• Averages

• Shapefiles

https://tecplot.azureedge.net/data/360GettingStarted.zip
http://www.smast.umassd.edu:8080/thredds/catalog/models/fvcom/NECOFS/Forecasts/catalog.html?dataset=models/NECOFS/Forecasts/NECOFS_FVCOM_OCEAN_BOSTON_FORECAST.nc
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7 - 1   Loading and Manipulating Data

Step 1  Launch Tecplot 360 EX and Load the Data Set
Start Tecplot 360 EX from the Start menu (Windows), by typing tec360 in a terminal window (Linux), or by 
double-clicking the application icon in the Applications folder (Mac). The Tecplot 360 EX Welcome Screen 
appears, as shown here. (We will show the Windows version of Tecplot 360 EX in this document, but the 
product looks substantially the same on other platforms.)

The Welcome Screen appears each time you launch Tecplot 360 EX and gives you easy access to layouts 
you have recently worked with, along with quick links to documentation and other resources to help you 
get the most out of the product.
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To begin loading the data, click Load Data at the top of the Welcome Screen. (You may also choose Load 
Data from the File drop-down menu in the menu bar, or click the folder icon, second from the left, in the 
toolbar. These alternate methods are convenient when the Welcome Screen isnʹt visible.)

Navigate to your Tecplot 360 EX Getting Started Bundle folder and then the Ocean folder. Highlight the 
.nc file and select Open to open it in Tecplot 360 EX. (If you canʹt see this file, choose All Files in the menu 
at the bottom of the dialog.) The data file is opened and a 3D plot of the Boston harbor loads in the Tecplot 
360 EX workspace, as shown here, an orange box shows the bounds of the volume data. See Chapter 3: 
“Understanding Volume Surfaces”.
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Step 2  Inspecting the Data
The orange bounding box represents a volume dataset that is loaded with no style. For more information 
on Surfaces to Plot see Chapter 3: “Understanding Volume Surfaces”. To see what data has been loaded, 
open the Data Set Info dialog. From the top of the screen select Data-> Data Set Info. This will bring up a 
dialog with lists of loaded zones and variables. 

In the Zones field, we can see that the NetCDF ocean model has loaded 24 zones. In this case, each zone 
represents a new timestep of the data so we have 24 timesteps in total. We can also see in the other column 
the variables that have been loaded from the dataset. Close the Data Set Info dialog for now.

7 - 2   Making your first plot

Step 1  Turn on Contour to See the Domain
For the first representation of the data, turn on the Contour layer. Select the checkbox next to Contour on 
the Plot Sidebar.
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Making your first plot

A pop-up will appear asking about Surfaces to Plot. For now, select ʺYesʺ. A contour plot will appear with 
the default contour variable selected. In this case it is ʺlonʺ. This is because ʺlonʺ is the first, non-XYZ 
variable in the dataset.

Step 2  Assign XYZ to Lon, Lat
For this plot, change the X and Y coordinates to Lon and Lat. This will make it easier for things like 
georeferenced images to be placed in the plot (see “Insert a Georeferenced Image” on page 150). To do 
this, select Plot->Assign XYZ and change the X variable to ʺlonʺ and the Y variable to ʺlatʺ.

The plot will automatically update on pressing OK.
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Step 3  Adjusting Z-scaling
You may have noticed pop-ups that say, ʺAspect ratio exceeds ratio limit. The ratio has been adjusted.ʺ 
This is because Tecplot attempts to maintain a visually interesting axis ratio to prevent any one direction 
from being too small. However, adjust this ratio because the current plot is too tall in the Z direction. Select 
Plot-> Axis to open the Axis Details dialog.

Towards the bottom of the dialog is the Dependency field. These options can determine XYZ dependency 
based on your information. The Z-axis needs to be smaller so set the plot ʺXY Dependentʺ. Select the 
button next to ʺXY Dependentʺ and adjust the  Z-axis size factor to be something like ʺ0.000667ʺ.

Note that the Z-axis is still exaggerated even at this ratio, but it gives a better understanding of the overall 
scale.

Step 4  Change View and Lighting
If you want the map to change to a top-down view, select the rollerball rotate (shown below), click, and 
drag the screen around to get a top-down perspective.

Another option is selecting ʺSnap to Orientation viewʺ  in the Plot Sidebar and selecting the XY 
perspective.
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Making your first plot

From this angle, lighting effects wash out the contour color. For now we can turn off lighting by 
unchecking the ʺLightingʺ checkbox  on the Plot sidebar.

Now the plot should have no lighting effect and the contour data can be seen more clearly.

Step 5  Change the Contour Variable and Colormap
The contour variable has remained at the default of ʺlonʺ up until now, update to a more data relevant 
variable like ʺSalinityʺ. To do this, select the  button next to Contour on the Plot sidebar. The Contour & 
Multi-Coloring details menu appears.
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Notice the dropdown list at the top of the dialog is set to ʺlonʺ. Select the dropdown list and all the 
variables in your dataset appear. Now select ʺsalinityʺ as your new contour variable. The plot will 
automatically update.
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Making your first plot

Also select a new colormap based on the cmocean colormaps, in this case, the ʺcmocean - halineʺ colormap 
which is designed to be used with salinity plots. To change the colormap select the colormap dropdown 
from the middle of the Contour & Multi-Coloring Details dialog, and select ʺcmocean - halineʺ option.

Step 6  Use Value Blanking to Hide Dry Land
After updating the plot to ʺsalinityʺ notice the shoreline of Boston harbor within the plot. However,  the 
contours extend out from beyond the shoreline. This dataset has a variable called ʺwet_nodesʺ to 
determine what is wet (denoted by the variable = 1) and what is dry (denoted by the variable = 0). 

To hide the dry nodes on the plot where ʺwet_nodesʺ is equal to 0. Go to Plot->Blanking->Value Blanking 
to pull up the Value Blanking dialog.
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Then turn on the ʺInclude value blankingʺ checkbox. This will tell the plot that we want to blank 
something. Change the Blank when fields to be when ʺwet_nodesʺ, ʺis equal toʺ, ʺConstantʺ and ʺ0ʺ. Then 
select the ʺActiveʺ checkbox. The plot will update accordingly. The exact value blanking options are in the 
image above and final plot should look like this:

Step 7  Animating and Exporting a Movie File
Now that the plot is looking good, letʹs animate through time. Select the Play button on the Plot sidebar to 
play the animation. The plot will show the ebbing and flowing of salinity in the Boston harbor.

Note that the first animation takes longer because it needs to load data. The second play through will be 
faster as the data has already been loaded.

Now we want to save this animation to a movie file. On the Plot sidebar select the  button next to 
Solution time and the Time Animation details dialog will appear. This dialog can give more control over 
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Specific Ocean Plots

your plot animation but since the default settings are already sufficient, select the ʺExport to Fileʺ button 
next to the VCR buttons on the Time Animation details dialog.

Finally the Export dialog appears. From this dialog, we can select things such as export format, image 
width, antialiasing, and animation speed. For this instruction, select the MPEG-4 format. This will create a 
file with an .mp4 extension that is usable by most video viewers. Also, turn on antialiasing as well to get 
the definition on the shoreline and have smoother lines. Keep everything else the default and click OK.

Next, save the file to a convenient location as ʺboston_salinity.mp4ʺ. Congratulations youʹve created your 
first Tecplot ocean animation!

7 - 3   Specific Ocean Plots
The next section focuses on specific quick plots that can be achieved with this dataset. The goal being to 
teach how to create interesting plots quickly.

This section is a continuation from the previous section. If you are joining partway through, open the 
Ocean1.lay from the finallayouts directory.
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7 - 3.1   Visualizing Surface Velocities

Step 1  Turn on the Vectors
First turn on the Vector layer from the Plot Sidebar to visualize surface velocities. Select the checkbox next 
to Vector much like how we turned on the contour layer (see Turn on Contour to See the Domain). The 
Select Variables menu should appear allowing the selection of the U, V, and W variables.

For the next section, select the u, v, and ʺwwʺ variables from the dropdown.

Step 2  Value Blank Siglev
At this point all surfaces are showing vectors including the sea floor. To only show the sea surface, use 
value blanking to isolate the ocean surface by blanking when “siglev” is less than 0. Using the second 
value blanking constraint, select Plot -> Blanking -> Value Blanking and update the options to match the 
image below. Be sure to change the “Blank entire cells when” option to “all corners are blanked”.
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Step 3  Use Vector Tangents
Because the view is still 3D model, some vectors will look like dots as the vector is pointing vertically 
toward the screen. To prevent this turn on the Vector Tangents from the Zone Style dialog. Select the Zone 
Style button from the Plot Sidebar and the Zone Style dialog will appear.

Select the Vector tab and then select the checkbox under ʺVector Tangentsʺ. This will ensure that the 
vectors will be displayed tangential to the surface. Close the Zone Style dialog.
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Step 4  Calculate Velocity Magnitude
Since the Velocity Magnitude isnʹt located in the current dataset, we will need to calculate it. Typically new 
equations can be calculated using the Data Alter menu (Data -> Alter -> Specify Equations). However, the 
CFD Analyze menu can also be used to calculate Velocity magnitude which will prevent the need to type 
the equations in manually.

Firstly, we will need to set up the CFD Analyze menu by letting the Analyzer know the data’s field 
variables. Select Analyze -> Field Variables to bring up the Field Variables dialog. From this dialog we can 
set the necessary variables for analysis. For this calculation, setting the convective variables is sufficient. Be 
sure the Velocity button is checked and the vectors variables are the same as what is shown on the plot (u, 
v, and ww).

Next select Analyze -> Calculate Variables. This will bring up the Calculate Variables page. Select Velocity 
magnitude as the variable calculation and uncheck the Calculate on Demand button. This will make sure 
the points are calculated now instead of when the variable is plotted.
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Then select Calculate and the Velocity Magnitude variable will begin the calculation process for all zones. 
Information will appear upon completion that the calculation was successful. Now in the Data Set Info 
dialog (Data->Data Set Info) you can see the Velocity Magnitude variable at the end of the variable list.
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Step 5  Contour by Velocity Magnitude
To contour by velocity magnitude, see the previous section Step 5 Change the Contour Variable and 
Colormap  to update the Contour variable. Then switch the colormap to ʺcmocean-speedʺ, designed to be 
used with velocity. We also want to change the contour levels to only include data relevant to our study.

To do this, select Set Levels from the Contour & Multi-Coloring details dialog. When the dialog appears, 
change the option of Range Distribution to Min, Max, and Delta. With the minimum level at 0 and 
maximum level at 0.6 with a delta of 0.1.

Click OK and close the Contour & Multi-Coloring Details dialog. Here is what your plot should look like 
currently.
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Step 6  Resize Vectors
Since the vectors on screen are a little bit too large in the more dense areas of the plot, we should change 
the length. Select Plot-> Vector -> Details to adjust the vector length from the Vector Details dialog.

Set the Length to Relative (grid units/magnitude) and set the number to 0.005. This will update the vectors 
to be smaller and more manageable in the dense areas of the plot. Your final plot should be similar to the 
one you see below:
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At this point, use the zoom and pan tools to explore different regions of the data.

7 - 3.2   Insert a Georeferenced Image

Step 1  Set Up Coordinate System
Before inserting the image, ensure the coordinate system on your plot is the same as the georeferenced 
image that you are trying to insert. If a georeferenced image is inserted with a different coordinate system 
than the dataset, the image will not appear in the correct location. For this example, set the Boston dataset 
to be in lon/lat coordinates. 

Select Plot > Assign XYZ and assign lon to the X variable and assign lat to the Y variable. If you are 
continuing from the previous exercises, this step will already be done.

Step 2  Insert Georeferenced Image
Select Insert > Image/Georeferenced Image and select the ʹboston.pngʹ file from the same folder the data 
was loaded. The map of the Boston harbor will appear alongside the dataset. Click the Play button and 
notice that the colormap disappears behind the image as we animate through time.

Step 3  Update Image location
Because the sea surface height changes over time, the contour plots disappear behind the georeferenced 
image. Since we want the contours to always be on top, we will update the height of the georeferenced 
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image. Right click the georeferenced image and select Image Details. The 3D Image Geometry Details 
dialog appears. Notice that the Z position field defaults to 0. Update this field to -10 and click Accept. 

The image will now be moved below the contour flooding. Select the play button again from the Plot 
Sidebar and notice how the sea height fluctuates but never falls below the image like before.

7 - 3.3   Understanding Salinity Stratification
The next portion will use an iso-surface to identify the bathymetry of the dataset and use slices to identify 
layers through the volume. If you are continuing from the previous portion, remove the georeferenced 
image and turn off the blanking of siglev.
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Step 1  Turn off Zone Layers
On the plot sidebar, turn off all of the zone layers. This will revert the plot to an empty workspace with an 
orange bounding box much like when we first loaded the data.

Step 2  Show the Bathymetry
Turn on the iso-surface checkbox on the plot sidebar. This will create a surface based on a contour variable 
value. In this case, we want to create an iso-surface to show the bathymetry. To do this, select the  
button next to the iso-surface checkbox. This will bring up the Iso-surface Details dialog.

Set the Iso-surface definition to C3 and enter the value of -1. Update the Contour variable in group three to 
siglev via the Contour Details dialog. See the above image for the Contour details and Iso-surface details 
options. Also while you have the Contour details dialog open, update the contour group two to be colored 
by z using the “cmocean-deep” colormap and with the colormap reversed. Then select C2 in the Contour 



153

Specific Ocean Plots

tab of the Iso-surface details dialog. See the below image for the correct options for how to update the iso-
surface contour.

Setting the iso-surface definition will create an iso-surface of the bottom layer of the dataset. Rotating the 
plot around, you can see the ridges of the harbor floor through the dataset.
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Step 3  Place a Slice
Next, place a slice using the Slice tool and the Slice Details dialog using Y-planes at a position of 42.33. This 
will place a slice right around the middle half of the Boston dataset.



155

Specific Ocean Plots

Remove the z legend by right-clicking the legend edge and selecting “Hide”. Rotate the plot to see the slice 
easier like below.

Step 4  Contour the Slice by Salinity
Now that we have a slice placed in the region of interest, we want to contour by salinity to get the salinity 
stratification. Click the  button next to the Slice tool to bring up the Slice Details dialog. Select the 
Contour tab and be sure the contour group is set to 1.
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If the variable is not already salinity, update the variable in the Contour Details dialog.

Also be sure to turn on the slice mesh in the Other tab. This will show us the final plot. The slice displays 
the salinity stratification through the Boston harbor. Be sure to use the zoom and pan tools to orient the 
plot to your liking. 
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7 - 4   Advanced Topics
This section contains advanced topics that use Tecplot’s Python API, PyTecplot, to extend the functions 
that the GUI provides by pairing it with Python. This allows users to increase the overall capability of 
Tecplot 360. Each topic will have a video containing a link to the script as well as a transcript for reference.

7 - 4.1   Vertical Transect (external video)
A vertical transect gives a curved slice extracted through time. We have created a video showing the steps 
to create the Vertical Transect. It is located here: https://www.tecplot.com/2018/10/17/vertical-transect/

7 - 4.2   Time Average (external video)
The Time Average script creates a duplicate zone with the varaibles averaged over time. It is located here: 
https://www.tecplot.com/2018/10/17/calculating-average-over-time/

7 - 4.3   Shapefile conversion (external video)
The Shapefile conversion script converts a shapefile into Tecplot .plt format. It is located here: https://
www.tecplot.com/2018/10/17/converting-shapefiles-plt-using-pytecplot/

7 - 5   Next Steps
This concludes the Ocean Modeling tutorial for Tecplot 360 EX. At this point, you may wish to dig in to the 
User’s Manual or Help (Help>Tecplot 360 EX Help) for more details on the product in general or on 
specific features you’ve used in this tutorial.

We regularly create videos to introduce users to features of the product, not just introductory topics for 
new users, but also for advanced users and to highlight new features in the latest release. You can find 
these on our Web site at https://www.tecplot.com/category/tecplot-360-videos/?product=360 or on our 
YouTube channel at https://www.youtube.com/user/tecplot360/.

https://www.tecplot.com/category/tecplot-360-videos/?product=360
https://www.youtube.com/user/tecplot360/
https://www.tecplot.com/2018/10/17/vertical-transect/
https://www.tecplot.com/2018/10/17/calculating-average-over-time/
https://www.tecplot.com/2018/10/17/converting-shapefiles-plt-using-pytecplot/
https://www.tecplot.com/2018/10/17/converting-shapefiles-plt-using-pytecplot/
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