Flame Front Analysis	Comment by Margaret Connelly: Needs a brief introduction for Convergent Science, Gaurav, …
Engineers from Convergent Science are studying the effect of obstacles on the time taken for deflagration to detonation transition (DDT) in various configurations (blockage ratio and stagger ratio). Ideally one would like to delay DDT. This study could help understand how blockages can be used to control DDT.

Deflagration describes combustion at a velocity slower than the speed of sound. You see deflagration typically as common flame in everyday life, like in a fireplace or on burning candle. Detonation describes combustion at a higher velocity than the speed of sound. You see this in explosions that release shockwaves, such as a fighter jet breaking the sound barrier or a gas leak in a mine or a factory.
To quantify the results of the simulations, they wanted to compute the flame area (represented by an iso-surface at 1800 degrees) and the flame speed (determined by the max x-position over time, dXmax/dt).  Measuring flame area gives information on flame wrinkling which they wanted to correlate with flame speed.  They also wanted to see that how flame wrinkling changes as flame transitions from deflagration to detonation.
This guide explains the techniques and features used in Tecplot 360 and PyTecplot to extract this information from the simulation results.
Data and scripts for this case can be downloaded here: <insert link – Azure? GitHub?>. To run the scripts, be sure to unpack Data.tar.gz to a sub-directory called Data first.
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What does this simulation represent?
The technical term is deflagration to detonation transition (DDT). Deflagration describes combustion at a velocity slower than the speed of sound. You see deflagration typically as common flame in everyday life, like in a fireplace or on burning candle. Detonation describes combustion at a higher velocity than the speed of sound. You see this in explosions that release shockwaves, such as a fighter jet breaking the sound barrier or a gas leak in a mine or a factory.
What are you studying with this simulation?
We are studying the effect of obstacles on the time taken for transition to detonation in various configurations (blockage ratio and stagger ratio). Ideally one would like to delay DDT. This study could help understand how blockages can be used to control DDT.
Why are the flame area and flame speed important to you?
Measuring flame area would give us information on flame wrinkling which we would like to correlate with flame speed. We would like to see that how flame wrinkling changes as flame transitions from deflagration to detonation.How to compute the flame area and flame speed using Tecplot 360 and PyTecplot
The two quantities we need to compute from this dataset are flame area and flame speed.  FirstFirst, we need to define the flame front.  Once we have the flame front defineddefined, we can compute the flame area and flame speed.	Comment by Brandon Markham: Suggested: move this phrase/detail down under "Computing Flame Area".
Computing Flame Area
Flame area is relatively simple – you can simply use Analyze > Perform Integration > Length/Area/Volume to compute the area of the iso-surface.  Recall that Tecplot 360 performs calculations on Zones – so we must first extract the iso-surface to zones before we can use the integration feature.  So, the rough steps are:
1. Define an iso-surface at Temperature = 1800, which defines the flame front	Comment by Brandon Markham: Maybe I missed it in the sections above, but where does this guide reference the data? I'm not seeing a link or reference to specific data above.
2. Data > Extract > Iso-Surfaces Over Time
3. Analyze > Perform Integration
a. Choose Length/Area/Volume
b. Integrate by Time Strands and select the strand associated with the iso-surface you extracted.
c. Check the Plot Results As toggle
d. Press Integrate
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At this point you will have a new frame with a line plot that represents the flame area.  Select this frame and save this data to a data file using File > Write Data…
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Computing Flame Speed
The flame speed is defined as dXmax/dt.  Tecplot 360 cannot compute this equation with its built-in equation processing, so we’ll use the PyTecplot scripting language to not only extract the maximum X-position from the flame front at each timestep, but also compute the flame speed.  Once we’ve computed the results we’ll save the results to a Tecplot ASCII file.
The PyTecplot script below will connect to a live, running instance of Tecplot 360 to extract the information.  There are a couple prerequisites to running this script:
1. Ensure you have Python 3 and PyTecplot installed
2. Save the script (below) to a file (e.g. compute_flame_speed.py)
3. Enable PyTecplot connections via Scripting > PyTecplot Connections…
4. Ensure that the frame with the CONVERGE data is the active frame. As you can see in the script below it queries for the dataset associated with the active frame.
Once you’ve satisfied the pre-requisites, simply run the script:
> python -O compute_flame_speed.py

Python script contents	Comment by Brandon Markham: What if we put this script on GitHub?
import tecplot as tp
tp.session.connect()

ds = tp.active_frame().dataset
iso_zones = ds.zones("Iso*")

times = []
maxx = []
speed = []
# Assuming that the zones are given in time order
for z in iso_zones:
    maxx.append(z.values("X").max())
    times.append(z.solution_time)
    if len(maxx) == 1:
        speed.append(0)
    else:
        dx = (maxx[-1] - maxx[-2])
        dt = (times[-1] - times[-2])
        speed.append(dx/dt)
        
# Save the results to a Tecplot data file. We do this by creating a
# new dataset in Tecplot 360 with the results and saving to a file.
new_frame = tp.active_page().add_frame()
ds = new_frame.create_dataset("Flame Speed", var_names=["Solution Time", "Flame Speed"])
zone = ds.add_ordered_zone("Flame Speed", shape=len(times))
zone.values("Solution Time")[:] = times
zone.values("Flame Speed")[:] = speed
tp.data.save_tecplot_ascii("flame_speed.dat", frame=new_frame)
# We’ve saved the data to disk and no longer need the frame around
tp.active_page().delete_frame(new_frame)

Plotting the results
We now have one data file with the flame area results and another file with the flame speed results. To plot the results, simply create a new frame in Tecplot 360, then load the two files together.
By default, Tecplot 360 only plots the results for the first zone so you’ll have to use the Mapping Style dialog to plot the data of interest.  As seen in the image below, we’ve created two line maps, each plotting different data.  Because flame area and flame speed have very different magnitude we’re using the Y2 axis to plot the flame speed.
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To create the final plotted result we’ve added a line legend and modified the first line map name from “Result” to “Flame Area”.  We’ve also renamed the Y1 axis title to use “Flame Area”.
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How did Tecplot 360 and PyTecplot help you in this analysis?
Using Tecplot 360 we were able to define an iso-surface which represented the flame front. From that iso-surface we were able to use PyTecplot to gain access to the raw data to compute the area (quantification of flame wrinkling) and determine the maximum X-location for the flame front. Once we have the maximum X-location at each time step we derived the flame speed and saved the results to a new file, which we were able to use for further plotting and analysis.
The ability to not only create images but perform numerical analysis in a unified environment reduces the number of different tools that we need to use to get our job done. While this workflow required writing a script – as opposed to other scripting tools – Tecplot 360 allowed us to define and save the plot style through the graphical user interface. This greatly reduced the amount of code (and trial and error) to achieve the final plot.
Instructions:
Download the data and scripts <insert download link>
Ensure you have Python 3.7 or newer, PyTecplot, and numpy installed
Run > python -O FlameFrontAnalysis.py
When the script has completed you will have three new files: results.dat, results.plt, and result.lay. results.dat and results.plt contain the same data, but show the difference between ASCII and binary.
Open result.lay to see the final result
Bonus points:
Visit Tecplot’s GitHub repository (https://github.com/Tecplot/handyscripts) and clone it 
>git clone https://github.com/Tecplot/handyscripts.git
Use ParallelImageCreator.py to create individual images (in batch) from result.lay 
>python -O ParallelImageCreator.py result.lay -np 4 -w 2048 -ss 3 -b image 
This command will run 4 concurrent batch processes (requires a node-locked version of Tecplot 360 or access to a multi-seat network license) to create images named “imageNNNN.png”.  The number of concurrent process you can run will depend on your available hardware – on a 40-core Windows machine we found performance improvement with up to 8 concurrent processes, beyond that we encountered resource contention for the GPU (during rendering of images) and timing started to slow down. 
Use make_movie.py (requires the ‘pillow’ python module) to assemble those images into an MPEG-4 movie file. 
>python -O make_movie.py -imagebasename image -pattern %04d -framerate 24 -moviefilename mymovie.mp4
This script will generate a movie file and lets you easily play with the frame rate so you can get the playback speed you want without having to regenerate the images.

ParallelImageCreator.py Performance Results
To understand the scaling of multiple concurrent processes to create plots, we ran ParallelImageCreator.py on a 40 logical-core Windows machine.  At 16-concurrent processes we found that there was contention for the graphics card as it was attempting to render multiple images simultaneously. The command line below was used for testing.
>python -O ParallelImageCreator.py result.lay -np <numprocs> -w 2048 -ss 3 -b image
	Num Processors
	Execution Time

	1 (via GUI)
	530s*

	1
	578s

	2
	309s

	4
	195s

	8
	137s

	16
	170s


*GUI timing does not include the cost to open the layout and survey for the number of solution times in the dataset.  All other timings incur that start-up cost.
FlameFrontAnalysis_multiprocessing.py Results
The computation of the flame area and the extraction of the maximum x-location can be done embarrassingly parallel as each time-step is stored in a separate file.  We wrote a parallel version of the analysis script to test its scaling (see FlameFrontAnalysis_multiprocessing.py).  The source data is quite small per time-step and no rendering was done, so the processes are only limited by CPU and disk speed (as opposed to RAM and GPU). The results below show non-linear scaling up to 16 concurrent processes on a 40 logical-core Windows machine and decreased performance at 32 concurrent processes.
>python -O FlameFrontAnalysis_multiprocessing.py <numprocs>
	Num Processors
	Execution Time

	1
	55s

	2
	35s

	4
	25s

	8
	20s

	16
	18.5s

	32
	20s


Summary

In this how-to guide you learned the following:
· Loading CONVERGE data
· Defining and extracting an iso-surface
· Use of Length/Area/Volume integration
· Use of PyTecplot to extract data and to create new results
· Plotting of resulting data
Appendix – Automating the entire processReferences:

Note that this entire process can be fully automated using PyTecplot, so that the resulting data and plots can be created by running a single script.  See the FlameFrontAnalysis.py script in the downloadable package <insert same link as above> which shows how we automated the entire process.  The script uses a slightly different method to collect the flame area – rather than having Perform Integration create a new plot, this script uses Perform Integration to compute and collect the flame area at each timestep.  In the end this script saves the flame area and flame speed results to a file and creates a Tecplot 360 layout file for viewing the results. 
https://en.wikipedia.org/wiki/Deflagration_to_detonation_transition
https://en.wikipedia.org/wiki/Deflagration
https://en.wikipedia.org/wiki/Detonation
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